<!DOCTYPE html>
<html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs LoggedOut Sidebar Responsive" xmlns:fb="http://www.facebook.com/2008/fbml">
<head><meta charset="utf-8" />
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData)});}}
function AddPixelById(impFullId,pixelData){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData)});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){while(pixels.length>0){var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(__ez.template.isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
(new Image()).src=pixelURL;}}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=191-2&cb=1', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=191-2&cb=1', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=191-2&cb=2', false, [], true, false, true, false);</script>
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<base href="https://www.howtoforge.com" />
<script>
			var _b = document.getElementsByTagName('base')[0], _bH = "https://www.howtoforge.com/tutorial/perfect-server-centos-8-apache-mysql-php-pureftpd-postfix-dovecot-and-ispconfig/";
			if (_b && _b.href != _bH) _b.href = _bH;
		</script>
<title>The Perfect Server &ndash; CentOS 8 with Apache, Postfix, Dovecot, Pure-FTPD, BIND and ISPConfig 3.2</title>
<meta name="description" content="This tutorial shows how to install ISPConfig 3.2 on a CentOS 8 (64Bit) server. ISPConfig 3 is a web hosting control panel that allows you to configure... " />
<meta property="og:title" content="The Perfect Server &ndash; CentOS 8 with Apache, Postfix, Dovecot, Pure-FTPD, BIND and ISPConfig 3.2">
<meta property="og:description" content="This tutorial shows how to install ISPConfig 3.2 on a CentOS 8 (64Bit) server. ISPConfig 3 is a web hosting control panel that allows you to configure... ">
<meta property="og:site_name" content="HowtoForge">
<meta property="og:type" content="article">
<meta property="og:image" content="https://www.howtoforge.com/images/featured/centos-8-perfect-server1.jpg">
<meta property="og:image:secure_url" content="https://www.howtoforge.com/images/featured/centos-8-perfect-server1.jpg" />
<meta property="og:image:alt" content="The Perfect Server &ndash; CentOS 8 with Apache, Postfix, Dovecot, Pure-FTPD, BIND and ISPConfig 3.2" />
<meta name="twitter:image" content="https://www.howtoforge.com/images/featured/centos-8-perfect-server1.jpg" />
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="@howtoforgecom">
<meta name="twitter:creator" content="@howtoforgecom">
<meta name="twitter:title" content="The Perfect Server &ndash; CentOS 8 with Apache, Postfix, Dovecot, Pure-FTPD, BIND and ISPConfig 3.2">
<meta name="twitter:description" content="This tutorial shows how to install ISPConfig 3.2 on a CentOS 8 (64Bit) server. ISPConfig 3 is a web hosting control panel that allows you to configure... ">
<link rel="alternate" href="https://www.howtoforge.com/tutorial/perfect-server-centos-8-apache-mysql-php-pureftpd-postfix-dovecot-and-ispconfig/" hreflang="en" />
<link rel="canonical" href="https://www.howtoforge.com/tutorial/perfect-server-centos-8-apache-mysql-php-pureftpd-postfix-dovecot-and-ispconfig/" />
<link rel="amphtml" href="https://www.howtoforge.com/tutorial/perfect-server-centos-8-apache-mysql-php-pureftpd-postfix-dovecot-and-ispconfig/amp/" />
<script type="application/ld+json">
{
  "@context" : "http://schema.org",
  "@type" : "Article",
  "name" : "The Perfect Server &ndash; CentOS 8 with Apache, Postfix, Dovecot, Pure-FTPD, BIND and ISPConfig 3.2",
  "author" : {
    "@type" : "Person",
    "name" : "Till Brehm"
  },
  "articleSection" : "anti-spam/virus,apache,bind,centos,control panels,dns,email,ftp,ispconfig,linux,mysql,php,postfix,web server",
  "url" : "https://www.howtoforge.com/tutorial/perfect-server-centos-8-apache-mysql-php-pureftpd-postfix-dovecot-and-ispconfig/",
  "publisher" : {
    "@type" : "Organization",
    "name" : "Howtoforge"
  }
}
</script>
<noscript><style>.JsOnly, .jsOnly { display: none !important; }</style></noscript>
<link rel="stylesheet" href="/community/styles/executive/xenfocus/icons/css/font-awesome.min.css" />
<link href='//fonts.googleapis.com/css?family=Open+Sans:400,700' rel='stylesheet' type='text/css' />
<link href="/themes/howtoforge/templates/xf.css" rel="stylesheet">
<script src="/js/jquery/jquery-1.11.3.min.js"></script>
<script src="/community/js/xenforo/xenforo.js?_v=303ae0ca"></script>
<script src="/community/js/bbm/zloader.js?_v=303ae0ca"></script>
<script type="text/javascript" src="/js/fancybox/jquery.mousewheel-3.0.4.pack.js"></script>
<script type="text/javascript" src="/js/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
<link rel="stylesheet" type="text/css" href="/js/fancybox/jquery.fancybox-1.3.4.css" media="screen" />
<link href="/themes/howtoforge/templates/style.min.css" rel="stylesheet">
<link rel="alternate" type="application/rss+xml" title="RSS-Feed für Howtoforge" href="/feed.rss" />
<script src="/js/tinymce_4.1.7/tinymce.min.js"></script>
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/skin.min.css" as="style" />
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/content.min.css" as="style" />
<link rel="preload" href="/themes/howtoforge/css/custom.css" as="style" />
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/fonts/tinymce.woff" as="font">

<script type="text/javascript">
var gaProperty = 'UA-2155872-1';
var disableStr = 'ga-disable-' + gaProperty;
if (document.cookie.indexOf(disableStr + '=true') > -1) {
window[disableStr] = true;
}
function gaOptout() {
document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
window[disableStr] = true;
alert('Google Ananlyitics tracking has been disabled in this browser.');
}
</script>
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
	googletag.defineSlot('/1030080/howtoforge_com_list_sidebar_top', [300, 250], 'div-gpt-ad-1527185271042-4').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_list_content_middle', [[300, 250], [336, 280]], 'div-gpt-ad-1527185271042-5').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_a_300x250', [300, 250], 'div-gpt-ad-1527185271042-6').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_b_300x250', [300, 250], 'div-gpt-ad-1527185271042-7').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_leaderboard_b_728x90', [728, 90], 'div-gpt-ad-1527185271042-1').addService(googletag.pubads());
	googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-3043223216276099",
          enable_page_level_ads: true
     });
</script>


<script type="text/javascript" src="//m.servedby-buysellads.com/monetization.js"></script>

<script data-ezscrex="false" data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-158818458-34";</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(function(){
	_gat._createTracker('UA-158818458-34', 'e');
});
_gaq.push(function(){
	_gat._createTracker('UA-38339005-1', 'f');
});
_gaq.push(['e._setDomainName', 'howtoforge.com']);
_gaq.push(['f._setDomainName', 'howtoforge.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod72',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','howtoforge.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script>
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 178704;
var ezdomain = 'howtoforge.com';
var ezoicSearchable = 1;
</script>


<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":178704,"engaged_time_visit":0,"ezcache_level":1,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"8766270c-d64d-417a-7ebc-6093d2a620c9","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":1299,"serverid":"3.237.200.193:8593","state":"VA","t_epoch":1600529113,"template_id":126,"time_on_site_visit":0,"url":"https://www.howtoforge.com/tutorial/perfect-server-centos-8-apache-mysql-php-pureftpd-postfix-dovecot-and-ispconfig/","user_id":0,"word_count":6351,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=191-2&v=9" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_178704=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["8766270c-d64d-417a-7ebc-6093d2a620c9", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>
<body>
<div id="loginBar">
<div class="pageWidth">
<div class="pageContent">
<h3 id="loginBarHandle">
<label for="LoginControl"><a href="/community/login/" class="concealed noOutline">Log in or Sign up</a></label>
</h3>
<span class="helper"></span>
</div>
</div>
</div>
<header>
<div id="header">
<div id="logoBlock">
<div class="pageWidth">
<div class="pageContent">
<div id="logo"><a href="/">
<span></span>
<img src="/images/howtoforge_logo_trans.gif" alt="Howtoforge" style="margin-left:20px;" />
</a></div>
<span class="helper"></span>
</div>
</div>
</div>
<div id="navigation" class="pageWidth withSearch">
<div class="pageContent">
<nav>
<div class="navTabs">
<ul class="publicTabs">

<li class="navTab forums selected">
<a href="/" class="navLink">Tutorials</a>
<div class="tabLinks forumsTabLinks">
<ul class="secondaryContent blockLinksList">
<li><a href="/search/">Tutorial search</a></li>
</ul>
</div>
</li>
<li class="navTab forums PopupClosed">
<a href="/tutorials/" class="navLink">Tags</a>
</li>
<li class="navTab forums PopupClosed"><a href="/community/" class="navLink">Forums</a></li>
<li class="navTab forums PopupClosed"><a href="/linux-commands/" class="navLink">Linux Commands</a></li>
<li class="navTab forums PopupClosed"><a href="/subscription/" class="navLink">Subscribe</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.ispconfig.org" class="navLink">ISPConfig</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.lxer.com" class="navLink">News</a></li>
</ul>
</div>
<span class="helper"></span>
</nav>
</div>
</div>
<div id="searchBar" class="pageWidth">
<span id="QuickSearchPlaceholder" title=" Search..."> Search</span>
<fieldset id="QuickSearch">
<form action="/" method="post" class="formPopup">
<div class="primaryControls">

<input type="search" name="q" value="" class="textCtrl" placeholder="Search..." results="0" title="Enter your search and hit enter..." id="QuickSearchQuery" />

</div>
<input type="hidden" name="_xfToken" value="" />
</form>
</fieldset>
</div>
</div>
</header>
<div id="content" class="forum_list">
<div class="pageWidth">
<div class="pageContent">

<div class="mainContainer">
<div class="mainContent">

<div class="breadBoxTop">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Home</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/tutorial/perfect-server-centos-8-apache-mysql-php-pureftpd-postfix-dovecot-and-ispconfig/" class="crumb" rel="up" itemprop="url"><span itemprop="title">The Perfect Server CentOS 8 with Apache, PHP, Postfix, Dovecot, Pure-FTPD, BIND and ISPConfig 3.2 (Beta)</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>

<div id="htfContentPage">
<article>
<h1>The Perfect Server CentOS 8 with Apache, PHP, Postfix, Dovecot, Pure-FTPD, BIND and ISPConfig 3.2 (Beta)</h1>
<div class="contributeEdit" style="float:right; width:450px; max-width:100%;">
<div id="tocContainer">
<h3>On this page</h3>
<ol class="toc">
<li><a href="#-requirements">1 Requirements</a></li>
<li><a href="#-preliminary-note">2 Preliminary Note</a></li>
<li><a href="#nbspprepare-the-server">3&nbsp;Prepare the server</a></li>
<li><a href="#nbspenable-additional-repositories-and-install-some-software">4&nbsp;Enable Additional Repositories and Install Some Software</a></li>
<li><a href="#-quota">5 Quota</a>
<ol>
<li><a href="#enabling-quota-on-the-root-partition">Enabling quota on the / (root) partition</a></li>
<li><a href="#enabling-quota-on-a-separate-var-partition">Enabling quota on a separate /var partition</a></li>
</ol>
</li>
<li><a href="#-install-apache-php-mysql-and-phpmyadmin">6 Install Apache, PHP, MySQL and phpMyAdmin</a>
<ol>
<li><a href="#optional-change-the-apache-mpm-module">Optional: Change the Apache MPM Module</a></li>
</ol>
</li>
<li><a href="#-install-dovecot">7 Install Dovecot</a></li>
<li><a href="#-install-postfix">8 Install Postfix</a></li>
<li><a href="#-install-getmail">9 Install Getmail</a></li>
<li><a href="#-set-mysql-passwords-and-configure-phpmyadmin">10 Set MySQL Passwords and Configure phpMyAdmin</a></li>
<li><a href="#-install-amavisdnew-spamassassin-clamav-and-postgrey">11 Install Amavisd-new, SpamAssassin, ClamAV, and Postgrey</a></li>
<li><a href="#-installing-apache-with-modphp-modfcgiphp-phpfpm">12 Installing Apache with mod_php, mod_fcgi/PHP, PHP-FPM</a></li>
<li><a href="#-installation-of-modpython">13 Installation of mod_python</a></li>
<li><a href="#-install-pureftpd">14 Install PureFTPd</a></li>
<li><a href="#-install-bind">15 Install BIND</a></li>
<li><a href="#-install-awstats">16 Install AWStats</a></li>
<li><a href="#-install-jailkit">17 Install Jailkit</a></li>
<li><a href="#-install-failban">18 Install Fail2Ban</a></li>
<li><a href="#-install-rkhunter">19 Install rkhunter</a></li>
<li><a href="#-install-mailman">20 Install Mailman</a></li>
<li><a href="#-install-roundcube-webmail">21 Install Roundcube webmail</a></li>
<li><a href="#-install-ispconfig-">22 Install ISPConfig 3.2</a></li>
<li><a href="#-first-ispconfig-login">23 First ISPConfig Login</a>
<ol>
<li><a href="#-the-ispconfig-manual">23.1 The ISPConfig 3 Manual</a></li>
</ol>
</li>
<li><a href="#download-centos-server-as-virtual-machine">24 Download as&nbsp;a virtual machine</a></li>
<li><a href="#-links">25 Links</a></li>
</ol>
</div>
</div>
<p>This tutorial shows the installation of ISPConfig 3.2 on a CentOS 8 (64Bit) server. ISPConfig is a web hosting control panel that allows you to configure the following services through a web browser: Apache web server, PHP, Postfix mail server, MySQL, BIND nameserver, PureFTPd, SpamAssassin, ClamAV, Mailman, and many more.</p>
<h2 id="-requirements">1 Requirements</h2>
<p>To install such a system you will need the following:</p>
<ul>
<li>A Centos 8 minimal server system. This can be a server installed from scratch as described in our <a href="https://www.howtoforge.com/tutorial/centos-8-minimal-server/">Centos 8 minimal server tutorial</a> or a virtual-server or root-server from a hosting company that has a minimal Centos 8 setup installed.</li>
<li>A fast Internet connection.</li>
</ul>
<h2 id="-preliminary-note">2 Preliminary Note</h2>
<p>In this tutorial, I use the hostname <span class="system">server1.example.com</span> with the IP address <span class="system">192.168.0.100</span> and the gateway <span class="system">192.168.0.1</span>. These settings might differ for you, so you have to replace them where appropriate.</p>
<h2 id="nbspprepare-the-server">3&nbsp;Prepare the server</h2>
<p><strong>Set the keyboard layout</strong></p>
<p>In case that the keyboard layout of the server does not match your keyboard, you can switch to the right keyboard (in my case "de" for a German keyboard layout, with the localectl command:</p>
<pre class="command"><code spellcheck="false">localectl set-keymap de</code></pre>
<p>To get a list of all available keymaps, run:</p>
<pre class="command"><code spellcheck="false">localectl list-keymaps</code></pre>
<p>I want to install ISPConfig at the end of this tutorial, ISPConfig ships with the Bastille firewall script that I will use as the&nbsp;firewall, therefor&nbsp;I disable the default CentOS firewall now. Of course, you are free to leave the CentOS firewall on and configure it to your needs (but then you shouldn't use any other firewall later on as it will most probably interfere with the CentOS firewall).</p>
<p>Run...</p>
<pre class="command"><code spellcheck="false">dnf -y install net-tools wget rsyslog<br />systemctl stop firewalld.service<br />systemctl disable firewalld.service</code></pre>
<p>to stop and disable the CentOS firewall. It is ok when you get errors here, this just indicates that the firewall was not installed.</p>
<p>Then you should check that the firewall has really been disabled. To do so, run the command:</p>
<pre class="command"><code spellcheck="false">iptables -L</code></pre>
<p>The output should look like this:</p>
<pre class="system"><code spellcheck="false">[<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="98eaf7f7ecd8ebfdeaeefdeaa9">[email&#160;protected]</a> ~]# iptables -L<br />Chain INPUT (policy ACCEPT)<br />target prot opt source destination</code></pre>
<pre class="system"><code spellcheck="false">Chain FORWARD (policy ACCEPT)<br />target prot opt source destination</code></pre>
<pre class="system"><code spellcheck="false">Chain OUTPUT (policy ACCEPT)<br />target prot opt source destination</code></pre>
<p>Or use the firewall-cmd command:</p>
<pre class="command"><code spellcheck="false">firewall-cmd --state</code></pre>
<pre class="system"><code spellcheck="false">[<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="9eecf1f1eadeedfbece8fbecaf">[email&#160;protected]</a> ~]# firewall-cmd --state<br />not running<br />[<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="a8dac7c7dce8dbcddadecdda99">[email&#160;protected]</a> ~]#</code></pre>
<p>Now I will install the network configuration editor and the shell based editor "nano" that I will use&nbsp;in the next steps to edit the config files:</p>
<pre class="command"><code spellcheck="false">dnf -y install nano wget NetworkManager-tui yum-utils</code></pre>
<p>If you did not configure your network card during the installation, you can do that now. Run...</p>
<pre class="command"><code spellcheck="false">nmtui</code></pre>
<p>... and go to <span class="system">Edit a connection</span>:</p>
<p style="text-align: center;"><a class="fancybox" id="img-nmtui1" href="https://www.howtoforge.com/images/perfect_server_centos_7_1_x86_64_apache2_dovecot_ispconfig3/big/nmtui1.png"><img alt="Edit Network connection" src="https://www.howtoforge.com/images/perfect_server_centos_7_1_x86_64_apache2_dovecot_ispconfig3/nmtui1.png" width="550" height="300" /></a></p>
<p></p>
<p>Select your network interface:</p>
<p style="text-align: center;"><a class="fancybox" id="img-nmtui2" href="https://www.howtoforge.com/images/perfect_server_centos_7_1_x86_64_apache2_dovecot_ispconfig3/big/nmtui2.png"><img alt="Select network interface" src="https://www.howtoforge.com/images/perfect_server_centos_7_1_x86_64_apache2_dovecot_ispconfig3/nmtui2.png" width="550" height="278" /></a></p>
<p></p>
<p>Then fill in your network details - disable DHCP and fill in a static IP address, a netmask, your gateway, and one or two nameservers, then hit <span class="system">Ok</span>:</p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;">

<div id='div-gpt-ad-1527185271042-6' style='height:250px; width:300px;'>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-6'); });
</script>
</div>
</div>
<p><a class="fancybox" id="img-nmtui3" href="https://www.howtoforge.com/images/perfect_server_centos_7_1_x86_64_apache2_dovecot_ispconfig3/big/nmtui3.png"><img alt="Set netmask" src="https://www.howtoforge.com/images/perfect_server_centos_7_1_x86_64_apache2_dovecot_ispconfig3/nmtui3.png" width="550" height="328" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Next select <span class="system">OK</span> to confirm the changes that you made in the network settings</p>
<p><a class="fancybox" id="img-nmtui4" href="https://www.howtoforge.com/images/perfect_server_centos_7_1_x86_64_apache2_dovecot_ispconfig3/big/nmtui4.png"><img alt="Confirm network settings" src="https://www.howtoforge.com/images/perfect_server_centos_7_1_x86_64_apache2_dovecot_ispconfig3/nmtui4.png" width="550" height="115" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>and <span class="system">Quit</span> to close the nmtui network configuration tool.</p>
<p><a class="fancybox" id="img-nmtui5" href="https://www.howtoforge.com/images/perfect_server_centos_7_1_x86_64_apache2_dovecot_ispconfig3/big/nmtui5.png"><img src="https://www.howtoforge.com/images/perfect_server_centos_7_1_x86_64_apache2_dovecot_ispconfig3/nmtui5.png" alt="Quit nmtui" width="550" height="339" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>You should run</p>
<pre class="command"><code spellcheck="false">ifconfig</code></pre>
<p>now to check if the installer got your IP address right:</p>
<pre><code spellcheck="false">[<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="0f7d60607b4f7c6a7d796a7d3e">[email&#160;protected]</a> ~]# ifconfig<br />ens33: flags=4163&lt;UP,BROADCAST,RUNNING,MULTICAST&gt; &nbsp;mtu 1500<br />&nbsp; &nbsp; &nbsp; &nbsp; inet 192.168.0.100 &nbsp;netmask 255.255.255.0 &nbsp;broadcast 192.168.0.255<br />&nbsp; &nbsp; &nbsp; &nbsp; inet6 fe80::20c:29ff:feee:b665 &nbsp;prefixlen 64 &nbsp;scopeid 0x20&lt;link&gt;<br />&nbsp; &nbsp; &nbsp; &nbsp; inet6 2003:e1:bf22:1b00:20c:29ff:feee:b665 &nbsp;prefixlen 64 &nbsp;scopeid 0x0&lt;global&gt;<br />&nbsp; &nbsp; &nbsp; &nbsp; ether 00:0c:29:ee:b6:65 &nbsp;txqueuelen 1000 &nbsp;(Ethernet)<br />&nbsp; &nbsp; &nbsp; &nbsp; RX packets 2874 &nbsp;bytes 1369892 (1.3 MiB)<br />&nbsp; &nbsp; &nbsp; &nbsp; RX errors 0 &nbsp;dropped 546 &nbsp;overruns 0 &nbsp;frame 0<br />&nbsp; &nbsp; &nbsp; &nbsp; TX packets 968 &nbsp;bytes 160901 (157.1 KiB)<br />&nbsp; &nbsp; &nbsp; &nbsp; TX errors 0 &nbsp;dropped 0 overruns 0 &nbsp;carrier 0 &nbsp;collisions 0</code></pre>
<pre><code spellcheck="false">lo: flags=73&lt;UP,LOOPBACK,RUNNING&gt; &nbsp;mtu 65536<br />&nbsp; &nbsp; &nbsp; &nbsp; inet 127.0.0.1 &nbsp;netmask 255.0.0.0<br />&nbsp; &nbsp; &nbsp; &nbsp; inet6 ::1 &nbsp;prefixlen 128 &nbsp;scopeid 0x10&lt;host&gt;<br />&nbsp; &nbsp; &nbsp; &nbsp; loop &nbsp;txqueuelen 1000 &nbsp;(Local Loopback)<br />&nbsp; &nbsp; &nbsp; &nbsp; RX packets 0 &nbsp;bytes 0 (0.0 B)<br />&nbsp; &nbsp; &nbsp; &nbsp; RX errors 0 &nbsp;dropped 0 &nbsp;overruns 0 &nbsp;frame 0<br />&nbsp; &nbsp; &nbsp; &nbsp; TX packets 0 &nbsp;bytes 0 (0.0 B)<br />&nbsp; &nbsp; &nbsp; &nbsp; TX errors 0 &nbsp;dropped 0 overruns 0 &nbsp;carrier 0 &nbsp;collisions 0</code></pre>
<p>If your network card does not show up there, then it not be enabled on boot, In this case, open the file <span class="system">/etc/sysconfig/network-scripts/ifcfg-eth0</span></p>
<pre class="command"><code spellcheck="false">nano /etc/sysconfig/network-scripts/ifcfg-ens33</code></pre>
<p>and set ONBOOT to yes:</p>
<pre class="system"><code spellcheck="false">[...]<br />ONBOOT=yes<br />[...]</code></pre>
<p>and reboot the server.</p>
<p>Check your <span class="system">/etc/resolv.conf</span> if it lists all nameservers that you've previously configured:</p>
<pre class="command"><code spellcheck="false">cat /etc/resolv.conf</code></pre>
<p>If nameservers are missing, run</p>
<pre class="command"><code spellcheck="false">nmtui</code></pre>
<p>and add the missing nameservers again.</p>
<p>Now, on to the configuration...</p>
<p><strong>Adjusting /etc/hosts and /etc/hostname</strong></p>
<p>Next, we will edit <span class="system">/etc/hosts</span>. Make it look like this:</p>
<pre class="command"><code spellcheck="false">nano /etc/hosts</code></pre>
<pre><code spellcheck="false">127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4<br />192.168.0.100   server1.example.com     server1<br /><br />::1         localhost localhost.localdomain localhost6 localhost6.localdomain6</code></pre>
<p>Set the hostname in the /etc/hostname file. The file shall contain the fully qualified domain name (e.g. server1.example.com in my case) and not just the short name like "server1". Open the file with the nano editor:</p>
<pre class="command"><code spellcheck="false">nano /etc/hostname</code></pre>
<p>And set the hostname in the file.</p>
<pre><code spellcheck="false">server1.example.com</code></pre>
<p>Save the file and exit nano.</p>
<p><strong>Set SELinux to permissive</strong></p>
<p>SELinux is a security extension of CentOS that should provide extended security.&nbsp;ISPConfig does not ship with an SELinux rule set, therefore I&nbsp;set it to permissive (this is a must if you want to install ISPConfig later on).</p>
<p>Edit <span class="system">/etc/selinux/config</span> and set <span class="system">SELINUX=permissive</span>:</p>
<pre class="command"><code spellcheck="false">nano /etc/selinux/config</code></pre>
<pre># This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
#     enforcing - SELinux security policy is enforced.
#     permissive - SELinux prints warnings instead of enforcing.
#     disabled - No SELinux policy is loaded.
SELINUX=permissive
# SELINUXTYPE= can take one of these two values:
#     targeted - Targeted processes are protected,
#     mls - Multi Level Security protection.
SELINUXTYPE=targeted
</pre>
<p>Afterwards we must reboot the system:</p>
<pre class="command"><code spellcheck="false">reboot</code></pre>
<h2 id="nbspenable-additional-repositories-and-install-some-software">4&nbsp;Enable Additional Repositories and Install Some Software</h2>
<p>First, we import the GPG keys for software packages:</p>
<pre class="command"><code spellcheck="false">rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY*</code></pre>
<p>Then we enable the EPEL repository on our CentOS system as lots of the packages that we are going to install in the course of this tutorial are not available in the official CentOS 8 repository:</p>
<pre class="command"><code spellcheck="false"><span>dnf -y install epel-release</span></code></pre>
<p>Activate Power Tools:</p>
<pre class="command"><code spellcheck="false">dnf config-manager --set-enabled PowerTools</code></pre>
<p>Then we update our existing packages on the system:</p>
<pre class="command"><code spellcheck="false">dnf -y update</code></pre>
<p>Now we install some software packages that are needed later on:</p>
<pre class="command"><code spellcheck="false">dnf -y groupinstall 'Development Tools'</code></pre>
<h2 id="-quota">5 Quota</h2>
<p><span class="highlight">(If you have chosen a different partitioning scheme than I did, you must adjust this chapter so that quota applies to the partitions where you need it.) </span></p>
<p>To install quota, we run this command:</p>
<pre class="command"><code spellcheck="false">dnf -y install quota</code></pre>
<p>Now we check if the quota is already enabled for the file system where the website (/var/www) and Maildir data (var/vmail) is stored. In this example setup, I have one big root partition, so I search for ' / ':</p>
<pre class="command"><code spellcheck="false">mount | grep ' / '</code></pre>
<pre class="system"><code spellcheck="false">[<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="6d1f0202192d1e081f1b081f5c">[email&#160;protected]</a> ~]# mount | grep ' / '<br />/dev/mapper/centos-root on / type xfs (rw,relatime,attr2,inode64,noquota)<br />[<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="d3a1bcbca793a0b6a1a5b6a1e2">[email&#160;protected]</a> ~]#</code></pre>
<p>If you have a separate /var partition, then use:</p>
<pre class="command"><code spellcheck="false">mount | grep ' /var '</code></pre>
<p>instead. If the line contains the word "<strong>noquota</strong>", then proceed with the following steps to enable quota.</p>
<h3 id="enabling-quota-on-the-root-partition">Enabling quota on the / (root) partition</h3>
<p>Normally you would enable quota in the /etc/fstab file, but if the filesystem is the root filesystem "/", then quota has to be enabled by a boot parameter of the Linux Kernel.</p>
<p>Edit the grub configuration file:</p>
<pre class="command"><code spellcheck="false">nano /etc/default/grub</code></pre>
<p>Search for the line that starts with <span class="system">GRUB_CMDLINE_LINUX</span> and add <span class="system">rootflags=uquota,gquota</span> to the commandline parameters so that the resulting line looks like this:</p>
<pre><code spellcheck="false">GRUB_CMDLINE_LINUX="crashkernel=auto resume=/dev/mapper/cl-swap rd.lvm.lv=cl/root rd.lvm.lv=cl/swap rootflags=uquota,gquota"</code></pre>
<p>and apply the changes by running the following command.</p>
<pre class="command"><code spellcheck="false">cp /boot/grub2/grub.cfg /boot/grub2/grub.cfg_bak<br />grub2-mkconfig -o /boot/grub2/grub.cfg</code></pre>
<p>and reboot the server.</p>
<pre class="command"><code spellcheck="false">reboot</code></pre>
<p>Now check if quota is enabled:</p>
<pre class="command"><code spellcheck="false">mount | grep ' / '</code></pre>
<pre class="system"><code spellcheck="false">[<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="9ceef3f3e8dceff9eeeaf9eead">[email&#160;protected]</a> ~]# mount | grep ' / '<br />/dev/mapper/centos-root on / type xfs (rw,relatime,attr2,inode64,usrquota,grpquota)<br />[<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="bac8d5d5cefac9dfc8ccdfc88b">[email&#160;protected]</a> ~]#</code></pre>
<p>When quota is active, we can see "<strong>usrquota,grpquota</strong>" in the mount option list.</p>
<h3 id="enabling-quota-on-a-separate-var-partition">Enabling quota on a separate /var partition</h3>
<p>If you have a separate /var partition, then edit <span class="system">/etc/fstab</span> and add <span class="system">,uquota,gquota</span> to the <span class="system">/</span> partition (<span class="system">/dev/mapper/centos-var</span>):</p>
<pre class="command"><code spellcheck="false">nano /etc/fstab</code></pre>
<pre><br />#<br /># /etc/fstab<br /># Created by anaconda on Sun Sep 21 16:33:45 2014<br />#<br /># Accessible filesystems, by reference, are maintained under '/dev/disk'<br /># See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info<br />#<br />/dev/mapper/centos-root /                       xfs     defaults        1 1<br />/dev/mapper/centos-var /var                     xfs     defaults<span class="system">,uquota,gquota</span>        1 2<br />UUID=9ac06939-7e43-4efd-957a-486775edd7b4 /boot                   xfs     defaults        1 3<br />/dev/mapper/centos-swap swap                    swap    defaults        0 0
</pre>
<p>Then run</p>
<pre class="command"><code spellcheck="false">mount -o remount /var</code></pre>
<pre class="command"><code spellcheck="false">quotacheck -avugm<br />quotaon -avug</code></pre>
<p>to enable quota. When you get an error that there is no partition with quota enabled, then reboot the server before you proceed.</p>
<h2 id="-install-apache-php-mysql-and-phpmyadmin">6 Install Apache, PHP, MySQL and phpMyAdmin</h2>
<p>Enable the Remi repository to get newer PHP versions (currently PHP 7.4):</p>
<pre class="command"><code spellcheck="false">dnf install http://rpms.remirepo.net/enterprise/remi-release-8.rpm<br />dnf -y install yum-utils<br />dnf -y module reset php<br />dnf -y module install php:remi-7.4<br />dnf update</code></pre>
<p>We can install the needed packages with one single command:</p>
<pre class="command"><code spellcheck="false">dnf -y install httpd mod_ssl mariadb-server php php-mysqlnd php-mbstring</code></pre>
<p>To ensure that the server cannot be attacked through the <a href="https://www.howtoforge.com/tutorial/httpoxy-protect-your-server/">HTTPOXY</a>&nbsp;vulnerability, we will disable the HTTP_PROXY header in apache globally.&nbsp;</p>
<p>Add the apache header rule at the end of the httpd.conf file:</p>
<pre class="command"><code spellcheck="false">echo "RequestHeader unset Proxy early" &gt;&gt; /etc/httpd/conf/httpd.conf</code></pre>
<p>And restart httpd to apply the configuration change.</p>
<pre class="command"><code spellcheck="false">service httpd restart</code></pre>
<p>Install phpMyAdmin:</p>
<pre class="command"><code spellcheck="false">cd /tmp<br />wget https://files.phpmyadmin.net/phpMyAdmin/5.0.2/phpMyAdmin-5.0.2-all-languages.tar.gz<br />tar xzvf phpMyAdmin-5.0.2-all-languages.tar.gz<br />mkdir /usr/share/phpmyadmin<br />mv phpMyAdmin-5.0.2-all-languages/* /usr/share/phpmyadmin/<br />mkdir /usr/share/phpmyadmin/tmp<br />chown -R apache:apache /usr/share/phpmyadmin<br />chmod 777 /usr/share/phpmyadmin/tmp</code></pre>
<h3 id="optional-change-the-apache-mpm-module">Optional: Change the Apache MPM Module</h3>
<p>CentOS 8 uses the Apache MPM Event module by default, this is good on one side, as it allows you to use HTTP/2 protocol. On the other hand, it does not allow you to use the apache mod_php module. In general, one should use PHP-FPM as default today and ISPConfig supports that. In case you need the old mod_php mode for compatibility reasons, then you can switch the Apache MPM like this:</p>
<pre class="command"><code spellcheck="false">nano /etc/httpd/conf.modules.d/00-mpm.conf</code></pre>
<p>Add a # in front of the MPM event line so it looks like this:</p>
<pre><code spellcheck="false"># LoadModule mpm_event_module modules/mod_mpm_event.so</code></pre>
<p>Then remove the # in from of the MPM Prefork line, so it looks like this:</p>
<pre><code spellcheck="false">LoadModule mpm_prefork_module modules/mod_mpm_prefork.so</code></pre>
<p>Then restart httpd to apply the configuration change.</p>
<pre class="command"><code spellcheck="false">service httpd restart</code></pre>
<h2 id="-install-dovecot">7 Install Dovecot</h2>
<p>Dovecot can be installed as follows:</p>
<pre class="command"><code spellcheck="false">dnf -y install dovecot dovecot-mysql dovecot-pigeonhole</code></pre>
<p>Create an empty dovecot-sql.conf file and create symlinks:</p>
<pre class="command"><code spellcheck="false">touch /etc/dovecot/dovecot-sql.conf<br />ln -s /etc/dovecot/dovecot-sql.conf /etc/dovecot-sql.conf<br /><span>ln -s /etc/dovecot/dovecot.conf /etc/dovecot.conf</span></code></pre>
<p>Now create the system startup links and start Dovecot:</p>
<pre class="command"><code spellcheck="false">systemctl enable dovecot<br />systemctl start dovecot</code></pre>
<h2 id="-install-postfix">8 Install Postfix</h2>
<p>Postfix can be installed as follows:</p>
<pre class="command"><code spellcheck="false">dnf -y install postfix postfix-mysql</code></pre>
<p>Next, open the TLS/SSL and submission ports in Postfix:</p>
<pre class="command"><code spellcheck="false">nano /etc/postfix/master.cf</code></pre>
<p><span>Uncomment the&nbsp;</span><span class="system">submission</span><span>&nbsp;and&nbsp;</span><span class="system">smtps</span><span>&nbsp;sections as follows and add lines where necessary so that this section of the master.cf file looks exactly like the one below.&nbsp;</span><strong>IMPORTANT:</strong><span>&nbsp;Remove the # in front of the lines that start with smtps and submission too and not just from the -o lines after these lines!</span></p>
<pre><code spellcheck="false">[...]<br />submission inet n - n - - smtpd<br /> -o syslog_name=postfix/submission<br /> -o smtpd_tls_security_level=encrypt<br /> -o smtpd_sasl_auth_enable=yes<br /> -o smtpd_client_restrictions=permit_sasl_authenticated,reject<br /># -o smtpd_reject_unlisted_recipient=no<br /># -o smtpd_client_restrictions=$mua_client_restrictions<br /># -o smtpd_helo_restrictions=$mua_helo_restrictions<br /># -o smtpd_sender_restrictions=$mua_sender_restrictions<br /># -o smtpd_recipient_restrictions=<br /># -o smtpd_relay_restrictions=permit_sasl_authenticated,reject<br /># -o milter_macro_daemon_name=ORIGINATING<br />smtps inet n - n - - smtpd<br /> -o syslog_name=postfix/smtps<br /> -o smtpd_tls_wrappermode=yes<br /> -o smtpd_sasl_auth_enable=yes<br /> -o smtpd_client_restrictions=permit_sasl_authenticated,reject<br /># -o smtpd_reject_unlisted_recipient=no<br /># -o smtpd_client_restrictions=$mua_client_restrictions<br /># -o smtpd_helo_restrictions=$mua_helo_restrictions<br /># -o smtpd_sender_restrictions=$mua_sender_restrictions<br /># -o smtpd_recipient_restrictions=<br /># -o smtpd_relay_restrictions=permit_sasl_authenticated,reject<br /># -o milter_macro_daemon_name=ORIGINATING<br />[...]</code></pre>
<p>Then turn off Sendmail and start Postfix and MariaDB (MySQL):</p>
<pre class="command"><code spellcheck="false">systemctl enable mariadb.service<br />systemctl start mariadb.service</code></pre>
<pre class="command"><code spellcheck="false">systemctl enable postfix.service<br />systemctl restart postfix.service</code></pre>
<p>We disable sendmail to ensure that it does not get started in case it is installed on your server. So the error message "Failed to issue method call: Unit sendmail.service not loaded." can be ignored.</p>
<h2 id="-install-getmail">9 Install Getmail</h2>
<p>Getmail can be installed as follows:</p>
<pre class="command"><code spellcheck="false">dnf install python2<br />cd /tmp<br />wget http://pyropus.ca/software/getmail/old-versions/getmail-5.14.tar.gz<br />tar xvfz getmail-5.14.tar.gz<br />cd getmail-5.14<br />python2 setup.py build<br />python2 setup.py install</code></pre>
<h2 id="-set-mysql-passwords-and-configure-phpmyadmin">10 Set MySQL Passwords and Configure phpMyAdmin</h2>
<p>Set passwords for the MySQL root account:</p>
<pre class="command"><code spellcheck="false">mysql_secure_installation</code></pre>
<pre class="system"><code spellcheck="false">[<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="0c7e6363784c7f697e7a697e3d">[email&#160;protected]</a>&nbsp;tmp]#&nbsp;mysql_secure_installation<br /><br /><br />NOTE: RUNNING ALL PARTS OF THIS SCRIPT IS RECOMMENDED FOR ALL MariaDB<br />SERVERS IN PRODUCTION USE! PLEASE READ EACH STEP CAREFULLY!</code></pre>
<pre class="system"><code spellcheck="false">In order to log into MariaDB to secure it, we'll need the current<br />password for the root user. If you've just installed MariaDB, and<br />you haven't set the root password yet, the password will be blank,<br />so you should just press enter here.</code></pre>
<pre class="system"><code spellcheck="false">Enter current password for root (enter for none):<br />OK, successfully used password, moving on...</code></pre>
<pre class="system"><code spellcheck="false">Setting the root password ensures that nobody can log into the MariaDB<br />root user without the proper authorisation.<span class="system"><br /><br />Set&nbsp;root&nbsp;password?&nbsp;[Y/n]</span>&nbsp;<span class="highlight">&lt;--&nbsp;ENTER</span><br /><span class="system">New&nbsp;password:</span>&nbsp;<span class="highlight">&lt;--&nbsp;yourrootsqlpassword</span><br /><span class="system">Re-enter&nbsp;new&nbsp;password:</span>&nbsp;<span class="highlight">&lt;--&nbsp;yourrootsqlpassword</span><br /><span class="system">Password&nbsp;updated&nbsp;successfully!<br />Reloading&nbsp;privilege&nbsp;tables..<br />&nbsp;...&nbsp;Success!<br /><br /><br />By default, a MariaDB installation has an anonymous user, allowing anyone<br />to log into MariaDB without having to have a user account created for<br />them. This is intended only for testing, and to make the installation<br />go a bit smoother. You should remove them before moving into a<br />production environment.<br /><br />Remove&nbsp;anonymous&nbsp;users?&nbsp;[Y/n]</span>&nbsp;<span class="highlight">&lt;--&nbsp;ENTER</span><br /><span class="system">&nbsp;...&nbsp;Success!<br /><br />Normally,&nbsp;root&nbsp;should&nbsp;only&nbsp;be&nbsp;allowed&nbsp;to&nbsp;connect&nbsp;from&nbsp;'localhost'.&nbsp;&nbsp;This<br />ensures&nbsp;that&nbsp;someone&nbsp;cannot&nbsp;guess&nbsp;at&nbsp;the&nbsp;root&nbsp;password&nbsp;from&nbsp;the&nbsp;network.<br /><br />Disallow&nbsp;root&nbsp;login&nbsp;remotely?&nbsp;[Y/n]</span>&nbsp;<span class="highlight">&lt;--&nbsp;ENTER</span><br /><span class="system">&nbsp;...&nbsp;Success!<br /><br />By default, MariaDB comes with a database named 'test' that anyone can<br />access. This is also intended only for testing, and should be removed<br />before moving into a production environment.<br /><br />Remove&nbsp;test&nbsp;database&nbsp;and&nbsp;access&nbsp;to&nbsp;it?&nbsp;[Y/n]</span>&nbsp;<span class="highlight">&lt;--&nbsp;ENTER</span><br /><span class="system">&nbsp;-&nbsp;Dropping&nbsp;test&nbsp;database...<br />&nbsp;...&nbsp;Success!<br />&nbsp;-&nbsp;Removing&nbsp;privileges&nbsp;on&nbsp;test&nbsp;database...<br />&nbsp;...&nbsp;Success!<br /><br />Reloading&nbsp;the&nbsp;privilege&nbsp;tables&nbsp;will&nbsp;ensure&nbsp;that&nbsp;all&nbsp;changes&nbsp;made&nbsp;so&nbsp;far<br />will&nbsp;take&nbsp;effect&nbsp;immediately.<br /><br />Reload&nbsp;privilege&nbsp;tables&nbsp;now?&nbsp;[Y/n]</span>&nbsp;<span class="highlight">&lt;--&nbsp;ENTER</span><br /><span class="system">&nbsp;...&nbsp;Success!<br /><br />Cleaning&nbsp;up...<br /><br /><br /><br />All done! If you've completed all of the above steps, your MariaDB<br />installation should now be secure.<br /><br />Thanks for using MariaDB!<br /><br />[<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="483a27273c083b2d3a3e2d3a79">[email&#160;protected]</a>&nbsp;tmp]#</span></code></pre>
<p>Now we configure phpMyAdmin. Create this phpMyAdmin configuration file:</p>
<pre class="command"><code spellcheck="false">nano /etc/httpd/conf.d/phpmyadmin.conf</code></pre>
<p>Add this content to the file:</p>
<pre># phpMyAdmin - Web based MySQL browser written in php
#
# Allows only localhost by default
#
# But allowing phpMyAdmin to anyone other than localhost should be considered
# dangerous unless properly secured by SSL

Alias /phpMyAdmin /usr/share/phpmyadmin
Alias /phpmyadmin /usr/share/phpmyadmin

&lt;Directory /usr/share/phpmyadmin/&gt;
   &lt;IfModule mod_authz_core.c&gt;
     # Apache 2.4
<span class="highlight">  #  &lt;RequireAny&gt;
     #  Require ip 127.0.0.1
     #  Require ip ::1
  #  &lt;/RequireAny&gt;</span>
   &lt;/IfModule&gt;
   &lt;IfModule !mod_authz_core.c&gt;
     # Apache 2.2
     Order Deny,Allow
     Deny from All
     Allow from 127.0.0.1
     Allow from ::1
   &lt;/IfModule&gt;
&lt;/Directory&gt;
            </pre>
<p>Next, we change the authentication in phpMyAdmin from <span class="system">cookie</span> to <span class="system">http</span>:</p>
<pre class="command"><code spellcheck="false">cp -pf /usr/share/phpmyadmin/config.sample.inc.php /usr/share/phpmyadmin/config.inc.php<br />nano /usr/share/phpmyadmin/config.inc.php</code></pre>
<pre>[...]
/* Authentication type */
$cfg['Servers'][$i]['auth_type'] = 'http';
[...]</pre>
<p>Then we create the system startup links for Apache and start it:</p>
<pre class="command"><code spellcheck="false">systemctl enable httpd<br />systemctl restart httpd</code></pre>
<p>Now you can direct your browser to <span class="system">http://server1.example.com/phpmyadmin/</span> or <span class="system">http://192.168.0.100/phpmyadmin/</span> and log in with the user name <span class="system">root</span> and your new root MySQL password.</p>
<h2 id="-install-amavisdnew-spamassassin-clamav-and-postgrey">11 Install Amavisd-new, SpamAssassin, ClamAV, and Postgrey</h2>
<p>To install amavisd-new, SpamAssassin and ClamAV, run the following command:</p>
<pre class="command"><code spellcheck="false">dnf -y install amavisd-new spamassassin clamav-server clamav-data clamav-update clamav-filesystem clamav clamav-scanner-systemd clamav-devel clamav-lib clamav-server-systemd unzip bzip2 perl-DBD-mysql postgrey re2c</code></pre>
<p>Then we start freshclam, amavisd, and clamd.amavisd:</p>
<pre class="command"><code spellcheck="false">sa-update<br />freshclam<br />systemctl enable amavisd.service<br />systemctl start amavisd.service<br />systemctl start <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="6a09060b070e2a0b070b1c03190e44190f181c03090f">[email&#160;protected]</a><br /><span>systemctl enable postgrey.service</span><br /><span>systemctl start postgrey.service</span></code></pre>
<h2 id="-installing-apache-with-modphp-modfcgiphp-phpfpm">12 Installing Apache with mod_php, mod_fcgi/PHP, PHP-FPM</h2>
<p>ISPConfig 3 allows you to use mod_php, mod_fcgi/PHP, cgi/PHP, and PHP-FPM on a per website basis.</p>
<p>We can install Apache2 with mod_php, mod_fcgid, and PHP as follows:</p>
<pre class="command"><code spellcheck="false">dnf -y install php php-devel php-gd php-imap php-ldap php-mysql php-odbc php-pear php-xml php-xmlrpc php-pecl-apc php-mbstring php-mcrypt php-snmp php-soap php-tidy curl curl-devel perl-libwww-perl ImageMagick libxml2 libxml2-devel mod_fcgid php-cli httpd-devel php-fpm php-intl php-imagick php-pspell wget</code></pre>
<p>Next, we open <span class="system">/etc/php.ini</span>...</p>
<pre class="command"><code spellcheck="false">nano /etc/php.ini</code></pre>
<p>... and change the error reporting (so that notices aren't shown any longer), set the timezone and uncomment <span class="system">cgi.fix_pathinfo=1</span>:</p>
<pre>[...]
;error_reporting = E_ALL &amp; ~E_DEPRECATED
error_reporting = E_ALL &amp; ~E_NOTICE &amp; ~E_DEPRECATED &amp; ~E_STRICT
[...]
; cgi.fix_pathinfo provides *real* PATH_INFO/PATH_TRANSLATED support for CGI.  PHP's
; previous behaviour was to set PATH_TRANSLATED to SCRIPT_FILENAME, and to not grok
; what PATH_INFO is.  For more information on PAppp.tldTH_INFO, see the cgi specs.  Setting
; this to 1 will cause PHP CGI to fix its paths to conform to the spec.  A setting
; of zero causes PHP to behave as before.  Default is 1.  You should fix your scripts
; to use SCRIPT_FILENAME rather than PATH_TRANSLATED.
; http://www.php.net/manual/en/ini.core.php#ini.cgi.fix-pathinfo
cgi.fix_pathinfo=1<br />[...]<br />date.timezone = 'Europe/Berlin'
[...]</pre>
<p>Enable httpd and PHP-FPM to get started at boot time and start the PHP-FPM service.</p>
<pre class="command"><code spellcheck="false">systemctl start php-fpm.service<br />systemctl enable php-fpm.service<br />systemctl enable httpd.service</code></pre>
<p>Finally, we restart Apache:</p>
<pre class="command"><code spellcheck="false">systemctl restart httpd.service</code></pre>
<p>Now we will add support for Let's encrypt.</p>
<pre class="command"><code spellcheck="false">mkdir /opt/certbot<br />cd /opt/certbot<br />wget https://dl.eff.org/certbot-auto<br />chmod a+x ./certbot-auto</code></pre>
<p>Now run the certbot-auto command which will download and install the software and it's dependencies.</p>
<pre class="command"><code spellcheck="false">./certbot-auto</code></pre>
<p>The command will then tell you that "no names were found in your configuration files" and asks if it shall continue, please chose "c" to cancel here as the certs will be created by ispconfig.</p>
<p style="text-align: center;"><a class="fancybox" id="img-centos-certbot" href="https://www.howtoforge.com/images/perfect_server_centos_7_4_apache_dovecot_ispconfig/big/centos-certbot.png"><img src="https://www.howtoforge.com/images/perfect_server_centos_7_4_apache_dovecot_ispconfig/centos-certbot.png" alt="Install certbot on CentOS" width="550" height="194" /></a></p>
<h2 id="-installation-of-modpython">13 Installation of mod_python</h2>
<p>The Apache module mod_python is not available as RPM package, therefore we will compile it from source. The first step is to install the python development files and download the current mod_python version as .tar.gz file</p>
<pre class="command"><code spellcheck="false">dnf -y install python3-devel</code></pre>
<pre class="command"><code spellcheck="false">cd /usr/local/src/<br />wget http://dist.modpython.org/dist/mod_python-3.5.0.tgz<br />tar xfz mod_python-3.5.0.tgz<br />cd mod_python-3.5.0</code></pre>
<p>and then configure and compile the module.</p>
<pre class="command"><code spellcheck="false">./configure --with-python=/usr/bin/python3<br />make</code></pre>
<p>There is an error in the compiled module that will cause the installation to fail with the error "<em>version = "fatal: Not a git repository (or any of the parent directories): .git</em>". To fix that, run this sed command (the command is one line!).</p>
<pre class="command"><code spellcheck="false">sed -e 's/(git describe --always)/(git describe --always 2&gt;\/dev\/null)/g' -e 's/`git describe --always`/`git describe --always 2&gt;\/dev\/null`/g' -i $( find . -type f -name Makefile\* -o -name version.sh )</code></pre>
<p>Then install the module with this command.</p>
<pre class="command"><code spellcheck="false">make install</code></pre>
<p>and enable the module in Apache:</p>
<pre class="command"><code spellcheck="false">echo 'LoadModule python_module modules/mod_python.so' &gt; /etc/httpd/conf.modules.d/10-python.conf<br />systemctl restart httpd.service</code></pre>
<h2 id="-install-pureftpd">14 Install PureFTPd</h2>
<p>PureFTPd can be installed with the following command:</p>
<pre class="command"><code spellcheck="false">dnf -y install pure-ftpd</code></pre>
<p>Then create the system startup links and start PureFTPd:</p>
<pre class="command"><code spellcheck="false">systemctl enable pure-ftpd.service<br />systemctl start pure-ftpd.service</code></pre>
<p>Now we configure PureFTPd to allow FTP and TLS sessions. FTP is a very insecure protocol because all passwords and all data are transferred in clear text. By using TLS, the whole communication can be encrypted, thus making FTP much more secure.</p>
<p>OpenSSL is needed by TLS; to install OpenSSL, we simply run:</p>
<pre class="command"><code spellcheck="false">dnf install openssl</code></pre>
<p>Open <span class="system">/etc/pure-ftpd/pure-ftpd.conf</span>...</p>
<pre class="command"><code spellcheck="false">nano /etc/pure-ftpd/pure-ftpd.conf</code></pre>
<p>If you want to allow FTP and TLS sessions, set <span class="system">TLS</span> to <span class="system">1</span>&nbsp;by removing the # in front of the TLS line. It is highly recommended to enable TLS.</p>
<pre>[...]
# This option can accept three values :
# 0 : disable SSL/TLS encryption layer (default).
# 1 : accept both traditional and encrypted sessions.
# 2 : refuse connections that don't use SSL/TLS security mechanisms,
#     including anonymous sessions.
# Do _not_ uncomment this blindly. Be sure that :
# 1) Your server has been compiled with SSL/TLS support (--with-tls),
# 2) A valid certificate is in place,
# 3) Only compatible clients will log in.

TLS                      1
[...]</pre>
<p>In order to use TLS, we must create an SSL certificate. I create it in <span class="system">/etc/ssl/private/</span>, therefore I create that directory first:</p>
<pre class="command"><code spellcheck="false">mkdir -p /etc/ssl/private/</code></pre>
<p>Afterward, we can generate the SSL certificate as follows:</p>
<pre class="command"><code spellcheck="false">openssl req -x509 -nodes -days 7300 -newkey rsa:2048 -keyout /etc/ssl/private/pure-ftpd.pem -out /etc/ssl/private/pure-ftpd.pem</code></pre>
<p><span class="system">Country Name (2 letter code) [XX]: </span><span class="highlight">&lt;-- Enter your Country Name (e.g., "DE").</span><span class="system"><br />State or Province Name (full name) []:</span><span class="highlight">&lt;-- Enter your State or Province Name.</span><span class="system"><br />Locality Name (eg, city) [Default City]:</span><span class="highlight">&lt;-- Enter your City.</span><span class="system"><br />Organization Name (eg, company) [Default Company Ltd]:</span><span class="highlight">&lt;-- Enter your Organization Name (e.g., the name of your company).</span><span class="system"><br />Organizational Unit Name (eg, section) []:</span><span class="highlight">&lt;-- Enter your Organizational Unit Name (e.g. "IT Department").</span><span class="system"><br />Common Name (eg, your name or your server's hostname) []:</span><span class="highlight">&lt;-- Enter the Fully Qualified Domain Name of the system (e.g. "server1.example.com").</span><span class="system"><br />Email Address []:</span><span class="highlight">&lt;-- Enter your Email Address.</span></p>
<p>Change the permissions of the SSL certificate:</p>
<pre class="command"><code spellcheck="false">chmod 600 /etc/ssl/private/pure-ftpd.pem</code></pre>
<p>Create a DHParam file:</p>
<pre class="command"><code spellcheck="false"><span>openssl dhparam -out /etc/ssl/private/pure-ftpd-dhparams.pem 2048</span></code></pre>
<p>Finally, restart PureFTPd:</p>
<pre class="command"><code spellcheck="false">systemctl restart pure-ftpd.service</code></pre>
<p>That's it. You can now try to connect using your FTP client; however, you should configure your FTP client to use TLS.</p>
<h2 id="-install-bind">15 Install BIND</h2>
<p>We can install BIND as follows:</p>
<pre class="command"><code spellcheck="false">dnf -y install bind bind-utils haveged</code></pre>
<p>Make a backup of the existing <span class="system">/etc/named.conf</span> file and create a new one as follows:</p>
<pre class="command"><code spellcheck="false">cp /etc/named.conf /etc/named.conf_bak<br />cat /dev/null &gt; /etc/named.conf<br />nano /etc/named.conf</code></pre>
<pre>//
// named.conf
//
// Provided by Red Hat bind package to configure the ISC BIND named(8) DNS
// server as a caching only nameserver (as a localhost DNS resolver only).
//
// See /usr/share/doc/bind*/sample/ for example named configuration files.
//
options {
        listen-on port 53 { any; };
        listen-on-v6 port 53 { any; };
        directory       "/var/named";
        dump-file       "/var/named/data/cache_dump.db";
        statistics-file "/var/named/data/named_stats.txt";
        memstatistics-file "/var/named/data/named_mem_stats.txt";
        allow-query     { any; };
				allow-recursion {"none";};
        recursion no;
};
logging {
        channel default_debug {
                file "data/named.run";
                severity dynamic;
        };
};
zone "." IN {
        type hint;
        file "named.ca";
};
include "/etc/named.conf.local";</pre>
<p>Create the file <span class="system">/etc/named.conf.local</span> that is included at the end of <span class="system">/etc/named.conf</span> (<span class="system">/etc/named.conf.local</span> will later on get populated by ISPConfig if you create DNS zones in ISPConfig):</p>
<pre class="command"><code spellcheck="false">touch /etc/named.conf.local</code></pre>
<p>Then we create the startup links and start BIND:</p>
<pre class="command"><code spellcheck="false">systemctl enable named.service<br />systemctl start named.service<br /><span>systemctl enable&nbsp;haveged.service</span><br /><span>systemctl start haveged.service</span></code></pre>
<h2 id="-install-awstats">16 Install AWStats</h2>
<p>AWStats can be installed as follows:</p>
<pre class="command"><code spellcheck="false">dnf -y install awstats perl-DateTime-Format-HTTP perl-DateTime-Format-Builder</code></pre>
<p>The alternative web statistics application 'webalizer' is not available for CentOS 8 anymore, so you will only be able to use AWStats.</p>
<h2 id="-install-jailkit">17 Install Jailkit</h2>
<p>Jailkit is used to chroot SSH users and cronjobs. It can be installed as follows:</p>
<pre class="command"><code spellcheck="false">ln -s /usr/bin/python2 /usr/bin/python<br />cd /tmp<br />wget http://olivier.sessink.nl/jailkit/jailkit-2.21.tar.gz<br />tar xvfz jailkit-2.21.tar.gz<br />cd jailkit-2.21<br />./configure<br />make<br />make install<br />cd ..<br />rm -rf jailkit-2.21*</code></pre>
<h2 id="-install-failban">18 Install Fail2Ban</h2>
<p>This is optional but recommended, because the ISPConfig monitor tries to show the log.</p>
<pre class="command"><code spellcheck="false">dnf -y install iptables-services fail2ban fail2ban-systemd<br />systemctl stop firewalld.service<br />systemctl mask firewalld.service<br /><span>systemctl disable firewalld.service</span></code></pre>
<p>Next we create the&nbsp;/etc/fail2ban/jail.local file and enable monitoring for ssh, email and ftp service.</p>
<pre class="command"><code spellcheck="false">nano&nbsp;/etc/fail2ban/jail.local</code></pre>
<p>Add the following content to the jail.local file:</p>
<pre><code spellcheck="false">[sshd]<br />enabled = true<br />action = iptables[name=sshd, port=ssh, protocol=tcp]<br /><br />[pure-ftpd]<br />enabled = true<br />action = iptables[name=FTP, port=ftp, protocol=tcp]<br />maxretry = 3<br /><br />[dovecot]<br />enabled = true<br />action = iptables-multiport[name=dovecot, port="pop3,pop3s,imap,imaps", protocol=tcp]<br />maxretry = 5<br /><br />[postfix-sasl]<br />enabled = true<br />action = iptables-multiport[name=postfix-sasl, port="smtp,smtps,submission", protocol=tcp]<br />maxretry = 3</code></pre>
<p>Then create the system startup links for fail2ban and start it:</p>
<pre class="command"><code spellcheck="false">systemctl enable fail2ban.service<br />systemctl start fail2ban.service</code></pre>
<h2 id="-install-rkhunter">19 Install rkhunter</h2>
<p>rkhunter can be installed as follows:</p>
<pre class="command"><code spellcheck="false">dnf -y install rkhunter</code></pre>
<h2 id="-install-mailman">20 Install Mailman</h2>
<p>If you like to manage mailing lists with Mailman on your server, then install mailman now. Mailman is supported by ISPConfig, so you will be able to create new mailing lists trough ISPConfig later.</p>
<pre class="command"><code spellcheck="false">dnf -y install mailman</code></pre>
<p>Before we can start Mailman, a first mailing list called <span class="system">mailman</span> must be created:</p>
<pre class="command"><code spellcheck="false">touch /var/lib/mailman/data/aliases<br />postmap&nbsp;/var/lib/mailman/data/aliases<br />/usr/lib/mailman/bin/newlist mailman<br /><span>ln -s&nbsp;/usr/lib/mailman/mail/mailman /usr/bin/mailman</span></code></pre>
<p><span class="system">[<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="30425f5f447043554246554201">[email&#160;protected]</a>&nbsp;tmp]#&nbsp;/usr/lib/mailman/bin/newlist&nbsp;mailman<br />Enter&nbsp;the&nbsp;email&nbsp;of&nbsp;the&nbsp;person&nbsp;running&nbsp;the&nbsp;list:</span>&nbsp;<span class="highlight">&lt;--&nbsp;admin&nbsp;email&nbsp;address,&nbsp;e.g.&nbsp;<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="6b0702181f0a0f0602052b0e130a061b070e45080406">[email&#160;protected]</a></span><br /><span class="system">Initial&nbsp;mailman&nbsp;password:</span>&nbsp;<span class="highlight">&lt;--&nbsp;admin&nbsp;password&nbsp;for&nbsp;the&nbsp;mailman&nbsp;list</span><br /><span class="system">To&nbsp;finish&nbsp;creating&nbsp;your&nbsp;mailing&nbsp;list,&nbsp;you&nbsp;must&nbsp;edit&nbsp;your&nbsp;/etc/aliases&nbsp;(or<br />equivalent)&nbsp;file&nbsp;by&nbsp;adding&nbsp;the&nbsp;following&nbsp;lines,&nbsp;and&nbsp;possibly&nbsp;running&nbsp;the<br />`newaliases'&nbsp;program:<br /><br />##&nbsp;mailman&nbsp;mailing&nbsp;list<br />mailman:&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;"|/usr/lib/mailman/mail/mailman&nbsp;post&nbsp;mailman"<br />mailman-admin:&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;"|/usr/lib/mailman/mail/mailman&nbsp;admin&nbsp;mailman"<br />mailman-bounces:&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;"|/usr/lib/mailman/mail/mailman&nbsp;bounces&nbsp;mailman"<br />mailman-confirm:&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;"|/usr/lib/mailman/mail/mailman&nbsp;confirm&nbsp;mailman"<br />mailman-join:&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;"|/usr/lib/mailman/mail/mailman&nbsp;join&nbsp;mailman"<br />mailman-leave:&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;"|/usr/lib/mailman/mail/mailman&nbsp;leave&nbsp;mailman"<br />mailman-owner:&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;"|/usr/lib/mailman/mail/mailman&nbsp;owner&nbsp;mailman"<br />mailman-request:&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;"|/usr/lib/mailman/mail/mailman&nbsp;request&nbsp;mailman"<br />mailman-subscribe:&nbsp;&nbsp;&nbsp;&nbsp;"|/usr/lib/mailman/mail/mailman&nbsp;subscribe&nbsp;mailman"<br />mailman-unsubscribe:&nbsp;&nbsp;"|/usr/lib/mailman/mail/mailman&nbsp;unsubscribe&nbsp;mailman"<br /><br />Hit&nbsp;enter&nbsp;to&nbsp;notify&nbsp;mailman&nbsp;owner...</span>&nbsp;<span class="highlight">&lt;--&nbsp;ENTER</span><br /><br /><span class="system">[<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="7e0c11110a3e0d1b0c081b0c4f">[email&#160;protected]</a>&nbsp;tmp]#</span></p>
<p>Open <span class="system">/etc/aliases</span> afterwards...</p>
<pre class="command"><code spellcheck="false">nano /etc/aliases</code></pre>
<p>... and add the following lines:</p>
<pre>[...]
mailman:              "|/usr/lib/mailman/mail/mailman post mailman"
mailman-admin:        "|/usr/lib/mailman/mail/mailman admin mailman"
mailman-bounces:      "|/usr/lib/mailman/mail/mailman bounces mailman"
mailman-confirm:      "|/usr/lib/mailman/mail/mailman confirm mailman"
mailman-join:         "|/usr/lib/mailman/mail/mailman join mailman"
mailman-leave:        "|/usr/lib/mailman/mail/mailman leave mailman"
mailman-owner:        "|/usr/lib/mailman/mail/mailman owner mailman"
mailman-request:      "|/usr/lib/mailman/mail/mailman request mailman"
mailman-subscribe:    "|/usr/lib/mailman/mail/mailman subscribe mailman"
mailman-unsubscribe:  "|/usr/lib/mailman/mail/mailman unsubscribe mailman"</pre>
<p>Run</p>
<pre class="command"><code spellcheck="false">newaliases</code></pre>
<p>afterwards and restart Postfix:</p>
<pre class="command"><code spellcheck="false">systemctl restart postfix.service</code></pre>
<p>Now open the Mailman Apache configuration file <span class="system">/etc/httpd/conf.d/mailman.conf</span>...</p>
<pre class="command"><code spellcheck="false">nano /etc/httpd/conf.d/mailman.conf</code></pre>
<p>... and add the line <span class="system">ScriptAlias /cgi-bin/mailman/ /usr/lib/mailman/cgi-bin/</span>. Comment out <span class="system">Alias /pipermail/ /var/lib/mailman/archives/public/</span> and add the line <span class="system">Alias /pipermail /var/lib/mailman/archives/public/</span>:</p>
<pre>#
#  httpd configuration settings for use with mailman.
#

ScriptAlias /mailman/ /usr/lib/mailman/cgi-bin/
ScriptAlias /cgi-bin/mailman/ /usr/lib/mailman/cgi-bin/
&lt;Directory /usr/lib/mailman/cgi-bin/&gt;
    AllowOverride None
    Options ExecCGI
    Order allow,deny
    Allow from all
&lt;/Directory&gt;


#Alias /pipermail/ /var/lib/mailman/archives/public/
Alias /pipermail /var/lib/mailman/archives/public/
&lt;Directory /var/lib/mailman/archives/public&gt;
    Options Indexes MultiViews FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
    AddDefaultCharset Off
&lt;/Directory&gt;

# Uncomment the following line, to redirect queries to /mailman to the
# listinfo page (recommended).

# RedirectMatch ^/mailman[/]*$ /mailman/listinfo</pre>
<p>Restart Apache:</p>
<pre class="command"><code spellcheck="false">systemctl restart httpd.service</code></pre>
<p>Create the system startup links for Mailman and start it:</p>
<pre class="command"><code spellcheck="false">systemctl enable mailman.service<br />systemctl start mailman.service</code></pre>
<p>After you have installed ISPConfig 3, you can access Mailman as follows:</p>
<p>You can use the alias <span class="system">/cgi-bin/mailman</span> for all Apache vhosts (please note that <span class="highlight">suExec and CGI must be disabled</span> for all vhosts from which you want to access Mailman!), which means you can access the Mailman admin interface for a list at <span class="system">http://&lt;vhost&gt;/cgi-bin/mailman/admin/&lt;listname&gt;</span>, and the web page for users of a mailing list can be found at <span class="system">http://&lt;vhost&gt;/cgi-bin/mailman/listinfo/&lt;listname&gt;</span>.</p>
<p>Under <span class="system">http://&lt;vhost&gt;/pipermail/&lt;listname&gt;</span> you can find the mailing list archives.</p>
<h2 id="-install-roundcube-webmail">21 Install Roundcube webmail</h2>
<p>To install the RoundCube webmail client,&nbsp;download the latest version with wget to the /tmp folder:</p>
<pre class="command"><code spellcheck="false">cd /tmp<br />wget https://github.com/roundcube/roundcubemail/releases/download/1.4.3/roundcubemail-1.4.3-complete.tar.gz</code></pre>
<p>Unpack the tar.gz archive and move the RoundCube source to /usr/share/roundcubemail</p>
<pre class="command"><code spellcheck="false">tar xfz roundcubemail-1.4.3-complete.tar.gz<br />mkdir&nbsp;/usr/share/roundcubemail<br />mv /tmp/roundcubemail-1.4.3/* /usr/share/roundcubemail/<br />chown -R root:root&nbsp;/usr/share/roundcubemail<br />chown apache /usr/share/roundcubemail/temp<br />chown apache /usr/share/roundcubemail/logs</code></pre>
<p>Create a roundcubemail.conf configuration file with nano editor:</p>
<pre class="command"><code spellcheck="false">nano /etc/httpd/conf.d/roundcubemail.conf</code></pre>
<p>And add the following content to that file:</p>
<pre>#
# Round Cube Webmail is a browser-based multilingual IMAP client
#

Alias /roundcubemail /usr/share/roundcubemail<br />Alias /webmail /usr/share/roundcubemail

# Define who can access the Webmail
# You can enlarge permissions once configured

&lt;Directory /usr/share/roundcubemail/&gt;
        Options none
        AllowOverride Limit
        Require all granted
&lt;/Directory&gt;

# Define who can access the installer
# keep this secured once configured

&lt;Directory /usr/share/roundcubemail/installer&gt;
        Options none
        AllowOverride Limit
        Require all granted
&lt;/Directory&gt;


# Those directories should not be viewed by Web clients.
&lt;Directory /usr/share/roundcubemail/bin/&gt;
    Order Allow,Deny
    Deny from all
&lt;/Directory&gt;
&lt;Directory /usr/share/roundcubemail/plugins/enigma/home/&gt;
    Order Allow,Deny
    Deny from all
&lt;/Directory&gt;</pre>
<p>Restart Apache:</p>
<pre class="command"><code spellcheck="false">systemctl restart httpd.service</code></pre>
<p>Now we need a database for RoundCube mail, we will initialize it as follows:</p>
<pre class="command"><code spellcheck="false">mysql -u root -p</code></pre>
<p>At MariaDB prompt use:</p>
<pre class="command"><code spellcheck="false">CREATE DATABASE roundcubedb;<br />CREATE USER <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="493b263c272d2a3c2b2c3c3a2c3b0925262a282521263a3d">[email&#160;protected]</a> IDENTIFIED BY 'roundcubepassword';<br />GRANT ALL PRIVILEGES on roundcubedb.* to <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="ddafb2a8b3b9bea8bfb8a8aeb8af9db1b2bebcb1b5b2aea9">[email&#160;protected]</a> ;<br />FLUSH PRIVILEGES;<br />exit</code></pre>
<p>I am using the details for the&nbsp;RoundCube database as an example, please replace the values as per your choice for security reasons.</p>
<p>Now we will install&nbsp;RoundCube in the browser at <span class="system" style="font-family: monospace;">http://192.168.0.100/roundcubemail/installer</span></p>
<p><a class="fancybox" id="img-roundcubemail" href="https://www.howtoforge.com/images/perfect_server_centos_7_1_x86_64_apache2_dovecot_ispconfig3/big/roundcubemail.png"><img src="https://www.howtoforge.com/images/perfect_server_centos_7_1_x86_64_apache2_dovecot_ispconfig3/roundcubemail.png" /></a></p>
<p>Now&nbsp;create the config.inc.php file:</p>
<pre class="command"><code spellcheck="false">nano <span>/usr/share/roundcubemail/config</span>/config.inc.php</code></pre>
<pre><code spellcheck="false">&lt;?php<br /><br />/* Local configuration for Roundcube Webmail */<br /><br />// ----------------------------------<br />// SQL DATABASE<br />// ----------------------------------<br />// Database connection string (DSN) for read+write operations<br />// Format (compatible with PEAR MDB2): db_provider://user:<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="0d7d6c7e7e7a627f694d65627e79">[email&#160;protected]</a>/database<br />// Currently supported db_providers: mysql, pgsql, sqlite, mssql, sqlsrv, oracle<br />// For examples see http://pear.php.net/manual/en/package.database.mdb2.intro-dsn.php<br />// NOTE: for SQLite use absolute path (Linux): 'sqlite:////full/path/to/sqlite.db?mode=0646'<br />// or (Windows): 'sqlite:///C:/full/path/to/sqlite.db'<br />$config['db_dsnw'] = 'mysql://roundcubeuser:<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="3a48554f545e594f585f4a5b49494d55485e7a5655595b565255494e">[email&#160;protected]</a>/roundcubedb';<br /><br />// ----------------------------------<br />// IMAP<br />// ----------------------------------<br />// The IMAP host chosen to perform the log-in.<br />// Leave blank to show a textbox at login, give a list of hosts<br />// to display a pulldown menu or set one host as string.<br />// To use SSL/TLS connection, enter hostname with prefix ssl:// or tls://<br />// Supported replacement variables:<br />// %n - hostname ($_SERVER['SERVER_NAME'])<br />// %t - hostname without the first part<br />// %d - domain (http hostname $_SERVER['HTTP_HOST'] without the first part)<br />// %s - domain name after the '@' from e-mail address provided at login screen<br />// For example %n = mail.domain.tld, %t = domain.tld<br />// WARNING: After hostname change update of mail_host column in users table is<br />// required to match old user data records with the new host.<br />$config['default_host'] = 'localhost';<br />$config['smtp_server'] = 'localhost';<br />$config['smtp_port'] = 25;<br /><br />// provide an URL where a user can get support for this Roundcube installation<br />// PLEASE DO NOT LINK TO THE ROUNDCUBE.NET WEBSITE HERE!<br />$config['support_url'] = '';<br /><br />// This key is used for encrypting purposes, like storing of imap password<br />// in the session. For historical reasons it's called DES_key, but it's used<br />// with any configured cipher_method (see below).<br />$config['des_key'] = 'pb0UucO0eqjgvhrqYlFTBVjE';<br /><br />// ----------------------------------<br />// PLUGINS<br />// ----------------------------------<br />// List of active plugins (in plugins/ directory)<br />$config['plugins'] = array();<br /><br />// Set the spell checking engine. Possible values:<br />// - 'googie' - the default (also used for connecting to Nox Spell Server, see 'spellcheck_uri' setting)<br />// - 'pspell' - requires the PHP Pspell module and aspell installed<br />// - 'enchant' - requires the PHP Enchant module<br />// - 'atd' - install your own After the Deadline server or check with the people at http://www.afterthedeadline.com before using their API<br />// Since Google shut down their public spell checking service, the default settings<br />// connect to http://spell.roundcube.net which is a hosted service provided by Roundcube.<br />// You can connect to any other googie-compliant service by setting 'spellcheck_uri' accordingly.<br />$config['spellcheck_engine'] = 'pspell';<br /><span>$config['enable_installer'] = true;</span></code></pre>
<p>Then press "continue" in the web installer. On the following page, press on the button "Initialize database".</p>
<p>Finally, disable the Roundecubemail installer. Change the RoundCube config.inc.php configuration file</p>
<pre class="command"><code spellcheck="false"><span>nano&nbsp;</span><span>/usr/share/roundcubemail/config</span><span>/config.inc.php</span></code></pre>
<p><span>and change the line:</span></p>
<pre><code spellcheck="false"><span>$config['enable_installer'] = true;</span></code></pre>
<p><span>to:</span></p>
<pre><code spellcheck="false"><span>$config['enable_installer'] = false;</span></code></pre>
<p>Roundcube is available now under the aliases /webmail and /roundcubemail on your server:</p>
<p><em>http://192.168.0.100/webmail</em></p>
<p><span>The RoundCube login is the email address and password of an email account that you create later in ISPConfig.</span></p>
<h2 id="-install-ispconfig-">22 Install ISPConfig 3.2</h2>
<p>The ISPConfig installer will configure all services like Postfix, Dovecot, etc. for you.</p>
<p>You now also have the possibility to let the installer create an SSL vhost for the ISPConfig control panel&nbsp;so that ISPConfig can be accessed using <span class="system">https://</span> instead of <span class="system">http://</span>. To achieve this, just press <span class="system">ENTER</span> when you see this question: <span class="system">Do you want a secure (SSL) connection to the ISPConfig web interface (y,n) [y]:</span>.</p>
<p>To install ISPConfig 3.2 Beta, do this:</p>
<pre class="command"><code spellcheck="false">cd /tmp <br />wget -O ispconfig.tar.gz http://www.ispconfig.org/downloads/ISPConfig-3.2b2.tar.gz<br />tar xfz <span>ispconfig.tar.gz</span><br />cd ispconfig3*/install/</code></pre>
<p>The next step is to run:</p>
<pre class="command"><code spellcheck="false">php -q install.php</code></pre>
<p>This will start the ISPConfig 3 installer. The installer will configure all services like Postfix, Dovecot, etc. for you.</p>
<pre class="system"><code spellcheck="false">[<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="37455858437744524541524506">[email&#160;protected]</a> install]# php install.php</code></pre>
<pre class="system"><code spellcheck="false"><br />--------------------------------------------------------------------------------<br />_____ ___________ _____ __ _ ____<br />|_ _/ ___| ___ \ / __ \ / _(_) /__ \<br />| | \ `--.| |_/ / | / \/ ___ _ __ | |_ _ __ _ _/ /<br />| | `--. \ __/ | | / _ \| '_ \| _| |/ _` | |_ |<br />_| |_/\__/ / | | \__/\ (_) | | | | | | | (_| | ___\ \<br />\___/\____/\_| \____/\___/|_| |_|_| |_|\__, | \____/<br />__/ |<br />|___/<br />--------------------------------------------------------------------------------</code></pre>
<pre class="system"><code spellcheck="false"><br />&gt;&gt; Initial configuration</code></pre>
<pre class="system"><code spellcheck="false">Operating System: CentOS 8.2</code></pre>
<pre class="system"><code spellcheck="false">Following will be a few questions for primary configuration so be careful.<br />Default values are in [brackets] and can be accepted with &lt;ENTER&gt;.<br />Tap in "quit" (without the quotes) to stop the installer.</code></pre>
<pre class="system"><code spellcheck="false"><br />Select language (en,de) [en]: <span class="highlight">&lt;-- Hit Enter</span></code></pre>
<pre class="system"><code spellcheck="false">Installation mode (standard,expert) [standard]:&nbsp;<span class="highlight">&lt;-- Hit Enter</span></code></pre>
<pre class="system"><code spellcheck="false">Full qualified hostname (FQDN) of the server, eg server1.domain.tld [server1.example.com]:&nbsp;<span class="highlight">&lt;-- Hit Enter</span></code></pre>
<pre class="system"><code spellcheck="false">MySQL server hostname [localhost]:&nbsp;<span class="highlight">&lt;-- Hit Enter</span></code></pre>
<pre class="system"><code spellcheck="false">MySQL server port [3306]:&nbsp;<span class="highlight">&lt;-- Hit Enter</span></code></pre>
<pre class="system"><code spellcheck="false">MySQL root username [root]:&nbsp;<span class="highlight">&lt;-- Hit Enter</span></code></pre>
<pre class="system"><code spellcheck="false">MySQL root password []:&nbsp;<span class="highlight">&lt;-- Ente the MySQL root password here</span></code></pre>
<pre class="system"><code spellcheck="false">MySQL database to create [dbispconfig]:&nbsp;<span class="highlight">&lt;-- Hit Enter</span></code></pre>
<pre class="system"><code spellcheck="false">MySQL charset [utf8]:&nbsp;<span class="highlight">&lt;-- Hit Enter</span></code></pre>
<pre class="system"><code spellcheck="false">Configuring Postgrey<br />Configuring Postfix<br />Generating a 4096 bit RSA private key<br />................................++<br />.....................................................................................................................................................................................................................................................................................................................................................++<br />writing new private key to 'smtpd.key'<br />-----<br />You are about to be asked to enter information that will be incorporated<br />into your certificate request.<br />What you are about to enter is what is called a Distinguished Name or a DN.<br />There are quite a few fields but you can leave some blank<br />For some fields there will be a default value,<br />If you enter '.', the field will be left blank.<br />-----<br />Country Name (2 letter code) [XX]: <span class="highlight">&lt;-- Enter 2 Letter country code, e.g. US</span><br />State or Province Name (full name) []: <span class="highlight">&lt;-- Enter anme of State or Province</span><br />Locality Name (eg, city) [Default City]: <span class="highlight">&lt;-- Name of city</span><br />Organization Name (eg, company) [Default Company Ltd]: <span class="highlight">&lt;-- Company name</span><br />Organizational Unit Name (eg, section) []:&nbsp;<span class="highlight">&lt;-- Hit Enter</span><br />Common Name (eg, your name or your server's hostname) []: <span class="highlight">&lt;-- Enter server hostname here, in my case: server1.example.com</span><br />Email Address []: <span class="highlight">&lt;-- Enter Email address</span><br />Configuring mailman<br />Configuring Dovecot<br />Configuring Spamassassin<br />Configuring Amavisd<br />Configuring Getmail<br />Configuring Jailkit<br />Configuring Pureftpd<br />Configuring BIND<br />Configuring Apache<br />Configuring vlogger<br />[INFO] service OpenVZ not detected<br />Configuring Bastille Firewall<br />[INFO] service Metronome XMPP Server not detected<br />Configuring Fail2ban<br />Configuring Apps vhost<br />Installing ISPConfig<br />ISPConfig Port [8080]:&nbsp;<span class="highlight">&lt;-- Hit Enter</span></code></pre>
<pre class="system"><code spellcheck="false">Admin password [fad579a6]:&nbsp;<span class="highlight">&lt;-- Enter new password for ISPConfig admin user</span></code></pre>
<pre class="system"><code spellcheck="false">Re-enter admin password []:&nbsp;<span class="highlight">&lt;-- Repeat the password</span></code></pre>
<pre class="system"><code spellcheck="false">Do you want a secure (SSL) connection to the ISPConfig web interface (y,n) [y]:&nbsp;<span class="highlight">&lt;-- Hit Enter</span></code></pre>
<pre class="system"><code spellcheck="false">Generating RSA private key, 4096 bit long modulus<br />.................................................................................++<br />.....++<br />e is 65537 (0x10001)<br />You are about to be asked to enter information that will be incorporated<br />into your certificate request.<br />What you are about to enter is what is called a Distinguished Name or a DN.<br />There are quite a few fields but you can leave some blank<br />For some fields there will be a default value,<br />If you enter '.', the field will be left blank.<br />-----<br /><span>Country Name (2 letter code) [XX]:&nbsp;</span><span class="highlight">&lt;-- Enter 2 Letter country code, e.g. US</span><br /><span>State or Province Name (full name) []: </span><span class="highlight">&lt;-- Enter anme of State or Province</span><br /><span>Locality Name (eg, city) [Default City]: </span><span class="highlight">&lt;-- Name of city</span><br /><span>Organization Name (eg, company) [Default Company Ltd]: </span><span class="highlight">&lt;-- Company name</span><br /><span>Organizational Unit Name (eg, section) []:&nbsp;</span><span class="highlight">&lt;-- Hit Enter</span><br /><span>Common Name (eg, your name or your server's hostname) []: </span><span class="highlight">&lt;-- Enter server hostname here, in my case: server1.example.com</span><br /><span>Email Address []: </span><span class="highlight">&lt;-- Enter Email address</span></code></pre>
<pre class="system"><code spellcheck="false">Please enter the following 'extra' attributes<br />to be sent with your certificate request<br />A challenge password []:&nbsp;<span class="highlight">&lt;-- Hit Enter</span><br />An optional company name []:&nbsp;<span class="highlight">&lt;-- Hit Enter</span><br />writing RSA key</code></pre>
<pre class="system"><code spellcheck="false"><br />Configuring DBServer<br />Installing ISPConfig crontab<br />Installing ISPConfig crontab<br />no crontab for root<br />no crontab for getmail<br />Detect IP addresses<br />Restarting services ...<br />Installation completed.</code></pre>
<p>The installer automatically configures all underlying services, so there is no manual configuration needed.</p>
<h2 id="-first-ispconfig-login">23 First ISPConfig Login</h2>
<p>Afterwards you can access ISPConfig 3 under <span class="system">http(s)://server1.example.com:8080/</span> or <span class="system">http(s)://192.168.0.100:8080/</span> (<span class="system">http</span> or <span class="system">https&nbsp;</span>depends on what you chose during installation).</p>
<p>Log in with the username <span class="system">admin</span> and the password <span class="system">admin</span> (you should change the default password after your first login):</p>
<p></p>
<p style="text-align: center;"><a class="fancybox" id="img-ispconfig_3_1_login" href="https://www.howtoforge.com/images/perfect_server_centos_7_2_apache_dovecot_ispconfig/big/ispconfig_3_1_login.png"><img src="https://www.howtoforge.com/images/perfect_server_centos_7_2_apache_dovecot_ispconfig/ispconfig_3_1_login.png" alt="The ISPConfig Login" width="550" height="397" /></a></p>
<p>&nbsp;</p>
<div class="sponsor">
<h3 id="-the-ispconfig-manual">23.1 The ISPConfig 3 Manual</h3>
<p>In order to learn how to use ISPConfig 3, I strongly recommend <a href="http://www.howtoforge.com/download-the-ispconfig-3-manual" target="_blank" mce_real_href="/download-the-ispconfig-3-manual" rel="noopener">downloading the ISPConfig 3 Manual</a>.</p>
<p>On more than 300 pages, it covers the concept behind ISPConfig (admin, resellers, clients), explains how to install and update ISPConfig 3, includes a reference for all forms and form fields in ISPConfig together with examples of valid inputs, and provides tutorials for the most common tasks in ISPConfig 3. It also lines out how to make your server more secure and comes with a troubleshooting section at the end.</p>
<h2 id="download-centos-server-as-virtual-machine">24 Download as&nbsp;a virtual machine</h2>
<p>This setup is available as virtual machine download in ova/ovf format (compatible with VMWare and Virtualbox) for howtoforge subscribers.</p>
<p><strong>Login details for the VM</strong></p>
<ul>
<li>The root password is: howtoforge</li>
<li>The password of the ISPConfig "admin" user is:&nbsp;howtoforge</li>
<li>There is another shell user with the name "howtoforge" and password: howtoforge</li>
</ul>
<p>Please change both passwords on the&nbsp;first login.</p>
<ul>
<li>The IP address of the VM is 192.168.0.100</li>
</ul>
</div>
<h2 id="-links">25 Links</h2>
<ul>
<li>CentOS: <a href="http://www.centos.org/" target="_blank" rel="noopener">http://www.centos.org/</a></li>
<li>ISPConfig: <a href="http://www.ispconfig.org/" target="_blank" rel="noopener">http://www.ispconfig.org/</a></li>
</ul>
</article>

<aside class="authorbox" style="margin-top:20px;">
<img src="/images/profile/till-80.jpg" alt="Till Brehm" /> <p><strong>About Till Brehm</strong></p>
<p>Over 20 years experience as Software Developer and Linux System Administrator. Till Brehm is the founder and lead developer of the ISPConfig Hosting Control Panel software (since 2000) and he founded HowtoForge in 2005 as a place to share Linux knowledge with other Linux enthusiasts.</p>
</aside>

<div style="height:30px; margin-top:20px;">
<p style="text-align:right;"><img src="/images/pdficon_small.png" /> <a class="pdf-btn" href="javascript:void(0);">view as pdf</a> | <img src="/images/print.gif" /> <a class="print-btn" href="javascript:void(0);">print</a></p>
</div>
<div style="height:30px; margin-top:20px;">
<div style="float:left;"><b>Share this page:</b></div>
<p style="text-align:center;">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Ftutorial%2Fperfect-server-centos-8-apache-mysql-php-pureftpd-postfix-dovecot-and-ispconfig%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Ftutorial%2Fperfect-server-centos-8-apache-mysql-php-pureftpd-postfix-dovecot-and-ispconfig%2F&text=The+Perfect+Server+CentOS+8+with+Apache%2C+PHP%2C+Postfix%2C+Dovecot%2C+Pure-FTPD%2C+BIND+and+ISPConfig+3.2+%28Beta%29&via=howtoforgecom&related=howtoforgecom" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.howtoforge.com%2Ftutorial%2Fperfect-server-centos-8-apache-mysql-php-pureftpd-postfix-dovecot-and-ispconfig%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-gplus.png" height="20" /></a>
</p>
</div>
</div>


<div id="htfContentPagePaging">
<h2>Suggested articles</h2>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-3043223216276099" data-ad-slot="8940054090"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>


<div id="htfContentPageComment">
<a name="comments"></a>
<h2>0 Comment(s)</h2>

<div id="commentform">
<div class="commentContainerHead" style="font-size:18px;">Add comment</div>
<div class="commentContainer">
<form method="post" action="/tutorial/perfect-server-centos-8-apache-mysql-php-pureftpd-postfix-dovecot-and-ispconfig/#comments">
<input type="hidden" name="reply_to" id="reply-to-comment" value="0" />
<div id="commentFormDetail">
<div style="width:48%; float:left; margin-right:3%">
<label for="commentname">Name *</label>
<input id="commentname" name="commentname" value="" />
</div>
<div style="width:48%;float:left;">
<label for="commentname">Email *</label>
<input id="commentemail" name="commentemail" value="" />
</div>
<div style="clear:both;"></div>
</div>
<textarea id="commentedit" name="commentedit" style="width:auto;"></textarea>
<div>
<div style="float:left;">
<div class="g-recaptcha" data-sitekey="6LdX9fUSAAAAALWwVoPdeXScMSketz4npF-0QcQ1"></div>
<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en">
      </script>
</div>
<div style="margin-top:10px;margin-bottom:10px;">
<input type="submit" name="submit" class="button primary" style="float:right;" value="Submit comment">
</div>
<div style="clear:both;"></div>
</div>
<script>
	tinymce.init({
		selector: "textarea#commentedit",
		theme: "modern",
		height: 100,
		apply_source_formatting : true,
		remove_linebreaks : false,
		menubar : false,
		/*auto_focus : "commentedit",*/
		plugins: [
		"link"
		],
		/*plugins: [
			"advlist autolink link image lists charmap print preview hr anchor pagebreak spellchecker",
			"searchreplace wordcount visualblocks visualchars code fullscreen insertdatetime media nonbreaking",
			"save table contextmenu directionality emoticons template paste textcolor"
		],*/
		content_css: "https://www.howtoforge.com/themes/howtoforge/css/custom.css",
		toolbar: "undo redo | bold italic link", 
		/*style_formats: [
			{title: 'Bold text', inline: 'b'},
			{title: 'Red text', inline: 'span', styles: {color: '#ff0000'}},
			{title: 'Red header', block: 'h1', styles: {color: '#ff0000'}},
			{title: 'Example 1', inline: 'span', classes: 'example1'},
			{title: 'Example 2', inline: 'span', classes: 'example2'},
			{title: 'Table styles'},
			{title: 'Table row 1', selector: 'tr', classes: 'tablerow1'}
		]*/
	}); 
	</script>
</form>
</div>
</div>

</div>


<div class="breadBoxBottom">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Home</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/tutorial/perfect-server-centos-8-apache-mysql-php-pureftpd-postfix-dovecot-and-ispconfig/" class="crumb" rel="up" itemprop="url"><span itemprop="title">The Perfect Server CentOS 8 with Apache, PHP, Postfix, Dovecot, Pure-FTPD, BIND and ISPConfig 3.2 (Beta)</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
<script>
<!--

$(document).on('click', 'a.reply-to', function(e) {
	e.preventDefault();
	
	var self = $(this);
	var cid = self.attr('data-comment');
	console.log(cid);
	if(!cid) return this;
	
	$('#commentform').insertAfter('#comment' + cid);
	$('#reply-to-comment').val(cid);
	/*tinyMCE.activeEditor.focus();*/
	var textareaId = 'commentedit';
	tinyMCE.get(textareaId).remove();
	tinyMCE.execCommand("mceAddEditor", false, textareaId);
	tinyMCE.activeEditor.focus();
});
//-->
</script>
<div style="margin-top:10px;margin-bottom:10px;text-align:center;">

<center>


<div id='div-gpt-ad-1527185271042-1' style='height:90px; width:728px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-1'); });
</script>
</div>

</center>
</div>


<form action="/community/login/login?redirect=/tutorial/perfect-server-centos-8-apache-mysql-php-pureftpd-postfix-dovecot-and-ispconfig/" method="post" class="xenForm eAuth" id="login" style="display:none">
<ul id="eAuthUnit">
<li><a href="/community/register/facebook?reg=1" class="fbLogin" tabindex="110"><span>Log in with Facebook</span></a></li>
<li><a href="/community/register/twitter?reg=1" class="twitterLogin" tabindex="110"><span>Log in with Twitter</span></a></li>
<li><span class="googleLogin GoogleLogin JsOnly" tabindex="110" data-client-id="198773272284-b6tfk0c28bje81p774prrcrkq9jb3o44.apps.googleusercontent.com" data-redirect-url="/community/register/google?code=__CODE__&amp;csrf=hVMXbW_3rnrmq4Em"><span>Log in with Google</span></span></li>
</ul>
<div class="ctrlWrapper">
<dl class="ctrlUnit">
<dt><label for="LoginControl">Your name or email address:</label></dt>
<dd><input type="text" name="login" id="LoginControl" class="textCtrl" tabindex="101" /></dd>
</dl>
<dl class="ctrlUnit">
<dt>
<label for="ctrl_password">Do you already have an account?</label>
</dt>
<dd>
<ul>
<li><label for="ctrl_not_registered"><input type="radio" name="register" value="1" id="ctrl_not_registered" tabindex="105" />
No, create an account now.</label></li>
<li><label for="ctrl_registered"><input type="radio" name="register" value="0" id="ctrl_registered" tabindex="105" checked="checked" class="Disabler" />
Yes, my password is:</label></li>
<li id="ctrl_registered_Disabler">
<input type="password" name="password" class="textCtrl" id="ctrl_password" tabindex="102" />
<div class="lostPassword"><a href="/community/lost-password/" tabindex="106">Forgot your password?</a></div>
</li>
</ul>
</dd>
</dl>
<dl class="ctrlUnit submitUnit">
<dt></dt>
<dd>
<input type="submit" class="button primary" value="Log in" tabindex="104" data-loginPhrase="Log in" data-signupPhrase="Sign up" />
<label for="ctrl_remember" class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_remember" tabindex="103" /> Stay logged in</label>
</dd>
</dl>
</div>
<input type="hidden" name="cookie_check" value="1" />
<input type="hidden" name="redirect" value="/community/" />
<input type="hidden" name="_xfToken" value="" />
</form>

</div>
</div>

<aside>
<div class="sidebar">
<div class="section loginButton">
<div class="secondaryContent">
<label for="LoginControl" id="SignupButton"><a href="/community/login/" class="inner">Sign up now!</a></label>
</div>
</div>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-2">

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent socialMediaIcon">
<a href="https://twitter.com/howtoforgecom" target="_blank"><img src="/images/socialmedia/64x64/twitter.png" /></a>
<a href="https://www.facebook.com/howtoforge" target="_blank"><img src="/images/socialmedia/64x64/facebook.png" /></a>
<a href="https://news.ycombinator.com/" target="_blank" rel="nofollow"><img src="/images/socialmedia/64x64/hackernews.png" /></a>
<a href="https://www.howtoforge.com/feed" target="_blank"><img src="/images/socialmedia/64x64/rss.png" /></a>
</div>
</div>
</div>
<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Tutorial Info</p>
<div class="pairsJustified">
<dl class="discussionCount">
<dt>Author:</dt>
<dd><a href="/author/till+brehm/" rel="author">Till Brehm</a></dd>
</dl>
<dl class="discussionCount">
<dt>Published:</dt>
<dd>Sep 18, 2020</dd>
</dl>
<dl class="discussionCount">
<dt>Tags:</dt>
<dd><a href='/tutorials/anti-spam%2Fvirus/' rel='tag'>anti-spam/virus</a>, <a href='/tutorials/apache/' rel='tag'>apache</a>, <a href='/tutorials/bind/' rel='tag'>bind</a>, <a href='/tutorials/centos/' rel='tag'>centos</a>, <a href='/tutorials/control+panels/' rel='tag'>control panels</a>, <a href='/tutorials/dns/' rel='tag'>dns</a>, <a href='/tutorials/email/' rel='tag'>email</a>, <a href='/tutorials/ftp/' rel='tag'>ftp</a>, <a href='/tutorials/ispconfig/' rel='tag'>ispconfig</a>, <a href='/tutorials/linux/' rel='tag'>linux</a>, <a href='/tutorials/mysql/' rel='tag'>mysql</a>, <a href='/tutorials/php/' rel='tag'>php</a>, <a href='/tutorials/postfix/' rel='tag'>postfix</a>, <a href='/tutorials/web+server/' rel='tag'>web server</a></dd>
</dl>
</div>
</div>
</div>
<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">VMware image download</p>
<div class="pairsJustified">
<img class="rtimg" src="/images/star_vmware_image_red.png" alt="VMWare Image Download" />
<p style="font-weight:bold;">The Perfect Server CentOS 8 with Apache, PHP, Postfix, Dovecot, Pure-FTPD, BIND and ISPConfig 3.2 (Beta) as ready to use virtual machine image download in ovf/ova format, compatible with VMWare and Virtualbox.</p>
<p>&nbsp;</p>
<dl class="discussionCount">
<dt>Download:</dt>
<dd><a href="/subscription/">CentOS-8-2-perfect-server-apache.ova</dd>
</dl>
<dl class="discussionCount">
<dt>Guide:</dt>
<dd><a href="/import_vmware_images/">VMWare Image Import Guide.</dd>
</dl>
<dl class="discussionCount">
<dt>Other Downloads:</dt>
<dd><a href="/list-of-downloadable-vmware-images/">List of all VMWare Images</a></dd>
</dl>
</div>
</div>
</div>

<div id="sponsor-banner">
</div>

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent">
<p class="mnuinfo mnushare">Share This Page</p>
<p style="text-align:center;">
<a href="javascript:window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Ftutorial%2Fperfect-server-centos-8-apache-mysql-php-pureftpd-postfix-dovecot-and-ispconfig%2F', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="javascript:window.open('https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Ftutorial%2Fperfect-server-centos-8-apache-mysql-php-pureftpd-postfix-dovecot-and-ispconfig%2F&text=The+Perfect+Server+CentOS+8+with+Apache%2C+PHP%2C+Postfix%2C+Dovecot%2C+Pure-FTPD%2C+BIND+and+ISPConfig+3.2+%28Beta%29&via=howtoforgecom&related=howtoforgecom', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="javascript:window.open('https://news.ycombinator.com/submitlink?t=The+Perfect+Server+CentOS+8+with+Apache%2C+PHP%2C+Postfix%2C+Dovecot%2C+Pure-FTPD%2C+BIND+and+ISPConfig+3.2+%28Beta%29&u=https%3A%2F%2Fwww.howtoforge.com%2Ftutorial%2Fperfect-server-centos-8-apache-mysql-php-pureftpd-postfix-dovecot-and-ispconfig%2F', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-hackernews.png" height="20" /></a>
</p>
<p style="color:#EE; font-weight:bold; text-align:center; margin-top:5px;">40.2k Followers</p>
</div>
</div>
</div>


<script type="text/javascript">
    google_ad_client = "ca-pub-3043223216276099";
    google_ad_slot = "6709042890";
    google_ad_width = 300;
    google_ad_height = 600;
</script>

<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>


<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Popular Tutorials</p>
<div class="pairsJustified">
<ul>
<li><a href="/tutorial/linux-grep-command/">How to use grep to search for strings in files on the shell</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-setup-librenms-monitoring-tool-with-nginx-on-ubuntu-2004/">How to Setup LibreNMS Monitoring Tool with Nginx on Ubuntu 20.04</a></li>
<li><hr /></li>
<li><a href="/tutorial/perfect-server-ubuntu-20.04-with-apache-php-myqsl-pureftpd-bind-postfix-doveot-and-ispconfig/">The Perfect Server - Ubuntu 20.04 with Apache, PHP, MariaDB, PureFTPD, BIND, Postfix, Dovecot and ISPConfig 3.2 (Beta)</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-use-ftp-on-the-linux-shell/">How to use the Linux ftp command to up- and download files on the shell</a></li>
<li><hr /></li>
<li><a href="/tutorial/perfect-server-ubuntu-18.04-with-apache-php-myqsl-pureftpd-bind-postfix-doveot-and-ispconfig/">The Perfect Server - Ubuntu 18.04 (Bionic Beaver) with Apache, PHP, MySQL, PureFTPD, BIND, Postfix, Dovecot and ISPConfig 3.1</a></li>
<li><hr /></li>
<li><a href="/faq/how-to-edit-files-on-the-command-line">How do I edit files on the command line?</a></li>
<li><hr /></li>
<li><a href="/tutorial/linux-search-files-from-the-terminal/">How to search files from the Terminal on Linux</a></li>
<li><hr /></li>
<li><a href="/install-plex-media-server-on-ubuntu-2004/">Install Plex Media Server on Ubuntu 20.04</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-setup-zsh-and-oh-my-zsh-on-linux/">How to Setup ZSH and Oh-my-zsh on Linux</a></li>
<li><hr /></li>
 <li><a href="/vim-basics">Vim Editor Basics</a></li>
<li><hr /></li>
</ul>
</div>
</div>
</div>
</div>
</div>
</aside>
</div>
</div>
</div>
<footer>
<div class="footer">
<div class="pageWidth">
<div class="pageContent">
<div class='skin_branding'><span>Xenforo skin by <a href="http://www.xenfocus.com" rel="nofollow">Xenfocus</a></span></div>
<ul class="footerLinks">
<li><a href="/contribute/">Contribute</a></li>
<li><a href="/community/misc/contact">Contact</a></li>
<li><a href="/community/help/">Help</a></li>
<li><a href="/imprint/">Imprint and Legal Notice</a></li>
<li><a href="#navigation" class="topLink">Top</a></li>
<li><a href="/feed" rel="alternate" class="globalFeed" target="_blank" title="RSS-Feed for Howtoforge">RSS-Feed</a></li>
</ul>
<span class="helper"></span>
</div>
</div>
</div>
<div class="footerLegal">
<div class="pageWidth">
<div class="pageContent">
<ul id="legal">
<li><a href="/community/help/terms">Terms and Rules</a> <a href="https://www.howtoforge.com/community/help/privacy-policy">Privacy Policy</a></li>
</ul>
<div id="copyright"><a href="https://www.howtoforge.com" class="concealed">Howtoforge <span>&copy; projektfarm GmbH.</span></a></div>
<span class="helper"></span>
</div>
</div>
</div>
</footer>
<div style="height:100px;"></div>

<div id="subscriptionModal" class="modal">
<div class="modal-content">
<span class="close">&times;</span>
<p>This feature is only available to subscribers. Get your subscription <a href="/subscription">here</a>.</p>
</div>
</div>
<script>
//* Modal
var modal = document.getElementById('subscriptionModal');
var span = document.getElementsByClassName("close")[0];
$(".pdf-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
$(".print-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
span.onclick = function() {
	$("#subscriptionModal").css('display', 'none');
}
window.onclick = function(event) {
    if (event.target == modal) {
		$("#subscriptionModal").css('display', 'none');
    }
}
//* Xenforo
jQuery.extend(true, XenForo,
{
	visitor: { user_id: 0 },
	serverTimeInfo:
	{
		now: 1409831907,
		today: 1409781600,
		todayDow: 4
	},
	_lightBoxUniversal: "0",
	_enableOverlays: "1",
	_animationSpeedMultiplier: "1",
	_overlayConfig:
	{
		top: "10%",
		speed: 200,
		closeSpeed: 100,
		mask:
		{
			color: "rgb(0, 0, 0)",
			opacity: "0.6",
			loadSpeed: 200,
			closeSpeed: 100
		}
	},
	_ignoredUsers: [],
	_loadedScripts: {"node_list":true,"node_category":true,"node_forum":true,"sidebar_share_page":true,"wf_default":true,"bbm_buttons":true,"login_bar":true,"twitter":true},
	_cookieConfig: { path: "/", domain: "", prefix: "xf_"},
	_csrfToken: "",
	_csrfRefreshUrl: "/community/login/csrf-token-refresh",
	_jsVersion: "303ae0ca"
});
jQuery.extend(XenForo.phrases,
{
	cancel: "Cancel",

	a_moment_ago:    "A moment ago",
	one_minute_ago:  "1 minute ago",
	x_minutes_ago:   "%minutes% minutes ago",
	today_at_x:      "Today at %time%",
	yesterday_at_x:  "Yesterday at %time%",
	day_x_at_time_y: "%day% at %time%",

	day0: "Sunday",
	day1: "Monday",
	day2: "Tuesday",
	day3: "Wednesday",
	day4: "Thursday",
	day5: "Friday",
	day6: "Saturday",

	_months: "January,February,March,April,May,June,July,August,September,October,November,December",
	_daysShort: "Sun,Mon,Tue,Wed,Thu,Fri,Sat",

	following_error_occurred: "The following error occurred",
	server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
	logging_in: "Logging in",
	click_image_show_full_size_version: "Click this image to show the full-size version.",
	show_hidden_content_by_x: "Show hidden content by {names}"
});

// Facebook Javascript SDK
XenForo.Facebook.appId = "";
XenForo.Facebook.forceInit = true;

/*
document.addEventListener('DOMContentLoaded', function(event) {
  cookieChoices.showCookieConsentBar('Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.',
  'OK');
});
*/

$(document).ready(function() {
	$("a.fancybox").fancybox();
});

</script>

<script>
_bsa.init('custom', 'CKYD55QU', 'placement:howtoforge',
    {
      target: '#sponsor-banner',
      template: `
<a href="##link##" style="background: linear-gradient(-330deg, ##backgroundColor##D9, ##backgroundColor##D9 30%, ##backgroundColor## 70%) #fff;" class="native-banner">
<img class="native-img" src="##logo##">
<div style="color: ##textColor##" class="native-tagline">##tagline##</div>
<div style="color: ##textColor##" class="native-desc">##description##</div>
<div style="color: ##ctaTextColor##; background-color: ##ctaBackgroundColor##;" class="native-cta">##callToAction##</div>
<div style="background-color: ##textColor##B2; color: ##backgroundColor##" class="native-ad">Ad</div>
</a>
`
    }
  );
</script>

<script>
(function() {
  if (typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('fancybar', 'CKYDL27E', 'placement:howtoforgecom');
  }
})();
</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2155872-1', 'auto');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');

</script>
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=2&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=2&shcb=34', false, [], true, false, false, false);
</script>
<script>var _audins_dom="howtoforge_com",_audins_did=178704;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=191-2");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.howtoforge_com,DomainId.178704" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript' data-cfasync='false'></script></body>
</html>