<!DOCTYPE html>
<html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs LoggedOut Sidebar Responsive" xmlns:fb="http://www.facebook.com/2008/fbml">
<head><meta charset="utf-8" />
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">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</script>
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<base href="https://www.howtoforge.com" />
<script>
			var _b = document.getElementsByTagName('base')[0], _bH = "https://www.howtoforge.com/how-to-install-and-use-mongodb-on-ubuntu-2004/";
			if (_b && _b.href != _bH) _b.href = _bH;
		</script>
<title>How to Install and Use MongoDB on Ubuntu 20.04</title>
<meta name="description" content="MongoDB is an open-source and cross-platform document-oriented database system written in C++. It stores data in collections of JSON-like, flexible do... " />
<meta property="og:title" content="How to Install and Use MongoDB on Ubuntu 20.04">
<meta property="og:description" content="MongoDB is an open-source and cross-platform document-oriented database system written in C++. It stores data in collections of JSON-like, flexible do... ">
<meta property="og:site_name" content="HowtoForge">
<meta property="og:type" content="article">
<meta property="og:image" content="https://www.howtoforge.com/images/featured/ubuntu-mongodb1.jpg">
<meta property="og:image:secure_url" content="https://www.howtoforge.com/images/featured/ubuntu-mongodb1.jpg" />
<meta property="og:image:alt" content="How to Install and Use MongoDB on Ubuntu 20.04" />
<meta name="twitter:image" content="https://www.howtoforge.com/images/featured/ubuntu-mongodb1.jpg" />
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="@howtoforgecom">
<meta name="twitter:creator" content="@howtoforgecom">
<meta name="twitter:title" content="How to Install and Use MongoDB on Ubuntu 20.04">
<meta name="twitter:description" content="MongoDB is an open-source and cross-platform document-oriented database system written in C++. It stores data in collections of JSON-like, flexible do... ">
<link rel="alternate" href="https://www.howtoforge.com/how-to-install-and-use-mongodb-on-ubuntu-2004/" hreflang="en" />
<link rel="canonical" href="https://www.howtoforge.com/how-to-install-and-use-mongodb-on-ubuntu-2004/" />
<link rel="amphtml" href="https://www.howtoforge.com/how-to-install-and-use-mongodb-on-ubuntu-2004/amp/" />
<script type="application/ld+json">
{
  "@context" : "http://schema.org",
  "@type" : "Article",
  "name" : "How to Install and Use MongoDB on Ubuntu 20.04",
  "author" : {
    "@type" : "Person",
    "name" : "Hitesh Jethva"
  },
  "articleSection" : "linux,server,ubuntu",
  "url" : "https://www.howtoforge.com/how-to-install-and-use-mongodb-on-ubuntu-2004/",
  "publisher" : {
    "@type" : "Organization",
    "name" : "Howtoforge"
  }
}
</script>
<noscript><style>.JsOnly, .jsOnly { display: none !important; }</style></noscript>
<link rel="stylesheet" href="/community/styles/executive/xenfocus/icons/css/font-awesome.min.css" />
<link href='//fonts.googleapis.com/css?family=Open+Sans:400,700' rel='stylesheet' type='text/css' />
<link href="/themes/howtoforge/templates/xf.css" rel="stylesheet">
<script src="/js/jquery/jquery-1.11.3.min.js"></script>
<script src="/community/js/xenforo/xenforo.js?_v=303ae0ca"></script>
<script src="/community/js/bbm/zloader.js?_v=303ae0ca"></script>
<script type="text/javascript" src="/js/fancybox/jquery.mousewheel-3.0.4.pack.js"></script>
<script type="text/javascript" src="/js/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
<link rel="stylesheet" type="text/css" href="/js/fancybox/jquery.fancybox-1.3.4.css" media="screen" />
<link href="/themes/howtoforge/templates/style.min.css" rel="stylesheet">
<link rel="alternate" type="application/rss+xml" title="RSS-Feed für Howtoforge" href="/feed.rss" />
<script src="/js/tinymce_4.1.7/tinymce.min.js"></script>
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/skin.min.css" as="style" />
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/content.min.css" as="style" />
<link rel="preload" href="/themes/howtoforge/css/custom.css" as="style" />
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/fonts/tinymce.woff" as="font">

<script type="text/javascript">
var gaProperty = 'UA-2155872-1';
var disableStr = 'ga-disable-' + gaProperty;
if (document.cookie.indexOf(disableStr + '=true') > -1) {
window[disableStr] = true;
}
function gaOptout() {
document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
window[disableStr] = true;
alert('Google Ananlyitics tracking has been disabled in this browser.');
}
</script>
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
	googletag.defineSlot('/1030080/howtoforge_com_list_sidebar_top', [300, 250], 'div-gpt-ad-1527185271042-4').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_list_content_middle', [[300, 250], [336, 280]], 'div-gpt-ad-1527185271042-5').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_a_300x250', [300, 250], 'div-gpt-ad-1527185271042-6').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_b_300x250', [300, 250], 'div-gpt-ad-1527185271042-7').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_leaderboard_b_728x90', [728, 90], 'div-gpt-ad-1527185271042-1').addService(googletag.pubads());
	googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-3043223216276099",
          enable_page_level_ads: true
     });
</script>


<script src="//m.servedby-buysellads.com/monetization.js" type="text/javascript"></script>


<script type="text/javascript">
    window.cookieconsent_options = {"message":"This website uses cookies to ensure you get the best experience on our website, analyze site traffic and show you relevant ads.","dismiss":"Got it!","learnMore":"More info","link":"https://www.howtoforge.com/community/help/cookies","theme":"dark-bottom"};
</script>
<script type="text/javascript" src="/js/cookieconsent.latest.min.js"></script>

<script data-ezscrex="false" data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-158818458-34";</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['e._setAccount', 'UA-158818458-34']);
_gaq.push(['f._setAccount', 'UA-38339005-1']);
_gaq.push(['e._setDomainName', 'howtoforge.com']);
_gaq.push(['f._setDomainName', 'howtoforge.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod33-c',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','howtoforge.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script>
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 178704;
var ezdomain = 'howtoforge.com';
var ezoicSearchable = 1;
</script>


<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":178704,"engaged_time_visit":0,"ezcache_level":1,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"239b7ec6-1c41-4843-41cf-e37f746f40bd","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":1290,"serverid":"54.172.156.196:23750","state":"VA","t_epoch":1590030350,"template_id":126,"time_on_site_visit":0,"url":"https://www.howtoforge.com/how-to-install-and-use-mongodb-on-ubuntu-2004/","user_id":0,"word_count":1168,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=188-0&v=8" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl() {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_178704=" + new Date().getTime() + "|239b7ec6-1c41-4843-41cf-e37f746f40bd|false; " + expires, 3);
}
function attach_ezolpl() {
    if(window.attachEvent) {
        window.attachEvent('onload', create_ezolpl);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl();
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl;
        }
    }
}
attach_ezolpl();
</script></head>
<body>
<div id="loginBar">
<div class="pageWidth">
<div class="pageContent">
<h3 id="loginBarHandle">
<label for="LoginControl"><a href="/community/login/" class="concealed noOutline">Log in or Sign up</a></label>
</h3>
<span class="helper"></span>
</div>
</div>
</div>
<header>
<div id="header">
<div id="logoBlock">
<div class="pageWidth">
<div class="pageContent">
<div id="logo"><a href="/">
<span></span>
<img src="/images/howtoforge_logo_trans.gif" alt="Howtoforge" style="margin-left:20px;" />
</a></div>
<span class="helper"></span>
</div>
</div>
</div>
<div id="navigation" class="pageWidth withSearch">
<div class="pageContent">
<nav>
<div class="navTabs">
<ul class="publicTabs">

<li class="navTab forums selected">
<a href="/" class="navLink">Tutorials</a>
<div class="tabLinks forumsTabLinks">
<ul class="secondaryContent blockLinksList">
<li><a href="/search/">Tutorial search</a></li>
</ul>
</div>
</li>
<li class="navTab forums PopupClosed">
<a href="/tutorials/" class="navLink">Tags</a>
</li>
<li class="navTab forums PopupClosed"><a href="/community/" class="navLink">Forums</a></li>
<li class="navTab forums PopupClosed"><a href="/linux-commands/" class="navLink">Linux Commands</a></li>
<li class="navTab forums PopupClosed"><a href="/subscription/" class="navLink">Subscribe</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.ispconfig.org" class="navLink">ISPConfig</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.lxer.com" class="navLink">News</a></li>
</ul>
</div>
<span class="helper"></span>
</nav>
</div>
</div>
<div id="searchBar" class="pageWidth">
<span id="QuickSearchPlaceholder" title=" Search..."> Search</span>
<fieldset id="QuickSearch">
<form action="/" method="post" class="formPopup">
<div class="primaryControls">

<input type="search" name="q" value="" class="textCtrl" placeholder="Search..." results="0" title="Enter your search and hit enter..." id="QuickSearchQuery" />

</div>
<input type="hidden" name="_xfToken" value="" />
</form>
</fieldset>
</div>
</div>
</header>
<div id="content" class="forum_list">
<div class="pageWidth">
<div class="pageContent">

<div class="mainContainer">
<div class="mainContent">

<div class="breadBoxTop">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Home</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/how-to-install-and-use-mongodb-on-ubuntu-2004/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to Install and Use MongoDB on Ubuntu 20.04</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>

<div id="htfContentPage">
<div class="bsa-apiads"><a href="//srv.buysellads.com/ads/click/x/GTND42Q7CTYDTKQ7CV74YKQMFTAIE53LC6BD6Z3JCWADL53NCK7IE5QKC6BILK3ECKYDTK3EHJNCLSIZ" target="_blank" rel="nofollow">Shop great gifts for grads and perfect presents for dads in HP's Grads and Dads Gift Guide!</a></div>
<article>
<h1>How to Install and Use MongoDB on Ubuntu 20.04</h1>
<div class="contributeEdit" style="float:right; width:450px; max-width:100%;">
<div id="tocContainer">
<h3>This tutorial exists for these OS versions</h3>
<ul><li><strong>Ubuntu 20.04 (Focal Fossa)</strong></li><li><a href="/tutorial/install-mongodb-on-ubuntu-18.04/">Ubuntu 18.04 (Bionic Beaver)</a></li><li><a href="/tutorial/install-mongodb-on-ubuntu-16.04/">Ubuntu 16.04 (Xenial Xerus)</a></li><li><a href="/tutorial/install-mongodb-on-ubuntu-14.04/">Ubuntu 14.04 LTS (Trusty Tahr)</a></li></ul> <h3>On this page</h3>
<ol class="toc">
<li><a href="#prerequisites">Prerequisites</a></li>
<li><a href="#install-mongodb">Install MongoDB</a></li>
<li><a href="#configure-mongodb">Configure MongoDB</a></li>
<li><a href="#create-mongodb-admin-user">Create MongoDB Admin User</a></li>
<li><a href="#verify-mongodb-authentication">Verify MongoDB Authentication</a></li>
<li><a href="#conclusion">Conclusion</a></li>
</ol>
</div>
</div>
<p style="text-align: justify;">MongoDB is an open-source and cross-platform document-oriented database system written in C++. It stores data in collections of JSON-like, flexible documents and used to create powerful websites and applications. Due to its scalability and high performance, it is used for building modern applications that require powerful, mission-critical and high-availability databases.</p>
<p>In this tutorial, we will explain how to install and use MongoDB database system on Ubuntu 20.04 server.</p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;">

<div id='div-gpt-ad-1527185271042-6' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-6'); });
</script>
</div>
</div>
<h2 id="prerequisites">Prerequisites</h2>
<ul>
<li>A server running Ubuntu 20.04.</li>
<li>A root password is configured on your server.</li>
</ul>
<h2 id="install-mongodb">Install MongoDB</h2>
<p>By default, the latest version of MongoDB is not available in the Ubuntu 20.04 default repository. So you will need to add the official MongoDB repository in your system.</p>
<p>First, install Gnupg package with the following command:</p>
<pre class="command"><code spellcheck="false">apt-get install gnupg -y</code></pre>
<p>Next, download and add the MongoDB GPG key with the following command:</p>
<pre class="command"><code spellcheck="false">wget -qO - https://www.mongodb.org/static/pgp/server-4.2.asc | apt-key add -</code></pre>
<p>Next, add the MongoDB repository with the following command:</p>
<pre class="command"><code spellcheck="false">echo "deb [ arch=amd64,arm64 ] https://repo.mongodb.org/apt/ubuntu bionic/mongodb-org/4.2 multiverse" | tee /etc/apt/sources.list.d/mongodb-org-4.2.list</code></pre>
<p>Next, update the repository and install the MongoDB with the following command:</p>
<pre class="command"><code spellcheck="false">apt-get update -y<br />apt-get install mongodb-org -y</code></pre>
<p>Once the installation has been completed, start the MongoDB service and enable it to start at reboot with the following command:</p>
<pre class="command"><code spellcheck="false">systemctl start mongod<br />systemctl enable mongod</code></pre>
<p>You can now check the status of the MongoDB service with the following command:</p>
<pre class="command"><code spellcheck="false">systemctl status mongod</code></pre>
<p>You should get the following output:</p>
<pre>? mongod.service - MongoDB Database Server
     Loaded: loaded (/lib/systemd/system/mongod.service; enabled; vendor preset: enabled)
     Active: active (running) since Fri 2020-05-15 05:30:39 UTC; 18s ago
       Docs: https://docs.mongodb.org/manual
   Main PID: 106996 (mongod)
     Memory: 76.0M
     CGroup: /system.slice/mongod.service
             ??106996 /usr/bin/mongod --config /etc/mongod.conf

May 15 05:30:39 ubuntu2004 systemd[1]: Started MongoDB Database Server.
May 15 05:30:48 ubuntu2004 systemd[1]: /lib/systemd/system/mongod.service:11: PIDFile= references a path below legacy directory /var/run/, upd&gt;
lines 1-11/11 (END)
</pre>
<p>You can also verify the MongoDB version and the server address using the following command:</p>
<pre class="command"><code spellcheck="false">mongo --eval 'db.runCommand({ connectionStatus: 1 })'</code></pre>
<p>You should get the following output:</p>
<pre>MongoDB shell version v4.2.6
connecting to: mongodb://127.0.0.1:27017/?compressors=disabled&amp;gssapiServiceName=mongodb
Implicit session: session { "id" : UUID("e1575445-f441-4b30-a5d7-4cf68852e68f") }
MongoDB server version: 4.2.6
{
	"authInfo" : {
		"authenticatedUsers" : [ ],
		"authenticatedUserRoles" : [ ]
	},
	"ok" : 1  
}
</pre>
<h2 id="configure-mongodb">Configure MongoDB</h2>
<p>MongoDB default configuration file is located at /etc/mongod.conf. By default, each user will have access to all databases and perform any action. For production environments, it is recommended to enable the MongoDB authentication.</p>
<p>You can do it by editing the file /etc/mongod.conf:</p>
<pre class="command"><code spellcheck="false">nano /etc/mongod.conf</code></pre>
<p>Add the following lines:</p>
<pre>security:
  authorization: enabled
</pre>
<p>Save and close the file then restart the MongoDB service to apply the changes:</p>
<pre class="command"><code spellcheck="false">systemctl restart mongod</code></pre>
<h2 id="create-mongodb-admin-user">Create MongoDB Admin User</h2>
<p>After enabling the MongoDB authentication, you will need to create an admin user to access and manage the MongoDB database.</p>
<p>First, access the MongoDB console with the following command:</p>
<pre class="command"><code spellcheck="false">mongo</code></pre>
<p>You should see the following output:</p>
<pre>MongoDB shell version v4.2.6
connecting to: mongodb://127.0.0.1:27017/?compressors=disabled&amp;gssapiServiceName=mongodb
Implicit session: session { "id" : UUID("9ee0ea0c-cf95-4b83-9e88-00dc3a61e0a6") }
MongoDB server version: 4.2.6
Welcome to the MongoDB shell.
For interactive help, type "help".
For more comprehensive documentation, see
	http://docs.mongodb.org/
Questions? Try the support group
	http://groups.google.com/group/mongodb-user
</pre>
<p>Next, connect to the admin database with the following command:</p>
<pre class="command"><code spellcheck="false">&gt; use admin</code></pre>
<p>You should see the following output:</p>
<pre>switched to db admin
</pre>
<p>Next, create a new admin user and set the password with the following command:</p>
<pre class="command"><code spellcheck="false">&gt; db.createUser( { user: "admin", pwd: "password", roles: [ { role: "userAdminAnyDatabase", db: "admin" } ] } )</code></pre>
<p>You should get the following output:</p>
<pre>Successfully added user: {
	"user" : "admin",
	"roles" : [
		{
			"role" : "userAdminAnyDatabase",
			"db" : "admin"
		}
	]
}
</pre>
<p>Next, exit from the MongoDB console with the following command:</p>
<pre class="command"><code spellcheck="false">&gt; quit()</code></pre>
<h2 id="verify-mongodb-authentication">Verify MongoDB Authentication</h2>
<p>At this point, the MongoDB is configured with authentication.</p>
<p>Now, try to connect to MongoDB using the user which you have created earlier:</p>
<pre class="command"><code spellcheck="false">mongo -u admin -p --authenticationDatabase admin</code></pre>
<p>You will be asked to provide the password as shown below:</p>
<pre>MongoDB shell version v4.2.6
Enter password: 
</pre>
<p>Provide your admin password and hit Enter. You should see the following output:</p>
<pre>connecting to: mongodb://127.0.0.1:27017/?authSource=admin&amp;compressors=disabled&amp;gssapiServiceName=mongodb
Implicit session: session { "id" : UUID("00d6d1eb-d1c3-41ea-89c7-d46ec6d17bee") }
MongoDB server version: 4.2.6
</pre>
<p>Now, change the database to admin with the following command:</p>
<pre class="command"><code spellcheck="false">&gt; use admin</code></pre>
<p>You should see the following output:</p>
<pre>switched to db admin
</pre>
<p>Now, list the users with the following command:</p>
<pre class="command"><code spellcheck="false">&gt; show users</code></pre>
<p>You should get the following output:</p>
<pre>{
	"_id" : "admin.admin",
	"userId" : UUID("65907484-9d67-4e6e-bb88-a6666310e963"),
	"user" : "admin",
	"db" : "admin",
	"roles" : [
		{
			"role" : "userAdminAnyDatabase",
			"db" : "admin"
		}
	],
	"mechanisms" : [
		"SCRAM-SHA-1",
		"SCRAM-SHA-256"
	]
}
&gt; 
</pre>
<h2 id="conclusion">Conclusion</h2>
<p>In the above guide, you learned how to install and configure MongoDB on Ubuntu 20.04 server. For more information, you can visit the MongoDB documentation at <a href="https://docs.mongodb.com/manual/">Mongo Doc</a>.</p>
</article>

<aside class="authorbox" style="margin-top:20px;">
<img src="/images/profile/hitesh-80.jpg" alt="Hitesh Jethva" /> <p><strong>About Hitesh Jethva</strong></p>
<p>Over 8 years of experience as a Linux system administrator. My skills include a depth knowledge of Redhat/Centos, Ubuntu Nginx and Apache, Mysql, Subversion, Linux, Ubuntu, web hosting, web server, Squid proxy, NFS, FTP, DNS, Samba, LDAP, OpenVPN, Haproxy, Amazon web services, WHMCS, OpenStack Cloud, Postfix Mail Server, Security etc.</p>
</aside>

<div style="height:30px; margin-top:20px;">
<p style="text-align:right;"><img src="/images/pdficon_small.png" /> <a class="pdf-btn" href="javascript:void(0);">view as pdf</a> | <img src="/images/print.gif" /> <a class="print-btn" href="javascript:void(0);">print</a></p>
</div>
<div style="height:30px; margin-top:20px;">
<div style="float:left;"><b>Share this page:</b></div>
<p style="text-align:center;">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-and-use-mongodb-on-ubuntu-2004%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-and-use-mongodb-on-ubuntu-2004%2F&text=How+to+Install+and+Use+MongoDB+on+Ubuntu+20.04&via=howtoforgecom&related=howtoforgecom" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-and-use-mongodb-on-ubuntu-2004%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-gplus.png" height="20" /></a>
</p>
</div>
</div>


<div id="htfContentPagePaging">
<h2>Suggested articles</h2>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-3043223216276099" data-ad-slot="8940054090"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>


<div id="htfContentPageComment">
<a name="comments"></a>
<h2>0 Comment(s)</h2>

<div id="commentform">
<div class="commentContainerHead" style="font-size:18px;">Add comment</div>
<div class="commentContainer">
<form method="post" action="/how-to-install-and-use-mongodb-on-ubuntu-2004/#comments">
<input type="hidden" name="reply_to" id="reply-to-comment" value="0" />
<div id="commentFormDetail">
<div style="width:48%; float:left; margin-right:3%">
<label for="commentname">Name *</label>
<input id="commentname" name="commentname" value="" />
</div>
<div style="width:48%;float:left;">
<label for="commentname">Email *</label>
<input id="commentemail" name="commentemail" value="" />
</div>
<div style="clear:both;"></div>
</div>
<textarea id="commentedit" name="commentedit" style="width:auto;"></textarea>
<div>
<div style="float:left;">
<div class="g-recaptcha" data-sitekey="6LdX9fUSAAAAALWwVoPdeXScMSketz4npF-0QcQ1"></div>
<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en">
      </script>
</div>
<div style="margin-top:10px;margin-bottom:10px;">
<input type="submit" name="submit" class="button primary" style="float:right;" value="Submit comment">
</div>
<div style="clear:both;"></div>
</div>
<script>
	tinymce.init({
		selector: "textarea#commentedit",
		theme: "modern",
		height: 100,
		apply_source_formatting : true,
		remove_linebreaks : false,
		menubar : false,
		/*auto_focus : "commentedit",*/
		plugins: [
		"link"
		],
		/*plugins: [
			"advlist autolink link image lists charmap print preview hr anchor pagebreak spellchecker",
			"searchreplace wordcount visualblocks visualchars code fullscreen insertdatetime media nonbreaking",
			"save table contextmenu directionality emoticons template paste textcolor"
		],*/
		content_css: "https://www.howtoforge.com/themes/howtoforge/css/custom.css",
		toolbar: "undo redo | bold italic link", 
		/*style_formats: [
			{title: 'Bold text', inline: 'b'},
			{title: 'Red text', inline: 'span', styles: {color: '#ff0000'}},
			{title: 'Red header', block: 'h1', styles: {color: '#ff0000'}},
			{title: 'Example 1', inline: 'span', classes: 'example1'},
			{title: 'Example 2', inline: 'span', classes: 'example2'},
			{title: 'Table styles'},
			{title: 'Table row 1', selector: 'tr', classes: 'tablerow1'}
		]*/
	}); 
	</script>
</form>
</div>
</div>

</div>

<div class="breadBoxBottom">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Home</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/how-to-install-and-use-mongodb-on-ubuntu-2004/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to Install and Use MongoDB on Ubuntu 20.04</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
<script>
<!--

$(document).on('click', 'a.reply-to', function(e) {
	e.preventDefault();
	
	var self = $(this);
	var cid = self.attr('data-comment');
	console.log(cid);
	if(!cid) return this;
	
	$('#commentform').insertAfter('#comment' + cid);
	$('#reply-to-comment').val(cid);
	/*tinyMCE.activeEditor.focus();*/
	var textareaId = 'commentedit';
	tinyMCE.get(textareaId).remove();
	tinyMCE.execCommand("mceAddEditor", false, textareaId);
	tinyMCE.activeEditor.focus();
});
//-->
</script>
<div style="margin-top:10px;margin-bottom:10px;text-align:center;">

<center>


<div id='div-gpt-ad-1527185271042-1' style='height:90px; width:728px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-1'); });
</script>
</div>

</center>
</div>


<form action="/community/login/login?redirect=/how-to-install-and-use-mongodb-on-ubuntu-2004/" method="post" class="xenForm eAuth" id="login" style="display:none">
<ul id="eAuthUnit">
<li><a href="/community/register/facebook?reg=1" class="fbLogin" tabindex="110"><span>Log in with Facebook</span></a></li>
<li><a href="/community/register/twitter?reg=1" class="twitterLogin" tabindex="110"><span>Log in with Twitter</span></a></li>
<li><span class="googleLogin GoogleLogin JsOnly" tabindex="110" data-client-id="198773272284-b6tfk0c28bje81p774prrcrkq9jb3o44.apps.googleusercontent.com" data-redirect-url="/community/register/google?code=__CODE__&amp;csrf=hVMXbW_3rnrmq4Em"><span>Log in with Google</span></span></li>
</ul>
<div class="ctrlWrapper">
<dl class="ctrlUnit">
<dt><label for="LoginControl">Your name or email address:</label></dt>
<dd><input type="text" name="login" id="LoginControl" class="textCtrl" tabindex="101" /></dd>
</dl>
<dl class="ctrlUnit">
<dt>
<label for="ctrl_password">Do you already have an account?</label>
</dt>
<dd>
<ul>
<li><label for="ctrl_not_registered"><input type="radio" name="register" value="1" id="ctrl_not_registered" tabindex="105" />
No, create an account now.</label></li>
<li><label for="ctrl_registered"><input type="radio" name="register" value="0" id="ctrl_registered" tabindex="105" checked="checked" class="Disabler" />
Yes, my password is:</label></li>
<li id="ctrl_registered_Disabler">
<input type="password" name="password" class="textCtrl" id="ctrl_password" tabindex="102" />
<div class="lostPassword"><a href="/community/lost-password/" tabindex="106">Forgot your password?</a></div>
</li>
</ul>
</dd>
</dl>
<dl class="ctrlUnit submitUnit">
<dt></dt>
<dd>
<input type="submit" class="button primary" value="Log in" tabindex="104" data-loginPhrase="Log in" data-signupPhrase="Sign up" />
<label for="ctrl_remember" class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_remember" tabindex="103" /> Stay logged in</label>
</dd>
</dl>
</div>
<input type="hidden" name="cookie_check" value="1" />
<input type="hidden" name="redirect" value="/community/" />
<input type="hidden" name="_xfToken" value="" />
</form>

</div>
</div>

<aside>
<div class="sidebar">
<div class="section loginButton">
<div class="secondaryContent">
<label for="LoginControl" id="SignupButton"><a href="/community/login/" class="inner">Sign up now!</a></label>
</div>
</div>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-2">

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent socialMediaIcon">
<a href="https://twitter.com/howtoforgecom" target="_blank"><img src="/images/socialmedia/64x64/twitter.png" /></a>
<a href="https://www.facebook.com/howtoforge" target="_blank"><img src="/images/socialmedia/64x64/facebook.png" /></a>
<a href="https://news.ycombinator.com/" target="_blank" rel="nofollow"><img src="/images/socialmedia/64x64/hackernews.png" /></a>
<a href="https://www.howtoforge.com/feed" target="_blank"><img src="/images/socialmedia/64x64/rss.png" /></a>
</div>
</div>
</div>
<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Tutorial Info</p>
<div class="pairsJustified">
<dl class="discussionCount">
<dt>Author:</dt>
<dd><a href="/author/hitesh+jethva/" rel="author">Hitesh Jethva</a></dd>
</dl>
<dl class="discussionCount">
<dt>Published:</dt>
<dd>May 20, 2020</dd>
</dl>
<dl class="discussionCount">
<dt>Tags:</dt>
<dd><a href='/tutorials/linux/' rel='tag'>linux</a>, <a href='/tutorials/server/' rel='tag'>server</a>, <a href='/tutorials/ubuntu/' rel='tag'>ubuntu</a></dd>
</dl>
</div>
</div>
</div>

<div id="sponsor-banner">
</div>

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent">
<p class="mnuinfo mnushare">Share This Page</p>
<p style="text-align:center;">
<a href="javascript:window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-and-use-mongodb-on-ubuntu-2004%2F', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="javascript:window.open('https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-and-use-mongodb-on-ubuntu-2004%2F&text=How+to+Install+and+Use+MongoDB+on+Ubuntu+20.04&via=howtoforgecom&related=howtoforgecom', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="javascript:window.open('https://news.ycombinator.com/submitlink?t=How+to+Install+and+Use+MongoDB+on+Ubuntu+20.04&u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-and-use-mongodb-on-ubuntu-2004%2F', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-hackernews.png" height="20" /></a>
</p>
<p style="color:#EE; font-weight:bold; text-align:center; margin-top:5px;">40.2k Followers</p>
</div>
</div>
</div>


<script type="text/javascript">
    google_ad_client = "ca-pub-3043223216276099";
    google_ad_slot = "6709042890";
    google_ad_width = 300;
    google_ad_height = 600;
</script>

<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>


<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Popular Tutorials</p>
<div class="pairsJustified">
<ul>
<li><a href="/tutorial/linux-grep-command/">How to use grep to search for strings in files on the shell</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-use-ftp-on-the-linux-shell/">How to use the Linux ftp command to up- and download files on the shell</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-create-docker-images-with-dockerfile/">How to create Docker Images with a Dockerfile</a></li>
<li><hr /></li>
<li><a href="/tutorial/perfect-server-ubuntu-18.04-with-apache-php-myqsl-pureftpd-bind-postfix-doveot-and-ispconfig/">The Perfect Server - Ubuntu 18.04 (Bionic Beaver) with Apache, PHP, MySQL, PureFTPD, BIND, Postfix, Dovecot and ISPConfig 3.1</a></li>
<li><hr /></li>
<li><a href="/tutorial/linux-search-files-from-the-terminal/">How to search files from the Terminal on Linux</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-setup-zsh-and-oh-my-zsh-on-linux/">How to Setup ZSH and Oh-my-zsh on Linux</a></li>
<li><hr /></li>
<li><a href="/how-to-find-active-ssh-connections-on-linux/">How to Find Active SSH Connections on Linux</a></li>
<li><hr /></li>
<li><a href="/vim-basics">Vim Editor Basics</a></li>
<li><hr /></li>
<li><a href="/linux-basics-set-a-static-ip-on-ubuntu">Linux Basics - Set a Static IP on Ubuntu</a></li>
<li><hr /></li>
<li><a href="/configure-remote-access-to-your-ubuntu-desktop">How To Configure Remote Access To Your Ubuntu Desktop</a></li>
<li><hr /></li>
</ul>
</div>
</div>
</div>
</div>
</div>
</aside>
</div>
</div>
</div>
<footer>
<div class="footer">
<div class="pageWidth">
<div class="pageContent">
<div class='skin_branding'><span>Xenforo skin by <a href="http://www.xenfocus.com" rel="nofollow">Xenfocus</a></span></div>
<ul class="footerLinks">
<li><a href="/contribute/">Contribute</a></li>
<li><a href="/community/misc/contact">Contact</a></li>
<li><a href="/community/help/">Help</a></li>
<li><a href="/imprint/">Imprint and Legal Notice</a></li>
<li><a href="#navigation" class="topLink">Top</a></li>
<li><a href="/feed" rel="alternate" class="globalFeed" target="_blank" title="RSS-Feed for Howtoforge">RSS-Feed</a></li>
</ul>
<span class="helper"></span>
</div>
</div>
</div>
<div class="footerLegal">
<div class="pageWidth">
<div class="pageContent">
<ul id="legal">
<li><a href="/community/help/terms">Terms and Rules</a> <a href="https://www.howtoforge.com/community/help/privacy-policy">Privacy Policy</a></li>
</ul>
<div id="copyright"><a href="https://www.howtoforge.com" class="concealed">Howtoforge <span>&copy; projektfarm GmbH.</span></a></div>
<span class="helper"></span>
</div>
</div>
</div>
</footer>
<div style="height:100px;"></div>

<div id="subscriptionModal" class="modal">
<div class="modal-content">
<span class="close">&times;</span>
<p>This feature is only available to subscribers. Get your subscription <a href="/subscription">here</a>.</p>
</div>
</div>
<script>
//* Modal
var modal = document.getElementById('subscriptionModal');
var span = document.getElementsByClassName("close")[0];
$(".pdf-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
$(".print-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
span.onclick = function() {
	$("#subscriptionModal").css('display', 'none');
}
window.onclick = function(event) {
    if (event.target == modal) {
		$("#subscriptionModal").css('display', 'none');
    }
}
//* Xenforo
jQuery.extend(true, XenForo,
{
	visitor: { user_id: 0 },
	serverTimeInfo:
	{
		now: 1409831907,
		today: 1409781600,
		todayDow: 4
	},
	_lightBoxUniversal: "0",
	_enableOverlays: "1",
	_animationSpeedMultiplier: "1",
	_overlayConfig:
	{
		top: "10%",
		speed: 200,
		closeSpeed: 100,
		mask:
		{
			color: "rgb(0, 0, 0)",
			opacity: "0.6",
			loadSpeed: 200,
			closeSpeed: 100
		}
	},
	_ignoredUsers: [],
	_loadedScripts: {"node_list":true,"node_category":true,"node_forum":true,"sidebar_share_page":true,"wf_default":true,"bbm_buttons":true,"login_bar":true,"twitter":true},
	_cookieConfig: { path: "/", domain: "", prefix: "xf_"},
	_csrfToken: "",
	_csrfRefreshUrl: "/community/login/csrf-token-refresh",
	_jsVersion: "303ae0ca"
});
jQuery.extend(XenForo.phrases,
{
	cancel: "Cancel",

	a_moment_ago:    "A moment ago",
	one_minute_ago:  "1 minute ago",
	x_minutes_ago:   "%minutes% minutes ago",
	today_at_x:      "Today at %time%",
	yesterday_at_x:  "Yesterday at %time%",
	day_x_at_time_y: "%day% at %time%",

	day0: "Sunday",
	day1: "Monday",
	day2: "Tuesday",
	day3: "Wednesday",
	day4: "Thursday",
	day5: "Friday",
	day6: "Saturday",

	_months: "January,February,March,April,May,June,July,August,September,October,November,December",
	_daysShort: "Sun,Mon,Tue,Wed,Thu,Fri,Sat",

	following_error_occurred: "The following error occurred",
	server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
	logging_in: "Logging in",
	click_image_show_full_size_version: "Click this image to show the full-size version.",
	show_hidden_content_by_x: "Show hidden content by {names}"
});

// Facebook Javascript SDK
XenForo.Facebook.appId = "";
XenForo.Facebook.forceInit = true;

/*
document.addEventListener('DOMContentLoaded', function(event) {
  cookieChoices.showCookieConsentBar('Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.',
  'OK');
});
*/

$(document).ready(function() {
	$("a.fancybox").fancybox();
});

</script>

<script>
_bsa.init('custom', 'CKYD55QU', 'placement:howtoforge',
    {
      target: '#sponsor-banner',
      template: `
<a href="##link##" style="background: linear-gradient(-330deg, ##backgroundColor##D9, ##backgroundColor##D9 30%, ##backgroundColor## 70%) #fff;" class="native-banner">
<img class="native-img" src="##logo##">
<div style="color: ##textColor##" class="native-tagline">##tagline##</div>
<div style="color: ##textColor##" class="native-desc">##description##</div>
<div style="color: ##ctaTextColor##; background-color: ##ctaBackgroundColor##;" class="native-cta">##callToAction##</div>
<div style="background-color: ##textColor##B2; color: ##backgroundColor##" class="native-ad">Ad</div>
</a>
`
    }
  );
</script>

<script>
(function() {
  if (typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('fancybar', 'CKYDL27E', 'placement:howtoforgecom');
  }
})();
</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2155872-1', 'auto');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');

</script>
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=32', true, [], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=32', false, [], true, false, false, false);
</script>
<script>var _audins_dom="howtoforge_com",_audins_did=178704;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=188-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.howtoforge_com,DomainId.178704" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript' data-cfasync='false'></script><script type="text/javascript" onload="__ezcl.handle(true);" async src="/utilcave_com/inc/ezcl.webp?cb=4"></script></body>
</html>