<!DOCTYPE html>
<html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs LoggedOut Sidebar Responsive" xmlns:fb="http://www.facebook.com/2008/fbml">
<head>
	<meta charset="utf-8" />
	<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />
		<meta name="viewport" content="width=device-width, initial-scale=1">
		<base href="https://www.howtoforge.com" />
		<script>
			var _b = document.getElementsByTagName('base')[0], _bH = "https://www.howtoforge.com/tutorial/how-to-install-orangehrm-on-ubuntu/";
			if (_b && _b.href != _bH) _b.href = _bH;
		</script>
	<title>How to Install OrangeHRM on Ubuntu</title>
	<meta name="keywords" content="linux,server,ubuntu,web server" />
	<meta name="description" content="OrangeHRM is a widely used, web-based, open-source human resource management software that can be used to manages employee's attendance, performance, ... " />
	
	<meta name="og:title" content="How to Install OrangeHRM on Ubuntu">
	<meta name="og:description" content="OrangeHRM is a widely used, web-based, open-source human resource management software that can be used to manages employee's attendance, performance, ... ">
	<meta name="og:site_name" content="Howtoforge">
	<meta name="og:type" content="article">
	<meta property="og:image" content="https://www.howtoforge.com/images/teaser/linux.gif">	
	<meta name="twitter:card" content="summary">
	<meta name="twitter:site" content="howtoforgecom">
	<meta name="twitter:creator" content="howtoforgecom">
	<meta name="twitter:title" content="How to Install OrangeHRM on Ubuntu">
	<meta name="twitter:description" content="OrangeHRM is a widely used, web-based, open-source human resource management software that can be used to manages employee's attendance, performance, ... ">

	<link rel="alternate" href="https://www.howtoforge.com/tutorial/how-to-install-orangehrm-on-ubuntu/" hreflang="en" />	
		
	<link rel="canonical" href="https://www.howtoforge.com/tutorial/how-to-install-orangehrm-on-ubuntu/" />	
	<noscript><style>.JsOnly, .jsOnly { display: none !important; }</style></noscript>
	<link rel="stylesheet" href="/community/styles/executive/xenfocus/icons/css/font-awesome.min.css" />
	<link href='//fonts.googleapis.com/css?family=Open+Sans:400,700' rel='stylesheet' type='text/css' />
	<!--<link rel="stylesheet" href="/community/css.php?css=xenforo,form,public&amp;style=3&amp;dir=LTR&amp;d=1417968046" />
	<link rel="stylesheet" href="/community/css.php?css=bbm_buttons,login_bar,node_category,node_forum,node_list,sidebar_share_page,wf_default&amp;style=3&amp;dir=LTR&amp;d=1417968046" />-->
	<link rel="stylesheet" href="/community/css.php?css=xenforo,form,public&amp;style=3&amp;dir=LTR&amp;d=1420029973"/>
	<link rel="stylesheet" href="/community/css.php?css=bb_code,bbm_buttons,facebook,google,login_bar,node_category,node_forum,node_list,profile_post_list_simple,sidebar_share_page,twitter,wf_default&amp;style=3&amp;dir=LTR&amp;d=1420029973"/>
	<script src="//ajax.googleapis.com/ajax/libs/jquery/1.11.3/jquery.min.js"></script>	
	<script>if (!window.jQuery) { document.write('<scr'+'ipt type="text/javascript" src="/js/jquery/jquery-1.11.3.min.js"><\/scr'+'ipt>'); }</script>
	<script src="/community/js/xenforo/xenforo.js?_v=303ae0ca"></script>
	<script src="/community/js/bbm/zloader.js?_v=303ae0ca"></script>
	<link href="//netdna.bootstrapcdn.com/font-awesome/4.0.3/css/font-awesome.css" rel="stylesheet">
	<script type="text/javascript" src="/js/fancybox/jquery.mousewheel-3.0.4.pack.js"></script>
	<script type="text/javascript" src="/js/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
	<link rel="stylesheet" type="text/css" href="/js/fancybox/jquery.fancybox-1.3.4.css" media="screen" />
	<link href="/themes/howtoforge/templates/style.css" rel="stylesheet">
	<link rel="alternate" type="application/rss+xml" title="RSS-Feed für Howtoforge" href="/feed.rss" />
	<script src="/js/tinymce_4.1.7/tinymce.min.js"></script>

<script type='text/javascript' src='https://partner.googleadservices.com/gampad/google_service.js'>
</script>
<script type='text/javascript'>
GS_googleAddAdSenseService("ca-pub-3043223216276099");
GS_googleEnableAllServices();
</script>
<script language="JavaScript">
GA_googleAddAttr("Category", "Linux");
GA_googleAddAttr("Category", "Server");
GA_googleAddAttr("Category", "Ubuntu");
GA_googleAddAttr("Category", "Web server");
</script>
<script type='text/javascript'>
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_leaderboard_a_728x90");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_rectangle_a_300x250");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_rectangle_b_300x250");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_halfpage_a_300x600");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_leaderboard_b_728x90");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_halfpage_b_300x600");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_a_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_b_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_c_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_d_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_list_sidebar_top");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_list_content_middle");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_list_bottom");
</script>

<script type='text/javascript'>
GA_googleFetchAds();
</script>

<!-- Begin Cookie Consent plugin by Silktide - http://silktide.com/cookieconsent -->
<script type="text/javascript">
    window.cookieconsent_options = {"message":"This website uses cookies to ensure you get the best experience on our website","dismiss":"Got it!","learnMore":"More info","link":"https://www.howtoforge.com/community/help/cookies","theme":"dark-bottom"};
</script>

<script type="text/javascript" src="/js/cookieconsent.latest.min.js"></script>
<!-- End Cookie Consent plugin -->


</head>
<body>
<div id="loginBar">
	<div class="pageWidth">
		<div class="pageContent">	
			<h3 id="loginBarHandle">
				<label for="LoginControl"><a href="/community/login/" class="concealed noOutline">Log in or Sign up</a></label>
			</h3>
			<span class="helper"></span>
		</div>
	</div>
</div>
<header>
<div id="header">
	<div id="logoBlock">
	<div class="pageWidth">
		<div class="pageContent">
					<div id="logo"><a href="/">
						<span></span>
						<img src="/images/howtoforge_logo_trans.gif" alt="Howtoforge" style="margin-left:20px;" />
					</a></div>
			<span class="helper"></span>
			<div class="langSwitch">
				<b><img src="/images/gb.png" alt="HowtoForge - Linux Tutorials in English" /> English</b> | <a href="https://www.howtoforge.de/" title="HowtoForge.de - Linux Tutorials auf Deutsch"><img src="/images/de.png" alt="HowtoForge.de - Linux Tutorials auf Deutsch" /> Deutsch</a>
			</div>
		</div>
	</div>
</div>
<div id="navigation" class="pageWidth withSearch">
	<div class="pageContent">
		<nav>
<div class="navTabs">
	<ul class="publicTabs">
		<!-- home -->
		<li class="navTab forums selected">
			<a href="/" class="navLink">Tutorials</a>
						<div class="tabLinks forumsTabLinks">
				<ul class="secondaryContent blockLinksList">
					<li><a href="/search/">Tutorial search</a></li>
				</ul>
			</div>
					</li>
		<li class="navTab forums PopupClosed">
			<a href="/tutorials/" class="navLink">Tags</a>
					</li>
		<li class="navTab forums PopupClosed"><a href="/community/" class="navLink">Forums</a></li>
		<li class="navTab forums PopupClosed"><a href="/linux-commands/" class="navLink">Linux Commands</a></li>
		<li class="navTab forums PopupClosed"><a href="/subscription/" class="navLink">Subscribe</a></li>
		<li class="navTab forums PopupClosed"><a href="http://www.ispconfig.org" class="navLink">ISPConfig</a></li>
		<li class="navTab forums PopupClosed"><a href="http://www.lxer.com" class="navLink">News</a></li>
	</ul>
</div>
<span class="helper"></span>
		</nav>	
	</div>
</div>
	

<div id="searchBar" class="pageWidth">
	<span id="QuickSearchPlaceholder" title=" Search..."> Search</span>
	<fieldset id="QuickSearch">
		<form action="/" method="post" class="formPopup">
			<div class="primaryControls">
				<!-- block: primaryControls -->
				<input type="search" name="q" value="" class="textCtrl" placeholder="Search..." results="0" title="Enter your search and hit enter..." id="QuickSearchQuery" />				
				<!-- end block: primaryControls -->
			</div>
			<input type="hidden" name="_xfToken" value="" />
		</form>		
	</fieldset>
</div>
</div>

		
		
	</header>
	
<div id="content" class="forum_list">
	<div class="pageWidth">
		<div class="pageContent">
			<!-- main content area -->
				<div class="mainContainer">
					<div class="mainContent">
						<!-- begin main template -->
						<div class="breadBoxTop">
<nav>
	<fieldset class="breadcrumb">
		<span class="crumbs">
				<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
					<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Tutorials</span></a>
					<span class="arrow"><span></span></span>
				</span>
				<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
					<a href="/tutorial/how-to-install-orangehrm-on-ubuntu/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to Install OrangeHRM on Ubuntu</span></a>
					<span class="arrow"><span>&gt;</span></span>
				</span>
		</span>
	</fieldset>
</nav>
</div>

<!-- Begin Article content -->
<div id="htfContentPage">


<h1>How to Install OrangeHRM on Ubuntu</h1>

<div class="bsa-apiads"><a href="//srv.buysellads.com/ads/click/x/GTND4237CABIK2QUF6B4YKQWF6SIPKJWCWAITZ3JCEAI523MCYYI627KC6BDL27MFTAI6K3EHJNCLSIZ" target="_blank" rel="nofollow">Java, Node.js, PHP, .NET. Get started in any language.</a><img src="https://ad.atdmt.com/i/img;p=11087214379277;idfa=;aaid=;idfa_lat=;aaid_lat=;cache=" height="1" width="1" border="0" style="display:none;" /><img src="https://pixel.adsafeprotected.com/rfw/st/81487/15646754/skeleton.gif" height="1" width="1" border="0" style="display:none;" /></div>
<div class="contributeEdit" style="float:right; width:450px; max-width:100%;">
	<!--<p style="text-align:right;"><button type="button" class="btn btn-success" onClick="document.location.href='/contribute/'">Write for HowtoForge</button></p>-->
		<div id="tocContainer">
		<h3>On this page</h3>
	<ol class="toc">
<li><a href="#-getting-started">1 Getting Started</a></li>
<li><a href="#-installing-apache-web-server">2 Installing Apache Web Server</a></li>
<li><a href="#-installing-php">3 Installing PHP</a></li>
<li><a href="#-installing-and-configuring-mariadb">4 Installing and Configuring MariaDB</a></li>
<li><a href="#-installing-orangehrm">5 Installing OrangeHRM</a></li>
<li><a href="#-configuring-apache-for-orangehrm">6 Configuring Apache for OrangeHRM</a></li>
<li><a href="#-accessing-orangehrm">7 Accessing OrangeHRM</a></li>
<li><a href="#conclusion">Conclusion</a></li>
</ol>
	</div>
	</div>



<p>OrangeHRM is a widely used, web-based, open-source human resource management software that can be used to manages employee's attendance, performance, recruitment and annual appraisals. It supports both Linux and Windows operating systems. It comes with lots of features that fulfills all your human resource management needs. OrangeHRM comes in three editions Opensource edition, Enterprise Edition, and Professional edition.</p>
<p>In this article, I&nbsp;will show you how to install OrangeHRM on an Ubuntu 14.04 server.</p>
<p><strong>Requirements</strong></p>
<ul>
<li>Fresh Ubuntu 14.04 server installed on your system.</li>
<li>PHP &gt; 5.5.0 with Apache and MySQL/MariaDB.</li>
<li>Sudo user with root privileges.</li>
</ul>
<h2 id="-getting-started">1 Getting Started</h2>
<p>Before starting, it is recommended to update your system with the latest stable version.</p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;"><!-- begin ad tag Rectangle A -->
<!-- howtoforge_com_article_rectangle_a_300x250 -->
<script type='text/javascript'>
GA_googleFillSlot('howtoforge_com_article_rectangle_a_300x250');
</script>
<!-- End ad tag Rectangle A --></div>
<p>You can do this by running the following command:</p>
<p class="command">sudo apt-get update -y<br />sudo apt-get upgrade -y</p>
<p>Once your system is updated, restart your system and login with sudo user.</p>
<h2 id="-installing-apache-web-server">2 Installing Apache Web Server</h2>
<p>Apache web server is required to run OrangeHRM. in this step we will install Apache with other required libraries to our system. You can install all of them by running the following command:</p>
<p class="command">sudo apt-get install apache2 apache2-data apache2-mpm-prefork libaio1 libapache2-mod-php5 libapr1 libaprutil1 libdbd-mysql-perl libdbi-perl libhtml-template-perl libmysqlclient18 libterm-readkey-perl libwrap0 tcpd -y</p>
<p>Once all the packages are installed, start Apache service and enable it to start on boot with the following command:</p>
<p class="command">sudo /etc/init.d/apache2 start<br />sudo update-rc.d apache2 defaults</p>
<h2 id="-installing-php">3 Installing PHP</h2>
<p>OrangeHRM supports PHP version greater than 5.5.0. You can install PHP5 and other libraries with the following command:</p>
<p class="command">sudo apt-get install php5 php5-cli php5-common php5-json php5-mysql php5-readline -y</p>
<p>Once the installation is completed, you can proceed to install the&nbsp;MariaDB server.</p>
<h2 id="-installing-and-configuring-mariadb">4 Installing and Configuring MariaDB</h2>
<p>OrangeHRM uses MariaDB/MySQL to store it's data. You can install MariaDB-server with the following command:</p>
<p class="command">sudo apt-get install mariadb-server -y</p>
<p>Once MariaDB is installed, start the MariaDB service and enable it to start on boot with the following command:</p>
<p class="command">sudo /etc/init.d/mysql start<br />sudo update-rc.d mysql defaults</p>
<p>By default MariaDB is not secured, so you will need to secure it. You can secure it by running the mysql_secure_installation script.</p>
<p class="command">sudo mysql_secure_installation</p>
<p>You will need to answer all the questions as shown in below output:</p>
<pre>NOTE: RUNNING ALL PARTS OF THIS SCRIPT IS RECOMMENDED FOR ALL MariaDB
      SERVERS IN PRODUCTION USE!  PLEASE READ EACH STEP CAREFULLY!

In order to log into MariaDB to secure it, we'll need the current
password for the root user.  If you've just installed MariaDB, and
you haven't set the root password yet, the password will be blank,
so you should just press enter here.

Enter current password for root (enter for none): 
OK, successfully used password, moving on...

Setting the root password ensures that nobody can log into the MariaDB
root user without the proper authorisation.

You already have a root password set, so you can safely answer 'n'.

Change the root password? [Y/n] n

 ... skipping.

By default, a MariaDB installation has an anonymous user, allowing anyone
to log into MariaDB without having to have a user account created for
them.  This is intended only for testing, and to make the installation
go a bit smoother.  You should remove them before moving into a
production environment.

Remove anonymous users? [Y/n] Y
 ... Success!

Normally, root should only be allowed to connect from 'localhost'.  This
ensures that someone cannot guess at the root password from the network.

Disallow root login remotely? [Y/n] Y
 ... Success!

By default, MariaDB comes with a database named 'test' that anyone can
access.  This is also intended only for testing, and should be removed
before moving into a production environment.

Remove test database and access to it? [Y/n] Y
 - Dropping test database...
 ... Success!
 - Removing privileges on test database...
 ... Success!

Reloading the privilege tables will ensure that all changes made so far
will take effect immediately.

Reload privilege tables now? [Y/n] Y
 ... Success!

Cleaning up...

All done!  If you've completed all of the above steps, your MariaDB
installation should now be secure.

Thanks for using MariaDB!
</pre>
<p>Once the MariaDB root password is set, login to MariaDB console with the following command:</p>
<p class="command">mysql -u root -p</p>
<p>Enter your root password when prompt, then create a database for OrangeHRM:</p>
<p class="command">MariaDB [(none)]&gt;CREATE DATABASE orangehrm_db;</p>
<p>Next, create a username and password for OrangeHRM with the following command:</p>
<p class="command">MariaDB [(none)]&gt;CREATE USER 'orangehrm'@'localhost' IDENTIFIED BY 'your-password';</p>
<p>Next, grant privileges to the OrangeHRM database with the following command:</p>
<p class="command">MariaDB [(none)]&gt;GRANT ALL PRIVILEGES ON orangehrm_db.* TO 'orangehrm'@'localhost';</p>
<p>Next, you will need to run the FLUSH PRIVILEGES command so that the privileges table will be reloaded by MariaDB and we can use new credential:</p>
<p class="command">MariaDB [(none)]&gt;FLUSH PRIVILEGES;</p>
<p>Finally, exit from the MariaDB console with the following command:</p>
<p class="command">MariaDB [(none)]&gt;\q</p>
<h2 id="-installing-orangehrm">5 Installing OrangeHRM</h2>
<p>First, download the latest stable version of the OrangeHRM from the SourceForge website. You can download it with the following command:</p>
<p class="command">wget https://excellmedia.dl.sourceforge.net/project/orangehrm/stable/3.3.3/orangehrm-3.3.3.zip</p>
<p>Once the download is completed, extract the downloaded archive with the following command:</p>
<p class="command">unzip orangehrm-3.3.3.zip</p>
<p>Next, move the extracted directory to the web root directory:</p>
<p class="command">sudo mv orangehrm-3.3.3 /var/www/html/orangehrm</p>
<p>And give proper permission to the orangehrm directory:</p>
<p class="command">sudo chown -R www-data:www-data /var/www/html/orangehrm<br />sudo chmod -R 777 /var/www/html/orangehrm</p>
<h2 id="-configuring-apache-for-orangehrm">6 Configuring Apache for OrangeHRM</h2>
<p>Now, you will need to create a virtual host for OrangeHRM. To do so create an&nbsp;orangehrm.conf file:</p>
<p class="command">sudo nano /etc/apache2/sites-available/orangehrm.conf</p>
<p>add the following contents:</p>
<pre>&lt;VirtualHost *:80&gt;
ServerAdmin admin@yourdomain.com
ServerName yourdomain.com
DocumentRoot /var/www/html/orangehrm
&lt;Directory /var/www/html/orangehrm&gt;
Options -Indexes +FollowSymLinks +MultiViews
AllowOverride All
Require all granted
&lt;/Directory&gt;
ErrorLog ${APACHE_LOG_DIR}/orangehrm-error.log
CustomLog ${APACHE_LOG_DIR}/orangehrm-access.log combined
&lt;/VirtualHost&gt;
</pre>
<p>Save and close the file. Then disable the default virtual host file and enable the OrangeHRM virtual host file with the following command:</p>
<p class="command">sudo a2dissite 000-defaults<br />sudo a2ensite orangehrm</p>
<p>Next, restart the Apache service to read the new virtual host configuration:</p>
<p class="command">sudo /etc/init.d/apache2 restart</p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;"><!-- begin ad tag Rectangle B -->
<!-- howtoforge_com_article_rectangle_b_300x250 -->
<script type='text/javascript'>
GA_googleFillSlot('howtoforge_com_article_rectangle_b_300x250');
</script>
<!-- End ad tag Rectangle B --></div>
<p>Once you are done, you can proceed to access OrangeHRM web interface.</p>
<h2 id="-accessing-orangehrm">7 Accessing OrangeHRM</h2>
<p>OrangeHRM runs on port 80. So you will need to allow port 80 through UFW firewall. By default UFW is disabled on your system, so you need to enable it first. You can enable it with the following command:</p>
<p class="command">sudo ufw enable</p>
<p>Once UFW firewall is enabled, you can allow port 80 by running the following command:</p>
<p class="command">sudo ufw allow tcp/80</p>
<p>You can now check the status of UFW firewall by running the following command:</p>
<p class="command">sudo ufw status</p>
<p>Now, open your favorite web browser and access the URL <span class="system">http://yourdomain.com</span>, you will be redirected to the OrangeHRM web installation wizard as shown in below image.</p>
<h2 style="text-align: center;"><a class="fancybox" id="img-Screenshot-of-orangehrm-welcome-page" href="https://www.howtoforge.com/images/how_to_install_orangehrm_on_ubuntu_1404/big/Screenshot-of-orangehrm-welcome-page.png"><img src="https://www.howtoforge.com/images/how_to_install_orangehrm_on_ubuntu_1404/Screenshot-of-orangehrm-welcome-page.png" alt="OrangeHRM Welcome Page" width="550" height="281" /></a></h2>
<p>Click on the "Next" button. You should see the License agreement in below image.</p>
<p style="text-align: center;"><a class="fancybox" id="img-Screenshot-of-orangehrm-accept-license" href="https://www.howtoforge.com/images/how_to_install_orangehrm_on_ubuntu_1404/big/Screenshot-of-orangehrm-accept-license.png"><img src="https://www.howtoforge.com/images/how_to_install_orangehrm_on_ubuntu_1404/Screenshot-of-orangehrm-accept-license.png" alt="Accept license agreement" width="550" height="304" /></a></p>
<p>Now, click on the "I Accept" button. You should see the following page.</p>
<p style="text-align: center;"><a class="fancybox" id="img-Screenshot-of-orangehrm-database-settings" href="https://www.howtoforge.com/images/how_to_install_orangehrm_on_ubuntu_1404/big/Screenshot-of-orangehrm-database-settings.png"><img src="https://www.howtoforge.com/images/how_to_install_orangehrm_on_ubuntu_1404/Screenshot-of-orangehrm-database-settings.png" alt="Database settings" width="550" height="299" /></a></p>
<p>Enter your database configuration information such as Database Host, Database Port, Database Name, Username, and Password. Then click on the "Next" button. You should see the following page.</p>
<p style="text-align: center;"><a class="fancybox" id="img-Screenshot-of-orangehrm-system-check" href="https://www.howtoforge.com/images/how_to_install_orangehrm_on_ubuntu_1404/big/Screenshot-of-orangehrm-system-check.png"><img src="https://www.howtoforge.com/images/how_to_install_orangehrm_on_ubuntu_1404/Screenshot-of-orangehrm-system-check.png" alt="System check" width="550" height="270" /></a></p>
<p>Make sure all of the system check items are green. Then Click on the "Next" button. You should see the following page.</p>
<p style="text-align: center;"><a class="fancybox" id="img-Screenshot-of-orangehrm-admin-user-creation" href="https://www.howtoforge.com/images/how_to_install_orangehrm_on_ubuntu_1404/big/Screenshot-of-orangehrm-admin-user-creation.png"><img src="https://www.howtoforge.com/images/how_to_install_orangehrm_on_ubuntu_1404/Screenshot-of-orangehrm-admin-user-creation.png" alt="Create admin user" width="550" height="275" /></a></p>
<p>Provide your admin user details like&nbsp;admin username and password. Then click on the "Next" button. You should see the following page.</p>
<p style="text-align: center;"><a class="fancybox" id="img-Screenshot-of-orangehrm-confirmation" href="https://www.howtoforge.com/images/how_to_install_orangehrm_on_ubuntu_1404/big/Screenshot-of-orangehrm-confirmation.png"><img src="https://www.howtoforge.com/images/how_to_install_orangehrm_on_ubuntu_1404/Screenshot-of-orangehrm-confirmation.png" alt="Confirm settings" width="550" height="307" /></a></p>
<p>Now, confirm all the details which you have provided earlier. Then click on the "Install" button. Once the installation is completed, you should see the following page.</p>
<p style="text-align: center;"><a class="fancybox" id="img-Screenshot-of-orangehrm-install-start" href="https://www.howtoforge.com/images/how_to_install_orangehrm_on_ubuntu_1404/big/Screenshot-of-orangehrm-install-start.png"><img src="https://www.howtoforge.com/images/how_to_install_orangehrm_on_ubuntu_1404/Screenshot-of-orangehrm-install-start.png" alt="Installation starts" width="550" height="295" /></a></p>
<p>Click on the "Next" button, you should see the following page.</p>
<p style="text-align: center;"><a class="fancybox" id="img-Screenshot-of-orangehrm-registration" href="https://www.howtoforge.com/images/how_to_install_orangehrm_on_ubuntu_1404/big/Screenshot-of-orangehrm-registration.png"><img src="https://www.howtoforge.com/images/how_to_install_orangehrm_on_ubuntu_1404/Screenshot-of-orangehrm-registration.png" alt="Registration" width="550" height="280" /></a></p>
<p>Provide your company name and click on the "Finish" button, you should see the OrangeHRM login page in below image.</p>
<p style="text-align: center;"><a class="fancybox" id="img-Screenshot-of-orangehrm-login-page" href="https://www.howtoforge.com/images/how_to_install_orangehrm_on_ubuntu_1404/big/Screenshot-of-orangehrm-login-page.png"><img src="https://www.howtoforge.com/images/how_to_install_orangehrm_on_ubuntu_1404/Screenshot-of-orangehrm-login-page.png" alt="Login page" width="550" height="263" /></a></p>
<p>Provide your admin credentials and click on the "Login" button, you should see the OrangeHRM Dashboard in below image.</p>
<p style="text-align: center;"><a class="fancybox" id="img-Screenshot-of-orangehrm-dashboard" href="https://www.howtoforge.com/images/how_to_install_orangehrm_on_ubuntu_1404/big/Screenshot-of-orangehrm-dashboard.png"><img src="https://www.howtoforge.com/images/how_to_install_orangehrm_on_ubuntu_1404/Screenshot-of-orangehrm-dashboard.png" alt="OrangeHRM Dashboard" width="550" height="251" /></a></p>
<h2 id="conclusion">Conclusion</h2>
<p>I hope, you have now enough knowledge to install and configure OrangeHRM in your server. Feel free to comments me if you have any doubt.</p>

<div style="height:30px; margin-top:20px;">
	<p style="text-align:right;"><img src="/images/pdficon_small.png" /> <a href="/subscription/">view as pdf</a> | <img src="/images/print.gif" /> <a href="/subscription/">print</a></p>
</div>
<div style="height:30px; margin-top:20px;">
	<div style="float:left;"><b>Share this page:</b></div>
		<div style="float:left; margin-left:10px;"><a href="https://twitter.com/share" class="twitter-share-button" data-count="horizontal" data-lang="en-US" data-url="https://www.howtoforge.com/tutorial/how-to-install-orangehrm-on-ubuntu/" data-via="howtoforgecom">Tweet</a> <a class="twitter-follow-button" href="https://twitter.com/howtoforgecom">Follow</a></div>
	<div style="float:left; margin-left:20px;"><fb:like href="https://www.howtoforge.com/tutorial/how-to-install-orangehrm-on-ubuntu/" layout="button_count" action="recommend" font="trebuchet ms" colorscheme="light"></fb:like></div>
	<div style="float:left; margin-left:50px;"><div class="g-plusone" data-size="medium" data-count="true" data-href="https://www.howtoforge.com/tutorial/how-to-install-orangehrm-on-ubuntu/"></div></div>
	</div>

</div>

<!-- End article content -->


<!-- Matched Content -->
<div id="htfContentPagePaging">
<h2>Suggested articles</h2>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-3043223216276099"
     data-ad-slot="8940054090"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<!-- Matched Content -->

<!-- Begin Comment section -->
<div id="htfContentPageComment">
<a name="comments"></a>
<h2>0 Comment(s)</h2>

<!-- begin comment form -->
<div id="commentform">
<div class="commentContainerHead" style="font-size:18px;">Add comment</div>
<div class="commentContainer">
<form method="post" action="/tutorial/how-to-install-orangehrm-on-ubuntu/#comments">
<input type="hidden" name="reply_to" id="reply-to-comment" value="0" />
<div id="commentFormDetail">
  <div style="width:48%; float:left; margin-right:3%">
    <label for="commentname">Name *</label>
    <input id="commentname" name="commentname" value="" />
  </div>
  <div style="width:48%;float:left;">
    <label for="commentname">Email *</label>
    <input id="commentemail" name="commentemail" value="" />
  </div>
  <div style="clear:both;"></div>
</div>
<textarea id="commentedit" name="commentedit" style="width:auto;"></textarea>
<div>
<div style="float:left;">
      <div class="g-recaptcha" data-sitekey="6LdX9fUSAAAAALWwVoPdeXScMSketz4npF-0QcQ1"></div>
      <script type="text/javascript"
          src="https://www.google.com/recaptcha/api.js?hl=en">
      </script>
</div>
<div style="margin-top:10px;margin-bottom:10px;">
	<input type="submit" name="submit" class="button primary" style="float:right;" value="Submit comment">
</div>
<div style="clear:both;"></div>
</div>

<!--<div style="height:30px;"><p>&nbsp;</p></div>-->
<script>
	tinymce.init({
		selector: "textarea#commentedit",
		theme: "modern",
		height: 100,
		apply_source_formatting : true,
		remove_linebreaks : false,
		menubar : false,
		/*auto_focus : "commentedit",*/
		plugins: [
		"link"
		],
		/*plugins: [
			"advlist autolink link image lists charmap print preview hr anchor pagebreak spellchecker",
			"searchreplace wordcount visualblocks visualchars code fullscreen insertdatetime media nonbreaking",
			"save table contextmenu directionality emoticons template paste textcolor"
		],*/
		content_css: "https://www.howtoforge.com/themes/howtoforge/css/custom.css",
		toolbar: "undo redo | bold italic link", 
		/*style_formats: [
			{title: 'Bold text', inline: 'b'},
			{title: 'Red text', inline: 'span', styles: {color: '#ff0000'}},
			{title: 'Red header', block: 'h1', styles: {color: '#ff0000'}},
			{title: 'Example 1', inline: 'span', classes: 'example1'},
			{title: 'Example 2', inline: 'span', classes: 'example2'},
			{title: 'Table styles'},
			{title: 'Table row 1', selector: 'tr', classes: 'tablerow1'}
		]*/
	}); 
	</script>
</form>
</div>
</div>
<!-- end comment form -->

</div>
<!-- End Comment section -->

<div class="breadBoxBottom">
<nav>
	<fieldset class="breadcrumb">
		<span class="crumbs">
				<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
					<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Tutorials</span></a>
					<span class="arrow"><span></span></span>
				</span>
				<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
					<a href="/tutorial/how-to-install-orangehrm-on-ubuntu/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to Install OrangeHRM on Ubuntu</span></a>
					<span class="arrow"><span>&gt;</span></span>
				</span>
		</span>
	</fieldset>
</nav>
</div>
<script>
<!--

$(document).on('click', 'a.reply-to', function(e) {
	e.preventDefault();
	
	var self = $(this);
	var cid = self.attr('data-comment');
	console.log(cid);
	if(!cid) return this;
	
	$('#commentform').insertAfter('#comment' + cid);
	$('#reply-to-comment').val(cid);
	/*tinyMCE.activeEditor.focus();*/
	var textareaId = 'commentedit';
	tinyMCE.get(textareaId).remove();
	tinyMCE.execCommand("mceAddEditor", false, textareaId);
	tinyMCE.activeEditor.focus();
});
//-->
</script>
						
<div style="margin-top:10px;margin-bottom:10px;text-align:center;">
<!--Start Leaderboard-->
<center>
<!-- begin ad tag Leaderboard B -->
<!-- howtoforge_com_article_leaderboard_b_728x90 -->
<script type='text/javascript'>
GA_googleFillSlot("howtoforge_com_article_leaderboard_b_728x90");
</script>
<!-- End ad tag Leaderboard B -->
</center>
<!--Ende Leaderboard--></div>
						<!-- end main template -->
						<!-- beginlogin form, to be moved to the upper drop-down -->
						<form action="/community/login/login?redirect=/tutorial/how-to-install-orangehrm-on-ubuntu/" method="post" class="xenForm eAuth" id="login" style="display:none">

	<ul id="eAuthUnit">
					<li><a href="/community/register/facebook?reg=1" class="fbLogin" tabindex="110"><span>Log in with Facebook</span></a></li>
					<li><a href="/community/register/twitter?reg=1" class="twitterLogin" tabindex="110"><span>Log in with Twitter</span></a></li>
					<li><span class="googleLogin GoogleLogin JsOnly" tabindex="110" data-client-id="198773272284-b6tfk0c28bje81p774prrcrkq9jb3o44.apps.googleusercontent.com" data-redirect-url="/community/register/google?code=__CODE__&amp;csrf=hVMXbW_3rnrmq4Em"><span>Log in with Google</span></span></li>	
		</ul>

	<div class="ctrlWrapper">
		<dl class="ctrlUnit">
			<dt><label for="LoginControl">Your name or email address:</label></dt>
			<dd><input type="text" name="login" id="LoginControl" class="textCtrl" tabindex="101" /></dd>
		</dl>
	
	
		<dl class="ctrlUnit">
			<dt>
				<label for="ctrl_password">Do you already have an account?</label>
			</dt>
			<dd>
				<ul>
					<li><label for="ctrl_not_registered"><input type="radio" name="register" value="1" id="ctrl_not_registered" tabindex="105" />
						No, create an account now.</label></li>
					<li><label for="ctrl_registered"><input type="radio" name="register" value="0" id="ctrl_registered" tabindex="105" checked="checked" class="Disabler" />
						Yes, my password is:</label></li>
					<li id="ctrl_registered_Disabler">
						<input type="password" name="password" class="textCtrl" id="ctrl_password" tabindex="102" />
						<div class="lostPassword"><a href="/community/lost-password/" tabindex="106">Forgot your password?</a></div>
					</li>
				</ul>
			</dd>
		</dl>
	
		
		<dl class="ctrlUnit submitUnit">
			<dt></dt>
			<dd>
				<input type="submit" class="button primary" value="Log in" tabindex="104" data-loginPhrase="Log in" data-signupPhrase="Sign up" />
				<label for="ctrl_remember" class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_remember" tabindex="103" /> Stay logged in</label>
			</dd>
		</dl>
	</div>

	<input type="hidden" name="cookie_check" value="1" />
	<input type="hidden" name="redirect" value="/community/" />
	<input type="hidden" name="_xfToken" value="" />

</form>
						<!-- end login form -->
					</div>
				</div>
				
				<!-- sidebar -->
				<aside>
					<div class="sidebar">

<div class="section loginButton">		
	<div class="secondaryContent">
		<label for="LoginControl" id="SignupButton"><a href="/community/login/" class="inner">Sign up now!</a></label>
	</div>
</div>


<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-2">

<!-- Social media -->
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
	<div class="section infoBlock sharePage">
		<div class="secondaryContent socialMediaIcon">
	<a href="https://twitter.com/howtoforgecom" target="_blank"><img src="/images/socialmedia/64x64/twitter.png" /></a>
	<a href="https://www.facebook.com/howtoforge" target="_blank"><img src="/images/socialmedia/64x64/facebook.png" /></a>
	<a href="https://plus.google.com/+howtoforge/posts" target="_blank"><img src="/images/socialmedia/64x64/googleplus.png" /></a>
	<a href="https://www.howtoforge.com/feed" target="_blank"><img src="/images/socialmedia/64x64/rss.png" /></a>
		</div>
	</div>
</div>
	
	<div class="section widget-group-no-name widget-container">
		<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
			<h3>Tutorial Info</h3>
			<div class="pairsJustified">
				<dl class="discussionCount">
					<dt>Author:</dt>
					<dd>Hitesh Jethva</dd>
				</dl>
												<dl class="discussionCount">
					<dt>Published:</dt>
					<dd>Jun 15, 2017</dd>
				</dl>
																<dl class="discussionCount">
					<dt>Tags:</dt>
					<dd><a href='/tutorials/linux/' rel='tag'>linux</a>, <a href='/tutorials/server/' rel='tag'>server</a>, <a href='/tutorials/ubuntu/' rel='tag'>ubuntu</a>, <a href='/tutorials/web+server/' rel='tag'>web server</a></dd>
				</dl>
			</div>	
		</div>
	</div>


<!-- Share buttons -->
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
	<div class="section infoBlock sharePage">
		<div class="secondaryContent">
			<h3>Share This Page</h3>
					<div class="tweet shareControl">
						<a href="https://twitter.com/share" class="twitter-share-button" data-count="horizontal" data-lang="en-US" data-url="https://www.howtoforge.com/tutorial/how-to-install-orangehrm-on-ubuntu/" data-via="howtoforgecom">Tweet</a> <a class="twitter-follow-button" data-show-screen-name="false" href="https://twitter.com/howtoforgecom">Follow</a>
					</div>
					<div class="facebookLike shareControl">
						<fb:like href="https://www.howtoforge.com/tutorial/how-to-install-orangehrm-on-ubuntu/" layout="button_count" action="recommend" font="trebuchet ms" colorscheme="light"></fb:like>
					</div>
					<div class="plusone shareControl">
						<div class="g-plusone" data-size="medium" data-count="true" data-href="https://www.howtoforge.com/tutorial/how-to-install-orangehrm-on-ubuntu/"></div>
					</div>
		</div>
	</div>
</div>

<!--
	<div class="section infoBlock sharePage">
		<div class="secondaryContent">
			<h3>Diese Seite empfehlen</h3>
					<div class="tweet shareControl">
						<a href="https://twitter.com/share" class="twitter-share-button" data-count="horizontal"
							data-lang="en-US"
							data-url="https://www.howtoforge.com/tutorial/how-to-install-orangehrm-on-ubuntu/"
							data-via="howtoforgecom"
							>Tweet</a>
					</div>
					<div class="facebookLike shareControl">
						<fb:like href="https://www.howtoforge.com/tutorial/how-to-install-orangehrm-on-ubuntu/" layout="button_count" action="recommend" font="trebuchet ms" colorscheme="light"></fb:like>
					</div>
		</div>
	</div>
-->
	<!--<div class="section infoBlock">
		<div class="secondaryContent"><div style="margin-left:35px;">-->
			<!--Start Sky-->
			<script type="text/javascript">
    google_ad_client = "ca-pub-3043223216276099";
    google_ad_slot = "6709042890";
    google_ad_width = 300;
    google_ad_height = 600;
</script>
<!-- Howtoforge sidebar 300x600 -->
<script type="text/javascript"
src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
				<!--Ende Sky-->
		<!--</div></div>
	</div>-->

</div>			
						
					</div>
				</aside>					
		</div>
	</div>
</div>

<footer>
	


<div class="footer">
	<div class="pageWidth">
		<div class="pageContent">
			
			<div class='skin_branding'><a href="http://www.xenfocus.com" rel="nofollow">Xenforo skin</a><span> by <a href="http://www.xenfocus.com" rel="nofollow">Xenfocus</a></span></div>			
			<ul class="footerLinks">
				<li><a href="/contribute/">Contribute</a></li>
				<li><a href="/community/misc/contact">Contact</a></li>
				<li><a href="/community/help/">Help</a></li>
				<li><a href="/imprint/">Imprint</a></li>
				<li><a href="/" class="homeLink">Tutorials</a></li>
				<li><a href="#navigation" class="topLink">Top</a></li>
				<li><a href="/feed" rel="alternate" class="globalFeed" target="_blank"
					title="RSS-Feed for Howtoforge">RSS-Feed</a></li>
			</ul>
			<span class="helper"></span>
		</div>
	</div>
</div>

<div class="footerLegal">
	<div class="pageWidth">
		<div class="pageContent">
			<ul id="legal">
				<li><a href="/community/help/terms">Terms</a></li>
			</ul>
			<div id="copyright"><a href="https://www.howtoforge.com" class="concealed">Howtoforge <span>&copy; projektfarm GmbH.</span></a></div>
			<span class="helper"></span>
		</div>
	</div>	
</div>
</footer>
<div style="height:100px;"></div>
<script>

jQuery.extend(true, XenForo,
{
	visitor: { user_id: 0 },
	serverTimeInfo:
	{
		now: 1409831907,
		today: 1409781600,
		todayDow: 4
	},
	_lightBoxUniversal: "0",
	_enableOverlays: "1",
	_animationSpeedMultiplier: "1",
	_overlayConfig:
	{
		top: "10%",
		speed: 200,
		closeSpeed: 100,
		mask:
		{
			color: "rgb(0, 0, 0)",
			opacity: "0.6",
			loadSpeed: 200,
			closeSpeed: 100
		}
	},
	_ignoredUsers: [],
	_loadedScripts: {"node_list":true,"node_category":true,"node_forum":true,"sidebar_share_page":true,"wf_default":true,"bbm_buttons":true,"login_bar":true,"twitter":true},
	_cookieConfig: { path: "/", domain: "", prefix: "xf_"},
	_csrfToken: "",
	_csrfRefreshUrl: "/community/login/csrf-token-refresh",
	_jsVersion: "303ae0ca"
});
jQuery.extend(XenForo.phrases,
{
	cancel: "Cancel",

	a_moment_ago:    "A moment ago",
	one_minute_ago:  "1 minute ago",
	x_minutes_ago:   "%minutes% minutes ago",
	today_at_x:      "Today at %time%",
	yesterday_at_x:  "Yesterday at %time%",
	day_x_at_time_y: "%day% at %time%",

	day0: "Sunday",
	day1: "Monday",
	day2: "Tuesday",
	day3: "Wednesday",
	day4: "Thursday",
	day5: "Friday",
	day6: "Saturday",

	_months: "January,February,March,April,May,June,July,August,September,October,November,December",
	_daysShort: "Sun,Mon,Tue,Wed,Thu,Fri,Sat",

	following_error_occurred: "The following error occurred",
	server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
	logging_in: "Logging in",
	click_image_show_full_size_version: "Click this image to show the full-size version.",
	show_hidden_content_by_x: "Show hidden content by {names}"
});

// Facebook Javascript SDK
XenForo.Facebook.appId = "";
XenForo.Facebook.forceInit = true;

/*
document.addEventListener('DOMContentLoaded', function(event) {
  cookieChoices.showCookieConsentBar('Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.',
  'OK');
});
*/

$(document).ready(function() {
	$("a.fancybox").fancybox();
});

</script>
<script async type="text/javascript" src="//cdn.fancybar.net/ac/fancybar.js?zoneid=1502&serve=C6ADVKE&placement=howtoforge" id="_fancybar_js"></script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2155872-1', 'auto');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');

</script>
</body>
</html>