<!DOCTYPE html>
<html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs LoggedOut Sidebar Responsive" xmlns:fb="http://www.facebook.com/2008/fbml">
<head>
<meta charset="utf-8" />
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<base href="https://www.howtoforge.com" />
<script>
			var _b = document.getElementsByTagName('base')[0], _bH = "https://www.howtoforge.com/tutorial/how-to-install-and-configure-askbot-on-ubuntu-1604/";
			if (_b && _b.href != _bH) _b.href = _bH;
		</script>
<title>How to Install and Configure Askbot on Ubuntu 16.04</title>
<meta name="keywords" content="linux,ubuntu" />
<meta name="description" content="In this tutorial, we will show you how to step-by-step install Askbot Django App using uWSGI and Nginx Web server, and we will be using Ubuntu 16.04 X... " />
<meta name="og:title" content="How to Install and Configure Askbot on Ubuntu 16.04">
<meta name="og:description" content="In this tutorial, we will show you how to step-by-step install Askbot Django App using uWSGI and Nginx Web server, and we will be using Ubuntu 16.04 X... ">
<meta name="og:site_name" content="Howtoforge">
<meta name="og:type" content="article">
<meta property="og:image" content="https://www.howtoforge.com/images/teaser/ubuntu.gif">
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="howtoforgecom">
<meta name="twitter:creator" content="howtoforgecom">
<meta name="twitter:title" content="How to Install and Configure Askbot on Ubuntu 16.04">
<meta name="twitter:description" content="In this tutorial, we will show you how to step-by-step install Askbot Django App using uWSGI and Nginx Web server, and we will be using Ubuntu 16.04 X... ">
<link rel="alternate" href="https://www.howtoforge.com/tutorial/how-to-install-and-configure-askbot-on-ubuntu-1604/" hreflang="en" />
<link rel="canonical" href="https://www.howtoforge.com/tutorial/how-to-install-and-configure-askbot-on-ubuntu-1604/" />
<link rel="amphtml" href="https://www.howtoforge.com/tutorial/how-to-install-and-configure-askbot-on-ubuntu-1604/amp/" />
<noscript><style>.JsOnly, .jsOnly { display: none !important; }</style></noscript>
<link rel="stylesheet" href="/community/styles/executive/xenfocus/icons/css/font-awesome.min.css" />
<link href='//fonts.googleapis.com/css?family=Open+Sans:400,700' rel='stylesheet' type='text/css' />

<link rel="stylesheet" href="/community/css.php?css=xenforo,form,public&amp;style=3&amp;dir=LTR&amp;d=1420029973" />
<link rel="stylesheet" href="/community/css.php?css=bb_code,bbm_buttons,facebook,google,login_bar,node_category,node_forum,node_list,profile_post_list_simple,sidebar_share_page,twitter,wf_default&amp;style=3&amp;dir=LTR&amp;d=1420029973" />
<script src="//ajax.googleapis.com/ajax/libs/jquery/1.11.3/jquery.min.js"></script>
<script>if (!window.jQuery) { document.write('<scr'+'ipt type="text/javascript" src="/js/jquery/jquery-1.11.3.min.js"><\/scr'+'ipt>'); }</script>
<script src="/community/js/xenforo/xenforo.js?_v=303ae0ca"></script>
<script src="/community/js/bbm/zloader.js?_v=303ae0ca"></script>
<link href="//netdna.bootstrapcdn.com/font-awesome/4.0.3/css/font-awesome.css" rel="stylesheet">
<script type="text/javascript" src="/js/fancybox/jquery.mousewheel-3.0.4.pack.js"></script>
<script type="text/javascript" src="/js/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
<link rel="stylesheet" type="text/css" href="/js/fancybox/jquery.fancybox-1.3.4.css" media="screen" />
<link href="/themes/howtoforge/templates/style.css" rel="stylesheet">
<link rel="alternate" type="application/rss+xml" title="RSS-Feed für Howtoforge" href="/feed.rss" />
<script src="/js/tinymce_4.1.7/tinymce.min.js"></script>
<script type='text/javascript' src='https://partner.googleadservices.com/gampad/google_service.js'>
</script>
<script type='text/javascript'>
GS_googleAddAdSenseService("ca-pub-3043223216276099");
GS_googleEnableAllServices();
</script>
<script language="JavaScript">
GA_googleAddAttr("Category", "Linux");
GA_googleAddAttr("Category", "Ubuntu");
</script>
<script type='text/javascript'>
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_leaderboard_a_728x90");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_rectangle_a_300x250");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_rectangle_b_300x250");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_halfpage_a_300x600");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_leaderboard_b_728x90");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_halfpage_b_300x600");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_a_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_b_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_c_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_d_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_list_sidebar_top");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_list_content_middle");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_list_bottom");
</script>
<script type='text/javascript'>
GA_googleFetchAds();
</script>

<script type="text/javascript">
    window.cookieconsent_options = {"message":"This website uses cookies to ensure you get the best experience on our website","dismiss":"Got it!","learnMore":"More info","link":"https://www.howtoforge.com/community/help/cookies","theme":"dark-bottom"};
</script>
<script type="text/javascript" src="/js/cookieconsent.latest.min.js"></script>

</head>
<body>
<div id="loginBar">
<div class="pageWidth">
<div class="pageContent">
<h3 id="loginBarHandle">
<label for="LoginControl"><a href="/community/login/" class="concealed noOutline">Log in or Sign up</a></label>
</h3>
<span class="helper"></span>
</div>
</div>
</div>
<header>
<div id="header">
<div id="logoBlock">
<div class="pageWidth">
<div class="pageContent">
<div id="logo"><a href="/">
<span></span>
<img src="/images/howtoforge_logo_trans.gif" alt="Howtoforge" style="margin-left:20px;" />
</a></div>
<span class="helper"></span>
<div class="langSwitch">
<b><img src="/images/gb.png" alt="HowtoForge - Linux Tutorials in English" /> English</b> | <a href="https://www.howtoforge.de/" title="HowtoForge.de - Linux Tutorials auf Deutsch"><img src="/images/de.png" alt="HowtoForge.de - Linux Tutorials auf Deutsch" /> Deutsch</a>
</div>
</div>
</div>
</div>
<div id="navigation" class="pageWidth withSearch">
<div class="pageContent">
<nav>
<div class="navTabs">
<ul class="publicTabs">

<li class="navTab forums selected">
<a href="/" class="navLink">Tutorials</a>
<div class="tabLinks forumsTabLinks">
<ul class="secondaryContent blockLinksList">
<li><a href="/search/">Tutorial search</a></li>
</ul>
</div>
</li>
<li class="navTab forums PopupClosed">
<a href="/tutorials/" class="navLink">Tags</a>
</li>
<li class="navTab forums PopupClosed"><a href="/community/" class="navLink">Forums</a></li>
<li class="navTab forums PopupClosed"><a href="/linux-commands/" class="navLink">Linux Commands</a></li>
<li class="navTab forums PopupClosed"><a href="/subscription/" class="navLink">Subscribe</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.ispconfig.org" class="navLink">ISPConfig</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.lxer.com" class="navLink">News</a></li>
</ul>
</div>
<span class="helper"></span>
</nav>
</div>
</div>
<div id="searchBar" class="pageWidth">
<span id="QuickSearchPlaceholder" title=" Search..."> Search</span>
<fieldset id="QuickSearch">
<form action="/" method="post" class="formPopup">
<div class="primaryControls">

<input type="search" name="q" value="" class="textCtrl" placeholder="Search..." results="0" title="Enter your search and hit enter..." id="QuickSearchQuery" />

</div>
<input type="hidden" name="_xfToken" value="" />
</form>
</fieldset>
</div>
</div>
</header>
<div id="content" class="forum_list">
<div class="pageWidth">
<div class="pageContent">

<div class="mainContainer">
<div class="mainContent">

<div class="breadBoxTop">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Tutorials</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/tutorial/how-to-install-and-configure-askbot-on-ubuntu-1604/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to Install and Configure Askbot on Ubuntu 16.04</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>

<div id="htfContentPage">
<div class="bsa-apiads"><a href="//srv.buysellads.com/ads/click/x/GTND42QJCVSDL53WFT74YKQMC67DKKQUCEYDPZ3JCWYI653LFTADT5QKC6BI4KJNCASDEK3EHJNCLSIZ" target="_blank" rel="nofollow">The #1 Customer Intelligence API</a></div>
<h1>How to Install and Configure Askbot on Ubuntu 16.04</h1>
<div class="contributeEdit" style="float:right; width:450px; max-width:100%;">

<div id="tocContainer">
<h3>On this page</h3>
<ol class="toc">
<li><a href="#prerequisites">Prerequisites</a></li>
<li><a href="#step-install-dependencies">Step 1 - Install dependencies</a>
<ol>
<li><a href="#step-install-and-configure-postgresql-database">Step 2 - Install and configure PostgreSQL database</a></li>
</ol>
</li>
<li><a href="#step-install-and-configure-askbot-django-app">Step 3 - Install and Configure Askbot Django App</a></li>
<li><a href="#step-install-and-configure-uwsgi">Step 4 - Install and Configure uWSGI</a>
<ol>
<li><a href="#step-install-and-configure-nginx">Step 5 - Install and configure Nginx</a></li>
<li><a href="#step-testing">Step 6 - Testing</a></li>
<li><a href="#reference">Reference</a>
</ol></li>
</ol>
</div>
</div>
<p>Askbot is an open source software for creating Q&amp;A forum based on Python Django Framework. It's similar to other Q&amp;A systems like StackOverflow and Yahoo Answers. The tool has been used by large open source software projects like Fedora and LibreOffice. Askbot was created by Mike Chan and Sailing Cai in 2009, and it's easy to install and configure on Linux systems like Ubuntu and CentOS.</p>
<p>In this tutorial, we will show you how to step-by-step install Askbot Django App using uWSGI and Nginx Web server, and we will be using Ubuntu 16.04 Xenial Xerus as our main operating system.</p>
<p><strong>What we will do:</strong></p>
<ol>
<li>Install dependencies</li>
<li>Install and configure PostgreSQL database</li>
<li>Install and configure Askbot</li>
<li>Install and configure uWSGI</li>
<li>Install and configure Nginx</li>
<li>Testing</li>
</ol>
<h2 id="prerequisites">Prerequisites</h2>
<ul>
<li>Ubuntu 16.04</li>
<li>Root privileges</li>
</ul>
<h2 id="step-install-dependencies">Step 1 - Install dependencies</h2>
<p>The first step we must do is to install packages that are needed for Askbot installation. So let's start. Connect to your Ubuntu server using SSH.</p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;">

<script type='text/javascript'>
GA_googleFillSlot('howtoforge_com_article_rectangle_a_300x250');
</script>
</div>
<p class="command">ssh <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="26544949526667554d4449527543545043546f76">[email&#160;protected]</a></p>
<p>Next, install packages like python-dev, pip etc with the following apt command.</p>
<p class="command">apt install -y build-essential python-pip python-dev python-flup libpng12-dev zlib1g-dev libpng-dev libjpeg-dev python-setuptools</p>
<p>All the required packages have been installed.</p>
<h3 id="step-install-and-configure-postgresql-database">Step 2 - Install and configure PostgreSQL database</h3>
<p>Askbot offers support for many database systems like MySQL, SQLite, and PostreSQL. In this tutorial, we will be using PostgreSQL as our database system.</p>
<p>We will install PostgreSQL, configure authentication for local user, and then create a new database and user for Askbot installation.</p>
<p>Install the PostgreSQL database using the following apt command.</p>
<p class="command">apt install -y postgresql postgresql-contrib</p>
<p>Now edit the <em>pg_hba.conf</em> file with&nbsp;<a href="https://www.howtoforge.com/vim-basics" target="_blank">vim</a> to configure local user authentication.</p>
<p class="command">vim /etc/postgresql/9.5/main/pg_hba.conf</p>
<p>Change all local user authentication using md5 as below.</p>
<pre class="system">local&nbsp;&nbsp; all&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; all&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; md5</pre>
<p style="text-align: center;"><a class="fancybox" id="img-1" href="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/big/1.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/1.png" /></a></p>
<p>Save and exit. Now, restart PostgreSQL services and enable it to automatically start at system boot.</p>
<p class="command">systemctl restart postgresql<br />systemctl enable postgresql</p>
<p>Next, we need to create a new database and user for Askbot installation. For our case, we will create a new database '<strong>askbotdb</strong>' with username '<strong>hakaselabs</strong>' and password '<strong>hakase123</strong>'.</p>
<p>Login as the <em>postgres</em> user and access the PostgreSQL shell 'psql'.</p>
<p class="command">su - postgres<br />psql</p>
<p>Change the <em>postgres</em> user password with your own password.</p>
<p class="command">\password postgres</p>
<p>And create a new database '<strong>askbotdb</strong>' and a new user '<strong>hakaselabs</strong>' with password '<strong>hakase123</strong>' using the following queries.</p>
<p class="command">create database askbotdb;<br />create user hakaselabs with password 'hakase123';<br />grant all privileges on database askbotdb to hakaselabs;<br />\q</p>
<p style="text-align: center;"><a class="fancybox" id="img-2" href="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/big/2.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/2.png" /></a></p>
<p>A new PostgreSQL database for Askbot installation has been created.</p>
<h2 id="step-install-and-configure-askbot-django-app">Step 3 - Install and Configure Askbot Django App</h2>
<p>All packages needed for Askbot installation have been installed and the PostgreSQL database has been created. Now, the next step is to install and configure Askbot.</p>
<p>We need to create a new user for Askbot installation, as we will not be using root user for it. Create a new user named '<strong>askbot</strong>' and give that user a new password.</p>
<p class="command">useradd -m -s /bin/bash askbot<br />passwd askbot</p>
<p>Next, add the <em>askbot</em> user to the sudo group using the following usermod command.</p>
<p class="command">usermod -a -G sudo askbot</p>
<p style="text-align: center;"><a class="fancybox" id="img-3" href="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/big/3.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/3.png" /></a></p>
<p>A new user has been created. Now we need to update python-pip and install virtualenv package. Install these packages using the following pip commands.</p>
<p class="command">pip install --upgrade pip<br />pip install virtualenv</p>
<p style="text-align: center;"><a class="fancybox" id="img-4" href="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/big/4.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/4.png" /></a></p>
<p>Now, log in as the 'askbot' user with the su command, and then install Askbot.</p>
<p class="command">su - askbot</p>
<p>And we want to create a new virtual environment for our askbot installation. Create a new virtual environment with virtualenv command.</p>
<p class="command">virtualenv hakase-labs</p>
<p>Go to the <em>hakase-labs</em> directory and activate the virtualenv.</p>
<p class="command">cd hakase-labs/<br />source bin/activate</p>
<p style="text-align: center;"><a class="fancybox" id="img-5" href="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/big/5.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/5.png" /></a></p>
<p>Install Askbot Django app with pip, including psycopg2 for PostgreSQL database connection.</p>
<p class="command">pip install askbot psycopg2</p>
<p>After the installation is complete, you will see result as shown below.</p>
<p style="text-align: center;"><a class="fancybox" id="img-6" href="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/big/6.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/6.png" /></a></p>
<p>Next, create a new directory for Askbot Django app - we will use the name 'myapp'. Create the directory and install Askbot in it.</p>
<p class="command">mkdir myapp/<br />cd myapp</p>
<p>Install Askbot with the command below.</p>
<p class="command">askbot-setup</p>
<p>When you are asked about the Askbot installation directory, just give the single '<strong>.</strong>' and press 'Enter'. Similarly, for database config, choose PostgreSQL by choosing number '<strong>1</strong>'. Input the database name '<strong>askbotdb</strong>', username '<strong>hakaselabs</strong>' with password '<strong>hakase123</strong>'.</p>
<p style="text-align: center;"><a class="fancybox" id="img-7" href="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/big/7.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/7.png" /></a></p>
<p>Now, generate static files directory with the following command.</p>
<p class="command">python manage.py collectstatic</p>
<p>Type 'yes' and press Enter to continue.</p>
<p style="text-align: center;"><a class="fancybox" id="img-8" href="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/big/8.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/8.png" /></a></p>
<p>Generate the PostgreSQL database with the syncdb option.</p>
<p class="command">python manage.py syncdb</p>
<p>And you will be asked about creating the admin user - type 'yes' and then type your admin user, email, and password.</p>
<p style="text-align: center;"><a class="fancybox" id="img-9" href="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/big/9.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/9.png" /></a></p>
<p>Askbot is now installed on the system under the 'askbot' user virtual environment. You can test the Askbot installation by running the runserver command below.</p>
<p class="command">python manage.py runserver 0.0.0.0:8080</p>
<p>Open your web browser and type the server IP with port 8080, and you will see the 'Askbot' page, as shown below.</p>
<p style="text-align: center;"><a class="fancybox" id="img-10" href="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/big/10.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/10.png" /></a></p>
<h2 id="step-install-and-configure-uwsgi">Step 4 - Install and Configure uWSGI</h2>
<p>uWSGI supports Python, Perl, and Ruby based applications. In this tutorial, we will be using uWSGI with the Nginx web server for our Askbot installation. Install uWSGI with the following pip command.</p>
<p class="command">sudo pip install uwsgi</p>
<p>Now create a new directory for the uWSGI site configuration '/etc/uwsgi/sites'.</p>
<p class="command">mkdir -p /etc/uwsgi/sites<br />/etc/uwsgi/sites</p>
<p>Add new uWSGI configuration file 'askbot.ini' to the 'sites' directory and edit it with vim.</p>
<p class="command">vim askbot.ini</p>
<p>There, paste the following uWSGI configuration.</p>
<pre class="system">[uwsgi]<br /><br /># Project directory, Python directory<br />chdir = /home/askbot/hakase-labs/myapp<br />home = /home/askbot/hakase-labs/<br />static-map = /m=/home/askbot/hakase-labs/myapp/static<br />wsgi-file = /home/askbot/hakase-labs/myapp/django.wsgi<br /><br />master = true<br />processes = 5<br /><br /># Askbot will running under the sock file<br />socket = /home/askbot/hakase-labs/myapp/askbot.sock<br />chmod-socket = 664<br />uid = askbot<br />gid = www-data<br />vacuum = true<br /><br /># uWSGI Log file<br />logto = /var/log/uwsgi.log</pre>
<p>That's it. Save and exit.</p>
<p><a class="fancybox" id="img-11" href="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/big/11.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/11.png" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Next, we need to create a new service file for uWSGI. Go to the '/etc/systemd/system/' directory and create a new uwsgi.service file using vim.</p>
<p class="command">cd /etc/systemd/system/<br />vim uwsgi.service</p>
<p>Paste the following uWSGI service configuration there.</p>
<pre class="system">[Unit]<br />Description=uWSGI Emperor service<br /><br />[Service]<br />ExecStartPre=/bin/bash -c 'mkdir -p /run/uwsgi; chown askbot:www-data /run/uwsgi'<br />ExecStart=/usr/local/bin/uwsgi --emperor /etc/uwsgi/sites<br />Restart=always<br />KillSignal=SIGQUIT<br />Type=notify<br />NotifyAccess=all<br /><br />[Install]<br />WantedBy=multi-user.target</pre>
<p>Save and exit. Then, reload the systemd services.</p>
<p class="command">systemctl daemon-reload</p>
<p>Now, start the uWSGI service and enable it to automatically launch at system boot.</p>
<p class="command">systemctl start uwsgi<br />systemctl enable uwsgi</p>
<p><a class="fancybox" id="img-12" href="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/big/12.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/12.png" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>uWSGI has been installed and configured for our Askbot app, and it's running as a system service.</p>
<h3 id="step-install-and-configure-nginx">Step 5 - Install and configure Nginx</h3>
<p>Askbot is now installed, and it's running under the uWSGI sock file 'askbot.sock'. In this step, we will be using Nginx web server as a reverse proxy for uWSGI application Askbot.</p>
<p>Install Nginx from the repository using the following apt command.</p>
<p class="command">apt install nginx</p>
<p>After the installation is complete, please go to the nginx configuration directory '/etc/nginx/' and add new nginx virtual host file 'askbot'.</p>
<p class="command">cd /etc/nginx<br />vim sites-available/askbot</p>
<p>Paste the following askbot nginx virtual host configuration.</p>
<pre class="system">server {<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; listen 80;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; server_name askbot.me www.askbot.me;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; location / {<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; include&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; uwsgi_params;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; uwsgi_pass&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; unix:/home/askbot/hakase-labs/myapp/askbot.sock;<br />&nbsp;&nbsp; }<br />}</pre>
<p>Save and exit.</p>
<p>Now enable the Askbot virtual host file by creating a symlink for 'askbot' file to 'sites-enabled' directory and test the nginx configuration.</p>
<p class="command">ln -s /etc/nginx/sites-available/askbot /etc/nginx/sites-enabled/<br />nginx -t</p>
<p><a class="fancybox" id="img-13" href="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/big/13.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/13.png" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>The Askbot virtual host is enabled. Now restart nginx services and enable it to start automatically at system boot.</p>
<p class="command">systemctl restart nginx<br />systemctl enable nginx</p>
<p>Nginx configuration has been completed, and it's running on port 80. Check it with the netstat command, as shown below.</p>
<p class="command">netstat -plntu</p>
<p>Now check askbot by checking the uWSGI sock file using the following netstat command.</p>
<p class="command">netstat -pl | grep askbot</p>
<p><a class="fancybox" id="img-14" href="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/big/14.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/14.png" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Nginx web server has been installed and configured for the Askbot Python Django app.</p>
<h3 id="step-testing">Step 6 - Testing</h3>
<p>Open your web browser and visit the Askbot domain name: askbot.me, and you should get the home page as shown below.</p>
<p><a class="fancybox" id="img-15" href="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/big/15.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/15.png" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Askbot user login.</p>
<p><a class="fancybox" id="img-16" href="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/big/16.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/16.png" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Askbot user Dashboard.</p>
<p><a class="fancybox" id="img-17" href="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/big/17.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/17.png" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Askbot Settings.</p>
<p><a class="fancybox" id="img-18" href="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/big/18.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/18.png" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Askbot Django admin login.</p>
<p><a class="fancybox" id="img-19" href="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/big/19.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/19.png" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Askbot Django admin Dashboard.</p>
<p><a class="fancybox" id="img-20" href="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/big/20.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_askbot_on_ubuntu_1604/20.png" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>The Q&amp;A system app 'Askbot' has been installed with uWSGI and Nginx web server on Ubuntu 16.04 server.</p>
<h3 id="reference">Reference</h3>
<p><a href="https://askbot.org/en/question/14954/how-to-configure-askbot-with-nginx-and-uwsgi/">https://askbot.org/en/question/</a></p>
<div style="height:30px; margin-top:20px;">
<p style="text-align:right;"><img src="/images/pdficon_small.png" /> <a href="/subscription/">view as pdf</a> | <img src="/images/print.gif" /> <a href="/subscription/">print</a></p>
</div>
<div style="height:30px; margin-top:20px;">
<div style="float:left;"><b>Share this page:</b></div>
<div style="float:left; margin-left:10px;"><a href="https://twitter.com/share" class="twitter-share-button" data-count="horizontal" data-lang="en-US" data-url="https://www.howtoforge.com/tutorial/how-to-install-and-configure-askbot-on-ubuntu-1604/" data-via="howtoforgecom">Tweet</a> <a class="twitter-follow-button" href="https://twitter.com/howtoforgecom">Follow</a></div>
<div style="float:left; margin-left:20px;"><fb:like href="https://www.howtoforge.com/tutorial/how-to-install-and-configure-askbot-on-ubuntu-1604/" layout="button_count" action="recommend" font="trebuchet ms" colorscheme="light"></fb:like></div>
<div style="float:left; margin-left:50px;"><div class="g-plusone" data-size="medium" data-count="true" data-href="https://www.howtoforge.com/tutorial/how-to-install-and-configure-askbot-on-ubuntu-1604/"></div></div>
</div>
</div>


<div id="htfContentPagePaging">
<h2>Suggested articles</h2>
<script data-cfasync="false" src="/cdn-cgi/scripts/af2821b0/cloudflare-static/email-decode.min.js"></script><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-3043223216276099" data-ad-slot="8940054090"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>


<div id="htfContentPageComment">
<a name="comments"></a>
<h2>0 Comment(s)</h2>

<div id="commentform">
<div class="commentContainerHead" style="font-size:18px;">Add comment</div>
<div class="commentContainer">
<form method="post" action="/tutorial/how-to-install-and-configure-askbot-on-ubuntu-1604/#comments">
<input type="hidden" name="reply_to" id="reply-to-comment" value="0" />
<div id="commentFormDetail">
<div style="width:48%; float:left; margin-right:3%">
<label for="commentname">Name *</label>
<input id="commentname" name="commentname" value="" />
</div>
<div style="width:48%;float:left;">
<label for="commentname">Email *</label>
<input id="commentemail" name="commentemail" value="" />
</div>
<div style="clear:both;"></div>
</div>
<textarea id="commentedit" name="commentedit" style="width:auto;"></textarea>
<div>
<div style="float:left;">
<div class="g-recaptcha" data-sitekey="6LdX9fUSAAAAALWwVoPdeXScMSketz4npF-0QcQ1"></div>
<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en">
      </script>
</div>
<div style="margin-top:10px;margin-bottom:10px;">
<input type="submit" name="submit" class="button primary" style="float:right;" value="Submit comment">
</div>
<div style="clear:both;"></div>
</div>

<script>
	tinymce.init({
		selector: "textarea#commentedit",
		theme: "modern",
		height: 100,
		apply_source_formatting : true,
		remove_linebreaks : false,
		menubar : false,
		/*auto_focus : "commentedit",*/
		plugins: [
		"link"
		],
		/*plugins: [
			"advlist autolink link image lists charmap print preview hr anchor pagebreak spellchecker",
			"searchreplace wordcount visualblocks visualchars code fullscreen insertdatetime media nonbreaking",
			"save table contextmenu directionality emoticons template paste textcolor"
		],*/
		content_css: "https://www.howtoforge.com/themes/howtoforge/css/custom.css",
		toolbar: "undo redo | bold italic link", 
		/*style_formats: [
			{title: 'Bold text', inline: 'b'},
			{title: 'Red text', inline: 'span', styles: {color: '#ff0000'}},
			{title: 'Red header', block: 'h1', styles: {color: '#ff0000'}},
			{title: 'Example 1', inline: 'span', classes: 'example1'},
			{title: 'Example 2', inline: 'span', classes: 'example2'},
			{title: 'Table styles'},
			{title: 'Table row 1', selector: 'tr', classes: 'tablerow1'}
		]*/
	}); 
	</script>
</form>
</div>
</div>

</div>

<div class="breadBoxBottom">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Tutorials</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/tutorial/how-to-install-and-configure-askbot-on-ubuntu-1604/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to Install and Configure Askbot on Ubuntu 16.04</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
<script>
<!--

$(document).on('click', 'a.reply-to', function(e) {
	e.preventDefault();
	
	var self = $(this);
	var cid = self.attr('data-comment');
	console.log(cid);
	if(!cid) return this;
	
	$('#commentform').insertAfter('#comment' + cid);
	$('#reply-to-comment').val(cid);
	/*tinyMCE.activeEditor.focus();*/
	var textareaId = 'commentedit';
	tinyMCE.get(textareaId).remove();
	tinyMCE.execCommand("mceAddEditor", false, textareaId);
	tinyMCE.activeEditor.focus();
});
//-->
</script>
<div style="margin-top:10px;margin-bottom:10px;text-align:center;">

<center>


<script type='text/javascript'>
GA_googleFillSlot("howtoforge_com_article_leaderboard_b_728x90");
</script>

</center>
</div>


<form action="/community/login/login?redirect=/tutorial/how-to-install-and-configure-askbot-on-ubuntu-1604/" method="post" class="xenForm eAuth" id="login" style="display:none">
<ul id="eAuthUnit">
<li><a href="/community/register/facebook?reg=1" class="fbLogin" tabindex="110"><span>Log in with Facebook</span></a></li>
<li><a href="/community/register/twitter?reg=1" class="twitterLogin" tabindex="110"><span>Log in with Twitter</span></a></li>
<li><span class="googleLogin GoogleLogin JsOnly" tabindex="110" data-client-id="198773272284-b6tfk0c28bje81p774prrcrkq9jb3o44.apps.googleusercontent.com" data-redirect-url="/community/register/google?code=__CODE__&amp;csrf=hVMXbW_3rnrmq4Em"><span>Log in with Google</span></span></li>
</ul>
<div class="ctrlWrapper">
<dl class="ctrlUnit">
<dt><label for="LoginControl">Your name or email address:</label></dt>
<dd><input type="text" name="login" id="LoginControl" class="textCtrl" tabindex="101" /></dd>
</dl>
<dl class="ctrlUnit">
<dt>
<label for="ctrl_password">Do you already have an account?</label>
</dt>
<dd>
 <ul>
<li><label for="ctrl_not_registered"><input type="radio" name="register" value="1" id="ctrl_not_registered" tabindex="105" />
No, create an account now.</label></li>
<li><label for="ctrl_registered"><input type="radio" name="register" value="0" id="ctrl_registered" tabindex="105" checked="checked" class="Disabler" />
Yes, my password is:</label></li>
<li id="ctrl_registered_Disabler">
<input type="password" name="password" class="textCtrl" id="ctrl_password" tabindex="102" />
<div class="lostPassword"><a href="/community/lost-password/" tabindex="106">Forgot your password?</a></div>
</li>
</ul>
</dd>
</dl>
<dl class="ctrlUnit submitUnit">
<dt></dt>
<dd>
<input type="submit" class="button primary" value="Log in" tabindex="104" data-loginPhrase="Log in" data-signupPhrase="Sign up" />
<label for="ctrl_remember" class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_remember" tabindex="103" /> Stay logged in</label>
</dd>
</dl>
</div>
<input type="hidden" name="cookie_check" value="1" />
<input type="hidden" name="redirect" value="/community/" />
<input type="hidden" name="_xfToken" value="" />
</form>

</div>
</div>

<aside>
<div class="sidebar">
<div class="section loginButton">
<div class="secondaryContent">
<label for="LoginControl" id="SignupButton"><a href="/community/login/" class="inner">Sign up now!</a></label>
</div>
</div>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-2">

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent socialMediaIcon">
<a href="https://twitter.com/howtoforgecom" target="_blank"><img src="/images/socialmedia/64x64/twitter.png" /></a>
<a href="https://www.facebook.com/howtoforge" target="_blank"><img src="/images/socialmedia/64x64/facebook.png" /></a>
<a href="https://plus.google.com/+howtoforge/posts" target="_blank"><img src="/images/socialmedia/64x64/googleplus.png" /></a>
<a href="https://www.howtoforge.com/feed" target="_blank"><img src="/images/socialmedia/64x64/rss.png" /></a>
</div>
</div>
</div>
<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Tutorial Info</p>
<div class="pairsJustified">
<dl class="discussionCount">
<dt>Author:</dt>
<dd>Muhammad Arul</dd>
</dl>
<dl class="discussionCount">
<dt>Published:</dt>
<dd>Dec 07, 2017</dd>
</dl>
<dl class="discussionCount">
<dt>Tags:</dt>
<dd><a href='/tutorials/linux/' rel='tag'>linux</a>, <a href='/tutorials/ubuntu/' rel='tag'>ubuntu</a></dd>
</dl>
</div>
</div>
</div>

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent">
<p class="mnuinfo mnushare">Share This Page</p>
<div class="tweet shareControl">
<a href="https://twitter.com/share" class="twitter-share-button" data-count="horizontal" data-lang="en-US" data-url="https://www.howtoforge.com/tutorial/how-to-install-and-configure-askbot-on-ubuntu-1604/" data-via="howtoforgecom">Tweet</a> <a class="twitter-follow-button" data-show-screen-name="false" href="https://twitter.com/howtoforgecom">Follow</a>
</div>
<div class="facebookLike shareControl">
<fb:like href="https://www.howtoforge.com/tutorial/how-to-install-and-configure-askbot-on-ubuntu-1604/" layout="button_count" action="recommend" font="trebuchet ms" colorscheme="light"></fb:like>
</div>
<div class="plusone shareControl">
<div class="g-plusone" data-size="medium" data-count="true" data-href="https://www.howtoforge.com/tutorial/how-to-install-and-configure-askbot-on-ubuntu-1604/"></div>
</div>
</div>
</div>
</div>



<script type="text/javascript">
    google_ad_client = "ca-pub-3043223216276099";
    google_ad_slot = "6709042890";
    google_ad_width = 300;
    google_ad_height = 600;
</script>

<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>


<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Popular Tutorials</p>
<div class="pairsJustified">
<ul>
<li><a href="/tutorial/install-mongodb-on-ubuntu-16.04/">How to Install and Configure MongoDB on Ubuntu 16.04</a></li>
<li><hr /></li>
<li><a href="/tutorial/perfect-server-debian-9-stretch-apache-bind-dovecot-ispconfig-3-1/">The Perfect Server - Debian 9 (Stretch) with Apache, BIND, Dovecot, PureFTPD and ISPConfig 3.1</a></li>
<li><hr /></li>
<li><a href="/linux_lvm">A Beginner's Guide To LVM</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-install-grafana-on-linux-servers/">How to Install Grafana on Linux Servers</a></li>
<li><hr /></li>
<li><a href="/tutorial/perfect-server-ubuntu-16.04-with-apache-php-myqsl-pureftpd-bind-postfix-doveot-and-ispconfig/">The Perfect Server - Ubuntu 16.04 (Xenial Xerus) with Apache, PHP, MySQL, PureFTPD, BIND, Postfix, Dovecot and ISPConfig 3.1</a></li>
<li><hr /></li>
<li><a href="/tutorial/write-a-custom-nagios-check-plugin/">How to Write a Custom Nagios Check Plugin</a></li>
<li><hr /></li>
<li><a href="/tutorial/install-apache-with-php-and-mysql-on-ubuntu-16-04-lamp/">Ubuntu 16.04 (LTS) LAMP server tutorial with Apache, PHP 7, and MySQL</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-use-ftp-on-the-linux-shell/">How to use the Linux ftp command to up- and download files on the shell</a></li>
<li><hr /></li>
<li><a href="/tutorial/ubuntu-perfect-server-with-apache-php-myqsl-pureftpd-bind-postfix-doveot-and-ispconfig/">The Perfect Server - Ubuntu 17.10 (Artful Aardvark) with Apache, PHP, MySQL, PureFTPD, BIND, Postfix, Dovecot and ISPConfig 3.1</a></li>
<li><hr /></li>
<li><a href="/tutorial/linux-grep-command/">How to use grep to search for strings in files on the shell</a></li>
<li><hr /></li>
</ul>
</div>
</div>
</div>
</div>
</div>
</aside>
</div>
</div>
</div>
<footer>
<div class="footer">
<div class="pageWidth">
<div class="pageContent">
<div class='skin_branding'><a href="http://www.xenfocus.com" rel="nofollow">Xenforo skin</a><span> by <a href="http://www.xenfocus.com" rel="nofollow">Xenfocus</a></span></div>
<ul class="footerLinks">
<li><a href="/contribute/">Contribute</a></li>
<li><a href="/community/misc/contact">Contact</a></li>
<li><a href="/community/help/">Help</a></li>
<li><a href="/imprint/">Imprint</a></li>
<li><a href="/" class="homeLink">Tutorials</a></li>
<li><a href="#navigation" class="topLink">Top</a></li>
<li><a href="/feed" rel="alternate" class="globalFeed" target="_blank" title="RSS-Feed for Howtoforge">RSS-Feed</a></li>
</ul>
<span class="helper"></span>
</div>
</div>
</div>
<div class="footerLegal">
<div class="pageWidth">
<div class="pageContent">
<ul id="legal">
<li><a href="/community/help/terms">Terms</a></li>
</ul>
<div id="copyright"><a href="https://www.howtoforge.com" class="concealed">Howtoforge <span>&copy; projektfarm GmbH.</span></a></div>
<span class="helper"></span>
</div>
</div>
</div>
</footer>
<div style="height:100px;"></div>
<script>

jQuery.extend(true, XenForo,
{
	visitor: { user_id: 0 },
	serverTimeInfo:
	{
		now: 1409831907,
		today: 1409781600,
		todayDow: 4
	},
	_lightBoxUniversal: "0",
	_enableOverlays: "1",
	_animationSpeedMultiplier: "1",
	_overlayConfig:
	{
		top: "10%",
		speed: 200,
		closeSpeed: 100,
		mask:
		{
			color: "rgb(0, 0, 0)",
			opacity: "0.6",
			loadSpeed: 200,
			closeSpeed: 100
		}
	},
	_ignoredUsers: [],
	_loadedScripts: {"node_list":true,"node_category":true,"node_forum":true,"sidebar_share_page":true,"wf_default":true,"bbm_buttons":true,"login_bar":true,"twitter":true},
	_cookieConfig: { path: "/", domain: "", prefix: "xf_"},
	_csrfToken: "",
	_csrfRefreshUrl: "/community/login/csrf-token-refresh",
	_jsVersion: "303ae0ca"
});
jQuery.extend(XenForo.phrases,
{
	cancel: "Cancel",

	a_moment_ago:    "A moment ago",
	one_minute_ago:  "1 minute ago",
	x_minutes_ago:   "%minutes% minutes ago",
	today_at_x:      "Today at %time%",
	yesterday_at_x:  "Yesterday at %time%",
	day_x_at_time_y: "%day% at %time%",

	day0: "Sunday",
	day1: "Monday",
	day2: "Tuesday",
	day3: "Wednesday",
	day4: "Thursday",
	day5: "Friday",
	day6: "Saturday",

	_months: "January,February,March,April,May,June,July,August,September,October,November,December",
	_daysShort: "Sun,Mon,Tue,Wed,Thu,Fri,Sat",

	following_error_occurred: "The following error occurred",
	server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
	logging_in: "Logging in",
	click_image_show_full_size_version: "Click this image to show the full-size version.",
	show_hidden_content_by_x: "Show hidden content by {names}"
});

// Facebook Javascript SDK
XenForo.Facebook.appId = "";
XenForo.Facebook.forceInit = true;

/*
document.addEventListener('DOMContentLoaded', function(event) {
  cookieChoices.showCookieConsentBar('Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.',
  'OK');
});
*/

$(document).ready(function() {
	$("a.fancybox").fancybox();
});

</script>
<script async type="text/javascript" src="//cdn.fancybar.net/ac/fancybar.js?zoneid=1502&serve=C6ADVKE&placement=howtoforge" id="_fancybar_js"></script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2155872-1', 'auto');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');

</script>
</body>
</html>