<!DOCTYPE html>
<html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs LoggedOut Sidebar Responsive" xmlns:fb="http://www.facebook.com/2008/fbml">
<head>
<meta charset="utf-8" />
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<base href="https://www.howtoforge.com" />
<script>
			var _b = document.getElementsByTagName('base')[0], _bH = "https://www.howtoforge.com/tutorial/debian-dokuwiki-apache-installation/";
			if (_b && _b.href != _bH) _b.href = _bH;
		</script>
<title>How to Install DokuWiki with Apache on Debian 9</title>
<meta name="keywords" content="apache,linux,web server" />
<meta name="description" content="DokuWiki is a free open source wiki application written completely in the PHP programming language and often deployed in Linux under Apache/Nginx web ... " />
<meta name="og:title" content="How to Install DokuWiki with Apache on Debian 9">
<meta name="og:description" content="DokuWiki is a free open source wiki application written completely in the PHP programming language and often deployed in Linux under Apache/Nginx web ... ">
<meta name="og:site_name" content="Howtoforge">
<meta name="og:type" content="article">
<meta property="og:image" content="https://www.howtoforge.com/images/teaser/debian.gif">
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="howtoforgecom">
<meta name="twitter:creator" content="howtoforgecom">
<meta name="twitter:title" content="How to Install DokuWiki with Apache on Debian 9">
<meta name="twitter:description" content="DokuWiki is a free open source wiki application written completely in the PHP programming language and often deployed in Linux under Apache/Nginx web ... ">
<link rel="alternate" href="https://www.howtoforge.com/tutorial/debian-dokuwiki-apache-installation/" hreflang="en" />
<link rel="canonical" href="https://www.howtoforge.com/tutorial/debian-dokuwiki-apache-installation/" />
<link rel="amphtml" href="https://www.howtoforge.com/tutorial/debian-dokuwiki-apache-installation/amp/" />
<noscript><style>.JsOnly, .jsOnly { display: none !important; }</style></noscript>
<link rel="stylesheet" href="/community/styles/executive/xenfocus/icons/css/font-awesome.min.css" />
<link href='//fonts.googleapis.com/css?family=Open+Sans:400,700' rel='stylesheet' type='text/css' />

<link rel="stylesheet" href="/community/css.php?css=xenforo,form,public&amp;style=3&amp;dir=LTR&amp;d=1420029973" />
<link rel="stylesheet" href="/community/css.php?css=bb_code,bbm_buttons,facebook,google,login_bar,node_category,node_forum,node_list,profile_post_list_simple,sidebar_share_page,twitter,wf_default&amp;style=3&amp;dir=LTR&amp;d=1420029973" />
<script src="//ajax.googleapis.com/ajax/libs/jquery/1.11.3/jquery.min.js"></script>
<script>if (!window.jQuery) { document.write('<scr'+'ipt type="text/javascript" src="/js/jquery/jquery-1.11.3.min.js"><\/scr'+'ipt>'); }</script>
<script src="/community/js/xenforo/xenforo.js?_v=303ae0ca"></script>
<script src="/community/js/bbm/zloader.js?_v=303ae0ca"></script>
<link href="//netdna.bootstrapcdn.com/font-awesome/4.0.3/css/font-awesome.css" rel="stylesheet">
<script type="text/javascript" src="/js/fancybox/jquery.mousewheel-3.0.4.pack.js"></script>
<script type="text/javascript" src="/js/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
<link rel="stylesheet" type="text/css" href="/js/fancybox/jquery.fancybox-1.3.4.css" media="screen" />
<link href="/themes/howtoforge/templates/style.css" rel="stylesheet">
<link rel="alternate" type="application/rss+xml" title="RSS-Feed für Howtoforge" href="/feed.rss" />
<script src="/js/tinymce_4.1.7/tinymce.min.js"></script>
<script type='text/javascript' src='https://partner.googleadservices.com/gampad/google_service.js'>
</script>
<script type='text/javascript'>
GS_googleAddAdSenseService("ca-pub-3043223216276099");
GS_googleEnableAllServices();
</script>
<script language="JavaScript">
GA_googleAddAttr("Category", "Apache");
GA_googleAddAttr("Category", "Linux");
GA_googleAddAttr("Category", "Web server");
</script>
<script type='text/javascript'>
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_leaderboard_a_728x90");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_rectangle_a_300x250");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_rectangle_b_300x250");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_halfpage_a_300x600");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_leaderboard_b_728x90");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_halfpage_b_300x600");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_a_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_b_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_c_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_d_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_list_sidebar_top");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_list_content_middle");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_list_bottom");
</script>
<script type='text/javascript'>
GA_googleFetchAds();
</script>

<script type="text/javascript">
    window.cookieconsent_options = {"message":"This website uses cookies to ensure you get the best experience on our website","dismiss":"Got it!","learnMore":"More info","link":"https://www.howtoforge.com/community/help/cookies","theme":"dark-bottom"};
</script>
<script type="text/javascript" src="/js/cookieconsent.latest.min.js"></script>

</head>
<body>
<div id="loginBar">
<div class="pageWidth">
<div class="pageContent">
<h3 id="loginBarHandle">
<label for="LoginControl"><a href="/community/login/" class="concealed noOutline">Log in or Sign up</a></label>
</h3>
<span class="helper"></span>
</div>
</div>
</div>
<header>
<div id="header">
<div id="logoBlock">
<div class="pageWidth">
<div class="pageContent">
<div id="logo"><a href="/">
<span></span>
<img src="/images/howtoforge_logo_trans.gif" alt="Howtoforge" style="margin-left:20px;" />
</a></div>
<span class="helper"></span>
<div class="langSwitch">
<b><img src="/images/gb.png" alt="HowtoForge - Linux Tutorials in English" /> English</b> | <a href="https://www.howtoforge.de/" title="HowtoForge.de - Linux Tutorials auf Deutsch"><img src="/images/de.png" alt="HowtoForge.de - Linux Tutorials auf Deutsch" /> Deutsch</a>
</div>
</div>
</div>
</div>
<div id="navigation" class="pageWidth withSearch">
<div class="pageContent">
<nav>
<div class="navTabs">
<ul class="publicTabs">

<li class="navTab forums selected">
<a href="/" class="navLink">Tutorials</a>
<div class="tabLinks forumsTabLinks">
<ul class="secondaryContent blockLinksList">
<li><a href="/search/">Tutorial search</a></li>
</ul>
</div>
</li>
<li class="navTab forums PopupClosed">
<a href="/tutorials/" class="navLink">Tags</a>
</li>
<li class="navTab forums PopupClosed"><a href="/community/" class="navLink">Forums</a></li>
<li class="navTab forums PopupClosed"><a href="/linux-commands/" class="navLink">Linux Commands</a></li>
<li class="navTab forums PopupClosed"><a href="/subscription/" class="navLink">Subscribe</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.ispconfig.org" class="navLink">ISPConfig</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.lxer.com" class="navLink">News</a></li>
</ul>
</div>
<span class="helper"></span>
</nav>
</div>
</div>
<div id="searchBar" class="pageWidth">
<span id="QuickSearchPlaceholder" title=" Search..."> Search</span>
<fieldset id="QuickSearch">
<form action="/" method="post" class="formPopup">
<div class="primaryControls">

<input type="search" name="q" value="" class="textCtrl" placeholder="Search..." results="0" title="Enter your search and hit enter..." id="QuickSearchQuery" />

</div>
<input type="hidden" name="_xfToken" value="" />
</form>
</fieldset>
</div>
</div>
</header>
<div id="content" class="forum_list">
<div class="pageWidth">
<div class="pageContent">

<div class="mainContainer">
<div class="mainContent">

<div class="breadBoxTop">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Tutorials</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/tutorial/debian-dokuwiki-apache-installation/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to Install DokuWiki with Apache on Debian 9</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>

<div id="htfContentPage">
<div class="bsa-apiads"><a href="//srv.buysellads.com/ads/click/x/GTND42QLC6BIP53WC6A4YKQMCVYIPKQECKYIKZ3JCW7D42J7CEYI523KC6BI6KQMCYADEK3EHJNCLSIZ" target="_blank" rel="nofollow">Take Triplebyte's quiz. Get offers from 200+ top tech companies.</a></div>
<h1>How to Install DokuWiki with Apache on Debian 9</h1>
<div class="contributeEdit" style="float:right; width:450px; max-width:100%;">

<div id="tocContainer">
<h3>On this page</h3>
<ol class="toc">
<li><a href="#requirements">Requirements</a></li>
<li><a href="#prerequirements">Pre-Requirements</a></li>
<li><a href="#installnbspdokuwikinbsp">Install&nbsp;DokuWiki&nbsp;</a></li>
</ol>
</div>
</div>
<p>This tutorial I will show you how to install and configure the latest version DokuWiki CMS platform on Debian 9.2 release, in order to create online documentation websites.<br /><br />DokuWiki is a free open source wiki application written completely in the PHP programming language and often deployed in Linux under Apache/Nginx web servers and PHP. <br /><br />DokuWiki software platform requires no RDBMS SQL database to run. In exchange, it uses simple plain text files as backend in order to store all data. DokuWiki is a simple and flexible platform with a clean syntax that can be successfully used to deploy powerful and collaborative documentation websites.</p>
<h2 id="requirements">Requirements</h2>
<ul>
<li><span></span>Minimal installation of debian 9 on a bare-metal server machine or on a virtual private server.</li>
<li>sudo root privileges for a local or remote account or direct access to root account.</li>
<li>A static IP address configured for one of your system network interfaces cards.</li>
<li>A domain name, private or public, depending on your deployment, with the proper DNS records configured for web services. If don&rsquo;t have a valid or a registered domain name you can perform the installation and access the website via your server IP address.</li>
<li>If you want to use website registration, mail order confirmations and other features, you should have a running mail server properly configured at your premises with remote access to its .IMAP and SMTP services.</li>
</ul>
<h2 id="prerequirements">Pre-Requirements</h2>
<p>Before starting to install and configure DokuWiki from sources in your own server, first assure the system meets all the software requirements for compiling and installing the application. In the first step, update your system repositories and software packages by issuing the following command.</p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;">

<script type='text/javascript'>
GA_googleFillSlot('howtoforge_com_article_rectangle_a_300x250');
</script>
</div>
<p class="command">apt&nbsp;update</p>
<p class="command">apt&nbsp;upgrade</p>
<p><strong></strong>On the next step, execute the following command in order to install some necessary utilities that will be used to further manage your system from the command line.</p>
<p class="command">apt&nbsp;install&nbsp;wget&nbsp;bash-completion&nbsp;zip&nbsp;unzip&nbsp;curl</p>
<p>After the system has been fully updated and the required utilities to manage your server have been installed, setup the name for your system by executing the following command (replace your hostname variable accordingly).</p>
<p class="command">hostnamectl&nbsp;set-hostname&nbsp;www.mywiki.com</p>
<p>Verify&nbsp;machine&nbsp;hostname&nbsp;and&nbsp;hosts&nbsp;file&nbsp;by&nbsp;issuing&nbsp;the&nbsp;below&nbsp;commands.</p>
<p class="command">hostnamectl&nbsp;</p>
<p class="command">cat&nbsp;/etc/hostname&nbsp;</p>
<p class="command">hostname&nbsp;&ndash;s</p>
<p class="command">hostname&nbsp;&ndash;f</p>
<p><strong><b>&nbsp;</b></strong>Next,&nbsp;install the ImageMagick&nbsp;software,&nbsp;required&nbsp;by&nbsp;DokuWiki&nbsp;to&nbsp;create&nbsp;image&nbsp;thumbnailing&nbsp;by&nbsp;issuing&nbsp;the following command.</p>
<p class="command">apt&nbsp;install&nbsp;imagemagick&nbsp;</p>
<p>&nbsp;Finally,&nbsp;reboot&nbsp;Debian&nbsp;server&nbsp;in&nbsp;order&nbsp;to&nbsp;apply&nbsp;kernel&nbsp;updates&nbsp;and&nbsp;the&nbsp;hostname&nbsp;changes&nbsp;properly.</p>
<p class="command">init&nbsp;6</p>
<p>DokuWiki is a web-based CMS wiki platform written in PHP server-side programming language. In order to execute the PHP file scripts of the application, a web server, such as Apache HTTP server, and a PHP processing gateway must be installed and operational in the system.&nbsp; In order to install Apache web server and the PHP interpreter alongside all required PHP modules needed by the application to run properly, issue the following command in your server console.</p>
<p class="command">apt&nbsp;install&nbsp;apache2&nbsp;libapache2-mod-php7.0&nbsp;php7.0&nbsp;php7.0-curl&nbsp;php7.0-gd&nbsp;php7.0-opcache&nbsp;php7.0-json&nbsp;php7.0-mbstring&nbsp;php7.0-intl&nbsp;php-imagick&nbsp;php7.0-xml</p>
<p>After Apache and PHP has been installed, test if the web server is up and running and listening for network connections on port 80 by issuing the following command with root privileges.</p>
<p class="command">netstat&nbsp;&ndash;tlpn</p>
<p><strong></strong>In&nbsp;case the <strong><b>netstat</b></strong>&nbsp;network&nbsp;utility&nbsp;is&nbsp;not&nbsp;installed by&nbsp;default on your&nbsp;Debian&nbsp;system,&nbsp;execute&nbsp;the following command&nbsp;to&nbsp;install&nbsp;it.</p>
<p class="command">apt&nbsp;install&nbsp;net-tools</p>
<p>By inspecting the netstat command output you can see the Apache web server is listening for incoming network connections on port 80. For the same task, you can also use the ss command, which is automatically installed by default in Debian 9.</p>
<p class="command">ss-&nbsp;tulpn</p>
<p>In case you have a firewall enabled on your system, such as UFW firewall application, you should add a new rule to allow HTTP traffic to pass through the firewall by issuing the following command.</p>
<p class="command">ufw&nbsp;allow&nbsp;WWW</p>
<p>or</p>
<p class="command">ufw&nbsp;allow&nbsp;80/tcp</p>
<p>If you&rsquo;re using iptables raw rules to manage Firewall rules on your Debian server, add the following rules to allow port 80 inbound traffic on the firewall so that visitors can browse your wiki application.</p>
<p class="command">apt-get&nbsp;install&nbsp;-y&nbsp;iptables-persistent</p>
<p class="command">iptables&nbsp;-I&nbsp;INPUT&nbsp;-p&nbsp;tcp&nbsp;--destination-port&nbsp;80&nbsp;-j&nbsp;ACCEPT</p>
<p class="command">iptables&nbsp;-I&nbsp;INPUT&nbsp;-p&nbsp;tcp&nbsp;--destination-port&nbsp;22&nbsp;-j&nbsp;ACCEPT</p>
<p class="command">netfilter-persistent&nbsp;save</p>
<p class="command">systemctl&nbsp;restart&nbsp;netfilter-persistent</p>
<p class="command">systemctl&nbsp;status&nbsp;netfilter-persistent</p>
<p class="command">systemctl&nbsp;enable&nbsp;netfilter-persistent.service</p>
<p><strong></strong>Next, enable and apply the following Apache module required by the the web application to activate the weboot&nbsp; .htaccess files. Run the following commands:</p>
<p class="command">a2enmod&nbsp;rewrite&nbsp;</p>
<p class="command">systemctl&nbsp;restart&nbsp;apache2</p>
<p>Finally, test if the Apache web server default web page can be displayed in your client's browsers by visiting your Debian machine IP address or your domain name or server FQDN via HTTP protocol, as shown in the image below. If you don&rsquo;t know your machine's IP address, execute ifconfig or <strong>ip a</strong> command&nbsp;to reveal the IP address of your server.</p>
<p><span><a href="http://your_domain.tld"><span style="text-decoration: underline;"><span>http://your_domain.tld</span></span></a></span>&nbsp;</p>
<p><a class="fancybox" id="img-Picture1" href="https://www.howtoforge.com/images/install_dokuwiki_in_debian_92/big/Picture1.png"><img src="https://www.howtoforge.com/images/install_dokuwiki_in_debian_92/Picture1.png" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>In order to install and access DowuWiki web admin panel backend and the frontend website via HTTPS protocol that will secure the traffic for your clients, issue the following command to enable Apache web server SSL module and SSL site configuration file.</p>
<p class="command">a2enmod&nbsp;ssl&nbsp;</p>
<p class="command">a2ensite&nbsp;default-ssl.conf</p>
<p>Next, open Apache default SSL site configuration file with a text editor and enable URL rewrite rules by adding the following lines of code after DocumentRoot directive. Run the following command:</p>
<p class="command">nano&nbsp;/etc/apache2/sites-enabled/default-ssl.conf</p>
<p><strong><em></em></strong>SSL&nbsp;site&nbsp;configuration&nbsp;file&nbsp;excerpt:</p>
<pre>&lt;Directory&nbsp;/var/www/html&gt;<br />&nbsp; Options&nbsp;+FollowSymlinks<br />&nbsp; AllowOverride&nbsp;All<br />&nbsp; Require&nbsp;all&nbsp;granted<br />&lt;/Directory&gt;</pre>
<p>Also,&nbsp;make&nbsp;the&nbsp;following&nbsp;change&nbsp;to&nbsp;VirtualHost&nbsp;line&nbsp;to make it look&nbsp;like the way it's shown&nbsp;in&nbsp;the excerpt below:</p>
<pre>&lt;VirtualHost&nbsp;*:443&gt;</pre>
<p><strong><a class="fancybox" id="img-Picture2" href="https://www.howtoforge.com/images/install_dokuwiki_in_debian_92/big/Picture2.png"><img src="https://www.howtoforge.com/images/install_dokuwiki_in_debian_92/Picture2.png" style="display: block; margin-left: auto; margin-right: auto;" /></a></strong></p>
<p></p>
<p>Close the SSL Apache file and open the /etc/apache2/sites-enabled/000-default.conf file for editing and add the same URL rewrite rules for SSL configuration file. Insert the lines of code after DocumentRoot statement as shown in the following example.</p>
<pre>&lt;Directory&nbsp;/var/www/html&gt;<br />&nbsp; Options&nbsp;+FollowSymlinks<br />&nbsp; AllowOverride&nbsp;All<br />&nbsp; Require&nbsp;all&nbsp;granted<br />&lt;/Directory&gt;</pre>
<p><strong><a class="fancybox" id="img-Picture3" href="https://www.howtoforge.com/images/install_dokuwiki_in_debian_92/big/Picture3.png"><img src="https://www.howtoforge.com/images/install_dokuwiki_in_debian_92/Picture3.png" style="display: block; margin-left: auto; margin-right: auto;" /></a></strong></p>
<p>Finally, restart Apache daemon to apply all rules configured so far and visit your domain via the HTTP protocol. Because you&rsquo;re using the automatically Self-Signed certificates pairs issued by Apache at installation, a certificate that is untrusted by the browser, an error warning should be displayed in the browser.</p>
<p class="command">systemctl&nbsp;restart&nbsp;apache2</p>
<p><span><a href="https://yourdomain.tld"><strong><span style="text-decoration: underline;"><b><span>https://yourdomain.tld</span></b></span></strong></a></span><strong><b>&nbsp;</b></strong></p>
<p><strong><a class="fancybox" id="img-Picture4" href="https://www.howtoforge.com/images/install_dokuwiki_in_debian_92/big/Picture4.png"><img src="https://www.howtoforge.com/images/install_dokuwiki_in_debian_92/Picture4.png" style="display: block; margin-left: auto; margin-right: auto;" /></a></strong></p>
<p>Accept the warning in order to accept the untrusted certificate and continue to be redirected to Apache default web page, as illustrated in the image below.</p>
<p style="text-align: center;"><a class="fancybox" id="img-Picture5" href="https://www.howtoforge.com/images/install_dokuwiki_in_debian_92/big/Picture5.png"><img src="https://www.howtoforge.com/images/install_dokuwiki_in_debian_92/Picture5.png" /></a></p>
<p>In case the UFW firewall application blocks incoming network connections to HTTPS port, you should add a new rule to allow HTTPS traffic to pass through firewall by issuing the following command.</p>
<p class="command">ufw&nbsp;allow&nbsp;&lsquo;WWW&nbsp;Full&rsquo;</p>
<p>or</p>
<p class="command">ufw&nbsp;allow&nbsp;443/tcp</p>
<p>If iptables is the default firewall application installed to protect your Debian system at the network level, add the following rule to allow port 443 inbound traffic in the firewall so that visitors can browse your domain name.</p>
<p class="command">iptables&nbsp;-I&nbsp;INPUT&nbsp;-p&nbsp;tcp&nbsp;--destination-port&nbsp;443&nbsp;-j&nbsp;ACCEPT</p>
<p class="command">netfilter-persistent&nbsp;save</p>
<p class="command">systemctl&nbsp;restart&nbsp;netfilter-persistent</p>
<p class="command">systemctl&nbsp;status&nbsp;netfilter-persistent</p>
<p>On the next step, we need to make some further changes to PHP default configuration file in order to assure that the following PHP variables are enabled and the PHP timezone setting is correctly configured and matches your system geographical location.&nbsp; Open /etc/php/7.0/apache2/php.ini file for editing and make sure that the following lines are setup as shown. Also, initially, make a backup of the PHP configuration file.</p>
<p class="command">cp&nbsp;/etc/php/7.0/apache2/php.ini{,.backup}</p>
<p class="command">nano&nbsp;/etc/php/7.0/apache2/php.ini</p>
<p><strong><b>&nbsp;</b></strong>Search,&nbsp;edit&nbsp;and&nbsp;change&nbsp;the&nbsp;following&nbsp;variables&nbsp;in&nbsp;<strong><b>php.ini</b></strong>&nbsp;configuration&nbsp;file:</p>
<pre><em><i>file_uploads&nbsp;=&nbsp;On<br />default_charset</i></em> <em><i>=&nbsp;UTF-8<br />memory_limit&nbsp;=&nbsp;128M<br />max_execution_time&nbsp;=&nbsp;300<br />upload_max_filesize&nbsp;=&nbsp;100M<br />short_open_tag&nbsp;=&nbsp;Off<br />output_buffering&nbsp;=&nbsp;Off<br />output_handler&nbsp;=<br />zlib.output_compression&nbsp;=&nbsp;Off<br />implicit_flush&nbsp;=&nbsp;Off<br />max_input_time&nbsp;=&nbsp;60<br />max_input_vars&nbsp;=&nbsp;10000<br />error_reporting&nbsp;=&nbsp;E_ALL&nbsp;&amp;&nbsp;~E_NOTICE<br />display_startup_errors&nbsp;=&nbsp;Off<br />log_errors&nbsp;=&nbsp;On<br />variables_order&nbsp;=&nbsp;&ldquo;EGPCS&rdquo;<br />register_argc_argv&nbsp;=&nbsp;Off<br />session.use_cookies&nbsp;=&nbsp;1<br />date.timezone&nbsp;=&nbsp;Europe/London</i></em></pre>
<p>Increase <em>upload_max_file_size</em> variable as suitable to support large file attachments and replace the time.zone variable accordingly to your physical time by consulting the list of time zones provided by PHP docs at the following link&nbsp;<span><a href="http://php.net/manual/en/timezones.php"><span style="text-decoration: underline;"><span>http://php.net/manual/en/timezones.php</span></span></a></span>&nbsp;</p>
<p>If you want to increase the load speed of your website pages via OPCache plugin available for PHP7, append the following OPCache settings at the bottom of the PHP interpreter configuration file, as detailed below:</p>
<pre>[opcache]<br /><em><i>opcache.enable=1 <br />opcache.enable_cli=1 <br />opcache.interned_strings_buffer=8 <br />opcache.max_accelerated_files=10000 <br />opcache.memory_consumption=128 <br />opcache.save_comments=1<br />opcache.revalidate_freq=1</i></em></pre>
<p>&nbsp;Close&nbsp;the&nbsp;<em>php.ini</em>&nbsp;configuration&nbsp;and&nbsp;restart&nbsp;apache&nbsp;daemon&nbsp;to&nbsp;apply&nbsp;the&nbsp;new&nbsp;changes&nbsp;by&nbsp;issuing&nbsp;the&nbsp;following&nbsp;command.</p>
<p class="command">systemctl&nbsp;restart&nbsp;apache2</p>
<p>Finally, create a PHP info file by executing the following command and check if the PHP time zone has been correctly configured by visiting the PHP info script file from a browser at the following URL, as illustrated in the below image. Scroll down to date setting to check PHP time zone configuration.</p>
<p class="command">echo&nbsp;'&lt;?php&nbsp;phpinfo();&nbsp;?&gt;'|&nbsp;tee&nbsp;/var/www/html/info.php</p>
<p><span><a href="https://domain.tld/info.php" target="_blank"><span style="text-decoration: underline;"><span></span></span>https://domain.tld/info.php</a> </span></p>
<p><span><span style="text-decoration: underline;"><span><a class="fancybox" id="img-Picture6" href="https://www.howtoforge.com/images/install_dokuwiki_in_debian_92/big/Picture6.png"><img src="https://www.howtoforge.com/images/install_dokuwiki_in_debian_92/Picture6.png" style="display: block; margin-left: auto; margin-right: auto;" /></a></span></span></span></p>
<h2 id="installnbspdokuwikinbsp">Install&nbsp;DokuWiki&nbsp;</h2>
<p>After all system requirements are met for installing your wiki documentation CMS, visit DokuWiki official download page at&nbsp;<a href="https://download.dokuwiki.org/" target="_blank">https://download.dokuwiki.org/</a> and grab the latest stable zip package compressed archive in your system by issuing the following command.</p>
<p class="command">wget<strong><b>&nbsp;</b></strong><span><a href="https://download.dokuwiki.org/src/dokuwiki/dokuwiki-stable.tgz"><span style="text-decoration: underline;"><span>https://download.dokuwiki.org/src/dokuwiki/dokuwiki-stable.tgz</span></span></a></span>&nbsp;</p>
<p>After the zip archive download finishes, extract the DokuWiki zip archive file to your current working directory and list the extracted files by issuing the following commands. Also, remove the default index.html file installed by Apache web server to webroot path and also delete the info.php file created earlier.</p>
<p class="command">tar&nbsp;xzvf&nbsp;dokuwiki-stable.tgz</p>
<p class="command">ls&nbsp;</p>
<p class="command">rm&nbsp;/var/www/html/index.html&nbsp;</p>
<p class="command">rm&nbsp;/var/www/html/info.php</p>
<p><strong></strong>The installation files of DokuWiki are located in your current working directory in dokuwiki-2017-20-19e directory. Issue the ls command to list the extracted directory files. Copy all the content of the extracted directory to your web server document root path by issuing the command below. Also, make sure you copy the hidden file .htaccess to HTTP server webroot path.</p>
<p class="command">ls&nbsp;dokuwiki-2017-02-19e/</p>
<p class="command">cp&nbsp;-rf&nbsp;dokuwiki-2017-02-19e/*&nbsp;/var/www/html/</p>
<p class="command">cp&nbsp;dokuwiki-2017-02-19e/.htaccess.dist&nbsp;/var/www/html/</p>
<p><strong></strong>Next, execute the following commands in order to grant Apache runtime user with full write permissions to the web root path. Use the ls command to list permissions for application&rsquo;s installed files located in the /var/www/html/ directory.</p>
<p class="command">chown&nbsp;-R&nbsp;www-data:www-data&nbsp;/var/www/html/</p>
<p class="command">ls&nbsp;&ndash;al&nbsp;/var/www/html/</p>
<p>Next, proceed with DokuWiki installation process by opening a browser and navigate your server&rsquo;s IP address or domain name or server FQDN via HTTPS protocol and open install.php script.</p>
<p><a href="https://yourdomain.tld/install.php%20" target="_blank"><span><span style="text-decoration: underline;"><span>https://yourdomain.tld</span></span></span></a><span style="text-decoration: underline;"><span><a href="https://yourdomain.tld/install.php%20" target="_blank">/install.php </a><br /></span></span></p>
<p>On the first installation script, add the name of your wiki platform and check Enable ACL. Supply a wiki superuser account name, the real name, and the email address of the superuser account, and choose a strong password to protect the superuser account. <br /><br />Next, select Public Wiki (read for everyone, write and upload for registered users) as your initial ACL policy and uncheck Allow users to register themselves in order to disable wiki registration process for visitors. Also, select your favorite content license from the presented options and uncheck the option to send anonymous data to DokuWiki developers once a month.</p>
<p>When you finish, hit on Save button to apply the configuration.</p>
<p><a class="fancybox" id="img-Picture7" href="https://www.howtoforge.com/images/install_dokuwiki_in_debian_92/big/Picture7.png"><img src="https://www.howtoforge.com/images/install_dokuwiki_in_debian_92/Picture7.png" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p></p>
<p>On the next screen, the installer will inform you that your previous configurations had been successfully saved to the DokuWiki configuration file located in your web server document root path, and you can delete the installation file.</p>
<p><a class="fancybox" id="img-Picture8" href="https://www.howtoforge.com/images/install_dokuwiki_in_debian_92/big/Picture8.png"><img src="https://www.howtoforge.com/images/install_dokuwiki_in_debian_92/Picture8.png" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Before logging in to your wiki CMS backend admin panel, return to the server console and issue the following commands to delete the installation file and secure DokuWiki system configuration files.</p>
<p class="command">rm&nbsp;-rf&nbsp;/var/www/html/install.php</p>
<p class="command">chown&nbsp;-R&nbsp;root:root&nbsp;/var/www/html/</p>
<p class="command">chown&nbsp;-R&nbsp;www-data:root&nbsp;/var/www/html/data/</p>
<p class="command">chown&nbsp;-R&nbsp;www-data:root&nbsp;/var/www/html/lib/plugins/</p>
<p class="command">chown&nbsp;-R&nbsp;www-data:root&nbsp;/var/www/html/lib/tpl/</p>
<p class="command">chown&nbsp;-R&nbsp;www-data:root&nbsp;/var/www/html/conf/local.php*</p>
<p class="command">chown&nbsp;-R&nbsp;www-data:root&nbsp;/var/www/html/conf/users.auth.php</p>
<p class="command">chown&nbsp;-R&nbsp;www-data:root&nbsp;/var/www/html/conf/acl.auth.php</p>
<p class="command">chown&nbsp;-R&nbsp;www-data:root&nbsp;/var/www/html/conf/plugins.local.php*</p>
<p>In order to visit your wiki application frontend, just navigate to your server IP address or domain name via HTTPS protocol and the default DokuWiki will be displayed as illustrated in the below screenshot.</p>
<p><span><a href="https://yourdomain.tld"><span style="text-decoration: underline;"><span></span></span></a><a href="https://yourdomain.tld" target="_blank">https://yourdomain.tld </a></span></p>
<p><span><span style="text-decoration: underline;"><span><a class="fancybox" id="img-Picture9" href="https://www.howtoforge.com/images/install_dokuwiki_in_debian_92/big/Picture9.png"><img src="https://www.howtoforge.com/images/install_dokuwiki_in_debian_92/Picture9.png" style="display: block; margin-left: auto; margin-right: auto;" /></a></span></span></span></p>
<p>To manage the DokuWiki platform, click on top Log In link and use the credentials configured during the installation process in order to log in to DokuWiki backend admin panel - as shown in the screenshot below.</p>
<p><a class="fancybox" id="img-Picture10" href="https://www.howtoforge.com/images/install_dokuwiki_in_debian_92/big/Picture10.png"><img src="https://www.howtoforge.com/images/install_dokuwiki_in_debian_92/Picture10.png" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p></p>
<p>To further configure your wiki platform, hit on top Admin button and use the Administration links to manage users, ACL, extensions, template style settings or other custom settings.</p>
<p><a class="fancybox" id="img-Picture11" href="https://www.howtoforge.com/images/install_dokuwiki_in_debian_92/big/Picture11.png"><img src="https://www.howtoforge.com/images/install_dokuwiki_in_debian_92/Picture11.png" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p></p>
<p>Finally, to force visitors to browse the wiki website and to securely access the backend interface via HTTPS protocol in order to encrypt the traffic between the server and client browsers, return to your server&rsquo;s terminal and open the .htaccess file located in your website document root path, by issuing the following commands.</p>
<p class="command">cp&nbsp;/var/www/html/.htaccess.dist&nbsp;/var/www/html/.htaccess</p>
<p class="command">nano&nbsp;/var/www/html/.htaccess</p>
<p>Then, edit the .htaccess file and at the bottom of the file, you can change the native PHP server settings with the below configurations. Modify the PHP settings to match your own server resources and configurations.</p>
<p><strong><b>&nbsp;.htaccess</b></strong>&nbsp;file&nbsp;excerpt:</p>
<pre>#&nbsp;Modify&nbsp;PHP&nbsp;settings<br /><em><i>php_value&nbsp;session.use_trans_sid&nbsp;0<br />php_value&nbsp;register_globals&nbsp;1<br />php_value&nbsp;upload_max_filesize&nbsp;100M<br />php_value&nbsp;post_max_size&nbsp;100M</i></em></pre>
<p>Finally,&nbsp;add&nbsp;the following rules&nbsp;in the .htaccess&nbsp;file&nbsp;in&nbsp;order&nbsp;to&nbsp;automatically&nbsp;redirect&nbsp;domain&nbsp;traffic&nbsp;to&nbsp;HTTPS.</p>
<pre><em><i>#&nbsp;Redirect&nbsp;to&nbsp;HTTPS&nbsp;for&nbsp;all&nbsp;pages&nbsp;including&nbsp;the&nbsp;main&nbsp;web&nbsp;page<br /></i></em><em><i>&lt;IfModule&nbsp;mod_rewrite.c&gt;<br />RewriteEngine&nbsp;On<br />RewriteCond&nbsp;%{HTTPS}&nbsp;off<br />RewriteRule&nbsp;(.*)&nbsp;https://%{SERVER_NAME}/$1&nbsp;[R,L]<br /><br />Options&nbsp;-Indexes<br />&lt;/IfModule&gt;</i></em></pre>
<p><strong><em><b><i>&nbsp;</i></b></em></strong>In case you want to redirect to https only the login, profile and admin pages, replace the above redirect rules with the ones shown below. In this case, the main page of your wiki website will not be redirected to https protocol.</p>
<pre><em><i>#&nbsp;Switch&nbsp;to&nbsp;HTTPS&nbsp;on&nbsp;login,&nbsp;profile&nbsp;and&nbsp;admin&nbsp;actions<br /></i></em><em><i>RewriteEngine&nbsp;On<br />RewriteCond&nbsp;%{HTTPS}&nbsp;!on<br />RewriteCond&nbsp;%{QUERY_STRING}&nbsp;do=(log|profile|admin)<br />RewriteRule&nbsp;^(.*)&nbsp;https://%{HTTP_HOST}/$1&nbsp;[R,QSA,L,NE]</i></em></pre>
<p>That&rsquo;s all! You have successfully installed and configured DokuWiki platform in Debian 9.2. However, because the Apache HTTP server uses Self-Signed certificates to encrypt the traffic between the server and visitors' browsers, a warning message will always be generated and displayed in their browsers. This warning is bad for your website reputation and SEO. In this case, you should buy a certificate issued by a trusted Certificate Authority or get a free certificate pair from Let&rsquo;s Encrypt CA.<br /><br />For other custom configurations regarding DokuWiki, visit the documentation page at the following address: <a href="https://www.dokuwiki.org/dokuwiki">https://www.dokuwiki.org/dokuwiki</a></p>
<div style="height:30px; margin-top:20px;">
<p style="text-align:right;"><img src="/images/pdficon_small.png" /> <a href="/subscription/">view as pdf</a> | <img src="/images/print.gif" /> <a href="/subscription/">print</a></p>
</div>
<div style="height:30px; margin-top:20px;">
<div style="float:left;"><b>Share this page:</b></div>
<div style="float:left; margin-left:10px;"><a href="https://twitter.com/share" class="twitter-share-button" data-count="horizontal" data-lang="en-US" data-url="https://www.howtoforge.com/tutorial/debian-dokuwiki-apache-installation/" data-via="howtoforgecom">Tweet</a> <a class="twitter-follow-button" href="https://twitter.com/howtoforgecom">Follow</a></div>
<div style="float:left; margin-left:20px;"><fb:like href="https://www.howtoforge.com/tutorial/debian-dokuwiki-apache-installation/" layout="button_count" action="recommend" font="trebuchet ms" colorscheme="light"></fb:like></div>
<div style="float:left; margin-left:50px;"><div class="g-plusone" data-size="medium" data-count="true" data-href="https://www.howtoforge.com/tutorial/debian-dokuwiki-apache-installation/"></div></div>
</div>
</div>


<div id="htfContentPagePaging">
<h2>Suggested articles</h2>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-3043223216276099" data-ad-slot="8940054090"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>


<div id="htfContentPageComment">
<a name="comments"></a>
<h2>0 Comment(s)</h2>

<div id="commentform">
<div class="commentContainerHead" style="font-size:18px;">Add comment</div>
<div class="commentContainer">
<form method="post" action="/tutorial/debian-dokuwiki-apache-installation/#comments">
<input type="hidden" name="reply_to" id="reply-to-comment" value="0" />
<div id="commentFormDetail">
<div style="width:48%; float:left; margin-right:3%">
<label for="commentname">Name *</label>
<input id="commentname" name="commentname" value="" />
</div>
<div style="width:48%;float:left;">
<label for="commentname">Email *</label>
<input id="commentemail" name="commentemail" value="" />
</div>
<div style="clear:both;"></div>
</div>
<textarea id="commentedit" name="commentedit" style="width:auto;"></textarea>
<div>
<div style="float:left;">
<div class="g-recaptcha" data-sitekey="6LdX9fUSAAAAALWwVoPdeXScMSketz4npF-0QcQ1"></div>
<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en">
      </script>
</div>
<div style="margin-top:10px;margin-bottom:10px;">
<input type="submit" name="submit" class="button primary" style="float:right;" value="Submit comment">
</div>
<div style="clear:both;"></div>
</div>

<script>
	tinymce.init({
		selector: "textarea#commentedit",
		theme: "modern",
		height: 100,
		apply_source_formatting : true,
		remove_linebreaks : false,
		menubar : false,
		/*auto_focus : "commentedit",*/
		plugins: [
		"link"
		],
		/*plugins: [
			"advlist autolink link image lists charmap print preview hr anchor pagebreak spellchecker",
			"searchreplace wordcount visualblocks visualchars code fullscreen insertdatetime media nonbreaking",
			"save table contextmenu directionality emoticons template paste textcolor"
		],*/
		content_css: "https://www.howtoforge.com/themes/howtoforge/css/custom.css",
		toolbar: "undo redo | bold italic link", 
		/*style_formats: [
			{title: 'Bold text', inline: 'b'},
			{title: 'Red text', inline: 'span', styles: {color: '#ff0000'}},
			{title: 'Red header', block: 'h1', styles: {color: '#ff0000'}},
			{title: 'Example 1', inline: 'span', classes: 'example1'},
			{title: 'Example 2', inline: 'span', classes: 'example2'},
			{title: 'Table styles'},
			{title: 'Table row 1', selector: 'tr', classes: 'tablerow1'}
		]*/
	}); 
	</script>
</form>
</div>
</div>

</div>

<div class="breadBoxBottom">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Tutorials</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/tutorial/debian-dokuwiki-apache-installation/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to Install DokuWiki with Apache on Debian 9</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
<script>
<!--

$(document).on('click', 'a.reply-to', function(e) {
	e.preventDefault();
	
	var self = $(this);
	var cid = self.attr('data-comment');
	console.log(cid);
	if(!cid) return this;
	
	$('#commentform').insertAfter('#comment' + cid);
	$('#reply-to-comment').val(cid);
	/*tinyMCE.activeEditor.focus();*/
	var textareaId = 'commentedit';
	tinyMCE.get(textareaId).remove();
	tinyMCE.execCommand("mceAddEditor", false, textareaId);
	tinyMCE.activeEditor.focus();
});
//-->
</script>
<div style="margin-top:10px;margin-bottom:10px;text-align:center;">

<center>


<script type='text/javascript'>
GA_googleFillSlot("howtoforge_com_article_leaderboard_b_728x90");
</script>

</center>
</div>


<form action="/community/login/login?redirect=/tutorial/debian-dokuwiki-apache-installation/" method="post" class="xenForm eAuth" id="login" style="display:none">
<ul id="eAuthUnit">
<li><a href="/community/register/facebook?reg=1" class="fbLogin" tabindex="110"><span>Log in with Facebook</span></a></li>
<li><a href="/community/register/twitter?reg=1" class="twitterLogin" tabindex="110"><span>Log in with Twitter</span></a></li>
<li><span class="googleLogin GoogleLogin JsOnly" tabindex="110" data-client-id="198773272284-b6tfk0c28bje81p774prrcrkq9jb3o44.apps.googleusercontent.com" data-redirect-url="/community/register/google?code=__CODE__&amp;csrf=hVMXbW_3rnrmq4Em"><span>Log in with Google</span></span></li>
</ul>
<div class="ctrlWrapper">
<dl class="ctrlUnit">
<dt><label for="LoginControl">Your name or email address:</label></dt>
<dd><input type="text" name="login" id="LoginControl" class="textCtrl" tabindex="101" /></dd>
</dl>
<dl class="ctrlUnit">
<dt>
<label for="ctrl_password">Do you already have an account?</label>
</dt>
<dd>
<ul>
<li><label for="ctrl_not_registered"><input type="radio" name="register" value="1" id="ctrl_not_registered" tabindex="105" />
No, create an account now.</label></li>
<li><label for="ctrl_registered"><input type="radio" name="register" value="0" id="ctrl_registered" tabindex="105" checked="checked" class="Disabler" />
Yes, my password is:</label></li>
<li id="ctrl_registered_Disabler">
<input type="password" name="password" class="textCtrl" id="ctrl_password" tabindex="102" />
<div class="lostPassword"><a href="/community/lost-password/" tabindex="106">Forgot your password?</a></div>
</li>
</ul>
</dd>
</dl>
<dl class="ctrlUnit submitUnit">
<dt></dt>
<dd>
<input type="submit" class="button primary" value="Log in" tabindex="104" data-loginPhrase="Log in" data-signupPhrase="Sign up" />
<label for="ctrl_remember" class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_remember" tabindex="103" /> Stay logged in</label>
</dd>
</dl>
</div>
<input type="hidden" name="cookie_check" value="1" />
<input type="hidden" name="redirect" value="/community/" />
<input type="hidden" name="_xfToken" value="" />
</form>

</div>
</div>

<aside>
<div class="sidebar">
<div class="section loginButton">
<div class="secondaryContent">
<label for="LoginControl" id="SignupButton"><a href="/community/login/" class="inner">Sign up now!</a></label>
</div>
</div>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-2">

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent socialMediaIcon">
<a href="https://twitter.com/howtoforgecom" target="_blank"><img src="/images/socialmedia/64x64/twitter.png" /></a>
<a href="https://www.facebook.com/howtoforge" target="_blank"><img src="/images/socialmedia/64x64/facebook.png" /></a>
<a href="https://plus.google.com/+howtoforge/posts" target="_blank"><img src="/images/socialmedia/64x64/googleplus.png" /></a>
<a href="https://www.howtoforge.com/feed" target="_blank"><img src="/images/socialmedia/64x64/rss.png" /></a>
</div>
</div>
</div>
<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Tutorial Info</p>
<div class="pairsJustified">
<dl class="discussionCount">
<dt>Author:</dt>
<dd>Matt Vas</dd>
</dl>
<dl class="discussionCount">
<dt>Published:</dt>
<dd>Mar 20, 2018</dd>
</dl>
<dl class="discussionCount">
<dt>Tags:</dt>
<dd><a href='/tutorials/apache/' rel='tag'>apache</a>, <a href='/tutorials/linux/' rel='tag'>linux</a>, <a href='/tutorials/web+server/' rel='tag'>web server</a></dd>
</dl>
</div>
</div>
</div>
<script src="//m.servedby-buysellads.com/monetization.js" type="text/javascript"></script>
<div class="native-sidebar"></div>
<script>
  (function(){
    if(typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('default', 'CKYD55QU', 'placement:howtoforge', {
      target: '.native-sidebar',
      align: 'horizontal',
      disable_css: 'true'
    });
      }
  })();
</script>

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent">
<p class="mnuinfo mnushare">Share This Page</p>
<div class="tweet shareControl">
<a href="https://twitter.com/share" class="twitter-share-button" data-count="horizontal" data-lang="en-US" data-url="https://www.howtoforge.com/tutorial/debian-dokuwiki-apache-installation/" data-via="howtoforgecom">Tweet</a> <a class="twitter-follow-button" data-show-screen-name="false" href="https://twitter.com/howtoforgecom">Follow</a>
</div>
<div class="facebookLike shareControl">
<fb:like href="https://www.howtoforge.com/tutorial/debian-dokuwiki-apache-installation/" layout="button_count" action="recommend" font="trebuchet ms" colorscheme="light"></fb:like>
</div>
<div class="plusone shareControl">
<div class="g-plusone" data-size="medium" data-count="true" data-href="https://www.howtoforge.com/tutorial/debian-dokuwiki-apache-installation/"></div>
</div>
</div>
</div>
</div>



<script type="text/javascript">
    google_ad_client = "ca-pub-3043223216276099";
    google_ad_slot = "6709042890";
    google_ad_width = 300;
    google_ad_height = 600;
</script>

<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>


<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Popular Tutorials</p>
<div class="pairsJustified">
<ul>
<li><a href="/tutorial/perfect-server-debian-9-stretch-apache-bind-dovecot-ispconfig-3-1/">The Perfect Server - Debian 9 (Stretch) with Apache, BIND, Dovecot, PureFTPD and ISPConfig 3.1</a></li>
<li><hr /></li>
<li><a href="/linux-nm-command/">Linux nm Command Tutorial for Beginners (10 Examples)</a></li>
<li><hr /></li>
<li><a href="/setting-changing-resetting-mysql-root-passwords">Setting, Changing And Resetting MySQL Root Passwords</a></li>
<li><hr /></li>
<li><a href="/tutorial/ispconfig-automated-install-script/">ISPConfig 3.1: Automated installation on Debian and Ubuntu</a></li>
<li><hr /></li>
<li><a href="/tutorial/linux-grep-command/">How to use grep to search for strings in files on the shell</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-use-ftp-on-the-linux-shell/">How to use the Linux ftp command to up- and download files on the shell</a></li>
<li><hr /></li>
<li><a href="/tutorial/perfect-server-ubuntu-16.04-with-apache-php-myqsl-pureftpd-bind-postfix-doveot-and-ispconfig/">The Perfect Server - Ubuntu 16.04 (Xenial Xerus) with Apache, PHP, MySQL, PureFTPD, BIND, Postfix, Dovecot and ISPConfig 3.1</a></li>
<li><hr /></li>
<li><a href="/tutorial/ubuntu-goaccess-apache-log-analyzer/">Install GoAccess Apache Log Analyzer Tool on Ubuntu 16.04</a></li>
<li><hr /></li>
<li><a href="/linux_lvm">A Beginner's Guide To LVM</a></li>
<li><hr /></li>
<li><a href="/linux-man-command/">Linux man Command Tutorial for Beginners (8 Examples)</a></li>
<li><hr /></li>
</ul>
</div>
</div>
</div>
</div>
</div>
</aside>
</div>
</div>
</div>
<footer>
<div class="footer">
<div class="pageWidth">
<div class="pageContent">
<div class='skin_branding'><a href="http://www.xenfocus.com" rel="nofollow">Xenforo skin</a><span> by <a href="http://www.xenfocus.com" rel="nofollow">Xenfocus</a></span></div>
<ul class="footerLinks">
<li><a href="/contribute/">Contribute</a></li>
<li><a href="/community/misc/contact">Contact</a></li>
<li><a href="/community/help/">Help</a></li>
<li><a href="/imprint/">Imprint</a></li>
<li><a href="/" class="homeLink">Tutorials</a></li>
<li><a href="#navigation" class="topLink">Top</a></li>
<li><a href="/feed" rel="alternate" class="globalFeed" target="_blank" title="RSS-Feed for Howtoforge">RSS-Feed</a></li>
</ul>
<span class="helper"></span>
</div>
</div>
</div>
<div class="footerLegal">
<div class="pageWidth">
<div class="pageContent">
<ul id="legal">
<li><a href="/community/help/terms">Terms</a></li>
</ul>
<div id="copyright"><a href="https://www.howtoforge.com" class="concealed">Howtoforge <span>&copy; projektfarm GmbH.</span></a></div>
<span class="helper"></span>
</div>
</div>
</div>
</footer>
<div style="height:100px;"></div>
<script>

jQuery.extend(true, XenForo,
{
	visitor: { user_id: 0 },
	serverTimeInfo:
	{
		now: 1409831907,
		today: 1409781600,
		todayDow: 4
	},
	_lightBoxUniversal: "0",
	_enableOverlays: "1",
	_animationSpeedMultiplier: "1",
	_overlayConfig:
	{
		top: "10%",
		speed: 200,
		closeSpeed: 100,
		mask:
		{
			color: "rgb(0, 0, 0)",
			opacity: "0.6",
			loadSpeed: 200,
			closeSpeed: 100
		}
	},
	_ignoredUsers: [],
	_loadedScripts: {"node_list":true,"node_category":true,"node_forum":true,"sidebar_share_page":true,"wf_default":true,"bbm_buttons":true,"login_bar":true,"twitter":true},
	_cookieConfig: { path: "/", domain: "", prefix: "xf_"},
	_csrfToken: "",
	_csrfRefreshUrl: "/community/login/csrf-token-refresh",
	_jsVersion: "303ae0ca"
});
jQuery.extend(XenForo.phrases,
{
	cancel: "Cancel",

	a_moment_ago:    "A moment ago",
	one_minute_ago:  "1 minute ago",
	x_minutes_ago:   "%minutes% minutes ago",
	today_at_x:      "Today at %time%",
	yesterday_at_x:  "Yesterday at %time%",
	day_x_at_time_y: "%day% at %time%",

	day0: "Sunday",
	day1: "Monday",
	day2: "Tuesday",
	day3: "Wednesday",
	day4: "Thursday",
	day5: "Friday",
	day6: "Saturday",

	_months: "January,February,March,April,May,June,July,August,September,October,November,December",
	_daysShort: "Sun,Mon,Tue,Wed,Thu,Fri,Sat",

	following_error_occurred: "The following error occurred",
	server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
	logging_in: "Logging in",
	click_image_show_full_size_version: "Click this image to show the full-size version.",
	show_hidden_content_by_x: "Show hidden content by {names}"
});

// Facebook Javascript SDK
XenForo.Facebook.appId = "";
XenForo.Facebook.forceInit = true;

/*
document.addEventListener('DOMContentLoaded', function(event) {
  cookieChoices.showCookieConsentBar('Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.',
  'OK');
});
*/

$(document).ready(function() {
	$("a.fancybox").fancybox();
});

</script>
<script async type="text/javascript" src="//cdn.fancybar.net/ac/fancybar.js?zoneid=1502&serve=C6ADVKE&placement=howtoforge" id="_fancybar_js"></script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2155872-1', 'auto');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');

</script>
</body>
</html>