<!DOCTYPE html>
<html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs LoggedOut Sidebar Responsive" xmlns:fb="http://www.facebook.com/2008/fbml">
<head>
<meta charset="utf-8" />
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<base href="https://www.howtoforge.com" />
<script>
			var _b = document.getElementsByTagName('base')[0], _bH = "https://www.howtoforge.com/install-adminer-database-management-tool-on-debian-10/";
			if (_b && _b.href != _bH) _b.href = _bH;
		</script>
<title>Install Adminer Database Management Tool on Debian 10</title>
<meta name="description" content="Managing database systems like MySQL, PostgreSQL, Oracle, and SQLite form the web-based UI is easier than using the command-line tool. Adminer is one ... " />
<meta property="og:title" content="Install Adminer Database Management Tool on Debian 10">
<meta property="og:description" content="Managing database systems like MySQL, PostgreSQL, Oracle, and SQLite form the web-based UI is easier than using the command-line tool. Adminer is one ... ">
<meta property="og:site_name" content="HowtoForge">
<meta property="og:type" content="article">
<meta property="og:image" content="https://www.howtoforge.com/images/featured/debian-adminer-database-manager.jpg">
<meta property="og:image:secure_url" content="https://www.howtoforge.com/images/featured/debian-adminer-database-manager.jpg" />
<meta property="og:image:alt" content="Install Adminer Database Management Tool on Debian 10" />
<meta name="twitter:image" content="https://www.howtoforge.com/images/featured/debian-adminer-database-manager.jpg" />
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="@howtoforgecom">
<meta name="twitter:creator" content="@howtoforgecom">
<meta name="twitter:title" content="Install Adminer Database Management Tool on Debian 10">
<meta name="twitter:description" content="Managing database systems like MySQL, PostgreSQL, Oracle, and SQLite form the web-based UI is easier than using the command-line tool. Adminer is one ... ">
<link rel="alternate" href="https://www.howtoforge.com/install-adminer-database-management-tool-on-debian-10/" hreflang="en" />
<link rel="canonical" href="https://www.howtoforge.com/tutorial/install-adminer-database-management-tool-on-debian-10/" />
<link rel="amphtml" href="https://www.howtoforge.com/install-adminer-database-management-tool-on-debian-10/amp/" />
<script type="application/ld+json">
{
  "@context" : "http://schema.org",
  "@type" : "Article",
  "name" : "Install Adminer Database Management Tool on Debian 10",
  "author" : {
    "@type" : "Person",
    "name" : "Hitesh Jethva"
  },
  "articleSection" : "debian,mysql",
  "url" : "https://www.howtoforge.com/install-adminer-database-management-tool-on-debian-10/",
  "publisher" : {
    "@type" : "Organization",
    "name" : "Howtoforge"
  }
}
</script>
<noscript><style>.JsOnly, .jsOnly { display: none !important; }</style></noscript>
<link rel="stylesheet" href="/community/styles/executive/xenfocus/icons/css/font-awesome.min.css" />
<link href='//fonts.googleapis.com/css?family=Open+Sans:400,700' rel='stylesheet' type='text/css' />
<link href="/themes/howtoforge/templates/xf.css" rel="stylesheet">
<script src="/js/jquery/jquery-1.11.3.min.js"></script>
<script src="/community/js/xenforo/xenforo.js?_v=303ae0ca"></script>
<script src="/community/js/bbm/zloader.js?_v=303ae0ca"></script>
<script type="text/javascript" src="/js/fancybox/jquery.mousewheel-3.0.4.pack.js"></script>
<script type="text/javascript" src="/js/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
<link rel="stylesheet" type="text/css" href="/js/fancybox/jquery.fancybox-1.3.4.css" media="screen" />
<link href="/themes/howtoforge/templates/style.min.css" rel="stylesheet">
<link rel="alternate" type="application/rss+xml" title="RSS-Feed für Howtoforge" href="/feed.rss" />
<script src="/js/tinymce_4.1.7/tinymce.min.js"></script>
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/skin.min.css" as="style" />
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/content.min.css" as="style" />
<link rel="preload" href="/themes/howtoforge/css/custom.css" as="style" />
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/fonts/tinymce.woff" as="font">

<script type="text/javascript">
var gaProperty = 'UA-2155872-1';
var disableStr = 'ga-disable-' + gaProperty;
if (document.cookie.indexOf(disableStr + '=true') > -1) {
window[disableStr] = true;
}
function gaOptout() {
document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
window[disableStr] = true;
alert('Google Ananlyitics tracking has been disabled in this browser.');
}
</script>
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
	googletag.defineSlot('/1030080/howtoforge_com_list_sidebar_top', [300, 250], 'div-gpt-ad-1527185271042-4').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_list_content_middle', [[300, 250], [336, 280]], 'div-gpt-ad-1527185271042-5').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_a_300x250', [300, 250], 'div-gpt-ad-1527185271042-6').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_b_300x250', [300, 250], 'div-gpt-ad-1527185271042-7').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_leaderboard_b_728x90', [728, 90], 'div-gpt-ad-1527185271042-1').addService(googletag.pubads());
	googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-3043223216276099",
          enable_page_level_ads: true
     });
</script>


<script src="//m.servedby-buysellads.com/monetization.js" type="text/javascript"></script>


<script type="text/javascript">
    window.cookieconsent_options = {"message":"This website uses cookies to ensure you get the best experience on our website, analyze site traffic and show you relevant ads.","dismiss":"Got it!","learnMore":"More info","link":"https://www.howtoforge.com/community/help/cookies","theme":"dark-bottom"};
</script>
<script type="text/javascript" src="/js/cookieconsent.latest.min.js"></script>

</head>
<body>
<div id="loginBar">
<div class="pageWidth">
<div class="pageContent">
<h3 id="loginBarHandle">
<label for="LoginControl"><a href="/community/login/" class="concealed noOutline">Log in or Sign up</a></label>
</h3>
<span class="helper"></span>
</div>
</div>
</div>
<header>
<div id="header">
<div id="logoBlock">
<div class="pageWidth">
<div class="pageContent">
<div id="logo"><a href="/">
<span></span>
<img src="/images/howtoforge_logo_trans.gif" alt="Howtoforge" style="margin-left:20px;" />
</a></div>
<span class="helper"></span>
</div>
</div>
</div>
<div id="navigation" class="pageWidth withSearch">
<div class="pageContent">
<nav>
<div class="navTabs">
<ul class="publicTabs">

<li class="navTab forums selected">
<a href="/" class="navLink">Tutorials</a>
<div class="tabLinks forumsTabLinks">
<ul class="secondaryContent blockLinksList">
<li><a href="/search/">Tutorial search</a></li>
</ul>
</div>
</li>
<li class="navTab forums PopupClosed">
<a href="/tutorials/" class="navLink">Tags</a>
</li>
<li class="navTab forums PopupClosed"><a href="/community/" class="navLink">Forums</a></li>
<li class="navTab forums PopupClosed"><a href="/linux-commands/" class="navLink">Linux Commands</a></li>
<li class="navTab forums PopupClosed"><a href="/subscription/" class="navLink">Subscribe</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.ispconfig.org" class="navLink">ISPConfig</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.lxer.com" class="navLink">News</a></li>
</ul>
</div>
<span class="helper"></span>
</nav>
</div>
</div>
<div id="searchBar" class="pageWidth">
<span id="QuickSearchPlaceholder" title=" Search..."> Search</span>
<fieldset id="QuickSearch">
<form action="/" method="post" class="formPopup">
<div class="primaryControls">

<input type="search" name="q" value="" class="textCtrl" placeholder="Search..." results="0" title="Enter your search and hit enter..." id="QuickSearchQuery" />

</div>
<input type="hidden" name="_xfToken" value="" />
</form>
</fieldset>
</div>
</div>
</header>
<div id="content" class="forum_list">
<div class="pageWidth">
<div class="pageContent">

<div class="mainContainer">
<div class="mainContent">

<div class="breadBoxTop">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Home</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/install-adminer-database-management-tool-on-debian-10/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Install Adminer Database Management Tool on Debian 10</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>

<div id="htfContentPage">
<div class="bsa-apiads"><a href="https://ispprotect.com/?pk_campaign=htftxt" target="_blank" rel="nofollow">Scan your Web-Server for Malware with ISPProtect now. Get Free Trial.</a></div>
<article>
<h1>Install Adminer Database Management Tool on Debian 10</h1>
<div class="contributeEdit" style="float:right; width:450px; max-width:100%;">
<div id="tocContainer">
<h3>On this page</h3>
<ol class="toc">
<li><a href="#prerequisites">Prerequisites</a></li>
<li><a href="#getting-started">Getting Started</a></li>
<li><a href="#install-lamp-server">Install LAMP Server</a></li>
<li><a href="#secure-mariadb-installation">Secure MariaDB Installation</a></li>
<li><a href="#install-adminer">Install Adminer</a></li>
<li><a href="#access-adminer-dashboard">Access Adminer Dashboard</a></li>
<li><a href="#enable-ssl-for-adminer-and-get-a-free-ssl-certificate-from-lets-encrypt">Enable SSL for Adminer and get a free SSL Certificate from Let's Encrypt</a></li>
<li><a href="#conclusion">Conclusion</a></li>
</ol>
</div>
</div>
<p>Managing database systems like MySQL, PostgreSQL, Oracle, and SQLite form the web-based UI is easier than using the command-line tool. Adminer is one of the best full-featured database management tool written in PHP. It is very similar to phpMyAdmin that can be used to manage MySQL, SQLite, Oracle, PostgreSQL databases. Adminer is a simple and user-friendly database management tool compared to other tools.</p>
<p><strong>Features </strong></p>
<ul>
<li>Multi-language support.</li>
<li>Supports various database systems including, MySQL, PostgreSQL, Oracle, Elasticsearch, MongoDB and many more.</li>
<li>Export and Import databases and tables.</li>
<li>Add, remove and modify databases and tables.</li>
<li>Run SQL queries from a text file.</li>
<li>Display and kill processes.</li>
<li>Extend the functionality using plugins.</li>
</ul>
<p>In this tutorial, we will show you how to install the Adminer database management tool on Debian 10.</p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;">

<div id='div-gpt-ad-1527185271042-6' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-6'); });
</script>
</div>
</div>
<h2 id="prerequisites">Prerequisites</h2>
<ul>
<li>A server running Debian 10.</li>
<li>A root password is configured on your server.</li>
</ul>
<h2 id="getting-started">Getting Started</h2>
<p>Before starting, it is recommended to update your server with the latest version using the following command:</p>
<pre class="command"><code spellcheck="false">apt-get update -y<br /> apt-get upgrade -y</code></pre>
<p>Once your server is updated, restart it to implement the changes.</p>
<h2 id="install-lamp-server">Install LAMP Server</h2>
<p>First, Adminer requires LAMP server installed in your server. You can install LAMP server using the following command:</p>
<pre class="command"><code spellcheck="false">apt-get install apache2 php libapache2-mod-php php-curl php-cli php-mysql php-gd mariadb-server -y</code></pre>
<p>Once installed, start the Apache and MariaDB service and enable them to start after system reboot with the following command:</p>
<pre class="command"><code spellcheck="false">systemctl start apache2<br /> systemctl start mariadb<br /> systemctl enable apache2<br /> systemctl enable mariadb</code></pre>
<p>Once you are done, you can proceed to the next step.</p>
<h2 id="secure-mariadb-installation">Secure MariaDB Installation</h2>
<p>By default, MariaDB is not secured. So you will need to secure it by running the mysql_secure_installation script.</p>
<pre class="command"><code spellcheck="false">mysql_secure_installation</code></pre>
<p>Answer all questions as shown below:</p>
<pre>Enter current password for root (enter for none): 
Set root password? [Y/n] Y
Remove anonymous users? [Y/n] Y   
Disallow root login remotely? [Y/n] Y
Remove test database and access to it? [Y/n] Y
Reload privilege tables now? [Y/n] Y
</pre>
<p>Once the MariaDB is secured, you will need to set the root password for MariaDB.</p>
<p>First, log in to MariaDB shell with the following command:</p>
<pre class="command"><code spellcheck="false">mysql</code></pre>
<p>Next, set password for root user with the following command:</p>
<pre class="command"><code spellcheck="false">MariaDB [(none)]&gt; SET PASSWORD FOR 'root'@'localhost' = PASSWORD("newpassword");</code></pre>
<p>Next, flush the privileges and exit from the MariaDB shell with the following command:</p>
<pre class="command"><code spellcheck="false">MariaDB [(none)]&gt; flush privileges;<br /> MariaDB [(none)]&gt; exit;</code></pre>
<p>Once you are finished, you can proceed to the next step.</p>
<h2 id="install-adminer">Install Adminer</h2>
<p>By default, Adminer is not available in the Debian 10 default repository. So, you will need to download the Adminer installation file from their official website. You can download it to the Apache web root directory with the following command:</p>
<pre class="command"><code spellcheck="false">wget "http://www.adminer.org/latest.php" -O /var/www/html/adminer.php</code></pre>
<p>Once the download is completed, change the permission of the downloaded file with the following command:</p>
<pre class="command"><code spellcheck="false">chown -R www-data:www-data /var/www/html/adminer.php<br /> chmod 755 /var/www/html/adminer.php</code></pre>
<p>Once you are done, you can proceed to the next step.</p>
<h2 id="access-adminer-dashboard">Access Adminer Dashboard</h2>
<p>Now, open your web browser and type the URL <span class="highlight">http://your-server-ip/adminer.php</span>. You will be redirected to the Adminer login page:</p>
<p><a class="fancybox" id="img-page1" href="https://www.howtoforge.com/images/install_adminer_database_management_tool_on_debian_10/big/page1.png"><img src="https://www.howtoforge.com/images/install_adminer_database_management_tool_on_debian_10/page1.png" alt="Adminer Login" width="750" height="348" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Provide your MariaDB root username, password and click on the <strong>Login</strong> button. You should see the Adminer dashboard in the following page:</p>
<p><a class="fancybox" id="img-page2" href="https://www.howtoforge.com/images/install_adminer_database_management_tool_on_debian_10/big/page2.png"><img src="https://www.howtoforge.com/images/install_adminer_database_management_tool_on_debian_10/page2.png" alt="Adminer Database Management Tool" width="750" height="378" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Now, click on the <strong>localhost</strong> button on the top screen, you should see the following page:</p>
<p><a class="fancybox" id="img-page3" href="https://www.howtoforge.com/images/install_adminer_database_management_tool_on_debian_10/big/page3.png"><img src="https://www.howtoforge.com/images/install_adminer_database_management_tool_on_debian_10/page3.png" alt="Select database" width="750" height="288" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Now, click on the "<strong>Create Database</strong>" button. You should see the following page:</p>
<p><a class="fancybox" id="img-page4" href="https://www.howtoforge.com/images/install_adminer_database_management_tool_on_debian_10/big/page4.png"><img src="https://www.howtoforge.com/images/install_adminer_database_management_tool_on_debian_10/page4.png" alt="Create Database" width="750" height="130" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Now, provide the database name you want to create and click on the <strong>Save</strong> button to create the database as shown below:</p>
<p><a class="fancybox" id="img-page5" href="https://www.howtoforge.com/images/install_adminer_database_management_tool_on_debian_10/big/page5.png"><img src="https://www.howtoforge.com/images/install_adminer_database_management_tool_on_debian_10/page5.png" alt="Newly Created database in Adminer" width="750" height="309" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<h2 id="enable-ssl-for-adminer-and-get-a-free-ssl-certificate-from-lets-encrypt">Enable SSL for Adminer and get a free SSL Certificate from Let's Encrypt</h2>
<p><span></span>The first step to secure Adminer with a Let's Encrypt SSL Certificate is to install the python3-certbot-apache&nbsp;package. Run the following command:</p>
<pre class="command"><code spellcheck="false">apt-get -y install&nbsp;python3-certbot-apache</code></pre>
<p>In the next step we request an SSL certificate from Let's Encrypt by using the certbot client program. During this process the Let's Encrypt server tries to connect to your server using the domain name you provide to the certbot command. It is important that this domain name already points to your server in the DNS, so that the website is already reachable via its domain name on port 80 (http). If the website is not accessible from the Internet, the creation of the Let's Encrypt SSL certificate will fail.</p>
<p>Before we can start creating the SSL certificate, we need to set the domain name in the vhost configuration file. Open the default vhost file with an editor:</p>
<pre class="command"><code spellcheck="false">nano /etc/apache2/sites-available/000-default.conf</code></pre>
<p>and add the line:</p>
<pre class="command"><code spellcheck="false">ServerName example.com</code></pre>
<p>Right below the 'DocumentRoot' line. Replace example.com with the domain name of your own website.</p>
<p>Then create the SSL Certificate with this command:</p>
<pre class="command"><code spellcheck="false">certbot --apache -d example.com</code></pre>
<p>Replace example.com with your domain name here again. The command will start a wizard that asks you several questions.</p>
<p>Enter the email address where the administrator who is responsible for this website can be reached.</p>
<p><a class="fancybox" id="img-le-email-address" href="https://www.howtoforge.com/images/install-apache-with-php-and-mysql-on-ubuntu-18-04-lamp/big/le-email-address.png"><a class="fancybox" id="img-le-email-address" href="https://www.howtoforge.com/images/install-apache-with-php-and-mysql-on-ubuntu-18-04-lamp/big/le-email-address.png"><img src="https://www.howtoforge.com/images/install-apache-with-php-and-mysql-on-ubuntu-18-04-lamp/le-email-address.png" alt="Set Email address" width="550" height="85" style="display: block; margin-left: auto; margin-right: auto;" /></a></a></p>
<p>Accept the terms and conditions of the Let's Encrypt SSL authority.</p>
<p><a class="fancybox" id="img-le-terms" href="https://www.howtoforge.com/images/install-apache-with-php-and-mysql-on-ubuntu-18-04-lamp/big/le-terms.png"><a class="fancybox" id="img-le-terms" href="https://www.howtoforge.com/images/install-apache-with-php-and-mysql-on-ubuntu-18-04-lamp/big/le-terms.png"><img src="https://www.howtoforge.com/images/install-apache-with-php-and-mysql-on-ubuntu-18-04-lamp/le-terms.png" alt="Accept terms and conditions" width="550" height="108" style="display: block; margin-left: auto; margin-right: auto;" /></a></a></p>
<p>Certbot will ask you now if you like to share your email address with the Electronic Frontier Foundation. Choose here whatever you prefer.</p>
<p><a class="fancybox" id="img-le-share-email" href="https://www.howtoforge.com/images/install-apache-with-php-and-mysql-on-ubuntu-18-04-lamp/big/le-share-email.png"><a class="fancybox" id="img-le-share-email" href="https://www.howtoforge.com/images/install-apache-with-php-and-mysql-on-ubuntu-18-04-lamp/big/le-share-email.png"><img src="https://www.howtoforge.com/images/install-apache-with-php-and-mysql-on-ubuntu-18-04-lamp/le-share-email.png" alt="Email address FSF" width="550" height="95" style="display: block; margin-left: auto; margin-right: auto;" /></a></a></p>
<p>Then choose if you want to redirect non-SSL requests to https:// automatically. I'll select yes here to avoid duplicate content problems when the website is available as http:// and https:// version.</p>
<p><a class="fancybox" id="img-le-redirect" href="https://www.howtoforge.com/images/install-apache-with-php-and-mysql-on-ubuntu-18-04-lamp/big/le-redirect.png"><a class="fancybox" id="img-le-redirect" href="https://www.howtoforge.com/images/install-apache-with-php-and-mysql-on-ubuntu-18-04-lamp/big/le-redirect.png"><img src="https://www.howtoforge.com/images/install-apache-with-php-and-mysql-on-ubuntu-18-04-lamp/le-redirect.png" alt="Redirect HTTP requests" width="550" height="222" style="display: block; margin-left: auto; margin-right: auto;" /></a></a></p>
<p>The SSL certificate has been issued successfully.</p>
<p><a class="fancybox" id="img-le-success" href="https://www.howtoforge.com/images/install-apache-with-php-and-mysql-on-ubuntu-18-04-lamp/big/le-success.png"><a class="fancybox" id="img-le-success" href="https://www.howtoforge.com/images/install-apache-with-php-and-mysql-on-ubuntu-18-04-lamp/big/le-success.png"><img src="https://www.howtoforge.com/images/install-apache-with-php-and-mysql-on-ubuntu-18-04-lamp/le-success.png" alt="SSL cert issued successfully" width="550" height="235" style="display: block; margin-left: auto; margin-right: auto;" /></a></a></p>
<p>When you access the website now with a browser, you will get redirected automatically to SSL and the green padlock in front of the URL bar in the browser shows that we are using a trusted SSL certificate now.</p>
<h2 id="conclusion">Conclusion</h2>
<p>In the above tutorial, you learned how to install Adminer on Debian 10 server. You can now manage your database easily with Adminer web-based interface. Feel free to ask me if you have any questions.</p>
</article>

<aside class="authorbox" style="margin-top:20px;">
<img src="/images/profile/hitesh-80.jpg" alt="Hitesh Jethva" /> <p><strong>About Hitesh Jethva</strong></p>
<p>Over 8 years of experience as a Linux system administrator. My skills include a depth knowledge of Redhat/Centos, Ubuntu Nginx and Apache, Mysql, Subversion, Linux, Ubuntu, web hosting, web server, Squid proxy, NFS, FTP, DNS, Samba, LDAP, OpenVPN, Haproxy, Amazon web services, WHMCS, OpenStack Cloud, Postfix Mail Server, Security etc.</p>
</aside>

<div style="height:30px; margin-top:20px;">
<p style="text-align:right;"><img src="/images/pdficon_small.png" /> <a class="pdf-btn" href="javascript:void(0);">view as pdf</a> | <img src="/images/print.gif" /> <a class="print-btn" href="javascript:void(0);">print</a></p>
</div>
<div style="height:30px; margin-top:20px;">
<div style="float:left;"><b>Share this page:</b></div>
<p style="text-align:center;">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Finstall-adminer-database-management-tool-on-debian-10%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Finstall-adminer-database-management-tool-on-debian-10%2F&text=Install+Adminer+Database+Management+Tool+on+Debian+10&via=howtoforgecom&related=howtoforgecom" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.howtoforge.com%2Finstall-adminer-database-management-tool-on-debian-10%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-gplus.png" height="20" /></a>
</p>
</div>
</div>


<div id="htfContentPagePaging">
<h2>Suggested articles</h2>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-3043223216276099" data-ad-slot="8940054090"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>


<div id="htfContentPageComment">
<a name="comments"></a>
<h2>0 Comment(s)</h2>

<div id="commentform">
<div class="commentContainerHead" style="font-size:18px;">Add comment</div>
<div class="commentContainer">
<form method="post" action="/install-adminer-database-management-tool-on-debian-10/#comments">
<input type="hidden" name="reply_to" id="reply-to-comment" value="0" />
<div id="commentFormDetail">
<div style="width:48%; float:left; margin-right:3%">
<label for="commentname">Name *</label>
<input id="commentname" name="commentname" value="" />
</div>
<div style="width:48%;float:left;">
<label for="commentname">Email *</label>
<input id="commentemail" name="commentemail" value="" />
</div>
<div style="clear:both;"></div>
</div>
<textarea id="commentedit" name="commentedit" style="width:auto;"></textarea>
<div>
<div style="float:left;">
<div class="g-recaptcha" data-sitekey="6LdX9fUSAAAAALWwVoPdeXScMSketz4npF-0QcQ1"></div>
<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en">
      </script>
</div>
<div style="margin-top:10px;margin-bottom:10px;">
<input type="submit" name="submit" class="button primary" style="float:right;" value="Submit comment">
</div>
<div style="clear:both;"></div>
</div>
<script>
	tinymce.init({
		selector: "textarea#commentedit",
		theme: "modern",
		height: 100,
		apply_source_formatting : true,
		remove_linebreaks : false,
		menubar : false,
		/*auto_focus : "commentedit",*/
		plugins: [
		"link"
		],
		/*plugins: [
			"advlist autolink link image lists charmap print preview hr anchor pagebreak spellchecker",
			"searchreplace wordcount visualblocks visualchars code fullscreen insertdatetime media nonbreaking",
			"save table contextmenu directionality emoticons template paste textcolor"
		],*/
		content_css: "https://www.howtoforge.com/themes/howtoforge/css/custom.css",
		toolbar: "undo redo | bold italic link", 
		/*style_formats: [
			{title: 'Bold text', inline: 'b'},
			{title: 'Red text', inline: 'span', styles: {color: '#ff0000'}},
			{title: 'Red header', block: 'h1', styles: {color: '#ff0000'}},
			{title: 'Example 1', inline: 'span', classes: 'example1'},
			{title: 'Example 2', inline: 'span', classes: 'example2'},
			{title: 'Table styles'},
			{title: 'Table row 1', selector: 'tr', classes: 'tablerow1'}
		]*/
	}); 
	</script>
</form>
</div>
</div>

</div>

<div class="breadBoxBottom">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Home</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/install-adminer-database-management-tool-on-debian-10/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Install Adminer Database Management Tool on Debian 10</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
<script>
<!--

$(document).on('click', 'a.reply-to', function(e) {
	e.preventDefault();
	
	var self = $(this);
	var cid = self.attr('data-comment');
	console.log(cid);
	if(!cid) return this;
	
	$('#commentform').insertAfter('#comment' + cid);
	$('#reply-to-comment').val(cid);
	/*tinyMCE.activeEditor.focus();*/
	var textareaId = 'commentedit';
	tinyMCE.get(textareaId).remove();
	tinyMCE.execCommand("mceAddEditor", false, textareaId);
	tinyMCE.activeEditor.focus();
});
//-->
</script>
<div style="margin-top:10px;margin-bottom:10px;text-align:center;">

<center>


<div id='div-gpt-ad-1527185271042-1' style='height:90px; width:728px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-1'); });
</script>
</div>

</center>
</div>


<form action="/community/login/login?redirect=/install-adminer-database-management-tool-on-debian-10/" method="post" class="xenForm eAuth" id="login" style="display:none">
<ul id="eAuthUnit">
<li><a href="/community/register/facebook?reg=1" class="fbLogin" tabindex="110"><span>Log in with Facebook</span></a></li>
<li><a href="/community/register/twitter?reg=1" class="twitterLogin" tabindex="110"><span>Log in with Twitter</span></a></li>
<li><span class="googleLogin GoogleLogin JsOnly" tabindex="110" data-client-id="198773272284-b6tfk0c28bje81p774prrcrkq9jb3o44.apps.googleusercontent.com" data-redirect-url="/community/register/google?code=__CODE__&amp;csrf=hVMXbW_3rnrmq4Em"><span>Log in with Google</span></span></li>
</ul>
<div class="ctrlWrapper">
<dl class="ctrlUnit">
<dt><label for="LoginControl">Your name or email address:</label></dt>
<dd><input type="text" name="login" id="LoginControl" class="textCtrl" tabindex="101" /></dd>
</dl>
<dl class="ctrlUnit">
<dt>
<label for="ctrl_password">Do you already have an account?</label>
</dt>
<dd>
<ul>
<li><label for="ctrl_not_registered"><input type="radio" name="register" value="1" id="ctrl_not_registered" tabindex="105" />
No, create an account now.</label></li>
<li><label for="ctrl_registered"><input type="radio" name="register" value="0" id="ctrl_registered" tabindex="105" checked="checked" class="Disabler" />
Yes, my password is:</label></li>
<li id="ctrl_registered_Disabler">
<input type="password" name="password" class="textCtrl" id="ctrl_password" tabindex="102" />
<div class="lostPassword"><a href="/community/lost-password/" tabindex="106">Forgot your password?</a></div>
</li>
</ul>
</dd>
</dl>
<dl class="ctrlUnit submitUnit">
<dt></dt>
<dd>
<input type="submit" class="button primary" value="Log in" tabindex="104" data-loginPhrase="Log in" data-signupPhrase="Sign up" />
<label for="ctrl_remember" class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_remember" tabindex="103" /> Stay logged in</label>
</dd>
</dl>
</div>
<input type="hidden" name="cookie_check" value="1" />
<input type="hidden" name="redirect" value="/community/" />
<input type="hidden" name="_xfToken" value="" />
</form>

</div>
</div>

<aside>
<div class="sidebar">
<div class="section loginButton">
<div class="secondaryContent">
<label for="LoginControl" id="SignupButton"><a href="/community/login/" class="inner">Sign up now!</a></label>
</div>
</div>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-2">

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent socialMediaIcon">
<a href="https://twitter.com/howtoforgecom" target="_blank"><img src="/images/socialmedia/64x64/twitter.png" /></a>
<a href="https://www.facebook.com/howtoforge" target="_blank"><img src="/images/socialmedia/64x64/facebook.png" /></a>
<a href="https://news.ycombinator.com/" target="_blank" rel="nofollow"><img src="/images/socialmedia/64x64/hackernews.png" /></a>
<a href="https://www.howtoforge.com/feed" target="_blank"><img src="/images/socialmedia/64x64/rss.png" /></a>
</div>
</div>
</div>
<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Tutorial Info</p>
<div class="pairsJustified">
<dl class="discussionCount">
<dt>Author:</dt>
<dd><a href="/author/hitesh+jethva/" rel="author">Hitesh Jethva</a></dd>
</dl>
<dl class="discussionCount">
<dt>Published:</dt>
<dd>Jan 23, 2020</dd>
</dl>
<dl class="discussionCount">
<dt>Tags:</dt>
<dd><a href='/tutorials/debian/' rel='tag'>debian</a>, <a href='/tutorials/mysql/' rel='tag'>mysql</a></dd>
</dl>
</div>
</div>
</div>
<div id="sponsor-banner">
</div>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent">
<p class="mnuinfo mnushare">Share This Page</p>
<p style="text-align:center;">
<a href="javascript:window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Finstall-adminer-database-management-tool-on-debian-10%2F', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="javascript:window.open('https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Finstall-adminer-database-management-tool-on-debian-10%2F&text=Install+Adminer+Database+Management+Tool+on+Debian+10&via=howtoforgecom&related=howtoforgecom', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="javascript:window.open('https://news.ycombinator.com/submitlink?t=Install+Adminer+Database+Management+Tool+on+Debian+10&u=https%3A%2F%2Fwww.howtoforge.com%2Finstall-adminer-database-management-tool-on-debian-10%2F', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-hackernews.png" height="20" /></a>
</p>
<p style="color:#EE; font-weight:bold; text-align:center; margin-top:5px;">40.2k Followers</p>
</div>
</div>
</div>


<script type="text/javascript">
    google_ad_client = "ca-pub-3043223216276099";
    google_ad_slot = "6709042890";
    google_ad_width = 300;
    google_ad_height = 600;
</script>

<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>


<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Popular Tutorials</p>
<div class="pairsJustified">
<ul>
<li><a href="/tutorial/linux-grep-command/">How to use grep to search for strings in files on the shell</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-create-docker-images-with-dockerfile/">How to create Docker Images with a Dockerfile</a></li>
<li><hr /></li>
<li><a href="/vim-basics">Vim Editor Basics</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-use-ftp-on-the-linux-shell/">How to use the Linux ftp command to up- and download files on the shell</a></li>
<li><hr /></li>
<li><a href="/tutorial/linux-search-files-from-the-terminal/">How to search files from the Terminal on Linux</a></li>
<li><hr /></li>
<li><a href="/tutorial/perfect-server-ubuntu-18.04-with-apache-php-myqsl-pureftpd-bind-postfix-doveot-and-ispconfig/">The Perfect Server - Ubuntu 18.04 (Bionic Beaver) with Apache, PHP, MySQL, PureFTPD, BIND, Postfix, Dovecot and ISPConfig 3.1</a></li>
<li><hr /></li>
<li><a href="/setting-changing-resetting-mysql-root-passwords">Setting, Changing and Resetting MySQL Root Passwords</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-setup-zsh-and-oh-my-zsh-on-linux/">How to Setup ZSH and Oh-my-zsh on Linux</a></li>
<li><hr /></li>
<li><a href="/linux-basics-set-a-static-ip-on-ubuntu">Linux Basics - Set a Static IP on Ubuntu</a></li>
<li><hr /></li>
<li><a href="/configure-remote-access-to-your-ubuntu-desktop">How To Configure Remote Access To Your Ubuntu Desktop</a></li>
<li><hr /></li>
</ul>
</div>
</div>
</div>
</div>
</div>
</aside>
</div>
</div>
</div>
<footer>
<div class="footer">
<div class="pageWidth">
<div class="pageContent">
<div class='skin_branding'><span>Xenforo skin by <a href="http://www.xenfocus.com" rel="nofollow">Xenfocus</a></span></div>
<ul class="footerLinks">
<li><a href="/contribute/">Contribute</a></li>
<li><a href="/community/misc/contact">Contact</a></li>
<li><a href="/community/help/">Help</a></li>
<li><a href="/imprint/">Imprint and Legal Notice</a></li>
<li><a href="#navigation" class="topLink">Top</a></li>
<li><a href="/feed" rel="alternate" class="globalFeed" target="_blank" title="RSS-Feed for Howtoforge">RSS-Feed</a></li>
</ul>
<span class="helper"></span>
</div>
</div>
</div>
<div class="footerLegal">
<div class="pageWidth">
<div class="pageContent">
<ul id="legal">
<li><a href="/community/help/terms">Terms and Rules</a> <a href="https://www.howtoforge.com/community/help/privacy-policy">Privacy Policy</a></li>
</ul>
<div id="copyright"><a href="https://www.howtoforge.com" class="concealed">Howtoforge <span>&copy; projektfarm GmbH.</span></a></div>
<span class="helper"></span>
</div>
</div>
</div>
</footer>
<div style="height:100px;"></div>

<div id="subscriptionModal" class="modal">
<div class="modal-content">
<span class="close">&times;</span>
<p>This feature is only available to subscribers. Get your subscription <a href="/subscription">here</a>.</p>
</div>
</div>
<script>
//* Modal
var modal = document.getElementById('subscriptionModal');
var span = document.getElementsByClassName("close")[0];
$(".pdf-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
$(".print-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
span.onclick = function() {
	$("#subscriptionModal").css('display', 'none');
}
window.onclick = function(event) {
    if (event.target == modal) {
		$("#subscriptionModal").css('display', 'none');
    }
}
//* Xenforo
jQuery.extend(true, XenForo,
{
	visitor: { user_id: 0 },
	serverTimeInfo:
	{
		now: 1409831907,
		today: 1409781600,
		todayDow: 4
	},
	_lightBoxUniversal: "0",
	_enableOverlays: "1",
	_animationSpeedMultiplier: "1",
	_overlayConfig:
	{
		top: "10%",
		speed: 200,
		closeSpeed: 100,
		mask:
		{
			color: "rgb(0, 0, 0)",
			opacity: "0.6",
			loadSpeed: 200,
			closeSpeed: 100
		}
	},
	_ignoredUsers: [],
	_loadedScripts: {"node_list":true,"node_category":true,"node_forum":true,"sidebar_share_page":true,"wf_default":true,"bbm_buttons":true,"login_bar":true,"twitter":true},
	_cookieConfig: { path: "/", domain: "", prefix: "xf_"},
	_csrfToken: "",
	_csrfRefreshUrl: "/community/login/csrf-token-refresh",
	_jsVersion: "303ae0ca"
});
jQuery.extend(XenForo.phrases,
{
	cancel: "Cancel",

	a_moment_ago:    "A moment ago",
	one_minute_ago:  "1 minute ago",
	x_minutes_ago:   "%minutes% minutes ago",
	today_at_x:      "Today at %time%",
	yesterday_at_x:  "Yesterday at %time%",
	day_x_at_time_y: "%day% at %time%",

	day0: "Sunday",
	day1: "Monday",
	day2: "Tuesday",
	day3: "Wednesday",
	day4: "Thursday",
	day5: "Friday",
	day6: "Saturday",

	_months: "January,February,March,April,May,June,July,August,September,October,November,December",
	_daysShort: "Sun,Mon,Tue,Wed,Thu,Fri,Sat",

	following_error_occurred: "The following error occurred",
	server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
	logging_in: "Logging in",
	click_image_show_full_size_version: "Click this image to show the full-size version.",
	show_hidden_content_by_x: "Show hidden content by {names}"
});

// Facebook Javascript SDK
XenForo.Facebook.appId = "";
XenForo.Facebook.forceInit = true;

/*
document.addEventListener('DOMContentLoaded', function(event) {
  cookieChoices.showCookieConsentBar('Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.',
  'OK');
});
*/

$(document).ready(function() {
	$("a.fancybox").fancybox();
});

</script>
<script>
_bsa.init('custom', 'CKYD55QU', 'placement:howtoforge',
    {
      target: '#sponsor-banner',
      template: `
<a href="##link##" style="background: linear-gradient(-330deg, ##backgroundColor##D9, ##backgroundColor##D9 30%, ##backgroundColor## 70%) #fff;" class="native-banner">
<img class="native-img" src="##logo##">
<div style="color: ##textColor##" class="native-tagline">##tagline##</div>
<div style="color: ##textColor##" class="native-desc">##description##</div>
<div style="color: ##ctaTextColor##; background-color: ##ctaBackgroundColor##;" class="native-cta">##callToAction##</div>
<div style="background-color: ##textColor##B2; color: ##backgroundColor##" class="native-ad">Ad</div>
</a>
`
    }
  );
</script>
<script>
(function() {
  if (typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('fancybar', 'CKYDL27E', 'placement:howtoforgecom');
  }
})();
</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2155872-1', 'auto');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');

</script>
</body>
</html>