<!DOCTYPE html><html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs LoggedOut Sidebar Responsive" xmlns:fb="http://www.facebook.com/2008/fbml"><head><meta charset="utf-8" />
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
if(typeof isOrig==='undefined'){isOrig=false;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){if((impId!=="0"||isOrig===true)&&adUnit!==""){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}}
function AddPixelById(impFullId,pixelData,isOrig,revenue){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];var pix={type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig};if(typeof revenue!=='undefined'){pix.revenue=revenue;}
pixels.push(pix);}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}});}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false;}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=195-2&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=195-2&cb=4', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=195-2&cb=5', false, [], true, false, true, false);</script>
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<base href="https://www.howtoforge.com" />
<script>
			var _b = document.getElementsByTagName('base')[0], _bH = "https://www.howtoforge.com/how-to-install-koel-music-streaming-server-using-docker-on-rocky-linux-8/";
			if (_b && _b.href != _bH) _b.href = _bH;
		</script>
<title>How to Install Koel Music Streaming Server using Docker on Rocky Linux 8</title>
<meta name="description" content="Koel is a web-based audio streaming service written in the Laravel PHP framework. It allows you to stream your personal music collection and access it... " />
<meta property="og:title" content="How to Install Koel Music Streaming Server using Docker on Rocky Linux 8" />
<meta property="og:description" content="Koel is a web-based audio streaming service written in the Laravel PHP framework. It allows you to stream your personal music collection and access it... " />
<meta property="og:site_name" content="HowtoForge" />
<meta property="og:type" content="article" />
<meta property="og:image" content="https://www.howtoforge.com/images/featured/rocky-linux-koel.png" />
<meta property="og:image:secure_url" content="https://www.howtoforge.com/images/featured/rocky-linux-koel.png" />
<meta property="og:image:alt" content="How to Install Koel Music Streaming Server using Docker on Rocky Linux 8" />
<meta name="twitter:image" content="https://www.howtoforge.com/images/featured/rocky-linux-koel.png" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@howtoforgecom" />
<meta name="twitter:creator" content="@howtoforgecom" />
<meta name="twitter:title" content="How to Install Koel Music Streaming Server using Docker on Rocky Linux 8" />
<meta name="twitter:description" content="Koel is a web-based audio streaming service written in the Laravel PHP framework. It allows you to stream your personal music collection and access it... " />
<link rel="alternate" href="https://www.howtoforge.com/how-to-install-koel-music-streaming-server-using-docker-on-rocky-linux-8/" hreflang="en" />
<link rel="canonical" href="https://www.howtoforge.com/how-to-install-koel-music-streaming-server-using-docker-on-rocky-linux-8/" />
<link rel="amphtml" href="https://www.howtoforge.com/how-to-install-koel-music-streaming-server-using-docker-on-rocky-linux-8/amp/" />
<script type="application/ld+json">
{
  "@context" : "http://schema.org",
  "@type" : "Article",
  "name" : "How to Install Koel Music Streaming Server using Docker on Rocky Linux 8",
  "author" : {
    "@type" : "Person",
    "name" : "Navjot Singh"
  },
  "articleSection" : "linux,php",
  "url" : "https://www.howtoforge.com/how-to-install-koel-music-streaming-server-using-docker-on-rocky-linux-8/",
  "publisher" : {
    "@type" : "Organization",
    "name" : "Howtoforge"
  }
}
</script>
<noscript><style>.JsOnly, .jsOnly { display: none !important; }</style></noscript>

<link rel="stylesheet" href="/themes/howtoforge/icons/css/font-awesome.min.css" />

<link href="/themes/howtoforge/fonts/opensans.css?family=Open+Sans:400,700" rel="stylesheet" type="text/css" />
<link href="/themes/howtoforge/templates/xf.css" rel="stylesheet" />
<script src="/js/jquery/jquery-1.11.3.min.js"></script>

<script src="/themes/howtoforge/js/xenforo/xenforo.js?_v=303ae0ca"></script>

<script src="/themes/howtoforge/js/bbm/zloader.js?_v=303ae0ca"></script>
<script type="text/javascript" src="/js/fancybox/jquery.mousewheel-3.0.4.pack.js"></script>
<script type="text/javascript" src="/js/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
<link rel="stylesheet" type="text/css" href="/js/fancybox/jquery.fancybox-1.3.4.css" media="screen" />
<link href="/themes/howtoforge/templates/style.min.css" rel="stylesheet" />
<link rel="alternate" type="application/rss+xml" title="RSS-Feed für Howtoforge" href="/feed.rss" />
<script src="/js/tinymce_4.1.7/tinymce.min.js"></script>
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/skin.min.css" as="style" />
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/content.min.css" as="style" />
<link rel="preload" href="/themes/howtoforge/css/custom.css" as="style" />
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/fonts/tinymce.woff" as="font" crossorigin="anonymous" />

<script type="text/javascript">
var gaProperty = 'UA-2155872-1';
var disableStr = 'ga-disable-' + gaProperty;
if (document.cookie.indexOf(disableStr + '=true') > -1) {
window[disableStr] = true;
}
function gaOptout() {
document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
window[disableStr] = true;
alert('Google Ananlyitics tracking has been disabled in this browser.');
}
</script>
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
	googletag.defineSlot('/1030080/howtoforge_com_list_sidebar_top', [300, 250], 'div-gpt-ad-1527185271042-4').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_list_content_middle', [[300, 250], [336, 280]], 'div-gpt-ad-1527185271042-5').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_a_300x250', [300, 250], 'div-gpt-ad-1527185271042-6').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_b_300x250', [300, 250], 'div-gpt-ad-1527185271042-7').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_leaderboard_b_728x90', [728, 90], 'div-gpt-ad-1527185271042-1').addService(googletag.pubads());
	googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-3043223216276099",
          enable_page_level_ads: true
     });
</script>


<script type="text/javascript" src="//m.servedby-buysellads.com/monetization.js"></script>

<script type="text/javascript">var ezouid = "1";</script><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script>
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 178704;
var ezdomain = 'howtoforge.com';
var ezoicSearchable = 1;
</script>


<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":178704,"domain_test_group":20210302,"engaged_time_visit":0,"ezcache_level":2,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"f4bd8326-6228-4e97-4a1c-25c25160b4c0","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":55614,"response_time_orig":8,"serverid":"3.227.1.245:3268","state":"VA","t_epoch":1652141333,"template_id":126,"time_on_site_visit":0,"url":"https://www.howtoforge.com/how-to-install-koel-music-streaming-server-using-docker-on-rocky-linux-8/","user_id":0,"word_count":2553,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_178704=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["f4bd8326-6228-4e97-4a1c-25c25160b4c0", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>
<body>
<div id="loginBar">
<div class="pageWidth">
<div class="pageContent">
<h3 id="loginBarHandle">
<label for="LoginControl"><a href="/community/login/" class="concealed noOutline">Log in or Sign up</a></label>
</h3>
<span class="helper"></span>
</div>
</div>
</div>
<header>
<div id="header">
<div id="logoBlock">
<div class="pageWidth">
<div class="pageContent">
<div id="logo"><a href="/">
<span></span>
<img src="/images/howtoforge_logo_trans.gif" alt="Howtoforge" style="margin-left:20px;" />
</a></div>
<span class="helper"></span>
</div>
</div>
</div>
<div id="navigation" class="pageWidth withSearch">
<div class="pageContent">
<nav>
<div class="navTabs">
<ul class="publicTabs">

<li class="navTab forums selected">
<a href="/" class="navLink">Tutorials</a>
<div class="tabLinks forumsTabLinks">
<ul class="secondaryContent blockLinksList">
<li><a href="/search/">Tutorial search</a></li>
</ul>
</div>
</li>
<li class="navTab forums PopupClosed">
<a href="/tutorials/" class="navLink">Tags</a>
</li>
<li class="navTab forums PopupClosed"><a href="/community/" class="navLink">Forums</a></li>
<li class="navTab forums PopupClosed"><a href="/linux-commands/" class="navLink">Linux Commands</a></li>
<li class="navTab forums PopupClosed"><a href="/subscription/" class="navLink">Subscribe</a></li>
<li class="navTab forums PopupClosed"><a href="https://www.ispconfig.org" class="navLink">ISPConfig</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.lxer.com" class="navLink">News</a></li>
</ul>
</div>
<span class="helper"></span>
</nav>
</div>
</div>
<div id="searchBar" class="pageWidth">
<span id="QuickSearchPlaceholder" title=" Search..."> Search</span>
<fieldset id="QuickSearch">
<form action="/" method="post" class="formPopup">
<div class="primaryControls">

<input type="search" name="q" value="" class="textCtrl" placeholder="Search..." results="0" title="Enter your search and hit enter..." id="QuickSearchQuery" />

</div>
<input type="hidden" name="_xfToken" value="" />
</form>
</fieldset>
</div>
</div>
</header>
<div id="content" class="forum_list">
<div class="pageWidth">
<div class="pageContent">

<div class="mainContainer">
<div class="mainContent">

<div class="breadBoxTop">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://schema.org/BreadcrumbList">
<span itemprop="itemListElement" itemscope="" itemtype="http://schema.org/ListItem">
<a href="/" class="crumb" rel="up" itemprop="item"><span itemprop="name">Home</span></a>
<meta itemprop="position" content="1" />
</span>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://schema.org/BreadcrumbList">
<span itemprop="itemListElement" itemscope="" itemtype="http://schema.org/ListItem">
<a href="/how-to-install-koel-music-streaming-server-using-docker-on-rocky-linux-8/" class="crumb" rel="up" itemprop="item"><span itemprop="name">How to Install Koel Music Streaming Server using Docker on Rocky Linux 8</span></a>
<meta itemprop="position" content="2" />
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</span></fieldset>
</nav>
</div>

<div id="htfContentPage">
<div class="bsa-apiads"></div>
<article>
<h1>How to Install Koel Music Streaming Server using Docker on Rocky Linux 8</h1>
<div class="contributeEdit" style="float:right; width:450px; max-width:100%;">
<div id="tocContainer">
<h3>On this page</h3>
<ol class="toc">
<li><a href="#prerequisites">Prerequisites</a></li>
<li><a href="#step-1---configure-firewall">Step 1 - Configure Firewall</a></li>
<li><a href="#step-2---install-docker">Step 2 - Install Docker</a></li>
<li><a href="#step-3---install-docker-compose">Step 3 - Install Docker Compose</a></li>
<li><a href="#step-4---create-koel-app-key">Step 4 - Create Koel App Key</a></li>
<li><a href="#step-5---create-koel-environment-file">Step 5 - Create Koel Environment File</a></li>
<li><a href="#step-6---create-koel-docker-compose-file">Step 6 - Create Koel Docker Compose File</a></li>
<li><a href="#step-7---start-koel-container">Step 7 - Start Koel Container</a>
<ol>
<li><a href="#initialize-koel-for-the-first-time">Initialize Koel for the first time</a></li>
<li><a href="#change-administrator-password">Change Administrator Password</a></li>
</ol>
</li>
<li><a href="#step-8---install-ssl">Step 8 - Install SSL</a></li>
<li><a href="#step-9---install-nginx">Step 9 - Install Nginx</a></li>
<li><a href="#step-10---access-koel">Step 10 - Access Koel</a></li>
<li><a href="#step-11---import-music">Step 11 - Import Music</a></li>
<li><a href="#step-12---update-koel">Step 12 - Update Koel</a></li>
<li><a href="#conclusion">Conclusion</a></li>
</ol>
</div>
</div>
<p>Koel is a web-based audio streaming service written in the Laravel PHP framework. It allows you to stream your personal music collection and access it from anywhere in the world. It supports multiple media formats, including AAC, OGG, WMA, FLAC, and APE.</p>
<p>In this tutorial, you will learn how to install Koel Music Streaming Server using Docker on a Rocky Linux 8 machine.</p>
<h2 id="prerequisites">Prerequisites</h2>
<ul>
<li>
<p>A Server running Rocky Linux 8.5.</p>
</li>
<li>
<p>A non-root user with sudo privileges.</p>
</li>
<li>
<p>Update everything.</p>
<pre class="command">$ sudo dnf update
</pre>
</li>
<li>
<p>Install essential packages.</p>
<pre class="command">$ sudo dnf install yum-utils nano curl
</pre>
</li>
<li>
<p>A custom domain name pointing to the server like <code class="system">koel.example.com</code>.</p>
</li>
</ul>
<h2 id="step-1---configure-firewall">Step 1 - Configure Firewall</h2>
<p>The first step is to configure the firewall. Rocky Linux uses Firewalld Firewall. Check the firewall&#39;s status.</p>
<pre class="command">$ sudo firewall-cmd --state
running
</pre>
<p>The firewall works with different zones, and the public zone is the default one that we will use. List all the services and ports active on the firewall.</p>
<pre class="command">$ sudo firewall-cmd --permanent --list-services
</pre>
<p>It should show the following output.</p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;">

<div id="div-gpt-ad-1527185271042-6" style="height:250px; width:300px;">
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-6'); });
</script>
</div>
</div>
<pre class="command">cockpit dhcpv6-client ssh
</pre>
<p>Allow HTTP and HTTPS ports.</p>
<pre class="command">$ sudo firewall-cmd --permanent --add-service=http
$ sudo firewall-cmd --permanent --add-service=https
</pre>
<p>Recheck the status of the firewall.</p>
<pre class="command">$ sudo firewall-cmd --permanent --list-services
</pre>
<p>You should see a similar output.</p>
<pre class="command">cockpit dhcpv6-client http https ssh
</pre>
<p>Reload the firewall to enable the changes.</p>
<pre class="command">$ sudo firewall-cmd --reload
</pre>
<h2 id="step-2---install-docker">Step 2 - Install Docker</h2>
<p>Rocky Linux ships with an older version of Docker. To install the latest version, first, install the official Docker repository.</p>
<pre class="command">$ sudo yum-config-manager \
    --add-repo \
    https://download.docker.com/linux/centos/docker-ce.repo
</pre>
<p>Install the latest version of Docker.</p>
<pre class="command">$ sudo dnf install docker-ce docker-ce-cli containerd.io
</pre>
<p>Enable and run the Docker daemon.</p>
<pre class="command">$ sudo systemctl enable docker --now
</pre>
<p>Verify that it is running.</p>
<pre class="command">? docker.service - Docker Application Container Engine
   Loaded: loaded (/usr/lib/systemd/system/docker.service; enabled; vendor preset: disabled)
   Active: active (running) since Sat 2022-04-02 13:26:08 UTC; 2s ago
     Docs: https://docs.docker.com
 Main PID: 21152 (dockerd)
    Tasks: 7
   Memory: 30.9M
   CGroup: /system.slice/docker.service
           ??21152 /usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock
...
</pre>
<p>By default, Docker requires root privileges. If you want to avoid using <code class="system">sudo</code> every time you run the <code class="system">docker</code> command, add your username to the <code class="system">docker</code> group.</p>
<pre class="command">$ sudo usermod -aG docker $(whoami)
</pre>
<p>You will need to log out of the server and back in as the same user to enable this change.</p>
<h2 id="step-3---install-docker-compose">Step 3 - Install Docker Compose</h2>
<p>Download the latest stable release of Docker Compose.</p>
<pre class="command">$ sudo curl -L &#34;https://github.com/docker/compose/releases/download/1.29.2/docker-compose-$(uname -s)-$(uname -m)&#34; -o /usr/local/bin/docker-compose
</pre>
<p>Apply executable permissions to the Docker Compose binary file.</p>
<pre class="command">$ sudo chmod +x /usr/local/bin/docker-compose
</pre>
<p>Test the installation.</p>
<pre class="command">$ docker-compose --version
docker-compose version 1.29.2, build 5becea4c
</pre>
<p>Install the Docker-compose Bash Completion script.</p>
<pre class="command">$ sudo curl \
    -L https://raw.githubusercontent.com/docker/compose/1.29.2/contrib/completion/bash/docker-compose \
    -o /etc/bash_completion.d/docker-compose
</pre>
<p>Reload your profile settings to make the bash-completion work.</p>
<pre class="command">$ source ~/.bashrc
</pre>
<h2 id="step-4---create-koel-app-key">Step 4 - Create Koel App Key</h2>
<p>We will generate Koel&#39;s App key by running the container for a short moment. Run the following command to run the container and access its shell.</p>
<pre class="command">$ docker run -it --rm phanan/koel bash
</pre>
<p>Once in the container, run the following command to generate the application key.</p>
<pre class="command">$ php artisan key:generate --force
</pre>
<p>Output the modified environment file with the newly generated app key.</p>
<pre class="command">$ cat .env
APP_KEY=base64:fjtO7aVHHKWfk4DThKqf1nci6o2DuMkNd90TKX6Gj+4=
</pre>
<p>Copy the key value and exit the container shell.</p>
<pre class="command">$ exit
</pre>
<h2 id="step-5---create-koel-environment-file">Step 5 - Create Koel Environment File</h2>
<p>Create a directory for Koel.</p>
<pre class="command">$ mkdir ~/koel
</pre>
<p>Switch to the directory.</p>
<pre class="command">$ cd ~/koel
</pre>
<p>Create the music directory.</p>
<pre class="command">$ mkdir music
</pre>
<p>Create and open the <code class="system">.env</code> file.</p>
<pre class="command">$ nano .env
</pre>
<p>Paste the following code in it.</p>
<pre class="command">APP_NAME=Koel

# A random 32-char string. You can leave this empty if use php artisan koel:init.
APP_KEY=base64:fjtO7aVHHKWfk4DThKqf1nci6o2DuMkNd90TKX6Gj+4=

# The ABSOLUTE path to your media. This value can always be changed later via the web interface.
MEDIA_PATH=/music

APP_ENV=production
APP_DEBUG=true
APP_URL=https://koel.example.com

# The maximum scan time, in seconds. Increase this if you have a huge library.
# Note: This setting doesn&#39;t have effect when scanning via koel:sync.
APP_MAX_SCAN_TIME=600

# The memory limit, in MB, used by the scanning process.
# For example, if you want to set a memory limit of 2048MB, enter &#34;2048&#34; (without
# quotes) here.
MEMORY_LIMIT=512

# The streaming method.
# Can be either &#39;php&#39; (default), &#39;x-sendfile&#39;, or &#39;x-accel-redirect&#39;
# See https://docs.koel.dev/#streaming-music for more information.
# Note: This setting doesn&#39;t have effect if the media needs transcoding (e.g. FLAC).
STREAMING_METHOD=x-sendfile

# If you want Koel to integrate with Last.fm, set the API details here.
# See https://docs.koel.dev/3rd-party.html#last-fm for more information
LASTFM_API_KEY=
LASTFM_API_SECRET=

# If you want to use Amazon S3 with Koel, fill the info here and follow the
# installation guide at https://docs.koel.dev/aws-s3.html
AWS_ACCESS_KEY_ID=
AWS_SECRET_ACCESS_KEY=
AWS_REGION=

# If you want Koel to integrate with YouTube, set the API key here.
# See https://docs.koel.dev/3rd-party.html#youtube for more information.
YOUTUBE_API_KEY=

# You can also configure Koel to use a CDN to serve the media files.
# This url must be mapped to the home URL of your Koel&#39;s installation.
# No trailing slash, please.
CDN_URL=

# The bit rate of the output mp3 stream. Higher value results in better quality,
# but slower streaming and more bandwidth.
OUTPUT_BIT_RATE=128

# Whether to allow song downloading.
# Note that if you&#39;re downloading more than one song, Koel will zip them up
# using PHP&#39;s ZipArchive. So if the module isn&#39;t available in the current
# environment, such a download will (silently) fail.
ALLOW_DOWNLOAD=true

# If this is set to true, the query to get artist, album, and song information will be cached.
# This can give a boost to Koel&#39;s boot time, especially if your library is huge.
# However, the cache deserialization process can be memory sensitive, so if you encounter
# errors, try setting this to false.
CACHE_MEDIA=true

# Koel attempts to detect if your website use HTTPS and generates secure URLs accordingly.
# If this attempts for any reason, you can force it by setting this value to true.
FORCE_HTTPS=true

# The variables below are Laravel-specific.
# You can change them if you know what you&#39;re doing. Otherwise, just leave them as-is.
APP_LOG_LEVEL=debug
BROADCAST_DRIVER=log
CACHE_DRIVER=file
SESSION_DRIVER=file
QUEUE_DRIVER=sync
</pre>
<p>Save the file by pressing <strong>Ctrl + X</strong> and entering <strong>Y</strong> when prompted.</p>
<p>Most of the settings are self-explanatory above. The following settings need to be configured to make it work. Paste the app key generated in the previous step against the <code class="system">APP_KEY</code> variable. Enter your domain name under <code class="system">APP_URL</code>, and set the memory limit in MBs depending on your server&#39;s resources. We have set the streaming method to <code class="system">x-sendfile</code> as Koel&#39;s docker image uses Apache and comes pre-configured with it. The <code class="system">FORCE_HTTPS</code> setting is set to true because we will use Nginx as a load balancer along with Let&#39;s Encrypt SSL to serve Koel to the web. Configure other services if you want to use them along with Koel.</p>
<h2 id="step-6---create-koel-docker-compose-file">Step 6 - Create Koel Docker Compose File</h2>
<p>Create and open the file <code class="system">docker-compose.yml</code> for editing.</p>
<pre class="command">$ nano docker-compose.yml
</pre>
<p>Paste the following code into it.</p>
<pre class="command">version: &#39;3.3&#39;

services:
  koel:
    image: phanan/koel
    container_name: koel
    depends_on:
      - koeldb
    restart: unless-stopped
    ports:
      - 8080:80
    environment:
      - DB_CONNECTION=mysql
      - DB_HOST=koeldb
      - DB_USERNAME=koel
      - DB_PASSWORD=koelpassword
      - DB_DATABASE=koel
    volumes:
      - ./music:/music
      - ./.env:/var/www/html/.env
      - covers:/var/www/html/public/img/covers
      - search_index:/var/www/html/storage/search-indexes

  koeldb:
    image: mysql/mysql-server:8.0
    restart: unless-stopped
    volumes:
      - db:/var/lib/mysql
    environment:
      - MYSQL_ROOT_PASSWORD=rootpassword
      - MYSQL_DATABASE=koel
      - MYSQL_USER=koel
      - MYSQL_PASSWORD=koelpassword

volumes:
  db:
    driver: local
  covers:
    driver: local
  search_index:
    driver: local
</pre>
<p>Save the file by pressing <strong>Ctrl + X</strong> and entering <strong>Y</strong> when prompted.</p>
<p>The above file launches containers based on Koel and MySQL&#39;s docker images. It exposes Koel to port 8080 on your machine. The music and the environment file are mounted to the respective locations on the container. The directory for music covers and the search index, along with MySQL data, is mounted as local volumes. Choose a strong password for the variables <code class="system">MYSQL_ROOT_PASSWORD</code>, <code class="system">MYSQL_PASSWORD</code> and match those values with the variables for the Koel container in the file above. To link the Koel container with the database container, make sure the <code class="system">DB_HOST</code> and <code class="system">depends_on</code> variables are named after the Database container&#39;s service name.</p>
<h2 id="step-7---start-koel-container">Step 7 - Start Koel Container</h2>
<p>Launch the Koel Container using the following command.</p>
<pre class="command">$ docker-compose up -d
</pre>
<h3 id="initialize-koel-for-the-first-time">Initialize Koel for the first time</h3>
<p>Log in to the Koel Container shell. <code class="system">koel</code> in the command below refers to the name of the container set via the <code class="system">container_name</code> variable in the Docker compose file above. If you don&#39;t have a container name set, you will have to find the name of the container first and use that in the following command.</p>
<pre class="command">$ docker exec --user www-data -it koel bash
</pre>
<p>Run the following command to create an administrator account and initialize the database.</p>
<pre class="command">$ php artisan koel:init --no-assets
</pre>
<h3 id="change-administrator-password">Change Administrator Password</h3>
<p>Koel creates a default administrator account with the following credentials.</p>
<pre class="command">email: <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="3253565f5b5c72595d575e1c565744">[email&#160;protected]</a>
password: KoelIsCool
</pre>
<p>You can change the password for the administrator account using the following command from inside the container shell.</p>
<pre class="command">$ php artisan koel:admin:change-password
</pre>
<p>Exit the container shell.</p>
<pre class="command">$ exit
</pre>
<h2 id="step-8---install-ssl">Step 8 - Install SSL</h2>
<p>To install an SSL certificate using Let&#39;s Encrypt, we need to install the Certbot tool.</p>
<p>Firstly, you need to download and install the EPEL repository.</p>
<pre class="command">$ sudo dnf install epel-release
</pre>
<p>Run the following commands to install Certbot.</p>
<pre class="command">$ sudo dnf install certbot
</pre>
<p>Generate the SSL certificate.</p>
<pre class="command">$ sudo certbot certonly --standalone --agree-tos --no-eff-email --staple-ocsp --preferred-challenges http -m <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="b3ddd2ded6f3d6cbd2dec3dfd69dd0dcde">[email&#160;protected]</a> -d koel.example.com
</pre>
<p>The above command will download a certificate to the <code class="system">/etc/letsencrypt/live/koel.example.com</code> directory on your server.</p>
<p>Generate a <strong>Diffie-Hellman group</strong> certificate.</p>
<pre class="command">$ sudo openssl dhparam -out /etc/ssl/certs/dhparam.pem 4096
</pre>
<p>Create a challenge web root directory for Let&#39;s Encrypt auto-renewal.</p>
<pre class="command">$ sudo mkdir -p /var/lib/letsencrypt
</pre>
<p>Create a Cron Job to renew the SSL. It will run every day to check the certificate and renew it if needed. For that, first, create the file <code class="system">/etc/cron.daily/certbot-renew</code> and open it for editing.</p>
<pre class="command">$ sudo nano /etc/cron.daily/certbot-renew
</pre>
<p>Paste the following code.</p>
<pre class="command">#!/bin/sh
certbot renew --cert-name koel.example.com --webroot -w /var/lib/letsencrypt/ --post-hook &#34;systemctl reload nginx&#34;
</pre>
<p>Save the file by pressing <strong>Ctrl + X</strong> and entering <strong>Y</strong> when prompted.</p>
<p>Change the permissions on the task file to make it executable.</p>
<pre class="command">$ sudo chmod +x /etc/cron.daily/certbot-renew
</pre>
<h2 id="step-9---install-nginx">Step 9 - Install Nginx</h2>
<p>We will be installing the latest version of Nginx. Create and open the file <code class="system">/etc/yum.repos.d/nginx.repo</code> for editing.</p>
<pre class="command">$ sudo nano /etc/yum.repos.d/nginx.repo
</pre>
<p>Paste the following lines in it.</p>
<pre class="command">[nginx-stable]
name=nginx stable repo
baseurl=http://nginx.org/packages/centos/$releasever/$basearch/
gpgcheck=1
enabled=1
gpgkey=https://nginx.org/keys/nginx_signing.key
module_hotfixes=true

[nginx-mainline]
name=nginx mainline repo
baseurl=http://nginx.org/packages/mainline/centos/$releasever/$basearch/
gpgcheck=1
enabled=0
gpgkey=https://nginx.org/keys/nginx_signing.key
module_hotfixes=true
</pre>
<p>Save the file by pressing <strong>Ctrl + X</strong> and entering <strong>Y</strong> when prompted.</p>
<p>Install Nginx.</p>
<pre class="command">$ sudo dnf install nginx
</pre>
<p>Verify the installation.</p>
<pre class="command">$ nginx -v
nginx version: nginx/1.20.2
</pre>
<p>Enable and start the Nginx service.</p>
<pre class="command">$ sudo systemctl enable nginx --now
</pre>
<p>Create and open the file <code class="system">/etc/nginx/conf.d/koel.conf</code> for editing.</p>
<pre class="command">$ sudo nano /etc/nginx/conf.d/koel.conf
</pre>
<p>Paste the following code in it.</p>
<pre class="command"># Redirect all non-encrypted to encrypted
server {
    listen 80;
    listen [::]:80;
    server_name koel.example.com;
    return 301 https://$host$request_uri;
}

server {
    listen 443 ssl http2;
    listen [::]:443 ssl http2;
    
    server_name koel.example.com;

    ssl_certificate     /etc/letsencrypt/live/koel.example.com/fullchain.pem;
    ssl_certificate_key /etc/letsencrypt/live/koel.example.com/privkey.pem;
    ssl_trusted_certificate /etc/letsencrypt/live/koel.example.com/chain.pem;
    ssl_session_timeout 1d;
    ssl_session_cache shared:MozSSL:10m;
    ssl_session_tickets off;
    ssl_stapling on;
    ssl_stapling_verify on;
    ssl_dhparam /etc/ssl/certs/dhparam.pem;
    
    ssl_protocols TLSv1.2 TLSv1.3;
    ssl_ciphers ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384;

    access_log /var/log/nginx/koel.example.com.access.log main;
    error_log  /var/log/nginx/koel.example.com.error.log;

    location / {
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_set_header X-Forwarded-Proto $scheme;
        proxy_set_header X-Forwarded-Port $server_port;
        proxy_set_header X-Forwarded-Host $host;
        client_max_body_size 400M;
    	proxy_pass  http://localhost:8080;
    	proxy_http_version 1.1;
        proxy_set_header Host $host;
    }
}
</pre>
<p>Once finished, save the file by pressing <strong>Ctrl + X</strong> and entering <strong>Y</strong> when prompted. The above configuration allows Nginx to act as a proxy server and bind to the port 8080 on localhost.</p>
<p>Open the file <code class="system">/etc/nginx/nginx.conf</code> for editing.</p>
<pre class="command">$ sudo nano /etc/nginx/nginx.conf
</pre>
<p>Add the following line before the line <code class="system">include /etc/nginx/conf.d/*.conf;</code>.</p>
<pre class="command">server_names_hash_bucket_size  64;
</pre>
<p>Save the file by pressing <strong>Ctrl + X</strong> and entering <strong>Y</strong> when prompted.</p>
<p>Verify the Nginx configuration file syntax.</p>
<pre class="command">$ sudo nginx -t
nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful
</pre>
<p>Restart the Nginx service to enable the new configuration.</p>
<pre class="command">$ sudo systemctl restart nginx
</pre>
<h2 id="step-10---access-koel">Step 10 - Access Koel</h2>
<p>You can access Koel by visiting the URL <code class="system">https://koel.example.com</code> in your browser. You will be greeted by the following login screen.</p>
<p><a class="fancybox" id="img-koel_login_screen" href="https://www.howtoforge.com/images/how_to_install_koel_music_streaming_server_using_docker_on_rocky_linux_8/big/koel_login_screen.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_koel_music_streaming_server_using_docker_on_rocky_linux_8/koel_login_screen.png" referrerpolicy="no-referrer" alt="Koel Login Screen" width="464" height="477" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Enter <code class="system"><a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="3051545d595e705b5f555c1e545546">[email&#160;protected]</a></code> as your username and the password you set before logging in. The following dashboard will appear on successful login.</p>
<p><a class="fancybox" id="img-koel_dashboard" href="https://www.howtoforge.com/images/how_to_install_koel_music_streaming_server_using_docker_on_rocky_linux_8/big/koel_dashboard.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_koel_music_streaming_server_using_docker_on_rocky_linux_8/koel_dashboard.png" referrerpolicy="no-referrer" alt="Koel Dashboard" width="750" height="520" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<h2 id="step-11---import-music">Step 11 - Import Music</h2>
<p>Copy the music files you want to import to the <code class="system">~/koel/music</code> folder of your system. You can use the <code class="system">scp</code> command to import the files from your local PC to the server.</p>
<pre class="command">$ scp test.mp3 <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="394c4a5c4b79">[email&#160;protected]</a>&lt;yourserverIP&gt;:/home/user/koel/music
</pre>
<p>Once you have copied the files to the <code class="system">~/koel/music</code> folder, run the following command to import the music into Koel.</p>
<pre class="command">$ docker exec --user www-data koel php artisan koel:sync
</pre>
<p>The music will show up in Koel&#39;s web interface, and you can start playing.</p>
<p>Koel&#39;s web interface also allows you to upload songs directly.</p>
<h2 id="step-12---update-koel">Step 12 - Update Koel</h2>
<p>Switch to the Koel directory.</p>
<pre class="command">$ cd ~/koel
</pre>
<p>Pull the latest Koel Docker image.</p>
<pre class="command">$ docker-compose pull
</pre>
<p>Power down the container.</p>
<pre class="command">$ docker-compose down --remove-orphans
</pre>
<p>Start the container with updated images.</p>
<pre class="command">$ docker-compose up -d
</pre>
<p>Verify the Docker containers.</p>
<pre class="command">$ docker ps
</pre>
<h2 id="conclusion">Conclusion</h2>
<p>This concludes the tutorial on installing Koel Music Streaming Service using Docker on a Rocky Linux server. If you have any questions, post them in the comments below.</p>
</article>
<div style="height:30px; margin-top:20px;">
<p style="text-align:right;"><img src="/images/pdficon_small.png" /> <a class="pdf-btn" href="javascript:void(0);">view as pdf</a> | <img src="/images/print.gif" /> <a class="print-btn" href="javascript:void(0);">print</a></p>
</div>
<div style="height:30px; margin-top:20px;">
<div style="float:left;"><b>Share this page:</b></div>
<p style="text-align:center;">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-koel-music-streaming-server-using-docker-on-rocky-linux-8%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-koel-music-streaming-server-using-docker-on-rocky-linux-8%2F&amp;text=How+to+Install+Koel+Music+Streaming+Server+using+Docker+on+Rocky+Linux+8&amp;via=howtoforgecom&amp;related=howtoforgecom" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-koel-music-streaming-server-using-docker-on-rocky-linux-8%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-gplus.png" height="20" /></a>
</p>
</div>
</div>


<div id="htfContentPagePaging">
<h2>Suggested articles</h2>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-3043223216276099" data-ad-slot="8940054090"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>


<div id="htfContentPageComment">
<a name="comments"></a>
<h2>0 Comment(s)</h2>

<div id="commentform">
<div class="commentContainerHead" style="font-size:18px;">Add comment</div>
<div class="commentContainer">
<form method="post" action="/how-to-install-koel-music-streaming-server-using-docker-on-rocky-linux-8/#comments">
<input type="hidden" name="reply_to" id="reply-to-comment" value="0" />
<div id="commentFormDetail">
<div style="width:48%; float:left; margin-right:3%">
<label for="commentname">Name *</label>
<input id="commentname" name="commentname" value="" />
</div>
<div style="width:48%;float:left;">
<label for="commentname">Email *</label>
<input id="commentemail" name="commentemail" value="" />
</div>
<div style="clear:both;"></div>
</div>
<textarea id="commentedit" name="commentedit" style="width:auto;"></textarea>
<div>
<div style="float:left;">
<div class="g-recaptcha" data-sitekey="6LdX9fUSAAAAALWwVoPdeXScMSketz4npF-0QcQ1"></div>
<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en">
      </script>
</div>
<div style="margin-top:10px;margin-bottom:10px;">
<input type="submit" name="submit" class="button primary" style="float:right;" value="Submit comment" />
</div>
<div style="clear:both;"></div>
</div>
<script>
	tinymce.init({
		selector: "textarea#commentedit",
		theme: "modern",
		height: 100,
		apply_source_formatting : true,
		remove_linebreaks : false,
		menubar : false,
		/*auto_focus : "commentedit",*/
		plugins: [
		"link"
		],
		/*plugins: [
			"advlist autolink link image lists charmap print preview hr anchor pagebreak spellchecker",
			"searchreplace wordcount visualblocks visualchars code fullscreen insertdatetime media nonbreaking",
			"save table contextmenu directionality emoticons template paste textcolor"
		],*/
		content_css: "https://www.howtoforge.com/themes/howtoforge/css/custom.css",
		toolbar: "undo redo | bold italic link", 
		/*style_formats: [
			{title: 'Bold text', inline: 'b'},
			{title: 'Red text', inline: 'span', styles: {color: '#ff0000'}},
			{title: 'Red header', block: 'h1', styles: {color: '#ff0000'}},
			{title: 'Example 1', inline: 'span', classes: 'example1'},
			{title: 'Example 2', inline: 'span', classes: 'example2'},
			{title: 'Table styles'},
			{title: 'Table row 1', selector: 'tr', classes: 'tablerow1'}
		]*/
	}); 
	</script>
</form>
</div>
</div>

</div>

<div class="breadBoxBottom">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Home</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/how-to-install-koel-music-streaming-server-using-docker-on-rocky-linux-8/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to Install Koel Music Streaming Server using Docker on Rocky Linux 8</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
<script>
<!--

$(document).on('click', 'a.reply-to', function(e) {
	e.preventDefault();
	
	var self = $(this);
	var cid = self.attr('data-comment');
	console.log(cid);
	if(!cid) return this;
	
	$('#commentform').insertAfter('#comment' + cid);
	$('#reply-to-comment').val(cid);
	/*tinyMCE.activeEditor.focus();*/
	var textareaId = 'commentedit';
	tinyMCE.get(textareaId).remove();
	tinyMCE.execCommand("mceAddEditor", false, textareaId);
	tinyMCE.activeEditor.focus();
});
//-->
</script>
<div style="margin-top:10px;margin-bottom:10px;text-align:center;">

<center>


<div id="div-gpt-ad-1527185271042-1" style="height:90px; width:728px;">
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-1'); });
</script>
</div>

</center>
</div>


<form action="/community/login/login?redirect=/how-to-install-koel-music-streaming-server-using-docker-on-rocky-linux-8/" method="post" class="xenForm eAuth" id="login" style="display:none">
<ul id="eAuthUnit">
<li><a href="/community/register/facebook?reg=1" class="fbLogin" tabindex="110"><span>Log in with Facebook</span></a></li>
<li><a href="/community/register/twitter?reg=1" class="twitterLogin" tabindex="110"><span>Log in with Twitter</span></a></li>
<li><span class="googleLogin GoogleLogin JsOnly" tabindex="110" data-client-id="198773272284-b6tfk0c28bje81p774prrcrkq9jb3o44.apps.googleusercontent.com" data-redirect-url="/community/register/google?code=__CODE__&amp;csrf=hVMXbW_3rnrmq4Em"><span>Log in with Google</span></span></li>
</ul>
<div class="ctrlWrapper">
<dl class="ctrlUnit">
<dt><label for="LoginControl">Your name or email address:</label></dt>
<dd><input type="text" name="login" id="LoginControl" class="textCtrl" tabindex="101" /></dd>
</dl>
<dl class="ctrlUnit">
<dt>
<label for="ctrl_password">Do you already have an account?</label>
</dt>
<dd>
<ul>
<li><label for="ctrl_not_registered"><input type="radio" name="register" value="1" id="ctrl_not_registered" tabindex="105" />
No, create an account now.</label></li>
<li><label for="ctrl_registered"><input type="radio" name="register" value="0" id="ctrl_registered" tabindex="105" checked="checked" class="Disabler" />
Yes, my password is:</label></li>
<li id="ctrl_registered_Disabler">
<input type="password" name="password" class="textCtrl" id="ctrl_password" tabindex="102" />
<div class="lostPassword"><a href="/community/lost-password/" tabindex="106">Forgot your password?</a></div>
</li>
</ul>
</dd>
</dl>
<dl class="ctrlUnit submitUnit">
<dt></dt>
<dd>
<input type="submit" class="button primary" value="Log in" tabindex="104" data-loginphrase="Log in" data-signupphrase="Sign up" />
<label for="ctrl_remember" class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_remember" tabindex="103" /> Stay logged in</label>
</dd>
</dl>
</div>
<input type="hidden" name="cookie_check" value="1" />
<input type="hidden" name="redirect" value="/community/" />
<input type="hidden" name="_xfToken" value="" />
</form>

</div>
</div>

<aside>
<div class="sidebar">
<div class="section loginButton">
<div class="secondaryContent">
<label for="LoginControl" id="SignupButton"><a href="/community/login/" class="inner">Sign up now!</a></label>
</div>
</div>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-2">

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent socialMediaIcon">
<a href="https://twitter.com/howtoforgecom" target="_blank"><img src="/images/socialmedia/64x64/twitter.png" /></a>
<a href="https://www.facebook.com/howtoforge" target="_blank"><img src="/images/socialmedia/64x64/facebook.png" /></a>
<a href="https://news.ycombinator.com/" target="_blank" rel="nofollow"><img src="/images/socialmedia/64x64/hackernews.png" /></a>
<a href="https://www.howtoforge.com/feed" target="_blank"><img src="/images/socialmedia/64x64/rss.png" /></a>
</div>
</div>
</div>
<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Tutorial Info</p>
<div class="pairsJustified">
<dl class="discussionCount">
<dt>Author:</dt>
<dd><a href="/author/navjot+singh/" rel="author">Navjot Singh</a></dd>
</dl>
<dl class="discussionCount">
<dt>Published:</dt>
<dd>May 09, 2022</dd>
</dl>
<dl class="discussionCount">
<dt>Tags:</dt>
<dd><a href="/tutorials/linux/" rel="tag">linux</a>, <a href="/tutorials/php/" rel="tag">php</a></dd>
</dl>
</div>
</div>
</div>

<div id="sponsor-banner">
</div>

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent">
<p class="mnuinfo mnushare">Share This Page</p>
<p style="text-align:center;">
<a href="javascript:window.open(&#39;https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-koel-music-streaming-server-using-docker-on-rocky-linux-8%2F&#39;, &#39;_blank&#39;, &#39;status=1,height=500,width=360,resizable=0&#39;);void(0);"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="javascript:window.open(&#39;https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-koel-music-streaming-server-using-docker-on-rocky-linux-8%2F&amp;text=How+to+Install+Koel+Music+Streaming+Server+using+Docker+on+Rocky+Linux+8&amp;via=howtoforgecom&amp;related=howtoforgecom&#39;, &#39;_blank&#39;, &#39;status=1,height=500,width=360,resizable=0&#39;);void(0);"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="javascript:window.open(&#39;https://news.ycombinator.com/submitlink?t=How+to+Install+Koel+Music+Streaming+Server+using+Docker+on+Rocky+Linux+8&amp;u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-koel-music-streaming-server-using-docker-on-rocky-linux-8%2F&#39;, &#39;_blank&#39;, &#39;status=1,height=500,width=360,resizable=0&#39;);void(0);"><img src="/images/socialmedia/btn-hackernews.png" height="20" /></a>
</p>
<p style="color:#EE; font-weight:bold; text-align:center; margin-top:5px;">40.2k Followers</p>
</div>
</div>
</div>


<script type="text/javascript">
    google_ad_client = "ca-pub-3043223216276099";
    google_ad_slot = "6709042890";
    google_ad_width = 300;
    google_ad_height = 600;
</script>

<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>


<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Popular Tutorials</p>
<div class="pairsJustified">
<ul>
<li><a href="/intrusion_detection_with_ossec_hids">Securing Your Server With A Host-based Intrusion Detection System</a></li>
<li><hr /></li>
<li><a href="/test_your_linux_firewall_with_ftester">How To Test Your Linux-Distro Firewall</a></li>
<li><hr /></li>
<li><a href="/tutorial/ispconfig-multiserver-setup-debian-ubuntu/">ISPConfig Perfect Multiserver setup on Ubuntu 20.04 and Debian 10</a></li>
<li><hr /></li>
<li><a href="/how-to-install-vnc-server-on-debian-11/">How to Install VNC Server on Debian 11</a></li>
<li><hr /></li>
<li><a href="/tutorial/linux-grep-command/">How to use grep to search for strings in files on the Linux shell</a></li>
<li><hr /></li>
<li><a href="/how-to-install-gitea-code-hosting-using-docker-on-rocky-linux-8/">How to Install Gitea Code Hosting using Docker on Rocky Linux 8</a></li>
<li><hr /></li>
<li><a href="/tutorial/perfect-server-ubuntu-18-04-nginx-bind-dovecot-and-ispconfig-3/">The Perfect Server - Ubuntu 18.04 (Nginx, MySQL, PHP, Postfix, BIND, Dovecot, Pure-FTPD and ISPConfig 3.1)</a></li>
<li><hr /></li>
<li><a href="/managing-a-headless-virtualbox-installation-with-phpvirtualbox-ubuntu-12.04">Managing A Headless VirtualBox Installation With phpvirtualbox (Ubuntu 12.04)</a></li>
<li><hr /></li>
<li><a href="/how-to-install-netdata-on-alma-linux-8/">How to Install Netdata with Nginx on Alma Linux 8</a></li>
<li><hr /></li>
<li><a href="/linux-lscpu-command/">Linux lscpu Command Tutorial for Beginners (5 Examples)</a></li>
<li><hr /></li>
</ul>
</div>
</div>
</div>
</div>
</div>
</aside>
</div>
</div>
</div>
<footer>
<div class="footer">
<div class="pageWidth">
<div class="pageContent">
<div class="skin_branding"><span>Xenforo skin by <a href="http://www.xenfocus.com" rel="nofollow">Xenfocus</a></span></div>
<ul class="footerLinks">
<li><a href="https://howtoforge.nl">Dutch</a></li>
<li><a href="https://howtoforge.fr">French</a></li>
<li><a href="/contribute/">Contribute</a></li>
<li><a href="/community/misc/contact">Contact</a></li>
<li><a href="/community/help/">Help</a></li>
<li><a href="/imprint/">Imprint and Legal Notice</a></li>
<li><a href="#navigation" class="topLink">Top</a></li>
<li><a href="/feed" rel="alternate" class="globalFeed" target="_blank" title="RSS-Feed for Howtoforge">RSS-Feed</a></li>
</ul>
<span class="helper"></span>
</div>
</div>
</div>
<div class="footerLegal">
<div class="pageWidth">
<div class="pageContent">
<ul id="legal">
<li><a href="/community/help/terms">Terms and Rules</a> <a href="https://www.howtoforge.com/community/help/privacy-policy">Privacy Policy</a></li>
</ul>
<div id="copyright"><a href="https://www.howtoforge.com" class="concealed">Howtoforge <span>© projektfarm GmbH.</span></a></div>
<span class="helper"></span>
</div>
</div>
</div>
</footer>
<div style="height:100px;"></div>

<div id="subscriptionModal" class="modal">
<div class="modal-content">
<span class="close">×</span>
<p>This feature is only available to subscribers. Get your subscription <a href="/subscription">here</a>.</p>
</div>
</div>
<script>
//* Modal
var modal = document.getElementById('subscriptionModal');
var span = document.getElementsByClassName("close")[0];
$(".pdf-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
$(".print-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
span.onclick = function() {
	$("#subscriptionModal").css('display', 'none');
}
window.onclick = function(event) {
    if (event.target == modal) {
		$("#subscriptionModal").css('display', 'none');
    }
}
//* Xenforo
jQuery.extend(true, XenForo,
{
	visitor: { user_id: 0 },
	serverTimeInfo:
	{
		now: 1409831907,
		today: 1409781600,
		todayDow: 4
	},
	_lightBoxUniversal: "0",
	_enableOverlays: "1",
	_animationSpeedMultiplier: "1",
	_overlayConfig:
	{
		top: "10%",
		speed: 200,
		closeSpeed: 100,
		mask:
		{
			color: "rgb(0, 0, 0)",
			opacity: "0.6",
			loadSpeed: 200,
			closeSpeed: 100
		}
	},
	_ignoredUsers: [],
	_loadedScripts: {"node_list":true,"node_category":true,"node_forum":true,"sidebar_share_page":true,"wf_default":true,"bbm_buttons":true,"login_bar":true,"twitter":true},
	_cookieConfig: { path: "/", domain: "", prefix: "xf_"},
	_csrfToken: "",
	_csrfRefreshUrl: "/community/login/csrf-token-refresh",
	_jsVersion: "303ae0ca"
});
jQuery.extend(XenForo.phrases,
{
	cancel: "Cancel",

	a_moment_ago:    "A moment ago",
	one_minute_ago:  "1 minute ago",
	x_minutes_ago:   "%minutes% minutes ago",
	today_at_x:      "Today at %time%",
	yesterday_at_x:  "Yesterday at %time%",
	day_x_at_time_y: "%day% at %time%",

	day0: "Sunday",
	day1: "Monday",
	day2: "Tuesday",
	day3: "Wednesday",
	day4: "Thursday",
	day5: "Friday",
	day6: "Saturday",

	_months: "January,February,March,April,May,June,July,August,September,October,November,December",
	_daysShort: "Sun,Mon,Tue,Wed,Thu,Fri,Sat",

	following_error_occurred: "The following error occurred",
	server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
	logging_in: "Logging in",
	click_image_show_full_size_version: "Click this image to show the full-size version.",
	show_hidden_content_by_x: "Show hidden content by {names}"
});

// Facebook Javascript SDK
XenForo.Facebook.appId = "";
XenForo.Facebook.forceInit = true;

/*
document.addEventListener('DOMContentLoaded', function(event) {
  cookieChoices.showCookieConsentBar('Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.',
  'OK');
});
*/

$(document).ready(function() {
	$("a.fancybox").fancybox();
});

</script>

<script>
_bsa.init('custom', 'CKYD55QU', 'placement:howtoforge',
    {
      target: '#sponsor-banner',
      template: `
<a href="##link##" style="background: linear-gradient(-330deg, ##backgroundColor##D9, ##backgroundColor##D9 30%, ##backgroundColor## 70%) #fff;" class="native-banner">
<img class="native-img" src="##logo##">
<div style="color: ##textColor##" class="native-tagline">##tagline##</div>
<div style="color: ##textColor##" class="native-desc">##description##</div>
<div style="color: ##ctaTextColor##; background-color: ##ctaBackgroundColor##;" class="native-cta">##callToAction##</div>
<div style="background-color: ##textColor##B2; color: ##backgroundColor##" class="native-ad">Ad</div>
</a>
`
    }
  );
</script>

<script>
(function() {
  if (typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('fancybar', 'CKYDL27E', 'placement:howtoforgecom');
  }
})();
</script>
<script>
(function() {
  if (typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('custom', 'CEBDK2JM', 'placement:howtoforgecom', {
      target: '.bsa-apiads',
      template:
`
<a href="##statlink##" target="_blank" rel="sponsored nofollow">##company## — ##description##</a>
`
    });
  }
})();
</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2155872-1', 'auto');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');

</script>
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('/detroitchicago/edmonton.webp', '/detroitchicago/edmonton.webp?a=a&cb=2&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('/porpoiseant/jellyfish.webp', '/porpoiseant/jellyfish.webp?a=a&cb=2&shcb=34', false, [], true, false, false, false);
</script>
<script>var _audins_dom="howtoforge_com",_audins_did=178704;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=195-2");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.howtoforge_com,DomainId.178704" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=2&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script>
<script>__ez.queue.addFile('/beardeddragon/drake.js', '/beardeddragon/drake.js?gcb=2&cb=2', false, [], true, false, true, false);</script><script type="text/javascript" onload="__ezcl.handle(true);" async src="/utilcave_com/inc/ezcl.webp?cb=4"></script></body></html>