<!DOCTYPE html><html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs LoggedOut Sidebar Responsive" xmlns:fb="http://www.facebook.com/2008/fbml"><head><meta charset="utf-8" />
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=194-2&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=194-2&cb=3', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=194-2&cb=5', false, [], true, false, true, false);</script>
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<base href="https://www.howtoforge.com" />
<script>
			var _b = document.getElementsByTagName('base')[0], _bH = "https://www.howtoforge.com/how-to-install-joomla-with-apache-on-debian-10/";
			if (_b && _b.href != _bH) _b.href = _bH;
		</script>
<title>How to Install Joomla with Apache and Let&#39;s Encrypt SSL on Debian 10</title>
<meta name="description" content="Joomla is a free and open-source content management system used to create, modify and manage the content of a website. In this tutorial, I will show y... " />
<meta property="og:title" content="How to Install Joomla with Apache and Let&#39;s Encrypt SSL on Debian 10" />
<meta property="og:description" content="Joomla is a free and open-source content management system used to create, modify and manage the content of a website. In this tutorial, I will show y... " />
<meta property="og:site_name" content="HowtoForge" />
<meta property="og:type" content="article" />
<meta property="og:image" content="https://www.howtoforge.com/images/featured/joomla-apache-debian.jpg" />
<meta property="og:image:secure_url" content="https://www.howtoforge.com/images/featured/joomla-apache-debian.jpg" />
<meta property="og:image:alt" content="How to Install Joomla with Apache and Let&#39;s Encrypt SSL on Debian 10" />
<meta name="twitter:image" content="https://www.howtoforge.com/images/featured/joomla-apache-debian.jpg" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@howtoforgecom" />
<meta name="twitter:creator" content="@howtoforgecom" />
<meta name="twitter:title" content="How to Install Joomla with Apache and Let&#39;s Encrypt SSL on Debian 10" />
<meta name="twitter:description" content="Joomla is a free and open-source content management system used to create, modify and manage the content of a website. In this tutorial, I will show y... " />
<link rel="alternate" href="https://www.howtoforge.com/how-to-install-joomla-with-apache-on-debian-10/" hreflang="en" />
<link rel="canonical" href="https://www.howtoforge.com/how-to-install-joomla-with-apache-on-debian-10/" />
<link rel="amphtml" href="https://www.howtoforge.com/how-to-install-joomla-with-apache-on-debian-10/amp/" />
<script type="application/ld+json">
{
  "@context" : "http://schema.org",
  "@type" : "Article",
  "name" : "How to Install Joomla with Apache and Let's Encrypt SSL on Debian 10",
  "author" : {
    "@type" : "Person",
    "name" : "Hitesh Jethva"
  },
  "articleSection" : "apache,debian,linux,web server",
  "url" : "https://www.howtoforge.com/how-to-install-joomla-with-apache-on-debian-10/",
  "publisher" : {
    "@type" : "Organization",
    "name" : "Howtoforge"
  }
}
</script>
<noscript><style>.JsOnly, .jsOnly { display: none !important; }</style></noscript>
<link rel="stylesheet" href="/community/styles/executive/xenfocus/icons/css/font-awesome.min.css" />
<link href="//fonts.googleapis.com/css?family=Open+Sans:400,700" rel="stylesheet" type="text/css" />
<link href="/themes/howtoforge/templates/xf.css" rel="stylesheet" />
<script src="/js/jquery/jquery-1.11.3.min.js"></script>
<script src="/community/js/xenforo/xenforo.js?_v=303ae0ca"></script>
<script src="/community/js/bbm/zloader.js?_v=303ae0ca"></script>
<script type="text/javascript" src="/js/fancybox/jquery.mousewheel-3.0.4.pack.js"></script>
<script type="text/javascript" src="/js/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
<link rel="stylesheet" type="text/css" href="/js/fancybox/jquery.fancybox-1.3.4.css" media="screen" />
<link href="/themes/howtoforge/templates/style.min.css" rel="stylesheet" />
<link rel="alternate" type="application/rss+xml" title="RSS-Feed für Howtoforge" href="/feed.rss" />
<script src="/js/tinymce_4.1.7/tinymce.min.js"></script>
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/skin.min.css" as="style" />
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/content.min.css" as="style" />
<link rel="preload" href="/themes/howtoforge/css/custom.css" as="style" />
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/fonts/tinymce.woff" as="font" />

<script type="text/javascript">
var gaProperty = 'UA-2155872-1';
var disableStr = 'ga-disable-' + gaProperty;
if (document.cookie.indexOf(disableStr + '=true') > -1) {
window[disableStr] = true;
}
function gaOptout() {
document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
window[disableStr] = true;
alert('Google Ananlyitics tracking has been disabled in this browser.');
}
</script>
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
	googletag.defineSlot('/1030080/howtoforge_com_list_sidebar_top', [300, 250], 'div-gpt-ad-1527185271042-4').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_list_content_middle', [[300, 250], [336, 280]], 'div-gpt-ad-1527185271042-5').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_a_300x250', [300, 250], 'div-gpt-ad-1527185271042-6').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_b_300x250', [300, 250], 'div-gpt-ad-1527185271042-7').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_leaderboard_b_728x90', [728, 90], 'div-gpt-ad-1527185271042-1').addService(googletag.pubads());
	googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-3043223216276099",
          enable_page_level_ads: true
     });
</script>


<script type="text/javascript" src="//m.servedby-buysellads.com/monetization.js"></script>

<script type="text/javascript">var ezouid = "1";</script><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script>
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 178704;
var ezdomain = 'howtoforge.com';
var ezoicSearchable = 1;
</script>


<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":178704,"domain_test_group":20210302,"engaged_time_visit":0,"ezcache_level":2,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"43a63644-8b4a-4811-7bc4-f5575f29a503","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":47393,"response_time_orig":3,"serverid":"3.80.126.156:2675","state":"VA","t_epoch":1617961795,"template_id":126,"time_on_site_visit":0,"url":"https://www.howtoforge.com/how-to-install-joomla-with-apache-on-debian-10/","user_id":0,"word_count":1917,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_178704=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["43a63644-8b4a-4811-7bc4-f5575f29a503", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script><script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head>
<body>
<div id="loginBar">
<div class="pageWidth">
<div class="pageContent">
<h3 id="loginBarHandle">
<label for="LoginControl"><a href="/community/login/" class="concealed noOutline">Log in or Sign up</a></label>
</h3>
<span class="helper"></span>
</div>
</div>
</div>
<header>
<div id="header">
<div id="logoBlock">
<div class="pageWidth">
<div class="pageContent">
<div id="logo"><a href="/">
<span></span>
<img src="/images/howtoforge_logo_trans.gif" alt="Howtoforge" style="margin-left:20px;" />
</a></div>
<span class="helper"></span>
</div>
</div>
</div>
<div id="navigation" class="pageWidth withSearch">
<div class="pageContent">
<nav>
<div class="navTabs">
<ul class="publicTabs">

<li class="navTab forums selected">
<a href="/" class="navLink">Tutorials</a>
<div class="tabLinks forumsTabLinks">
<ul class="secondaryContent blockLinksList">
<li><a href="/search/">Tutorial search</a></li>
</ul>
</div>
</li>
<li class="navTab forums PopupClosed">
<a href="/tutorials/" class="navLink">Tags</a>
</li>
<li class="navTab forums PopupClosed"><a href="/community/" class="navLink">Forums</a></li>
<li class="navTab forums PopupClosed"><a href="/linux-commands/" class="navLink">Linux Commands</a></li>
<li class="navTab forums PopupClosed"><a href="/subscription/" class="navLink">Subscribe</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.ispconfig.org" class="navLink">ISPConfig</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.lxer.com" class="navLink">News</a></li>
</ul>
</div>
<span class="helper"></span>
</nav>
</div>
</div>
<div id="searchBar" class="pageWidth">
<span id="QuickSearchPlaceholder" title=" Search..."> Search</span>
<fieldset id="QuickSearch">
<form action="/" method="post" class="formPopup">
<div class="primaryControls">

<input type="search" name="q" value="" class="textCtrl" placeholder="Search..." results="0" title="Enter your search and hit enter..." id="QuickSearchQuery" />

</div>
<input type="hidden" name="_xfToken" value="" />
</form>
</fieldset>
</div>
</div>
</header>
<div id="content" class="forum_list">
<div class="pageWidth">
<div class="pageContent">

<div class="mainContainer">
<div class="mainContent">

<div class="breadBoxTop">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Home</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/how-to-install-joomla-with-apache-on-debian-10/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to Install Joomla with Apache and Let&#39;s Encrypt SSL on Debian 10</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>

<div id="htfContentPage">
<div class="bsa-apiads"></div>
<article>
<h1>How to Install Joomla with Apache and Let&#39;s Encrypt SSL on Debian 10</h1>
<div class="contributeEdit" style="float:right; width:450px; max-width:100%;">
<div id="tocContainer">
<h3>This tutorial exists for these OS versions</h3>
<ul><li><strong>Debian 10 (Buster)</strong></li><li><a href="/tutorial/how-to-install-joomla-on-debian-9/">Debian 9 (Stretch)</a></li></ul> <h3>On this page</h3>
<ol class="toc">
<li><a href="#prerequisites">Prerequisites</a></li>
<li><a href="#getting-started">Getting Started</a></li>
<li><a href="#install-lamp-server">Install LAMP Server</a></li>
<li><a href="#create-a-database-for-joomla">Create a Database for Joomla</a></li>
<li><a href="#install-joomla">Install Joomla</a></li>
<li><a href="#configure-apache-web-server">Configure Apache Web Server</a></li>
<li><a href="#access-joomla">Access Joomla</a></li>
<li><a href="#secure-joomla-with-lets-encrypt-ssl">Secure Joomla with Let&#39;s Encrypt SSL</a></li>
<li><a href="#conclusion">Conclusion</a></li>
</ol>
</div>
</div>
<p>Joomla is a free and open-source content management system used to create, modify and manage the content of a website. It is simple and easy to use so you don&#39;t need to have any HTML or CSS knowledge to build the website. It is written in PHP and uses MySQL as a database. It offers a wide range of features that make it a flexible content management system right out of the box. It comes with hundreds of free extensions that allow you to customize and extend the functionality.</p>
<p>In this tutorial, I will show you how to install Joomla CMS with Apache and Let&#39;s Encrypt on Debian 10.</p>
<h2 id="prerequisites">Prerequisites</h2>
<ul>
<li>A server running Debian 10.</li>
<li>A valid domain name pointed with your server IP.</li>
<li>A root password is configured the server.</li>
</ul>
<h2 id="getting-started">Getting Started</h2>
<p>First, update the system packages to the updated version by running the following command:</p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;">

<div id="div-gpt-ad-1527185271042-6" style="height:250px; width:300px;">
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-6'); });
</script>
</div>
</div>
<pre class="command"><code spellcheck="false">apt-get update -y</code></pre>
<p>Once all the packages are updated, you can proceed to the next step.</p>
<h2 id="install-lamp-server">Install LAMP Server</h2>
<p>Next, you will need to install the Apache web server, MariaDB database, PHP and other PHP extensions to your system. You can install all of them with the following command:</p>
<pre class="command"><code spellcheck="false">apt-get install apache2 mariadb-server php openssl php-imagick php-common php-curl php-gd php-imap php-intl php-json php-ldap php-mbstring php-mysql php-pgsql php-smbclient php-ssh2 php-sqlite3 php-xml php-zip -y</code></pre>
<p>Once all the packages are installed, you can proceed to the next step.</p>
<h2 id="create-a-database-for-joomla">Create a Database for Joomla</h2>
<p>Joomla uses MySQL or MariaDB to store its content. So you will need to create a database and user for Joomla.</p>
<p>First, connect to the MariaDB with the following command:</p>
<pre class="command"><code spellcheck="false">mysql</code></pre>
<p>Once connected, create a database and user with the following command:</p>
<pre class="command"><code spellcheck="false">MariaDB [(none)]&gt; CREATE DATABASE joomladb;<br />MariaDB [(none)]&gt; GRANT ALL ON joomladb.* TO &#39;joomlauser&#39;@&#39;localhost&#39; IDENTIFIED BY &#39;password&#39;;</code></pre>
<p>Next, flush the privileges and exit from the MariaDB with the following command:</p>
<pre class="command"><code spellcheck="false">MariaDB [(none)]&gt; FLUSH PRIVILEGES;<br />MariaDB [(none)]&gt; EXIT;</code></pre>
<p>Once you are finished, you can proceed to the next step.</p>
<h2 id="install-joomla">Install Joomla</h2>
<p>Next, download the latest version of Joomla with the following command:</p>
<pre class="command"><code spellcheck="false">wget https://downloads.joomla.org/cms/joomla3/3-9-25/Joomla_3-9-25-Stable-Full_Package.tar.bz2</code></pre>
<p>Once the download is completed, create a directory for Joomla inside the Apache web root:</p>
<pre class="command"><code spellcheck="false">mkdir /var/www/html/joomla</code></pre>
<p>Next, run the following command to extract the downloaded file to the Joomla directory:</p>
<pre class="command"><code spellcheck="false">bunzip2 Joomla_3-9-25-Stable-Full_Package.tar.bz2<br />tar -xvf Joomla_3-9-25-Stable-Full_Package.tar -C /var/www/html/joomla/</code></pre>
<p>Next, set proper permission and ownership to the Joomla directory with the following command:</p>
<pre class="command"><code spellcheck="false">chown -R www-data:www-data /var/www/html/joomla<br />chmod -R 755 /var/www/html/joomla</code></pre>
<p>Once you are finished, you can proceed to the next step.</p>
<h2 id="configure-apache-web-server">Configure Apache Web Server</h2>
<p>Next, you will need to create an Apache virtual host configuration file to host the Joomla.</p>
<p>You can create it with the following command:</p>
<pre class="command"><code spellcheck="false">nano /etc/apache2/sites-available/joomla.conf</code></pre>
<p>Add the following lines:</p>
<pre>&lt;VirtualHost *:80&gt;
   ServerName joomla.example.com 
   ServerAdmin <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="6512000708041611001725001d04081509004b060a08">[email&#160;protected]</a>
   DocumentRoot /var/www/html/joomla
   &lt;Directory /var/www/html/joomla&gt;
	    Allowoverride all
   &lt;/Directory&gt;
&lt;/VirtualHost&gt;
</pre>
<p>Save and close the file then enable the Apache virtual host with the following command:</p>
<pre class="command"><code spellcheck="false">a2ensite joomla</code></pre>
<p>Next, restart the Apache service to apply the changes:</p>
<pre class="command"><code spellcheck="false">systemctl restart apache2</code></pre>
<p>Next, verify the status of the Apache with the following command:</p>
<pre class="command"><code spellcheck="false">systemctl status apache2</code></pre>
<p>You should get the following output:</p>
<pre>? apache2.service - The Apache HTTP Server
   Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
   Active: active (running) since Mon 2021-03-22 09:26:20 UTC; 4s ago
     Docs: https://httpd.apache.org/docs/2.4/
  Process: 14495 ExecStart=/usr/sbin/apachectl start (code=exited, status=0/SUCCESS)
 Main PID: 14499 (apache2)
    Tasks: 6 (limit: 4701)
   Memory: 18.8M
   CGroup: /system.slice/apache2.service
           ??14499 /usr/sbin/apache2 -k start
           ??14500 /usr/sbin/apache2 -k start
           ??14501 /usr/sbin/apache2 -k start
           ??14502 /usr/sbin/apache2 -k start
           ??14503 /usr/sbin/apache2 -k start
           ??14504 /usr/sbin/apache2 -k start

Mar 22 09:26:20 debian10 systemd[1]: Starting The Apache HTTP Server...
</pre>
<h2 id="access-joomla">Access Joomla</h2>
<p>Now, open your web browser and access the Joomla web interface using the URL<strong> http://joomla.example.com</strong>. You will be redirected to the following page:</p>
<p><a class="fancybox" id="img-p1" href="https://www.howtoforge.com/images/how_to_install_joomla_with_apache_on_debian_10/big/p1.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_joomla_with_apache_on_debian_10/p1.png" alt="Joomla installer" width="750" height="409" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Now, provide your site name, email address, admin username, password, and click on the <strong>Next</strong> button. You should see the following page:</p>
<p><a class="fancybox" id="img-p3" href="https://www.howtoforge.com/images/how_to_install_joomla_with_apache_on_debian_10/big/p3.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_joomla_with_apache_on_debian_10/p3.png" alt="Database configuration" width="750" height="470" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Provide your database name, database username, password, and click on the <strong>Next</strong> button. You should see the following page:</p>
<p><a class="fancybox" id="img-p4" href="https://www.howtoforge.com/images/how_to_install_joomla_with_apache_on_debian_10/big/p4.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_joomla_with_apache_on_debian_10/p4.png" alt="Finalize installation" width="750" height="413" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p><a class="fancybox" id="img-p41" href="https://www.howtoforge.com/images/how_to_install_joomla_with_apache_on_debian_10/big/p41.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_joomla_with_apache_on_debian_10/p41.png" alt="Pre-installation check" width="750" height="336" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Now, confirm all the settings and click on the<strong> Install</strong> button to start the installation. Once the installation has been completed, you should see the following page:</p>
<p><a class="fancybox" id="img-p5" href="https://www.howtoforge.com/images/how_to_install_joomla_with_apache_on_debian_10/big/p5.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_joomla_with_apache_on_debian_10/p5.png" alt="Joomla installed successfully" width="750" height="448" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Click on the <strong>Remove</strong> <strong>installation</strong> <strong>folder</strong>. You should see the following page:</p>
<p><a class="fancybox" id="img-p6" href="https://www.howtoforge.com/images/how_to_install_joomla_with_apache_on_debian_10/big/p6.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_joomla_with_apache_on_debian_10/p6.png" alt="Remove installation folder" width="750" height="335" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Now, click on the <strong>Administrator</strong> button, you should see the Joomla login page:</p>
<p><a class="fancybox" id="img-p7" href="https://www.howtoforge.com/images/how_to_install_joomla_with_apache_on_debian_10/big/p7.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_joomla_with_apache_on_debian_10/p7.png" alt="Joomla Login" width="750" height="351" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Provide your Admin credentials and click on the <strong>Login</strong> button, you should see the Joomla Control Panel in the following image:</p>
<p><a class="fancybox" id="img-p9" href="https://www.howtoforge.com/images/how_to_install_joomla_with_apache_on_debian_10/big/p9.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_joomla_with_apache_on_debian_10/p9.png" alt="Joomla Admin Dashboard" width="750" height="395" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<h2 id="secure-joomla-with-lets-encrypt-ssl">Secure Joomla with Let&#39;s Encrypt SSL</h2>
<p>It is always a good idea to secure your website with Let&#39;s Encrypt SSL. You will need to install the Certbot client to install and manage the SSL. You can install it with the following command:</p>
<pre class="command"><code spellcheck="false">apt-get install python3-certbot-apache -y</code></pre>
<p>Once the Certbot is installed, run the following command to secure your website with Let&#39;s Encrypt SSL:</p>
<pre class="command"><code spellcheck="false">certbot --apache -d joomla.example.com</code></pre>
<p>You will be asked to provide your email and accept the term of service as shown below:</p>
<pre>Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator standalone, Installer None
Enter email address (used for urgent renewal and security notices) (Enter &#39;c&#39; to
cancel): <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="305859445a55445846510109080170575d51595c1e535f5d">[email&#160;protected]</a>

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Please read the Terms of Service at
https://letsencrypt.org/documents/LE-SA-v1.2-November-15-2017.pdf. You must
agree in order to register with the ACME server at
https://acme-v02.api.letsencrypt.org/directory
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
(A)gree/(C)ancel: A

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Would you be willing to share your email address with the Electronic Frontier
Foundation, a founding partner of the Let&#39;s Encrypt project and the non-profit
organization that develops Certbot? We&#39;d like to send you email about our work
encrypting the web, EFF news, campaigns, and ways to support digital freedom.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
(Y)es/(N)o: Y
Plugins selected: Authenticator apache, Installer apache
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for joomla.example.com
Enabled Apache rewrite module
Waiting for verification...
Cleaning up challenges
Created an SSL vhost at /etc/apache2/sites-available/joomla-le-ssl.conf
Enabled Apache socache_shmcb module
Enabled Apache ssl module
Deploying Certificate to VirtualHost /etc/apache2/sites-available/joomla-le-ssl.conf
Enabling available site: /etc/apache2/sites-available/joomla-le-ssl.conf
</pre>
<p>Next, select whether or not to redirect HTTP traffic to HTTPS as shown below:</p>
<pre>Please choose whether or not to redirect HTTP traffic to HTTPS, removing HTTP access.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
1: No redirect - Make no further changes to the webserver configuration.
2: Redirect - Make all requests redirect to secure HTTPS access. Choose this for
new sites, or if you&#39;re confident your site works on HTTPS. You can undo this
change by editing your web server&#39;s configuration.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Select the appropriate number [1-2] then [enter] (press &#39;c&#39; to cancel): 2
</pre>
<p>Type 2 and hit Enter to install the Let&#39;s Encrypt SSL for your website:</p>
<pre>Enabled Apache rewrite module
Redirecting vhost in /etc/apache2/sites-enabled/joomla.conf to ssl vhost in /etc/apache2/sites-available/joomla-le-ssl.conf

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Congratulations! You have successfully enabled https://joomla.example.com

You should test your configuration at:
https://www.ssllabs.com/ssltest/analyze.html?d=joomla.example.com
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

IMPORTANT NOTES:
 - Congratulations! Your certificate and chain have been saved at:
   /etc/letsencrypt/live/joomla.example.com/fullchain.pem
   Your key file has been saved at:
   /etc/letsencrypt/live/joomla.example.com/privkey.pem
   Your cert will expire on 2020-10-23. To obtain a new or tweaked
   version of this certificate in the future, simply run certbot again
   with the &#34;certonly&#34; option. To non-interactively renew *all* of
   your certificates, run &#34;certbot renew&#34;
 - If you like Certbot, please consider supporting our work by:

   Donating to ISRG / Let&#39;s Encrypt:   https://letsencrypt.org/donate
   Donating to EFF:                    https://eff.org/donate-le
</pre>
<h2 id="conclusion">Conclusion</h2>
<p>Congratulations! you have successfully installed Joomla CMS on Debian 10 server. You can now build your own website easily using Joomla. Feel free to ask me if you have any questions.</p>
</article>

<aside class="authorbox" style="margin-top:20px;">
<img src="/images/profile/hitesh-80.jpg" alt="Hitesh Jethva" /> <p><strong>About Hitesh Jethva</strong></p>
<p>Over 8 years of experience as a Linux system administrator. My skills include a depth knowledge of Redhat/Centos, Ubuntu Nginx and Apache, Mysql, Subversion, Linux, Ubuntu, web hosting, web server, Squid proxy, NFS, FTP, DNS, Samba, LDAP, OpenVPN, Haproxy, Amazon web services, WHMCS, OpenStack Cloud, Postfix Mail Server, Security etc.</p>
</aside>

<div style="height:30px; margin-top:20px;">
<p style="text-align:right;"><img src="/images/pdficon_small.png" /> <a class="pdf-btn" href="javascript:void(0);">view as pdf</a> | <img src="/images/print.gif" /> <a class="print-btn" href="javascript:void(0);">print</a></p>
</div>
<div style="height:30px; margin-top:20px;">
<div style="float:left;"><b>Share this page:</b></div>
<p style="text-align:center;">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-joomla-with-apache-on-debian-10%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-joomla-with-apache-on-debian-10%2F&amp;text=How+to+Install+Joomla+with+Apache+and+Let%27s+Encrypt+SSL+on+Debian+10&amp;via=howtoforgecom&amp;related=howtoforgecom" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-joomla-with-apache-on-debian-10%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-gplus.png" height="20" /></a>
</p>
</div>
</div>


<div id="htfContentPagePaging">
<h2>Suggested articles</h2>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-3043223216276099" data-ad-slot="8940054090"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>


<div id="htfContentPageComment">
<a name="comments"></a>
<h2>0 Comment(s)</h2>

<div id="commentform">
<div class="commentContainerHead" style="font-size:18px;">Add comment</div>
<div class="commentContainer">
<form method="post" action="/how-to-install-joomla-with-apache-on-debian-10/#comments">
<input type="hidden" name="reply_to" id="reply-to-comment" value="0" />
<div id="commentFormDetail">
<div style="width:48%; float:left; margin-right:3%">
<label for="commentname">Name *</label>
<input id="commentname" name="commentname" value="" />
</div>
<div style="width:48%;float:left;">
<label for="commentname">Email *</label>
<input id="commentemail" name="commentemail" value="" />
</div>
<div style="clear:both;"></div>
</div>
<textarea id="commentedit" name="commentedit" style="width:auto;"></textarea>
<div>
<div style="float:left;">
<div class="g-recaptcha" data-sitekey="6LdX9fUSAAAAALWwVoPdeXScMSketz4npF-0QcQ1"></div>
<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en">
      </script>
</div>
<div style="margin-top:10px;margin-bottom:10px;">
<input type="submit" name="submit" class="button primary" style="float:right;" value="Submit comment" />
</div>
<div style="clear:both;"></div>
</div>
<script>
	tinymce.init({
		selector: "textarea#commentedit",
		theme: "modern",
		height: 100,
		apply_source_formatting : true,
		remove_linebreaks : false,
		menubar : false,
		/*auto_focus : "commentedit",*/
		plugins: [
		"link"
		],
		/*plugins: [
			"advlist autolink link image lists charmap print preview hr anchor pagebreak spellchecker",
			"searchreplace wordcount visualblocks visualchars code fullscreen insertdatetime media nonbreaking",
			"save table contextmenu directionality emoticons template paste textcolor"
		],*/
		content_css: "https://www.howtoforge.com/themes/howtoforge/css/custom.css",
		toolbar: "undo redo | bold italic link", 
		/*style_formats: [
			{title: 'Bold text', inline: 'b'},
			{title: 'Red text', inline: 'span', styles: {color: '#ff0000'}},
			{title: 'Red header', block: 'h1', styles: {color: '#ff0000'}},
			{title: 'Example 1', inline: 'span', classes: 'example1'},
			{title: 'Example 2', inline: 'span', classes: 'example2'},
			{title: 'Table styles'},
			{title: 'Table row 1', selector: 'tr', classes: 'tablerow1'}
		]*/
	}); 
	</script>
</form>
</div>
</div>

</div>

<div class="breadBoxBottom">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Home</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/how-to-install-joomla-with-apache-on-debian-10/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to Install Joomla with Apache and Let&#39;s Encrypt SSL on Debian 10</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
<script>
<!--

$(document).on('click', 'a.reply-to', function(e) {
	e.preventDefault();
	
	var self = $(this);
	var cid = self.attr('data-comment');
	console.log(cid);
	if(!cid) return this;
	
	$('#commentform').insertAfter('#comment' + cid);
	$('#reply-to-comment').val(cid);
	/*tinyMCE.activeEditor.focus();*/
	var textareaId = 'commentedit';
	tinyMCE.get(textareaId).remove();
	tinyMCE.execCommand("mceAddEditor", false, textareaId);
	tinyMCE.activeEditor.focus();
});
//-->
</script>
<div style="margin-top:10px;margin-bottom:10px;text-align:center;">

<center>


<div id="div-gpt-ad-1527185271042-1" style="height:90px; width:728px;">
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-1'); });
</script>
</div>

</center>
</div>


<form action="/community/login/login?redirect=/how-to-install-joomla-with-apache-on-debian-10/" method="post" class="xenForm eAuth" id="login" style="display:none">
<ul id="eAuthUnit">
<li><a href="/community/register/facebook?reg=1" class="fbLogin" tabindex="110"><span>Log in with Facebook</span></a></li>
<li><a href="/community/register/twitter?reg=1" class="twitterLogin" tabindex="110"><span>Log in with Twitter</span></a></li>
<li><span class="googleLogin GoogleLogin JsOnly" tabindex="110" data-client-id="198773272284-b6tfk0c28bje81p774prrcrkq9jb3o44.apps.googleusercontent.com" data-redirect-url="/community/register/google?code=__CODE__&amp;csrf=hVMXbW_3rnrmq4Em"><span>Log in with Google</span></span></li>
</ul>
<div class="ctrlWrapper">
<dl class="ctrlUnit">
<dt><label for="LoginControl">Your name or email address:</label></dt>
<dd><input type="text" name="login" id="LoginControl" class="textCtrl" tabindex="101" /></dd>
</dl>
<dl class="ctrlUnit">
<dt>
<label for="ctrl_password">Do you already have an account?</label>
</dt>
<dd>
<ul>
<li><label for="ctrl_not_registered"><input type="radio" name="register" value="1" id="ctrl_not_registered" tabindex="105" />
No, create an account now.</label></li>
<li><label for="ctrl_registered"><input type="radio" name="register" value="0" id="ctrl_registered" tabindex="105" checked="checked" class="Disabler" />
Yes, my password is:</label></li>
<li id="ctrl_registered_Disabler">
<input type="password" name="password" class="textCtrl" id="ctrl_password" tabindex="102" />
<div class="lostPassword"><a href="/community/lost-password/" tabindex="106">Forgot your password?</a></div>
</li>
</ul>
</dd>
</dl>
<dl class="ctrlUnit submitUnit">
<dt></dt>
<dd>
<input type="submit" class="button primary" value="Log in" tabindex="104" data-loginphrase="Log in" data-signupphrase="Sign up" />
<label for="ctrl_remember" class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_remember" tabindex="103" /> Stay logged in</label>
</dd>
</dl>
</div>
<input type="hidden" name="cookie_check" value="1" />
<input type="hidden" name="redirect" value="/community/" />
<input type="hidden" name="_xfToken" value="" />
</form>

</div>
</div>

<aside>
<div class="sidebar">
<div class="section loginButton">
<div class="secondaryContent">
<label for="LoginControl" id="SignupButton"><a href="/community/login/" class="inner">Sign up now!</a></label>
</div>
</div>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-2">

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent socialMediaIcon">
<a href="https://twitter.com/howtoforgecom" target="_blank"><img src="/images/socialmedia/64x64/twitter.png" /></a>
<a href="https://www.facebook.com/howtoforge" target="_blank"><img src="/images/socialmedia/64x64/facebook.png" /></a>
<a href="https://news.ycombinator.com/" target="_blank" rel="nofollow"><img src="/images/socialmedia/64x64/hackernews.png" /></a>
<a href="https://www.howtoforge.com/feed" target="_blank"><img src="/images/socialmedia/64x64/rss.png" /></a>
</div>
</div>
</div>
<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Tutorial Info</p>
<div class="pairsJustified">
<dl class="discussionCount">
<dt>Author:</dt>
<dd><a href="/author/hitesh+jethva/" rel="author">Hitesh Jethva</a></dd>
</dl>
<dl class="discussionCount">
<dt>Published:</dt>
<dd>Apr 08, 2021</dd>
</dl>
<dl class="discussionCount">
<dt>Tags:</dt>
<dd><a href="/tutorials/apache/" rel="tag">apache</a>, <a href="/tutorials/debian/" rel="tag">debian</a>, <a href="/tutorials/linux/" rel="tag">linux</a>, <a href="/tutorials/web+server/" rel="tag">web server</a></dd>
</dl>
</div>
</div>
</div>

<div id="sponsor-banner">
</div>

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent">
<p class="mnuinfo mnushare">Share This Page</p>
<p style="text-align:center;">
<a href="javascript:window.open(&#39;https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-joomla-with-apache-on-debian-10%2F&#39;, &#39;_blank&#39;, &#39;status=1,height=500,width=360,resizable=0&#39;);void(0);"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="javascript:window.open(&#39;https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-joomla-with-apache-on-debian-10%2F&amp;text=How+to+Install+Joomla+with+Apache+and+Let%27s+Encrypt+SSL+on+Debian+10&amp;via=howtoforgecom&amp;related=howtoforgecom&#39;, &#39;_blank&#39;, &#39;status=1,height=500,width=360,resizable=0&#39;);void(0);"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="javascript:window.open(&#39;https://news.ycombinator.com/submitlink?t=How+to+Install+Joomla+with+Apache+and+Let%27s+Encrypt+SSL+on+Debian+10&amp;u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-joomla-with-apache-on-debian-10%2F&#39;, &#39;_blank&#39;, &#39;status=1,height=500,width=360,resizable=0&#39;);void(0);"><img src="/images/socialmedia/btn-hackernews.png" height="20" /></a>
</p>
<p style="color:#EE; font-weight:bold; text-align:center; margin-top:5px;">40.2k Followers</p>
</div>
</div>
</div>


<script type="text/javascript">
    google_ad_client = "ca-pub-3043223216276099";
    google_ad_slot = "6709042890";
    google_ad_width = 300;
    google_ad_height = 600;
</script>

<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>


<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Popular Tutorials</p>
<div class="pairsJustified">
<ul>
<li><a href="/tutorial/ispconfig-multiserver-setup-debian-ubuntu/">ISPConfig Perfect Multiserver setup on Ubuntu 20.04 and Debian 10</a></li>
<li><hr /></li>
<li><a href="/tutorial/linux-grep-command/">How to use grep to search for strings in files on the shell</a></li>
<li><hr /></li>
<li><a href="/install-varnish-cache-6-for-apache-nginx-on-centos-8/">Install Varnish Cache 6 for Apache/Nginx on CentOS 8</a></li>
<li><hr /></li>
<li><a href="/linux_lvm">A Beginner&#39;s Guide To LVM</a></li>
 <li><hr /></li>
<li><a href="/configure-remote-access-to-your-ubuntu-desktop">How To Configure Remote Access To Your Ubuntu Desktop</a></li>
<li><hr /></li>
<li><a href="/faq/how-to-edit-files-on-the-command-line">How do I edit files on the command line?</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-install-php-7-on-debian/">How to install PHP 7.1, 7.2 and 5.6 as PHP-FPM &amp; FastCGI for ISPConfig 3 on Debian 9</a></li>
<li><hr /></li>
<li><a href="/tutorial/centos-passbolt-password-manager-installation/">How to Install Passbolt Self-Hosted Password Manager on CentOS 8</a></li>
<li><hr /></li>
<li><a href="/how-to-copy-items-from-one-dynamodb-to-another-dynamodb-table-using-python-on-aws/">How to copy items from one DynamoDB to another DynamoDB table using Python on AWS</a></li>
<li><hr /></li>
<li><a href="/tutorial/repair-linux-boot-with-grub-rescue/">Repair Linux boot failures in GRUB 2 rescue mode</a></li>
<li><hr /></li>
</ul>
</div>
</div>
</div>
</div>
</div>
</aside>
</div>
</div>
</div>
<footer>
<div class="footer">
<div class="pageWidth">
<div class="pageContent">
<div class="skin_branding"><span>Xenforo skin by <a href="http://www.xenfocus.com" rel="nofollow">Xenfocus</a></span></div>
<ul class="footerLinks">
<li><a href="/contribute/">Contribute</a></li>
<li><a href="/community/misc/contact">Contact</a></li>
<li><a href="/community/help/">Help</a></li>
<li><a href="/imprint/">Imprint and Legal Notice</a></li>
<li><a href="#navigation" class="topLink">Top</a></li>
<li><a href="/feed" rel="alternate" class="globalFeed" target="_blank" title="RSS-Feed for Howtoforge">RSS-Feed</a></li>
</ul>
<span class="helper"></span>
</div>
</div>
</div>
<div class="footerLegal">
<div class="pageWidth">
<div class="pageContent">
<ul id="legal">
<li><a href="/community/help/terms">Terms and Rules</a> <a href="https://www.howtoforge.com/community/help/privacy-policy">Privacy Policy</a></li>
</ul>
<div id="copyright"><a href="https://www.howtoforge.com" class="concealed">Howtoforge <span>© projektfarm GmbH.</span></a></div>
<span class="helper"></span>
</div>
</div>
</div>
</footer>
<div style="height:100px;"></div>

<div id="subscriptionModal" class="modal">
<div class="modal-content">
<span class="close">×</span>
<p>This feature is only available to subscribers. Get your subscription <a href="/subscription">here</a>.</p>
</div>
</div>
<script>
//* Modal
var modal = document.getElementById('subscriptionModal');
var span = document.getElementsByClassName("close")[0];
$(".pdf-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
$(".print-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
span.onclick = function() {
	$("#subscriptionModal").css('display', 'none');
}
window.onclick = function(event) {
    if (event.target == modal) {
		$("#subscriptionModal").css('display', 'none');
    }
}
//* Xenforo
jQuery.extend(true, XenForo,
{
	visitor: { user_id: 0 },
	serverTimeInfo:
	{
		now: 1409831907,
		today: 1409781600,
		todayDow: 4
	},
	_lightBoxUniversal: "0",
	_enableOverlays: "1",
	_animationSpeedMultiplier: "1",
	_overlayConfig:
	{
		top: "10%",
		speed: 200,
		closeSpeed: 100,
		mask:
		{
			color: "rgb(0, 0, 0)",
			opacity: "0.6",
			loadSpeed: 200,
			closeSpeed: 100
		}
	},
	_ignoredUsers: [],
	_loadedScripts: {"node_list":true,"node_category":true,"node_forum":true,"sidebar_share_page":true,"wf_default":true,"bbm_buttons":true,"login_bar":true,"twitter":true},
	_cookieConfig: { path: "/", domain: "", prefix: "xf_"},
	_csrfToken: "",
	_csrfRefreshUrl: "/community/login/csrf-token-refresh",
	_jsVersion: "303ae0ca"
});
jQuery.extend(XenForo.phrases,
{
	cancel: "Cancel",

	a_moment_ago:    "A moment ago",
	one_minute_ago:  "1 minute ago",
	x_minutes_ago:   "%minutes% minutes ago",
	today_at_x:      "Today at %time%",
	yesterday_at_x:  "Yesterday at %time%",
	day_x_at_time_y: "%day% at %time%",

	day0: "Sunday",
	day1: "Monday",
	day2: "Tuesday",
	day3: "Wednesday",
	day4: "Thursday",
	day5: "Friday",
	day6: "Saturday",

	_months: "January,February,March,April,May,June,July,August,September,October,November,December",
	_daysShort: "Sun,Mon,Tue,Wed,Thu,Fri,Sat",

	following_error_occurred: "The following error occurred",
	server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
	logging_in: "Logging in",
	click_image_show_full_size_version: "Click this image to show the full-size version.",
	show_hidden_content_by_x: "Show hidden content by {names}"
});

// Facebook Javascript SDK
XenForo.Facebook.appId = "";
XenForo.Facebook.forceInit = true;

/*
document.addEventListener('DOMContentLoaded', function(event) {
  cookieChoices.showCookieConsentBar('Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.',
  'OK');
});
*/

$(document).ready(function() {
	$("a.fancybox").fancybox();
});

</script>

<script>
_bsa.init('custom', 'CKYD55QU', 'placement:howtoforge',
    {
      target: '#sponsor-banner',
      template: `
<a href="##link##" style="background: linear-gradient(-330deg, ##backgroundColor##D9, ##backgroundColor##D9 30%, ##backgroundColor## 70%) #fff;" class="native-banner">
<img class="native-img" src="##logo##">
<div style="color: ##textColor##" class="native-tagline">##tagline##</div>
<div style="color: ##textColor##" class="native-desc">##description##</div>
<div style="color: ##ctaTextColor##; background-color: ##ctaBackgroundColor##;" class="native-cta">##callToAction##</div>
<div style="background-color: ##textColor##B2; color: ##backgroundColor##" class="native-ad">Ad</div>
</a>
`
    }
  );
</script>

<script>
(function() {
  if (typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('fancybar', 'CKYDL27E', 'placement:howtoforgecom');
  }
})();
</script>
<script>
(function() {
  if (typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('custom', 'CEBDK2JM', 'placement:howtoforgecom', {
      target: '.bsa-apiads',
      template:
`
<a href="##statlink##" target="_blank" rel="sponsored nofollow">##company## — ##description##</a>
`
    });
  }
})();
</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2155872-1', 'auto');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');

</script>
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=2&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=2&shcb=34', false, [], true, false, false, false);
</script>
<script>var _audins_dom="howtoforge_com",_audins_did=178704;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=194-2");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.howtoforge_com,DomainId.178704" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=2&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script><script type="text/javascript">(function(){window['__CF$cv$params']={r:'63d2d4058eb659d9',m:'552ec2208b796c1fef653b3fbb857048b55dc701-1617961795-1800-AY8KDfrRSUb2icw/ztBQ3Jck5tp9H2Ov0nD9tVn0miVotndZqO7GCYH+062q8AcTRh/g7I1UC47UoC5rpHokKhEbk/5dSTzw+Vx+V2rK4Zxk0U1rnkgFBivQIk6uq3nxc73zBNWIi1Ap5YlR/XhwAyOmNHnDNKsFfi9IZczwx7Jq1Xdcj3jdCt5JhtpWfN9o0A==',s:[0x6b524fc28f,0xbcb3aa9043],}})();</script></body></html>