<!DOCTYPE html>
<html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs LoggedOut Sidebar Responsive" xmlns:fb="http://www.facebook.com/2008/fbml">
<head>
<meta charset="utf-8" />
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<base href="https://www.howtoforge.com" />
<script>
			var _b = document.getElementsByTagName('base')[0], _bH = "https://www.howtoforge.com/configure-network-interface-using-nmcli-on-centos-7/";
			if (_b && _b.href != _bH) _b.href = _bH;
		</script>
<title>How to Configure Network Interfaces using NMCLI on Centos 7.6</title>
<meta name="description" content="The first thing after installing a Linux OS as a server is configuring the network interface to have remote access and from your workstation/laptop. I... " />
<meta property="og:title" content="How to Configure Network Interfaces using NMCLI on Centos 7.6">
<meta property="og:description" content="The first thing after installing a Linux OS as a server is configuring the network interface to have remote access and from your workstation/laptop. I... ">
<meta property="og:site_name" content="HowtoForge">
<meta property="og:type" content="article">
<meta property="og:image" content="https://www.howtoforge.com/images/featured/centos-network-configuration.jpg">
<meta property="og:image:secure_url" content="https://www.howtoforge.com/images/featured/centos-network-configuration.jpg" />
<meta property="og:image:alt" content="How to Configure Network Interfaces using NMCLI on Centos 7.6" />
<meta name="twitter:image" content="https://www.howtoforge.com/images/featured/centos-network-configuration.jpg" />
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="@howtoforgecom">
<meta name="twitter:creator" content="@howtoforgecom">
<meta name="twitter:title" content="How to Configure Network Interfaces using NMCLI on Centos 7.6">
<meta name="twitter:description" content="The first thing after installing a Linux OS as a server is configuring the network interface to have remote access and from your workstation/laptop. I... ">
<link rel="alternate" href="https://www.howtoforge.com/configure-network-interface-using-nmcli-on-centos-7/" hreflang="en" />
<link rel="canonical" href="https://www.howtoforge.com/configure-network-interface-using-nmcli-on-centos-7/" />
<link rel="amphtml" href="https://www.howtoforge.com/configure-network-interface-using-nmcli-on-centos-7/amp/" />
<script type="application/ld+json">
{
  "@context" : "http://schema.org",
  "@type" : "Article",
  "name" : "How to Configure Network Interfaces using NMCLI on Centos 7.6",
  "author" : {
    "@type" : "Person",
    "name" : "Amine YAHIA CHERIF"
  },
  "articleSection" : "centos,linux,networking",
  "url" : "https://www.howtoforge.com/configure-network-interface-using-nmcli-on-centos-7/",
  "publisher" : {
    "@type" : "Organization",
    "name" : "Howtoforge"
  }
}
</script>
<noscript><style>.JsOnly, .jsOnly { display: none !important; }</style></noscript>
<link rel="stylesheet" href="/community/styles/executive/xenfocus/icons/css/font-awesome.min.css" />
<link href='//fonts.googleapis.com/css?family=Open+Sans:400,700' rel='stylesheet' type='text/css' />
<link href="/themes/howtoforge/templates/xf.css" rel="stylesheet">
<script src="/js/jquery/jquery-1.11.3.min.js"></script>
<script src="/community/js/xenforo/xenforo.js?_v=303ae0ca"></script>
<script src="/community/js/bbm/zloader.js?_v=303ae0ca"></script>
<script type="text/javascript" src="/js/fancybox/jquery.mousewheel-3.0.4.pack.js"></script>
<script type="text/javascript" src="/js/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
<link rel="stylesheet" type="text/css" href="/js/fancybox/jquery.fancybox-1.3.4.css" media="screen" />
<link href="/themes/howtoforge/templates/style.min.css" rel="stylesheet">
<link rel="alternate" type="application/rss+xml" title="RSS-Feed für Howtoforge" href="/feed.rss" />
<script src="/js/tinymce_4.1.7/tinymce.min.js"></script>

<script type="text/javascript">
var gaProperty = 'UA-2155872-1';
var disableStr = 'ga-disable-' + gaProperty;
if (document.cookie.indexOf(disableStr + '=true') > -1) {
window[disableStr] = true;
}
function gaOptout() {
document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
window[disableStr] = true;
alert('Google Ananlyitics tracking has been disabled in this browser.');
}
</script>
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
	googletag.defineSlot('/1030080/howtoforge_com_list_sidebar_top', [300, 250], 'div-gpt-ad-1527185271042-4').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_list_content_middle', [[300, 250], [336, 280]], 'div-gpt-ad-1527185271042-5').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_a_300x250', [300, 250], 'div-gpt-ad-1527185271042-6').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_b_300x250', [300, 250], 'div-gpt-ad-1527185271042-7').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_leaderboard_b_728x90', [728, 90], 'div-gpt-ad-1527185271042-1').addService(googletag.pubads());
	googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-3043223216276099",
          enable_page_level_ads: true
     });
</script>


<script src="//m.servedby-buysellads.com/monetization.js" type="text/javascript"></script>


<script type="text/javascript">
    window.cookieconsent_options = {"message":"This website uses cookies to ensure you get the best experience on our website, analyze site traffic and show you relevant ads.","dismiss":"Got it!","learnMore":"More info","link":"https://www.howtoforge.com/community/help/cookies","theme":"dark-bottom"};
</script>
<script type="text/javascript" src="/js/cookieconsent.latest.min.js"></script>

</head>
<body>
<div id="loginBar">
<div class="pageWidth">
<div class="pageContent">
<h3 id="loginBarHandle">
<label for="LoginControl"><a href="/community/login/" class="concealed noOutline">Log in or Sign up</a></label>
</h3>
<span class="helper"></span>
</div>
</div>
</div>
<header>
<div id="header">
<div id="logoBlock">
<div class="pageWidth">
<div class="pageContent">
<div id="logo"><a href="/">
<span></span>
<img src="/images/howtoforge_logo_trans.gif" alt="Howtoforge" style="margin-left:20px;" />
</a></div>
<span class="helper"></span>
</div>
</div>
</div>
<div id="navigation" class="pageWidth withSearch">
<div class="pageContent">
<nav>
<div class="navTabs">
<ul class="publicTabs">

<li class="navTab forums selected">
<a href="/" class="navLink">Tutorials</a>
<div class="tabLinks forumsTabLinks">
<ul class="secondaryContent blockLinksList">
<li><a href="/search/">Tutorial search</a></li>
</ul>
</div>
</li>
<li class="navTab forums PopupClosed">
<a href="/tutorials/" class="navLink">Tags</a>
</li>
<li class="navTab forums PopupClosed"><a href="/community/" class="navLink">Forums</a></li>
<li class="navTab forums PopupClosed"><a href="/linux-commands/" class="navLink">Linux Commands</a></li>
<li class="navTab forums PopupClosed"><a href="/subscription/" class="navLink">Subscribe</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.ispconfig.org" class="navLink">ISPConfig</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.lxer.com" class="navLink">News</a></li>
</ul>
</div>
<span class="helper"></span>
</nav>
</div>
</div>
<div id="searchBar" class="pageWidth">
<span id="QuickSearchPlaceholder" title=" Search..."> Search</span>
<fieldset id="QuickSearch">
<form action="/" method="post" class="formPopup">
<div class="primaryControls">

<input type="search" name="q" value="" class="textCtrl" placeholder="Search..." results="0" title="Enter your search and hit enter..." id="QuickSearchQuery" />

</div>
<input type="hidden" name="_xfToken" value="" />
</form>
</fieldset>
</div>
</div>
</header>
<div id="content" class="forum_list">
<div class="pageWidth">
<div class="pageContent">

<div class="mainContainer">
<div class="mainContent">

<div class="breadBoxTop">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Home</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/configure-network-interface-using-nmcli-on-centos-7/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to Configure Network Interfaces using NMCLI on Centos 7.6</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>

<div id="htfContentPage">
<div class="bsa-apiads"><a href="https://ispprotect.com/?pk_campaign=htftxt" target="_blank" rel="nofollow">Scan your Web-Server for Malware with ISPProtect now. Get Free Trial.</a></div>
<article>
<h1>How to Configure Network Interfaces using NMCLI on Centos 7.6</h1>
<div class="contributeEdit" style="float:right; width:450px; max-width:100%;">
<div id="tocContainer">
<h3>On this page</h3>
<ol class="toc">
<li><a href="#preliminary-note">Preliminary Note</a></li>
<li><a href="#network-device">Network Device</a></li>
<li><a href="#profile-connection">Profile Connection</a></li>
</ol>
</div>
</div>
<p>The first thing after installing a Linux OS as a server is configuring the network interface to have remote access and from your workstation/laptop and a cup of coffee you could manage your server at your convenient.</p>
<p>In this tutorial, we will use nmcli which stands for Network Manager Command Line tool for configuring our network interfaces.</p>
<h2 id="preliminary-note">Preliminary Note</h2>
<p>The particularity of this command is you don&rsquo;t need any requirements, however, it&rsquo;s run as a root</p>
<p>The basic format of nmcli:</p>
<pre class="command"><code spellcheck="false">nmcli [OPTIONS] OBJECT { COMMAND | help }</code></pre>
<p>OBJECT could be one of these options: connection, device, general, networking, radio, agent and monitor and we can use a prefix of these options:&nbsp;</p>
<p>nmcli -p device --&gt; nmcli -p dev --&gt; nmcli -p d</p>
<p>Note: -p stands for --pretty is an option</p>
<p>In this part of the tutorial, we will cover two objects: Connection and Device</p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;">

<div id='div-gpt-ad-1527185271042-6' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-6'); });
</script>
</div>
</div>
<h2 id="network-device">Network Device</h2>
<p>We can use this object with those most used commands: status, show, and set</p>
<p>We will start with display our interfaces (devices) if we have many with there status:</p>
<pre class="command"><code spellcheck="false">nmcli device status</code></pre>
<p>Output:</p>
<p><a class="fancybox" id="img-pastedimage01" href="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/big/pastedimage01.png"><img src="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/pastedimage01.png" alt="Network Device status" width="750" height="147" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>The first column is the name interfaces, my physical interface is ens33 it may be different from your environment, the last column is the name of profile it&rsquo;s also called &ldquo;connection profile&rdquo;.</p>
<p>Another way:</p>
<pre class="command"><code spellcheck="false">nmcli -p device</code></pre>
<p>The option -p stands for Pretty is a human-readable output.</p>
<p>Output :</p>
<p><a class="fancybox" id="img-pastedimage1" href="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/big/pastedimage1.png"><img src="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/pastedimage1.png" alt="Get list of network devices on CentOS" width="750" height="217" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>We use nmcli dev show to list all information about all interfaces (it&rsquo;s a lot of information), so we will specify an interface we will use ens33:</p>
<pre class="command"><code spellcheck="false">nmcli dev show ens33</code></pre>
<p>Output:</p>
<p><a class="fancybox" id="img-pastedimage2" href="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/big/pastedimage2.png"><img src="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/pastedimage2.png" alt="Show status of ens33 device" width="750" height="316" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>All information here is plenty explicit, we don&rsquo;t need to go through this output.&nbsp;&nbsp;</p>
<p>We could set any devices to be managed with nmcli or not, using the set command.</p>
<p>To list our devices and check if it&rsquo;s managed or not.</p>
<pre class="command"><code spellcheck="false">nmcli device status</code></pre>
<p>Output:</p>
<p><a class="fancybox" id="img-pastedimage3" href="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/big/pastedimage3.png"><img src="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/pastedimage3.png" alt="Use nmcli to show network device status" width="598" height="174" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Notice the STATE column.</p>
<p>Now I will change ens33 to an unmanaged interface.</p>
<pre class="command"><code spellcheck="false">sudo nmcli device set ens33 managed no</code></pre>
<p>Output:</p>
<p><a class="fancybox" id="img-pastedimage4" href="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/big/pastedimage4.png"><img src="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/pastedimage4.png" alt="Set network device status to unmanaged" width="750" height="179" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Note that we can not manage ens33 interface with NetworkManager anymore but the device is still connected.</p>
<p>Let&rsquo;s enable to manage ens33 interface:</p>
<pre class="command"><code spellcheck="false">sudo nmcli device set ens33 managed yes</code></pre>
<p>Check the status of my interfaces:</p>
<pre class="command"><code spellcheck="false">nmcli device status</code></pre>
<p>output :</p>
<p><a class="fancybox" id="img-pastedimage5" href="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/big/pastedimage5.png"><img src="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/pastedimage5.png" alt="Set device state to managed" width="750" height="157" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Finally, we will see how to activate and deactivate our devices (interfaces) with disconnect and connect commands.</p>
<pre class="command"><code spellcheck="false">sudo nmcli dev disconnect ens33</code></pre>
<p>You should have a successful message: Device &ldquo;ens33&rdquo; successfully disconnected.</p>
<p>Show the status of devices:</p>
<pre class="command"><code spellcheck="false">nmcli dev status</code></pre>
<p>Output:</p>
<p style="text-align: center;"><a class="fancybox" id="img-pastedimage6" href="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/big/pastedimage6.png"><img src="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/pastedimage6.png" alt="Device status" width="750" height="161" /></a></p>
<p>Notice the ens33 device is marked in red, the status is disconnected and no connexion profile attached. The device will be automatically activated after reboot or we can activate manually.</p>
<p>To activate our devices:</p>
<pre class="command"><code spellcheck="false">sudo nmcli dev connect ens33</code></pre>
<p>Output:</p>
<p><a class="fancybox" id="img-pastedimage7" href="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/big/pastedimage7.png"><img src="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/pastedimage7.png" alt="Connect network device" width="750" height="69" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>The message with successful activation and a UUID of the profile connexion at the end.</p>
<p>Status of our interfaces:</p>
<pre class="command"><code spellcheck="false">nmcli dev status</code></pre>
<p>Output:</p>
<p><a class="fancybox" id="img-pastedimage8" href="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/big/pastedimage8.png"><img src="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/pastedimage8.png" alt="Device connected successfully" width="750" height="149" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>The interface is no longer deactivate.</p>
<h2 id="profile-connection">Profile Connection</h2>
<p>Now let&rsquo;s focus on the profile by showing the information:</p>
<pre class="command"><code spellcheck="false">nmcli connection show</code></pre>
<p>Output:</p>
<p><a class="fancybox" id="img-pastedimage9" href="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/big/pastedimage9.png"><img src="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/pastedimage9.png" alt="Show connections" width="750" height="141" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>The first column is the name of the connection (not the device name), the second is The UUID or Universal Unique Identifier and the last one is the name of the device.</p>
<p>Profiles are the saved configuration of interfaces it&rsquo;s stored in <span class="system"> /etc/sysconfig/network-scripts/ </span> and named with a prefix <span class="system">ifcfg-</span> and then the name of the profile, let&rsquo;s see:</p>
<p><a class="fancybox" id="img-pastedimage10" href="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/big/pastedimage10.png"><img src="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/pastedimage10.png" alt="Network scripts" width="750" height="176" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>The profiles with the name of devices are auto-generated,<span class="system"> ifcfg-amine</span> is created manually.</p>
<p>Now let&rsquo;s create some profiles.</p>
<p>Note: I have two physical interfaces attached to my virtual machine ens33 and ens37.</p>
<p>We will create an ethernet configuration profile with a dynamic IP address.</p>
<pre class="command"><code spellcheck="false">sudo nmcli con add type ethernet con-name HomeDHCP ifname ens37</code></pre>
<p>The interface is ethernet type, HomeDHCP is the name of the profile, ens37 is the interface which is the profile is attached to.</p>
<p>Output:</p>
<p><a class="fancybox" id="img-pastedimage11" href="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/big/pastedimage11.png"><img src="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/pastedimage11.png" alt="Add new ethernet profile" width="679" height="61" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Let see profiles now:</p>
<p><a class="fancybox" id="img-pastedimage12" href="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/big/pastedimage12.png"><img src="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/pastedimage12.png" alt="Get list of profiles" width="750" height="153" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Notice here the profile is created but not attached to ens37 interface, we have to activate our new profile by:</p>
<pre class="command"><code spellcheck="false">sudo nmcli con up HomeDHCP</code></pre>
<p>Careful the name of the profile is case sensitive.</p>
<p>Output:</p>
<p><a class="fancybox" id="img-pastedimage13" href="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/big/pastedimage13.png"><img src="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/pastedimage13.png" alt="Activate connection" width="750" height="72" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Let see again:</p>
<p><a class="fancybox" id="img-pastedimage14" href="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/big/pastedimage14.png"><img src="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/pastedimage14.png" alt="Result of activating the connection" width="750" height="159" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Notice the first column NAME HomeDHCP is attached to ens37 interface. And ens37 profile (auto-generated) is not attached to any of the interfaces.</p>
<p>Let&rsquo;s see inside the profile:</p>
<pre class="command"><code spellcheck="false">nmcli con show HomeDHCP</code></pre>
<p>And check the file created in <span class="system"> /etc/sysconfig/network-scripts/ifcfg-HomeDHCP</span></p>
<p><a class="fancybox" id="img-pastedimage15" href="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/big/pastedimage15.png"><img src="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/pastedimage15.png" alt="Content of network config script" width="731" height="350" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Let&rsquo;s deactivate the HomeDHCP profile from the ens37 interface.</p>
<pre class="command"><code spellcheck="false">sudo nmcli con down HomeDHCP</code></pre>
<p>output :</p>
<p><a class="fancybox" id="img-pastedimage16" href="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/big/pastedimage16.png"><img src="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/pastedimage16.png" alt="New ens37 device is active" width="750" height="174" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Notice that the default profile is attached to ens37 interface.</p>
<p>Let&rsquo;s delete the HomeDHCP profile:</p>
<pre class="command"><code spellcheck="false">sudo nmcli con delete HomeDHCP</code></pre>
<p>Output:&nbsp;</p>
<p><a class="fancybox" id="img-pastedimage17" href="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/big/pastedimage17.png"><img src="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/pastedimage17.png" alt="Delete device" width="750" height="82" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p><a class="fancybox" id="img-pastedimage18" href="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/big/pastedimage18.png"><img src="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/pastedimage18.png" alt="Result after deleting a device" width="750" height="138" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>No more HomeDHCP profile.</p>
<p>Let&rsquo;s now create an ethernet configuration profile named HomeStatic with static address IP.</p>
<pre class="command"><code spellcheck="false">sudo nmcli con add type ethernet con-name HomeStatic ifname ens37 ip4 192.168.0.10/24 gw4 192.168.0.1</code></pre>
<p>Output:</p>
<p><a class="fancybox" id="img-pastedimage19" href="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/big/pastedimage19.png"><img src="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/pastedimage19.png" alt="ethernet configuration profile" width="750" height="100" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Check our interfaces connexion:</p>
<pre class="command"><code spellcheck="false">nmcli con s</code></pre>
<p>Output:</p>
<p><a class="fancybox" id="img-pastedimage20" href="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/big/pastedimage20.png"><img src="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/pastedimage20.png" alt="New static IP device" width="750" height="152" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Remember we have to attach the profile to the interface by activating the profile:</p>
<pre class="command"><code spellcheck="false">sudo nmcli con up HomeStatic</code></pre>
<p>Output:</p>
<p><a class="fancybox" id="img-pastedimage21" href="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/big/pastedimage21.png"><img src="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/pastedimage21.png" alt="Connection activated successfully" width="750" height="80" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Display the profile configuration:</p>
<pre class="command"><code spellcheck="false">nmcli dev show ens33</code></pre>
<p>Output:</p>
<p><a class="fancybox" id="img-pastedimage22" href="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/big/pastedimage22.png"><img src="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/pastedimage22.png" alt="nmcli dev show ens33" width="750" height="297" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Another way but there are many information so we will focus on what we want to see.</p>
<p>Output:</p>
<p><a class="fancybox" id="img-pastedimage23" href="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/big/pastedimage23.png"><img src="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/pastedimage23.png" alt="Output" width="750" height="407" style="display: block; margin-left: auto; margin-right: auto;" /></a><a class="fancybox" id="img-pastedimage24" href="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/big/pastedimage24.png"><img src="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/pastedimage24.png" alt="Output 2" width="750" height="482" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Notice here we don&rsquo;t have any information of DNS servers so we will add a dns server with another command:</p>
<pre class="command"><code spellcheck="false">sudo nmcli con modify HomeStatic ipv4.dns "8.8.8.8 8.8.4.4"</code></pre>
<p>check :</p>
<pre class="command"><code spellcheck="false">nmcli c s HomeStatic</code></pre>
<p><a class="fancybox" id="img-pastedimage25" href="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/big/pastedimage25.png"><img src="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/pastedimage25.png" alt="nmcli c s HomeStatic" width="750" height="415" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Another way to add a dns server address:</p>
<pre class="command"><code spellcheck="false">sudo nmcli c mod HomeStatic +ipv4.dns "192.168.0.1"</code></pre>
<p><a class="fancybox" id="img-pastedimage26" href="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/big/pastedimage26.png"><img src="https://www.howtoforge.com/images/how_to_configure_network_interface_using_nmcli_on_centos7_rh7/pastedimage26.png" alt="sudo nmcli c mod HomeStatic +ipv4.dns &quot;192.168.0.1&quot;" width="750" height="415" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>And of course to delete a dns server address:</p>
<pre class="command"><code spellcheck="false">sudo nmcli c mod HomeStatic -ipv4.dns "192.168.0.1"</code></pre>
<p>So far we go through the basic operations of networking to communicate with our servers with those two Objects and there commands in the next tutorial we will continue to explore and try to end up with a script to summarize what we have done.</p>
</article>
<div style="height:30px; margin-top:20px;">
<p style="text-align:right;"><img src="/images/pdficon_small.png" /> <a class="pdf-btn" href="javascript:void(0);">view as pdf</a> | <img src="/images/print.gif" /> <a class="print-btn" href="javascript:void(0);">print</a></p>
</div>
<div style="height:30px; margin-top:20px;">
<div style="float:left;"><b>Share this page:</b></div>
<p style="text-align:center;">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Fconfigure-network-interface-using-nmcli-on-centos-7%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Fconfigure-network-interface-using-nmcli-on-centos-7%2F&text=How+to+Configure+Network+Interfaces+using+NMCLI+on+Centos+7.6&via=howtoforgecom&related=howtoforgecom" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.howtoforge.com%2Fconfigure-network-interface-using-nmcli-on-centos-7%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-gplus.png" height="20" /></a>
</p>
</div>
</div>


<div id="htfContentPagePaging">
<h2>Suggested articles</h2>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-3043223216276099" data-ad-slot="8940054090"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>


<div id="htfContentPageComment">
<a name="comments"></a>
<h2>0 Comment(s)</h2>

<div id="commentform">
<div class="commentContainerHead" style="font-size:18px;">Add comment</div>
<div class="commentContainer">
<form method="post" action="/configure-network-interface-using-nmcli-on-centos-7/#comments">
<input type="hidden" name="reply_to" id="reply-to-comment" value="0" />
<div id="commentFormDetail">
<div style="width:48%; float:left; margin-right:3%">
<label for="commentname">Name *</label>
<input id="commentname" name="commentname" value="" />
</div>
<div style="width:48%;float:left;">
<label for="commentname">Email *</label>
<input id="commentemail" name="commentemail" value="" />
</div>
<div style="clear:both;"></div>
</div>
<textarea id="commentedit" name="commentedit" style="width:auto;"></textarea>
<div>
<div style="float:left;">
<div class="g-recaptcha" data-sitekey="6LdX9fUSAAAAALWwVoPdeXScMSketz4npF-0QcQ1"></div>
<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en">
      </script>
</div>
<div style="margin-top:10px;margin-bottom:10px;">
<input type="submit" name="submit" class="button primary" style="float:right;" value="Submit comment">
</div>
<div style="clear:both;"></div>
</div>
<script>
	tinymce.init({
		selector: "textarea#commentedit",
		theme: "modern",
		height: 100,
		apply_source_formatting : true,
		remove_linebreaks : false,
		menubar : false,
		/*auto_focus : "commentedit",*/
		plugins: [
		"link"
		],
		/*plugins: [
			"advlist autolink link image lists charmap print preview hr anchor pagebreak spellchecker",
			"searchreplace wordcount visualblocks visualchars code fullscreen insertdatetime media nonbreaking",
			"save table contextmenu directionality emoticons template paste textcolor"
		],*/
		content_css: "https://www.howtoforge.com/themes/howtoforge/css/custom.css",
		toolbar: "undo redo | bold italic link", 
		/*style_formats: [
			{title: 'Bold text', inline: 'b'},
			{title: 'Red text', inline: 'span', styles: {color: '#ff0000'}},
			{title: 'Red header', block: 'h1', styles: {color: '#ff0000'}},
			{title: 'Example 1', inline: 'span', classes: 'example1'},
			{title: 'Example 2', inline: 'span', classes: 'example2'},
			{title: 'Table styles'},
			{title: 'Table row 1', selector: 'tr', classes: 'tablerow1'}
		]*/
	}); 
	</script>
</form>
</div>
</div>

</div>

<div class="breadBoxBottom">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Home</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/configure-network-interface-using-nmcli-on-centos-7/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to Configure Network Interfaces using NMCLI on Centos 7.6</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
<script>
<!--

$(document).on('click', 'a.reply-to', function(e) {
	e.preventDefault();
	
	var self = $(this);
	var cid = self.attr('data-comment');
	console.log(cid);
	if(!cid) return this;
	
	$('#commentform').insertAfter('#comment' + cid);
	$('#reply-to-comment').val(cid);
	/*tinyMCE.activeEditor.focus();*/
	var textareaId = 'commentedit';
	tinyMCE.get(textareaId).remove();
	tinyMCE.execCommand("mceAddEditor", false, textareaId);
	tinyMCE.activeEditor.focus();
});
//-->
</script>
<div style="margin-top:10px;margin-bottom:10px;text-align:center;">

<center>


<div id='div-gpt-ad-1527185271042-1' style='height:90px; width:728px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-1'); });
</script>
</div>

</center>
</div>


<form action="/community/login/login?redirect=/configure-network-interface-using-nmcli-on-centos-7/" method="post" class="xenForm eAuth" id="login" style="display:none">
<ul id="eAuthUnit">
<li><a href="/community/register/facebook?reg=1" class="fbLogin" tabindex="110"><span>Log in with Facebook</span></a></li>
<li><a href="/community/register/twitter?reg=1" class="twitterLogin" tabindex="110"><span>Log in with Twitter</span></a></li>
<li><span class="googleLogin GoogleLogin JsOnly" tabindex="110" data-client-id="198773272284-b6tfk0c28bje81p774prrcrkq9jb3o44.apps.googleusercontent.com" data-redirect-url="/community/register/google?code=__CODE__&amp;csrf=hVMXbW_3rnrmq4Em"><span>Log in with Google</span></span></li>
</ul>
<div class="ctrlWrapper">
<dl class="ctrlUnit">
<dt><label for="LoginControl">Your name or email address:</label></dt>
<dd><input type="text" name="login" id="LoginControl" class="textCtrl" tabindex="101" /></dd>
</dl>
<dl class="ctrlUnit">
<dt>
<label for="ctrl_password">Do you already have an account?</label>
</dt>
<dd>
<ul>
<li><label for="ctrl_not_registered"><input type="radio" name="register" value="1" id="ctrl_not_registered" tabindex="105" />
No, create an account now.</label></li>
<li><label for="ctrl_registered"><input type="radio" name="register" value="0" id="ctrl_registered" tabindex="105" checked="checked" class="Disabler" />
Yes, my password is:</label></li>
<li id="ctrl_registered_Disabler">
<input type="password" name="password" class="textCtrl" id="ctrl_password" tabindex="102" />
<div class="lostPassword"><a href="/community/lost-password/" tabindex="106">Forgot your password?</a></div>
</li>
</ul>
</dd>
</dl>
<dl class="ctrlUnit submitUnit">
<dt></dt>
<dd>
<input type="submit" class="button primary" value="Log in" tabindex="104" data-loginPhrase="Log in" data-signupPhrase="Sign up" />
<label for="ctrl_remember" class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_remember" tabindex="103" /> Stay logged in</label>
</dd>
</dl>
</div>
<input type="hidden" name="cookie_check" value="1" />
<input type="hidden" name="redirect" value="/community/" />
<input type="hidden" name="_xfToken" value="" />
</form>

</div>
</div>

<aside>
<div class="sidebar">
<div class="section loginButton">
<div class="secondaryContent">
<label for="LoginControl" id="SignupButton"><a href="/community/login/" class="inner">Sign up now!</a></label>
</div>
</div>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-2">

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent socialMediaIcon">
<a href="https://twitter.com/howtoforgecom" target="_blank"><img src="/images/socialmedia/64x64/twitter.png" /></a>
<a href="https://www.facebook.com/howtoforge" target="_blank"><img src="/images/socialmedia/64x64/facebook.png" /></a>
<a href="https://news.ycombinator.com/" target="_blank" rel="nofollow"><img src="/images/socialmedia/64x64/hackernews.png" /></a>
<a href="https://www.howtoforge.com/feed" target="_blank"><img src="/images/socialmedia/64x64/rss.png" /></a>
</div>
</div>
</div>
<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Tutorial Info</p>
<div class="pairsJustified">
<dl class="discussionCount">
<dt>Author:</dt>
<dd><a href="/author/amine+yahia+cherif/" rel="author">Amine YAHIA CHERIF</a></dd>
</dl>
<dl class="discussionCount">
<dt>Published:</dt>
<dd>Oct 17, 2019</dd>
</dl>
<dl class="discussionCount">
<dt>Tags:</dt>
<dd><a href='/tutorials/centos/' rel='tag'>centos</a>, <a href='/tutorials/linux/' rel='tag'>linux</a>, <a href='/tutorials/networking/' rel='tag'>networking</a></dd>
</dl>
</div>
</div>
</div>
<div id="sponsor-banner">
</div>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent">
<p class="mnuinfo mnushare">Share This Page</p>
<p style="text-align:center;">
<a href="javascript:window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Fconfigure-network-interface-using-nmcli-on-centos-7%2F', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="javascript:window.open('https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Fconfigure-network-interface-using-nmcli-on-centos-7%2F&text=How+to+Configure+Network+Interfaces+using+NMCLI+on+Centos+7.6&via=howtoforgecom&related=howtoforgecom', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="javascript:window.open('https://news.ycombinator.com/submitlink?t=How+to+Configure+Network+Interfaces+using+NMCLI+on+Centos+7.6&u=https%3A%2F%2Fwww.howtoforge.com%2Fconfigure-network-interface-using-nmcli-on-centos-7%2F', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-hackernews.png" height="20" /></a>
</p>
<p style="color:#EE; font-weight:bold; text-align:center; margin-top:5px;">40.2k Followers</p>
</div>
</div>
</div>


<script type="text/javascript">
    google_ad_client = "ca-pub-3043223216276099";
    google_ad_slot = "6709042890";
    google_ad_width = 300;
    google_ad_height = 600;
</script>

<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>


<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Popular Tutorials</p>
<div class="pairsJustified">
<ul>
<li><a href="/tutorial/linux-grep-command/">How to use grep to search for strings in files on the shell</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-create-docker-images-with-dockerfile/">How to create Docker Images with a Dockerfile</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-use-ftp-on-the-linux-shell/">How to use the Linux ftp command to up- and download files on the shell</a></li>
<li><hr /></li>
<li><a href="/vim-basics">Vim Editor Basics</a></li>
<li><hr /></li>
<li><a href="/configure-remote-access-to-your-ubuntu-desktop">How To Configure Remote Access To Your Ubuntu Desktop</a></li>
<li><hr /></li>
<li><a href="/setting-changing-resetting-mysql-root-passwords">Setting, Changing and Resetting MySQL Root Passwords</a></li>
<li><hr /></li>
<li><a href="/tutorial/linux-search-files-from-the-terminal/">How to search files from the Terminal on Linux</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-setup-zsh-and-oh-my-zsh-on-linux/">How to Setup ZSH and Oh-my-zsh on Linux</a></li>
<li><hr /></li>
<li><a href="/linux_lvm">A Beginner's Guide To LVM</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-upgrade-kernel-in-centos-7-server/">How to Upgrade the Linux Kernel on CentOS 7</a></li>
<li><hr /></li>
</ul>
</div>
</div>
</div>
</div>
</div>
</aside>
</div>
</div>
</div>
<footer>
<div class="footer">
<div class="pageWidth">
<div class="pageContent">
<div class='skin_branding'><span>Xenforo skin by <a href="http://www.xenfocus.com" rel="nofollow">Xenfocus</a></span></div>
<ul class="footerLinks">
<li><a href="/contribute/">Contribute</a></li>
<li><a href="/community/misc/contact">Contact</a></li>
<li><a href="/community/help/">Help</a></li>
<li><a href="/imprint/">Imprint and Legal Notice</a></li>
<li><a href="#navigation" class="topLink">Top</a></li>
<li><a href="/feed" rel="alternate" class="globalFeed" target="_blank" title="RSS-Feed for Howtoforge">RSS-Feed</a></li>
</ul>
<span class="helper"></span>
</div>
</div>
</div>
<div class="footerLegal">
<div class="pageWidth">
<div class="pageContent">
<ul id="legal">
<li><a href="/community/help/terms">Terms and Rules</a> <a href="https://www.howtoforge.com/community/help/privacy-policy">Privacy Policy</a></li>
</ul>
<div id="copyright"><a href="https://www.howtoforge.com" class="concealed">Howtoforge <span>&copy; projektfarm GmbH.</span></a></div>
<span class="helper"></span>
</div>
</div>
</div>
</footer>
<div style="height:100px;"></div>

<div id="subscriptionModal" class="modal">
<div class="modal-content">
<span class="close">&times;</span>
<p>This feature is only available to subscribers. Get your subscription <a href="/subscription">here</a>.</p>
</div>
</div>
<script>
//* Modal
var modal = document.getElementById('subscriptionModal');
var span = document.getElementsByClassName("close")[0];
$(".pdf-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
$(".print-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
span.onclick = function() {
	$("#subscriptionModal").css('display', 'none');
}
window.onclick = function(event) {
    if (event.target == modal) {
		$("#subscriptionModal").css('display', 'none');
    }
}
//* Xenforo
jQuery.extend(true, XenForo,
{
	visitor: { user_id: 0 },
	serverTimeInfo:
	{
		now: 1409831907,
		today: 1409781600,
		todayDow: 4
	},
	_lightBoxUniversal: "0",
	_enableOverlays: "1",
	_animationSpeedMultiplier: "1",
	_overlayConfig:
	{
		top: "10%",
		speed: 200,
		closeSpeed: 100,
		mask:
		{
			color: "rgb(0, 0, 0)",
			opacity: "0.6",
			loadSpeed: 200,
			closeSpeed: 100
		}
	},
	_ignoredUsers: [],
	_loadedScripts: {"node_list":true,"node_category":true,"node_forum":true,"sidebar_share_page":true,"wf_default":true,"bbm_buttons":true,"login_bar":true,"twitter":true},
	_cookieConfig: { path: "/", domain: "", prefix: "xf_"},
	_csrfToken: "",
	_csrfRefreshUrl: "/community/login/csrf-token-refresh",
	_jsVersion: "303ae0ca"
});
jQuery.extend(XenForo.phrases,
{
	cancel: "Cancel",

	a_moment_ago:    "A moment ago",
	one_minute_ago:  "1 minute ago",
	x_minutes_ago:   "%minutes% minutes ago",
	today_at_x:      "Today at %time%",
	yesterday_at_x:  "Yesterday at %time%",
	day_x_at_time_y: "%day% at %time%",

	day0: "Sunday",
	day1: "Monday",
	day2: "Tuesday",
	day3: "Wednesday",
	day4: "Thursday",
	day5: "Friday",
	day6: "Saturday",

	_months: "January,February,March,April,May,June,July,August,September,October,November,December",
	_daysShort: "Sun,Mon,Tue,Wed,Thu,Fri,Sat",

	following_error_occurred: "The following error occurred",
	server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
	logging_in: "Logging in",
	click_image_show_full_size_version: "Click this image to show the full-size version.",
	show_hidden_content_by_x: "Show hidden content by {names}"
});

// Facebook Javascript SDK
XenForo.Facebook.appId = "";
XenForo.Facebook.forceInit = true;

/*
document.addEventListener('DOMContentLoaded', function(event) {
  cookieChoices.showCookieConsentBar('Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.',
  'OK');
});
*/

$(document).ready(function() {
	$("a.fancybox").fancybox();
});

</script>
<script>
_bsa.init('custom', 'CKYD55QU', 'placement:howtoforge',
    {
      target: '#sponsor-banner',
      template: `
<a href="##link##" style="background: linear-gradient(-330deg, ##backgroundColor##D9, ##backgroundColor##D9 30%, ##backgroundColor## 70%) #fff;" class="native-banner">
<img class="native-img" src="##logo##">
<div style="color: ##textColor##" class="native-tagline">##tagline##</div>
<div style="color: ##textColor##" class="native-desc">##description##</div>
<div style="color: ##ctaTextColor##; background-color: ##ctaBackgroundColor##;" class="native-cta">##callToAction##</div>
<div style="background-color: ##textColor##B2; color: ##backgroundColor##" class="native-ad">Ad</div>
</a>
`
    }
  );
</script>
<script>
(function() {
  if (typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('fancybar', 'CKYDL27E', 'placement:howtoforgecom');
  }
})();
</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2155872-1', 'auto');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');

</script>
</body>
</html>