<!DOCTYPE html>
<html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs LoggedOut Sidebar Responsive" xmlns:fb="http://www.facebook.com/2008/fbml">
<head>
<meta charset="utf-8" />
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<base href="https://www.howtoforge.com" />
<script>
			var _b = document.getElementsByTagName('base')[0], _bH = "https://www.howtoforge.com/tutorial/ubuntu-apache-tomcat/";
			if (_b && _b.href != _bH) _b.href = _bH;
		</script>
<title>How to Install and Configure Apache Tomcat 9 on Ubuntu 18.04 LTS</title>
<meta name="keywords" content="linux,server,ubuntu" />
<meta name="description" content="Apache Tomcat is an open source Java Servlet implementation developed by the Apache Software Foundation. In this tutorial, we will show you how to ins... " />
<meta name="og:title" content="How to Install and Configure Apache Tomcat 9 on Ubuntu 18.04 LTS">
<meta name="og:description" content="Apache Tomcat is an open source Java Servlet implementation developed by the Apache Software Foundation. In this tutorial, we will show you how to ins... ">
<meta name="og:site_name" content="Howtoforge">
<meta name="og:type" content="article">
<meta property="og:image" content="https://www.howtoforge.com/images/teaser/ubuntu.gif">
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="howtoforgecom">
<meta name="twitter:creator" content="howtoforgecom">
<meta name="twitter:title" content="How to Install and Configure Apache Tomcat 9 on Ubuntu 18.04 LTS">
<meta name="twitter:description" content="Apache Tomcat is an open source Java Servlet implementation developed by the Apache Software Foundation. In this tutorial, we will show you how to ins... ">
<link rel="alternate" href="https://www.howtoforge.com/tutorial/ubuntu-apache-tomcat/" hreflang="en" />
<link rel="canonical" href="https://www.howtoforge.com/tutorial/ubuntu-apache-tomcat/" />
<link rel="amphtml" href="https://www.howtoforge.com/tutorial/ubuntu-apache-tomcat/amp/" />
<noscript><style>.JsOnly, .jsOnly { display: none !important; }</style></noscript>
<link rel="stylesheet" href="/community/styles/executive/xenfocus/icons/css/font-awesome.min.css" />
<link href='//fonts.googleapis.com/css?family=Open+Sans:400,700' rel='stylesheet' type='text/css' />

<link href="/themes/howtoforge/templates/xf.css" rel="stylesheet">
<script src="/js/jquery/jquery-1.11.3.min.js"></script>
<script src="/community/js/xenforo/xenforo.js?_v=303ae0ca"></script>
<script src="/community/js/bbm/zloader.js?_v=303ae0ca"></script>

<script type="text/javascript" src="/js/fancybox/jquery.mousewheel-3.0.4.pack.js"></script>
<script type="text/javascript" src="/js/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
<link rel="stylesheet" type="text/css" href="/js/fancybox/jquery.fancybox-1.3.4.css" media="screen" />
<link href="/themes/howtoforge/templates/style.css" rel="stylesheet">
<link rel="alternate" type="application/rss+xml" title="RSS-Feed für Howtoforge" href="/feed.rss" />
<script src="/js/tinymce_4.1.7/tinymce.min.js"></script>

<script type="text/javascript">
var gaProperty = 'UA-2155872-1';
var disableStr = 'ga-disable-' + gaProperty;
if (document.cookie.indexOf(disableStr + '=true') > -1) {
window[disableStr] = true;
}
function gaOptout() {
document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
window[disableStr] = true;
alert('Google Ananlyitics tracking has been disabled in this browser.');
}
</script>
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
	googletag.defineSlot('/1030080/howtoforge_com_list_sidebar_top', [300, 250], 'div-gpt-ad-1527185271042-4').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_list_content_middle', [[300, 250], [336, 280]], 'div-gpt-ad-1527185271042-5').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_a_300x250', [300, 250], 'div-gpt-ad-1527185271042-6').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_b_300x250', [300, 250], 'div-gpt-ad-1527185271042-7').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_leaderboard_b_728x90', [728, 90], 'div-gpt-ad-1527185271042-1').addService(googletag.pubads());
	googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script type="text/javascript">
    window.cookieconsent_options = {"message":"This website uses cookies to ensure you get the best experience on our website, analyze site traffic and show you relevant ads.","dismiss":"Got it!","learnMore":"More info","link":"https://www.howtoforge.com/community/help/cookies","theme":"dark-bottom"};
</script>
<script type="text/javascript" src="/js/cookieconsent.latest.min.js"></script>

</head>
<body>
<div id="loginBar">
<div class="pageWidth">
<div class="pageContent">
<h3 id="loginBarHandle">
<label for="LoginControl"><a href="/community/login/" class="concealed noOutline">Log in or Sign up</a></label>
</h3>
<span class="helper"></span>
</div>
</div>
</div>
<header>
<div id="header">
<div id="logoBlock">
<div class="pageWidth">
<div class="pageContent">
<div id="logo"><a href="/">
<span></span>
<img src="/images/howtoforge_logo_trans.gif" alt="Howtoforge" style="margin-left:20px;" />
</a></div>
<span class="helper"></span>
<div class="langSwitch">
<b><img src="/images/gb.png" alt="HowtoForge - Linux Tutorials in English" /> English</b> | <a href="https://www.howtoforge.de/" title="HowtoForge.de - Linux Tutorials auf Deutsch"><img src="/images/de.png" alt="HowtoForge.de - Linux Tutorials auf Deutsch" /> Deutsch</a>
</div>
</div>
</div>
</div>
<div id="navigation" class="pageWidth withSearch">
<div class="pageContent">
<nav>
<div class="navTabs">
<ul class="publicTabs">

<li class="navTab forums selected">
<a href="/" class="navLink">Tutorials</a>
<div class="tabLinks forumsTabLinks">
<ul class="secondaryContent blockLinksList">
<li><a href="/search/">Tutorial search</a></li>
</ul>
</div>
</li>
<li class="navTab forums PopupClosed">
<a href="/tutorials/" class="navLink">Tags</a>
</li>
<li class="navTab forums PopupClosed"><a href="/community/" class="navLink">Forums</a></li>
<li class="navTab forums PopupClosed"><a href="/linux-commands/" class="navLink">Linux Commands</a></li>
<li class="navTab forums PopupClosed"><a href="/subscription/" class="navLink">Subscribe</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.ispconfig.org" class="navLink">ISPConfig</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.lxer.com" class="navLink">News</a></li>
</ul>
</div>
<span class="helper"></span>
</nav>
</div>
</div>
<div id="searchBar" class="pageWidth">
<span id="QuickSearchPlaceholder" title=" Search..."> Search</span>
<fieldset id="QuickSearch">
<form action="/" method="post" class="formPopup">
<div class="primaryControls">

<input type="search" name="q" value="" class="textCtrl" placeholder="Search..." results="0" title="Enter your search and hit enter..." id="QuickSearchQuery" />

</div>
<input type="hidden" name="_xfToken" value="" />
</form>
</fieldset>
</div>
</div>
</header>
<div id="content" class="forum_list">
<div class="pageWidth">
<div class="pageContent">

<div class="mainContainer">
<div class="mainContent">

<div class="breadBoxTop">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Tutorials</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/tutorial/ubuntu-apache-tomcat/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to Install and Configure Apache Tomcat 9 on Ubuntu 18.04 LTS</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>

<div id="htfContentPage">
<div class="bsa-apiads"><a href="//srv.buysellads.com/ads/click/x/GTND42QLCASDLK7UCAA4YKQMCVSI523YC6AD4Z3JCW7D52QLCABDL53KC6BI627NFTADEK3EHJNCLSIZ" target="_blank" rel="nofollow">Finish Signing Up—Start Using 25+ Always-Free Products</a><img src="https://ad.doubleclick.net/ddm/trackimp/N572608.452584BUYSELLADS.COM/B20911639.217792243;dc_trk_aid=416498285;dc_trk_cid=99622446;ord=[1527691833];dc_lat=;dc_rdid=;tag_for_child_directed_treatment=?" height="1" width="1" border="0" style="display:none;" /><img src="https://pixel.adsafeprotected.com/rfw/st/154421/23778735/skeleton.gif" height="1" width="1" border="0" style="display:none;" /></div>
<h1>How to Install and Configure Apache Tomcat 9 on Ubuntu 18.04 LTS</h1>
<div class="contributeEdit" style="float:right; width:450px; max-width:100%;">

<div id="tocContainer">
<h3>This tutorial exists for these OS versions</h3>
<ul><li><strong>Ubuntu 18.04 (Bionic Beaver)</strong></li><li><a href="/tutorial/how-to-install-apache-tomcat-8-5-on-ubuntu-16-04/">Ubuntu 16.04 (Xenial Xerus)</a></li><li><a href="/tomcat-on-ubuntu-14.04-install">Ubuntu 14.04 LTS (Trusty Tahr)</a></li></ul> <h3>On this page</h3>
<ol class="toc">
<li><a href="#prerequisites">Prerequisites</a></li>
<li><a href="#what-we-will-do">What we will do?</a></li>
<li><a href="#step-install-java-on-ubuntu-">Step 1 - Install Java on Ubuntu 18.04</a></li>
<li><a href="#step-configure-java-environment">Step 2 - Configure Java Environment</a></li>
<li><a href="#step-install-apache-tomcat">Step 3 - Install Apache Tomcat</a></li>
<li><a href="#step-configure-apache-tomcat-as-a-service">Step 4 - Configure Apache Tomcat as a Service</a></li>
<li><a href="#step-configure-apache-tomcat-user">Step 5 - Configure Apache Tomcat User</a></li>
<li><a href="#step-testing">Step 6 - Testing</a></li>
<li><a href="#reference">Reference</a></li>
</ol>
</div>
</div>
<p>Apache Tomcat is an open source Java Servlet implementation developed by the Apache Software Foundation. In addition to the implementation of Java Servlets, Tomcat supports other Java server technologies too, including JavaServer Pages (JSP), Java Expression Language, and Java WebSocket. Tomcat provides an HTTP Web Server for Java applications that supports HTTP/2, OpenSSL for JSSE, and TLS virtual hosting.</p>
<p>In this tutorial, we will show you how to install and configure the Apache Tomcat 9.0.8 on Ubuntu 18.04 LTS (Bionic Beaver). We will also learn how to install Java on Ubuntu 18.04 LTS, configure a user for apache tomcat, and run the apache tomcat as a systemd service.</p>
<h2 id="prerequisites">Prerequisites</h2>
<ul>
<li>Ubuntu 18.04 - 64bit</li>
<li>2 GB or more memory (Recommended)</li>
<li>Root Privileges</li>
</ul>
<h2 id="what-we-will-do">What we will do?</h2>
<ol>
<li>Install Java on Ubuntu 18.04</li>
<li>Configure Java Environment</li>
<li>Install Apache Tomcat 9</li>
<li>Configure Apache Tomcat as a Service</li>
<li>Configure Apache Tomcat Users</li>
<li>Testing</li>
</ol>
<h2 id="step-install-java-on-ubuntu-">Step 1 - Install Java on Ubuntu 18.04</h2>
<p>In this step, we will install Java JRE and JDK from the PPA repository. To do that, we have to install a new package 'software-properties-common' first for managing the repository.</p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;">

<div id='div-gpt-ad-1527185271042-6' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-6'); });
</script>
</div>
</div>
<p>Install 'software-properties-common' package.</p>
<p class="command">sudo apt install software-properties-common -y</p>
<p>Add the java 'webupd8team' repository using the 'add-apt-repository' command.</p>
<p class="command">sudo add-apt-repository ppa:webupd8team/java</p>
<p>And install java using the apt command below.</p>
<p class="command">sudo apt install oracle-java8-installer -y</p>
<p>When the installation is complete, check the java version installed on the system.</p>
<p class="command">java -version</p>
<p>And you will get the result as below.</p>
<pre class="system">java version "1.8.0_171"<br /> Java(TM) SE Runtime Environment (build 1.8.0_171-b11)<br /> Java HotSpot(TM) 64-Bit Server VM (build 25.171-b11, mixed mode)</pre>
<p style="text-align: center;"><a class="fancybox" id="img-1" href="https://www.howtoforge.com/images/how_to_install_and_configure_apache_tomcat_9_on_ubuntu_1804/big/1.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_apache_tomcat_9_on_ubuntu_1804/1.png" alt="Install Java on Ubuntu" width="500" height="130" /></a></p>
<p>Java has been installed on Ubuntu 18.04.</p>
<h2 id="step-configure-java-environment">Step 2 - Configure Java Environment</h2>
<p>In the first step, we've installed Java. Now we need to configure the JAVA_HOME environment variable on the Ubuntu server so that Java applications can find the Java installation directory. Tomcat needs a JAVA_HOME environment to be set up properly.</p>
<p>Before we configure the JAVA_HOME environment, we need to know where the Java directory is. Check the location of the Java directory with the command below:</p>
<p class="command">sudo update-alternatives --config java</p>
<p style="text-align: center;"><a class="fancybox" id="img-2" href="https://www.howtoforge.com/images/how_to_install_and_configure_apache_tomcat_9_on_ubuntu_1804/big/2.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_apache_tomcat_9_on_ubuntu_1804/2.png" alt="Configure Java Environment" width="500" height="182" /></a></p>
<p>The java directory&nbsp; is "<strong>/usr/lib/jvm/java-8-oracle/jre</strong>"</p>
<p>Now edit the '/etc/environment' file using <a href="https://www.howtoforge.com/vim-basics" target="_blank">vim</a>.</p>
<p class="command">vim /etc/environment</p>
<p>Paste the following configuration there.</p>
<pre>JAVA_HOME="/usr/lib/jvm/java-8-oracle/jre"</pre>
<p>Save and exit.</p>
<p>Edit the '~/.bashrc' file.</p>
<p class="command">vim ~/.bashrc</p>
<p>Paste the below configuration.</p>
<pre>export JAVA_HOME=/usr/lib/jvm/java-8-oracle/jre
export PATH=$JAVA_HOME/bin:$PATH</pre>
<p>Save and exit.</p>
<p>Now reload the '~/.bashrc' script and test the 'JAVA_HOME' directory.</p>
<p class="command">source ~/.bashrc<br />echo $JAVA_HOME</p>
<p style="text-align: center;"><a class="fancybox" id="img-3" href="https://www.howtoforge.com/images/how_to_install_and_configure_apache_tomcat_9_on_ubuntu_1804/big/3.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_apache_tomcat_9_on_ubuntu_1804/3.png" alt="Setup Java environment" width="500" height="192" /></a></p>
<p>The java environment setup has been completed.</p>
<h2 id="step-install-apache-tomcat">Step 3 - Install Apache Tomcat</h2>
<p>In this step, we will install the Apache Tomcat under the 'tomcat' user and group. We will download the apache tomcat binary files, configure the Catalina tomcat servlet container environment, and do a first test of the Tomcat server.</p>
<p>Add new user and group named 'tomcat' using the commands below.</p>
<p class="command">groupadd tomcat<br />useradd -s /bin/false -g tomcat -d /opt/tomcat tomcat</p>
<p>Now go to the '/opt/' directory and download the latest apache tomcat stable version (9.0.8) using the wget command.</p>
<p class="command">cd /opt/<br />wget http://www-eu.apache.org/dist/tomcat/tomcat-9/v9.0.8/bin/apache-tomcat-9.0.8.tar.gz</p>
<p>Extract the apache tomcat package file and rename the directory to 'tomcat'.</p>
<p class="command">tar -xzvf apache-tomcat-9.0.8.tar.gz<br />mv apache-tomcat-9.0.8/ tomcat/</p>
<p>Change the owner of tomcat directory and files to the 'tomcat' user and group, then make all apache tomcat binary files executable.</p>
<p class="command">chown -R tomcat:tomcat /opt/tomcat<br />chmod +x /opt/tomcat/bin/*</p>
<p>Next, we will configure the Catalina tomcat servlet container environment by editing the '~/.bashrc' file using vim.</p>
<p class="command">vim ~/.bashrc</p>
<p>Paste the following configuration there.</p>
<pre>export CATALINA_HOME=/opt/tomcat</pre>
<p>Save and exit.</p>
<p>Reload the '~/.bashrc' file and test the Catalina environment.</p>
<p class="command">source ~/.bashrc<br />echo $CATALINA_HOME</p>
<p>You will get the result as shown below.</p>
<p style="text-align: center;"><a class="fancybox" id="img-4" href="https://www.howtoforge.com/images/how_to_install_and_configure_apache_tomcat_9_on_ubuntu_1804/big/4.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_apache_tomcat_9_on_ubuntu_1804/4.png" alt="Setup Tomcat" width="500" height="199" /></a></p>
<p>Now test to run the Apache Tomcat itself.</p>
<p>Run the command below to start Apache tomcat.</p>
<p class="command">$CATALINA_HOME/bin/startup.sh</p>
<p>And you'll see the result - apache tomcat has been started. It will run on the default port '8080' - you can check the port using netstat command.</p>
<p class="command">netstat -plntu</p>
<p>The Apache Tomcat is running the server under port 8080.</p>
<p style="text-align: center;"><a class="fancybox" id="img-5" href="https://www.howtoforge.com/images/how_to_install_and_configure_apache_tomcat_9_on_ubuntu_1804/big/5.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_apache_tomcat_9_on_ubuntu_1804/5.png" alt="Install and start Apache Tomcat" width="500" height="261" /></a></p>
<p>Another way for testing the apache tomcat is by visiting the server IP address with port 8080.</p>
<p><a href="http://192.168.10.100:8080/">http://192.168.10.100:8080/</a></p>
<p>And you will see the apache tomcat homepage as below.</p>
<p style="text-align: center;"><a class="fancybox" id="img-6" href="https://www.howtoforge.com/images/how_to_install_and_configure_apache_tomcat_9_on_ubuntu_1804/big/6.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_apache_tomcat_9_on_ubuntu_1804/6.png" alt="Tomcat started" width="500" height="286" /></a></p>
<p>Apache Tomcat has been installed on Ubuntu 18.04.</p>
<p>Now run the command below to stop the apache tomcat.</p>
<p class="command">$CATALINA_HOME/bin/shutdown.sh<br />chown -hR tomcat:tomcat /opt/tomcat/</p>
<p style="text-align: center;"><a class="fancybox" id="img-7" href="https://www.howtoforge.com/images/how_to_install_and_configure_apache_tomcat_9_on_ubuntu_1804/big/7.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_apache_tomcat_9_on_ubuntu_1804/7.png" alt="Stop Tomcat server" width="500" height="161" /></a></p>
<h2 id="step-configure-apache-tomcat-as-a-service">Step 4 - Configure Apache Tomcat as a Service</h2>
<p>In this tutorial, we want to run Apache Tomcat as tomcat user with a systemd service file so it can be started and stopped easily. Now we need to create the 'apache-tomcat.service' file.</p>
<p>Go to the systemd system directory and create a new file 'apache-tomcat.service'.</p>
<p class="command">cd /etc/systemd/system/<br />vim apache-tomcat.service</p>
<p>Paste the following configuration there:</p>
<pre>[Unit]
Description=Apache Tomcat 9 Servlet Container
After=syslog.target network.target

[Service]
User=tomcat
Group=tomcat
Type=forking
Environment=CATALINA_PID=/opt/tomcat/tomcat.pid
Environment=CATALINA_HOME=/opt/tomcat
Environment=CATALINA_BASE=/opt/tomcat
ExecStart=/opt/tomcat/bin/startup.sh
ExecStop=/opt/tomcat/bin/shutdown.sh
Restart=on-failure

[Install]
WantedBy=multi-user.target</pre>
<p>Save and exit.</p>
<p>Now reload the systemd service.</p>
<p class="command">systemctl daemon-reload</p>
<p>And start the 'apache-tomcat' service using the systemctl commands below.</p>
<p class="command">systemctl start apache-tomcat<br />systemctl enable apache-tomcat</p>
<p style="text-align: center;"><a class="fancybox" id="img-8" href="https://www.howtoforge.com/images/how_to_install_and_configure_apache_tomcat_9_on_ubuntu_1804/big/8.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_apache_tomcat_9_on_ubuntu_1804/8.png" alt="Configure Apache Tomcat as a Service" width="500" height="123" /></a></p>
<p>The Apache Tomcat is now running as a service on Ubuntu 18.04, check it using following commands.</p>
<p class="command">netstat -plntu<br />systemctl status apache-tomcat</p>
<p style="text-align: center;"><a class="fancybox" id="img-9" href="https://www.howtoforge.com/images/how_to_install_and_configure_apache_tomcat_9_on_ubuntu_1804/big/9.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_apache_tomcat_9_on_ubuntu_1804/9.png" alt="Check Tomcat service" width="500" height="291" /></a></p>
<p>The Apache Tomcat is now running and it's using the port 8080 as a default port.</p>
<h2 id="step-configure-apache-tomcat-user">Step 5 - Configure Apache Tomcat User</h2>
<p>In this step, we will configure the users for Apache Tomcat. We will add a new user to access the manager UI, and then allow the manager and host-manager access.</p>
<p>Go to the '/opt/tomcat/conf' directory and edit the 'tomcat-users.xml' file using vim.</p>
<p class="command">cd /opt/tomcat/conf<br />vim tomcat-users.xml</p>
<p>Paste the following configuration before the closing configuration '<em>&lt;/tomcat-users&gt;</em>'.</p>
<pre>&lt;role rolename="manager-gui"/&gt;
&lt;user username="hakase" password="hakasepassword01" roles="manager-gui,admin-gui"/&gt;</pre>
<p>Save and exit.</p>
<p style="text-align: center;"><a class="fancybox" id="img-10" href="https://www.howtoforge.com/images/how_to_install_and_configure_apache_tomcat_9_on_ubuntu_1804/big/10.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_apache_tomcat_9_on_ubuntu_1804/10.png" alt="Configure Apache Tomcat User" width="500" height="198" /></a></p>
<p>Now allow external access to the 'manager' dashboard by editing it's configuration 'context.xml' file.</p>
<p class="command">cd /opt/tomcat/webapps/manager/META-INF/<br />vim context.xml</p>
<p>Comment the 'allow' line 19-20.</p>
<pre>&lt;!--  &lt;Valve className="org.apache.catalina.valves.RemoteAddrValve"
         allow="127\.\d+\.\d+\.\d+|::1|0:0:0:0:0:0:0:1" /&gt; --&gt;</pre>
<p>Save and exit.</p>
<p style="text-align: center;"><a class="fancybox" id="img-11" href="https://www.howtoforge.com/images/how_to_install_and_configure_apache_tomcat_9_on_ubuntu_1804/big/11.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_apache_tomcat_9_on_ubuntu_1804/11.png" alt="Configure Tomcat tolisten on external network interface" width="500" height="134" /></a></p>
<p>And for the 'host-manager'.</p>
<p class="command">cd /opt/tomcat/webapps/host-manager/META-INF/<br />vim context.xml</p>
<p>Comment the 'allow' line 19-20.</p>
<pre>&lt;!--  &lt;Valve className="org.apache.catalina.valves.RemoteAddrValve"
         allow="127\.\d+\.\d+\.\d+|::1|0:0:0:0:0:0:0:1" /&gt; --&gt;</pre>
<p>Save and exit.</p>
<p style="text-align: center;"><a class="fancybox" id="img-12" href="https://www.howtoforge.com/images/how_to_install_and_configure_apache_tomcat_9_on_ubuntu_1804/big/12.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_apache_tomcat_9_on_ubuntu_1804/12.png" alt="comment out org.apache.catalina.valves.RemoteAddrValve" width="500" height="116" /></a></p>
<p>Restart the Apache Tomcat service using the systemctl command.</p>
<p class="command">systemctl restart apache-tomcat</p>
<p>The apache tomcat-users configuration, manager, and host-manager configuration has been completed.</p>
<h2 id="step-testing">Step 6 - Testing</h2>
<p>Open your web browser and type in your server IP with port 8080. You will see the Apache Tomcat home page.</p>
<p><a href="http://192.168.10.100:8080/">http://192.168.10.100:8080/</a></p>
<p style="text-align: center;"><a class="fancybox" id="img-13" href="https://www.howtoforge.com/images/how_to_install_and_configure_apache_tomcat_9_on_ubuntu_1804/big/13.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_apache_tomcat_9_on_ubuntu_1804/13.png" alt="Apache Tomcat runs as a service" width="500" height="284" /></a></p>
<p>Go to the manager dashboard with the URL below:</p>
<p><a href="http://192.168.10.100:8080/manager/html">http://192.168.10.100:8080/manager/html</a></p>
<p>Type the admin username 'hakase' with password 'hakasepassword01' from step 5.</p>
<p style="text-align: center;"><a class="fancybox" id="img-14" href="https://www.howtoforge.com/images/how_to_install_and_configure_apache_tomcat_9_on_ubuntu_1804/big/14.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_apache_tomcat_9_on_ubuntu_1804/14.png" alt="Apache Tomcat application manager" width="500" height="277" /></a></p>
<p>Now go to the host-manager dashboard through URL below:</p>
<p><a href="http://192.168.10.100:8080/host-manager/html">http://192.168.10.100:8080/host-manager/html</a></p>
<p>Enter the admin user and password from step 5, you will see the Tomcat Virtual Host Manager.</p>
<p style="text-align: center;"><a class="fancybox" id="img-15" href="https://www.howtoforge.com/images/how_to_install_and_configure_apache_tomcat_9_on_ubuntu_1804/big/15.png"><img src="https://www.howtoforge.com/images/how_to_install_and_configure_apache_tomcat_9_on_ubuntu_1804/15.png" alt="Apache Tomcat Virtual Host Manager" width="500" height="288" /></a></p>
<p>Apache Tomcat 9.0.8 has been installed successfully on Ubuntu 18.04 Bionic Beaver.</p>
<h2 id="reference">Reference</h2>
<ul>
<li><a href="http://tomcat.apache.org/">http://tomcat.apache.org/</a></li>
</ul>
<div style="height:30px; margin-top:20px;">
<p style="text-align:right;"><img src="/images/pdficon_small.png" /> <a href="/subscription/">view as pdf</a> | <img src="/images/print.gif" /> <a href="/subscription/">print</a></p>
</div>
<div style="height:30px; margin-top:20px;">
<div style="float:left;"><b>Share this page:</b></div>

<p style="text-align:center;">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Ftutorial%2Fubuntu-apache-tomcat%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Ftutorial%2Fubuntu-apache-tomcat%2F&text=How+to+Install+and+Configure+Apache+Tomcat+9+on+Ubuntu+18.04+LTS&via=howtoforgecom&related=howtoforgecom" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.howtoforge.com%2Ftutorial%2Fubuntu-apache-tomcat%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-gplus.png" height="20" /></a>
</p>
</div>
</div>


<div id="htfContentPagePaging">
<h2>Suggested articles</h2>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-3043223216276099" data-ad-slot="8940054090"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>


<div id="htfContentPageComment">
<a name="comments"></a>
<h2>0 Comment(s)</h2>

<div id="commentform">
<div class="commentContainerHead" style="font-size:18px;">Add comment</div>
<div class="commentContainer">
<form method="post" action="/tutorial/ubuntu-apache-tomcat/#comments">
<input type="hidden" name="reply_to" id="reply-to-comment" value="0" />
<div id="commentFormDetail">
<div style="width:48%; float:left; margin-right:3%">
<label for="commentname">Name *</label>
<input id="commentname" name="commentname" value="" />
</div>
<div style="width:48%;float:left;">
<label for="commentname">Email *</label>
<input id="commentemail" name="commentemail" value="" />
</div>
<div style="clear:both;"></div>
</div>
<textarea id="commentedit" name="commentedit" style="width:auto;"></textarea>
<div>
<div style="float:left;">
<div class="g-recaptcha" data-sitekey="6LdX9fUSAAAAALWwVoPdeXScMSketz4npF-0QcQ1"></div>
<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en">
      </script>
</div>
<div style="margin-top:10px;margin-bottom:10px;">
<input type="submit" name="submit" class="button primary" style="float:right;" value="Submit comment">
</div>
<div style="clear:both;"></div>
</div>

<script>
	tinymce.init({
		selector: "textarea#commentedit",
		theme: "modern",
		height: 100,
		apply_source_formatting : true,
		remove_linebreaks : false,
		menubar : false,
		/*auto_focus : "commentedit",*/
		plugins: [
		"link"
		],
		/*plugins: [
			"advlist autolink link image lists charmap print preview hr anchor pagebreak spellchecker",
			"searchreplace wordcount visualblocks visualchars code fullscreen insertdatetime media nonbreaking",
			"save table contextmenu directionality emoticons template paste textcolor"
		],*/
		content_css: "https://www.howtoforge.com/themes/howtoforge/css/custom.css",
		toolbar: "undo redo | bold italic link", 
		/*style_formats: [
			{title: 'Bold text', inline: 'b'},
			{title: 'Red text', inline: 'span', styles: {color: '#ff0000'}},
			{title: 'Red header', block: 'h1', styles: {color: '#ff0000'}},
			{title: 'Example 1', inline: 'span', classes: 'example1'},
			{title: 'Example 2', inline: 'span', classes: 'example2'},
			{title: 'Table styles'},
			{title: 'Table row 1', selector: 'tr', classes: 'tablerow1'}
		]*/
	}); 
	</script>
</form>
</div>
</div>

</div>

<div class="breadBoxBottom">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Tutorials</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/tutorial/ubuntu-apache-tomcat/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to Install and Configure Apache Tomcat 9 on Ubuntu 18.04 LTS</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
<script>
<!--

$(document).on('click', 'a.reply-to', function(e) {
	e.preventDefault();
	
	var self = $(this);
	var cid = self.attr('data-comment');
	console.log(cid);
	if(!cid) return this;
	
	$('#commentform').insertAfter('#comment' + cid);
	$('#reply-to-comment').val(cid);
	/*tinyMCE.activeEditor.focus();*/
	var textareaId = 'commentedit';
	tinyMCE.get(textareaId).remove();
	tinyMCE.execCommand("mceAddEditor", false, textareaId);
	tinyMCE.activeEditor.focus();
});
//-->
</script>
<div style="margin-top:10px;margin-bottom:10px;text-align:center;">

<center>


<div id='div-gpt-ad-1527185271042-1' style='height:90px; width:728px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-1'); });
</script>
</div>

</center>
</div>


<form action="/community/login/login?redirect=/tutorial/ubuntu-apache-tomcat/" method="post" class="xenForm eAuth" id="login" style="display:none">
<ul id="eAuthUnit">
<li><a href="/community/register/facebook?reg=1" class="fbLogin" tabindex="110"><span>Log in with Facebook</span></a></li>
<li><a href="/community/register/twitter?reg=1" class="twitterLogin" tabindex="110"><span>Log in with Twitter</span></a></li>
<li><span class="googleLogin GoogleLogin JsOnly" tabindex="110" data-client-id="198773272284-b6tfk0c28bje81p774prrcrkq9jb3o44.apps.googleusercontent.com" data-redirect-url="/community/register/google?code=__CODE__&amp;csrf=hVMXbW_3rnrmq4Em"><span>Log in with Google</span></span></li>
</ul>
<div class="ctrlWrapper">
<dl class="ctrlUnit">
<dt><label for="LoginControl">Your name or email address:</label></dt>
<dd><input type="text" name="login" id="LoginControl" class="textCtrl" tabindex="101" /></dd>
</dl>
<dl class="ctrlUnit">
<dt>
<label for="ctrl_password">Do you already have an account?</label>
</dt>
<dd>
<ul>
<li><label for="ctrl_not_registered"><input type="radio" name="register" value="1" id="ctrl_not_registered" tabindex="105" />
No, create an account now.</label></li>
<li><label for="ctrl_registered"><input type="radio" name="register" value="0" id="ctrl_registered" tabindex="105" checked="checked" class="Disabler" />
Yes, my password is:</label></li>
<li id="ctrl_registered_Disabler">
<input type="password" name="password" class="textCtrl" id="ctrl_password" tabindex="102" />
<div class="lostPassword"><a href="/community/lost-password/" tabindex="106">Forgot your password?</a></div>
</li>
</ul>
</dd>
</dl>
<dl class="ctrlUnit submitUnit">
<dt></dt>
<dd>
<input type="submit" class="button primary" value="Log in" tabindex="104" data-loginPhrase="Log in" data-signupPhrase="Sign up" />
<label for="ctrl_remember" class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_remember" tabindex="103" /> Stay logged in</label>
</dd>
</dl>
</div>
<input type="hidden" name="cookie_check" value="1" />
<input type="hidden" name="redirect" value="/community/" />
<input type="hidden" name="_xfToken" value="" />
</form>

</div>
</div>

<aside>
<div class="sidebar">
<div class="section loginButton">
<div class="secondaryContent">
<label for="LoginControl" id="SignupButton"><a href="/community/login/" class="inner">Sign up now!</a></label>
</div>
</div>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-2">

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent socialMediaIcon">
<a href="https://twitter.com/howtoforgecom" target="_blank"><img src="/images/socialmedia/64x64/twitter.png" /></a>
<a href="https://www.facebook.com/howtoforge" target="_blank"><img src="/images/socialmedia/64x64/facebook.png" /></a>
<a href="https://plus.google.com/+howtoforge/posts" target="_blank"><img src="/images/socialmedia/64x64/googleplus.png" /></a>
<a href="https://www.howtoforge.com/feed" target="_blank"><img src="/images/socialmedia/64x64/rss.png" /></a>
</div>
</div>
</div>
<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Tutorial Info</p>
<div class="pairsJustified">
<dl class="discussionCount">
<dt>Author:</dt>
<dd>Muhammad Arul</dd>
</dl>
<dl class="discussionCount">
<dt>Published:</dt>
<dd>May 30, 2018</dd>
</dl>
<dl class="discussionCount">
<dt>Tags:</dt>
<dd><a href='/tutorials/linux/' rel='tag'>linux</a>, <a href='/tutorials/server/' rel='tag'>server</a>, <a href='/tutorials/ubuntu/' rel='tag'>ubuntu</a></dd>
</dl>
</div>
</div>
</div>
<script src="//m.servedby-buysellads.com/monetization.js" type="text/javascript"></script>
<div class="native-sidebar"></div>
<script>
  (function(){
    if(typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('default', 'CKYD55QU', 'placement:howtoforge', {
      target: '.native-sidebar',
      align: 'horizontal',
      disable_css: 'true'
    });
      }
  })();
</script>


<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent">
<p class="mnuinfo mnushare">Share This Page</p>
<p style="text-align:center;">
<a href="javascript:window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Ftutorial%2Fubuntu-apache-tomcat%2F', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a> 
<a href="javascript:window.open('https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Ftutorial%2Fubuntu-apache-tomcat%2F&text=How+to+Install+and+Configure+Apache+Tomcat+9+on+Ubuntu+18.04+LTS&via=howtoforgecom&related=howtoforgecom', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="javascript:window.open('https://plus.google.com/share?url=https%3A%2F%2Fwww.howtoforge.com%2Ftutorial%2Fubuntu-apache-tomcat%2F', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-gplus.png" height="20" /></a>
</p>
<p style="color:#EE; font-weight:bold; text-align:center; margin-top:5px;">40.2k Followers</p>
</div>
</div>
</div>



<script type="text/javascript">
    google_ad_client = "ca-pub-3043223216276099";
    google_ad_slot = "6709042890";
    google_ad_width = 300;
    google_ad_height = 600;
</script>

<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>


<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Popular Tutorials</p>
<div class="pairsJustified">
<ul>
<li><a href="/tutorial/perfect-server-ubuntu-18.04-with-apache-php-myqsl-pureftpd-bind-postfix-doveot-and-ispconfig/">The Perfect Server - Ubuntu 18.04 (Bionic Beaver) with Apache, PHP, MySQL, PureFTPD, BIND, Postfix, Dovecot and ISPConfig 3.1</a></li>
<li><hr /></li>
<li><a href="/tutorial/linux-grep-command/">How to use grep to search for strings in files on the shell</a></li>
<li><hr /></li>
<li><a href="/setting-changing-resetting-mysql-root-passwords">Setting, Changing And Resetting MySQL Root Passwords</a></li>
<li><hr /></li>
<li><a href="/linux-tac-command/">Linux tac Command Tutorial for Beginners (with Examples)</a></li>
<li><hr /></li>
<li><a href="/tutorial/setup-new-user-and-ssh-key-authentication-using-ansible/">Setup New User and SSH Key Auth. using Ansible on Ubuntu 18.04</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-use-ftp-on-the-linux-shell/">How to use the Linux ftp command to up- and download files on the shell</a></li>
<li><hr /></li>
<li><a href="/tutorial/centos-kubernetes-docker-cluster/">How to Install a Kubernetes Docker Cluster on CentOS 7</a></li>
<li><hr /></li>
<li><a href="/linux-basics-set-a-static-ip-on-ubuntu">Linux Basics - Set a Static IP on Ubuntu</a></li>
<li><hr /></li>
<li><a href="/tutorial/perfect-server-ubuntu-16.04-with-apache-php-myqsl-pureftpd-bind-postfix-doveot-and-ispconfig/">The Perfect Server - Ubuntu 16.04 (Xenial Xerus) with Apache, PHP, MySQL, PureFTPD, BIND, Postfix, Dovecot and ISPConfig 3.1</a></li>
<li><hr /></li>
<li><a href="/tutorial/ubuntu-ariadne-cms/">How to Install Ariadne CMS on Ubuntu 18.04 LTS</a></li>
<li><hr /></li>
</ul>
</div>
</div>
</div>
</div>
</div>
</aside>
</div>
</div>
</div>
<footer>
<div class="footer">
<div class="pageWidth">
<div class="pageContent">
<div class='skin_branding'><a href="http://www.xenfocus.com" rel="nofollow">Xenforo skin</a><span> by <a href="http://www.xenfocus.com" rel="nofollow">Xenfocus</a></span></div>
<ul class="footerLinks">
<li><a href="/contribute/">Contribute</a></li>
<li><a href="/community/misc/contact">Contact</a></li>
<li><a href="/community/help/">Help</a></li>
<li><a href="/imprint/">Imprint and Legal Notice</a></li>
<li><a href="/" class="homeLink">Tutorials</a></li>
<li><a href="#navigation" class="topLink">Top</a></li>
<li><a href="/feed" rel="alternate" class="globalFeed" target="_blank" title="RSS-Feed for Howtoforge">RSS-Feed</a></li>
</ul>
<span class="helper"></span>
</div>
</div>
</div>
<div class="footerLegal">
<div class="pageWidth">
<div class="pageContent">
<ul id="legal">
<li><a href="/community/help/terms">Terms and Rules</a> <a href="https://www.howtoforge.com/community/help/privacy-policy">Privacy Policy</a></li>
</ul>
<div id="copyright"><a href="https://www.howtoforge.com" class="concealed">Howtoforge <span>&copy; projektfarm GmbH.</span></a></div>
<span class="helper"></span>
</div>
</div>
</div>
</footer>
<div style="height:100px;"></div>
<script>

jQuery.extend(true, XenForo,
{
	visitor: { user_id: 0 },
	serverTimeInfo:
	{
		now: 1409831907,
		today: 1409781600,
		todayDow: 4
	},
	_lightBoxUniversal: "0",
	_enableOverlays: "1",
	_animationSpeedMultiplier: "1",
	_overlayConfig:
	{
		top: "10%",
		speed: 200,
		closeSpeed: 100,
		mask:
		{
			color: "rgb(0, 0, 0)",
			opacity: "0.6",
			loadSpeed: 200,
			closeSpeed: 100
		}
	},
	_ignoredUsers: [],
	_loadedScripts: {"node_list":true,"node_category":true,"node_forum":true,"sidebar_share_page":true,"wf_default":true,"bbm_buttons":true,"login_bar":true,"twitter":true},
	_cookieConfig: { path: "/", domain: "", prefix: "xf_"},
	_csrfToken: "",
	_csrfRefreshUrl: "/community/login/csrf-token-refresh",
	_jsVersion: "303ae0ca"
});
jQuery.extend(XenForo.phrases,
{
	cancel: "Cancel",

	a_moment_ago:    "A moment ago",
	one_minute_ago:  "1 minute ago",
	x_minutes_ago:   "%minutes% minutes ago",
	today_at_x:      "Today at %time%",
	yesterday_at_x:  "Yesterday at %time%",
	day_x_at_time_y: "%day% at %time%",

	day0: "Sunday",
	day1: "Monday",
	day2: "Tuesday",
	day3: "Wednesday",
	day4: "Thursday",
	day5: "Friday",
	day6: "Saturday",

	_months: "January,February,March,April,May,June,July,August,September,October,November,December",
	_daysShort: "Sun,Mon,Tue,Wed,Thu,Fri,Sat",

	following_error_occurred: "The following error occurred",
	server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
	logging_in: "Logging in",
	click_image_show_full_size_version: "Click this image to show the full-size version.",
	show_hidden_content_by_x: "Show hidden content by {names}"
});

// Facebook Javascript SDK
XenForo.Facebook.appId = "";
XenForo.Facebook.forceInit = true;

/*
document.addEventListener('DOMContentLoaded', function(event) {
  cookieChoices.showCookieConsentBar('Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.',
  'OK');
});
*/

$(document).ready(function() {
	$("a.fancybox").fancybox();
});

</script>

<script>
(function() {
  if (typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('fancybar', 'CKYDL27E', 'placement:howtoforgecom');
  }
})();
</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2155872-1', 'auto');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');

</script>
</body>
</html>