<!DOCTYPE html>
<html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs LoggedOut Sidebar Responsive" xmlns:fb="http://www.facebook.com/2008/fbml">
<head>
<meta charset="utf-8" />
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<base href="https://www.howtoforge.com" />
<script>
			var _b = document.getElementsByTagName('base')[0], _bH = "https://www.howtoforge.com/tutorial/ubuntu-airsonic-media-server/";
			if (_b && _b.href != _bH) _b.href = _bH;
		</script>
<title>How to Install Airsonic Media Server on Ubuntu 18.04 LTS</title>
<meta name="keywords" content="linux,server,ubuntu" />
<meta name="description" content="Airsonic is free and open source media server. Its a self-hosted web-based media streamer that provides ubiquitous access to your music, makes it eas... " />
<meta name="og:title" content="How to Install Airsonic Media Server on Ubuntu 18.04 LTS">
<meta name="og:description" content="Airsonic is free and open source media server. Its a self-hosted web-based media streamer that provides ubiquitous access to your music, makes it eas... ">
<meta name="og:site_name" content="Howtoforge">
<meta name="og:type" content="article">
<meta property="og:image" content="https://www.howtoforge.com/images/teaser/ubuntu.gif">
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="howtoforgecom">
<meta name="twitter:creator" content="howtoforgecom">
<meta name="twitter:title" content="How to Install Airsonic Media Server on Ubuntu 18.04 LTS">
<meta name="twitter:description" content="Airsonic is free and open source media server. Its a self-hosted web-based media streamer that provides ubiquitous access to your music, makes it eas... ">
<link rel="alternate" href="https://www.howtoforge.com/tutorial/ubuntu-airsonic-media-server/" hreflang="en" />
<link rel="canonical" href="https://www.howtoforge.com/tutorial/ubuntu-airsonic-media-server/" />
<link rel="amphtml" href="https://www.howtoforge.com/tutorial/ubuntu-airsonic-media-server/amp/" />
<noscript><style>.JsOnly, .jsOnly { display: none !important; }</style></noscript>
<link rel="stylesheet" href="/community/styles/executive/xenfocus/icons/css/font-awesome.min.css" />
<link href='//fonts.googleapis.com/css?family=Open+Sans:400,700' rel='stylesheet' type='text/css' />

<link href="/themes/howtoforge/templates/xf.css" rel="stylesheet">
<script src="/js/jquery/jquery-1.11.3.min.js"></script>
<script src="/community/js/xenforo/xenforo.js?_v=303ae0ca"></script>
<script src="/community/js/bbm/zloader.js?_v=303ae0ca"></script>

<script type="text/javascript" src="/js/fancybox/jquery.mousewheel-3.0.4.pack.js"></script>
<script type="text/javascript" src="/js/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
<link rel="stylesheet" type="text/css" href="/js/fancybox/jquery.fancybox-1.3.4.css" media="screen" />
<link href="/themes/howtoforge/templates/style.css" rel="stylesheet">
<link rel="alternate" type="application/rss+xml" title="RSS-Feed für Howtoforge" href="/feed.rss" />
<script src="/js/tinymce_4.1.7/tinymce.min.js"></script>

<script type="text/javascript">
var gaProperty = 'UA-2155872-1';
var disableStr = 'ga-disable-' + gaProperty;
if (document.cookie.indexOf(disableStr + '=true') > -1) {
window[disableStr] = true;
}
function gaOptout() {
document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
window[disableStr] = true;
alert('Google Ananlyitics tracking has been disabled in this browser.');
}
</script>
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
	googletag.defineSlot('/1030080/howtoforge_com_list_sidebar_top', [300, 250], 'div-gpt-ad-1527185271042-4').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_list_content_middle', [[300, 250], [336, 280]], 'div-gpt-ad-1527185271042-5').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_a_300x250', [300, 250], 'div-gpt-ad-1527185271042-6').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_b_300x250', [300, 250], 'div-gpt-ad-1527185271042-7').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_leaderboard_b_728x90', [728, 90], 'div-gpt-ad-1527185271042-1').addService(googletag.pubads());
	googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script type="text/javascript">
    window.cookieconsent_options = {"message":"This website uses cookies to ensure you get the best experience on our website, analyze site traffic and show you relevant ads.","dismiss":"Got it!","learnMore":"More info","link":"https://www.howtoforge.com/community/help/cookies","theme":"dark-bottom"};
</script>
<script type="text/javascript" src="/js/cookieconsent.latest.min.js"></script>

</head>
<body>
<div id="loginBar">
<div class="pageWidth">
<div class="pageContent">
<h3 id="loginBarHandle">
<label for="LoginControl"><a href="/community/login/" class="concealed noOutline">Log in or Sign up</a></label>
</h3>
<span class="helper"></span>
</div>
</div>
</div>
<header>
<div id="header">
<div id="logoBlock">
<div class="pageWidth">
<div class="pageContent">
<div id="logo"><a href="/">
<span></span>
<img src="/images/howtoforge_logo_trans.gif" alt="Howtoforge" style="margin-left:20px;" />
</a></div>
<span class="helper"></span>
<div class="langSwitch">
<b><img src="/images/gb.png" alt="HowtoForge - Linux Tutorials in English" /> English</b> | <a href="https://www.howtoforge.de/" title="HowtoForge.de - Linux Tutorials auf Deutsch"><img src="/images/de.png" alt="HowtoForge.de - Linux Tutorials auf Deutsch" /> Deutsch</a>
</div>
</div>
</div>
</div>
<div id="navigation" class="pageWidth withSearch">
<div class="pageContent">
<nav>
<div class="navTabs">
<ul class="publicTabs">

<li class="navTab forums selected">
<a href="/" class="navLink">Tutorials</a>
<div class="tabLinks forumsTabLinks">
<ul class="secondaryContent blockLinksList">
<li><a href="/search/">Tutorial search</a></li>
</ul>
</div>
</li>
<li class="navTab forums PopupClosed">
<a href="/tutorials/" class="navLink">Tags</a>
</li>
<li class="navTab forums PopupClosed"><a href="/community/" class="navLink">Forums</a></li>
<li class="navTab forums PopupClosed"><a href="/linux-commands/" class="navLink">Linux Commands</a></li>
<li class="navTab forums PopupClosed"><a href="/subscription/" class="navLink">Subscribe</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.ispconfig.org" class="navLink">ISPConfig</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.lxer.com" class="navLink">News</a></li>
</ul>
</div>
<span class="helper"></span>
</nav>
</div>
</div>
<div id="searchBar" class="pageWidth">
<span id="QuickSearchPlaceholder" title=" Search..."> Search</span>
<fieldset id="QuickSearch">
<form action="/" method="post" class="formPopup">
<div class="primaryControls">

<input type="search" name="q" value="" class="textCtrl" placeholder="Search..." results="0" title="Enter your search and hit enter..." id="QuickSearchQuery" />

</div>
<input type="hidden" name="_xfToken" value="" />
</form>
</fieldset>
</div>
</div>
</header>
<div id="content" class="forum_list">
<div class="pageWidth">
<div class="pageContent">

<div class="mainContainer">
<div class="mainContent">

<div class="breadBoxTop">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Tutorials</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/tutorial/ubuntu-airsonic-media-server/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to Install Airsonic Media Server on Ubuntu 18.04 LTS</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>

<div id="htfContentPage">
<div class="bsa-apiads"><a href="//srv.buysellads.com/ads/click/x/GTND42QICTSDK2J7CES4YKQMCKYD523WCESD6Z3JCW7IT53WCE7D423KC6BICK3NFTSIKK3EHJNCLSIZ" target="_blank" rel="nofollow">It's teamwork, but simpler, more pleasant and more productive.</a><img src="https://slack.sp1.convertro.com/view/vt/v1/slack/0/cvo.gif?cvosrc=display.carbon.two%20cpc&utm_source=carbon&utm_medium=display&utm_campaign=two%20cpc" height="1" width="1" border="0" style="display:none;" /></div>
<h1>How to Install Airsonic Media Server on Ubuntu 18.04 LTS</h1>
<div class="contributeEdit" style="float:right; width:450px; max-width:100%;">

<div id="tocContainer">
<h3>On this page</h3>
<ol class="toc">
<li><a href="#prerequisites">Prerequisites</a></li>
<li><a href="#what-we-will-do">What we will do?</a></li>
<li><a href="#step-install-java-openjdk">Step 1 - Install Java OpenJDK</a></li>
<li><a href="#step-install-and-configure-airsonic">Step 2 - Install and Configure Airsonic</a></li>
<li><a href="#step-generate-new-ssl-letsencrypt-certificate">Step 3 - Generate New SSL Letsencrypt Certificate</a></li>
<li><a href="#step-install-and-configure-nginx-as-a-reverse-proxy">Step 4 - Install and Configure Nginx as a Reverse proxy</a></li>
<li><a href="#step-configure-ufw-firewall">Step 5 - Configure UFW Firewall</a></li>
<li><a href="#step-testing">Step 6 - Testing</a>
<ol>
<li><a href="#-change-default-password">- Change Default Password</a></li>
<li><a href="#-set-up-media-folders">- Set up Media Folders</a></li>
</ol>
</li>
<li><a href="#reference">Reference</a></li>
</ol>
</div>
</div>
<p>Airsonic is free and open source media server. It's a self-hosted web-based media streamer that provides ubiquitous access to your music, makes it easy to share your music with friends or listen to your music while at work. Airsonic has been created with Java as a full fork of the Subsonic, and designed to handle very large music collections and optimized for MP3 stream. Airsonic works with any audio or video formats that can stream over the HTTP protocol, including WMA, FLAC, APE etc.</p>
<p>In this tutorial, I will show you step-by-step how to install Airsonic on Ubuntu 18.04. We will show you how to deploy the stand-alone Airsonic installation using the .WAR package, run Airsonic as a service, and then configure the Nginx web server as a reverse proxy for Airsonic.</p>
<h2 id="prerequisites">Prerequisites</h2>
<ul>
<li>Ubuntu 18.04</li>
<li>Root privileges</li>
</ul>
<h2 id="what-we-will-do">What we will do?</h2>
<ol>
<li>Install Java OpenJDK</li>
<li>Install and Configure AirSonic</li>
<li>Generate New SSL Letsencrypt Certificate</li>
<li>Configure Nginx as a Reverse Proxy</li>
<li>Configure UFW Firewall</li>
<li>Testing</li>
</ol>
<h2 id="step-install-java-openjdk">Step 1 - Install Java OpenJDK</h2>
<p>Airsonic is a Java-based application software, so we need to install Java on the server, and it requires the OpenJDK 1.8x series installation. In this first step, we will install Java OpenJDK from the PPA repository webupd8team.</p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;">

<div id='div-gpt-ad-1527185271042-6' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-6'); });
</script>
</div>
</div>
<p>Install the 'software-properties-common' packages and then add the Java OpenJDK PPA repository.</p>
<p>Run the following apt commands.</p>
<p class="command">sudo apt install software-properties-common apt-transport-https -y<br />sudo add-apt-repository ppa:webupd8team/java -y</p>
<p>Now install the Java OpenJDK.</p>
<p class="command">sudo apt install oracle-java8-installer -y</p>
<p>And after the installation is complete, check the Java OpenJDK version.</p>
<p class="command">java -version</p>
<p>Now you will get the Java OpenJDK 1.8 series has been installed on the Ubuntu 18.04 system.</p>
<p style="text-align: center;"><a class="fancybox" id="img-1" href="https://www.howtoforge.com/images/how_to_install_airsonic_on_ubuntu_1804/big/1.png"><img src="https://www.howtoforge.com/images/how_to_install_airsonic_on_ubuntu_1804/1.png" alt="Install Java OpenJDK" width="500" height="125" /></a></p>
<h2 id="step-install-and-configure-airsonic">Step 2 - Install and Configure Airsonic</h2>
<p>Airsonic provides different installation packages, for this guide, we will be using the 'stand-alone WAR installation'.</p>
<p>Create a new user named 'airsonic', and create a new directory '/opt/airsonic'.</p>
<p class="command">useradd airsonic<br />mkdir -p /opt/airsonic</p>
<p>Now go to the '/opt/airsonic' directory and download the Airsonic '.WAR' package file using wget.</p>
<p class="command">cd /opt/airsonic<br />wget https://github.com/airsonic/airsonic/releases/download/v10.1.1/airsonic.war</p>
<p>And change the owner of the '/opt/airsonic' directory to the 'airsonic' user and group.</p>
<p class="command">chown -R airsonic:airsonic /opt/airsonic</p>
<p>The Airsonic '.WAR' binary package has been downloaded.</p>
<p style="text-align: center;"><a class="fancybox" id="img-2" href="https://www.howtoforge.com/images/how_to_install_airsonic_on_ubuntu_1804/big/2.png"><img src="https://www.howtoforge.com/images/how_to_install_airsonic_on_ubuntu_1804/2.png" alt="Install and Configure Airsonic" width="500" height="208" /></a></p>
<p>Next, we need to create a new service file for Airsonic, go to the '/etc/systemd/system' directory and create a new service file 'airsonic.service'.</p>
<p class="command">cd /etc/systemd/system/<br />vim airsonic.service</p>
<p>Paste the following Airsonic service configuration there.</p>
<pre>[Unit]
Description=Airsonic Media Server
After=remote-fs.target network.target
AssertPathExists=/opt/airsonic

[Service]
Type=simple
Environment="JAVA_JAR=/opt/airsonic/airsonic.war"
Environment="JAVA_OPTS=-Xmx700m"
Environment="AIRSONIC_HOME=/opt/airsonic"
Environment="PORT=8080"
Environment="CONTEXT_PATH=/airsonic"
Environment="JAVA_ARGS="
EnvironmentFile=-/etc/sysconfig/airsonic
ExecStart=/usr/bin/java \
          $JAVA_OPTS \
          -Dairsonic.home=${AIRSONIC_HOME} \
          -Dserver.context-path=${CONTEXT_PATH} \
          -Dserver.port=${PORT} \
          -jar ${JAVA_JAR} $JAVA_ARGS
User=airsonic
Group=airsonic

[Install]
WantedBy=multi-user.target</pre>
<p>Save and exit.</p>
<p>Reload the systemd system and create a new airsonic default configuration file on the '/etc/default' directory.</p>
<p class="command">sudo systemctl daemon-reload<br />vim /etc/default/airsonic</p>
<p>Paste the following default airsonic configuration there.</p>
<pre># Set the location of the standalone war to use
JAVA_JAR=/opt/airsonic/airsonic.war

# Set any java opts separated by spaces
JAVA_OPTS=-Xmx700m

# Set a different location for the airsonic home.
# If this path is /opt/libresonic or even contains "libresonic",
# the data from a previous libresonic can be used as is (i.e. without
# renaming libresonic.properties,db/libresonic*, etc
AIRSONIC_HOME=/opt/airsonic

# Change the port to listen on
PORT=8080

# Change the path that is listened to on
CONTEXT_PATH=/airsonic

# Add any java args. These are different than JAVA_OPTS in that
# they are passed directly to the program. The default is empty:
#JAVA_ARGS=

# Note that there are several settings for spring boot, not explicitly listed
# here, but can be used in either JAVA_OPTS or JAVA_ARGS. The full list
# can be found here:
# https://docs.spring.io/spring-boot/docs/1.4.5.RELEASE/reference/htmlsingle/#common-application-properties
# For example to set debug across the board:
#JAVA_ARGS=--debug

# Or to change the IP address that is listened to:
JAVA_ARGS=--server.address=127.0.0.1</pre>
<p>Save and exit.</p>
<p>Now start the Airsonic service and enable it to launch everytime at system boot.</p>
<p class="command">systemctl start airsonic<br />systemctl enable airsonic</p>
<p style="text-align: center;"><a class="fancybox" id="img-3" href="https://www.howtoforge.com/images/how_to_install_airsonic_on_ubuntu_1804/big/3.png"><img src="https://www.howtoforge.com/images/how_to_install_airsonic_on_ubuntu_1804/3.png" alt="Start airsonic service" width="500" height="130" /></a></p>
<p>The airsonic 'stand-alone' installation is complete, and now it's up and running, check it using the netstat command.</p>
<p class="command">netstat -plntu</p>
<p>And you will get the default port Airsonic '8080' on the 'LISTEN' state, used by the Java Airsonic service.</p>
<p style="text-align: center;"><a class="fancybox" id="img-4" href="https://www.howtoforge.com/images/how_to_install_airsonic_on_ubuntu_1804/big/4.png"><img src="https://www.howtoforge.com/images/how_to_install_airsonic_on_ubuntu_1804/4.png" alt="Check network with netstat" width="500" height="155" /></a></p>
<h2 id="step-generate-new-ssl-letsencrypt-certificate">Step 3 - Generate New SSL Letsencrypt Certificate</h2>
<p>In this tutorial, we will deploy Airsonic under the HTTPS connection of Nginx reverse proxy with the domain name 'music.hakase-labs.io'.</p>
<p>And for this step, we will generate the SSL certificates from Letsencrypt. Install the Letsencrypt tool using the following apt command.</p>
<p class="command">sudo apt install letsencrypt -y</p>
<p>The Letsencrypt tool has been installed.</p>
<p>Next, we need to generate the new SSL certificates for the 'music.hakase-labs.io' domain using the command below.</p>
<p class="command">certbot certonly --standalone -d music.hakase-labs.io</p>
<p>You will be asked for the email address, and it's used for the renew notification. For the Letsencrypt TOS agreement, type 'A' to agree and for the share email address, you can type 'N' for No.</p>
<p style="text-align: center;"><a class="fancybox" id="img-5" href="https://www.howtoforge.com/images/how_to_install_airsonic_on_ubuntu_1804/big/5.png"><img src="https://www.howtoforge.com/images/how_to_install_airsonic_on_ubuntu_1804/5.png" alt="Create SSL cert" width="500" height="382" /></a></p>
<p>When all is complete, you will get the result as shown below.</p>
<p style="text-align: center;"><a class="fancybox" id="img-6" href="https://www.howtoforge.com/images/how_to_install_airsonic_on_ubuntu_1804/big/6.png"><img src="https://www.howtoforge.com/images/how_to_install_airsonic_on_ubuntu_1804/6.png" alt="Letsencrypt SSL certificate has been issued" width="500" height="290" /></a></p>
<p>SSL Letsencrypt for the 'music.hakase-labs.io' domain has been generated, all certificates located at the '/etc/letsencrypt/live/domain' directory.</p>
<h2 id="step-install-and-configure-nginx-as-a-reverse-proxy">Step 4 - Install and Configure Nginx as a Reverse proxy</h2>
<p>In this step, we will install the Nginx web server and configure it as a reverse proxy for the Airsonic software on port 8080.</p>
<p>Install the Nginx web server using the following apt command.</p>
<p class="command">sudo apt install nginx -y</p>
<p>Now go to the '/etc/nginx' directory and create a new virtual host file 'airsonic'.</p>
<p class="command">cd /etc/nginx/<br />vim sites-available/airsonic</p>
<p>Paste the following configuration there.</p>
<pre>server {
    listen 80;
    listen [::]:80;
    server_name music.hakase-labs.io;
    # enforce https
    return 301 https://$server_name$request_uri;
}

server {
    listen              443 ssl;
    server_name         music.hakase-labs.io;
    ssl_certificate /etc/letsencrypt/live/music.hakase-labs.io/fullchain.pem;
    ssl_certificate_key /etc/letsencrypt/live/music.hakase-labs.io/privkey.pem;

    location /airsonic {
      proxy_set_header X-Real-IP         $remote_addr;
      proxy_set_header X-Forwarded-For   $proxy_add_x_forwarded_for;
      proxy_set_header X-Forwarded-Proto https;
      proxy_set_header X-Forwarded-Host  $http_host;
      proxy_set_header Host              $http_host;
      proxy_max_temp_file_size           0;
      proxy_pass                         http://127.0.0.1:8080;
      proxy_redirect                     http:// https://;
    }
}</pre>
<p>Save and exit.</p>
<p>Activate the 'airsonic' virtual host file and test the configuration.</p>
<p class="command">ln -s /etc/nginx/sites-available/airsonic /etc/nginx/sites-enabled/<br />nginx -t</p>
<p>Make sure there is no error, then restart the nginx service and enable it to launch everytime at system boot.</p>
<p class="command">systemctl restart nginx<br />systemctl enable nginx</p>
<p style="text-align: center;"><a class="fancybox" id="img-7" href="https://www.howtoforge.com/images/how_to_install_airsonic_on_ubuntu_1804/big/7.png"><img src="https://www.howtoforge.com/images/how_to_install_airsonic_on_ubuntu_1804/7.png" alt="Install Nginx and configure it as reverse proxy" width="500" height="191" /></a></p>
<p>The Nginx web server is now running as a reverse proxy for the Airsonic on port 8080, and it's running under the https secure connection.</p>
<p>Check it using netstat command below.</p>
<p class="command">netstat -plntu</p>
<p style="text-align: center;"><a class="fancybox" id="img-8" href="https://www.howtoforge.com/images/how_to_install_airsonic_on_ubuntu_1804/big/8.png"><img src="https://www.howtoforge.com/images/how_to_install_airsonic_on_ubuntu_1804/8.png" alt="Check nginx port" width="500" height="168" /></a></p>
<h2 id="step-configure-ufw-firewall">Step 5 - Configure UFW Firewall</h2>
<p>In this tutorial, we will turn on the firewall, and we will be using the UFW firewall for Ubuntu.</p>
<p>Open the SSH, HTTP and HTTPS service on the UFW firewall list by running commands below.</p>
<p class="command">ufw allow ssh<br />ufw allow http<br />ufw allow https</p>
<p>Now enable the ufw firewall.</p>
<p class="command">ufw enable</p>
<p>Type 'y' and press Enter to start and enable the UFW firewall.</p>
<p>And the ufw firewall has been enabled.</p>
<p style="text-align: center;"><a class="fancybox" id="img-9" href="https://www.howtoforge.com/images/how_to_install_airsonic_on_ubuntu_1804/big/9.png"><img src="https://www.howtoforge.com/images/how_to_install_airsonic_on_ubuntu_1804/9.png" alt="Configure UFW Firewall" width="500" height="423" /></a></p>
<h2 id="step-testing">Step 6 - Testing</h2>
<p>Open your web browser and type the Airsonic installation URL on the address bar. Mine is:</p>
<p><em><strong>https://music.hakase-labs.io/airsonic/</strong></em></p>
<p>Now you will be shown the Airsonic login page.</p>
<p style="text-align: center;"><a class="fancybox" id="img-10" href="https://www.howtoforge.com/images/how_to_install_airsonic_on_ubuntu_1804/big/10.png"><img src="https://www.howtoforge.com/images/how_to_install_airsonic_on_ubuntu_1804/10.png" alt="Airsonic login" width="500" height="217" /></a></p>
<p>Log in as a default user 'admin' with password 'admin', and press the 'Log In' button.</p>
<p>And when you logged in, you will see the Airsonic Dashboard.</p>
<h3 id="-change-default-password">- Change Default Password</h3>
<p>Click on the 'Change administrator password' button.</p>
<p style="text-align: center;"><a class="fancybox" id="img-11" href="https://www.howtoforge.com/images/how_to_install_airsonic_on_ubuntu_1804/big/11.png"><img src="https://www.howtoforge.com/images/how_to_install_airsonic_on_ubuntu_1804/11.png" alt="Change the password" width="500" height="286" /></a></p>
<p>Now select the 'admin' user and give a mark on the 'Change password', then type new admin password and click 'Save'.</p>
<p style="text-align: center;"><a class="fancybox" id="img-12" href="https://www.howtoforge.com/images/how_to_install_airsonic_on_ubuntu_1804/big/12.png"><img src="https://www.howtoforge.com/images/how_to_install_airsonic_on_ubuntu_1804/12.png" alt="Admin settings" width="500" height="224" /></a></p>
<p>The default admin password for Airsonic has been changed.</p>
<h3 id="-set-up-media-folders">- Set up Media Folders</h3>
<p>Back to the terminal shell server, create new media folders manually and change the owner of media folder directory to 'airsonic' user.</p>
<p class="command">mkdir -p /var/music<br />chown -R airsonic:airsonic /var/music</p>
<p>Now on the Airsonic admin dashboard, click the 'Settings' button and click the 'Media folders' tab.</p>
<p style="text-align: center;"><a class="fancybox" id="img-13" href="https://www.howtoforge.com/images/how_to_install_airsonic_on_ubuntu_1804/big/13.png"><img src="https://www.howtoforge.com/images/how_to_install_airsonic_on_ubuntu_1804/13.png" alt="Configure Media folder" width="500" height="295" /></a></p>
<p>Make sure the default 'Music' media folders has been enabled, then click 'Save' button.</p>
<p>Now move to the 'User' tab, select the 'admin' user and make a check on the 'Music' media folder as below.</p>
<p style="text-align: center;"><a class="fancybox" id="img-14" href="https://www.howtoforge.com/images/how_to_install_airsonic_on_ubuntu_1804/big/14.png"><img src="https://www.howtoforge.com/images/how_to_install_airsonic_on_ubuntu_1804/14.png" alt="User tab" width="500" height="291" /></a></p>
<p>The default 'Music' media folder has been enabled, and the 'admin' user now has an access to the media folders.</p>
<p>Below is my Airsonic dashboard after making some changes.</p>
<p style="text-align: center;"><a class="fancybox" id="img-15" href="https://www.howtoforge.com/images/how_to_install_airsonic_on_ubuntu_1804/big/15.png"><img src="https://www.howtoforge.com/images/how_to_install_airsonic_on_ubuntu_1804/15.png" alt="Airsonic dashboard" width="500" height="288" /></a></p>
<p>The Airsonic media streamer installation with Nginx as a reverse proxy on Ubuntu 18.04 has been completed successfully.</p>
<h2 id="reference">Reference</h2>
<ul>
<li><a href="https://airsonic.github.io/docs">https://airsonic.github.io/docs/</a></li>
</ul>
<div style="height:30px; margin-top:20px;">
<p style="text-align:right;"><img src="/images/pdficon_small.png" /> <a href="/subscription/">view as pdf</a> | <img src="/images/print.gif" /> <a href="/subscription/">print</a></p>
</div>
<div style="height:30px; margin-top:20px;">
<div style="float:left;"><b>Share this page:</b></div>

<p style="text-align:center;">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Ftutorial%2Fubuntu-airsonic-media-server%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Ftutorial%2Fubuntu-airsonic-media-server%2F&text=How+to+Install+Airsonic+Media+Server+on+Ubuntu+18.04+LTS&via=howtoforgecom&related=howtoforgecom" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.howtoforge.com%2Ftutorial%2Fubuntu-airsonic-media-server%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-gplus.png" height="20" /></a>
</p>
</div>
</div>


<div id="htfContentPagePaging">
<h2>Suggested articles</h2>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-3043223216276099" data-ad-slot="8940054090"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>


<div id="htfContentPageComment">
<a name="comments"></a>
<h2>0 Comment(s)</h2>

<div id="commentform">
<div class="commentContainerHead" style="font-size:18px;">Add comment</div>
<div class="commentContainer">
<form method="post" action="/tutorial/ubuntu-airsonic-media-server/#comments">
<input type="hidden" name="reply_to" id="reply-to-comment" value="0" />
<div id="commentFormDetail">
<div style="width:48%; float:left; margin-right:3%">
<label for="commentname">Name *</label>
<input id="commentname" name="commentname" value="" />
</div>
<div style="width:48%;float:left;">
<label for="commentname">Email *</label>
<input id="commentemail" name="commentemail" value="" />
</div>
<div style="clear:both;"></div>
</div>
<textarea id="commentedit" name="commentedit" style="width:auto;"></textarea>
<div>
<div style="float:left;">
<div class="g-recaptcha" data-sitekey="6LdX9fUSAAAAALWwVoPdeXScMSketz4npF-0QcQ1"></div>
<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en">
      </script>
</div>
<div style="margin-top:10px;margin-bottom:10px;">
<input type="submit" name="submit" class="button primary" style="float:right;" value="Submit comment">
</div>
<div style="clear:both;"></div>
</div>

<script>
	tinymce.init({
		selector: "textarea#commentedit",
		theme: "modern",
		height: 100,
		apply_source_formatting : true,
		remove_linebreaks : false,
		menubar : false,
		/*auto_focus : "commentedit",*/
		plugins: [
		"link"
		],
		/*plugins: [
			"advlist autolink link image lists charmap print preview hr anchor pagebreak spellchecker",
			"searchreplace wordcount visualblocks visualchars code fullscreen insertdatetime media nonbreaking",
			"save table contextmenu directionality emoticons template paste textcolor"
		],*/
		content_css: "https://www.howtoforge.com/themes/howtoforge/css/custom.css",
		toolbar: "undo redo | bold italic link", 
		/*style_formats: [
			{title: 'Bold text', inline: 'b'},
			{title: 'Red text', inline: 'span', styles: {color: '#ff0000'}},
			{title: 'Red header', block: 'h1', styles: {color: '#ff0000'}},
			{title: 'Example 1', inline: 'span', classes: 'example1'},
			{title: 'Example 2', inline: 'span', classes: 'example2'},
			{title: 'Table styles'},
			{title: 'Table row 1', selector: 'tr', classes: 'tablerow1'}
		]*/
	}); 
	</script>
</form>
</div>
</div>

</div>

<div class="breadBoxBottom">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Tutorials</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/tutorial/ubuntu-airsonic-media-server/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to Install Airsonic Media Server on Ubuntu 18.04 LTS</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
<script>
<!--

$(document).on('click', 'a.reply-to', function(e) {
	e.preventDefault();
	
	var self = $(this);
	var cid = self.attr('data-comment');
	console.log(cid);
	if(!cid) return this;
	
	$('#commentform').insertAfter('#comment' + cid);
	$('#reply-to-comment').val(cid);
	/*tinyMCE.activeEditor.focus();*/
	var textareaId = 'commentedit';
	tinyMCE.get(textareaId).remove();
	tinyMCE.execCommand("mceAddEditor", false, textareaId);
	tinyMCE.activeEditor.focus();
});
//-->
</script>
<div style="margin-top:10px;margin-bottom:10px;text-align:center;">

<center>


<div id='div-gpt-ad-1527185271042-1' style='height:90px; width:728px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-1'); });
</script>
</div>

</center>
</div>


<form action="/community/login/login?redirect=/tutorial/ubuntu-airsonic-media-server/" method="post" class="xenForm eAuth" id="login" style="display:none">
<ul id="eAuthUnit">
<li><a href="/community/register/facebook?reg=1" class="fbLogin" tabindex="110"><span>Log in with Facebook</span></a></li>
<li><a href="/community/register/twitter?reg=1" class="twitterLogin" tabindex="110"><span>Log in with Twitter</span></a></li>
<li><span class="googleLogin GoogleLogin JsOnly" tabindex="110" data-client-id="198773272284-b6tfk0c28bje81p774prrcrkq9jb3o44.apps.googleusercontent.com" data-redirect-url="/community/register/google?code=__CODE__&amp;csrf=hVMXbW_3rnrmq4Em"><span>Log in with Google</span></span></li>
</ul>
<div class="ctrlWrapper">
<dl class="ctrlUnit">
<dt><label for="LoginControl">Your name or email address:</label></dt>
<dd><input type="text" name="login" id="LoginControl" class="textCtrl" tabindex="101" /></dd>
</dl>
<dl class="ctrlUnit">
<dt>
<label for="ctrl_password">Do you already have an account?</label>
</dt>
<dd>
<ul>
<li><label for="ctrl_not_registered"><input type="radio" name="register" value="1" id="ctrl_not_registered" tabindex="105" />
No, create an account now.</label></li>
<li><label for="ctrl_registered"><input type="radio" name="register" value="0" id="ctrl_registered" tabindex="105" checked="checked" class="Disabler" />
Yes, my password is:</label></li>
<li id="ctrl_registered_Disabler">
<input type="password" name="password" class="textCtrl" id="ctrl_password" tabindex="102" />
<div class="lostPassword"><a href="/community/lost-password/" tabindex="106">Forgot your password?</a></div>
</li>
</ul>
</dd>
</dl>
<dl class="ctrlUnit submitUnit">
<dt></dt>
<dd>
 <input type="submit" class="button primary" value="Log in" tabindex="104" data-loginPhrase="Log in" data-signupPhrase="Sign up" />
<label for="ctrl_remember" class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_remember" tabindex="103" /> Stay logged in</label>
</dd>
</dl>
</div>
<input type="hidden" name="cookie_check" value="1" />
<input type="hidden" name="redirect" value="/community/" />
<input type="hidden" name="_xfToken" value="" />
</form>

</div>
</div>

<aside>
<div class="sidebar">
<div class="section loginButton">
<div class="secondaryContent">
<label for="LoginControl" id="SignupButton"><a href="/community/login/" class="inner">Sign up now!</a></label>
</div>
</div>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-2">

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent socialMediaIcon">
<a href="https://twitter.com/howtoforgecom" target="_blank"><img src="/images/socialmedia/64x64/twitter.png" /></a>
<a href="https://www.facebook.com/howtoforge" target="_blank"><img src="/images/socialmedia/64x64/facebook.png" /></a>
<a href="https://plus.google.com/+howtoforge/posts" target="_blank"><img src="/images/socialmedia/64x64/googleplus.png" /></a>
<a href="https://www.howtoforge.com/feed" target="_blank"><img src="/images/socialmedia/64x64/rss.png" /></a>
</div>
</div>
</div>
<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Tutorial Info</p>
<div class="pairsJustified">
<dl class="discussionCount">
<dt>Author:</dt>
<dd>Muhammad Arul</dd>
</dl>
<dl class="discussionCount">
<dt>Published:</dt>
<dd>Jul 03, 2018</dd>
</dl>
<dl class="discussionCount">
<dt>Tags:</dt>
<dd><a href='/tutorials/linux/' rel='tag'>linux</a>, <a href='/tutorials/server/' rel='tag'>server</a>, <a href='/tutorials/ubuntu/' rel='tag'>ubuntu</a></dd>
</dl>
</div>
</div>
</div>
<script src="//m.servedby-buysellads.com/monetization.js" type="text/javascript"></script>
<div class="native-sidebar"></div>
<script>
  (function(){
    if(typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('default', 'CKYD55QU', 'placement:howtoforge', {
      target: '.native-sidebar',
      align: 'horizontal',
      disable_css: 'true'
    });
      }
  })();
</script>


<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent">
<p class="mnuinfo mnushare">Share This Page</p>
<p style="text-align:center;">
<a href="javascript:window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Ftutorial%2Fubuntu-airsonic-media-server%2F', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="javascript:window.open('https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Ftutorial%2Fubuntu-airsonic-media-server%2F&text=How+to+Install+Airsonic+Media+Server+on+Ubuntu+18.04+LTS&via=howtoforgecom&related=howtoforgecom', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="javascript:window.open('https://plus.google.com/share?url=https%3A%2F%2Fwww.howtoforge.com%2Ftutorial%2Fubuntu-airsonic-media-server%2F', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-gplus.png" height="20" /></a>
</p>
<p style="color:#EE; font-weight:bold; text-align:center; margin-top:5px;">40.2k Followers</p>
</div>
</div>
</div>



<script type="text/javascript">
    google_ad_client = "ca-pub-3043223216276099";
    google_ad_slot = "6709042890";
    google_ad_width = 300;
    google_ad_height = 600;
</script>

<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>


<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Popular Tutorials</p>
<div class="pairsJustified">
<ul>
<li><a href="/tutorial/perfect-server-debian-9-stretch-apache-bind-dovecot-ispconfig-3-1/">The Perfect Server - Debian 9 (Stretch) with Apache, BIND, Dovecot, PureFTPD and ISPConfig 3.1</a></li>
<li><hr /></li>
<li><a href="/tutorial/linux-grep-command/">How to use grep to search for strings in files on the shell</a></li>
<li><hr /></li>
<li><a href="/tutorial/perfect-server-ubuntu-18.04-with-apache-php-myqsl-pureftpd-bind-postfix-doveot-and-ispconfig/">The Perfect Server - Ubuntu 18.04 (Bionic Beaver) with Apache, PHP, MySQL, PureFTPD, BIND, Postfix, Dovecot and ISPConfig 3.1</a></li>
<li><hr /></li>
<li><a href="/linux-dpkg-command/">Linux dpkg Command Tutorial for Beginners (8 Examples)</a></li>
<li><hr /></li>
<li><a href="/setting-changing-resetting-mysql-root-passwords">Setting, Changing And Resetting MySQL Root Passwords</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-install-nginx-with-brotli-compression-on-ubuntu-1804/">How to Install Nginx with Brotli Compression on Ubuntu 18.04 LTS</a></li>
<li><hr /></li>
<li><a href="/linux-tty-command/">Linux tty Command Tutorial for Beginners (with Examples)</a></li>
<li><hr /></li>
<li><a href="/tutorial/debian-espocrm/">How to Install EspoCRM Open Source CRM Software on Debian 9</a></li>
 <li><hr /></li>
<li><a href="/tutorial/how-to-build-nginx-from-source-on-ubuntu-1804-lts/">How to Build NGINX from source on Ubuntu 18.04 LTS</a></li>
<li><hr /></li>
<li><a href="/tutorial/centos-rancher-docker-container-management-platform/">How to Install Rancher Docker Container Manager on CentOS 7</a></li>
<li><hr /></li>
</ul>
</div>
</div>
</div>
</div>
</div>
</aside>
</div>
</div>
</div>
<footer>
<div class="footer">
<div class="pageWidth">
<div class="pageContent">
<div class='skin_branding'><a href="http://www.xenfocus.com" rel="nofollow">Xenforo skin</a><span> by <a href="http://www.xenfocus.com" rel="nofollow">Xenfocus</a></span></div>
<ul class="footerLinks">
<li><a href="/contribute/">Contribute</a></li>
<li><a href="/community/misc/contact">Contact</a></li>
<li><a href="/community/help/">Help</a></li>
<li><a href="/imprint/">Imprint and Legal Notice</a></li>
<li><a href="/" class="homeLink">Tutorials</a></li>
<li><a href="#navigation" class="topLink">Top</a></li>
<li><a href="/feed" rel="alternate" class="globalFeed" target="_blank" title="RSS-Feed for Howtoforge">RSS-Feed</a></li>
</ul>
<span class="helper"></span>
</div>
</div>
</div>
<div class="footerLegal">
<div class="pageWidth">
<div class="pageContent">
<ul id="legal">
<li><a href="/community/help/terms">Terms and Rules</a> <a href="https://www.howtoforge.com/community/help/privacy-policy">Privacy Policy</a></li>
</ul>
<div id="copyright"><a href="https://www.howtoforge.com" class="concealed">Howtoforge <span>&copy; projektfarm GmbH.</span></a></div>
<span class="helper"></span>
</div>
</div>
</div>
</footer>
<div style="height:100px;"></div>
<script>

jQuery.extend(true, XenForo,
{
	visitor: { user_id: 0 },
	serverTimeInfo:
	{
		now: 1409831907,
		today: 1409781600,
		todayDow: 4
	},
	_lightBoxUniversal: "0",
	_enableOverlays: "1",
	_animationSpeedMultiplier: "1",
	_overlayConfig:
	{
		top: "10%",
		speed: 200,
		closeSpeed: 100,
		mask:
		{
			color: "rgb(0, 0, 0)",
			opacity: "0.6",
			loadSpeed: 200,
			closeSpeed: 100
		}
	},
	_ignoredUsers: [],
	_loadedScripts: {"node_list":true,"node_category":true,"node_forum":true,"sidebar_share_page":true,"wf_default":true,"bbm_buttons":true,"login_bar":true,"twitter":true},
	_cookieConfig: { path: "/", domain: "", prefix: "xf_"},
	_csrfToken: "",
	_csrfRefreshUrl: "/community/login/csrf-token-refresh",
	_jsVersion: "303ae0ca"
});
jQuery.extend(XenForo.phrases,
{
	cancel: "Cancel",

	a_moment_ago:    "A moment ago",
	one_minute_ago:  "1 minute ago",
	x_minutes_ago:   "%minutes% minutes ago",
	today_at_x:      "Today at %time%",
	yesterday_at_x:  "Yesterday at %time%",
	day_x_at_time_y: "%day% at %time%",

	day0: "Sunday",
	day1: "Monday",
	day2: "Tuesday",
	day3: "Wednesday",
	day4: "Thursday",
	day5: "Friday",
	day6: "Saturday",

	_months: "January,February,March,April,May,June,July,August,September,October,November,December",
	_daysShort: "Sun,Mon,Tue,Wed,Thu,Fri,Sat",

	following_error_occurred: "The following error occurred",
	server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
	logging_in: "Logging in",
	click_image_show_full_size_version: "Click this image to show the full-size version.",
	show_hidden_content_by_x: "Show hidden content by {names}"
});

// Facebook Javascript SDK
XenForo.Facebook.appId = "";
XenForo.Facebook.forceInit = true;

/*
document.addEventListener('DOMContentLoaded', function(event) {
  cookieChoices.showCookieConsentBar('Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.',
  'OK');
});
*/

$(document).ready(function() {
	$("a.fancybox").fancybox();
});

</script>

<script>
(function() {
  if (typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('fancybar', 'CKYDL27E', 'placement:howtoforgecom');
  }
})();
</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2155872-1', 'auto');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');

</script>
</body>
</html>