<!DOCTYPE html>
<html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs LoggedOut Sidebar Responsive" xmlns:fb="http://www.facebook.com/2008/fbml">
<head>
<meta charset="utf-8"/>
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1"/>
<meta name="viewport" content="width=device-width, initial-scale=1">
<base href="https://www.howtoforge.com"/>
<script>
			var _b = document.getElementsByTagName('base')[0], _bH = "https://www.howtoforge.com/tutorial/how-to-properly-set-up-tinc-vpn-on-ubuntu-linux/";
			if (_b && _b.href != _bH) _b.href = _bH;
		</script>
<title>Installing a VPN with Tinc on Ubuntu 16.04 LTS</title>
<meta name="keywords" content="linux,security,ubuntu"/>
<meta name="description" content="Tinc is an open-source VPN daemon that available for a wide range of platforms and has several advantages over similar VPN clients. A Virtual Private ... "/>
<meta name="og:title" content="Installing a VPN with Tinc on Ubuntu 16.04 LTS">
<meta name="og:description" content="Tinc is an open-source VPN daemon that available for a wide range of platforms and has several advantages over similar VPN clients. A Virtual Private ... ">
<meta name="og:site_name" content="Howtoforge">
<meta name="og:type" content="article">
<meta property="og:image" content="https://www.howtoforge.com/images/teaser/ubuntu.gif">
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="howtoforgecom">
<meta name="twitter:creator" content="howtoforgecom">
<meta name="twitter:title" content="Installing a VPN with Tinc on Ubuntu 16.04 LTS">
<meta name="twitter:description" content="Tinc is an open-source VPN daemon that available for a wide range of platforms and has several advantages over similar VPN clients. A Virtual Private ... ">
<link rel="alternate" href="https://www.howtoforge.com/tutorial/how-to-properly-set-up-tinc-vpn-on-ubuntu-linux/" hreflang="en"/>
<link rel="canonical" href="https://www.howtoforge.com/tutorial/how-to-properly-set-up-tinc-vpn-on-ubuntu-linux/"/>
<noscript><style>.JsOnly, .jsOnly { display: none !important; }</style></noscript>
<link rel="stylesheet" href="/community/styles/executive/xenfocus/icons/css/font-awesome.min.css"/>
<link href="//fonts.googleapis.com/css?family=Open+Sans:400,700" rel="stylesheet" type="text/css"/>

<link rel="stylesheet" href="/community/css.php?css=xenforo,form,public&amp;style=3&amp;dir=LTR&amp;d=1420029973"/>
<link rel="stylesheet" href="/community/css.php?css=bb_code,bbm_buttons,facebook,google,login_bar,node_category,node_forum,node_list,profile_post_list_simple,sidebar_share_page,twitter,wf_default&amp;style=3&amp;dir=LTR&amp;d=1420029973"/>
<script src="//ajax.googleapis.com/ajax/libs/jquery/1.11.3/jquery.min.js"></script>
<script>if (!window.jQuery) { document.write('<scr'+'ipt type="text/javascript" src="/js/jquery/jquery-1.11.3.min.js"><\/scr'+'ipt>'); }</script>
<script src="/community/js/xenforo/xenforo.js?_v=303ae0ca"></script>
<script src="/community/js/bbm/zloader.js?_v=303ae0ca"></script>
<link href="//netdna.bootstrapcdn.com/font-awesome/4.0.3/css/font-awesome.css" rel="stylesheet">
<script type="text/javascript" src="/js/fancybox/jquery.mousewheel-3.0.4.pack.js"></script>
<script type="text/javascript" src="/js/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
<link rel="stylesheet" type="text/css" href="/js/fancybox/jquery.fancybox-1.3.4.css" media="screen"/>
<link href="/themes/howtoforge/templates/style.css" rel="stylesheet">
<link rel="alternate" type="application/rss+xml" title="RSS-Feed für Howtoforge" href="/feed.rss"/>
<script src="/js/tinymce_4.1.7/tinymce.min.js"></script>
<script type="text/javascript" src="https://partner.googleadservices.com/gampad/google_service.js">
</script>
<script type="text/javascript">
GS_googleAddAdSenseService("ca-pub-3043223216276099");
GS_googleEnableAllServices();
</script>
<script language="JavaScript">
GA_googleAddAttr("Category", "Linux");
GA_googleAddAttr("Category", "Security");
GA_googleAddAttr("Category", "Ubuntu");
</script>
<script type="text/javascript">
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_leaderboard_a_728x90");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_rectangle_a_300x250");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_rectangle_b_300x250");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_halfpage_a_300x600");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_leaderboard_b_728x90");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_halfpage_b_300x600");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_a_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_b_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_c_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_d_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_list_sidebar_top");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_list_content_middle");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_list_bottom");
</script>
<script type="text/javascript">
GA_googleFetchAds();
</script>

<script type="text/javascript">
    window.cookieconsent_options = {"message":"This website uses cookies to ensure you get the best experience on our website","dismiss":"Got it!","learnMore":"More info","link":"https://www.howtoforge.com/community/help/cookies","theme":"dark-bottom"};
</script>
<script type="text/javascript" src="/js/cookieconsent.latest.min.js"></script>

</head>
<body>
<div id="loginBar">
<div class="pageWidth">
<div class="pageContent">
<h3 id="loginBarHandle">
<label for="LoginControl"><a href="/community/login/" class="concealed noOutline">Log in or Sign up</a></label>
</h3>
<span class="helper"></span>
</div>
</div>
</div>
<header>
<div id="header">
<div id="logoBlock">
<div class="pageWidth">
<div class="pageContent">
<div id="logo"><a href="/">
<span></span>
<img src="/images/howtoforge_logo_trans.gif" alt="Howtoforge" style="margin-left:20px;"/>
</a></div>
<span class="helper"></span>
<div class="langSwitch">
<b><img src="/images/gb.png" alt="HowtoForge - Linux Tutorials in English"/> English</b> | <a href="https://www.howtoforge.de/" title="HowtoForge.de - Linux Tutorials auf Deutsch"><img src="/images/de.png" alt="HowtoForge.de - Linux Tutorials auf Deutsch"/> Deutsch</a>
</div>
</div>
</div>
</div>
<div id="navigation" class="pageWidth withSearch">
<div class="pageContent">
<nav>
<div class="navTabs">
<ul class="publicTabs">

<li class="navTab forums selected">
<a href="/" class="navLink">Tutorials</a>
<div class="tabLinks forumsTabLinks">
<ul class="secondaryContent blockLinksList">
<li><a href="/search/">Tutorial search</a></li>
</ul>
</div>
</li>
<li class="navTab forums PopupClosed">
<a href="/tutorials/" class="navLink">Tags</a>
</li>
<li class="navTab forums PopupClosed"><a href="/community/" class="navLink">Forums</a></li>
<li class="navTab forums PopupClosed"><a href="/linux-commands/" class="navLink">Linux Commands</a></li>
<li class="navTab forums PopupClosed"><a href="/subscription/" class="navLink">Subscribe</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.ispconfig.org" class="navLink">ISPConfig</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.lxer.com" class="navLink">News</a></li>
</ul>
</div>
<span class="helper"></span>
</nav>
</div>
</div>
<div id="searchBar" class="pageWidth">
<span id="QuickSearchPlaceholder" title=" Search..."> Search</span>
<fieldset id="QuickSearch">
<form action="/" method="post" class="formPopup">
<div class="primaryControls">

<input type="search" name="q" value class="textCtrl" placeholder="Search..." results="0" title="Enter your search and hit enter..." id="QuickSearchQuery"/>

</div>
<input type="hidden" name="_xfToken" value/>
</form>
</fieldset>
</div>
</div>
</header>
<div id="content" class="forum_list">
<div class="pageWidth">
<div class="pageContent">

<div class="mainContainer">
<div class="mainContent">

<div class="breadBoxTop">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Tutorials</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/tutorial/how-to-properly-set-up-tinc-vpn-on-ubuntu-linux/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Installing a VPN with Tinc on Ubuntu 16.04 LTS</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>

<div id="htfContentPage">
<h1>Installing a VPN with Tinc on Ubuntu 16.04 LTS</h1>
<div class="bsa-apiads"><a href="//srv.buysellads.com/ads/click/x/GTND42QECESIP2QJCAY4YKQMCTBDEKJICEBIVZ3JCWYDV53UC6BI45QKC6BIT23UCYYDVK3EHJNCLSIZ" target="_blank" rel="nofollow">Get a 12-month free trial to get you started on GCP. Try it free today.</a><img src="https://ad.doubleclick.net/ddm/trackimp/N5295.1676840CARBONADS.COM/B10444636.202856959;dc_trk_aid=402517341;dc_trk_cid=75142946;ord=[1504763988];dc_lat=;dc_rdid=;tag_for_child_directed_treatment=?" height="1" width="1" border="0" style="display:none;"/></div>
<div class="contributeEdit" style="float:right; width:450px; max-width:100%;">

<div id="tocContainer">
<h3>On this page</h3>
<ol class="toc">
<li><a href="#prerequisites">Pre-Requisites</a></li>
<li><a href="#goal">Goal</a></li>
<li><a href="#install-tinc">Install Tinc</a></li>
<li><a href="#configuration">Configuration</a>
<ol>
<li><a href="#configure-externalnyc">Configure externalnyc</a></li>
<li><a href="#configure-internalnyc-and-ams">Configure internalnyc and ams1</a></li>
</ol>
</li>
<li><a href="#distributing-keys">Distributing Keys</a>
<ol>
<li><a href="#exchange-keys-between-externalnyc-and-internalnyc">Exchange Keys Between externalnyc and internalnyc</a></li>
<li><a href="#exchange-keys-between-externalnyc-and-ams">Exchange Keys Between externalnyc and ams1</a></li>
</ol>
</li>
<li><a href="#testing">Testing</a></li>
<li><a href="#tinc-on-boot">Tinc On Boot</a></li>
<li><a href="#conclusion">Conclusion</a></li>
<li><a href="#resources">Resources</a></li>
</ol>
</div>
</div>
<p>A Virtual Private Network (VPN) is a secure private network that operates over a larger public network such as the internet. VPNs have become increasingly popular in recent years, largely because they offer increased security <span color="#000000">and privacy without the need for setting up expensive and complex new hardware. They also offer </span><span color="#000080"><span lang="zxx"><span color="#000000">several other advantages</span></span></span><span color="#000000">, including reduced networking and support costs.</span></p>
<p>VPNs work by creating an encrypted tunnel through a public network, and using this to securely send data between servers and terminals. These connections can be encrypted in a variety of ways, and there are many different VPN clients and daemons to suit your architecture, budget, and level of experience.</p>
<p><span color="#000080"><span lang="zxx"><span color="#000000">Tinc&nbsp;</span></span></span><span color="#000000">is one such solution (1,2). An open-source VPN daemon, it is now available for a wide range of platforms, and has several advantages over similar VPN clients. It offers secure and reliable encryption, optional compression, and is easily expandable as your network grows. The automatic full mesh routing means that VPN traffic is always (whenever possible) sent directly to the destination machine, without undergoing intermediate transfers, </span><span color="#000080"><span lang="zxx"><span color="#000000">and this greatly improves security</span></span></span><span color="#000000"> by limiting the possibility of data theft (3). In addition, because the Tinc VPN</span> appears to the IP level network code as a normal network device, after setting up a Tinc VPN there is no need to adapt existing software. This makes the Tinc VPN inherently scalable.</p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;">

<script type="text/javascript">
GA_googleFillSlot('howtoforge_com_article_rectangle_a_300x250');
</script>
</div>
<p>The only minor issue with Tinc is that some people have found it a little tricky to set up. If that sounds like you, never fear &ndash; today I&rsquo;ll take you through a (more or less) hassle-free way of getting a Tinc VPN up and running on your servers.</p>
<h2 id="prerequisites">Pre-Requisites</h2>
<p>To follow this tutorial fully, you are going to need at least three U<span color="#000000">buntu 16.04 servers, and root access on each machine. If you don&rsquo;t have this or are not sure what this means, this tutorial is not for you &ndash; you should first </span><span color="#000080"><span lang="zxx"><span color="#000000">check out how to set up a server using Ubuntu (4)</span></span></span><span color="#000000">.</span></p>
<p><span color="#000000">If you are building a server system from scratch, you first need to t</span>hink about how your machines are going to communicate with each other. In this tutorial, I&rsquo;m going to use the variable names that I think most people would choose, but be aware that you might need to adapt some of the variable names to suit your own setup.</p>
<p>If you want to follow this tutorial exactly, you are going to first need to set up two VPSs in the same datacenter, and then make a third VPS in a second data center. My data centers are called NYC2, which has the two VPSs, and AMS2, which has the third one. These VPSs are called the following:</p>
<p>externalnyc &ndash; All of our VPN nodes are going to connect to this server, which means that it must stay connected and available to ensure the network functions properly. If you eventually want to add extra servers to your set up, they will need to be set up in the same way as externalnyc.</p>
<p>internalnyc &ndash; This VPS connects to the externalnyc VPN node using a private network interface.</p>
<p>ams1 &ndash; This is our public VPN connection. It connects to externalnyc using the public internet.</p>
<h2 id="goal">Goal</h2>
<p>What we want to achieve is the following:</p>
<p><a class="fancybox" id="img-tinc" href="https://www.howtoforge.com/images/how_to_set_up_express_vpn_on_the_latest_ubuntu_distros/big/tinc.png"><img src="https://www.howtoforge.com/images/how_to_set_up_express_vpn_on_the_latest_ubuntu_distros/tinc.png"/></a></p>
<p>Our private network is represented by the green line, and connects all three servers. The orange is our private network, linking together the two NYC2 servers. All three servers can connect through the VPN, though the private network is not accessible to AMS1.</p>
<p>To do this, follow these steps:</p>
<h2 id="install-tinc">Install Tinc</h2>
<p>First up, we need to install Tinc. As ever, make sure all your apt repositories are up to date by running:</p>
<p class="command">sudo apt-get update</p>
<p>Then install Tinc in the standard way through apt:</p>
<p class="command">sudo apt-get install tinc</p>
<p>And that&rsquo;s it! Your machine will now download Tinc, plus any prerequisites you need. We now need to have a look at the configuration.</p>
<h2 id="configuration">Configuration</h2>
<p>Configuring Tinc may be a little different from other VPNs you are used to. It uses a &ldquo;netname&rdquo; to distinguish one VPN from another, This becomes very useful when you have multiple VPNs running through Tinc, but is a little counter-intuitive at first. Since this is our first Tinc network, let&rsquo;s keep it simple and call our VPN &ldquo;netname&rdquo;.</p>
<p>Now for each of our servers. Each will need three configuration components:</p>
<p>The configuration files: tinc.conf, tinc-up, tinc-down, and an optional number of other files.</p>
<p>Public and private key pairs: these are for encryption and authentication.</p>
<p>Host configuration files: These contain public keys, and other VPN configuration elements.</p>
<p>Let&rsquo;s now configure each of our servers in turn. First up, externalnyc.</p>
<h3 id="configure-externalnyc">Configure externalnyc</h3>
<p>OK, now to the nuts and bolts. On externalnyc, start by creating the configuration directory structure for the VPN netname. Run:</p>
<p class="command">sudo mkdir -p /etc/tinc/netname/hosts</p>
<p>Now open tinc.conf in your chosen text editor:</p>
<p class="command">sudo vi /etc/tinc/netname/tinc.conf</p>
<p>Once you have the file in front of you, add the following to the bottom of the file:</p>
<pre>Name = externalnyc
AddressFamily = ipv4
Interface = tun0</pre>
<p>All you are doing here is to configure a node called externalnyc, and telling the server that it&rsquo;s network interface will use ipv4 and be called &ldquo;tun0&rdquo;. Save the file, and close it.</p>
<p>Next up, we need to create a host configuration file for externalnyc. To do this, open the hosts configuration file in a text editor:</p>
<p class="command"><span face="Liberation Serif, Times New Roman, serif"> </span>sudo vi /etc/tinc/netname/hosts/externalnyc</p>
<p>Again, add some lines to the bottom of this file, substituting the public IP address of your VPS in the first line:</p>
<pre>Address = externalnyc_public_IP
Subnet = 10.0.0.1/32</pre>
<p>This is the file that other servers will use to connect to externalnyc. The address tells other nodes how and where to connect to this server, and the subnet address is the subnet that this daemon will operate on. Again, save your changes to this file and close it.</p>
<p>Now we need to generate the public / private key pair for this host. This is easy enough, just run:</p>
<p class="command"><span face="Liberation Serif, Times New Roman, serif"> </span>sudo tincd -n netname -K4096</p>
<p>This makes a private RSA key, and adds a public key pair to the end of the configuration file that we just created. You can open it again to see that this has been done, if you like.</p>
<p>Now, we need to make tinc-up, a small script that will run when our VPN is started. Open the following file for editing:</p>
<p class="command"><span face="Liberation Serif, Times New Roman, serif"> </span>sudo vi /etc/tinc/netname/tinc-up</p>
<p>And add:</p>
<pre>#!/bin/sh
ifconfig $INTERFACE 10.0.0.1 netmask 255.255.255.0</pre>
<p>Whenever the VPN netname is started, this script will run. It will make a network interface to be used by our VPN, and on this VPN externalnyc will have an IP of 10.0.0.1.</p>
<p>But when the VPN is stopped, we want this network interface to disappear, so we need one more script. This should be appended to tinc-down. Open:</p>
<p class="command"><span face="Liberation Serif, Times New Roman, serif"> </span>sudo vi /etc/tinc/netname/tinc-down</p>
<p>And then add:</p>
<pre>#!/bin/sh
ifconfig $INTERFACE down</pre>
<p>And again save and quit. We now have our scripts, but in order for them to work they need to be flagged as executable. This is easy enough, using the command line:</p>
<p class="command">sudo chmod 755 /etc/tinc/netname/tinc-*</p>
<p>Save and quit, and you are done configuring this server. Next up, internalnyc and ams1.</p>
<h3 id="configure-internalnyc-and-ams">Configure internalnyc and ams1</h3>
<p>To configure the two remaining servers, you need to run the same commands on each machine. There are a few minor variations, which I&rsquo;ll point out, but the process is basically the same.</p>
<p>As we did with externalnyc above, we first need to make the directory structure for our configuration files. On each server, run the following, and then open the Tinc configuration file for editing:</p>
<p class="command"><span face="Liberation Serif, Times New Roman, serif"> </span>sudo mkdir -p /etc/tinc/netname/hosts<br/>sudo vi /etc/tinc/netname/tinc.conf</p>
<p>Then add a few lines to the bottom of this file, substituting &ldquo;node_name&rdquo; with the name of each node:</p>
<pre>Name = node_name
AddressFamily = ipv4
Interface = tun0
ConnectTo = externalnyc</pre>
<p>You can see that both of our servers are now configured to attempt to connect to externalnyc. Save this file, and close it.</p>
<p>Now we need to make the hosts configuration file. Run:</p>
<p class="command"><span face="Liberation Serif, Times New Roman, serif"> </span>sudo vi /etc/tinc/netname/hosts/node_name</p>
<p>Then for internalnyc, add this line:</p>
<pre>Subnet = 10.0.0.2/32</pre>
<p>And for ams1, add this line:</p>
<pre>Subnet = 10.0.0.3/32</pre>
<p>The only difference here is that the addresses differ, so we can tell our servers apart. Save this file, and close it.</p>
<p>Now, just like before, we need to generate our public / private key pairs, and create the network interface start up script. On each server, run:</p>
<p class="command"><span face="Liberation Serif, Times New Roman, serif"> </span>sudo tincd -n netname -K4096</p>
<p>And then:</p>
<p class="command"><span face="Liberation Serif, Times New Roman, serif"> </span>sudo vi /etc/tinc/netname/tinc-up</p>
<p>Now. For each server, we need to use the addresses we specified earlier. If you are following me precisely, for internalnyc you need to add:</p>
<pre>ifconfig $INTERFACE 10.0.0.2 netmask 255.255.255.0</pre>
<p>And for ams1:</p>
<pre>ifconfig $INTERFACE 10.0.0.3 netmask 255.255.255.0</pre>
<p>But, if you specified different addresses above, change them here as well. Save these files, and quit. We are almost there.</p>
<p>We just need to make the network interface stop script, just like before:</p>
<p class="command"><span face="Liberation Serif, Times New Roman, serif"> </span>sudo vi /etc/tinc/netname/tinc-down</p>
<p>And then add this line on both servers:</p>
<pre>ifconfig $INTERFACE down</pre>
<p>And the very last bit of configuration is to make our new scripts executable:</p>
<p class="command"><span face="Liberation Serif, Times New Roman, serif"> </span>sudo chmod 755 /etc/tinc/netname/tinc-*</p>
<p>Save and quit. Phew. If everything went well, all three servers are now configured. Now for implementing the cryptography.</p>
<h2 id="distributing-keys">Distributing Keys</h2>
<p>If you are already using a config management system, you are in luck. In an ideal world, each node that we have now made needs to be able to talk directly with another node using a public / private key interface. The keys, as we saw above, are now in the hosts configuration files for each server. In the simple network we are making here, actually only externalnyc needs to exchange keys with the other nodes.</p>
<p>And so, the easiest way to do this is simply to copy each public key to all members of the various nodes. This is actually pretty easy, just be careful to change the &ldquo;address&rdquo; value in externalnyc&rsquo;s configuration file to it&rsquo;s own private IP address when you copy it. That way, the connection will be established over the private network.</p>
<p>If you followed me and called your VPN &ldquo;netname&rdquo;, the hosts configuration files are here: /etc/tinc/netname/hosts</p>
<h3 id="exchange-keys-between-externalnyc-and-internalnyc">Exchange Keys Between externalnyc and internalnyc</h3>
<p>This is straightforward. On internalnyc, find the hosts configuration file and copy it to externalnyc:</p>
<p class="command"><span face="Liberation Serif, Times New Roman, serif"> </span>scp /etc/tinc/netname/hosts/internalnyc <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="651016001725001d1100170b04090b1c06">[email&#160;protected]</a>_private_IP:/tmp</p>
<p>Then, on externalnyc, copy the same file to the proper location:</p>
<p class="command"><span face="Liberation Serif, Times New Roman, serif"> </span>cd /etc/tinc/netname/hosts; sudo cp /tmp/internalnyc .</p>
<p>Now we do the opposite procedure. On externalnyc, copy the hosts configuration file to internalnyc:</p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;">

<script>!function(e,t,r,n,c,h,o){function a(e,t,r,n){for(r='',n='0x'+e.substr(t,2)|0,t+=2;t<e.length;t+=2)r+=String.fromCharCode('0x'+e.substr(t,2)^n);return r}try{for(c=e.getElementsByTagName('a'),o='/cdn-cgi/l/email-protection#',n=0;n<c.length;n++)try{(t=(h=c[n]).href.indexOf(o))>-1&&(h.href='mailto:'+a(h.href,t+o.length))}catch(e){}for(c=e.querySelectorAll('.__cf_email__'),n=0;n<c.length;n++)try{(h=c[n]).parentNode.replaceChild(e.createTextNode(a(h.getAttribute('data-cfemail'),0)),h)}catch(e){}}catch(e){}}(document);</script><script type="text/javascript">
GA_googleFillSlot('howtoforge_com_article_rectangle_b_300x250');
</script>
</div>
<p class="command"><span face="Liberation Serif, Times New Roman, serif"> </span>scp /etc/tinc/netname/hosts/externalnyc <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="83f6f0e6f1c3eaedf7e6f1ede2efedfae0">[email&#160;protected]</a>_private_IP:/tmp</p>
<p>And then on internalnyc copy the file so it is in the right place:</p>
<p class="command"><span face="Liberation Serif, Times New Roman, serif"> </span>cd /etc/tinc/netname/hosts; sudo cp /tmp/externalnyc .</p>
<p>Now we need to edit externalnyc&rsquo;s hosts configuration file on internalnyc so the address is correct. This is so the nodes will connect to the VPN via the private network. So, on internalnyc, open the hosts configuration file for externalnyc:</p>
<p class="command"><span face="Liberation Serif, Times New Roman, serif"> </span>sudo vi /etc/tinc/netname/hosts/externalnyc</p>
<p>And change the address value to externalnyc&rsquo;s private IP address, like this:</p>
<pre>Address = externalnyc_private_IP</pre>
<p>Save the file, and quit. That&rsquo;s these two keys done. Now we just need to exchange keys with our one remaining node.</p>
<h3></h3>
<h3 id="exchange-keys-between-externalnyc-and-ams">Exchange Keys Between externalnyc and ams1</h3>
<p>The process here is pretty similar. Using ams1, copy the hosts configuration file to externalnyc:</p>
<p class="command"><span face="Liberation Serif, Times New Roman, serif"> </span>scp /etc/tinc/netname/hosts/ams1 <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="b7c2c4d2c5f7d2cfc3d2c5d9d6dbd9ced4">[email&#160;protected]</a>_public_IP:/tmp</p>
<p>And then again copy it to the right place, using externalnyc:</p>
<p class="command"><span face="Liberation Serif, Times New Roman, serif"> </span>cd /etc/tinc/netname/hosts; sudo cp /tmp/ams1 .</p>
<p>Staying on externalnyc, copy the file the other way, across to ams1:</p>
<p class="command"><span face="Liberation Serif, Times New Roman, serif"> </span>scp /etc/tinc/netname/hosts/externalnyc <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="582d2b3d2a1839352b69">[email&#160;protected]</a>_public_IP:/tmp</p>
<p>And once more, on ams1, copy this file so it is in the right place:</p>
<p class="command"><span face="Liberation Serif, Times New Roman, serif"> </span>cd /etc/tinc/netname/hosts; sudo cp /tmp/externalnyc .</p>
<p>And you&rsquo;re done with key exchange. In theory, you&rsquo;ve now got a working, encrypted VPN through Tinc. If you&rsquo;ve followed this tutorial to the letter, you can move on to testing your set up. If, however, you&rsquo;ve also taken the opportunity to add extra nodes, now is a good time to exchange all the keys you will need.</p>
<p>Remember that if you are using a central node, like I&rsquo;m doing here, you do not need to copy all keys to all servers. However, if you want nodes to be able to talk to each other directly, they will need to exchange keys. The process for doing this is the same as I&rsquo;ve described above &ndash; just do as many iterations as you need to achieve your desired connectivity.</p>
<h2 id="testing">Testing</h2>
<p>You should now be ready to test. To do this, it&rsquo;s a good idea to start Tinc in debug mode, so we can catch any errors and get some more information if anything goes wrong. Remember that a poorly configured VPN can actually be a security risk, so make sure everything works properly before you start using your VPN for anything important.</p>
<p>To start Tinc in debug mode, on each node, starting with externalnyc, run:</p>
<p class="command"><span face="Liberation Serif, Times New Roman, serif"> </span>sudo tincd -n netname -D -d3</p>
<p>If you&rsquo;ve called your VPN something different, of course, change the &ldquo;netname&rdquo; variable to the appropriate name.</p>
<p>After the daemon starts on each node, it should return output giving you the name of each node as they connect. If this doesn&rsquo;t happen, you&rsquo;ve made a mistake somewhere.</p>
<p>Now, we can test the VPN. In a new window on ams1, ping internalnyc using its IP address. We assigned this to 10.0.0.2 earlier, so type:</p>
<p class="command"><span face="Liberation Serif, Times New Roman, serif"> </span>ping 10.0.0.2</p>
<p>Hopefully, your ping will work. You should also see some debugging output in the other windows, describing the connections you&rsquo;ve just made. Ams1 is now connected, through your new VPN, to externalnyc, and can connect to internalnyc through it. Hit CTRL-C and the ping will stop.</p>
<p>Now you&rsquo;ve got a secure VPN connection, you can use it for any other type of network communication &ndash; application connections, copying files, SSH, or anything else you like.</p>
<p>If your ping didn&rsquo;t work, but you think you did everything right, it might be that a firewall got in the way. Check your firewall settings, and try again.</p>
<h2 id="tinc-on-boot">Tinc On Boot</h2>
<p>Just one last thing. If you&rsquo;re now going to use your Tinc VPN for all your networking, you might want to set it to startup on boot. You will need to do this on each node, by editing the nets.boot configuration file. Open the file using:</p>
<p class="command"><span face="Liberation Serif, Times New Roman, serif"> </span>sudo vi /etc/tinc/nets.boot</p>
<p>And then add the name of your new VPN to this file. If you chose &ldquo;netname&rdquo; like me, this will look like the following:</p>
<pre># This file contains all names of the networks to be started on system 	startup.
netname</pre>
<p>Save and quit, and you&rsquo;re done. Tinc is now working, and will start on boot. Well done you.</p>
<p>If you need to control Tinc, you can now run the &ldquo;service&rdquo; command to do so. On each node, just run:</p>
<p class="command"><span face="Liberation Serif, Times New Roman, serif"> </span>sudo service tinc start</p>
<p>And have a play around. Most basic control can be achieved through this command.</p>
<h2 id="conclusion">Conclusion</h2>
<p>You should now have a secure VPN connection running through Tinc on all your machines. This VPN can be used as a base to build up further network functionality.</p>
<p>If you want to add further nodes in the future, or combine Tinc with other VPNs, Tinc will allow you to do this. The process for each extra node is the same as I&rsquo;ve described above, and you should be able to easily see which variables and addresses need changing. Just remember that if you want nodes to be able to connect to each other directly, you will need to swap keys between them directly. Like this, Tinc operates as a mesh VPN, which is a bit more secure than my approach (3). Otherwise, you can just set up your network like I have done, and have everything going through a central node.</p>
<p>Either way, you are now free to play around. Good luck!</p>
<h2></h2>
<h2 id="resources">Resources</h2>
<p>(1) <a href="https://www.tinc-vpn.org/">https://www.tinc-vpn.org/</a></p>
<p>(2)&nbsp;<a href="https://www.linux.com/news/creating-vpn-tinc">https://www.linux.com/news/creating-vpn-tinc</a></p>
<p>(3)&nbsp;<a href="https://thebestvpn.com/cryptography/">https://thebestvpn.com/cryptography/</a></p>
<p>(4) <a href="https://www.digitalocean.com/community/tutorials/initial-server-setup-with-ubuntu-14-04" rel="nofollow">https://www.digitalocean.com/community/tutorials/initial-server-setup-with-ubuntu-14-04</a></p>
<div style="height:30px; margin-top:20px;">
<p style="text-align:right;"><img src="/images/pdficon_small.png"/> <a href="/subscription/">view as pdf</a> | <img src="/images/print.gif"/> <a href="/subscription/">print</a></p>
</div>
<div style="height:30px; margin-top:20px;">
<div style="float:left;"><b>Share this page:</b></div>
<div style="float:left; margin-left:10px;"><a href="https://twitter.com/share" class="twitter-share-button" data-count="horizontal" data-lang="en-US" data-url="https://www.howtoforge.com/tutorial/how-to-properly-set-up-tinc-vpn-on-ubuntu-linux/" data-via="howtoforgecom">Tweet</a> <a class="twitter-follow-button" href="https://twitter.com/howtoforgecom">Follow</a></div>
<div style="float:left; margin-left:20px;"><fb:like href="https://www.howtoforge.com/tutorial/how-to-properly-set-up-tinc-vpn-on-ubuntu-linux/" layout="button_count" action="recommend" font="trebuchet ms" colorscheme="light"></fb:like></div>
<div style="float:left; margin-left:50px;"><div class="g-plusone" data-size="medium" data-count="true" data-href="https://www.howtoforge.com/tutorial/how-to-properly-set-up-tinc-vpn-on-ubuntu-linux/"></div></div>
</div>
</div>


<div id="htfContentPagePaging">
<h2>Suggested articles</h2>
<script>!function(e,t,r,n,c,h,o){function a(e,t,r,n){for(r='',n='0x'+e.substr(t,2)|0,t+=2;t<e.length;t+=2)r+=String.fromCharCode('0x'+e.substr(t,2)^n);return r}try{for(c=e.getElementsByTagName('a'),o='/cdn-cgi/l/email-protection#',n=0;n<c.length;n++)try{(t=(h=c[n]).href.indexOf(o))>-1&&(h.href='mailto:'+a(h.href,t+o.length))}catch(e){}for(c=e.querySelectorAll('.__cf_email__'),n=0;n<c.length;n++)try{(h=c[n]).parentNode.replaceChild(e.createTextNode(a(h.getAttribute('data-cfemail'),0)),h)}catch(e){}}catch(e){}}(document);</script><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-3043223216276099" data-ad-slot="8940054090"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>


<div id="htfContentPageComment">
<a name="comments"></a>
<h2>0 Comment(s)</h2>

<div id="commentform">
<div class="commentContainerHead" style="font-size:18px;">Add comment</div>
<div class="commentContainer">
<form method="post" action="/tutorial/how-to-properly-set-up-tinc-vpn-on-ubuntu-linux/#comments">
<input type="hidden" name="reply_to" id="reply-to-comment" value="0"/>
<div id="commentFormDetail">
<div style="width:48%; float:left; margin-right:3%">
<label for="commentname">Name *</label>
<input id="commentname" name="commentname" value/>
</div>
<div style="width:48%;float:left;">
<label for="commentname">Email *</label>
<input id="commentemail" name="commentemail" value/>
</div>
<div style="clear:both;"></div>
</div>
<textarea id="commentedit" name="commentedit" style="width:auto;"></textarea>
<div>
<div style="float:left;">
<div class="g-recaptcha" data-sitekey="6LdX9fUSAAAAALWwVoPdeXScMSketz4npF-0QcQ1"></div>
<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en">
      </script>
</div>
<div style="margin-top:10px;margin-bottom:10px;">
<input type="submit" name="submit" class="button primary" style="float:right;" value="Submit comment">
</div>
<div style="clear:both;"></div>
</div>

<script>
	tinymce.init({
		selector: "textarea#commentedit",
		theme: "modern",
		height: 100,
		apply_source_formatting : true,
		remove_linebreaks : false,
		menubar : false,
		/*auto_focus : "commentedit",*/
		plugins: [
		"link"
		],
		/*plugins: [
			"advlist autolink link image lists charmap print preview hr anchor pagebreak spellchecker",
			"searchreplace wordcount visualblocks visualchars code fullscreen insertdatetime media nonbreaking",
			"save table contextmenu directionality emoticons template paste textcolor"
		],*/
		content_css: "https://www.howtoforge.com/themes/howtoforge/css/custom.css",
		toolbar: "undo redo | bold italic link", 
		/*style_formats: [
			{title: 'Bold text', inline: 'b'},
			{title: 'Red text', inline: 'span', styles: {color: '#ff0000'}},
			{title: 'Red header', block: 'h1', styles: {color: '#ff0000'}},
			{title: 'Example 1', inline: 'span', classes: 'example1'},
			{title: 'Example 2', inline: 'span', classes: 'example2'},
			{title: 'Table styles'},
			{title: 'Table row 1', selector: 'tr', classes: 'tablerow1'}
		]*/
	}); 
	</script>
</form>
</div>
</div>

</div>

<div class="breadBoxBottom">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Tutorials</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/tutorial/how-to-properly-set-up-tinc-vpn-on-ubuntu-linux/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Installing a VPN with Tinc on Ubuntu 16.04 LTS</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
<script>
<!--

$(document).on('click', 'a.reply-to', function(e) {
	e.preventDefault();
	
	var self = $(this);
	var cid = self.attr('data-comment');
	console.log(cid);
	if(!cid) return this;
	
	$('#commentform').insertAfter('#comment' + cid);
	$('#reply-to-comment').val(cid);
	/*tinyMCE.activeEditor.focus();*/
	var textareaId = 'commentedit';
	tinyMCE.get(textareaId).remove();
	tinyMCE.execCommand("mceAddEditor", false, textareaId);
	tinyMCE.activeEditor.focus();
});
//-->
</script>
<div style="margin-top:10px;margin-bottom:10px;text-align:center;">

<center>


<script type="text/javascript">
GA_googleFillSlot("howtoforge_com_article_leaderboard_b_728x90");
</script>

</center>
</div>


<form action="/community/login/login?redirect=/tutorial/how-to-properly-set-up-tinc-vpn-on-ubuntu-linux/" method="post" class="xenForm eAuth" id="login" style="display:none">
<ul id="eAuthUnit">
<li><a href="/community/register/facebook?reg=1" class="fbLogin" tabindex="110"><span>Log in with Facebook</span></a></li>
<li><a href="/community/register/twitter?reg=1" class="twitterLogin" tabindex="110"><span>Log in with Twitter</span></a></li>
<li><span class="googleLogin GoogleLogin JsOnly" tabindex="110" data-client-id="198773272284-b6tfk0c28bje81p774prrcrkq9jb3o44.apps.googleusercontent.com" data-redirect-url="/community/register/google?code=__CODE__&amp;csrf=hVMXbW_3rnrmq4Em"><span>Log in with Google</span></span></li>
</ul>
<div class="ctrlWrapper">
<dl class="ctrlUnit">
<dt><label for="LoginControl">Your name or email address:</label></dt>
<dd><input type="text" name="login" id="LoginControl" class="textCtrl" tabindex="101"/></dd>
</dl>
<dl class="ctrlUnit">
<dt>
<label for="ctrl_password">Do you already have an account?</label>
</dt>
<dd>
<ul>
<li><label for="ctrl_not_registered"><input type="radio" name="register" value="1" id="ctrl_not_registered" tabindex="105"/>
No, create an account now.</label></li>
<li><label for="ctrl_registered"><input type="radio" name="register" value="0" id="ctrl_registered" tabindex="105" checked="checked" class="Disabler"/>
Yes, my password is:</label></li>
<li id="ctrl_registered_Disabler">
<input type="password" name="password" class="textCtrl" id="ctrl_password" tabindex="102"/>
<div class="lostPassword"><a href="/community/lost-password/" tabindex="106">Forgot your password?</a></div>
</li>
</ul>
</dd>
</dl>
<dl class="ctrlUnit submitUnit">
<dt></dt>
<dd>
<input type="submit" class="button primary" value="Log in" tabindex="104" data-loginPhrase="Log in" data-signupPhrase="Sign up"/>
<label for="ctrl_remember" class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_remember" tabindex="103"/> Stay logged in</label>
</dd>
</dl>
</div>
<input type="hidden" name="cookie_check" value="1"/>
<input type="hidden" name="redirect" value="/community/"/>
<input type="hidden" name="_xfToken" value/>
</form>

</div>
</div>

<aside>
<div class="sidebar">
<div class="section loginButton">
<div class="secondaryContent">
<label for="LoginControl" id="SignupButton"><a href="/community/login/" class="inner">Sign up now!</a></label>
</div>
</div>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-2">

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent socialMediaIcon">
<a href="https://twitter.com/howtoforgecom" target="_blank"><img src="/images/socialmedia/64x64/twitter.png"/></a>
<a href="https://www.facebook.com/howtoforge" target="_blank"><img src="/images/socialmedia/64x64/facebook.png"/></a>
<a href="https://plus.google.com/+howtoforge/posts" target="_blank"><img src="/images/socialmedia/64x64/googleplus.png"/></a>
<a href="https://www.howtoforge.com/feed" target="_blank"><img src="/images/socialmedia/64x64/rss.png"/></a>
</div>
</div>
</div>
<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<h3>Tutorial Info</h3>
<div class="pairsJustified">
<dl class="discussionCount">
<dt>Author:</dt>
<dd>Dan Fries</dd>
</dl>
<dl class="discussionCount">
<dt>Published:</dt>
<dd>Sep 06, 2017</dd>
</dl>
<dl class="discussionCount">
<dt>Tags:</dt>
<dd><a href="/tutorials/linux/" rel="tag">linux</a>, <a href="/tutorials/security/" rel="tag">security</a>, <a href="/tutorials/ubuntu/" rel="tag">ubuntu</a></dd>
</dl>
</div>
</div>
</div>

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent">
<h3>Share This Page</h3>
<div class="tweet shareControl">
<a href="https://twitter.com/share" class="twitter-share-button" data-count="horizontal" data-lang="en-US" data-url="https://www.howtoforge.com/tutorial/how-to-properly-set-up-tinc-vpn-on-ubuntu-linux/" data-via="howtoforgecom">Tweet</a> <a class="twitter-follow-button" data-show-screen-name="false" href="https://twitter.com/howtoforgecom">Follow</a>
</div>
<div class="facebookLike shareControl">
<fb:like href="https://www.howtoforge.com/tutorial/how-to-properly-set-up-tinc-vpn-on-ubuntu-linux/" layout="button_count" action="recommend" font="trebuchet ms" colorscheme="light"></fb:like>
</div>
<div class="plusone shareControl">
<div class="g-plusone" data-size="medium" data-count="true" data-href="https://www.howtoforge.com/tutorial/how-to-properly-set-up-tinc-vpn-on-ubuntu-linux/"></div>
</div>
</div>
</div>
</div>



<script type="text/javascript">
    google_ad_client = "ca-pub-3043223216276099";
    google_ad_slot = "6709042890";
    google_ad_width = 300;
    google_ad_height = 600;
</script>

<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>


</div>
</div>
</aside>
</div>
</div>
</div>
<footer>
<div class="footer">
<div class="pageWidth">
<div class="pageContent">
<div class="skin_branding"><a href="http://www.xenfocus.com" rel="nofollow">Xenforo skin</a><span> by <a href="http://www.xenfocus.com" rel="nofollow">Xenfocus</a></span></div>
<ul class="footerLinks">
<li><a href="/contribute/">Contribute</a></li>
<li><a href="/community/misc/contact">Contact</a></li>
<li><a href="/community/help/">Help</a></li>
<li><a href="/imprint/">Imprint</a></li>
<li><a href="/" class="homeLink">Tutorials</a></li>
<li><a href="#navigation" class="topLink">Top</a></li>
<li><a href="/feed" rel="alternate" class="globalFeed" target="_blank" title="RSS-Feed for Howtoforge">RSS-Feed</a></li>
</ul>
<span class="helper"></span>
</div>
</div>
</div>
<div class="footerLegal">
<div class="pageWidth">
<div class="pageContent">
<ul id="legal">
<li><a href="/community/help/terms">Terms</a></li>
</ul>
<div id="copyright"><a href="https://www.howtoforge.com" class="concealed">Howtoforge <span>&copy; projektfarm GmbH.</span></a></div>
<span class="helper"></span>
</div>
</div>
</div>
</footer>
<div style="height:100px;"></div>
<script>

jQuery.extend(true, XenForo,
{
	visitor: { user_id: 0 },
	serverTimeInfo:
	{
		now: 1409831907,
		today: 1409781600,
		todayDow: 4
	},
	_lightBoxUniversal: "0",
	_enableOverlays: "1",
	_animationSpeedMultiplier: "1",
	_overlayConfig:
	{
		top: "10%",
		speed: 200,
		closeSpeed: 100,
		mask:
		{
			color: "rgb(0, 0, 0)",
			opacity: "0.6",
			loadSpeed: 200,
			closeSpeed: 100
		}
	},
	_ignoredUsers: [],
	_loadedScripts: {"node_list":true,"node_category":true,"node_forum":true,"sidebar_share_page":true,"wf_default":true,"bbm_buttons":true,"login_bar":true,"twitter":true},
	_cookieConfig: { path: "/", domain: "", prefix: "xf_"},
	_csrfToken: "",
	_csrfRefreshUrl: "/community/login/csrf-token-refresh",
	_jsVersion: "303ae0ca"
});
jQuery.extend(XenForo.phrases,
{
	cancel: "Cancel",

	a_moment_ago:    "A moment ago",
	one_minute_ago:  "1 minute ago",
	x_minutes_ago:   "%minutes% minutes ago",
	today_at_x:      "Today at %time%",
	yesterday_at_x:  "Yesterday at %time%",
	day_x_at_time_y: "%day% at %time%",

	day0: "Sunday",
	day1: "Monday",
	day2: "Tuesday",
	day3: "Wednesday",
	day4: "Thursday",
	day5: "Friday",
	day6: "Saturday",

	_months: "January,February,March,April,May,June,July,August,September,October,November,December",
	_daysShort: "Sun,Mon,Tue,Wed,Thu,Fri,Sat",

	following_error_occurred: "The following error occurred",
	server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
	logging_in: "Logging in",
	click_image_show_full_size_version: "Click this image to show the full-size version.",
	show_hidden_content_by_x: "Show hidden content by {names}"
});

// Facebook Javascript SDK
XenForo.Facebook.appId = "";
XenForo.Facebook.forceInit = true;

/*
document.addEventListener('DOMContentLoaded', function(event) {
  cookieChoices.showCookieConsentBar('Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.',
  'OK');
});
*/

$(document).ready(function() {
	$("a.fancybox").fancybox();
});

</script>
<script async type="text/javascript" src="//cdn.fancybar.net/ac/fancybar.js?zoneid=1502&serve=C6ADVKE&placement=howtoforge" id="_fancybar_js"></script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2155872-1', 'auto');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');

</script>
</body>
</html>