<!DOCTYPE html>
<html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs LoggedOut Sidebar Responsive" xmlns:fb="http://www.facebook.com/2008/fbml">
<head>
<meta charset="utf-8"/>
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1"/>
<meta name="viewport" content="width=device-width, initial-scale=1">
<base href="https://www.howtoforge.com"/>
<script>
			var _b = document.getElementsByTagName('base')[0], _bH = "https://www.howtoforge.com/tutorial/how-to-perform-directory-comparison-using-meld/";
			if (_b && _b.href != _bH) _b.href = _bH;
		</script>
<title>How to perform directory comparison using Meld</title>
<meta name="keywords" content="desktop,linux,programming"/>
<meta name="description" content="In the beginner's tutorial, we mentioned that Meld can be used to compare both files as well as directories. Now that we've already covered file compa... "/>
<meta name="og:title" content="How to perform directory comparison using Meld">
<meta name="og:description" content="In the beginner's tutorial, we mentioned that Meld can be used to compare both files as well as directories. Now that we've already covered file compa... ">
<meta name="og:site_name" content="Howtoforge">
<meta name="og:type" content="article">
<meta property="og:image" content="https://www.howtoforge.com/images/teaser/linux.gif">
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="howtoforgecom">
<meta name="twitter:creator" content="howtoforgecom">
<meta name="twitter:title" content="How to perform directory comparison using Meld">
<meta name="twitter:description" content="In the beginner's tutorial, we mentioned that Meld can be used to compare both files as well as directories. Now that we've already covered file compa... ">
<link rel="alternate" href="https://www.howtoforge.com/tutorial/how-to-perform-directory-comparison-using-meld/" hreflang="en"/>
<link rel="canonical" href="https://www.howtoforge.com/tutorial/how-to-perform-directory-comparison-using-meld/"/>
<noscript><style>.JsOnly,.jsOnly{display:none!important;}</style></noscript>
<link rel="stylesheet" href="/community/styles/executive/xenfocus/icons/css/font-awesome.min.css"/>
<link href='//fonts.googleapis.com/css?family=Open+Sans:400,700' rel='stylesheet' type='text/css'/>
 
<link rel="stylesheet" href="/community/css.php?css=xenforo,form,public&amp;style=3&amp;dir=LTR&amp;d=1420029973"/>
<link rel="stylesheet" href="/community/css.php?css=bb_code,bbm_buttons,facebook,google,login_bar,node_category,node_forum,node_list,profile_post_list_simple,sidebar_share_page,twitter,wf_default&amp;style=3&amp;dir=LTR&amp;d=1420029973"/>
<script src="//ajax.googleapis.com/ajax/libs/jquery/1.11.3/jquery.min.js"></script>
<script>if (!window.jQuery) { document.write('<scr'+'ipt type="text/javascript" src="/js/jquery/jquery-1.11.3.min.js"><\/scr'+'ipt>'); }</script>
<script src="/community/js/xenforo/xenforo.js?_v=303ae0ca"></script>
<script src="/community/js/bbm/zloader.js?_v=303ae0ca"></script>
<link href="//netdna.bootstrapcdn.com/font-awesome/4.0.3/css/font-awesome.css" rel="stylesheet">
<script type="text/javascript" src="/js/fancybox/jquery.mousewheel-3.0.4.pack.js"></script>
<script type="text/javascript" src="/js/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
<link rel="stylesheet" type="text/css" href="/js/fancybox/jquery.fancybox-1.3.4.css" media="screen"/>
<link href="/themes/howtoforge/templates/style.css" rel="stylesheet">
<link rel="alternate" type="application/rss+xml" title="RSS-Feed für Howtoforge" href="/feed.rss"/>
<script src="/js/tinymce_4.1.7/tinymce.min.js"></script>
<script type='text/javascript' src='https://partner.googleadservices.com/gampad/google_service.js'>
</script>
<script type='text/javascript'>
GS_googleAddAdSenseService("ca-pub-3043223216276099");
GS_googleEnableAllServices();
</script>
<script language="JavaScript">
GA_googleAddAttr("Category", "Desktop");
GA_googleAddAttr("Category", "Linux");
GA_googleAddAttr("Category", "Programming");
</script>
<script type='text/javascript'>
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_leaderboard_a_728x90");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_rectangle_a_300x250");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_rectangle_b_300x250");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_halfpage_a_300x600");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_leaderboard_b_728x90");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_halfpage_b_300x600");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_a_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_b_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_c_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_d_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_list_sidebar_top");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_list_content_middle");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_list_bottom");
</script>
<script type='text/javascript'>
GA_googleFetchAds();
</script>
 
<script type="text/javascript">
    window.cookieconsent_options = {"message":"This website uses cookies to ensure you get the best experience on our website","dismiss":"Got it!","learnMore":"More info","link":"https://www.howtoforge.com/community/help/cookies","theme":"dark-bottom"};
</script>
<script type="text/javascript" src="/js/cookieconsent.latest.min.js"></script>
 
</head>
<body>
<div id="loginBar">
<div class="pageWidth">
<div class="pageContent">
<h3 id="loginBarHandle">
<label for="LoginControl"><a href="/community/login/" class="concealed noOutline">Log in or Sign up</a></label>
</h3>
<span class="helper"></span>
</div>
</div>
</div>
<header>
<div id="header">
<div id="logoBlock">
<div class="pageWidth">
<div class="pageContent">
<div id="logo"><a href="/">
<span></span>
<img src="/images/howtoforge_logo_trans.gif" alt="Howtoforge" style="margin-left:20px;"/>
</a></div>
<span class="helper"></span>
<div class="langSwitch">
<b><img src="/images/gb.png" alt="HowtoForge - Linux Tutorials in English"/> English</b> | <a href="https://www.howtoforge.de/" title="HowtoForge.de - Linux Tutorials auf Deutsch"><img src="/images/de.png" alt="HowtoForge.de - Linux Tutorials auf Deutsch"/> Deutsch</a>
</div>
</div>
</div>
</div>
<div id="navigation" class="pageWidth withSearch">
<div class="pageContent">
<nav>
<div class="navTabs">
<ul class="publicTabs">
 
<li class="navTab forums selected">
<a href="/" class="navLink">Tutorials</a>
<div class="tabLinks forumsTabLinks">
<ul class="secondaryContent blockLinksList">
<li><a href="/search/">Tutorial search</a></li>
</ul>
</div>
</li>
<li class="navTab forums PopupClosed">
<a href="/tutorials/" class="navLink">Tags</a>
</li>
<li class="navTab forums PopupClosed"><a href="/community/" class="navLink">Forums</a></li>
<li class="navTab forums PopupClosed"><a href="/contribute/" class="navLink">Contribute</a></li>
<li class="navTab forums PopupClosed"><a href="/subscription/" class="navLink">Subscribe</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.ispconfig.org" class="navLink">ISPConfig</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.lxer.com" class="navLink">News</a></li>
</ul>
</div>
<span class="helper"></span>
</nav>
</div>
</div>
<div id="searchBar" class="pageWidth">
<span id="QuickSearchPlaceholder" title=" Search..."> Search</span>
<fieldset id="QuickSearch">
<form action="/" method="post" class="formPopup">
<div class="primaryControls">
 
<input type="search" name="q" value="" class="textCtrl" placeholder="Search..." results="0" title="Enter your search and hit enter..." id="QuickSearchQuery"/>
 
</div>
<input type="hidden" name="_xfToken" value=""/>
</form>
</fieldset>
</div>
</div>
</header>
<div id="content" class="forum_list">
<div class="pageWidth">
<div class="pageContent">
 
<div class="mainContainer">
<div class="mainContent">
 
<div class="breadBoxTop">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Tutorials</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/tutorial/how-to-perform-directory-comparison-using-meld/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to perform directory comparison using Meld</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
 
<div id="htfContentPage">
<h1>How to perform directory comparison using Meld</h1>
<div class="bsa-apiads"><a href="//srv.buysellads.com/ads/click/x/GTND423YCWBIC277CWB4YKQWFTBIPKQEC67IKZ3JCEADP23WCTBIEK7KC6BDE2QMCYBI6K3EHJNCLSIZ" target="_blank" rel="nofollow">Continuous integration and delivery behind your firewall.</a><img src="https://www.launchbit.com/taz-pixel/11341-6761-111"/></div>
<div class="contributeEdit" style="float:right; width:450px; max-width:100%;">
 
<div id="tocContainer">
<h3>On this page</h3>
<ol class="toc">
<li><a href="#compare-directories-using-meld">Compare directories using Meld</a></li>
<li><a href="#conclusion">Conclusion</a></li>
</ol>
</div>
</div>
<p>We've <a href="https://www.howtoforge.com/tutorial/beginners-guide-to-visual-merge-tool-meld-on-linux/">already covered</a>&nbsp;Meld from a beginner's point of view (including the tool's installation part), and we've also covered some tips/tricks that are primarily aimed at intermediate Meld users. If you remember, in the beginner's tutorial, we mentioned that Meld can be used to compare both files as well as directories. Now that we've already covered file comparison, it's time to discuss the tool's directory comparison feature.</p>
<p class="system"><em>But before we do that&nbsp;it'd be worth sharing that all the instructions and examples presented in this tutorial have been tested on Ubuntu 14.04 and the Meld version we've used is 3.14.2.</em></p>
<p></p>
<h2 id="compare-directories-using-meld">Compare directories using Meld</h2>
<p>To compare two directories using Meld, launch the tool and select the <em>Directory comparison</em> option.</p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;"> 
 
<script type='text/javascript'>
GA_googleFillSlot('howtoforge_com_article_rectangle_a_300x250');
</script>
 </div>
<p style="text-align: center;"><a class="fancybox" id="img-meld-dir-comp-1" href="https://www.howtoforge.com/images/beginners-guide-to-visual-merge-tool-meld-on-linux-part-3/big/meld-dir-comp-1.png"><img src="https://www.howtoforge.com/images/beginners-guide-to-visual-merge-tool-meld-on-linux-part-3/meld-dir-comp-1.png" alt="Compare directories using Meld" width="500" height="253"/></a></p>
<p>Then select the directories that you want to compare:</p>
<p style="text-align: center;"><a class="fancybox" id="img-meld-sel-dir-2" href="https://www.howtoforge.com/images/beginners-guide-to-visual-merge-tool-meld-on-linux-part-3/big/meld-sel-dir-2.png"><img src="https://www.howtoforge.com/images/beginners-guide-to-visual-merge-tool-meld-on-linux-part-3/meld-sel-dir-2.png" alt="select the directories" width="500" height="252"/></a></p>
<p>Once that is done, click the <em>Compare</em> button, and you'll see that Meld will compare both directories side by side, like the tool does in case of files:</p>
<p style="text-align: center;"><a class="fancybox" id="img-meld-dircomp-begins-3" href="https://www.howtoforge.com/images/beginners-guide-to-visual-merge-tool-meld-on-linux-part-3/big/meld-dircomp-begins-3.png"><img src="https://www.howtoforge.com/images/beginners-guide-to-visual-merge-tool-meld-on-linux-part-3/meld-dircomp-begins-3.png" alt="Compare directories visually" width="500" height="268"/></a></p>
<p>Of course, these being directories, they are displayed<span>&nbsp;as side-by-side trees. And as you can see in the screenshot above, the differences - whether it's a new file or a changed file - &nbsp;are highlighted in different colors. </span></p>
<p>According to Meld's official documentation, each file or folder that you see in the comparison area of the window has a state of its own. A state basically reveals how a particular&nbsp;file/folder is different from the corresponding entry in the other directory.</p>
<p>The following table - taken from the tool's website - explains in details the folder comparison states in Meld.</p>
<div class="table">
<table class="table">
<thead>
<tr>
<td>
<p class="p first-child"><strong>State</strong></p>
</td>
<td>
<p class="p first-child"><strong>Appearance</strong></p>
</td>
<td>
<p class="p first-child"><strong>Meaning</strong></p>
</td>
</tr>
</thead>
<tbody>
<tr>
<td>
<p class="p first-child">Same</p>
</td>
<td>
<p class="p first-child">Normal font</p>
</td>
<td>
<p class="p first-child">The file/folder is the same across all compared folders.</p>
</td>
</tr>
<tr>
<td>
<p class="p first-child">Same when filtered</p>
</td>
<td>
<p class="p first-child">Italics</p>
</td>
<td>
<p class="p first-child">These files are different across folders, but once text filters&nbsp;are applied, these files become identical.</p>
</td>
</tr>
<tr>
<td>
<p class="p first-child">Modified</p>
</td>
<td>
<p class="p first-child">Blue and bold</p>
</td>
<td>
<p class="p first-child">These files differ between the folders being compared.</p>
</td>
</tr>
<tr>
<td>
<p class="p first-child">New</p>
</td>
<td>
<p class="p first-child">Green and bold</p>
</td>
<td>
<p class="p first-child">This file/folder exists in this folder, but not in the others.</p>
</td>
</tr>
<tr>
<td>
<p class="p first-child">Missing</p>
</td>
<td>
<p class="p first-child">Greyed out text with a line through the middle</p>
</td>
<td>
<p class="p first-child">This file/folder doesn't exist in this folder, but does in one of the others.</p>
</td>
</tr>
<tr>
<td>
<p class="p first-child">Error</p>
</td>
<td>
<p class="p first-child">Bright red with a yellow background and bold</p>
</td>
<td>
<p class="p first-child">When comparing this file, an error occurred. The most common error causes are file permissions (i.e., <span class=" app" xmlns:e="http://projectmallard.org/experimental/">Meld</span> was not allowed to open the file) and filename encoding errors.</p>
</td>
</tr>
</tbody>
</table>
</div>
<p>By default, Meld shows all the contents of the folders being compared, even if they are same (meaning there's no difference between them). However, you can ask the tool to not display these files/directories by clicking the <em>Same</em> button in the toolbar - the click should&nbsp;disable this button.</p>
<p style="text-align: center;"><span><a class="fancybox" id="img-meld-same-button" href="https://www.howtoforge.com/images/beginners-guide-to-visual-merge-tool-meld-on-linux-part-3/big/meld-same-button.png"><img src="https://www.howtoforge.com/images/beginners-guide-to-visual-merge-tool-meld-on-linux-part-3/meld-same-button.png" alt="same button" width="254" height="45"/></a></span></p>
<p style="text-align: center;"></p>
<p style="text-align: center;"><a class="fancybox" id="img-meld-same-disabled" href="https://www.howtoforge.com/images/beginners-guide-to-visual-merge-tool-meld-on-linux-part-3/big/meld-same-disabled.png"><img src="https://www.howtoforge.com/images/beginners-guide-to-visual-merge-tool-meld-on-linux-part-3/meld-same-disabled.png" alt="Meld compare buttons" width="243" height="37"/></a></p>
<p>For example, here's our directory comparison when I clicked and disabled the <em>Same</em> button:</p>
<p style="text-align: center;"><a class="fancybox" id="img-meld-only-diff" href="https://www.howtoforge.com/images/beginners-guide-to-visual-merge-tool-meld-on-linux-part-3/big/meld-only-diff.png"><img src="https://www.howtoforge.com/images/beginners-guide-to-visual-merge-tool-meld-on-linux-part-3/meld-only-diff.png" alt="Directory Comparison without same files" width="500" height="269"/></a></p>
<p></p>
<p>So you can see that only the differences between the two directories (new and modified files) are shown now. Similarly, if you disable the <em>New</em> button, only the modified files will be displayed. So basically, you can use these buttons to customize what kind of changes are displayed by Meld while comparing two directories.</p>
<p>Coming to the changes, you can hop from one change to another using the up and down arrow keys that sit above the display area in the tool's window, and to open two files for side-by-side comparison, you can either double click the name of any of the files, or click the <em>Compare</em> button that sits beside the arrows.</p>
<p><a class="fancybox" id="img-meld-compare-arrows" href="https://www.howtoforge.com/images/beginners-guide-to-visual-merge-tool-meld-on-linux-part-3/big/meld-compare-arrows.png"><img src="https://www.howtoforge.com/images/beginners-guide-to-visual-merge-tool-meld-on-linux-part-3/meld-compare-arrows.png" alt="meld compare arrow keys" width="167" height="36" style="display: block; margin-left: auto; margin-right: auto;"/></a></p>
<p><span><strong>Note 1</strong>: If you observe closely, there are bars on the left and right-hand sides of the display area in Meld window. These bars basically provide "a simple coloured summary of the comparison results." For each differing file or folder, there's a small colored section in these bars. You can click any such section to directly jump&nbsp;<span>to that place in the comparison area.</span></span></p>
<p><span><span><strong>Note 2</strong>: While you can always open files side by side and merge changes the way you want, in case you want all the changes to be merged to the corresponding file/folder (meaning you want to make the corresponding file/folder exactly same) then you can use the <em>Copy Left</em> and <em>Copy Right</em> buttons:</span></span></p>
<p style="text-align: center;"><a class="fancybox" id="img-meld-copy-right-left" href="https://www.howtoforge.com/images/beginners-guide-to-visual-merge-tool-meld-on-linux-part-3/big/meld-copy-right-left.png"><img src="https://www.howtoforge.com/images/beginners-guide-to-visual-merge-tool-meld-on-linux-part-3/meld-copy-right-left.png" alt="meld copy right part" width="214" height="34"/></a></p>
<p><span><span>For example, select a file or folder in the left pane and click the <em>Copy Right</em> button to make the corresponding entry in the right pane exactly same.</span></span></p>
<p>Moving on, there's a <em>Filters</em> drop-down menu that sits just next to the <em>Same</em>, <em>New</em>, and <em>Modified</em> trio of buttons. Here you can select/deselect file types to tell Meld whether or not to show&nbsp;these kind of files/folders in the display area during a directory comparison. The official documentation explains the entries in this menu as "<span>patterns of filenames that will </span><span class=" em" xmlns:e="http://projectmallard.org/experimental/">not</span><span> be looked at when performing a folder comparison."</span></p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;"> 
 
<script type='text/javascript'>
GA_googleFillSlot('howtoforge_com_article_rectangle_b_300x250');
</script>
 </div>
<p>The entries in the list include backups, OS-specific metadata, version control, binaries, and media.</p>
<p><a class="fancybox" id="img-meld-filters" href="https://www.howtoforge.com/images/beginners-guide-to-visual-merge-tool-meld-on-linux-part-3/big/meld-filters.png"><img src="https://www.howtoforge.com/images/beginners-guide-to-visual-merge-tool-meld-on-linux-part-3/meld-filters.png" alt="Meld filters" width="201" height="168" style="display: block; margin-left: auto; margin-right: auto;"/></a></p>
<p></p>
<p>The aforementioned menu is also accessible by heading to <em>View-&gt;File Filters</em>. You can add new elements to this menu (as well as remove existing ones if you want) by going to <em>Edit-&gt;Preferences-&gt;File Filters</em>.</p>
<p style="text-align: center;"><a class="fancybox" id="img-meld-edit-filters-menu" href="https://www.howtoforge.com/images/beginners-guide-to-visual-merge-tool-meld-on-linux-part-3/big/meld-edit-filters-menu.png"><img src="https://www.howtoforge.com/images/beginners-guide-to-visual-merge-tool-meld-on-linux-part-3/meld-edit-filters-menu.png" alt="Meld preferences" width="500" height="503"/></a></p>
<p>To create a new filter, you need to use&nbsp;<span>shell glob patterns. Following is the list of&nbsp;<span>shell glob characters that </span><span class=" app" xmlns:e="http://projectmallard.org/experimental/">Meld</span><span> recognises:</span></span></p>
<div class="table">
<table class="table" style="margin-left: auto; margin-right: auto;">
<thead>
<tr>
<td>
<p class="p first-child"><strong>Wildcard</strong></p>
</td>
<td>
<p class="p first-child"><strong>Matches</strong></p>
</td>
</tr>
</thead>
<tbody>
<tr>
<td>
<p class="p first-child"><span class=" code" xmlns:e="http://projectmallard.org/experimental/">*</span></p>
</td>
<td>
<p class="p first-child">anything (i.e., zero or more characters)</p>
</td>
</tr>
<tr>
<td>
<p class="p first-child"><span class=" code" xmlns:e="http://projectmallard.org/experimental/">?</span></p>
</td>
<td>
<p class="p first-child">exactly one character</p>
</td>
</tr>
<tr>
<td>
<p class="p first-child"><span class=" code" xmlns:e="http://projectmallard.org/experimental/">[abc]</span></p>
</td>
<td>
<p class="p first-child">any one of the listed characters</p>
</td>
</tr>
<tr>
<td>
<p class="p first-child"><span class=" code" xmlns:e="http://projectmallard.org/experimental/">[!abc]</span></p>
</td>
<td>
<p class="p first-child">anything <span class=" em" xmlns:e="http://projectmallard.org/experimental/">except</span> one of the listed characters</p>
</td>
</tr>
<tr>
<td>
<p class="p first-child"><span class=" code" xmlns:e="http://projectmallard.org/experimental/">{cat,dog}</span></p>
</td>
<td>
<p class="p first-child">either "cat" or "dog"</p>
</td>
</tr>
</tbody>
</table>
</div>
<div class="note note-tip">
<div class="note-inner">
<div class="note-contents"></div>
</div>
</div>
<p>Finally, an important point worth knowing about Meld is that the case of a file's name plays an important part as<span>&nbsp;comparison is case sensitive by default. This means that, for example, the files </span><span class=" file" xmlns:e="http://projectmallard.org/experimental/">README</span><span>, </span><span class=" file" xmlns:e="http://projectmallard.org/experimental/">readme</span><span> and </span><span class=" file" xmlns:e="http://projectmallard.org/experimental/">ReadMe</span><span> would all be treated by the tool as different files.</span></p>
<p><span>Thankfully, however, Meld also provides you a way to turn off this feature. All you have to do is to head to the <em>View</em> menu and then select the&nbsp;<em>Ignore Filename Case</em> option.</span></p>
<p style="text-align: center;"><a class="fancybox" id="img-meld-ignore-case" href="https://www.howtoforge.com/images/beginners-guide-to-visual-merge-tool-meld-on-linux-part-3/big/meld-ignore-case.png"><img src="https://www.howtoforge.com/images/beginners-guide-to-visual-merge-tool-meld-on-linux-part-3/meld-ignore-case.png" alt="Meld ignore filename case" width="437" height="242"/></a></p>
<h2 id="conclusion">Conclusion</h2>
<p>As you'd agree, directory comparison using Meld isn't difficult - in fact I'd say it's pretty easy. The only&nbsp;area that might require time to learn is creating file filters, but that's not to say you should never learn it. Obviously, it all depends on what your requirement is.&nbsp;</p>
<p>Oh, and yes, you can even compare three directories using Meld, a feature that you can access by <em>clicking the 3-way comparison</em> box when you choose the directories that you want to compare. We didn't discuss the feature in this article, but definitely will in one of our future articles.</p>
<div style="height:30px; margin-top:20px;">
<p style="text-align:right;"><img src="/images/pdficon_small.png"/> <a href="/subscription/">view as pdf</a> | <img src="/images/print.gif"/> <a href="/subscription/">print</a></p>
</div>
<div style="height:30px; margin-top:20px;">
<div style="float:left;"><b>Share this page:</b></div>
<div style="float:left; margin-left:10px;"><a href="https://twitter.com/share" class="twitter-share-button" data-count="horizontal" data-lang="en-US" data-url="https://www.howtoforge.com/tutorial/how-to-perform-directory-comparison-using-meld/" data-via="howtoforgecom">Tweet</a> <a class="twitter-follow-button" href="https://twitter.com/howtoforgecom">Follow</a></div>
<div style="float:left; margin-left:20px;"><fb:like href="https://www.howtoforge.com/tutorial/how-to-perform-directory-comparison-using-meld/" layout="button_count" action="recommend" font="trebuchet ms" colorscheme="light"></fb:like></div>
<div style="float:left; margin-left:50px;"><div class="g-plusone" data-size="medium" data-count="true" data-href="https://www.howtoforge.com/tutorial/how-to-perform-directory-comparison-using-meld/"></div></div>
</div>
</div>
 
 
<div id="htfContentPageComment">
<a name="comments"></a>
<h2>0 Comment(s)</h2>
 
<div id="commentform">
<div class="commentContainerHead" style="font-size:18px;">Add comment</div>
<div class="commentContainer">
<form method="post" action="/tutorial/how-to-perform-directory-comparison-using-meld/#comments">
<input type="hidden" name="reply_to" id="reply-to-comment" value="0"/>
<div id="commentFormDetail">
<div style="width:48%; float:left; margin-right:3%">
<label for="commentname">Name *</label>
<input id="commentname" name="commentname" value=""/>
</div>
<div style="width:48%;float:left;">
<label for="commentname">Email *</label>
<input id="commentemail" name="commentemail" value=""/>
</div>
<div style="clear:both;"></div>
</div>
<textarea id="commentedit" name="commentedit" style="width:auto;"></textarea>
<div>
<div style="float:left;">
<div class="g-recaptcha" data-sitekey="6LdX9fUSAAAAALWwVoPdeXScMSketz4npF-0QcQ1"></div>
<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en">
      </script>
</div>
<div style="margin-top:10px;margin-bottom:10px;">
<input type="submit" name="submit" class="button primary" style="float:right;" value="Submit comment">
</div>
<div style="clear:both;"></div>
</div>
 
<script>
	tinymce.init({
		selector: "textarea#commentedit",
		theme: "modern",
		height: 100,
		apply_source_formatting : true,
		remove_linebreaks : false,
		menubar : false,
		/*auto_focus : "commentedit",*/
		plugins: [
		"link"
		],
		/*plugins: [
			"advlist autolink link image lists charmap print preview hr anchor pagebreak spellchecker",
			"searchreplace wordcount visualblocks visualchars code fullscreen insertdatetime media nonbreaking",
			"save table contextmenu directionality emoticons template paste textcolor"
		],*/
		content_css: "https://www.howtoforge.com/themes/howtoforge/css/custom.css",
		toolbar: "undo redo | bold italic link", 
		/*style_formats: [
			{title: 'Bold text', inline: 'b'},
			{title: 'Red text', inline: 'span', styles: {color: '#ff0000'}},
			{title: 'Red header', block: 'h1', styles: {color: '#ff0000'}},
			{title: 'Example 1', inline: 'span', classes: 'example1'},
			{title: 'Example 2', inline: 'span', classes: 'example2'},
			{title: 'Table styles'},
			{title: 'Table row 1', selector: 'tr', classes: 'tablerow1'}
		]*/
	}); 
	</script>
</form>
</div>
</div>
 
</div>
 
<div class="breadBoxBottom">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Tutorials</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/tutorial/how-to-perform-directory-comparison-using-meld/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to perform directory comparison using Meld</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
<script>
<!--

$(document).on('click', 'a.reply-to', function(e) {
	e.preventDefault();
	
	var self = $(this);
	var cid = self.attr('data-comment');
	console.log(cid);
	if(!cid) return this;
	
	$('#commentform').insertAfter('#comment' + cid);
	$('#reply-to-comment').val(cid);
	/*tinyMCE.activeEditor.focus();*/
	var textareaId = 'commentedit';
	tinyMCE.get(textareaId).remove();
	tinyMCE.execCommand("mceAddEditor", false, textareaId);
	tinyMCE.activeEditor.focus();
});
//-->
</script>
<div style="margin-top:10px;margin-bottom:10px;text-align:center;">
 
<center>
 
 
<script type='text/javascript'>
GA_googleFillSlot("howtoforge_com_article_leaderboard_b_728x90");
</script>
 
</center>
 </div>
 
 
<form action="/community/login/login?redirect=/tutorial/how-to-perform-directory-comparison-using-meld/" method="post" class="xenForm eAuth" id="login" style="display:none">
<ul id="eAuthUnit">
<li><a href="/community/register/facebook?reg=1" class="fbLogin" tabindex="110"><span>Log in with Facebook</span></a></li>
<li><a href="/community/register/twitter?reg=1" class="twitterLogin" tabindex="110"><span>Log in with Twitter</span></a></li>
<li><span class="googleLogin GoogleLogin JsOnly" tabindex="110" data-client-id="198773272284-b6tfk0c28bje81p774prrcrkq9jb3o44.apps.googleusercontent.com" data-redirect-url="/community/register/google?code=__CODE__&amp;csrf=hVMXbW_3rnrmq4Em"><span>Log in with Google</span></span></li>
</ul>
<div class="ctrlWrapper">
<dl class="ctrlUnit">
<dt><label for="LoginControl">Your name or email address:</label></dt>
<dd><input type="text" name="login" id="LoginControl" class="textCtrl" tabindex="101"/></dd>
</dl>
<dl class="ctrlUnit">
<dt>
<label for="ctrl_password">Do you already have an account?</label>
</dt>
<dd>
<ul>
<li><label for="ctrl_not_registered"><input type="radio" name="register" value="1" id="ctrl_not_registered" tabindex="105"/>
No, create an account now.</label></li>
<li><label for="ctrl_registered"><input type="radio" name="register" value="0" id="ctrl_registered" tabindex="105" checked="checked" class="Disabler"/>
Yes, my password is:</label></li>
<li id="ctrl_registered_Disabler">
<input type="password" name="password" class="textCtrl" id="ctrl_password" tabindex="102"/>
<div class="lostPassword"><a href="/community/lost-password/" tabindex="106">Forgot your password?</a></div>
</li>
</ul>
</dd>
</dl>
<dl class="ctrlUnit submitUnit">
<dt></dt>
<dd>
<input type="submit" class="button primary" value="Log in" tabindex="104" data-loginPhrase="Log in" data-signupPhrase="Sign up"/>
<label for="ctrl_remember" class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_remember" tabindex="103"/> Stay logged in</label>
</dd>
</dl>
</div>
<input type="hidden" name="cookie_check" value="1"/>
<input type="hidden" name="redirect" value="/community/"/>
<input type="hidden" name="_xfToken" value=""/>
</form>
 
</div>
</div>
 
<aside>
<div class="sidebar">
<div class="section loginButton">
<div class="secondaryContent">
<label for="LoginControl" id="SignupButton"><a href="/community/login/" class="inner">Sign up now!</a></label>
</div>
</div>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-2">
 
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent socialMediaIcon">
<a href="https://twitter.com/howtoforgecom" target="_blank"><img src="/images/socialmedia/64x64/twitter.png"/></a>
<a href="https://www.facebook.com/howtoforge" target="_blank"><img src="/images/socialmedia/64x64/facebook.png"/></a>
<a href="https://plus.google.com/+howtoforge/posts" target="_blank"><img src="/images/socialmedia/64x64/googleplus.png"/></a>
<a href="https://www.howtoforge.com/feed" target="_blank"><img src="/images/socialmedia/64x64/rss.png"/></a>
</div>
</div>
</div>
<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<h3>Tutorial Info</h3>
<div class="pairsJustified">
<dl class="discussionCount">
<dt>Author:</dt>
<dd>Ansh</dd>
</dl>
<dl class="discussionCount">
<dt>Published:</dt>
<dd>Jan 27, 2017</dd>
</dl>
<dl class="discussionCount">
<dt>Tags:</dt>
<dd><a href='/tutorials/desktop/' rel='tag'>desktop</a>, <a href='/tutorials/linux/' rel='tag'>linux</a>, <a href='/tutorials/programming/' rel='tag'>programming</a></dd>
</dl>
</div>
</div>
</div>
 
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent">
<h3>Share This Page</h3>
<div class="tweet shareControl">
<a href="https://twitter.com/share" class="twitter-share-button" data-count="horizontal" data-lang="en-US" data-url="https://www.howtoforge.com/tutorial/how-to-perform-directory-comparison-using-meld/" data-via="howtoforgecom">Tweet</a> <a class="twitter-follow-button" data-show-screen-name="false" href="https://twitter.com/howtoforgecom">Follow</a>
</div>
<div class="facebookLike shareControl">
<fb:like href="https://www.howtoforge.com/tutorial/how-to-perform-directory-comparison-using-meld/" layout="button_count" action="recommend" font="trebuchet ms" colorscheme="light"></fb:like>
</div>
<div class="plusone shareControl">
<div class="g-plusone" data-size="medium" data-count="true" data-href="https://www.howtoforge.com/tutorial/how-to-perform-directory-comparison-using-meld/"></div>
</div>
</div>
</div>
</div>
 
 
 
<script type="text/javascript">
    google_ad_client = "ca-pub-3043223216276099";
    google_ad_slot = "6709042890";
    google_ad_width = 300;
    google_ad_height = 600;
</script>
 
<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
 
 
</div>
</div>
</aside>
</div>
</div>
</div>
<footer>
<div class="footer">
<div class="pageWidth">
<div class="pageContent">
<div class='skin_branding'><a href="http://www.xenfocus.com" rel="nofollow">Xenforo skin</a><span> by <a href="http://www.xenfocus.com" rel="nofollow">Xenfocus</a></span></div>
<ul class="footerLinks">
<li><a href="/community/misc/contact">Contact</a></li>
<li><a href="/community/help/">Help</a></li>
<li><a href="/imprint/">Imprint</a></li>
<li><a href="/" class="homeLink">Tutorials</a></li>
<li><a href="#navigation" class="topLink">Top</a></li>
<li><a href="/feed" rel="alternate" class="globalFeed" target="_blank" title="RSS-Feed for Howtoforge">RSS-Feed</a></li>
</ul>
<span class="helper"></span>
</div>
</div>
</div>
<div class="footerLegal">
<div class="pageWidth">
<div class="pageContent">
<ul id="legal">
<li><a href="/community/help/terms">Terms</a></li>
</ul>
<div id="copyright"><a href="https://www.howtoforge.com" class="concealed">Howtoforge <span>&copy; projektfarm GmbH.</span></a></div>
<span class="helper"></span>
</div>
</div>
</div>
</footer>
<div style="height:100px;"></div>
<script>

jQuery.extend(true, XenForo,
{
	visitor: { user_id: 0 },
	serverTimeInfo:
	{
		now: 1409831907,
		today: 1409781600,
		todayDow: 4
	},
	_lightBoxUniversal: "0",
	_enableOverlays: "1",
	_animationSpeedMultiplier: "1",
	_overlayConfig:
	{
		top: "10%",
		speed: 200,
		closeSpeed: 100,
		mask:
		{
			color: "rgb(0, 0, 0)",
			opacity: "0.6",
			loadSpeed: 200,
			closeSpeed: 100
		}
	},
	_ignoredUsers: [],
	_loadedScripts: {"node_list":true,"node_category":true,"node_forum":true,"sidebar_share_page":true,"wf_default":true,"bbm_buttons":true,"login_bar":true,"twitter":true},
	_cookieConfig: { path: "/", domain: "", prefix: "xf_"},
	_csrfToken: "",
	_csrfRefreshUrl: "/community/login/csrf-token-refresh",
	_jsVersion: "303ae0ca"
});
jQuery.extend(XenForo.phrases,
{
	cancel: "Cancel",

	a_moment_ago:    "A moment ago",
	one_minute_ago:  "1 minute ago",
	x_minutes_ago:   "%minutes% minutes ago",
	today_at_x:      "Today at %time%",
	yesterday_at_x:  "Yesterday at %time%",
	day_x_at_time_y: "%day% at %time%",

	day0: "Sunday",
	day1: "Monday",
	day2: "Tuesday",
	day3: "Wednesday",
	day4: "Thursday",
	day5: "Friday",
	day6: "Saturday",

	_months: "January,February,March,April,May,June,July,August,September,October,November,December",
	_daysShort: "Sun,Mon,Tue,Wed,Thu,Fri,Sat",

	following_error_occurred: "The following error occurred",
	server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
	logging_in: "Logging in",
	click_image_show_full_size_version: "Click this image to show the full-size version.",
	show_hidden_content_by_x: "Show hidden content by {names}"
});

// Facebook Javascript SDK
XenForo.Facebook.appId = "";
XenForo.Facebook.forceInit = true;

/*
document.addEventListener('DOMContentLoaded', function(event) {
  cookieChoices.showCookieConsentBar('Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.',
  'OK');
});
*/

$(document).ready(function() {
	$("a.fancybox").fancybox();
});

</script>
<script async type="text/javascript" src="//cdn.fancybar.net/ac/fancybar.js?zoneid=1502&serve=C6ADVKE&placement=howtoforge" id="_fancybar_js"></script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2155872-1', 'auto');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');

</script>
</body>
</html>