<!DOCTYPE html><html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs LoggedOut Sidebar Responsive" xmlns:fb="http://www.facebook.com/2008/fbml"><head><meta charset="utf-8" />
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=195-2&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=195-2&cb=4', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=195-2&cb=5', false, [], true, false, true, false);</script>
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<base href="https://www.howtoforge.com" />
<script>
			var _b = document.getElementsByTagName('base')[0], _bH = "https://www.howtoforge.com/how-to-install-apache-tomcat-on-rocky-linux-8/";
			if (_b && _b.href != _bH) _b.href = _bH;
		</script>
<title>How to Install Apache Tomcat 10 with Nginx on Rocky Linux 8</title>
<meta name="description" content="Tomcat is an open-source web server for Java-based applications. It is used for deploying Java Servlet and JSP applications.  We will install Tomcat 1... " />
<meta property="og:title" content="How to Install Apache Tomcat 10 with Nginx on Rocky Linux 8" />
<meta property="og:description" content="Tomcat is an open-source web server for Java-based applications. It is used for deploying Java Servlet and JSP applications.  We will install Tomcat 1... " />
<meta property="og:site_name" content="HowtoForge" />
<meta property="og:type" content="article" />
<meta property="og:image" content="https://www.howtoforge.com/images/featured/tomcat-rocky-linux.jpg" />
<meta property="og:image:secure_url" content="https://www.howtoforge.com/images/featured/tomcat-rocky-linux.jpg" />
<meta property="og:image:alt" content="How to Install Apache Tomcat 10 with Nginx on Rocky Linux 8" />
<meta name="twitter:image" content="https://www.howtoforge.com/images/featured/tomcat-rocky-linux.jpg" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@howtoforgecom" />
<meta name="twitter:creator" content="@howtoforgecom" />
<meta name="twitter:title" content="How to Install Apache Tomcat 10 with Nginx on Rocky Linux 8" />
<meta name="twitter:description" content="Tomcat is an open-source web server for Java-based applications. It is used for deploying Java Servlet and JSP applications.  We will install Tomcat 1... " />
<link rel="alternate" href="https://www.howtoforge.com/how-to-install-apache-tomcat-on-rocky-linux-8/" hreflang="en" />
<link rel="canonical" href="https://www.howtoforge.com/how-to-install-apache-tomcat-on-rocky-linux-8/" />
<link rel="amphtml" href="https://www.howtoforge.com/how-to-install-apache-tomcat-on-rocky-linux-8/amp/" />
<script type="application/ld+json">
{
  "@context" : "http://schema.org",
  "@type" : "Article",
  "name" : "How to Install Apache Tomcat 10 with Nginx on Rocky Linux 8",
  "author" : {
    "@type" : "Person",
    "name" : "Navjot Singh"
  },
  "articleSection" : "linux,nginx,server",
  "url" : "https://www.howtoforge.com/how-to-install-apache-tomcat-on-rocky-linux-8/",
  "publisher" : {
    "@type" : "Organization",
    "name" : "Howtoforge"
  }
}
</script>
<noscript><style>.JsOnly, .jsOnly { display: none !important; }</style></noscript>
<link rel="stylesheet" href="/community/styles/executive/xenfocus/icons/css/font-awesome.min.css" />
<link href="//fonts.googleapis.com/css?family=Open+Sans:400,700" rel="stylesheet" type="text/css" />
<link href="/themes/howtoforge/templates/xf.css" rel="stylesheet" />
<script src="/js/jquery/jquery-1.11.3.min.js"></script>
<script src="/community/js/xenforo/xenforo.js?_v=303ae0ca"></script>
<script src="/community/js/bbm/zloader.js?_v=303ae0ca"></script>
<script type="text/javascript" src="/js/fancybox/jquery.mousewheel-3.0.4.pack.js"></script>
<script type="text/javascript" src="/js/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
<link rel="stylesheet" type="text/css" href="/js/fancybox/jquery.fancybox-1.3.4.css" media="screen" />
<link href="/themes/howtoforge/templates/style.min.css" rel="stylesheet" />
<link rel="alternate" type="application/rss+xml" title="RSS-Feed für Howtoforge" href="/feed.rss" />
<script src="/js/tinymce_4.1.7/tinymce.min.js"></script>
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/skin.min.css" as="style" />
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/content.min.css" as="style" />
<link rel="preload" href="/themes/howtoforge/css/custom.css" as="style" />
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/fonts/tinymce.woff" as="font" crossorigin="anonymous" />

<script type="text/javascript">
var gaProperty = 'UA-2155872-1';
var disableStr = 'ga-disable-' + gaProperty;
if (document.cookie.indexOf(disableStr + '=true') > -1) {
window[disableStr] = true;
}
function gaOptout() {
document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
window[disableStr] = true;
alert('Google Ananlyitics tracking has been disabled in this browser.');
}
</script>
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
	googletag.defineSlot('/1030080/howtoforge_com_list_sidebar_top', [300, 250], 'div-gpt-ad-1527185271042-4').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_list_content_middle', [[300, 250], [336, 280]], 'div-gpt-ad-1527185271042-5').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_a_300x250', [300, 250], 'div-gpt-ad-1527185271042-6').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_b_300x250', [300, 250], 'div-gpt-ad-1527185271042-7').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_leaderboard_b_728x90', [728, 90], 'div-gpt-ad-1527185271042-1').addService(googletag.pubads());
	googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-3043223216276099",
          enable_page_level_ads: true
     });
</script>


<script type="text/javascript" src="//m.servedby-buysellads.com/monetization.js"></script>

<script type="text/javascript">var ezouid = "1";</script><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script>
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 178704;
var ezdomain = 'howtoforge.com';
var ezoicSearchable = 1;
</script>


<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":178704,"domain_test_group":20210302,"engaged_time_visit":0,"ezcache_level":2,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"4ba3d867-cd20-475f-628d-0884967a6986","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":47703,"response_time_orig":4,"serverid":"54.81.148.221:30142","state":"VA","t_epoch":1641888145,"template_id":126,"time_on_site_visit":0,"url":"https://www.howtoforge.com/how-to-install-apache-tomcat-on-rocky-linux-8/","user_id":0,"word_count":1755,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_178704=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["4ba3d867-cd20-475f-628d-0884967a6986", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>
<body>
<div id="loginBar">
<div class="pageWidth">
<div class="pageContent">
<h3 id="loginBarHandle">
<label for="LoginControl"><a href="/community/login/" class="concealed noOutline">Log in or Sign up</a></label>
</h3>
<span class="helper"></span>
</div>
</div>
</div>
<header>
<div id="header">
<div id="logoBlock">
<div class="pageWidth">
<div class="pageContent">
<div id="logo"><a href="/">
<span></span>
<img src="/images/howtoforge_logo_trans.gif" alt="Howtoforge" style="margin-left:20px;" />
</a></div>
<span class="helper"></span>
</div>
</div>
</div>
<div id="navigation" class="pageWidth withSearch">
<div class="pageContent">
<nav>
<div class="navTabs">
<ul class="publicTabs">

<li class="navTab forums selected">
<a href="/" class="navLink">Tutorials</a>
<div class="tabLinks forumsTabLinks">
<ul class="secondaryContent blockLinksList">
<li><a href="/search/">Tutorial search</a></li>
</ul>
</div>
</li>
<li class="navTab forums PopupClosed">
<a href="/tutorials/" class="navLink">Tags</a>
</li>
<li class="navTab forums PopupClosed"><a href="/community/" class="navLink">Forums</a></li>
<li class="navTab forums PopupClosed"><a href="/linux-commands/" class="navLink">Linux Commands</a></li>
<li class="navTab forums PopupClosed"><a href="/subscription/" class="navLink">Subscribe</a></li>
<li class="navTab forums PopupClosed"><a href="https://www.ispconfig.org" class="navLink">ISPConfig</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.lxer.com" class="navLink">News</a></li>
</ul>
</div>
<span class="helper"></span>
</nav>
</div>
</div>
<div id="searchBar" class="pageWidth">
<span id="QuickSearchPlaceholder" title=" Search..."> Search</span>
<fieldset id="QuickSearch">
<form action="/" method="post" class="formPopup">
<div class="primaryControls">

<input type="search" name="q" value="" class="textCtrl" placeholder="Search..." results="0" title="Enter your search and hit enter..." id="QuickSearchQuery" />

</div>
<input type="hidden" name="_xfToken" value="" />
</form>
</fieldset>
</div>
</div>
</header>
<div id="content" class="forum_list">
<div class="pageWidth">
<div class="pageContent">

<div class="mainContainer">
<div class="mainContent">

<div class="breadBoxTop">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://schema.org/BreadcrumbList">
<span itemprop="itemListElement" itemscope="" itemtype="http://schema.org/ListItem">
<a href="/" class="crumb" rel="up" itemprop="item"><span itemprop="name">Home</span></a>
<meta itemprop="position" content="1" />
</span>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://schema.org/BreadcrumbList">
<span itemprop="itemListElement" itemscope="" itemtype="http://schema.org/ListItem">
<a href="/how-to-install-apache-tomcat-on-rocky-linux-8/" class="crumb" rel="up" itemprop="item"><span itemprop="name">How to Install Apache Tomcat 10 with Nginx on Rocky Linux 8</span></a>
<meta itemprop="position" content="2" />
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</span></fieldset>
</nav>
</div>

<div id="htfContentPage">
<div class="bsa-apiads"></div>
<article>
<h1>How to Install Apache Tomcat 10 with Nginx on Rocky Linux 8</h1>
<div class="contributeEdit" style="float:right; width:450px; max-width:100%;">
<div id="tocContainer">
<h3>On this page</h3>
<ol class="toc">
<li><a href="#prerequisites">Prerequisites</a></li>
<li><a href="#step-1---install-java">Step 1 - Install Java</a></li>
<li><a href="#step-2---create-a-system-user">Step 2 - Create a System User</a></li>
<li><a href="#step-3---download-tomcat">Step 3 - Download Tomcat</a></li>
<li><a href="#step-4---create-a-systemd-unit-file">Step 4 - Create a Systemd Unit File</a></li>
<li><a href="#step-5---start-and-enable-the-tomcat-service">Step 5 - Start and Enable the Tomcat service</a></li>
<li><a href="#step-6---configure-firewall">Step 6 - Configure Firewall</a></li>
<li><a href="#step-7---configure-tomcat-web-management-interface">Step 7 - Configure Tomcat Web Management Interface</a></li>
<li><a href="#step-8---install-ssl">Step 8 - Install SSL</a></li>
<li><a href="#step-9---install-nginx">Step 9 - Install Nginx</a></li>
<li><a href="#step-10---run-tomcat">Step 10 - Run TomCat</a></li>
<li><a href="#conclusion">Conclusion</a></li>
</ol>
</div>
</div>
<p>Tomcat is an open-source web server for Java-based applications. It is used for deploying Java Servlet and JSP applications. Java servlets are small programs defining how a server handles requests and responses. Tomcat acts as an open-source implementation of the Java Servlet, JavaServer Pages, Java Expression Language, and Java WebSocket technologies.</p>
<p>There are multiple versions of Tomcat available. We will discuss the installation of Tomcat 10 for our tutorial. If you want to install Tomcat 9, the instructions will be the same. If there are any changes, they will be specified in the tutorial.</p>
<p>For our tutorial, we will install Tomcat 10 along with the Nginx server to act as a reverse proxy and protect it using SSL. There is a Tomcat 10.1.x version which is the latest alpha version of Tomcat, but we will not be installing that.</p>
<h2 id="prerequisites">Prerequisites</h2>
<ul>
<li>
<p>A server running Rocky Linux 8.5</p>
</li>
<li>
<p>A non-sudo user with superuser privileges.</p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;">

<div id="div-gpt-ad-1527185271042-6" style="height:250px; width:300px;">
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-6'); });
</script>
</div>
</div>
</li>
<li>
<p>Make sure everything is updated.</p>
<pre class="command">$ sudo dnf update
</pre>
</li>
<li>
<p>Packages required for the installation.</p>
<pre class="command">$ sudo dnf install wget tar
</pre>
</li>
</ul>
<h2 id="step-1---install-java">Step 1 - Install Java</h2>
<p>Tomcat 9 and 10 require Java 8 and later. We will install OpenJDK 11, the open-source implementation of the Java platform.</p>
<p>Run the following command to install OpenJDK.</p>
<pre class="command">$ sudo dnf install java-11-openjdk-devel
</pre>
<p>Verify the installation.</p>
<pre class="command">$ java -version
openjdk version &#34;11.0.13&#34; 2021-10-19 LTS
OpenJDK Runtime Environment 18.9 (build 11.0.13+8-LTS)
OpenJDK 64-Bit Server VM 18.9 (build 11.0.13+8-LTS, mixed mode, sharing)
</pre>
<h2 id="step-2---create-a-system-user">Step 2 - Create a System User</h2>
<p>We will create a new system user to minimize any security risk by running Tomcat as a root user. For the new user, we will set <code class="system">/opt/tomcat</code> as the home directory.</p>
<p>Run the following command to create a new system user for Tomcat.</p>
<pre class="command">$ sudo useradd -m -U -d /opt/tomcat -s /bin/false tomcat
</pre>
<h2 id="step-3---download-tomcat">Step 3 - Download Tomcat</h2>
<p>The latest version of Tomcat v10 can be downloaded from <a href="https://tomcat.apache.org/download-10.cgi">its download page</a>. At the time of writing this tutorial, v10.0.14 is the latest available version. Check the latest version before you download Tomcat.</p>
<p>Use <code class="system">wget</code> to download Tomcat.</p>
<pre class="command">$ VERSION=10.0.14
$ wget https://dlcdn.apache.org/tomcat/tomcat-10/v${VERSION}/bin/apache-tomcat-${VERSION}.tar.gz
</pre>
<p>Extract the file to the <code class="system">/opt/tomcat</code> directory.</p>
<pre class="command">$ sudo tar -xf apache-tomcat-${VERSION}.tar.gz -C /opt/tomcat/
</pre>
<p>Create a symbolic link to the latest version of Tomcat that points to Tomcat&#39;s installation directory.</p>
<pre class="command">$ sudo ln -s /opt/tomcat/apache-tomcat-${VERSION} /opt/tomcat/latest
</pre>
<p>Change the ownership of the directory to the user created earlier.</p>
<pre class="command">$ sudo chown -R tomcat:tomcat /opt/tomcat
</pre>
<h2 id="step-4---create-a-systemd-unit-file">Step 4 - Create a Systemd Unit File</h2>
<p>The next step is to create a service file for the Tomcat server so that it can be started automatically.</p>
<p>Create and open the file <code class="system">/etc/systemd/system/tomcat.service</code> for editing.</p>
<pre class="command">$ sudo nano /etc/systemd/system/tomcat.service
</pre>
<p>Paste the following code.</p>
<pre class="command">[Unit]
Description=Apache Tomcat 10 Servlet container
Wants=network.target
After=network.target

[Service]
Type=forking

User=tomcat
Group=tomcat

Environment=&#34;JAVA_HOME=/usr/lib/jvm/jre&#34;
Environment=&#34;JAVA_OPTS=-Djava.security.egd=file:///dev/urandom&#34;

Environment=&#34;CATALINA_BASE=/opt/tomcat/latest&#34;
Environment=&#34;CATALINA_HOME=/opt/tomcat/latest&#34;
Environment=&#34;CATALINA_PID=/opt/tomcat/latest/temp/tomcat.pid&#34;
Environment=&#34;CATALINA_OPTS=-Xms512M -Xmx1024M -server -XX:+UseParallelGC&#34;

ExecStart=/opt/tomcat/latest/bin/startup.sh
ExecStop=/opt/tomcat/latest/bin/shutdown.sh
Restart=always

[Install]
WantedBy=multi-user.target
</pre>
<p>Save the file by pressing <strong>Ctrl + X</strong> and entering <strong>Y</strong> when prompted to save.</p>
<h2 id="step-5---start-and-enable-the-tomcat-service">Step 5 - Start and Enable the Tomcat service</h2>
<p>Reload the service daemon to enable the Tomcat service.</p>
<pre class="command">$ sudo systemctl daemon-reload
</pre>
<p>Enable and Start the Tomcat service.</p>
<pre class="command">$ sudo systemctl enable tomcat --now
</pre>
<p>Check the service status.</p>
<pre class="command">$ sudo systemctl status tomcat
? tomcat.service - Apache Tomcat 10 Servlet container
   Loaded: loaded (/etc/systemd/system/tomcat.service; enabled; vendor preset: disabled)
   Active: active (running) since Fri 2021-12-17 15:54:28 UTC; 24s ago
  Process: 86219 ExecStart=/opt/tomcat/latest/bin/startup.sh (code=exited, status=0/SUCCESS)
 Main PID: 86226 (java)
    Tasks: 19 (limit: 11411)
   Memory: 132.7M
   CGroup: /system.slice/tomcat.service
           ??86226 /usr/lib/jvm/jre/bin/java -Djava.util.logging.config.file=/opt/tomcat/latest/conf/logging.properties&gt;

Dec 17 15:54:27 howtoforge systemd[1]: Starting Apache Tomcat 10 Servlet container...
Dec 17 15:54:28 howtoforge systemd[1]: Started Apache Tomcat 10 Servlet container.
</pre>
<h2 id="step-6---configure-firewall">Step 6 - Configure Firewall</h2>
<p>Rocky Linux uses Firewalld Firewall. Check the firewall&#39;s status.</p>
<pre class="command">$ sudo firewall-cmd --state
running
</pre>
<p>Allow HTTP and HTTPS ports.</p>
<pre class="command">$ sudo firewall-cmd --permanent --add-service=http
$ sudo firewall-cmd --permanent --add-service=https
</pre>
<p>Reload the firewall to enable the changes.</p>
<pre class="command">$ sudo firewall-cmd --reload
</pre>
<h2 id="step-7---configure-tomcat-web-management-interface">Step 7 - Configure Tomcat Web Management Interface</h2>
<p>The web management interface will only be accessible once we create a user credential for it.</p>
<p>Tomcat users and roles are defined in the <code class="system">/opt/tomcat/latest/conf/tomcat-users.xml</code> file. Open the file for editing.</p>
<pre class="command">$ sudo nano /opt/tomcat/latest/conf/tomcat-users.xml
</pre>
<p>Add the following lines before the <code class="system">&lt;/tomcat-users</code> line. Replace the username and password with your credentials.</p>
<p>Choose different credentials for Manager and Administrator Tomcat portals.</p>
<pre class="command">&lt;tomcat-users&gt;
&lt;!--
    Comments
--&gt;
&lt;role rolename=&#34;manager-gui&#34;/&gt;
    &lt;user username=&#34;manager&#34; password=&#34;managerpassword&#34; roles=&#34;manager-gui&#34; /&gt;
&lt;role rolename=&#34;admin-gui&#34;/&gt;
	&lt;user username=&#34;admin&#34; password=&#34;adminpassword&#34; roles=&#34;admin-gui&#34;/&gt;
&lt;/tomcat-users&gt;
</pre>
<p>Save the file by pressing <strong>Ctrl + X</strong> and entering <strong>Y</strong> when prompted to save.</p>
<p>By default, the Tomcat interface is only accessible from the localhost. If you need to access it from anywhere, you need to configure it.</p>
<p>Open the <code class="system">/opt/tomcat/latest/webapps/manager/META-INF/context.xml</code> for editing.</p>
<pre class="command">$ sudo nano /opt/tomcat/latest/webapps/manager/META-INF/context.xml
</pre>
<p>Remove the following lines or comment them out as specified below by enclosing it in <code class="system">&lt;!--</code> and <code class="system">--&gt;</code>.</p>
<pre class="command">&lt;!--
  &lt;Valve className=&#34;org.apache.catalina.valves.RemoteAddrValve&#34;
         allow=&#34;127\.\d+\.\d+\.\d+|::1|0:0:0:0:0:0:0:1&#34; /&gt;
--&gt;
</pre>
<p>Allowing access from any IP address is a security risk. You can restrict it by allowing access only from your public IP address. If your public IP address is <strong>22.22.22.22</strong>, then change the line as follows.</p>
<pre class="command"> &lt;Valve className=&#34;org.apache.catalina.valves.RemoteAddrValve&#34;
         allow=&#34;127\.\d+\.\d+\.\d+|::1|0:0:0:0:0:0:0:1|22.22.22.22&#34; /&gt;
</pre>
<p>The list of allowed IP addresses is separated by a vertical bar (<strong>|</strong>). You can either add single IP addresses or use a regular expression.</p>
<p>Save the file by pressing <strong>Ctrl + X</strong> and entering <strong>Y</strong> when prompted to save.</p>
<p>Perform the same changes on the file <code class="system">/opt/tomcat/latest/webapps/host-manager/META-INF/context.xml</code> as well.</p>
<p>Once finished, restart the Tomcat server.</p>
<pre class="command">$ sudo systemctl restart tomcat
</pre>
<h2 id="step-8---install-ssl">Step 8 - Install SSL</h2>
<p>To install an SSL certificate using Let&#39;s Encrypt, we need to install the Certbot tool.</p>
<p>Firstly, you need to download and install the EPEL repository.</p>
<pre class="command">$ sudo dnf install epel-release
</pre>
<p>Run the following commands to install Certbot.</p>
<pre class="command">$ sudo dnf install certbot
</pre>
<p>Generate the SSL certificate.</p>
<pre class="command">$ sudo certbot certonly --standalone --agree-tos --no-eff-email --staple-ocsp --preferred-challenges http -m <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="a4cac5c9c1e4c1dcc5c9d4c8c18ac7cbc9">[email&#160;protected]</a> -d tomcat.example.com
</pre>
<p>The above command will download a certificate to the <code class="system">/etc/letsencrypt/live/tomcat.example.com</code> directory on your server.</p>
<p>Generate a <strong>Diffie-Hellman group</strong> certificate.</p>
<pre class="command">$ sudo openssl dhparam -out /etc/ssl/certs/dhparam.pem 2048
</pre>
<p>Create a challenge webroot directory for Let&#39;s Encrypt auto-renewal.</p>
<pre class="command">$ sudo mkdir -p /var/lib/letsencrypt
</pre>
<p>Create a Cron Job to renew the SSL. It will run every day to check the certificate and renew if needed. For that, first, create the file <code class="system">/etc/cron.daily/certbot-renew</code> and open it for editing.</p>
<pre class="command">$ sudo nano /etc/cron.daily/certbot-renew
</pre>
<p>Paste the following code.</p>
<pre class="command">#!/bin/sh
certbot renew --cert-name tomcat.example.com --webroot -w /var/lib/letsencrypt/ --post-hook &#34;systemctl reload nginx&#34;
</pre>
<p>Save the file by pressing <strong>Ctrl + X</strong> and entering <strong>Y</strong> when prompted.</p>
<p>Change the permissions on the task file to make it executable.</p>
<pre class="command">$ sudo chmod +x /etc/cron.daily/certbot-renew
</pre>
<h2 id="step-9---install-nginx">Step 9 - Install Nginx</h2>
<p>Rocky Linux 8.5 ships with the latest stable version of Nginx. Install it using the following command.</p>
<pre class="command">$ sudo dnf module install nginx:1.20
</pre>
<p>Verify the installation.</p>
<pre class="command">$ nginx -v
nginx version: nginx/1.20.1
</pre>
<p>Enable and start the Nginx service.</p>
<pre class="command">$ sudo systemctl enable nginx --now
</pre>
<p>Create and open the file <code class="system">/etc/nginx/conf.d/tomcat.conf</code> for editing.</p>
<pre class="command">$ sudo nano /etc/nginx/conf.d/tomcat.conf
</pre>
<p>Paste the following code in it.</p>
<pre class="command">server {
    listen       443 ssl http2;
    listen       [::]:443 ssl http2;
    server_name  tomcat.example.com;

    access_log  /var/log/nginx/tomcat.access.log;
    error_log   /var/log/nginx/tomcat.error.log;
    
    # SSL
    ssl_certificate      /etc/letsencrypt/live/tomcat.example.com/fullchain.pem;
    ssl_certificate_key  /etc/letsencrypt/live/tomcat.example.com/privkey.pem;
    ssl_trusted_certificate /etc/letsencrypt/live/tomcat.example.com/chain.pem;
    ssl_session_timeout  5m;
    ssl_session_cache shared:MozSSL:10m;
    ssl_session_tickets off;
    ssl_protocols TLSv1.2 TLSv1.3;
    ssl_prefer_server_ciphers on;
    ssl_ciphers ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384;
    ssl_ecdh_curve X25519:prime256v1:secp384r1:secp521r1;
    ssl_stapling on;
    ssl_stapling_verify on;
    ssl_dhparam /etc/ssl/certs/dhparam.pem;
    resolver 8.8.8.8;

    location / {
      proxy_pass http://127.0.0.1:8080;
      proxy_set_header X-Real-IP $remote_addr;
      proxy_set_header X-Forwarded-Host $host;
      proxy_set_header X-Forwarded-Server $host;
      proxy_set_header Host $host;
      proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
  }
}
# enforce HTTPS
server {
    listen       80;
    listen       [::]:80;
    server_name  tomcat.example.com;
    return 301   https://$host$request_uri;
}
</pre>
<p>Save the file by pressing <strong>Ctrl + X</strong> and entering <strong>Y</strong> when prompted once finished.</p>
<p>Open the file <code class="system">/etc/nginx/nginx.conf</code> for editing.</p>
<pre class="command">$ sudo nano /etc/nginx/nginx.conf
</pre>
<p>Add the following line before the line <code class="system">include /etc/nginx/conf.d/*.conf;</code>.</p>
<pre class="command">server_names_hash_bucket_size  64;
</pre>
<p>Save the file by pressing <strong>Ctrl + X</strong> and entering <strong>Y</strong> when prompted.</p>
<p>Verify the Nginx configuration file syntax.</p>
<pre class="command">$ sudo nginx -t
nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful
</pre>
<p>Restart the Nginx service to enable the new configuration.</p>
<pre class="command">$ sudo systemctl restart nginx
</pre>
<h2 id="step-10---run-tomcat">Step 10 - Run TomCat</h2>
<p>Launch <code class="system">https://tomcat.example.com</code> in your browser, and it will open the following screen.</p>
<p><a class="fancybox" id="img-tomcat-home" href="https://www.howtoforge.com/images/how_to_install_apache_tomcat_on_rocky_linux_8/big/tomcat-home.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_apache_tomcat_on_rocky_linux_8/tomcat-home.png" referrerpolicy="no-referrer" alt="Tomcat Web Management Home" width="750" height="670" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>You can now access the Server Status, Manager App and Host Manager pages using the login credentials we configured in step 7.</p>
<h2 id="conclusion">Conclusion</h2>
<p>This concludes our tutorial on installing and configuring Tomcat Server on a Rocky Linux 8.5 based server and serving it via Nginx reverse proxy, and using SSL to protect it. If you have any questions, post them in the comments below.</p>
</article>
<div style="height:30px; margin-top:20px;">
<p style="text-align:right;"><img src="/images/pdficon_small.png" /> <a class="pdf-btn" href="javascript:void(0);">view as pdf</a> | <img src="/images/print.gif" /> <a class="print-btn" href="javascript:void(0);">print</a></p>
</div>
<div style="height:30px; margin-top:20px;">
<div style="float:left;"><b>Share this page:</b></div>
<p style="text-align:center;">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-apache-tomcat-on-rocky-linux-8%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-apache-tomcat-on-rocky-linux-8%2F&amp;text=How+to+Install+Apache+Tomcat+10+with+Nginx+on+Rocky+Linux+8&amp;via=howtoforgecom&amp;related=howtoforgecom" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-apache-tomcat-on-rocky-linux-8%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-gplus.png" height="20" /></a>
</p>
</div>
</div>


<div id="htfContentPagePaging">
<h2>Suggested articles</h2>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-3043223216276099" data-ad-slot="8940054090"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>


<div id="htfContentPageComment">
<a name="comments"></a>
<h2>0 Comment(s)</h2>

<div id="commentform">
<div class="commentContainerHead" style="font-size:18px;">Add comment</div>
<div class="commentContainer">
<form method="post" action="/how-to-install-apache-tomcat-on-rocky-linux-8/#comments">
<input type="hidden" name="reply_to" id="reply-to-comment" value="0" />
<div id="commentFormDetail">
<div style="width:48%; float:left; margin-right:3%">
<label for="commentname">Name *</label>
<input id="commentname" name="commentname" value="" />
</div>
<div style="width:48%;float:left;">
<label for="commentname">Email *</label>
<input id="commentemail" name="commentemail" value="" />
</div>
<div style="clear:both;"></div>
</div>
<textarea id="commentedit" name="commentedit" style="width:auto;"></textarea>
<div>
<div style="float:left;">
<div class="g-recaptcha" data-sitekey="6LdX9fUSAAAAALWwVoPdeXScMSketz4npF-0QcQ1"></div>
<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en">
      </script>
</div>
<div style="margin-top:10px;margin-bottom:10px;">
<input type="submit" name="submit" class="button primary" style="float:right;" value="Submit comment" />
</div>
<div style="clear:both;"></div>
</div>
<script>
	tinymce.init({
		selector: "textarea#commentedit",
		theme: "modern",
		height: 100,
		apply_source_formatting : true,
		remove_linebreaks : false,
		menubar : false,
		/*auto_focus : "commentedit",*/
		plugins: [
		"link"
		],
		/*plugins: [
			"advlist autolink link image lists charmap print preview hr anchor pagebreak spellchecker",
			"searchreplace wordcount visualblocks visualchars code fullscreen insertdatetime media nonbreaking",
			"save table contextmenu directionality emoticons template paste textcolor"
		],*/
		content_css: "https://www.howtoforge.com/themes/howtoforge/css/custom.css",
		toolbar: "undo redo | bold italic link", 
		/*style_formats: [
			{title: 'Bold text', inline: 'b'},
			{title: 'Red text', inline: 'span', styles: {color: '#ff0000'}},
			{title: 'Red header', block: 'h1', styles: {color: '#ff0000'}},
			{title: 'Example 1', inline: 'span', classes: 'example1'},
			{title: 'Example 2', inline: 'span', classes: 'example2'},
			{title: 'Table styles'},
			{title: 'Table row 1', selector: 'tr', classes: 'tablerow1'}
		]*/
	}); 
	</script>
</form>
</div>
</div>

</div>

<div class="breadBoxBottom">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Home</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/how-to-install-apache-tomcat-on-rocky-linux-8/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to Install Apache Tomcat 10 with Nginx on Rocky Linux 8</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
<script>
<!--

$(document).on('click', 'a.reply-to', function(e) {
	e.preventDefault();
	
	var self = $(this);
	var cid = self.attr('data-comment');
	console.log(cid);
	if(!cid) return this;
	
	$('#commentform').insertAfter('#comment' + cid);
	$('#reply-to-comment').val(cid);
	/*tinyMCE.activeEditor.focus();*/
	var textareaId = 'commentedit';
	tinyMCE.get(textareaId).remove();
	tinyMCE.execCommand("mceAddEditor", false, textareaId);
	tinyMCE.activeEditor.focus();
});
//-->
</script>
<div style="margin-top:10px;margin-bottom:10px;text-align:center;">

<center>


<div id="div-gpt-ad-1527185271042-1" style="height:90px; width:728px;">
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-1'); });
</script>
</div>

</center>
</div>


<form action="/community/login/login?redirect=/how-to-install-apache-tomcat-on-rocky-linux-8/" method="post" class="xenForm eAuth" id="login" style="display:none">
<ul id="eAuthUnit">
<li><a href="/community/register/facebook?reg=1" class="fbLogin" tabindex="110"><span>Log in with Facebook</span></a></li>
<li><a href="/community/register/twitter?reg=1" class="twitterLogin" tabindex="110"><span>Log in with Twitter</span></a></li>
<li><span class="googleLogin GoogleLogin JsOnly" tabindex="110" data-client-id="198773272284-b6tfk0c28bje81p774prrcrkq9jb3o44.apps.googleusercontent.com" data-redirect-url="/community/register/google?code=__CODE__&amp;csrf=hVMXbW_3rnrmq4Em"><span>Log in with Google</span></span></li>
</ul>
<div class="ctrlWrapper">
<dl class="ctrlUnit">
<dt><label for="LoginControl">Your name or email address:</label></dt>
<dd><input type="text" name="login" id="LoginControl" class="textCtrl" tabindex="101" /></dd>
</dl>
<dl class="ctrlUnit">
<dt>
<label for="ctrl_password">Do you already have an account?</label>
</dt>
<dd>
<ul>
<li><label for="ctrl_not_registered"><input type="radio" name="register" value="1" id="ctrl_not_registered" tabindex="105" />
No, create an account now.</label></li>
<li><label for="ctrl_registered"><input type="radio" name="register" value="0" id="ctrl_registered" tabindex="105" checked="checked" class="Disabler" />
Yes, my password is:</label></li>
<li id="ctrl_registered_Disabler">
<input type="password" name="password" class="textCtrl" id="ctrl_password" tabindex="102" />
<div class="lostPassword"><a href="/community/lost-password/" tabindex="106">Forgot your password?</a></div>
</li>
</ul>
</dd>
</dl>
<dl class="ctrlUnit submitUnit">
<dt></dt>
<dd>
<input type="submit" class="button primary" value="Log in" tabindex="104" data-loginphrase="Log in" data-signupphrase="Sign up" />
<label for="ctrl_remember" class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_remember" tabindex="103" /> Stay logged in</label>
</dd>
</dl>
</div>
<input type="hidden" name="cookie_check" value="1" />
<input type="hidden" name="redirect" value="/community/" />
<input type="hidden" name="_xfToken" value="" />
</form>

</div>
</div>

<aside>
<div class="sidebar">
<div class="section loginButton">
<div class="secondaryContent">
<label for="LoginControl" id="SignupButton"><a href="/community/login/" class="inner">Sign up now!</a></label>
</div>
</div>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-2">

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent socialMediaIcon">
<a href="https://twitter.com/howtoforgecom" target="_blank"><img src="/images/socialmedia/64x64/twitter.png" /></a>
<a href="https://www.facebook.com/howtoforge" target="_blank"><img src="/images/socialmedia/64x64/facebook.png" /></a>
<a href="https://news.ycombinator.com/" target="_blank" rel="nofollow"><img src="/images/socialmedia/64x64/hackernews.png" /></a>
<a href="https://www.howtoforge.com/feed" target="_blank"><img src="/images/socialmedia/64x64/rss.png" /></a>
</div>
</div>
</div>
<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Tutorial Info</p>
<div class="pairsJustified">
<dl class="discussionCount">
<dt>Author:</dt>
<dd><a href="/author/navjot+singh/" rel="author">Navjot Singh</a></dd>
</dl>
<dl class="discussionCount">
<dt>Published:</dt>
<dd>Jan 10, 2022</dd>
</dl>
<dl class="discussionCount">
<dt>Tags:</dt>
<dd><a href="/tutorials/linux/" rel="tag">linux</a>, <a href="/tutorials/nginx/" rel="tag">nginx</a>, <a href="/tutorials/server/" rel="tag">server</a></dd>
</dl>
</div>
</div>
</div>

<div id="sponsor-banner">
</div>

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent">
<p class="mnuinfo mnushare">Share This Page</p>
<p style="text-align:center;">
<a href="javascript:window.open(&#39;https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-apache-tomcat-on-rocky-linux-8%2F&#39;, &#39;_blank&#39;, &#39;status=1,height=500,width=360,resizable=0&#39;);void(0);"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="javascript:window.open(&#39;https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-apache-tomcat-on-rocky-linux-8%2F&amp;text=How+to+Install+Apache+Tomcat+10+with+Nginx+on+Rocky+Linux+8&amp;via=howtoforgecom&amp;related=howtoforgecom&#39;, &#39;_blank&#39;, &#39;status=1,height=500,width=360,resizable=0&#39;);void(0);"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="javascript:window.open(&#39;https://news.ycombinator.com/submitlink?t=How+to+Install+Apache+Tomcat+10+with+Nginx+on+Rocky+Linux+8&amp;u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-apache-tomcat-on-rocky-linux-8%2F&#39;, &#39;_blank&#39;, &#39;status=1,height=500,width=360,resizable=0&#39;);void(0);"><img src="/images/socialmedia/btn-hackernews.png" height="20" /></a>
</p>
<p style="color:#EE; font-weight:bold; text-align:center; margin-top:5px;">40.2k Followers</p>
</div>
</div>
</div>


<script type="text/javascript">
    google_ad_client = "ca-pub-3043223216276099";
    google_ad_slot = "6709042890";
    google_ad_width = 300;
    google_ad_height = 600;
</script>

<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>


<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Popular Tutorials</p>
<div class="pairsJustified">
<ul>
<li><a href="/tutorial/how-to-install-piwik-with-nginx-on-ubuntu-15-10/">How to Install Piwik with Nginx on Ubuntu 15.10</a></li>
<li><hr /></li>
<li><a href="/configuring_apache_for_maximum_performance">Configuring Apache for Maximum Performance</a></li>
<li><hr /></li>
<li><a href="/how-to-install-rust-programming-language-on-debian-11/">How to Install Rust Programming Language on Debian 11</a></li>
<li><hr /></li>
<li><a href="/tutorial/ispconfig-multiserver-setup-debian-ubuntu/">ISPConfig Perfect Multiserver setup on Ubuntu 20.04 and Debian 10</a></li>
<li><hr /></li>
<li><a href="/how-to-install-gitea-with-postgresql-on-debian-11/">How to Install Gitea with PostgreSQL on Debian 11</a></li>
<li><hr /></li>
<li><a href="/how-to-install-ruby-on-rails-with-postgresql-rocky-linux/">How to Install Ruby on Rails with PostgreSQL on Rocky Linux 8.4</a></li>
<li><hr /></li>
<li><a href="/how-to-install-redis-server-on-debian-11/">How to Install Redis Server on Debian 11</a></li>
<li><hr /></li>
<li><a href="/how-to-install-sails-js-framework-on-debian-11/">How to Install Sails.js MVC Framework with Nginx on Debian 11</a></li>
<li><hr /></li>
<li><a href="/how-to-create-a-virtual-machine-scale-set-on-azure/">How to create a Virtual Machine scale set on Azure</a></li>
<li><hr /></li>
<li><a href="/how-to-install-clickhouse-on-debian-11/">How to Install ClickHouse OLAP Database System on Debian 11</a></li>
<li><hr /></li>
</ul>
</div>
</div>
</div>
</div>
</div>
</aside>
</div>
</div>
</div>
<footer>
<div class="footer">
<div class="pageWidth">
<div class="pageContent">
<div class="skin_branding"><span>Xenforo skin by <a href="http://www.xenfocus.com" rel="nofollow">Xenfocus</a></span></div>
<ul class="footerLinks">
<li><a href="/contribute/">Contribute</a></li>
<li><a href="/community/misc/contact">Contact</a></li>
<li><a href="/community/help/">Help</a></li>
<li><a href="/imprint/">Imprint and Legal Notice</a></li>
<li><a href="#navigation" class="topLink">Top</a></li>
<li><a href="/feed" rel="alternate" class="globalFeed" target="_blank" title="RSS-Feed for Howtoforge">RSS-Feed</a></li>
</ul>
<span class="helper"></span>
</div>
</div>
</div>
<div class="footerLegal">
<div class="pageWidth">
<div class="pageContent">
<ul id="legal">
<li><a href="/community/help/terms">Terms and Rules</a> <a href="https://www.howtoforge.com/community/help/privacy-policy">Privacy Policy</a></li>
</ul>
<div id="copyright"><a href="https://www.howtoforge.com" class="concealed">Howtoforge <span>© projektfarm GmbH.</span></a></div>
<span class="helper"></span>
</div>
</div>
</div>
</footer>
<div style="height:100px;"></div>

<div id="subscriptionModal" class="modal">
<div class="modal-content">
<span class="close">×</span>
<p>This feature is only available to subscribers. Get your subscription <a href="/subscription">here</a>.</p>
</div>
</div>
<script>
//* Modal
var modal = document.getElementById('subscriptionModal');
var span = document.getElementsByClassName("close")[0];
$(".pdf-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
$(".print-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
span.onclick = function() {
	$("#subscriptionModal").css('display', 'none');
}
window.onclick = function(event) {
    if (event.target == modal) {
		$("#subscriptionModal").css('display', 'none');
    }
}
//* Xenforo
jQuery.extend(true, XenForo,
{
	visitor: { user_id: 0 },
	serverTimeInfo:
	{
		now: 1409831907,
		today: 1409781600,
		todayDow: 4
	},
	_lightBoxUniversal: "0",
	_enableOverlays: "1",
	_animationSpeedMultiplier: "1",
	_overlayConfig:
	{
		top: "10%",
		speed: 200,
		closeSpeed: 100,
		mask:
		{
			color: "rgb(0, 0, 0)",
			opacity: "0.6",
			loadSpeed: 200,
			closeSpeed: 100
		}
	},
	_ignoredUsers: [],
	_loadedScripts: {"node_list":true,"node_category":true,"node_forum":true,"sidebar_share_page":true,"wf_default":true,"bbm_buttons":true,"login_bar":true,"twitter":true},
	_cookieConfig: { path: "/", domain: "", prefix: "xf_"},
	_csrfToken: "",
	_csrfRefreshUrl: "/community/login/csrf-token-refresh",
	_jsVersion: "303ae0ca"
});
jQuery.extend(XenForo.phrases,
{
	cancel: "Cancel",

	a_moment_ago:    "A moment ago",
	one_minute_ago:  "1 minute ago",
	x_minutes_ago:   "%minutes% minutes ago",
	today_at_x:      "Today at %time%",
	yesterday_at_x:  "Yesterday at %time%",
	day_x_at_time_y: "%day% at %time%",

	day0: "Sunday",
	day1: "Monday",
	day2: "Tuesday",
	day3: "Wednesday",
	day4: "Thursday",
	day5: "Friday",
	day6: "Saturday",

	_months: "January,February,March,April,May,June,July,August,September,October,November,December",
	_daysShort: "Sun,Mon,Tue,Wed,Thu,Fri,Sat",

	following_error_occurred: "The following error occurred",
	server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
	logging_in: "Logging in",
	click_image_show_full_size_version: "Click this image to show the full-size version.",
	show_hidden_content_by_x: "Show hidden content by {names}"
});

// Facebook Javascript SDK
XenForo.Facebook.appId = "";
XenForo.Facebook.forceInit = true;

/*
document.addEventListener('DOMContentLoaded', function(event) {
  cookieChoices.showCookieConsentBar('Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.',
  'OK');
});
*/

$(document).ready(function() {
	$("a.fancybox").fancybox();
});

</script>

<script>
_bsa.init('custom', 'CKYD55QU', 'placement:howtoforge',
    {
      target: '#sponsor-banner',
      template: `
<a href="##link##" style="background: linear-gradient(-330deg, ##backgroundColor##D9, ##backgroundColor##D9 30%, ##backgroundColor## 70%) #fff;" class="native-banner">
<img class="native-img" src="##logo##">
<div style="color: ##textColor##" class="native-tagline">##tagline##</div>
<div style="color: ##textColor##" class="native-desc">##description##</div>
<div style="color: ##ctaTextColor##; background-color: ##ctaBackgroundColor##;" class="native-cta">##callToAction##</div>
<div style="background-color: ##textColor##B2; color: ##backgroundColor##" class="native-ad">Ad</div>
</a>
`
    }
  );
</script>

<script>
(function() {
  if (typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('fancybar', 'CKYDL27E', 'placement:howtoforgecom');
  }
})();
</script>
<script>
(function() {
  if (typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('custom', 'CEBDK2JM', 'placement:howtoforgecom', {
      target: '.bsa-apiads',
      template:
`
<a href="##statlink##" target="_blank" rel="sponsored nofollow">##company## — ##description##</a>
`
    });
  }
})();
</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2155872-1', 'auto');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');

</script>
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('/detroitchicago/edmonton.webp', '/detroitchicago/edmonton.webp?a=a&cb=2&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('/porpoiseant/jellyfish.webp', '/porpoiseant/jellyfish.webp?a=a&cb=2&shcb=34', false, [], true, false, false, false);
</script>
<script>var _audins_dom="howtoforge_com",_audins_did=178704;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=195-2");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.howtoforge_com,DomainId.178704" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=2&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script></body></html>