<!DOCTYPE html><html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs LoggedOut Sidebar Responsive" xmlns:fb="http://www.facebook.com/2008/fbml"><head><meta charset="utf-8" />
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>!function(){function e(i){return e="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e(i)}__ez.pel=function(){var i=[];function t(t,o,d,_,n,r,a,s){if(__ez.dot.isDefined(t)&&0!=__ez.dot.isAnyDefined(t.getSlotElementId,t.ElementId)){void 0===s&&(s=!1);var p=parseInt(__ez.dot.getTargeting(t,"ap")),f=__ez.dot.getSlotIID(t),u=__ez.dot.getAdUnit(t,s),z=parseInt(__ez.dot.getTargeting(t,"compid")),g=0,c=0,l=function(i){if("undefined"==typeof _ezim_d)return!1;var t=__ez.dot.getAdUnitPath(i).split("/").pop();if("object"===("undefined"==typeof _ezim_d?"undefined":e(_ezim_d))&&_ezim_d.hasOwnProperty(t))return _ezim_d[t];for(var o in _ezim_d)if(o.split("/").pop()===t)return _ezim_d[o];return!1}(t);"object"==e(l)&&(void 0!==l.creative_id&&(c=l.creative_id),void 0!==l.line_item_id&&(g=l.line_item_id)),__ez.dot.isDefined(f,u)&&__ez.dot.isValid(o)&&("0"===f&&!0!==s||""===u||i.push({type:"impression",impression_id:f,domain_id:__ez.dot.getDID(),unit:u,t_epoch:__ez.dot.getEpoch(0),revenue:d,est_revenue:_,ad_position:p,ad_size:"",bid_floor_filled:n,bid_floor_prev:r,stat_source_id:a,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:z,line_item_id:g,creative_id:c,data:__ez.dot.dataToStr(o),is_orig:s||__ez.template.isOrig}))}}function o(){void 0!==document.visibilityState&&"prerender"===document.visibilityState||(__ez.dot.isDefined(i)&&i.length>0&&[i.filter((function(e){return e.is_orig})),i.filter((function(e){return!e.is_orig}))].forEach((function(e){for(;e.length>0;){var i=e[0].is_orig||!1,t=5;t>e.length&&(t=e.length);var o=e.splice(0,t),d=__ez.dot.getURL("/porpoiseant/army.gif")+"?orig="+(!0===i?1:0)+"&sts="+btoa(JSON.stringify(o));(void 0!==window.isAmp&&isAmp||void 0!==window.ezWp&&ezWp)&&void 0!==window._ezaq&&_ezaq.hasOwnProperty("domain_id")&&(d+="&visit_uuid="+_ezaq.visit_uuid),__ez.dot.Fire(d)}})),i=[])}return{Add:t,AddAndFire:function(e,i){t(e,i,0,0,0,0,0),o()},AddAndFireOrig:function(e,i){t(e,i,0,0,0,0,0,!0),o()},AddById:function(e,t,o,d){var _=e.split("/");if(__ez.dot.isDefined(e)&&3===_.length&&__ez.dot.isValid(t)){var n=_[0],r={type:"impression",impression_id:_[2],domain_id:__ez.dot.getDID(),unit:n,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(t),is_orig:o||__ez.template.isOrig};void 0!==d&&(r.revenue=d),i.push(r)}},Fire:o,GetPixels:function(){return i}}}()}();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=195-2&cb=6', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=195-2&cb=5', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=195-2&cb=7', false, [], true, false, true, false);</script>
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<base href="https://www.howtoforge.com" />
<script>
			var _b = document.getElementsByTagName('base')[0], _bH = "https://www.howtoforge.com/how-to-deploy-ghost-cms-on-rocky-linux-9/";
			if (_b && _b.href != _bH) _b.href = _bH;
		</script>
<title>How to deploy Ghost CMS on Rocky Linux 9</title>
<meta name="description" content="Ghost is an open-source blogging platform to help you create a professional-looking blog. This tutorial will explore how to install Ghost CMS using Ng... " />
<meta property="og:title" content="How to deploy Ghost CMS on Rocky Linux 9" />
<meta property="og:description" content="Ghost is an open-source blogging platform to help you create a professional-looking blog. This tutorial will explore how to install Ghost CMS using Ng... " />
<meta property="og:site_name" content="HowtoForge" />
<meta property="og:type" content="article" />
<meta property="og:image" content="https://www.howtoforge.com/images/featured/rocky-linux-ghost-cms.png" />
<meta property="og:image:secure_url" content="https://www.howtoforge.com/images/featured/rocky-linux-ghost-cms.png" />
<meta property="og:image:alt" content="How to deploy Ghost CMS on Rocky Linux 9" />
<meta name="twitter:image" content="https://www.howtoforge.com/images/featured/rocky-linux-ghost-cms.png" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@howtoforgecom" />
<meta name="twitter:creator" content="@howtoforgecom" />
<meta name="twitter:title" content="How to deploy Ghost CMS on Rocky Linux 9" />
<meta name="twitter:description" content="Ghost is an open-source blogging platform to help you create a professional-looking blog. This tutorial will explore how to install Ghost CMS using Ng... " />
<link rel="alternate" href="https://www.howtoforge.com/how-to-deploy-ghost-cms-on-rocky-linux-9/" hreflang="en" />
<link rel="canonical" href="https://www.howtoforge.com/how-to-deploy-ghost-cms-on-rocky-linux-9/" />
<link rel="amphtml" href="https://www.howtoforge.com/how-to-deploy-ghost-cms-on-rocky-linux-9/amp/" />
<script type="application/ld+json">
{
  "@context" : "http://schema.org",
  "@type" : "Article",
  "name" : "How to deploy Ghost CMS on Rocky Linux 9",
  "author" : {
    "@type" : "Person",
    "name" : "Navjot Singh"
  },
  "articleSection" : "linux,nginx,server,web server",
  "url" : "https://www.howtoforge.com/how-to-deploy-ghost-cms-on-rocky-linux-9/",
  "publisher" : {
    "@type" : "Organization",
    "name" : "Howtoforge"
  }
}
</script>
<noscript><style>.JsOnly, .jsOnly { display: none !important; }</style></noscript>

<link rel="stylesheet" href="/themes/howtoforge/icons/css/font-awesome.min.css" />

<link href="/themes/howtoforge/fonts/opensans.css?family=Open+Sans:400,700" rel="stylesheet" type="text/css" />
<link href="/themes/howtoforge/templates/xf.css" rel="stylesheet" />
<script src="/js/jquery/jquery-1.11.3.min.js"></script>

<script src="/themes/howtoforge/js/xenforo/xenforo.js?_v=303ae0ca"></script>

<script src="/themes/howtoforge/js/bbm/zloader.js?_v=303ae0ca"></script>
<script type="text/javascript" src="/js/fancybox/jquery.mousewheel-3.0.4.pack.js"></script>
<script type="text/javascript" src="/js/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
<link rel="stylesheet" type="text/css" href="/js/fancybox/jquery.fancybox-1.3.4.css" media="screen" />
<link href="/themes/howtoforge/templates/style.min.css" rel="stylesheet" />
<link rel="alternate" type="application/rss+xml" title="RSS-Feed für Howtoforge" href="/feed.rss" />
<script src="/js/tinymce_4.1.7/tinymce.min.js"></script>
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/skin.min.css" as="style" />
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/content.min.css" as="style" />
<link rel="preload" href="/themes/howtoforge/css/custom.css" as="style" />
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/fonts/tinymce.woff" as="font" crossorigin="anonymous" />

<script type="text/javascript">
var gaProperty = 'UA-2155872-1';
var disableStr = 'ga-disable-' + gaProperty;
if (document.cookie.indexOf(disableStr + '=true') > -1) {
window[disableStr] = true;
}
function gaOptout() {
document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
window[disableStr] = true;
alert('Google Ananlyitics tracking has been disabled in this browser.');
}
</script>
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
	googletag.defineSlot('/1030080/howtoforge_com_list_sidebar_top', [300, 250], 'div-gpt-ad-1527185271042-4').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_list_content_middle', [[300, 250], [336, 280]], 'div-gpt-ad-1527185271042-5').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_a_300x250', [300, 250], 'div-gpt-ad-1527185271042-6').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_b_300x250', [300, 250], 'div-gpt-ad-1527185271042-7').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_leaderboard_b_728x90', [728, 90], 'div-gpt-ad-1527185271042-1').addService(googletag.pubads());
	googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-3043223216276099",
          enable_page_level_ads: true
     });
</script>


<script type="text/javascript" src="//m.servedby-buysellads.com/monetization.js"></script>

<script type="text/javascript">var ezouid = "1";</script><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script>
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 178704;
var ezdomain = 'howtoforge.com';
var ezoicSearchable = 1;
</script>


<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":178704,"domain_test_group":20230804,"engaged_time_visit":0,"ezcache_level":2,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"bb5a8b2f-0e21-440e-5d2c-2b5be7948186","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":61057,"response_time_orig":7,"serverid":"18.208.188.188:3119","state":"VA","t_epoch":1671575496,"template_id":126,"time_on_site_visit":0,"url":"https://www.howtoforge.com/how-to-deploy-ghost-cms-on-rocky-linux-9/","user_id":0,"word_count":3211,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_178704=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["bb5a8b2f-0e21-440e-5d2c-2b5be7948186", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>
<body>
<div id="loginBar">
<div class="pageWidth">
<div class="pageContent">
<h3 id="loginBarHandle">
<label for="LoginControl"><a href="https://forum.howtoforge.com/login/" class="concealed noOutline">Log in or Sign up</a></label>
</h3>
<span class="helper"></span>
</div>
</div>
</div>
<header>
<div id="header">
<div id="logoBlock">
<div class="pageWidth">
<div class="pageContent">
<div id="logo"><a href="/">
<span></span>
<img src="/images/howtoforge_logo_trans.gif" alt="Howtoforge" style="margin-left:20px;" />
</a></div>
<span class="helper"></span>
</div>
</div>
</div>
<div id="navigation" class="pageWidth withSearch">
<div class="pageContent">
<nav>
<div class="navTabs">
<ul class="publicTabs">

<li class="navTab forums selected">
<a href="/" class="navLink">Tutorials</a>
<div class="tabLinks forumsTabLinks">
<ul class="secondaryContent blockLinksList">
<li><a href="/search/">Tutorial search</a></li>
</ul>
</div>
</li>
<li class="navTab forums PopupClosed">
<a href="/tutorials/" class="navLink">Tags</a>
</li>
<li class="navTab forums PopupClosed"><a href="https://forum.howtoforge.com/" class="navLink">Forums</a></li>
<li class="navTab forums PopupClosed"><a href="/linux-commands/" class="navLink">Linux Commands</a></li>
<li class="navTab forums PopupClosed"><a href="/subscription/" class="navLink">Subscribe</a></li>
</ul>
</div>
<span class="helper"></span>
</nav>
</div>
</div>
<div id="searchBar" class="pageWidth">
<span id="QuickSearchPlaceholder" title=" Search..."> Search</span>
<fieldset id="QuickSearch">
<form action="/" method="post" class="formPopup">
<div class="primaryControls">

<input type="search" name="q" value="" class="textCtrl" placeholder="Search..." results="0" title="Enter your search and hit enter..." id="QuickSearchQuery" />

</div>
<input type="hidden" name="_xfToken" value="" />
</form>
</fieldset>
</div>
</div>
</header>
<div id="content" class="forum_list">
<div class="pageWidth">
<div class="pageContent">

<div class="mainContainer">
<div class="mainContent">

<div class="breadBoxTop">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://schema.org/BreadcrumbList">
<span itemprop="itemListElement" itemscope="" itemtype="http://schema.org/ListItem">
<a href="/" class="crumb" rel="up" itemprop="item"><span itemprop="name">Home</span></a>
<meta itemprop="position" content="1" />
</span>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://schema.org/BreadcrumbList">
<span itemprop="itemListElement" itemscope="" itemtype="http://schema.org/ListItem">
<a href="/how-to-deploy-ghost-cms-on-rocky-linux-9/" class="crumb" rel="up" itemprop="item"><span itemprop="name">How to deploy Ghost CMS on Rocky Linux 9</span></a>
<meta itemprop="position" content="2" />
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</span></fieldset>
</nav>
</div>

<div id="htfContentPage">
<div class="bsa-apiads"></div>
<article>
<h1>How to deploy Ghost CMS on Rocky Linux 9</h1>
<div class="contributeEdit" style="float:right; width:450px; max-width:100%;">
<div id="tocContainer">
<h3>On this page</h3>
<ol class="toc">
<li><a href="#prerequisites">Prerequisites</a></li>
<li><a href="#step-1---configure-firewall">Step 1 - Configure Firewall</a></li>
<li><a href="#step-2---install-nginx">Step 2 - Install Nginx</a></li>
<li><a href="#step-3---install-nodejs">Step 3 - Install Node.js</a></li>
<li><a href="#step-4---install-mysql">Step 4 - Install MySQL</a></li>
<li><a href="#step-5---install-ghost">Step 5 - Install Ghost</a>
<ol>
<li><a href="#install-ghost-cli">Install Ghost-CLI</a></li>
<li><a href="#prepare-ghost-directory">Prepare Ghost Directory</a></li>
<li><a href="#install-ghost">Install Ghost</a></li>
</ol>
</li>
<li><a href="#step-6---install-ssl">Step 6 - Install SSL</a></li>
<li><a href="#step-7---configure-nginx">Step 7 - Configure Nginx</a></li>
<li><a href="#step-8---configure-selinux">Step 8 - Configure SELinux</a></li>
<li><a href="#step-9---run-the-site">Step 9 - Run the Site</a></li>
<li><a href="#step-10---complete-setup">Step 10 - Complete the Setup</a></li>
<li><a href="#step-11---configure-mailer">Step 11 - Configure Mailer</a></li>
<li><a href="#step-12---update-ghost">Step 12 - Update Ghost</a></li>
<li><a href="#conclusion">Conclusion</a></li>
</ol>
</div>
</div>
<p>Ghost is an open-source blogging platform to help you create a professional-looking blog. It was launched in 2013 as an alternative to WordPress because it was getting overly complex. It is written in JavaScript and is powered by the Node.js library.</p>
<p>This tutorial will explore how to install Ghost CMS using Nginx and MySQL on a server powered by Rocky Linux 9. We will use the Nginx server to host the blog and the Let&#39;s Encrypt SSL certificate to secure our installation.</p>
<h2 id="prerequisites">Prerequisites</h2>
<ul>
<li>
<p>A server running Rocky Linux 9.</p>
</li>
<li>
<p>A non-root user with sudo privileges.</p>
</li>
<li>
<p>A fully qualified domain name (FQDN) pointing to your server. For our purposes, we will use <code class="system">ghost.example.com</code> as the domain name.</p>
</li>
<li>
<p>Make sure everything is updated.</p>
<pre class="command">$ sudo dnf update
</pre>
</li>
<li>
<p>Install basic utility packages. Some of them may already be installed.</p>
<pre class="command">$ sudo dnf install wget curl nano unzip yum-utils -y
</pre>
</li>
</ul>
<h2 id="step-1---configure-firewall">Step 1 - Configure Firewall</h2>
<p>The first step is to configure the firewall. Rocky Linux uses Firewalld Firewall. Check the firewall&#39;s status.</p>
<pre class="command">$ sudo firewall-cmd --state
running
</pre>
<p>The firewall works with different zones, and the public zone is the default one that we will use. List all the services and ports active on the firewall.</p>
<pre class="command">$ sudo firewall-cmd --permanent --list-services
</pre>
<p>It should show the following output.</p>
<pre class="command">cockpit dhcpv6-client ssh
</pre>
<p>Wiki.js needs HTTP and HTTPS ports to function. Open them.</p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;">

<div id="div-gpt-ad-1527185271042-6" style="height:250px; width:300px;">
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-6'); });
</script>
</div>
</div>
<pre class="command">$ sudo firewall-cmd --add-service=http --permanent
$ sudo firewall-cmd --add-service=https --permanent
</pre>
<p>Reload the firewall to apply the changes.</p>
<pre class="command">$ sudo firewall-cmd --reload
</pre>
<h2 id="step-2---install-nginx">Step 2 - Install Nginx</h2>
<p>Rocky Linux 9 ships with an older version of Nginx. You need to download the official Nginx repository to install the latest version.</p>
<p>Create and open the <code class="system">/etc/yum.repos.d/nginx.repo</code> file for creating the official Nginx repository.</p>
<pre class="command">$ sudo nano /etc/yum.repos.d/nginx.repo
</pre>
<p>Paste the following code in it.</p>
<pre class="command">[nginx-stable]
name=nginx stable repo
baseurl=http://nginx.org/packages/centos/$releasever/$basearch/
gpgcheck=1
enabled=1
gpgkey=https://nginx.org/keys/nginx_signing.key
module_hotfixes=true

[nginx-mainline]
name=nginx mainline repo
baseurl=http://nginx.org/packages/mainline/centos/$releasever/$basearch/
gpgcheck=1
enabled=0
gpgkey=https://nginx.org/keys/nginx_signing.key
module_hotfixes=true
</pre>
<p>Save the file by pressing <strong>Ctrl + X</strong> and entering <strong>Y</strong> when prompted.</p>
<p>Install the Nginx server.</p>
<pre class="command">$ sudo dnf install nginx -y
</pre>
<p>Verify the installation.</p>
<pre class="command">$ nginx -v
nginx version: nginx/1.22.1
</pre>
<p>Enable and start the Nginx server.</p>
<pre class="command">$ sudo systemctl enable nginx --now
</pre>
<p>Check the status of the server.</p>
<pre class="command">$ sudo systemctl status nginx
? nginx.service - nginx - high performance web server
     Loaded: loaded (/usr/lib/systemd/system/nginx.service; enabled; vendor preset: disabled)
     Active: active (running) since Tue 2022-10-25 08:27:47 UTC; 2s ago
       Docs: http://nginx.org/en/docs/
    Process: 1650 ExecStart=/usr/sbin/nginx -c /etc/nginx/nginx.conf (code=exited, status=0/SUCCESS)
   Main PID: 1651 (nginx)
      Tasks: 2 (limit: 5912)
     Memory: 1.9M
        CPU: 7ms
     CGroup: /system.slice/nginx.service
             ??1651 &#34;nginx: master process /usr/sbin/nginx -c /etc/nginx/nginx.conf&#34;
             ??1652 &#34;nginx: worker process&#34;

Oct 25 08:27:47 ghost.example.com systemd[1]: Starting nginx - high performance web server...
</pre>
<h2 id="step-3---install-nodejs">Step 3 - Install Node.js</h2>
<p>Ghost Installer needs Nodejs to work. Run the following commands to install Node 16.</p>
<pre class="command">$ curl -fsSL https://rpm.nodesource.com/setup_16.x | sudo bash -
</pre>
<p>Install Node.</p>
<pre class="command">$ sudo dnf install -y nodejs
</pre>
<p>Verify Node installation.</p>
<pre class="command">$ node --version
v16.18.0
</pre>
<p>At the time of writing this tutorial, Node 18 is out and is the LTS version. Ghost is yet to add support for it. Do keep a check on the <a href="https://ghost.org/docs/faq/node-versions/">Ghost document about Node versions</a> for the latest Node version supported. When Ghost adds support for Node 18, install Node 18 using the following commands instead.</p>
<pre class="command">$ curl -fsSL https://rpm.nodesource.com/setup_18.x | sudo bash -
$ sudo dnf install -y nodejs
</pre>
<h2 id="step-4---install-mysql">Step 4 - Install MySQL</h2>
<p>Rocky Linux 9 ships with the latest version of MySQL. You can install it with a single command.</p>
<pre class="command">$ sudo dnf install mysql-server
</pre>
<p>Check the version of MySQL.</p>
<pre class="command">$ mysql --version
mysql  Ver 8.0.30 for Linux on x86_64 (Source distribution)
</pre>
<p>Enable and start the MySQL service.</p>
<pre class="command">$ sudo systemctl enable mysqld --now
</pre>
<p>Check the service status.</p>
<pre class="command">$ sudo systemctl status mysqld
? mysqld.service - MySQL 8.0 database server
     Loaded: loaded (/usr/lib/systemd/system/mysqld.service; enabled; vendor preset: disabled)
     Active: active (running) since Tue 2022-10-25 09:00:26 UTC; 3s ago
    Process: 2920 ExecStartPre=/usr/libexec/mysql-check-socket (code=exited, status=0/SUCCESS)
    Process: 2942 ExecStartPre=/usr/libexec/mysql-prepare-db-dir mysqld.service (code=exited, status=0/SUCCESS)
   Main PID: 3021 (mysqld)
     Status: &#34;Server is operational&#34;
      Tasks: 39 (limit: 5912)
     Memory: 404.4M
        CPU: 4.686s
     CGroup: /system.slice/mysqld.service
             ??3021 /usr/libexec/mysqld --basedir=/usr

Oct 25 09:00:18 ghost.example.com systemd[1]: Starting MySQL 8.0 database server...
Oct 25 09:00:18 ghost.example.com mysql-prepare-db-dir[2942]: Initializing MySQL database
Oct 25 09:00:26 ghost.example.com systemd[1]: Started MySQL 8.0 database server.
</pre>
<p>You can log in to the MySQL shell using Unix authentication by default. But you cannot run the security setup wizard. Therefore, the following step is necessary for MySQL versions 8.0.28 and above. Enter the MySQL Shell.</p>
<pre class="command">$ sudo mysql
</pre>
<p>Run the following command to set the password for your root user. Make sure it has a mix of numbers, uppercase, lowercase, and special characters.</p>
<pre class="command">mysql&gt; ALTER USER &#39;root&#39;@&#39;localhost&#39; IDENTIFIED WITH mysql_native_password BY &#39;YourPassword12!&#39;;
</pre>
<p>Exit the shell. The caveat to this step is that you can no longer log in to the MySQL shell using Unix authentication.</p>
<pre class="command">mysql&gt; exit
</pre>
<p>Run the MySQL secure install script.</p>
<pre class="command">$ sudo mysql_secure_installation
</pre>
<p>You will be asked to install the Validate Password Component. It checks the strength of passwords used in MySQL. Press <strong>Y</strong> to install it.</p>
<pre class="command">Securing the MySQL server deployment.

Connecting to MySQL using a blank password.

VALIDATE PASSWORD COMPONENT can be used to test passwords
and improve security. It checks the strength of password
and allows the users to set only those passwords which are
secure enough. Would you like to setup VALIDATE PASSWORD component?

Press y|Y for Yes, any other key for No: Y
</pre>
<p>Next, you will be asked to set the level of the password validation policy. Choose <strong>2</strong> as it is the strongest one. You will then be asked to create a root password. Enter a password with the given requirements. And when asked whether you want to continue with the password, press <strong>Y</strong> to proceed.</p>
<pre class="command">There are three levels of password validation policy:

LOW    Length &gt;= 8
MEDIUM Length &gt;= 8, numeric, mixed case, and special characters
STRONG Length &gt;= 8, numeric, mixed case, special characters and dictionary                  file

Please enter 0 = LOW, 1 = MEDIUM and 2 = STRONG: 2
Please set the password for root here.

New password: 

Re-enter new password: 

Estimated strength of the password: 100 
Do you wish to continue with the password provided?(Press y|Y for Yes, any other key for No) : Y
</pre>
<p>Finally, press <strong>Y</strong> to remove anonymous users, disallow remote root logins, remove the test database, and reload the privilege tables.</p>
<pre class="command">By default, a MySQL installation has an anonymous user,
allowing anyone to log into MySQL without having to have
a user account created for them. This is intended only for
testing, and to make the installation go a bit smoother.
You should remove them before moving into a production
environment.

Remove anonymous users? (Press y|Y for Yes, any other key for No) : Y
Success.


Normally, root should only be allowed to connect from
&#39;localhost&#39;. This ensures that someone cannot guess at
the root password from the network.

Disallow root login remotely? (Press y|Y for Yes, any other key for No) : Y
Success.

By default, MySQL comes with a database named &#39;test&#39; that
anyone can access. This is also intended only for testing,
and should be removed before moving into a production
environment.


Remove test database and access to it? (Press y|Y for Yes, any other key for No) : Y
 - Dropping test database...
Success.

 - Removing privileges on test database...
Success.

Reloading the privilege tables will ensure that all changes
made so far will take effect immediately.

Reload privilege tables now? (Press y|Y for Yes, any other key for No) : Y
Success.

All done!
</pre>
<p>This completes the process of installing and securing MySQL.</p>
<h2 id="step-5---install-ghost">Step 5 - Install Ghost</h2>
<p>The Ghost installation will comprise three components - Ghost-CLI command line tool that installs and manages updates to the Ghost blog and the blog package itself.</p>
<h3 id="install-ghost-cli">Install Ghost-CLI</h3>
<p>Run the following command to install the Ghost-CLI tool. Ignore any warnings you receive during the process.</p>
<pre class="command">$ sudo npm install <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="8ee9e6e1fdfaa3ede2e7cee2effaebfdfa">[email&#160;protected]</a> -g
</pre>
<h3 id="prepare-ghost-directory">Prepare Ghost Directory</h3>
<p>Create the Ghost root directory.</p>
<pre class="command">$ sudo mkdir -p /var/www/html/ghost
</pre>
<p>Set the ownership of the directory to the current user.</p>
<pre class="command">$ sudo chown $USER:$USER /var/www/html/ghost
</pre>
<p>Set the correct directory permissions.</p>
<pre class="command">$ sudo chmod 755 /var/www/html/ghost
</pre>
<p>Switch to the Ghost directory.</p>
<pre class="command">$ cd /var/www/html/ghost
</pre>
<h3 id="install-ghost">Install Ghost</h3>
<p>Installing Ghost is a single command process.</p>
<pre class="command">$ ghost install
</pre>
<p>During the installation, the CLI tool will ask a number of questions to configure the blog.</p>
<ul>
<li>At the time of writing this tutorial, Ghost-CLI doesn&#39;t support any other OS apart from Ubuntu. It will ask if you still want to continue with the installation. Press <strong>Y</strong> to continue.</li>
<li><strong>Blog URL</strong>: Enter your complete blog URL along with the https protocol. (<code class="system">https://ghost.example.com</code>)</li>
<li><strong>MySQL Hostname</strong>: Press Enter to use the default value of <code class="system">localhost</code> since our Ghost install and MySQL are on the same server.</li>
<li><strong>MySQL Username</strong>: Enter <code class="system">root</code> as your MySQL username.</li>
<li><strong>MySQL Password</strong>: Enter your root password created before.</li>
<li><strong>Ghost database name</strong>: Give a name for your Ghost database. (<code class="system">ghostdb</code>)</li>
<li><strong>Sudo password</strong>: Enter your system&#39;s sudo password to perform elevated commands.</li>
<li><strong>Set up a ghost MySQL user?</strong>: The installer will ask if you want to create a separate MySQL user for Ghost. Press <strong>Y</strong> to proceed.</li>
<li><strong>Set up Nginx?</strong>: Usually, Ghost-CLI detects your Nginx installation and automatically configures it for your blog. But as of now, it can&#39;t detect our Nginx install. Hence, the installer will automatically skip this step. We will configure Nginx manually.</li>
<li><strong>Set up SSL?</strong>: Since it skipped over the Nginx configuration, the CLI tool will also skip setting up an SSL.</li>
<li><strong>Set up systemd?</strong>: Ghost will ask if you want to set up a system service for Ghost. Press <strong>Y</strong> to proceed.</li>
<li><strong>Start Ghost?</strong>: Press <strong>Y</strong> to start your Ghost installation. The service will start but we will need to configure Nginx and SSL to make it work.</li>
</ul>
<h2 id="step-6---install-ssl">Step 6 - Install SSL</h2>
<p>Before proceeding, we need to install the Certbot tool and an SSL certificate for our domain.</p>
<p>To install Certbot, we will use the Snapd package installer. Snapd always carries the latest stable version of Certbot, which you should use.</p>
<p>Snapd tool requires the Epel repository to work.</p>
<pre class="command">$ sudo dnf install epel-release -y
</pre>
<p>We will use Snapd to install Certbot. Install Snapd.</p>
<pre class="command">$ sudo dnf install snapd -y
</pre>
<p>Enable and Start the Snap service.</p>
<pre class="command">$ sudo systemctl enable snapd.socket --now
</pre>
<p>Create necessary links for Snapd to work.</p>
<pre class="command">$ sudo ln -s /var/lib/snapd/snap /snap
$ echo &#39;export PATH=$PATH:/var/lib/snapd/snap/bin&#39; | sudo tee -a /etc/profile.d/snapd.sh
</pre>
<p>Ensure that your version of snapd is up to date.</p>
<pre class="command">$ sudo snap install core 
$ sudo snap refresh core
</pre>
<p>Install Certbot.</p>
<pre class="command">$ sudo snap install --classic certbot
</pre>
<p>Use the following command to ensure that the Certbot command can be run by creating a symbolic link to the <code class="system">/usr/bin</code> directory.</p>
<pre class="command">$ sudo ln -s /snap/bin/certbot /usr/bin/certbot
</pre>
<p>Generate an SSL certificate.</p>
<pre class="command">$ sudo certbot certonly --nginx --agree-tos --no-eff-email --staple-ocsp --preferred-challenges http -m <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="80eee1ede5c0e5f8e1edf0ece5aee3efed">[email&#160;protected]</a> -d ghost.example.com
</pre>
<p>The above command will download a certificate to the <code class="system">/etc/letsencrypt/live/ghost.example.com</code> directory on your server.</p>
<p>Generate a <strong>Diffie-Hellman group</strong> certificate.</p>
<pre class="command">$ sudo openssl dhparam -dsaparam -out /etc/ssl/certs/dhparam.pem 4096
</pre>
<p>Do a dry run of the process to check whether the SSL renewal is working fine.</p>
<pre class="command">$ sudo certbot renew --dry-run
</pre>
<p>If you see no errors, you are all set. Your certificate will renew automatically.</p>
<h2 id="step-7---configure-nginx">Step 7 - Configure Nginx</h2>
<p>Create and open the file <code class="system">/etc/nginx/conf.d/ghost.conf</code> for editing.</p>
<pre class="command">$ sudo nano /etc/nginx/conf.d/ghost.conf
</pre>
<p>Paste the following code in the <code class="system">ghost.conf</code> file. Replace all instances of <code class="system">ghost.example.com</code> with your domain.</p>
<pre class="command">## enforce HTTPS
server {
  listen 80;
  listen [::]:80;
  server_name ghost.example.com;
  return 301 https://$server_name$request_uri;
}

server {
  listen 443 ssl http2;
  listen [::]:443 ssl http2;
  server_name ghost.example.com;

  access_log /var/log/nginx/ghost.access.log;
  error_log /var/log/nginx/ghost.error.log;
  client_max_body_size 20m;

  http2_push_preload on; # Enable HTTP/2 Server Push

  ssl_certificate     /etc/letsencrypt/live/ghost.example.com/fullchain.pem;
  ssl_certificate_key /etc/letsencrypt/live/ghost.example.com/privkey.pem;
  ssl_trusted_certificate /etc/letsencrypt/live/ghost.example.com/chain.pem;
  ssl_session_timeout 1d;

  # Enable TLS versions (TLSv1.3 is required upcoming HTTP/3 QUIC).
  ssl_protocols TLSv1.2 TLSv1.3;

  # Enable TLSv1.3&#39;s 0-RTT. Use $ssl_early_data when reverse proxying to
  # prevent replay attacks.
  #
  # @see: https://nginx.org/en/docs/http/ngx_http_ssl_module.html#ssl_early_data
  ssl_early_data on;

  ssl_ciphers &#39;ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:ECDHE-ECDSA-AES256-SHA384:ECDHE-RSA-AES256-SHA384&#39;;
  ssl_prefer_server_ciphers on;
  ssl_ecdh_curve X25519:prime256v1:secp384r1:secp521r1;
  ssl_session_cache shared:SSL:50m;
  ssl_session_tickets off;

  # OCSP Stapling ---
  # fetch OCSP records from URL in ssl_certificate and cache them
  ssl_stapling on;
  ssl_stapling_verify on;
  ssl_dhparam /etc/ssl/certs/dhparam.pem;

  add_header X-Early-Data $tls1_3_early_data;

  location / {
    proxy_set_header Host $http_host;
    proxy_set_header X-Real-IP $remote_addr;
    proxy_set_header X-Forwarded-Proto https;
    proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
    proxy_pass http://localhost:2368;
  }
}

# This block is useful for debugging TLS v1.3. Please feel free to remove this
# and use the `$ssl_early_data` variable exposed by NGINX directly should you
# wish to do so.
map $ssl_early_data $tls1_3_early_data {
  &#34;~.&#34; $ssl_early_data;
  default &#34;&#34;;
}
</pre>
<p>The above configuration will redirect all HTTP requests to HTTPS and will serve as a proxy for Ghost service to serve it via your domain.</p>
<p>Save the file by pressing <strong>Ctrl + X</strong> and entering <strong>Y</strong> when prompted.</p>
<p>Open the file <code class="system">/etc/nginx/nginx.conf</code> for editing.</p>
<pre class="command">$ sudo nano /etc/nginx/nginx.conf
</pre>
<p>Add the following line before the line <code class="system">include /etc/nginx/conf.d/*.conf;</code>.</p>
<pre class="command">server_names_hash_bucket_size  64;
</pre>
<p>Save the file by pressing <strong>Ctrl + X</strong> and entering <strong>Y</strong> when prompted.</p>
<p>Verify your Nginx configuration.</p>
<pre class="command">$ sudo nginx -t
</pre>
<p>If you see no errors, it means you are good to go. Reload the Nginx server.</p>
<pre class="command">$ sudo systemctl reload nginx
</pre>
<h2 id="step-8---configure-selinux">Step 8 - Configure SELinux</h2>
<p>Allow Nginx to connect to the network.</p>
<pre class="command">$ sudo setsebool -P httpd_can_network_connect 1
</pre>
<h2 id="step-9---run-the-site">Step 9 - Run the Site</h2>
<p>Now, you can verify your installation by opening <code class="system">https://ghost.example.com</code> in your web browser. You will get the following page indicating a successful installation.</p>
<p><a class="fancybox" id="img-ghost-homepage" href="https://www.howtoforge.com/images/how_to_deploy_ghost_cms_on_rocky_linux_9/big/ghost-homepage.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_deploy_ghost_cms_on_rocky_linux_9/ghost-homepage.png" referrerpolicy="no-referrer" alt="Ghost Homepage" width="750" height="583" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<h2 id="step-10---complete-setup">Step 10 - Complete the Setup</h2>
<p>To finish setting up your Ghost blog, visit <code class="system">https://ghost.example.com/ghost</code> in your browser. The extra <code class="system">/ghost</code> at the end of your blog&#39;s domain redirects you to Ghost&#39;s Admin Panel or, in this case, the setup since you are accessing it for the first time.</p>
<p>You will be required to create your Administrator account and choose a blog title.</p>
<p><a class="fancybox" id="img-ghost-setup" href="https://www.howtoforge.com/images/how_to_deploy_ghost_cms_on_rocky_linux_9/big/ghost-setup.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_deploy_ghost_cms_on_rocky_linux_9/ghost-setup.png" referrerpolicy="no-referrer" alt="Ghost Setup Details" width="576" height="750" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Enter your details and click the <strong>Create account &amp; start publishing</strong> button to proceed.</p>
<p>Next, you will be taken to the following screen, where you are given options such as writing your first post, customizing your site, and importing members.</p>
<p><a class="fancybox" id="img-ghost-installer-suggestions" href="https://www.howtoforge.com/images/how_to_deploy_ghost_cms_on_rocky_linux_9/big/ghost-installer-suggestions.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_deploy_ghost_cms_on_rocky_linux_9/ghost-installer-suggestions.png" referrerpolicy="no-referrer" alt="Ghost Installer Suggestions" width="750" height="580" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>We will choose the <strong>Explore Ghost admin</strong> to explore and go to the dashboard directly. At the end of the setup, you will be greeted with the Ghost&#39;s Administration panel.</p>
<p><a class="fancybox" id="img-ghost-admin-dashboard" href="https://www.howtoforge.com/images/how_to_deploy_ghost_cms_on_rocky_linux_9/big/ghost-admin-dashboard.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_deploy_ghost_cms_on_rocky_linux_9/ghost-admin-dashboard.png" referrerpolicy="no-referrer" alt="Ghost Admin Dashboard" width="750" height="597" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>If you want to switch to dark mode, you can do so by clicking on the toggle switch next to the settings gear button at the bottom of the settings page.</p>
<p><a class="fancybox" id="img-ghost-dark-mode-toggle" href="https://www.howtoforge.com/images/how_to_deploy_ghost_cms_on_rocky_linux_9/big/ghost-dark-mode-toggle.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_deploy_ghost_cms_on_rocky_linux_9/ghost-dark-mode-toggle.png" referrerpolicy="no-referrer" alt="Ghost Dark Mode Toggle" width="177" height="73" /></a></p>
<p>Switch to the Posts page and you will see a default post. You can unpublish or delete it and start posting.</p>
<p><a class="fancybox" id="img-ghost-posts-panel" href="https://www.howtoforge.com/images/how_to_deploy_ghost_cms_on_rocky_linux_9/big/ghost-posts-panel.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_deploy_ghost_cms_on_rocky_linux_9/ghost-posts-panel.png" referrerpolicy="no-referrer" alt="Ghost Posts Panel" width="750" height="568" style="display: block; margin-left: auto; margin-right: auto;" /></a>)</p>
<h2 id="step-11---configure-mailer">Step 11 - Configure Mailer</h2>
<p>Ghost not only acts as a blogging platform but also as a newsletter manager. For day-to-day operations, you can use any transactional mail service to work with Ghost for sending mail. But if you want to send newsletters via Ghost, the only official bulk mailer supported is Mailgun. You can use a different newsletter service too but for that, you will need to use the Zapier integration feature of Ghost.</p>
<p>Let us first configure an SMTP service for transactional emails. For this open the file <code class="system">/var/www/html/ghost/config.production.json</code> file for editing.</p>
<pre class="command">$ nano /var/www/html/ghost/config.production.json
</pre>
<p>Find the following lines.</p>
<pre class="command"> &#34;mail&#34;: {
    &#34;transport&#34;: &#34;Direct&#34;
  },
</pre>
<p>Replace them with the following code.</p>
<pre class="command">&#34;mail&#34;: {
    &#34;from&#34;: &#34;&#39;Acme Support&#39; <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="6e000f030b2e0b160f031e020b400d0103">[email&#160;protected]</a>&#34;,
    &#34;transport&#34;: &#34;SMTP&#34;,
    &#34;options&#34;: {
        &#34;host&#34;: &#34;YOUR-SES-SERVER-NAME&#34;,
        &#34;port&#34;: 465,
        &#34;service&#34;: &#34;SES&#34;,
        &#34;auth&#34;: {
            &#34;user&#34;: &#34;YOUR-SES-SMTP-ACCESS-KEY-ID&#34;,
            &#34;pass&#34;: &#34;YOUR-SES-SMTP-SECRET-ACCESS-KEY&#34;
        }
    }
},
</pre>
<p>Here we are using the Amazon SES Mail service since it is very cheap and lifetime free if you are using their EC2 service.</p>
<p>If you want to use their newsletter service using Mailgun, enter the following code instead.</p>
<pre class="command">&#34;mail&#34;: {
  &#34;from&#34;: &#34;&#39;Acme Support&#39; <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="0668676b6346637e676b766a632865696b">[email&#160;protected]</a>&#34;,
  &#34;transport&#34;: &#34;SMTP&#34;,
  &#34;options&#34;: {
    &#34;service&#34;: &#34;Mailgun&#34;,
    &#34;host&#34;: &#34;smtp.mailgun.org&#34;,
    &#34;port&#34;: 587,
    &#34;secure&#34;: true,
    &#34;auth&#34;: {
      &#34;user&#34;: &#34;<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="a2d2cdd1d6cfc3d1d6c7d0e2c7dac3cfd2cec78ccfc3cbcec5d7cc8ccdd0c5">[email&#160;protected]</a>&#34;,
      &#34;pass&#34;: &#34;1234567890&#34;
    }
  }
},
</pre>
<p>Save the file by pressing <strong>Ctrl + X</strong> and entering <strong>Y</strong> when prompted.</p>
<p>Once finished, restart the Ghost application for the changes to take effect.</p>
<pre class="command">$ ghost restart
</pre>
<p>To configure the newsletter settings, visit the <strong>Settings &gt;&gt; Email newsletter</strong> section.</p>
<p><a class="fancybox" id="img-ghost-newsletter-settings" href="https://www.howtoforge.com/images/how_to_deploy_ghost_cms_on_rocky_linux_9/big/ghost-newsletter-settings.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_deploy_ghost_cms_on_rocky_linux_9/ghost-newsletter-settings.png" referrerpolicy="no-referrer" alt="Ghost email newsletter settings" width="750" height="664" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Click on the <strong>Mailgun configuration</strong> link to expand.</p>
<p>Fill in your Mailgun Region, domain, and API key.</p>
<p><a class="fancybox" id="img-ghost-mailgun-settings" href="https://www.howtoforge.com/images/how_to_deploy_ghost_cms_on_rocky_linux_9/big/ghost-mailgun-settings.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_deploy_ghost_cms_on_rocky_linux_9/ghost-mailgun-settings.png" referrerpolicy="no-referrer" alt="Ghost MailGun newsletter Settings" width="672" height="294" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Click the <strong>Save</strong> button on the top right to save the settings.</p>
<p>To test the newsletter delivery, open any post, open up its settings and click the <strong>Email newsletter</strong> option. Next, send a test email to check if it works. If you don&#39;t get any errors, it means your newsletter delivery is working.</p>
<h2 id="step-12---update-ghost">Step 12 - Update Ghost</h2>
<p>There are two types of Ghost updates - Minor updates and Major updates.</p>
<p>First, take a full backup if you want to run a minor update.</p>
<pre class="command">$ cd /var/www/html/ghost
$ ghost backup
</pre>
<p>Run the update command to perform the minor update.</p>
<pre class="command">$ ghost update
</pre>
<p>To perform a major update, you should follow the <a href="https://ghost.org/docs/update/#updating-to-the-latest-major-version">official detailed update guide over at Ghost</a>. Depending upon which version you are at currently and the major version you want to update to, steps will vary.</p>
<h2 id="conclusion">Conclusion</h2>
<p>This concludes our tutorial on how to set up Ghost CMS on your Rocky Linux 9 server using Nginx. If you have any questions or feedback, share them in the comments below.</p>
</article>
<div style="height:30px; margin-top:20px;">
<p style="text-align:right;"><img src="/images/pdficon_small.png" /> <a class="pdf-btn" href="javascript:void(0);">view as pdf</a> | <img src="/images/print.gif" /> <a class="print-btn" href="javascript:void(0);">print</a></p>
</div>
<div style="height:30px; margin-top:20px;">
<div style="float:left;"><b>Share this page:</b></div>
<p style="text-align:center;">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-deploy-ghost-cms-on-rocky-linux-9%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-deploy-ghost-cms-on-rocky-linux-9%2F&amp;text=How+to+deploy+Ghost+CMS+on+Rocky+Linux+9&amp;via=howtoforgecom&amp;related=howtoforgecom" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-deploy-ghost-cms-on-rocky-linux-9%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-gplus.png" height="20" /></a>
</p>
</div>
</div>


<div id="htfContentPagePaging">
<h2>Suggested articles</h2>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-3043223216276099" data-ad-slot="8940054090"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>


<div id="htfContentPageComment">
<a name="comments"></a>
<h2>0 Comment(s)</h2>

<div id="commentform">
<div class="commentContainerHead" style="font-size:18px;">Add comment</div>
<div class="commentContainer">
<form method="post" action="/how-to-deploy-ghost-cms-on-rocky-linux-9/#comments">
<input type="hidden" name="reply_to" id="reply-to-comment" value="0" />
<div id="commentFormDetail">
<div style="width:48%; float:left; margin-right:3%">
<label for="commentname">Name *</label>
<input id="commentname" name="commentname" value="" />
</div>
<div style="width:48%;float:left;">
<label for="commentname">Email *</label>
<input id="commentemail" name="commentemail" value="" />
</div>
<div style="clear:both;"></div>
</div>
<textarea id="commentedit" name="commentedit" style="width:auto;"></textarea>
<div>
<div style="float:left;">
<div class="g-recaptcha" data-sitekey="6LdX9fUSAAAAALWwVoPdeXScMSketz4npF-0QcQ1"></div>
<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en">
      </script>
</div>
<div style="margin-top:10px;margin-bottom:10px;">
<input type="submit" name="submit" class="button primary" style="float:right;" value="Submit comment" />
</div>
<div style="clear:both;"></div>
</div>
<script>
	tinymce.init({
		selector: "textarea#commentedit",
		theme: "modern",
		height: 100,
		apply_source_formatting : true,
		remove_linebreaks : false,
		menubar : false,
		/*auto_focus : "commentedit",*/
		plugins: [
		"link"
		],
		/*plugins: [
			"advlist autolink link image lists charmap print preview hr anchor pagebreak spellchecker",
			"searchreplace wordcount visualblocks visualchars code fullscreen insertdatetime media nonbreaking",
			"save table contextmenu directionality emoticons template paste textcolor"
		],*/
		content_css: "https://www.howtoforge.com/themes/howtoforge/css/custom.css",
		toolbar: "undo redo | bold italic link", 
		/*style_formats: [
			{title: 'Bold text', inline: 'b'},
			{title: 'Red text', inline: 'span', styles: {color: '#ff0000'}},
			{title: 'Red header', block: 'h1', styles: {color: '#ff0000'}},
			{title: 'Example 1', inline: 'span', classes: 'example1'},
			{title: 'Example 2', inline: 'span', classes: 'example2'},
			{title: 'Table styles'},
			{title: 'Table row 1', selector: 'tr', classes: 'tablerow1'}
		]*/
	}); 
	</script>
</form>
</div>
</div>

</div>

<div class="breadBoxBottom">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Home</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/how-to-deploy-ghost-cms-on-rocky-linux-9/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to deploy Ghost CMS on Rocky Linux 9</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
<script>
<!--

$(document).on('click', 'a.reply-to', function(e) {
	e.preventDefault();
	
	var self = $(this);
	var cid = self.attr('data-comment');
	console.log(cid);
	if(!cid) return this;
	
	$('#commentform').insertAfter('#comment' + cid);
	$('#reply-to-comment').val(cid);
	/*tinyMCE.activeEditor.focus();*/
	var textareaId = 'commentedit';
	tinyMCE.get(textareaId).remove();
	tinyMCE.execCommand("mceAddEditor", false, textareaId);
	tinyMCE.activeEditor.focus();
});
//-->
</script>
<div style="margin-top:10px;margin-bottom:10px;text-align:center;">

<center>


<div id="div-gpt-ad-1527185271042-1" style="height:90px; width:728px;">
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-1'); });
</script>
</div>

</center>
</div>


<form action="https://forum.howtoforge.com/login/login?redirect=/how-to-deploy-ghost-cms-on-rocky-linux-9/" method="post" class="xenForm eAuth" id="login" style="display:none">
<ul id="eAuthUnit">
<li><a href="https://forum.howtoforge.com/community/register/facebook?reg=1" class="fbLogin" tabindex="110"><span>Log in with Facebook</span></a></li>
<li><a href="https://forum.howtoforge.com/community/register/twitter?reg=1" class="twitterLogin" tabindex="110"><span>Log in with Twitter</span></a></li>
<li><span class="googleLogin GoogleLogin JsOnly" tabindex="110" data-client-id="198773272284-b6tfk0c28bje81p774prrcrkq9jb3o44.apps.googleusercontent.com" data-redirect-url="https://forum.howtoforge.com/register/google?code=__CODE__&amp;csrf=hVMXbW_3rnrmq4Em"><span>Log in with Google</span></span></li>
</ul>
<div class="ctrlWrapper">
<dl class="ctrlUnit">
<dt><label for="LoginControl">Your name or email address:</label></dt>
<dd><input type="text" name="login" id="LoginControl" class="textCtrl" tabindex="101" /></dd>
</dl>
<dl class="ctrlUnit">
<dt>
<label for="ctrl_password">Do you already have an account?</label>
</dt>
<dd>
<ul>
<li><label for="ctrl_not_registered"><input type="radio" name="register" value="1" id="ctrl_not_registered" tabindex="105" />
No, create an account now.</label></li>
<li><label for="ctrl_registered"><input type="radio" name="register" value="0" id="ctrl_registered" tabindex="105" checked="checked" class="Disabler" />
Yes, my password is:</label></li>
<li id="ctrl_registered_Disabler">
<input type="password" name="password" class="textCtrl" id="ctrl_password" tabindex="102" />
<div class="lostPassword"><a href="https://forum.howtoforge.com/lost-password/" tabindex="106">Forgot your password?</a></div>
</li>
</ul>
</dd>
</dl>
<dl class="ctrlUnit submitUnit">
<dt></dt>
<dd>
<input type="submit" class="button primary" value="Log in" tabindex="104" data-loginphrase="Log in" data-signupphrase="Sign up" />
<label for="ctrl_remember" class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_remember" tabindex="103" /> Stay logged in</label>
</dd>
</dl>
</div>
<input type="hidden" name="cookie_check" value="1" />
<input type="hidden" name="redirect" value="https://forum.howtoforge.com/" />
<input type="hidden" name="_xfToken" value="" />
</form>

</div>
</div>

<aside>
<div class="sidebar">
<div class="section loginButton">
<div class="secondaryContent">
<label for="LoginControl" id="SignupButton"><a href="https://forum.howtoforge.com/login/" class="inner">Sign up now!</a></label>
</div>
</div>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-2">

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent socialMediaIcon">
<a href="https://twitter.com/howtoforgecom" target="_blank"><img src="/images/socialmedia/64x64/twitter.png" /></a>
<a href="https://www.facebook.com/howtoforge" target="_blank"><img src="/images/socialmedia/64x64/facebook.png" /></a>
<a href="https://news.ycombinator.com/" target="_blank" rel="nofollow"><img src="/images/socialmedia/64x64/hackernews.png" /></a>
<a href="https://www.howtoforge.com/feed" target="_blank"><img src="/images/socialmedia/64x64/rss.png" /></a>
</div>
</div>
</div>
<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Tutorial Info</p>
<div class="pairsJustified">
<dl class="discussionCount">
<dt>Author:</dt>
<dd><a href="/author/navjot+singh/" rel="author">Navjot Singh</a></dd>
</dl>
<dl class="discussionCount">
<dt>Published:</dt>
<dd>Dec 20, 2022</dd>
</dl>
<dl class="discussionCount">
<dt>Tags:</dt>
<dd><a href="/tutorials/linux/" rel="tag">linux</a>, <a href="/tutorials/nginx/" rel="tag">nginx</a>, <a href="/tutorials/server/" rel="tag">server</a>, <a href="/tutorials/web+server/" rel="tag">web server</a></dd>
</dl>
</div>
</div>
</div>

<div id="sponsor-banner">
</div>

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent">
<p class="mnuinfo mnushare">Share This Page</p>
<p style="text-align:center;">
<a href="javascript:window.open(&#39;https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-deploy-ghost-cms-on-rocky-linux-9%2F&#39;, &#39;_blank&#39;, &#39;status=1,height=500,width=360,resizable=0&#39;);void(0);"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="javascript:window.open(&#39;https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-deploy-ghost-cms-on-rocky-linux-9%2F&amp;text=How+to+deploy+Ghost+CMS+on+Rocky+Linux+9&amp;via=howtoforgecom&amp;related=howtoforgecom&#39;, &#39;_blank&#39;, &#39;status=1,height=500,width=360,resizable=0&#39;);void(0);"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="javascript:window.open(&#39;https://news.ycombinator.com/submitlink?t=How+to+deploy+Ghost+CMS+on+Rocky+Linux+9&amp;u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-deploy-ghost-cms-on-rocky-linux-9%2F&#39;, &#39;_blank&#39;, &#39;status=1,height=500,width=360,resizable=0&#39;);void(0);"><img src="/images/socialmedia/btn-hackernews.png" height="20" /></a>
</p>
<p style="color:#EE; font-weight:bold; text-align:center; margin-top:5px;">40.2k Followers</p>
</div>
</div>
</div>


<script type="text/javascript">
    google_ad_client = "ca-pub-3043223216276099";
    google_ad_slot = "6709042890";
    google_ad_width = 300;
    google_ad_height = 600;
</script>

<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>


<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Popular Tutorials</p>
<div class="pairsJustified">
<ul>
<li><a href="/how-to-enable-ssl-for-postgresql-connections/">How to Enable SSL for PostgreSQL connections</a></li>
<li><hr /></li>
<li><a href="/how-to-setup-dns-server-with-bind-on-rocky-linux-9/">How to Install a DNS Server with BIND on Rocky Linux 9</a></li>
<li><hr /></li>
<li><a href="/how-to-monitor-network-traffic-with-vnstat-on-ubuntu-22-04/">How to Monitor Network Traffic with vnStat on Ubuntu 22.04</a></li>
<li><hr /></li>
<li><a href="/how-to-install-mastodon-social-network-on-ubuntu-22-04/">How to Install Mastodon Social Network on Ubuntu 22.04</a></li>
<li><hr /></li>
<li><a href="/how-to-install-and-configure-gocd-on-ubuntu-22-04/">How to Install and Configure GoCD on Ubuntu 22.04</a></li>
<li><hr /></li>
<li><a href="/tutorial/ispconfig-multiserver-setup-debian-ubuntu/">ISPConfig Perfect Multiserver setup on Ubuntu 20.04 and Debian 10</a></li>
<li><hr /></li>
<li><a href="/how-to-block-package-and-kernel-updates-in-centos-rocky-linux/">How to Block Package and Kernel Updates in CentOS / Rocky Linux</a></li>
<li><hr /></li>
<li><a href="/tutorial/install-apache-with-php-and-mysql-on-ubuntu-16-04-lamp/">Ubuntu 16.04 (LTS) LAMP server tutorial with Apache, PHP 7, and MySQL</a></li>
<li><hr /></li>
<li><a href="/how-to-install-django-with-postgres-nginx-and-gunicorn-on-rocky-linux-9/">How to Install Django with Postgres, Nginx, and Gunicorn on Rocky Linux 9</a></li>
<li><hr /></li>
<li><a href="/how-to-install-odoo-16-on-ubuntu-22-04/">How to Install Odoo 16 ERP Software on Ubuntu 22.04</a></li>
<li><hr /></li>
</ul>
</div>
</div>
</div>
</div>
</div>
</aside>
</div>
</div>
</div>
<footer>
<div class="footer">
<div class="pageWidth">
<div class="pageContent">
<div class="skin_branding"><span>Xenforo skin by <a href="http://www.xenfocus.com" rel="nofollow">Xenfocus</a></span></div>
<ul class="footerLinks">
<li><a href="/contribute/">Contribute</a></li>
<li><a href="https://forum.howtoforge.com/misc/contact">Contact</a></li>
<li><a href="https://forum.howtoforge.com/help/">Help</a></li>
<li><a href="/imprint/">Imprint and Legal Notice</a></li>
<li><a href="#navigation" class="topLink">Top</a></li>
<li><a href="/feed" rel="alternate" class="globalFeed" target="_blank" title="RSS-Feed for Howtoforge">RSS-Feed</a></li>
</ul>
<span class="helper"></span>
</div>
</div>
</div>
<div class="footerLegal">
<div class="pageWidth">
<div class="pageContent">
<ul id="legal">
<li><a href="https://forum.howtoforge.com/help/terms">Terms and Rules</a> <a href="https://forum.howtoforge.com/help/privacy-policy">Privacy Policy</a></li>
</ul>
<div id="copyright"><a href="https://www.howtoforge.com" class="concealed">Howtoforge <span>© projektfarm GmbH.</span></a></div>
<span class="helper"></span>
</div>
</div>
</div>
</footer>
<div style="height:100px;"></div>

<div id="subscriptionModal" class="modal">
<div class="modal-content">
<span class="close">×</span>
<p>This feature is only available to subscribers. Get your subscription <a href="/subscription">here</a>.</p>
</div>
</div>
<script>
//* Modal
var modal = document.getElementById('subscriptionModal');
var span = document.getElementsByClassName("close")[0];
$(".pdf-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
$(".print-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
span.onclick = function() {
	$("#subscriptionModal").css('display', 'none');
}
window.onclick = function(event) {
    if (event.target == modal) {
		$("#subscriptionModal").css('display', 'none');
    }
}
//* Xenforo
jQuery.extend(true, XenForo,
{
	visitor: { user_id: 0 },
	serverTimeInfo:
	{
		now: 1409831907,
		today: 1409781600,
		todayDow: 4
	},
	_lightBoxUniversal: "0",
	_enableOverlays: "1",
	_animationSpeedMultiplier: "1",
	_overlayConfig:
	{
		top: "10%",
		speed: 200,
		closeSpeed: 100,
		mask:
		{
			color: "rgb(0, 0, 0)",
			opacity: "0.6",
			loadSpeed: 200,
			closeSpeed: 100
		}
	},
	_ignoredUsers: [],
	_loadedScripts: {"node_list":true,"node_category":true,"node_forum":true,"sidebar_share_page":true,"wf_default":true,"bbm_buttons":true,"login_bar":true,"twitter":true},
	_cookieConfig: { path: "/", domain: "", prefix: "xf_"},
	_csrfToken: "",
	_csrfRefreshUrl: "https://forum.howtoforge.com/login/csrf-token-refresh",
	_jsVersion: "303ae0ca"
});
jQuery.extend(XenForo.phrases,
{
	cancel: "Cancel",

	a_moment_ago:    "A moment ago",
	one_minute_ago:  "1 minute ago",
	x_minutes_ago:   "%minutes% minutes ago",
	today_at_x:      "Today at %time%",
	yesterday_at_x:  "Yesterday at %time%",
	day_x_at_time_y: "%day% at %time%",

	day0: "Sunday",
	day1: "Monday",
	day2: "Tuesday",
	day3: "Wednesday",
	day4: "Thursday",
	day5: "Friday",
	day6: "Saturday",

	_months: "January,February,March,April,May,June,July,August,September,October,November,December",
	_daysShort: "Sun,Mon,Tue,Wed,Thu,Fri,Sat",

	following_error_occurred: "The following error occurred",
	server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
	logging_in: "Logging in",
	click_image_show_full_size_version: "Click this image to show the full-size version.",
	show_hidden_content_by_x: "Show hidden content by {names}"
});

// Facebook Javascript SDK
XenForo.Facebook.appId = "";
XenForo.Facebook.forceInit = true;

/*
document.addEventListener('DOMContentLoaded', function(event) {
  cookieChoices.showCookieConsentBar('Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.',
  'OK');
});
*/

$(document).ready(function() {
	$("a.fancybox").fancybox();
});

</script>

<script>
_bsa.init('custom', 'CKYD55QU', 'placement:howtoforge',
    {
      target: '#sponsor-banner',
      template: `
<a href="##link##" style="background: linear-gradient(-330deg, ##backgroundColor##D9, ##backgroundColor##D9 30%, ##backgroundColor## 70%) #fff;" class="native-banner">
<img class="native-img" src="##logo##">
<div style="color: ##textColor##" class="native-tagline">##tagline##</div>
<div style="color: ##textColor##" class="native-desc">##description##</div>
<div style="color: ##ctaTextColor##; background-color: ##ctaBackgroundColor##;" class="native-cta">##callToAction##</div>
<div style="background-color: ##textColor##B2; color: ##backgroundColor##" class="native-ad">Ad</div>
</a>
`
    }
  );
</script>

<script>
(function() {
  if (typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('fancybar', 'CKYDL27E', 'placement:howtoforgecom');
  }
})();
</script>
<script>
(function() {
  if (typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('custom', 'CEBDK2JM', 'placement:howtoforgecom', {
      target: '.bsa-apiads',
      template:
`
<a href="##statlink##" target="_blank" rel="sponsored nofollow">##company## — ##description##</a>
`
    });
  }
})();
</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2155872-1', 'auto');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');

</script>
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('/detroitchicago/edmonton.webp', '/detroitchicago/edmonton.webp?a=a&cb=2&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('/porpoiseant/jellyfish.webp', '/porpoiseant/jellyfish.webp?a=a&cb=2&shcb=34', false, [], true, false, false, false);
</script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=2&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script>
<script type="text/javascript" data-cfasync="false"></script>
<script>var _audins_dom="howtoforge_com",_audins_did=178704;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=195-2");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.howtoforge_com,DomainId.178704" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script>__ez.queue.addFile('/beardeddragon/drake.js', '/beardeddragon/drake.js?gcb=2&cb=4', false, [], true, false, true, false);</script></body></html>