<!DOCTYPE html><html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs LoggedOut Sidebar Responsive" xmlns:fb="http://www.facebook.com/2008/fbml"><head><meta charset="utf-8" />
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=195-2&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=195-2&cb=4', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=195-2&cb=5', false, [], true, false, true, false);</script>
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<base href="https://www.howtoforge.com" />
<script>
			var _b = document.getElementsByTagName('base')[0], _bH = "https://www.howtoforge.com/how-create-and-attach-an-ebs-elastic-block-storage-volume-to-an-ec2-instance-on-aws/";
			if (_b && _b.href != _bH) _b.href = _bH;
		</script>
<title>How to create and attach an EBS (Elastic Block Storage) Volume to an EC2 Instance on AWS</title>
<meta name="description" content="Elastic Block Storage (EBS) is a high-performance block storage service. It is designed for use with Elastic Cloud Compute i.e. EC2 for transactions... " />
<meta property="og:title" content="How to create and attach an EBS (Elastic Block Storage) Volume to an EC2 Instance on AWS" />
<meta property="og:description" content="Elastic Block Storage (EBS) is a high-performance block storage service. It is designed for use with Elastic Cloud Compute i.e. EC2 for transactions... " />
<meta property="og:site_name" content="HowtoForge" />
<meta property="og:type" content="article" />
<meta property="og:image" content="https://www.howtoforge.com/images/featured/ebs-ec2-aws.jpg" />
<meta property="og:image:secure_url" content="https://www.howtoforge.com/images/featured/ebs-ec2-aws.jpg" />
<meta property="og:image:alt" content="How to create and attach an EBS (Elastic Block Storage) Volume to an EC2 Instance on AWS" />
<meta name="twitter:image" content="https://www.howtoforge.com/images/featured/ebs-ec2-aws.jpg" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@howtoforgecom" />
<meta name="twitter:creator" content="@howtoforgecom" />
<meta name="twitter:title" content="How to create and attach an EBS (Elastic Block Storage) Volume to an EC2 Instance on AWS" />
<meta name="twitter:description" content="Elastic Block Storage (EBS) is a high-performance block storage service. It is designed for use with Elastic Cloud Compute i.e. EC2 for transactions... " />
<link rel="alternate" href="https://www.howtoforge.com/how-create-and-attach-an-ebs-elastic-block-storage-volume-to-an-ec2-instance-on-aws/" hreflang="en" />
<link rel="canonical" href="https://www.howtoforge.com/how-create-and-attach-an-ebs-elastic-block-storage-volume-to-an-ec2-instance-on-aws/" />
<link rel="amphtml" href="https://www.howtoforge.com/how-create-and-attach-an-ebs-elastic-block-storage-volume-to-an-ec2-instance-on-aws/amp/" />
<script type="application/ld+json">
{
  "@context" : "http://schema.org",
  "@type" : "Article",
  "name" : "How to create and attach an EBS (Elastic Block Storage) Volume to an EC2 Instance on AWS",
  "author" : {
    "@type" : "Person",
    "name" : "Rahul Shivalkar"
  },
  "articleSection" : "cloud",
  "url" : "https://www.howtoforge.com/how-create-and-attach-an-ebs-elastic-block-storage-volume-to-an-ec2-instance-on-aws/",
  "publisher" : {
    "@type" : "Organization",
    "name" : "Howtoforge"
  }
}
</script>
<noscript><style>.JsOnly, .jsOnly { display: none !important; }</style></noscript>
<link rel="stylesheet" href="/community/styles/executive/xenfocus/icons/css/font-awesome.min.css" />
<link href="//fonts.googleapis.com/css?family=Open+Sans:400,700" rel="stylesheet" type="text/css" />
<link href="/themes/howtoforge/templates/xf.css" rel="stylesheet" />
<script src="/js/jquery/jquery-1.11.3.min.js"></script>
<script src="/community/js/xenforo/xenforo.js?_v=303ae0ca"></script>
<script src="/community/js/bbm/zloader.js?_v=303ae0ca"></script>
<script type="text/javascript" src="/js/fancybox/jquery.mousewheel-3.0.4.pack.js"></script>
<script type="text/javascript" src="/js/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
<link rel="stylesheet" type="text/css" href="/js/fancybox/jquery.fancybox-1.3.4.css" media="screen" />
<link href="/themes/howtoforge/templates/style.min.css" rel="stylesheet" />
<link rel="alternate" type="application/rss+xml" title="RSS-Feed für Howtoforge" href="/feed.rss" />
<script src="/js/tinymce_4.1.7/tinymce.min.js"></script>
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/skin.min.css" as="style" />
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/content.min.css" as="style" />
<link rel="preload" href="/themes/howtoforge/css/custom.css" as="style" />
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/fonts/tinymce.woff" as="font" crossorigin="anonymous" />

<script type="text/javascript">
var gaProperty = 'UA-2155872-1';
var disableStr = 'ga-disable-' + gaProperty;
if (document.cookie.indexOf(disableStr + '=true') > -1) {
window[disableStr] = true;
}
function gaOptout() {
document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
window[disableStr] = true;
alert('Google Ananlyitics tracking has been disabled in this browser.');
}
</script>
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
	googletag.defineSlot('/1030080/howtoforge_com_list_sidebar_top', [300, 250], 'div-gpt-ad-1527185271042-4').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_list_content_middle', [[300, 250], [336, 280]], 'div-gpt-ad-1527185271042-5').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_a_300x250', [300, 250], 'div-gpt-ad-1527185271042-6').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_b_300x250', [300, 250], 'div-gpt-ad-1527185271042-7').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_leaderboard_b_728x90', [728, 90], 'div-gpt-ad-1527185271042-1').addService(googletag.pubads());
	googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-3043223216276099",
          enable_page_level_ads: true
     });
</script>


<script type="text/javascript" src="//m.servedby-buysellads.com/monetization.js"></script>

<script type="text/javascript">var ezouid = "1";</script><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script>
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 178704;
var ezdomain = 'howtoforge.com';
var ezoicSearchable = 1;
</script>


<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":178704,"domain_test_group":20210302,"engaged_time_visit":0,"ezcache_level":2,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"9cc68bd7-add2-4fbc-445f-c490bbb255f5","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":46903,"response_time_orig":4,"serverid":"34.207.92.3:15004","state":"VA","t_epoch":1636170285,"template_id":126,"time_on_site_visit":0,"url":"https://www.howtoforge.com/how-create-and-attach-an-ebs-elastic-block-storage-volume-to-an-ec2-instance-on-aws/","user_id":0,"word_count":1245,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_178704=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["9cc68bd7-add2-4fbc-445f-c490bbb255f5", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script><script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head>
<body>
<div id="loginBar">
<div class="pageWidth">
<div class="pageContent">
<h3 id="loginBarHandle">
<label for="LoginControl"><a href="/community/login/" class="concealed noOutline">Log in or Sign up</a></label>
</h3>
<span class="helper"></span>
</div>
</div>
</div>
<header>
<div id="header">
<div id="logoBlock">
<div class="pageWidth">
<div class="pageContent">
<div id="logo"><a href="/">
<span></span>
<img src="/images/howtoforge_logo_trans.gif" alt="Howtoforge" style="margin-left:20px;" />
</a></div>
<span class="helper"></span>
</div>
</div>
</div>
<div id="navigation" class="pageWidth withSearch">
<div class="pageContent">
<nav>
<div class="navTabs">
<ul class="publicTabs">

<li class="navTab forums selected">
<a href="/" class="navLink">Tutorials</a>
<div class="tabLinks forumsTabLinks">
<ul class="secondaryContent blockLinksList">
<li><a href="/search/">Tutorial search</a></li>
</ul>
</div>
</li>
<li class="navTab forums PopupClosed">
<a href="/tutorials/" class="navLink">Tags</a>
</li>
<li class="navTab forums PopupClosed"><a href="/community/" class="navLink">Forums</a></li>
<li class="navTab forums PopupClosed"><a href="/linux-commands/" class="navLink">Linux Commands</a></li>
<li class="navTab forums PopupClosed"><a href="/subscription/" class="navLink">Subscribe</a></li>
<li class="navTab forums PopupClosed"><a href="https://www.ispconfig.org" class="navLink">ISPConfig</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.lxer.com" class="navLink">News</a></li>
</ul>
</div>
<span class="helper"></span>
</nav>
</div>
</div>
<div id="searchBar" class="pageWidth">
<span id="QuickSearchPlaceholder" title=" Search..."> Search</span>
<fieldset id="QuickSearch">
<form action="/" method="post" class="formPopup">
<div class="primaryControls">

<input type="search" name="q" value="" class="textCtrl" placeholder="Search..." results="0" title="Enter your search and hit enter..." id="QuickSearchQuery" />

</div>
<input type="hidden" name="_xfToken" value="" />
</form>
</fieldset>
</div>
</div>
</header>
<div id="content" class="forum_list">
<div class="pageWidth">
<div class="pageContent">

<div class="mainContainer">
<div class="mainContent">

<div class="breadBoxTop">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://schema.org/BreadcrumbList">
<span itemprop="itemListElement" itemscope="" itemtype="http://schema.org/ListItem">
<a href="/" class="crumb" rel="up" itemprop="item"><span itemprop="name">Home</span></a>
<meta itemprop="position" content="1" />
</span>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://schema.org/BreadcrumbList">
<span itemprop="itemListElement" itemscope="" itemtype="http://schema.org/ListItem">
<a href="/how-create-and-attach-an-ebs-elastic-block-storage-volume-to-an-ec2-instance-on-aws/" class="crumb" rel="up" itemprop="item"><span itemprop="name">How to create and attach an EBS (Elastic Block Storage) Volume to an EC2 Instance on AWS</span></a>
<meta itemprop="position" content="2" />
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</span></fieldset>
</nav>
</div>

<div id="htfContentPage">
<div class="bsa-apiads"></div>
<article>
<h1>How to create and attach an EBS (Elastic Block Storage) Volume to an EC2 Instance on AWS</h1>
<div class="contributeEdit" style="float:right; width:450px; max-width:100%;">
<div id="tocContainer">
<h3>On this page</h3>
<ol class="toc">
<li><a href="#prerequisites">Pre-requisites</a></li>
<li><a href="#what-we-will-do">What we will do</a></li>
<li><a href="#login-to-aws">Login to AWS</a></li>
<li><a href="#create-and-attach-an-ebs-volume-to-an-ec-instance">Create and attach an EBS volume to an EC2 instance.</a></li>
<li><a href="#mount-the-attached-volume-on-the-linux-system">Mount the attached volume on the Linux System</a></li>
<li><a href="#conclusion">Conclusion</a></li>
</ol>
</div>
</div>
<p style="text-align: left;">Elastic Block Storage (EBS) is a high-performance block storage service. It is designed for use with Elastic Cloud Compute i.e. EC2 for transactions and intensive workload. Relational and non-relational databases, enterprise applications, containerized applications, big data analytics engines, file systems, and media workflows are widely deployed on Amazon EBS. We can change types of EBS Volume,  increase volume size without disrupting our applications. Amazon EBS volumes are easy to create, use, encrypt, and protect. Amazon EBS architecture offers reliability for mission-critical applications. Each volume is designed to protect against failures by replicating data on it within the Availability Zones. Amazon EBS enables us to increase storage without any disruption to our critical workloads. EBS is built to be secure for data compliance. Newly created EBS volumes can be encrypted by default with a single setting in our account.</p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;">

<div id="div-gpt-ad-1527185271042-6" style="height:250px; width:300px;">
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-6'); });
</script>
</div>
</div>
<p style="text-align: justify;">To know more about EBS click <a href="https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/AmazonEBS.html">here</a> and to know about its pricing click <a href="https://aws.amazon.com/ebs/pricing/">here</a>.   </p>
<h2 id="prerequisites" style="text-align: justify;">Pre-requisites</h2>
<ol style="text-align: justify;">
<li style="font-weight: 400;">AWS Account (<a href="https://aws.amazon.com/free/">Create</a> if you don’t have one).</li>
<li style="font-weight: 400;">Basic understanding of EC2 instance. Click <a href="https://www.howtoforge.com/how-to-create-an-ec2-instance-on-aws/">here</a> to learn about it.</li>
</ol>
<h2 id="what-we-will-do" style="text-align: justify;">What we will do</h2>
<ol style="text-align: justify;">
<li style="font-weight: 400;">Login to AWS</li>
<li style="font-weight: 400;">Create and attach an EBS volume to an EC2 instance. </li>
<li style="font-weight: 400;">Mount the attached volume on the Linux System</li>
</ol>
<h2 id="login-to-aws" style="text-align: justify;">Login to AWS</h2>
<p style="text-align: justify;">Click <a href="https://console.aws.amazon.com/console/home">here</a> to go to AWS Login Page</p>
<p style="text-align: justify;">When you hit the above link, you will see a web page as follows where you are required to login using your login details.</p>
<p><a class="fancybox" id="img-Screenshot_2020-03-27_at_10.28_.28_AM_1" href="https://www.howtoforge.com/images/how_create_and_attach_an_ebs_elastic_block_storage_volume_to_an_ec2_instance_on_aws/big/Screenshot_2020-03-27_at_10.28_.28_AM_1.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_create_and_attach_an_ebs_elastic_block_storage_volume_to_an_ec2_instance_on_aws/Screenshot_2020-03-27_at_10.28_.28_AM_1.png" style="display: block; margin-left: auto; margin-right: auto;" alt="AWS Login" width="750" height="469" /></a></p>
<p style="text-align: justify;">Once you login into AWS successfully, you will see the main console with all the services listed as follows.</p>
<p><a class="fancybox" id="img-Screenshot_2020-03-27_at_10.28_.54_AM_" href="https://www.howtoforge.com/images/how_create_and_attach_an_ebs_elastic_block_storage_volume_to_an_ec2_instance_on_aws/big/Screenshot_2020-03-27_at_10.28_.54_AM_.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_create_and_attach_an_ebs_elastic_block_storage_volume_to_an_ec2_instance_on_aws/Screenshot_2020-03-27_at_10.28_.54_AM_.png" style="display: block; margin-left: auto; margin-right: auto;" alt="AWS Management Console" width="750" height="469" /></a></p>
<p style="text-align: justify;"></p>
<h2 id="create-and-attach-an-ebs-volume-to-an-ec-instance" style="text-align: justify;">Create and attach an EBS volume to an EC2 instance.</h2>
<p style="text-align: justify;">Once you login to AWS, click on services at the top of the screen and search for EC2. Click on the result to go to the main dashboard of EC2 service.</p>
<p><a class="fancybox" id="img-Screenshot_2020-03-27_at_10.29_.01_AM_" href="https://www.howtoforge.com/images/how_create_and_attach_an_ebs_elastic_block_storage_volume_to_an_ec2_instance_on_aws/big/Screenshot_2020-03-27_at_10.29_.01_AM_.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_create_and_attach_an_ebs_elastic_block_storage_volume_to_an_ec2_instance_on_aws/Screenshot_2020-03-27_at_10.29_.01_AM_.png" style="display: block; margin-left: auto; margin-right: auto;" alt="EC2" width="750" height="469" /></a></p>
<p style="text-align: justify;">This is the main dashboard of EC2 service. Scroll down and in the left panel click on <strong>Volume</strong> under <strong>Elastic Block Store.</strong></p>
<p><a class="fancybox" id="img-Screenshot_2020-03-27_at_10.29_.10_AM_" href="https://www.howtoforge.com/images/how_create_and_attach_an_ebs_elastic_block_storage_volume_to_an_ec2_instance_on_aws/big/Screenshot_2020-03-27_at_10.29_.10_AM_.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_create_and_attach_an_ebs_elastic_block_storage_volume_to_an_ec2_instance_on_aws/Screenshot_2020-03-27_at_10.29_.10_AM_.png" style="display: block; margin-left: auto; margin-right: auto;" alt="Elastic block store" width="750" height="469" /></a></p>
<p style="text-align: justify;">You will see the following screen. Here you may or may not see any existing volumes. As I already have an EC2 instance in my account the following listed EBS volume is attached to that existing EC2 instance. To create a new EBS volume click on &#34;<strong>Create Volume</strong>&#34;.</p>
<p><a class="fancybox" id="img-Screenshot_2020-03-27_at_10.29_.25_AM_2" href="https://www.howtoforge.com/images/how_create_and_attach_an_ebs_elastic_block_storage_volume_to_an_ec2_instance_on_aws/big/Screenshot_2020-03-27_at_10.29_.25_AM_2.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_create_and_attach_an_ebs_elastic_block_storage_volume_to_an_ec2_instance_on_aws/Screenshot_2020-03-27_at_10.29_.25_AM_2.png" style="display: block; margin-left: auto; margin-right: auto;" alt="Create EBS Volume" width="750" height="469" /></a></p>
<p style="text-align: justify;">Choose the type of volume that you want to create and specify the disk space that needs to be allocated to the volume. Select the Availability Zone. This should be the same as that of an EC2 instance to which this volume will be attached.</p>
<p style="text-align: justify;">You can skip other fields for now and proceed with &#34;<strong>Create Volume</strong>&#34;</p>
<p><a class="fancybox" id="img-Screenshot_2020-03-27_at_10.30_.11_AM_1" href="https://www.howtoforge.com/images/how_create_and_attach_an_ebs_elastic_block_storage_volume_to_an_ec2_instance_on_aws/big/Screenshot_2020-03-27_at_10.30_.11_AM_1.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_create_and_attach_an_ebs_elastic_block_storage_volume_to_an_ec2_instance_on_aws/Screenshot_2020-03-27_at_10.30_.11_AM_1.png" style="display: block; margin-left: auto; margin-right: auto;" alt="Volume type and details" width="750" height="469" /></a></p>
<p style="text-align: justify;">The creation will take some time and once the volume has been created you can see its status as &#34;<strong>Available</strong>&#34;. Once the status of the volume changes to available it can be attached to the desired EC2 instance.</p>
<p><a class="fancybox" id="img-Screenshot_2020-03-27_at_10.30_.20_AM_1" href="https://www.howtoforge.com/images/how_create_and_attach_an_ebs_elastic_block_storage_volume_to_an_ec2_instance_on_aws/big/Screenshot_2020-03-27_at_10.30_.20_AM_1.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_create_and_attach_an_ebs_elastic_block_storage_volume_to_an_ec2_instance_on_aws/Screenshot_2020-03-27_at_10.30_.20_AM_1.png" style="display: block; margin-left: auto; margin-right: auto;" alt="List of EBS Volumes" width="750" height="469" /></a></p>
<p style="text-align: justify;">To attach this EBS volume to an EC2 instance, click on <strong>Actions --&gt; Attach</strong> <strong>Volume</strong>.</p>
<p><a class="fancybox" id="img-Screenshot_2020-03-27_at_10.30_.31_AM_" href="https://www.howtoforge.com/images/how_create_and_attach_an_ebs_elastic_block_storage_volume_to_an_ec2_instance_on_aws/big/Screenshot_2020-03-27_at_10.30_.31_AM_.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_create_and_attach_an_ebs_elastic_block_storage_volume_to_an_ec2_instance_on_aws/Screenshot_2020-03-27_at_10.30_.31_AM_.png" style="display: block; margin-left: auto; margin-right: auto;" alt="Attach Volume" width="750" height="469" /></a></p>
<p style="text-align: justify;">In the following screen specify the Instance ID of the EC2  instance to which this EBS volume needs to be attached. Make sure that your instance is also in the same availability zone in which you have created the volume. Click on &#34;<strong>Attach</strong>&#34; to proceed.</p>
<p><a class="fancybox" id="img-Screenshot_2020-03-27_at_10.30_.40_AM_" href="https://www.howtoforge.com/images/how_create_and_attach_an_ebs_elastic_block_storage_volume_to_an_ec2_instance_on_aws/big/Screenshot_2020-03-27_at_10.30_.40_AM_.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_create_and_attach_an_ebs_elastic_block_storage_volume_to_an_ec2_instance_on_aws/Screenshot_2020-03-27_at_10.30_.40_AM_.png" style="display: block; margin-left: auto; margin-right: auto;" alt="Choose instance" width="750" height="469" /></a></p>
<h2 id="mount-the-attached-volume-on-the-linux-system" style="text-align: justify;">Mount the attached volume on the Linux System</h2>
<p style="text-align: justify;">After attaching the volume to an EC2 instance, we need to format it with the file system of our valid choice.</p>
<p style="text-align: justify;">To format and mount the volume on the Linux system, first connect to the system. Click <a href="https://www.howtoforge.com/how-to-create-an-ec2-instance-on-aws/">here</a> to see the steps to create and connect to the Linux EC2 instance.</p>
<p style="text-align: justify;">Once you are connected to the instance, use the <strong>lsblk</strong> command to view your available disk devices and their mount points.</p>
<p class="command" style="text-align: justify;">lsblk</p>
<p style="text-align: justify;">Use the <strong>file -s</strong> command to get information about the device, such as its file system type. If the output shows simply &#39;data&#39;,  there is no file system on the device and we can create a mount else if the device has a file system, the command shows information about the file system type.</p>
<p class="command" style="text-align: justify;">sudo file -s /dev/xvdf</p>
<p style="text-align: justify;">If you have an empty volume, use the <strong>mkfs -t</strong> command to create a file system on the volume.</p>
<p class="command" style="text-align: justify;"> sudo mkfs -t xfs /dev/xvdf</p>
<p style="text-align: justify;">Use the <strong>mkdir</strong> command to create a mount point directory for the volume.</p>
<p class="command" style="text-align: justify;">sudo mkdir /data</p>
<p style="text-align: justify;">Use the following command to mount the volume at the directory we created in the above step.</p>
<p class="command" style="text-align: justify;">sudo mount /dev/xvdf /data</p>
<p style="text-align: justify;">The mount point is not automatically preserved on system reboot. To automatically mount this EBS volume on system reboot, we need to make an entry of the device in <span>/etc/fstab.</span></p>
<p style="text-align: justify;">Before we make any changed in<span>/etc/fstab, let&#39;s c</span>reate a backup of it first.</p>
<p class="command" style="text-align: justify;">sudo cp /etc/fstab /etc/fstab.orig</p>
<p style="text-align: justify;">Use the <strong>blkid</strong> command to find the UUID of the device. Keep this UUID with you, it will be needed in the next steps.</p>
<p class="command" style="text-align: justify;">sudo blkid</p>
<p style="text-align: justify;">Open the /etc/fstab file.</p>
<p class="command" style="text-align: justify;">sudo vim /etc/fstab</p>
<p style="text-align: justify;">Add the following entry to /etc/fstab to mount the device at the specified mount point.</p>
<pre style="text-align: justify;">UUID=CHANGE_THIS_WITH_UIID_OF_THE_DEVICE_WE_FORMATED /data xfs defaults,nofail 0 2</pre>
<div style="text-align: justify;">
<p>To verify that your entry works, run the following commands to unmount the device and then mount all file systems in /etc/fstab.</p>
<pre class="command">sudo umount /data</pre>
</div>
<p class="command" style="text-align: justify;">sudo mount -a</p>
<p style="text-align: justify;">You can to refer the following screenshot to see all the above steps we performed.</p>
<p><a class="fancybox" id="img-Screenshot_2020-03-27_at_10.41_.01_AM_1" href="https://www.howtoforge.com/images/how_create_and_attach_an_ebs_elastic_block_storage_volume_to_an_ec2_instance_on_aws/big/Screenshot_2020-03-27_at_10.41_.01_AM_1.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_create_and_attach_an_ebs_elastic_block_storage_volume_to_an_ec2_instance_on_aws/Screenshot_2020-03-27_at_10.41_.01_AM_1.png" style="display: block; margin-left: auto; margin-right: auto;" alt="Mount EBS Volume" width="750" height="469" /></a></p>
<h2 id="conclusion" style="text-align: justify;">Conclusion</h2>
<p style="text-align: justify;">In this article we saw the steps to create an EBS volume and attach it to one of our EC2 instances. We also saw the steps to format the volume and mount it on directory in the Linux system and preserve the mount on system reboot. </p>
</article>
<div style="height:30px; margin-top:20px;">
<p style="text-align:right;"><img src="/images/pdficon_small.png" /> <a class="pdf-btn" href="javascript:void(0);">view as pdf</a> | <img src="/images/print.gif" /> <a class="print-btn" href="javascript:void(0);">print</a></p>
</div>
<div style="height:30px; margin-top:20px;">
<div style="float:left;"><b>Share this page:</b></div>
<p style="text-align:center;">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-create-and-attach-an-ebs-elastic-block-storage-volume-to-an-ec2-instance-on-aws%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-create-and-attach-an-ebs-elastic-block-storage-volume-to-an-ec2-instance-on-aws%2F&amp;text=How+to+create+and+attach+an+EBS+%28Elastic+Block+Storage%29+Volume+to+an+EC2+Instance+on+AWS&amp;via=howtoforgecom&amp;related=howtoforgecom" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-create-and-attach-an-ebs-elastic-block-storage-volume-to-an-ec2-instance-on-aws%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-gplus.png" height="20" /></a>
</p>
</div>
</div>


<div id="htfContentPagePaging">
<h2>Suggested articles</h2>
<script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-3043223216276099" data-ad-slot="8940054090"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>


<div id="htfContentPageComment">
<a name="comments"></a>
<h2>0 Comment(s)</h2>

<div id="commentform">
<div class="commentContainerHead" style="font-size:18px;">Add comment</div>
<div class="commentContainer">
<form method="post" action="/how-create-and-attach-an-ebs-elastic-block-storage-volume-to-an-ec2-instance-on-aws/#comments">
<input type="hidden" name="reply_to" id="reply-to-comment" value="0" />
<div id="commentFormDetail">
<div style="width:48%; float:left; margin-right:3%">
<label for="commentname">Name *</label>
<input id="commentname" name="commentname" value="" />
</div>
<div style="width:48%;float:left;">
<label for="commentname">Email *</label>
<input id="commentemail" name="commentemail" value="" />
</div>
<div style="clear:both;"></div>
</div>
<textarea id="commentedit" name="commentedit" style="width:auto;"></textarea>
<div>
<div style="float:left;">
<div class="g-recaptcha" data-sitekey="6LdX9fUSAAAAALWwVoPdeXScMSketz4npF-0QcQ1"></div>
<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en">
      </script>
</div>
<div style="margin-top:10px;margin-bottom:10px;">
<input type="submit" name="submit" class="button primary" style="float:right;" value="Submit comment" />
</div>
<div style="clear:both;"></div>
</div>
<script>
	tinymce.init({
		selector: "textarea#commentedit",
		theme: "modern",
		height: 100,
		apply_source_formatting : true,
		remove_linebreaks : false,
		menubar : false,
		/*auto_focus : "commentedit",*/
		plugins: [
		"link"
		],
		/*plugins: [
			"advlist autolink link image lists charmap print preview hr anchor pagebreak spellchecker",
			"searchreplace wordcount visualblocks visualchars code fullscreen insertdatetime media nonbreaking",
			"save table contextmenu directionality emoticons template paste textcolor"
		],*/
		content_css: "https://www.howtoforge.com/themes/howtoforge/css/custom.css",
		toolbar: "undo redo | bold italic link", 
		/*style_formats: [
			{title: 'Bold text', inline: 'b'},
			{title: 'Red text', inline: 'span', styles: {color: '#ff0000'}},
			{title: 'Red header', block: 'h1', styles: {color: '#ff0000'}},
			{title: 'Example 1', inline: 'span', classes: 'example1'},
			{title: 'Example 2', inline: 'span', classes: 'example2'},
			{title: 'Table styles'},
			{title: 'Table row 1', selector: 'tr', classes: 'tablerow1'}
		]*/
	}); 
	</script>
</form>
</div>
</div>

</div>

<div class="breadBoxBottom">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Home</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/how-create-and-attach-an-ebs-elastic-block-storage-volume-to-an-ec2-instance-on-aws/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to create and attach an EBS (Elastic Block Storage) Volume to an EC2 Instance on AWS</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
<script>
<!--

$(document).on('click', 'a.reply-to', function(e) {
	e.preventDefault();
	
	var self = $(this);
	var cid = self.attr('data-comment');
	console.log(cid);
	if(!cid) return this;
	
	$('#commentform').insertAfter('#comment' + cid);
	$('#reply-to-comment').val(cid);
	/*tinyMCE.activeEditor.focus();*/
	var textareaId = 'commentedit';
	tinyMCE.get(textareaId).remove();
	tinyMCE.execCommand("mceAddEditor", false, textareaId);
	tinyMCE.activeEditor.focus();
});
//-->
</script>
<div style="margin-top:10px;margin-bottom:10px;text-align:center;">

<center>


<div id="div-gpt-ad-1527185271042-1" style="height:90px; width:728px;">
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-1'); });
</script>
</div>

</center>
</div>


<form action="/community/login/login?redirect=/how-create-and-attach-an-ebs-elastic-block-storage-volume-to-an-ec2-instance-on-aws/" method="post" class="xenForm eAuth" id="login" style="display:none">
<ul id="eAuthUnit">
<li><a href="/community/register/facebook?reg=1" class="fbLogin" tabindex="110"><span>Log in with Facebook</span></a></li>
<li><a href="/community/register/twitter?reg=1" class="twitterLogin" tabindex="110"><span>Log in with Twitter</span></a></li>
<li><span class="googleLogin GoogleLogin JsOnly" tabindex="110" data-client-id="198773272284-b6tfk0c28bje81p774prrcrkq9jb3o44.apps.googleusercontent.com" data-redirect-url="/community/register/google?code=__CODE__&amp;csrf=hVMXbW_3rnrmq4Em"><span>Log in with Google</span></span></li>
</ul>
<div class="ctrlWrapper">
<dl class="ctrlUnit">
<dt><label for="LoginControl">Your name or email address:</label></dt>
<dd><input type="text" name="login" id="LoginControl" class="textCtrl" tabindex="101" /></dd>
</dl>
<dl class="ctrlUnit">
<dt>
<label for="ctrl_password">Do you already have an account?</label>
</dt>
<dd>
<ul>
<li><label for="ctrl_not_registered"><input type="radio" name="register" value="1" id="ctrl_not_registered" tabindex="105" />
No, create an account now.</label></li>
<li><label for="ctrl_registered"><input type="radio" name="register" value="0" id="ctrl_registered" tabindex="105" checked="checked" class="Disabler" />
Yes, my password is:</label></li>
<li id="ctrl_registered_Disabler">
<input type="password" name="password" class="textCtrl" id="ctrl_password" tabindex="102" />
<div class="lostPassword"><a href="/community/lost-password/" tabindex="106">Forgot your password?</a></div>
</li>
 </ul>
</dd>
</dl>
<dl class="ctrlUnit submitUnit">
<dt></dt>
<dd>
<input type="submit" class="button primary" value="Log in" tabindex="104" data-loginphrase="Log in" data-signupphrase="Sign up" />
<label for="ctrl_remember" class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_remember" tabindex="103" /> Stay logged in</label>
</dd>
</dl>
</div>
<input type="hidden" name="cookie_check" value="1" />
<input type="hidden" name="redirect" value="/community/" />
<input type="hidden" name="_xfToken" value="" />
</form>

</div>
</div>

<aside>
<div class="sidebar">
<div class="section loginButton">
<div class="secondaryContent">
<label for="LoginControl" id="SignupButton"><a href="/community/login/" class="inner">Sign up now!</a></label>
</div>
</div>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-2">

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent socialMediaIcon">
<a href="https://twitter.com/howtoforgecom" target="_blank"><img src="/images/socialmedia/64x64/twitter.png" /></a>
<a href="https://www.facebook.com/howtoforge" target="_blank"><img src="/images/socialmedia/64x64/facebook.png" /></a>
<a href="https://news.ycombinator.com/" target="_blank" rel="nofollow"><img src="/images/socialmedia/64x64/hackernews.png" /></a>
<a href="https://www.howtoforge.com/feed" target="_blank"><img src="/images/socialmedia/64x64/rss.png" /></a>
</div>
</div>
</div>
<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Tutorial Info</p>
<div class="pairsJustified">
<dl class="discussionCount">
<dt>Author:</dt>
<dd><a href="/author/rahul+shivalkar/" rel="author">Rahul Shivalkar</a></dd>
</dl>
<dl class="discussionCount">
<dt>Published:</dt>
<dd>Nov 05, 2021</dd>
</dl>
<dl class="discussionCount">
<dt>Tags:</dt>
<dd><a href="/tutorials/cloud/" rel="tag">cloud</a></dd>
</dl>
</div>
</div>
</div>

<div id="sponsor-banner">
</div>

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent">
<p class="mnuinfo mnushare">Share This Page</p>
<p style="text-align:center;">
<a href="javascript:window.open(&#39;https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-create-and-attach-an-ebs-elastic-block-storage-volume-to-an-ec2-instance-on-aws%2F&#39;, &#39;_blank&#39;, &#39;status=1,height=500,width=360,resizable=0&#39;);void(0);"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="javascript:window.open(&#39;https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-create-and-attach-an-ebs-elastic-block-storage-volume-to-an-ec2-instance-on-aws%2F&amp;text=How+to+create+and+attach+an+EBS+%28Elastic+Block+Storage%29+Volume+to+an+EC2+Instance+on+AWS&amp;via=howtoforgecom&amp;related=howtoforgecom&#39;, &#39;_blank&#39;, &#39;status=1,height=500,width=360,resizable=0&#39;);void(0);"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="javascript:window.open(&#39;https://news.ycombinator.com/submitlink?t=How+to+create+and+attach+an+EBS+%28Elastic+Block+Storage%29+Volume+to+an+EC2+Instance+on+AWS&amp;u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-create-and-attach-an-ebs-elastic-block-storage-volume-to-an-ec2-instance-on-aws%2F&#39;, &#39;_blank&#39;, &#39;status=1,height=500,width=360,resizable=0&#39;);void(0);"><img src="/images/socialmedia/btn-hackernews.png" height="20" /></a>
</p>
<p style="color:#EE; font-weight:bold; text-align:center; margin-top:5px;">40.2k Followers</p>
</div>
</div>
</div>


<script type="text/javascript">
    google_ad_client = "ca-pub-3043223216276099";
    google_ad_slot = "6709042890";
    google_ad_width = 300;
    google_ad_height = 600;
</script>

<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>


<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Popular Tutorials</p>
<div class="pairsJustified">
<ul>
<li><a href="/how-to-install-freeradius-and-daloradius-on-ubuntu-20-04/">How to Install FreeRADIUS and Daloradius on Ubuntu 20.04</a></li>
<li><hr /></li>
<li><a href="/how-to-create-a-static-website-on-s3-bucket/">How to Create a Static Website on an AWS S3 Bucket</a></li>
<li><hr /></li>
<li><a href="/how-to-take-a-backup-of-elasticsearch-cluster/">How to take a Backup of an Elasticsearch Cluster</a></li>
<li><hr /></li>
<li><a href="/intrusion_detection_with_ossec_hids">Securing Your Server With A Host-based Intrusion Detection System</a></li>
<li><hr /></li>
<li><a href="/how-to-install-netdata-on-debian-11/">How to Install Netdata on Debian 11</a></li>
<li><hr /></li>
<li><a href="/setup-simple-ci-cd-pipeline-using-github-and-jenkins-on-aws-ec2-linux-instance/">Setup simple CI/CD pipeline using Github and Jenkins on an AWS EC2 Linux instance</a></li>
<li><hr /></li>
<li><a href="/how-to-install-mono-on-debian-11/">How to Install Mono on Debian 11</a></li>
<li><hr /></li>
<li><a href="/how-to-install-and-configure-memcached-on-debian-11/">How to Install and Configure Memcached on Debian 11</a></li>
<li><hr /></li>
<li><a href="/how-to-create-a-network-load-balancer-on-aws/">How to create a Network Load Balancer on AWS</a></li>
<li><hr /></li>
<li><a href="/tutorial/repair-linux-boot-with-grub-rescue/">Repair Linux boot failures in GRUB 2 rescue mode</a></li>
<li><hr /></li>
</ul>
</div>
</div>
</div>
</div>
</div>
</aside>
</div>
</div>
</div>
<footer>
<div class="footer">
<div class="pageWidth">
<div class="pageContent">
<div class="skin_branding"><span>Xenforo skin by <a href="http://www.xenfocus.com" rel="nofollow">Xenfocus</a></span></div>
<ul class="footerLinks">
<li><a href="/contribute/">Contribute</a></li>
<li><a href="/community/misc/contact">Contact</a></li>
<li><a href="/community/help/">Help</a></li>
<li><a href="/imprint/">Imprint and Legal Notice</a></li>
<li><a href="#navigation" class="topLink">Top</a></li>
<li><a href="/feed" rel="alternate" class="globalFeed" target="_blank" title="RSS-Feed for Howtoforge">RSS-Feed</a></li>
</ul>
<span class="helper"></span>
</div>
</div>
</div>
<div class="footerLegal">
<div class="pageWidth">
<div class="pageContent">
<ul id="legal">
<li><a href="/community/help/terms">Terms and Rules</a> <a href="https://www.howtoforge.com/community/help/privacy-policy">Privacy Policy</a></li>
</ul>
<div id="copyright"><a href="https://www.howtoforge.com" class="concealed">Howtoforge <span>© projektfarm GmbH.</span></a></div>
<span class="helper"></span>
</div>
</div>
</div>
</footer>
<div style="height:100px;"></div>

<div id="subscriptionModal" class="modal">
<div class="modal-content">
<span class="close">×</span>
<p>This feature is only available to subscribers. Get your subscription <a href="/subscription">here</a>.</p>
</div>
</div>
<script>
//* Modal
var modal = document.getElementById('subscriptionModal');
var span = document.getElementsByClassName("close")[0];
$(".pdf-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
$(".print-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
span.onclick = function() {
	$("#subscriptionModal").css('display', 'none');
}
window.onclick = function(event) {
    if (event.target == modal) {
		$("#subscriptionModal").css('display', 'none');
    }
}
//* Xenforo
jQuery.extend(true, XenForo,
{
	visitor: { user_id: 0 },
	serverTimeInfo:
	{
		now: 1409831907,
		today: 1409781600,
		todayDow: 4
	},
	_lightBoxUniversal: "0",
	_enableOverlays: "1",
	_animationSpeedMultiplier: "1",
	_overlayConfig:
	{
		top: "10%",
		speed: 200,
		closeSpeed: 100,
		mask:
		{
			color: "rgb(0, 0, 0)",
			opacity: "0.6",
			loadSpeed: 200,
			closeSpeed: 100
		}
	},
	_ignoredUsers: [],
	_loadedScripts: {"node_list":true,"node_category":true,"node_forum":true,"sidebar_share_page":true,"wf_default":true,"bbm_buttons":true,"login_bar":true,"twitter":true},
	_cookieConfig: { path: "/", domain: "", prefix: "xf_"},
	_csrfToken: "",
	_csrfRefreshUrl: "/community/login/csrf-token-refresh",
	_jsVersion: "303ae0ca"
});
jQuery.extend(XenForo.phrases,
{
	cancel: "Cancel",

	a_moment_ago:    "A moment ago",
	one_minute_ago:  "1 minute ago",
	x_minutes_ago:   "%minutes% minutes ago",
	today_at_x:      "Today at %time%",
	yesterday_at_x:  "Yesterday at %time%",
	day_x_at_time_y: "%day% at %time%",

	day0: "Sunday",
	day1: "Monday",
	day2: "Tuesday",
	day3: "Wednesday",
	day4: "Thursday",
	day5: "Friday",
	day6: "Saturday",

	_months: "January,February,March,April,May,June,July,August,September,October,November,December",
	_daysShort: "Sun,Mon,Tue,Wed,Thu,Fri,Sat",

	following_error_occurred: "The following error occurred",
	server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
	logging_in: "Logging in",
	click_image_show_full_size_version: "Click this image to show the full-size version.",
	show_hidden_content_by_x: "Show hidden content by {names}"
});

// Facebook Javascript SDK
XenForo.Facebook.appId = "";
XenForo.Facebook.forceInit = true;

/*
document.addEventListener('DOMContentLoaded', function(event) {
  cookieChoices.showCookieConsentBar('Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.',
  'OK');
});
*/

$(document).ready(function() {
	$("a.fancybox").fancybox();
});

</script>

<script>
_bsa.init('custom', 'CKYD55QU', 'placement:howtoforge',
    {
      target: '#sponsor-banner',
      template: `
<a href="##link##" style="background: linear-gradient(-330deg, ##backgroundColor##D9, ##backgroundColor##D9 30%, ##backgroundColor## 70%) #fff;" class="native-banner">
<img class="native-img" src="##logo##">
<div style="color: ##textColor##" class="native-tagline">##tagline##</div>
<div style="color: ##textColor##" class="native-desc">##description##</div>
<div style="color: ##ctaTextColor##; background-color: ##ctaBackgroundColor##;" class="native-cta">##callToAction##</div>
<div style="background-color: ##textColor##B2; color: ##backgroundColor##" class="native-ad">Ad</div>
</a>
`
    }
  );
</script>

<script>
(function() {
  if (typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('fancybar', 'CKYDL27E', 'placement:howtoforgecom');
  }
})();
</script>
<script>
(function() {
  if (typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('custom', 'CEBDK2JM', 'placement:howtoforgecom', {
      target: '.bsa-apiads',
      template:
`
<a href="##statlink##" target="_blank" rel="sponsored nofollow">##company## — ##description##</a>
`
    });
  }
})();
</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2155872-1', 'auto');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');

</script>
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('/detroitchicago/edmonton.webp', '/detroitchicago/edmonton.webp?a=a&cb=2&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('/porpoiseant/jellyfish.webp', '/porpoiseant/jellyfish.webp?a=a&cb=2&shcb=34', false, [], true, false, false, false);
</script>
<script>var _audins_dom="howtoforge_com",_audins_did=178704;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=195-2");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.howtoforge_com,DomainId.178704" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=2&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script><script type="text/javascript">(function(){window['__CF$cv$params']={r:'6a9b533b380f5b46',m:'uD.V7ahk_ijcAAi1_Set9KbKsDW.z36drz2Gl6AKbqM-1636170285-0-AZuUTXv0rH3JXVPhuvUpGA3o3pC0D9lKLuKVnHBoS7bx3GGW3ylBKDdVfaP7yhAF7mMcRVp7yVjC/AxxYMd66k7iqQKIUMrGuIvp1G7WG+KYhheoFLTLUAGDnQ5MynGu/lt3FD5vHl3OroWwiqq4MTGWW1YwCuht/4uFF2/05CeyEDmHMbuNzZCgDg2bRdAnM9hed2FJQm8Fp6LhY9FkfbVUQsYWhgefa2OGcnGQdwdT',s:[0xbe1bb5ca8d,0xfcd3137d0b],}})();</script></body></html>