Error: Fedora 15 - Error: Package: glibc-2.14-5.i686 (updates) Requires: glibc-common = 2.14-5

You get an error like the following one on Fedora 15:

Error: Package: glibc-2.14-5.i686 (updates)
Requires: glibc-common = 2.14-5
Installed: glibc-common-2.14-7.x86_64 (@updates-testing)
glibc-common = 2.14-7
Available: glibc-common-2.13.90-9.x86_64 (fedora)
glibc-common = 2.13.90-9
Available: glibc-common-2.14-5.x86_64 (updates)
glibc-common = 2.14-5
You could try using --skip-broken to work around the problem
** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
nss_db-2.2.3-0.5.pre1.fc15.x86_64 has missing requires of libc.so.6(GLIBC_PRIVATE)(64bit)
nss_db-2.2.3-0.5.pre1.fc15.x86_64 has missing requires of libnss_files.so.2(GLIBC_PRIVATE)(64bit)

 

Solution

Running

yum distro-sync

should fix the problem.

Falko Timme

About Falko Timme

Falko Timme is an experienced Linux administrator and founder of Timme Hosting, a leading nginx business hosting company in Germany. He is one of the most active authors on HowtoForge since 2005 and one of the core developers of ISPConfig since 2000. He has also contributed to the O'Reilly book "Linux System Administration".

Share this page:

Suggested articles

0 Comment(s)

Add comment