<!DOCTYPE html>
<html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs LoggedOut Sidebar Responsive" xmlns:fb="http://www.facebook.com/2008/fbml">
<head>
	<meta charset="utf-8" />
	<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />
		<meta name="viewport" content="width=device-width, initial-scale=1">
		<base href="https://www.howtoforge.com" />
		<script>
			var _b = document.getElementsByTagName('base')[0], _bH = "https://www.howtoforge.com/tutorial/software-defined-networking-sdn-openflow-and-ovsdb-connection/";
			if (_b && _b.href != _bH) _b.href = _bH;
		</script>
	<title>Software Defined Networking (SDN) - OpenFlow and OVSDB connection</title>
	<meta name="keywords" content="linux,networking" />
	<meta name="description" content="This article is based on OpenFlow and OVSDB connection between SDN controller and OpenFlow-based switches and provides details on connection lifecycle... " />
	
	<meta name="og:title" content="Software Defined Networking (SDN) - OpenFlow and OVSDB connection">
	<meta name="og:description" content="This article is based on OpenFlow and OVSDB connection between SDN controller and OpenFlow-based switches and provides details on connection lifecycle... ">
	<meta name="og:site_name" content="Howtoforge">
	<meta name="og:type" content="article">
	<meta property="og:image" content="https://www.howtoforge.com/images/teaser/linux.gif">	
	<meta name="twitter:card" content="summary">
	<meta name="twitter:site" content="howtoforgecom">
	<meta name="twitter:creator" content="howtoforgecom">
	<meta name="twitter:title" content="Software Defined Networking (SDN) - OpenFlow and OVSDB connection">
	<meta name="twitter:description" content="This article is based on OpenFlow and OVSDB connection between SDN controller and OpenFlow-based switches and provides details on connection lifecycle... ">

	<link rel="alternate" href="https://www.howtoforge.com/tutorial/software-defined-networking-sdn-openflow-and-ovsdb-connection/" hreflang="en" />	
		
	<link rel="canonical" href="https://www.howtoforge.com/tutorial/software-defined-networking-sdn-openflow-and-ovsdb-connection/" />	
	<noscript><style>.JsOnly, .jsOnly { display: none !important; }</style></noscript>
	<link rel="stylesheet" href="/community/styles/executive/xenfocus/icons/css/font-awesome.min.css" />
	<link href='//fonts.googleapis.com/css?family=Open+Sans:400,700' rel='stylesheet' type='text/css' />
	<!--<link rel="stylesheet" href="/community/css.php?css=xenforo,form,public&amp;style=3&amp;dir=LTR&amp;d=1417968046" />
	<link rel="stylesheet" href="/community/css.php?css=bbm_buttons,login_bar,node_category,node_forum,node_list,sidebar_share_page,wf_default&amp;style=3&amp;dir=LTR&amp;d=1417968046" />-->
	<link rel="stylesheet" href="/community/css.php?css=xenforo,form,public&amp;style=3&amp;dir=LTR&amp;d=1420029973"/>
	<link rel="stylesheet" href="/community/css.php?css=bb_code,bbm_buttons,facebook,google,login_bar,node_category,node_forum,node_list,profile_post_list_simple,sidebar_share_page,twitter,wf_default&amp;style=3&amp;dir=LTR&amp;d=1420029973"/>
	<script src="//ajax.googleapis.com/ajax/libs/jquery/1.11.3/jquery.min.js"></script>	
	<script>if (!window.jQuery) { document.write('<scr'+'ipt type="text/javascript" src="/js/jquery/jquery-1.11.3.min.js"><\/scr'+'ipt>'); }</script>
	<script src="/community/js/xenforo/xenforo.js?_v=303ae0ca"></script>
	<script src="/community/js/bbm/zloader.js?_v=303ae0ca"></script>
	<link href="//netdna.bootstrapcdn.com/font-awesome/4.0.3/css/font-awesome.css" rel="stylesheet">
	<script type="text/javascript" src="/js/fancybox/jquery.mousewheel-3.0.4.pack.js"></script>
	<script type="text/javascript" src="/js/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
	<link rel="stylesheet" type="text/css" href="/js/fancybox/jquery.fancybox-1.3.4.css" media="screen" />
	<link href="/themes/howtoforge/templates/style.css" rel="stylesheet">
	<link rel="alternate" type="application/rss+xml" title="RSS-Feed für Howtoforge" href="/feed.rss" />
	<script src="/js/tinymce_4.1.7/tinymce.min.js"></script>

<script type='text/javascript' src='https://partner.googleadservices.com/gampad/google_service.js'>
</script>
<script type='text/javascript'>
GS_googleAddAdSenseService("ca-pub-3043223216276099");
GS_googleEnableAllServices();
</script>
<script language="JavaScript">
GA_googleAddAttr("Category", "Linux");
GA_googleAddAttr("Category", "Networking");
</script>
<script type='text/javascript'>
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_leaderboard_a_728x90");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_rectangle_a_300x250");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_rectangle_b_300x250");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_halfpage_a_300x600");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_leaderboard_b_728x90");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_halfpage_b_300x600");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_a_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_b_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_c_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_d_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_list_sidebar_top");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_list_content_middle");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_list_bottom");
</script>

<script type='text/javascript'>
GA_googleFetchAds();
</script>

<!-- Begin Cookie Consent plugin by Silktide - http://silktide.com/cookieconsent -->
<script type="text/javascript">
    window.cookieconsent_options = {"message":"This website uses cookies to ensure you get the best experience on our website","dismiss":"Got it!","learnMore":"More info","link":"https://www.howtoforge.com/community/help/cookies","theme":"dark-bottom"};
</script>

<script type="text/javascript" src="/js/cookieconsent.latest.min.js"></script>
<!-- End Cookie Consent plugin -->


</head>
<body>
<div id="loginBar">
	<div class="pageWidth">
		<div class="pageContent">	
			<h3 id="loginBarHandle">
				<label for="LoginControl"><a href="/community/login/" class="concealed noOutline">Log in or Sign up</a></label>
			</h3>
			<span class="helper"></span>
		</div>
	</div>
</div>
<header>
<div id="header">
	<div id="logoBlock">
	<div class="pageWidth">
		<div class="pageContent">
					<div id="logo"><a href="/">
						<span></span>
						<img src="/images/howtoforge_logo_trans.gif" alt="Howtoforge" style="margin-left:20px;" />
					</a></div>
			<span class="helper"></span>
			<div class="langSwitch">
				<b><img src="/images/gb.png" alt="HowtoForge - Linux Tutorials in English" /> English</b> | <a href="https://www.howtoforge.de/" title="HowtoForge.de - Linux Tutorials auf Deutsch"><img src="/images/de.png" alt="HowtoForge.de - Linux Tutorials auf Deutsch" /> Deutsch</a>
			</div>
		</div>
	</div>
</div>
<div id="navigation" class="pageWidth withSearch">
	<div class="pageContent">
		<nav>
<div class="navTabs">
	<ul class="publicTabs">
		<!-- home -->
		<li class="navTab forums selected">
			<a href="/" class="navLink">Tutorials</a>
						<div class="tabLinks forumsTabLinks">
				<ul class="secondaryContent blockLinksList">
					<li><a href="/search/">Tutorial search</a></li>
				</ul>
			</div>
					</li>
		<li class="navTab forums PopupClosed">
			<a href="/tutorials/" class="navLink">Tags</a>
					</li>
		<li class="navTab forums PopupClosed"><a href="/community/" class="navLink">Forums</a></li>
		<li class="navTab forums PopupClosed"><a href="/linux-commands/" class="navLink">Linux Commands</a></li>
		<li class="navTab forums PopupClosed"><a href="/subscription/" class="navLink">Subscribe</a></li>
		<li class="navTab forums PopupClosed"><a href="http://www.ispconfig.org" class="navLink">ISPConfig</a></li>
		<li class="navTab forums PopupClosed"><a href="http://www.lxer.com" class="navLink">News</a></li>
	</ul>
</div>
<span class="helper"></span>
		</nav>	
	</div>
</div>
	

<div id="searchBar" class="pageWidth">
	<span id="QuickSearchPlaceholder" title=" Search..."> Search</span>
	<fieldset id="QuickSearch">
		<form action="/" method="post" class="formPopup">
			<div class="primaryControls">
				<!-- block: primaryControls -->
				<input type="search" name="q" value="" class="textCtrl" placeholder="Search..." results="0" title="Enter your search and hit enter..." id="QuickSearchQuery" />				
				<!-- end block: primaryControls -->
			</div>
			<input type="hidden" name="_xfToken" value="" />
		</form>		
	</fieldset>
</div>
</div>

		
		
	</header>
	
<div id="content" class="forum_list">
	<div class="pageWidth">
		<div class="pageContent">
			<!-- main content area -->
				<div class="mainContainer">
					<div class="mainContent">
						<!-- begin main template -->
						<div class="breadBoxTop">
<nav>
	<fieldset class="breadcrumb">
		<span class="crumbs">
				<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
					<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Tutorials</span></a>
					<span class="arrow"><span></span></span>
				</span>
				<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
					<a href="/tutorial/software-defined-networking-sdn-openflow-and-ovsdb-connection/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Software Defined Networking (SDN) - OpenFlow and OVSDB connection</span></a>
					<span class="arrow"><span>&gt;</span></span>
				</span>
		</span>
	</fieldset>
</nav>
</div>

<!-- Begin Article content -->
<div id="htfContentPage">


<h1>Software Defined Networking (SDN) - OpenFlow and OVSDB connection</h1>

<div class="bsa-apiads"><a href="//srv.buysellads.com/ads/click/x/GTND4237F6BD5K7JCWB4YKQWF6AIP2QICAYIKZ3JCEAIL2Q7CWSI45QKC6BDL5QWFT7DEK3EHJNCLSIZ" target="_blank" rel="nofollow">How to build a Node.js powered website with Contentful in eight simple steps</a><img src="https://www.launchbit.com/taz-pixel/11341-6916-111" height="1" width="1" border="0" style="display:none;" /></div>
<div class="contributeEdit" style="float:right; width:450px; max-width:100%;">
	<!--<p style="text-align:right;"><button type="button" class="btn btn-success" onClick="document.location.href='/contribute/'">Write for HowtoForge</button></p>-->
	</div>



<p><span>This article is based on OpenFlow and OVSDB connection between SDN controller and Openflow based switches and provides details on connection lifecycle. We will use open source SDN controller </span><span>i.e.</span> <i><span>Opendaylight (ODL) Carbon release</span></i><span> and Openflow virtual switch </span><span>i.e.</span> <i><span>OpenVswitch (OVS) version 2.6.0</span></i><span> to describe about OVSDB and Openflow connection.</span></p>
<p><span>SDN controller manages underlying Openflow switches through two types of connection:</span></p>
<ul>
<li><span>OVSDB</span></li>
<li><span>Openflow</span></li>
</ul>
<h2><strong>OVSDB and Openflow connection</strong></h2>
<p><span>OVSDB is OVS database management protocol which defines schema for OVS database and specification for communication between controller and switch. SDN controller uses this protocol to control OVS switch by populating its database with the intended configuration.</span></p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;"><!-- begin ad tag Rectangle A -->
<!-- howtoforge_com_article_rectangle_a_300x250 -->
<script type='text/javascript'>
GA_googleFillSlot('howtoforge_com_article_rectangle_a_300x250');
</script>
<!-- End ad tag Rectangle A --></div>
<p><span>Typically, SDN controller runs in passive mode to listen for OVSDB and Openflow connections from OVS on ports 6640 and 6653 respectively. </span></p>
<p><span>So first, let us start ODL controller, you can download it from </span><a href="https://www.opendaylight.org/downloads"><span>here</span></a><span>. It is a prerequisite to set JAVA_HOME environment variable in your system to latest Java version. Running ODL is so easy, just do below steps:</span></p>
<ol>
<li><span>Download ODL distribution from </span><a href="https://www.opendaylight.org/downloads"><span>here</span></a><span>.</span></li>
<li><span>Unzip the ODL distribution.</span></li>
<li><span>Enter the </span><span>&lsquo;bin&rsquo;</span><span> sub-directory located under the top-level directory of the downloaded package.</span></li>
<li><span>Run the following command to get your controller up: karaf</span></li>
</ol>
<p><span>Below is the image for above steps performed:</span></p>
<p><span><a class="fancybox" id="img-sdn3-img1" href="https://www.howtoforge.com/images/how-to-compare-files-and-directories-in-linux-using-beyond-compare/big/sdn3-img1.png"><img src="https://www.howtoforge.com/images/how-to-compare-files-and-directories-in-linux-using-beyond-compare/sdn3-img1.png" alt="Install OpenDaylight" width="500" height="229" /></a></span></p>
<p><span>As we need to manage OVS switches to which OVSDB and Openflow connections will be made, so Openflow and OVSDB plugins need to be installed into ODL. </span><span>which is to be done</span><span> This can be done as shown below:</span></p>
<p><span><a class="fancybox" id="img-sdn3-img2" href="https://www.howtoforge.com/images/how-to-compare-files-and-directories-in-linux-using-beyond-compare/big/sdn3-img2.png"><img src="https://www.howtoforge.com/images/how-to-compare-files-and-directories-in-linux-using-beyond-compare/sdn3-img2.png" alt="Openflow and OVSDB plugin installation" width="500" height="236" /></a></span></p>
<p><span>Once Openflow and OVSDB plugins are installed, ODL starts listening for Openflow and OVSDB connections at 6653 and 6640 port respectively. This can be checked at controller by running the following commands:</span></p>
<p class="command"><span>netstat -a | grep 6653</span></p>
<p class="command"><span>netstat -a | grep 6640</span></p>
<p><span><a class="fancybox" id="img-sdn3-img3" href="https://www.howtoforge.com/images/how-to-compare-files-and-directories-in-linux-using-beyond-compare/big/sdn3-img3.png"><img src="https://www.howtoforge.com/images/how-to-compare-files-and-directories-in-linux-using-beyond-compare/sdn3-img3.png" alt="netstat result" width="500" height="85" /></a></span></p>
<p><span>It is noted that OVS switch should already be running before executing any OVS command. To run OVS on Ubuntu, run the following command with root permissions:</span></p>
<p class="command"><span>sudo /etc/init.d/openvswitch-switch start</span></p>
<p><span>It is available as service, so you can check its status as well.</span></p>
<p class="command"><span>sudo /etc/init.d/openvswitch-switch status</span></p>
<p><span>Once, OVS is running, you can execute its CLI commands also. For example, </span></p>
<p class="command"><span>sudo ovs-vsctl show</span></p>
<p><span>Below is the image for above command execution output:</span></p>
<p><span><a class="fancybox" id="img-sdn3-img4" href="https://www.howtoforge.com/images/how-to-compare-files-and-directories-in-linux-using-beyond-compare/big/sdn3-img4.png"><img src="https://www.howtoforge.com/images/how-to-compare-files-and-directories-in-linux-using-beyond-compare/sdn3-img4.png" alt="ovs-vsctl show" width="500" height="78" /></a></span></p>
<p><span>At OVS side, below command is run to initiate OVSDB connection with controller:</span></p>
<p class="command">ovs-vsctl set-manager tcp:&lt;controller-IP&gt;:6640</p>
<p><span>To confirm that the connection is established, below command can be run which shows </span><span>&lsquo;is_connected&rsquo;</span><span> flag is set to true in the output.</span></p>
<p class="command"><span>sudo ovs-vsctl show</span></p>
<p><span><a class="fancybox" id="img-sdn3-img5" href="https://www.howtoforge.com/images/how-to-compare-files-and-directories-in-linux-using-beyond-compare/big/sdn3-img5.png"><img src="https://www.howtoforge.com/images/how-to-compare-files-and-directories-in-linux-using-beyond-compare/sdn3-img5.png" alt="Connection is_connected flag" width="500" height="144" /></a></span></p>
<p><span>Openflow connection is made on bridge, so either you can create bridge on OVS or ODL can also create bridge on OVS by sending configuration to OVS via OVSDB connection. Over the bridge in OVS, below command can be run to connect bridge to ODL, </span><span>which establishes</span><span> establishing Openflow connection between ODL and OVS. </span></p>
<p class="command">ovs-vsctl set-controller &lt;bridge name&gt; tcp:&lt;controller-IP&gt;:6653</p>
<p><span>Check below for their connection details.</span></p>
<p><span><a class="fancybox" id="img-sdn3-img6" href="https://www.howtoforge.com/images/how-to-compare-files-and-directories-in-linux-using-beyond-compare/big/sdn3-img6.png"><img src="https://www.howtoforge.com/images/how-to-compare-files-and-directories-in-linux-using-beyond-compare/sdn3-img6.png" alt="connection details" width="500" height="148" /></a></span></p>
<p><span>As we have seen from OVS side that OVSDB and Openflow connections have been made and same can be verified at ODL side by running the following commands.</span></p>
<p class="command"><span>netstat -a | grep 6653</span></p>
<p class="command"><span>netstat -a | grep 6640</span></p>
<p><span>Check below image for the output of the commands which confirms connection ESTABLISHED state:</span></p>
<p><span><a class="fancybox" id="img-sdn3-img7" href="https://www.howtoforge.com/images/how-to-compare-files-and-directories-in-linux-using-beyond-compare/big/sdn3-img7.png"><img src="https://www.howtoforge.com/images/how-to-compare-files-and-directories-in-linux-using-beyond-compare/sdn3-img7.png" alt="Connections established" width="500" height="105" /></a></span></p>
<p><span>Since OVSDB and Openflow connection </span><span>as</span><span> are based on TCP, messages exchanged between ODL and OVS can be easily captured through Wireshark software. Check below packet capture image which shows messages exchanged during connection setup.</span></p>
<p><span><a class="fancybox" id="img-sdn3-img8" href="https://www.howtoforge.com/images/how-to-compare-files-and-directories-in-linux-using-beyond-compare/big/sdn3-img8.png"><img src="https://www.howtoforge.com/images/how-to-compare-files-and-directories-in-linux-using-beyond-compare/sdn3-img8.png" alt="Wireshark" width="500" height="264" /></a></span></p>
<p><span>In Wireshark packet capture logs, you can see various Openflow messages which are exchanged between controller and OVS during connection setup.</span></p>
<p><span>As you are seeing during connection setup, ODL sent FEATURES_REQUEST Openflow messages and in response, ODL received FEATURES_REPLY from OVS. Inside FEATURES_REPLY messages, ODL gets datapath ID (i.e. unique identifier) of OVS bridge which takes care of forwarding (based on Openflow rules configured by OFL) the traffic among the Virtual machines connected to the ports of OVS. </span></p>
<p><span>At OVS side, the following command can be run to show details of bridge.</span></p>
<p class="command"><span>sudo ovs-ofctl show br-int -OOpenFlow13</span></p>
<p><span>Check below image for the output of the command:</span></p>
<p><span><a class="fancybox" id="img-sdn3-img9" href="https://www.howtoforge.com/images/how-to-compare-files-and-directories-in-linux-using-beyond-compare/big/sdn3-img9.png"><img src="https://www.howtoforge.com/images/how-to-compare-files-and-directories-in-linux-using-beyond-compare/sdn3-img9.png" alt="ovfs-ofctl command result" width="500" height="139" /></a></span></p>
<p><span>Here, you can see FEATURE_REPLY shows the datapath ID (in hex format) of the bridge on OVS.</span></p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;"><!-- begin ad tag Rectangle B -->
<!-- howtoforge_com_article_rectangle_b_300x250 -->
<script type='text/javascript'>
GA_googleFillSlot('howtoforge_com_article_rectangle_b_300x250');
</script>
<!-- End ad tag Rectangle B --></div>
<p><span>Even ODL has dashboard DLUX feature which gives GUI web interface to ODL controller at url </span><a href="http://localhost:8181/index.html"><span>http://localhost:8181/index.html</span></a><span> on which ODL user can log in (by default username and password is &lsquo;admin&rsquo;) and check network topology on the browser of the system where ODL is running. Check below images for same.</span></p>
<p><span><a class="fancybox" id="img-sdn3-img10" href="https://www.howtoforge.com/images/how-to-compare-files-and-directories-in-linux-using-beyond-compare/big/sdn3-img10.png"><img src="https://www.howtoforge.com/images/how-to-compare-files-and-directories-in-linux-using-beyond-compare/sdn3-img10.png" alt="ODL has dashboard DLUX feature" width="500" height="265" /></a></span></p>
<p><span><a class="fancybox" id="img-sdn3-img11" href="https://www.howtoforge.com/images/how-to-compare-files-and-directories-in-linux-using-beyond-compare/big/sdn3-img11.png"><img src="https://www.howtoforge.com/images/how-to-compare-files-and-directories-in-linux-using-beyond-compare/sdn3-img11.png" alt="Topology" width="500" height="188" /></a></span></p>
<p><span>In the above image, you can see the OVS switch is shown in the network topology being managed by ODL controller. Since, we have connected one switch only, that is why only one Openflow node is shown. Here, OVS switch is shown with its datapath ID in decimal format.</span></p>
<p><span>To delete Openflow connection with ODL, below command can be run at OVS:</span></p>
<p class="command">ovs-vsctl del-controller &lt;bridge name&gt;</p>
<p><span>To delete OVSDB connection with ODL, below command can be run at OVS:</span></p>
<p class="command">ovs-vsctl del-manager</p>
<p><span>After connection is deleted, &lsquo;is_conncted&rsquo; flag that was &lsquo;true&rsquo; when connection was established, will disappear from output of &lsquo;ovs-vsctl show&rsquo; CLI command of OVS.</span></p>
<p><span>Check below image for OpenFlow and OVSDB connection deletion initiated from OVS side:</span></p>
<p><span><a class="fancybox" id="img-sdn3-img12" href="https://www.howtoforge.com/images/how-to-compare-files-and-directories-in-linux-using-beyond-compare/big/sdn3-img12.png"><img src="https://www.howtoforge.com/images/how-to-compare-files-and-directories-in-linux-using-beyond-compare/sdn3-img12.png" alt="OpenFlow and OVSDB connection" width="500" height="324" /></a></span></p>
<p><span>For debugging and troubleshooting, you can check log files maintained in ODL and OVS.</span></p>
<h2><strong>ODL logging path</strong></h2>
<p><span>When ODL distribution (which you have downloaded) is unzipped and you run the &lsquo;</span><span>karaf&rsquo;</span><span> binary executable, then &lsquo;</span><span>log&rsquo;</span><span> sub-directory gets created which contains </span><span>karaf.log</span><span> files and their generic path is: <em>~/distribution-karaf-&lt;version-number&gt;-&lt;release name&gt;/data/log.</em></span></p>
<p><span>Check below image for ODL side log files.</span></p>
<p><span><a class="fancybox" id="img-sdn3-img13" href="https://www.howtoforge.com/images/how-to-compare-files-and-directories-in-linux-using-beyond-compare/big/sdn3-img13.png"><img src="https://www.howtoforge.com/images/how-to-compare-files-and-directories-in-linux-using-beyond-compare/sdn3-img13.png" alt="ODL logging path" width="500" height="115" /></a></span></p>
<h2><strong>OVS logging path</strong></h2>
<p><span>When OVS is running, it generates an OVSDB log file named &lsquo;ovsdb-server.log&rsquo; and Openflow log file named &lsquo;ovs-vswitchd.log&rsquo; at path:</span></p>
<pre><span>/var/log/openvswitch</span></pre>
<p><span>Check below image for OVS side log files for OVSDB (ovsdb-server.log) and Openflow modules (ovs-vswitchd.log) of OVS. </span></p>
<p><span><a class="fancybox" id="img-sdn3-img14" href="https://www.howtoforge.com/images/how-to-compare-files-and-directories-in-linux-using-beyond-compare/big/sdn3-img14.png"><img src="https://www.howtoforge.com/images/how-to-compare-files-and-directories-in-linux-using-beyond-compare/sdn3-img14.png" alt="OVS logging path" width="500" height="158" /></a></span></p>
<p class="system"><span><span>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; +===+</span></span></p>
<p class="system"><span><span>This article is co-authored by&nbsp;<a href="https://www.linkedin.com/in/tarun-thakur-36b67a19/">Tarun Thakur</a>.</span></span></p>
<p>References:</p>
<ul>
<li><a href="https://www.rfc-editor.org/rfc/rfc7047.txt"><span>https://www.rfc-editor.org/rfc/rfc7047.txt</span></a></li>
</ul>

<div style="height:30px; margin-top:20px;">
	<p style="text-align:right;"><img src="/images/pdficon_small.png" /> <a href="/subscription/">view as pdf</a> | <img src="/images/print.gif" /> <a href="/subscription/">print</a></p>
</div>
<div style="height:30px; margin-top:20px;">
	<div style="float:left;"><b>Share this page:</b></div>
		<div style="float:left; margin-left:10px;"><a href="https://twitter.com/share" class="twitter-share-button" data-count="horizontal" data-lang="en-US" data-url="https://www.howtoforge.com/tutorial/software-defined-networking-sdn-openflow-and-ovsdb-connection/" data-via="howtoforgecom">Tweet</a> <a class="twitter-follow-button" href="https://twitter.com/howtoforgecom">Follow</a></div>
	<div style="float:left; margin-left:20px;"><fb:like href="https://www.howtoforge.com/tutorial/software-defined-networking-sdn-openflow-and-ovsdb-connection/" layout="button_count" action="recommend" font="trebuchet ms" colorscheme="light"></fb:like></div>
	<div style="float:left; margin-left:50px;"><div class="g-plusone" data-size="medium" data-count="true" data-href="https://www.howtoforge.com/tutorial/software-defined-networking-sdn-openflow-and-ovsdb-connection/"></div></div>
	</div>

</div>

<!-- End article content -->


<!-- Matched Content -->
<div id="htfContentPagePaging">
<h2>Suggested articles</h2>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-3043223216276099"
     data-ad-slot="8940054090"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<!-- Matched Content -->

<!-- Begin Comment section -->
<div id="htfContentPageComment">
<a name="comments"></a>
<h2>0 Comment(s)</h2>

<!-- begin comment form -->
<div id="commentform">
<div class="commentContainerHead" style="font-size:18px;">Add comment</div>
<div class="commentContainer">
<form method="post" action="/tutorial/software-defined-networking-sdn-openflow-and-ovsdb-connection/#comments">
<input type="hidden" name="reply_to" id="reply-to-comment" value="0" />
<div id="commentFormDetail">
  <div style="width:48%; float:left; margin-right:3%">
    <label for="commentname">Name *</label>
    <input id="commentname" name="commentname" value="" />
  </div>
  <div style="width:48%;float:left;">
    <label for="commentname">Email *</label>
    <input id="commentemail" name="commentemail" value="" />
  </div>
  <div style="clear:both;"></div>
</div>
<textarea id="commentedit" name="commentedit" style="width:auto;"></textarea>
<div>
<div style="float:left;">
      <div class="g-recaptcha" data-sitekey="6LdX9fUSAAAAALWwVoPdeXScMSketz4npF-0QcQ1"></div>
      <script type="text/javascript"
          src="https://www.google.com/recaptcha/api.js?hl=en">
      </script>
</div>
<div style="margin-top:10px;margin-bottom:10px;">
	<input type="submit" name="submit" class="button primary" style="float:right;" value="Submit comment">
</div>
<div style="clear:both;"></div>
</div>

<!--<div style="height:30px;"><p>&nbsp;</p></div>-->
<script>
	tinymce.init({
		selector: "textarea#commentedit",
		theme: "modern",
		height: 100,
		apply_source_formatting : true,
		remove_linebreaks : false,
		menubar : false,
		/*auto_focus : "commentedit",*/
		plugins: [
		"link"
		],
		/*plugins: [
			"advlist autolink link image lists charmap print preview hr anchor pagebreak spellchecker",
			"searchreplace wordcount visualblocks visualchars code fullscreen insertdatetime media nonbreaking",
			"save table contextmenu directionality emoticons template paste textcolor"
		],*/
		content_css: "https://www.howtoforge.com/themes/howtoforge/css/custom.css",
		toolbar: "undo redo | bold italic link", 
		/*style_formats: [
			{title: 'Bold text', inline: 'b'},
			{title: 'Red text', inline: 'span', styles: {color: '#ff0000'}},
			{title: 'Red header', block: 'h1', styles: {color: '#ff0000'}},
			{title: 'Example 1', inline: 'span', classes: 'example1'},
			{title: 'Example 2', inline: 'span', classes: 'example2'},
			{title: 'Table styles'},
			{title: 'Table row 1', selector: 'tr', classes: 'tablerow1'}
		]*/
	}); 
	</script>
</form>
</div>
</div>
<!-- end comment form -->

</div>
<!-- End Comment section -->

<div class="breadBoxBottom">
<nav>
	<fieldset class="breadcrumb">
		<span class="crumbs">
				<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
					<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Tutorials</span></a>
					<span class="arrow"><span></span></span>
				</span>
				<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
					<a href="/tutorial/software-defined-networking-sdn-openflow-and-ovsdb-connection/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Software Defined Networking (SDN) - OpenFlow and OVSDB connection</span></a>
					<span class="arrow"><span>&gt;</span></span>
				</span>
		</span>
	</fieldset>
</nav>
</div>
<script>
<!--

$(document).on('click', 'a.reply-to', function(e) {
	e.preventDefault();
	
	var self = $(this);
	var cid = self.attr('data-comment');
	console.log(cid);
	if(!cid) return this;
	
	$('#commentform').insertAfter('#comment' + cid);
	$('#reply-to-comment').val(cid);
	/*tinyMCE.activeEditor.focus();*/
	var textareaId = 'commentedit';
	tinyMCE.get(textareaId).remove();
	tinyMCE.execCommand("mceAddEditor", false, textareaId);
	tinyMCE.activeEditor.focus();
});
//-->
</script>
						
<div style="margin-top:10px;margin-bottom:10px;text-align:center;">
<!--Start Leaderboard-->
<center>
<!-- begin ad tag Leaderboard B -->
<!-- howtoforge_com_article_leaderboard_b_728x90 -->
<script type='text/javascript'>
GA_googleFillSlot("howtoforge_com_article_leaderboard_b_728x90");
</script>
<!-- End ad tag Leaderboard B -->
</center>
<!--Ende Leaderboard--></div>
						<!-- end main template -->
						<!-- beginlogin form, to be moved to the upper drop-down -->
						<form action="/community/login/login?redirect=/tutorial/software-defined-networking-sdn-openflow-and-ovsdb-connection/" method="post" class="xenForm eAuth" id="login" style="display:none">

	<ul id="eAuthUnit">
					<li><a href="/community/register/facebook?reg=1" class="fbLogin" tabindex="110"><span>Log in with Facebook</span></a></li>
					<li><a href="/community/register/twitter?reg=1" class="twitterLogin" tabindex="110"><span>Log in with Twitter</span></a></li>
					<li><span class="googleLogin GoogleLogin JsOnly" tabindex="110" data-client-id="198773272284-b6tfk0c28bje81p774prrcrkq9jb3o44.apps.googleusercontent.com" data-redirect-url="/community/register/google?code=__CODE__&amp;csrf=hVMXbW_3rnrmq4Em"><span>Log in with Google</span></span></li>	
		</ul>

	<div class="ctrlWrapper">
		<dl class="ctrlUnit">
			<dt><label for="LoginControl">Your name or email address:</label></dt>
			<dd><input type="text" name="login" id="LoginControl" class="textCtrl" tabindex="101" /></dd>
		</dl>
	
	
		<dl class="ctrlUnit">
			<dt>
				<label for="ctrl_password">Do you already have an account?</label>
			</dt>
			<dd>
				<ul>
					<li><label for="ctrl_not_registered"><input type="radio" name="register" value="1" id="ctrl_not_registered" tabindex="105" />
						No, create an account now.</label></li>
					<li><label for="ctrl_registered"><input type="radio" name="register" value="0" id="ctrl_registered" tabindex="105" checked="checked" class="Disabler" />
						Yes, my password is:</label></li>
					<li id="ctrl_registered_Disabler">
						<input type="password" name="password" class="textCtrl" id="ctrl_password" tabindex="102" />
						<div class="lostPassword"><a href="/community/lost-password/" tabindex="106">Forgot your password?</a></div>
					</li>
				</ul>
			</dd>
		</dl>
	
		
		<dl class="ctrlUnit submitUnit">
			<dt></dt>
			<dd>
				<input type="submit" class="button primary" value="Log in" tabindex="104" data-loginPhrase="Log in" data-signupPhrase="Sign up" />
				<label for="ctrl_remember" class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_remember" tabindex="103" /> Stay logged in</label>
			</dd>
		</dl>
	</div>

	<input type="hidden" name="cookie_check" value="1" />
	<input type="hidden" name="redirect" value="/community/" />
	<input type="hidden" name="_xfToken" value="" />

</form>
						<!-- end login form -->
					</div>
				</div>
				
				<!-- sidebar -->
				<aside>
					<div class="sidebar">

<div class="section loginButton">		
	<div class="secondaryContent">
		<label for="LoginControl" id="SignupButton"><a href="/community/login/" class="inner">Sign up now!</a></label>
	</div>
</div>


<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-2">

<!-- Social media -->
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
	<div class="section infoBlock sharePage">
		<div class="secondaryContent socialMediaIcon">
	<a href="https://twitter.com/howtoforgecom" target="_blank"><img src="/images/socialmedia/64x64/twitter.png" /></a>
	<a href="https://www.facebook.com/howtoforge" target="_blank"><img src="/images/socialmedia/64x64/facebook.png" /></a>
	<a href="https://plus.google.com/+howtoforge/posts" target="_blank"><img src="/images/socialmedia/64x64/googleplus.png" /></a>
	<a href="https://www.howtoforge.com/feed" target="_blank"><img src="/images/socialmedia/64x64/rss.png" /></a>
		</div>
	</div>
</div>
	
	<div class="section widget-group-no-name widget-container">
		<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
			<h3>Tutorial Info</h3>
			<div class="pairsJustified">
				<dl class="discussionCount">
					<dt>Author:</dt>
					<dd>Himanshu Arora</dd>
				</dl>
												<dl class="discussionCount">
					<dt>Published:</dt>
					<dd>Jul 07, 2017</dd>
				</dl>
																<dl class="discussionCount">
					<dt>Tags:</dt>
					<dd><a href='/tutorials/linux/' rel='tag'>linux</a>, <a href='/tutorials/networking/' rel='tag'>networking</a></dd>
				</dl>
			</div>	
		</div>
	</div>


<!-- Share buttons -->
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
	<div class="section infoBlock sharePage">
		<div class="secondaryContent">
			<h3>Share This Page</h3>
					<div class="tweet shareControl">
						<a href="https://twitter.com/share" class="twitter-share-button" data-count="horizontal" data-lang="en-US" data-url="https://www.howtoforge.com/tutorial/software-defined-networking-sdn-openflow-and-ovsdb-connection/" data-via="howtoforgecom">Tweet</a> <a class="twitter-follow-button" data-show-screen-name="false" href="https://twitter.com/howtoforgecom">Follow</a>
					</div>
					<div class="facebookLike shareControl">
						<fb:like href="https://www.howtoforge.com/tutorial/software-defined-networking-sdn-openflow-and-ovsdb-connection/" layout="button_count" action="recommend" font="trebuchet ms" colorscheme="light"></fb:like>
					</div>
					<div class="plusone shareControl">
						<div class="g-plusone" data-size="medium" data-count="true" data-href="https://www.howtoforge.com/tutorial/software-defined-networking-sdn-openflow-and-ovsdb-connection/"></div>
					</div>
		</div>
	</div>
</div>

<!--
	<div class="section infoBlock sharePage">
		<div class="secondaryContent">
			<h3>Diese Seite empfehlen</h3>
					<div class="tweet shareControl">
						<a href="https://twitter.com/share" class="twitter-share-button" data-count="horizontal"
							data-lang="en-US"
							data-url="https://www.howtoforge.com/tutorial/software-defined-networking-sdn-openflow-and-ovsdb-connection/"
							data-via="howtoforgecom"
							>Tweet</a>
					</div>
					<div class="facebookLike shareControl">
						<fb:like href="https://www.howtoforge.com/tutorial/software-defined-networking-sdn-openflow-and-ovsdb-connection/" layout="button_count" action="recommend" font="trebuchet ms" colorscheme="light"></fb:like>
					</div>
		</div>
	</div>
-->
	<!--<div class="section infoBlock">
		<div class="secondaryContent"><div style="margin-left:35px;">-->
			<!--Start Sky-->
			<script type="text/javascript">
    google_ad_client = "ca-pub-3043223216276099";
    google_ad_slot = "6709042890";
    google_ad_width = 300;
    google_ad_height = 600;
</script>
<!-- Howtoforge sidebar 300x600 -->
<script type="text/javascript"
src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
				<!--Ende Sky-->
		<!--</div></div>
	</div>-->

</div>			
						
					</div>
				</aside>					
		</div>
	</div>
</div>

<footer>
	


<div class="footer">
	<div class="pageWidth">
		<div class="pageContent">
			
			<div class='skin_branding'><a href="http://www.xenfocus.com" rel="nofollow">Xenforo skin</a><span> by <a href="http://www.xenfocus.com" rel="nofollow">Xenfocus</a></span></div>			
			<ul class="footerLinks">
				<li><a href="/contribute/">Contribute</a></li>
				<li><a href="/community/misc/contact">Contact</a></li>
				<li><a href="/community/help/">Help</a></li>
				<li><a href="/imprint/">Imprint</a></li>
				<li><a href="/" class="homeLink">Tutorials</a></li>
				<li><a href="#navigation" class="topLink">Top</a></li>
				<li><a href="/feed" rel="alternate" class="globalFeed" target="_blank"
					title="RSS-Feed for Howtoforge">RSS-Feed</a></li>
			</ul>
			<span class="helper"></span>
		</div>
	</div>
</div>

<div class="footerLegal">
	<div class="pageWidth">
		<div class="pageContent">
			<ul id="legal">
				<li><a href="/community/help/terms">Terms</a></li>
			</ul>
			<div id="copyright"><a href="https://www.howtoforge.com" class="concealed">Howtoforge <span>&copy; projektfarm GmbH.</span></a></div>
			<span class="helper"></span>
		</div>
	</div>	
</div>
</footer>
<div style="height:100px;"></div>
<script>

jQuery.extend(true, XenForo,
{
	visitor: { user_id: 0 },
	serverTimeInfo:
	{
		now: 1409831907,
		today: 1409781600,
		todayDow: 4
	},
	_lightBoxUniversal: "0",
	_enableOverlays: "1",
	_animationSpeedMultiplier: "1",
	_overlayConfig:
	{
		top: "10%",
		speed: 200,
		closeSpeed: 100,
		mask:
		{
			color: "rgb(0, 0, 0)",
			opacity: "0.6",
			loadSpeed: 200,
			closeSpeed: 100
		}
	},
	_ignoredUsers: [],
	_loadedScripts: {"node_list":true,"node_category":true,"node_forum":true,"sidebar_share_page":true,"wf_default":true,"bbm_buttons":true,"login_bar":true,"twitter":true},
	_cookieConfig: { path: "/", domain: "", prefix: "xf_"},
	_csrfToken: "",
	_csrfRefreshUrl: "/community/login/csrf-token-refresh",
	_jsVersion: "303ae0ca"
});
jQuery.extend(XenForo.phrases,
{
	cancel: "Cancel",

	a_moment_ago:    "A moment ago",
	one_minute_ago:  "1 minute ago",
	x_minutes_ago:   "%minutes% minutes ago",
	today_at_x:      "Today at %time%",
	yesterday_at_x:  "Yesterday at %time%",
	day_x_at_time_y: "%day% at %time%",

	day0: "Sunday",
	day1: "Monday",
	day2: "Tuesday",
	day3: "Wednesday",
	day4: "Thursday",
	day5: "Friday",
	day6: "Saturday",

	_months: "January,February,March,April,May,June,July,August,September,October,November,December",
	_daysShort: "Sun,Mon,Tue,Wed,Thu,Fri,Sat",

	following_error_occurred: "The following error occurred",
	server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
	logging_in: "Logging in",
	click_image_show_full_size_version: "Click this image to show the full-size version.",
	show_hidden_content_by_x: "Show hidden content by {names}"
});

// Facebook Javascript SDK
XenForo.Facebook.appId = "";
XenForo.Facebook.forceInit = true;

/*
document.addEventListener('DOMContentLoaded', function(event) {
  cookieChoices.showCookieConsentBar('Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.',
  'OK');
});
*/

$(document).ready(function() {
	$("a.fancybox").fancybox();
});

</script>
<script async type="text/javascript" src="//cdn.fancybar.net/ac/fancybar.js?zoneid=1502&serve=C6ADVKE&placement=howtoforge" id="_fancybar_js"></script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2155872-1', 'auto');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');

</script>
</body>
</html>