<!DOCTYPE html>
<html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs LoggedOut Sidebar Responsive" xmlns:fb="http://www.facebook.com/2008/fbml">
<head>
<meta charset="utf-8"/>
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1"/>
<meta name="viewport" content="width=device-width, initial-scale=1">
<base href="https://www.howtoforge.com"/>
<script>
			var _b = document.getElementsByTagName('base')[0], _bH = "https://www.howtoforge.com/tutorial/how-to-install-laravel-5x-with-nginx-and-php-fpm-7-on-centos-7/";
			if (_b && _b.href != _bH) _b.href = _bH;
		</script>
<title>How to Install Laravel 5.x with Nginx and PHP-FPM 7.1 on CentOS 7</title>
<meta name="keywords" content="centos,linux,server,web server"/>
<meta name="description" content="In this tutorial, I will show you how to install the Laravel Web Framework with Nginx web server, PHP-FPM 7.1 and MariaDB on a CentOS 7 system. Larave... "/>
<meta name="og:title" content="How to Install Laravel 5.x with Nginx and PHP-FPM 7.1 on CentOS 7">
<meta name="og:description" content="In this tutorial, I will show you how to install the Laravel Web Framework with Nginx web server, PHP-FPM 7.1 and MariaDB on a CentOS 7 system. Larave... ">
<meta name="og:site_name" content="Howtoforge">
<meta name="og:type" content="article">
<meta property="og:image" content="https://www.howtoforge.com/images/teaser/centos.gif">
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="howtoforgecom">
<meta name="twitter:creator" content="howtoforgecom">
<meta name="twitter:title" content="How to Install Laravel 5.x with Nginx and PHP-FPM 7.1 on CentOS 7">
<meta name="twitter:description" content="In this tutorial, I will show you how to install the Laravel Web Framework with Nginx web server, PHP-FPM 7.1 and MariaDB on a CentOS 7 system. Larave... ">
<link rel="alternate" href="https://www.howtoforge.com/tutorial/how-to-install-laravel-5x-with-nginx-and-php-fpm-7-on-centos-7/" hreflang="en"/>
<link rel="canonical" href="https://www.howtoforge.com/tutorial/how-to-install-laravel-5x-with-nginx-and-php-fpm-7-on-centos-7/"/>
<noscript><style>.JsOnly,.jsOnly{display:none!important;}</style></noscript>
<link rel="stylesheet" href="/community/styles/executive/xenfocus/icons/css/font-awesome.min.css"/>
<link href='//fonts.googleapis.com/css?family=Open+Sans:400,700' rel='stylesheet' type='text/css'/>
 
<link rel="stylesheet" href="/community/css.php?css=xenforo,form,public&amp;style=3&amp;dir=LTR&amp;d=1420029973"/>
<link rel="stylesheet" href="/community/css.php?css=bb_code,bbm_buttons,facebook,google,login_bar,node_category,node_forum,node_list,profile_post_list_simple,sidebar_share_page,twitter,wf_default&amp;style=3&amp;dir=LTR&amp;d=1420029973"/>
<script src="//ajax.googleapis.com/ajax/libs/jquery/1.11.3/jquery.min.js"></script>
<script>if (!window.jQuery) { document.write('<scr'+'ipt type="text/javascript" src="/js/jquery/jquery-1.11.3.min.js"><\/scr'+'ipt>'); }</script>
<script src="/community/js/xenforo/xenforo.js?_v=303ae0ca"></script>
<script src="/community/js/bbm/zloader.js?_v=303ae0ca"></script>
<link href="//netdna.bootstrapcdn.com/font-awesome/4.0.3/css/font-awesome.css" rel="stylesheet">
<script type="text/javascript" src="/js/fancybox/jquery.mousewheel-3.0.4.pack.js"></script>
<script type="text/javascript" src="/js/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
<link rel="stylesheet" type="text/css" href="/js/fancybox/jquery.fancybox-1.3.4.css" media="screen"/>
<link href="/themes/howtoforge/templates/style.css" rel="stylesheet">
<link rel="alternate" type="application/rss+xml" title="RSS-Feed für Howtoforge" href="/feed.rss"/>
<script src="/js/tinymce_4.1.7/tinymce.min.js"></script>
<script type='text/javascript' src='https://partner.googleadservices.com/gampad/google_service.js'>
</script>
<script type='text/javascript'>
GS_googleAddAdSenseService("ca-pub-3043223216276099");
GS_googleEnableAllServices();
</script>
<script language="JavaScript">
GA_googleAddAttr("Category", "Centos");
GA_googleAddAttr("Category", "Linux");
GA_googleAddAttr("Category", "Server");
GA_googleAddAttr("Category", "Web server");
</script>
<script type='text/javascript'>
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_leaderboard_a_728x90");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_rectangle_a_300x250");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_rectangle_b_300x250");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_halfpage_a_300x600");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_leaderboard_b_728x90");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_halfpage_b_300x600");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_a_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_b_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_c_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_d_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_list_sidebar_top");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_list_content_middle");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_list_bottom");
</script>
<script type='text/javascript'>
GA_googleFetchAds();
</script>
 
<script type="text/javascript">
    window.cookieconsent_options = {"message":"This website uses cookies to ensure you get the best experience on our website","dismiss":"Got it!","learnMore":"More info","link":"https://www.howtoforge.com/community/help/cookies","theme":"dark-bottom"};
</script>
<script type="text/javascript" src="/js/cookieconsent.latest.min.js"></script>
 
</head>
<body>
<div id="loginBar">
<div class="pageWidth">
<div class="pageContent">
<h3 id="loginBarHandle">
<label for="LoginControl"><a href="/community/login/" class="concealed noOutline">Log in or Sign up</a></label>
</h3>
<span class="helper"></span>
</div>
</div>
</div>
<header>
<div id="header">
<div id="logoBlock">
<div class="pageWidth">
<div class="pageContent">
<div id="logo"><a href="/">
<span></span>
<img src="/images/howtoforge_logo_trans.gif" alt="Howtoforge" style="margin-left:20px;"/>
</a></div>
<span class="helper"></span>
<div class="langSwitch">
<b><img src="/images/gb.png" alt="HowtoForge - Linux Tutorials in English"/> English</b> | <a href="https://www.howtoforge.de/" title="HowtoForge.de - Linux Tutorials auf Deutsch"><img src="/images/de.png" alt="HowtoForge.de - Linux Tutorials auf Deutsch"/> Deutsch</a>
</div>
</div>
</div>
</div>
<div id="navigation" class="pageWidth withSearch">
<div class="pageContent">
<nav>
<div class="navTabs">
<ul class="publicTabs">
 
<li class="navTab forums selected">
<a href="/" class="navLink">Tutorials</a>
<div class="tabLinks forumsTabLinks">
<ul class="secondaryContent blockLinksList">
<li><a href="/search/">Tutorial search</a></li>
</ul>
</div>
</li>
<li class="navTab forums PopupClosed">
<a href="/tutorials/" class="navLink">Tags</a>
</li>
<li class="navTab forums PopupClosed"><a href="/community/" class="navLink">Forums</a></li>
<li class="navTab forums PopupClosed"><a href="/linux-commands/" class="navLink">Linux Commands</a></li>
<li class="navTab forums PopupClosed"><a href="/subscription/" class="navLink">Subscribe</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.ispconfig.org" class="navLink">ISPConfig</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.lxer.com" class="navLink">News</a></li>
</ul>
</div>
<span class="helper"></span>
</nav>
</div>
</div>
<div id="searchBar" class="pageWidth">
<span id="QuickSearchPlaceholder" title=" Search..."> Search</span>
<fieldset id="QuickSearch">
<form action="/" method="post" class="formPopup">
<div class="primaryControls">
 
<input type="search" name="q" value="" class="textCtrl" placeholder="Search..." results="0" title="Enter your search and hit enter..." id="QuickSearchQuery"/>
 
</div>
<input type="hidden" name="_xfToken" value=""/>
</form>
</fieldset>
</div>
</div>
</header>
<div id="content" class="forum_list">
<div class="pageWidth">
<div class="pageContent">
 
<div class="mainContainer">
<div class="mainContent">
 
<div class="breadBoxTop">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Tutorials</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/tutorial/how-to-install-laravel-5x-with-nginx-and-php-fpm-7-on-centos-7/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to Install Laravel 5.x with Nginx and PHP-FPM 7.1 on CentOS 7</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
 
<div id="htfContentPage">
<h1>How to Install Laravel 5.x with Nginx and PHP-FPM 7.1 on CentOS 7</h1>
<div class="bsa-apiads"><a href="//srv.buysellads.com/ads/click/x/GTND4237CE7IK2JJCKY4YKQWF6BDVK7YC67DKZ3JCEAIVKJWCABIKKJKC6BDL23ICABDVK3EHJNCLSIZ" target="_blank" rel="nofollow">Create a powerful website with Squarespace. Start your free trial today.</a><img src="https://www.launchbit.com/taz-pixel/11341-6740-111" height="1" width="1" border="0" style="display:none;"/></div>
<div class="contributeEdit" style="float:right; width:450px; max-width:100%;">
 
<div id="tocContainer">
<h3>On this page</h3>
<ol class="toc">
<li><a href="#step-install-the-epel-repository">Step 1 - Install the EPEL Repository</a></li>
<li><a href="#step-install-nginx">Step 2 - Install Nginx</a></li>
<li><a href="#step-install-and-configure-phpfpm-">Step 3 - Install and Configure PHP-FPM 7.1</a></li>
<li><a href="#step-install-mariadb-server">Step 4 - Install MariaDB Server</a></li>
<li><a href="#step-install-php-composer">Step 5 - Install PHP Composer</a></li>
<li><a href="#step-configure-nginx-virtual-host-for-laravel">Step 6 - Configure Nginx Virtual Host for Laravel</a></li>
<li><a href="#step-install-laravel">Step 7 - Install Laravel</a></li>
<li><a href="#step-configure-selinux">Step 8 - Configure SELinux</a></li>
<li><a href="#step-testing-laravel">Step 9 - Testing Laravel</a></li>
<li><a href="#reference">Reference</a></li>
</ol>
</div>
</div>
<p>Laravel is an open source PHP framework that follows the MVC (Model-View-Controller) design pattern. It has been created by Taylor Otwell in 2011 as an attempt to provide an advanced alternative to the CodeIgniter (CI) framework. In 2011, the Laravel project released version 1 and 2, this year version 5.4 has been released with many improvements like Command-Line (CLI) support named 'artisan', built-in support for more database types and improved routing.</p>
<p>In this tutorial, I will show you how to install the Laravel Web Framework with Nginx web server, PHP-FPM 7.1 and MariaDB on a CentOS 7 system. I&nbsp;will show you step by step how to install and configure Laravel under the LEMP stack on CentOS 7 server.</p>
<p><strong>Prerequisite:</strong></p>
<ul>
<li>CentOS 7 Server.</li>
<li>Root Privileges.</li>
</ul>
<h2 id="step-install-the-epel-repository">Step 1 - Install the EPEL Repository</h2>
<p>EPEL or Extra Package for Enterprise Linux is an additional package repository that provides useful software packages that are not included in the CentOS official repository. It can be installed on RPM based Linux distributions like CentOS and Fedora.</p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;"> 
 
<script type='text/javascript'>
GA_googleFillSlot('howtoforge_com_article_rectangle_a_300x250');
</script>
 </div>
<p>In this tutorial, we need the EPEL repository for the Nginx installation as Nginx packages do not exist in the official CentOS repository. Install the EPEL repository with the yum command below.</p>
<p class="command">yum -y install epel-release</p>
<p>EPEL repository has been installed.</p>
<h2 id="step-install-nginx">Step 2 - Install Nginx</h2>
<p>In this tutorial, we will run a Laravel under the LEMP Stack. Nginx is the web server part of the LEMP stack and can be installed from EPEL repository.</p>
<p>Install Nginx 1.10 from the EPEL repository with yum.</p>
<p class="command">yum -y install nginx</p>
<p>When the installation is complete, start Nginx and add it to start at boot time.</p>
<p class="command">systemctl start nginx<br/>systemctl enable nginx</p>
<p>Nginx is running on port 80, check it with the&nbsp;netstat command below.</p>
<p class="command">netstat -plntu</p>
<p><a class="fancybox" id="img-1" href="https://www.howtoforge.com/images/how_to_install_laravel_5x_with_nginx_and_php_fpm_7_on_centos_7/big/1.png"><img src="https://www.howtoforge.com/images/how_to_install_laravel_5x_with_nginx_and_php_fpm_7_on_centos_7/1.png" alt="Install Nginx on CentOS 7" width="550" height="214"/></a></p>
<p>In case you get 'Command not found' as result, then install the net-tools&nbsp;package as shown below.</p>
<p class="command">yum -y install net-tools</p>
<h2 id="step-install-and-configure-phpfpm-">Step 3 - Install and Configure PHP-FPM 7.1</h2>
<p>Laravel can be installed on a server with PHP version &gt;= 5.6.4. In this tutorial, we will use the latest version PHP 7.1 that is supported by Laravel.</p>
<p>PHP 7.1 does not exist in the CentOS base repository, we need to install it from a third party repository named 'webtatic'.</p>
<p>Install the webtatic repository with this rpm command.</p>
<p class="command">rpm -Uvh https://mirror.webtatic.com/yum/el7/webtatic-release.rpm</p>
<p>Now we can install PHP-FPM with all of the extensions needed by Laravel with a single yum command.</p>
<p class="command">yum install -y php71w php71w-curl php71w-common php71w-cli php71w-mysql php71w-mbstring php71w-fpm php71w-xml php71w-pdo php71w-zip</p>
<p>PHP 7.1 has been installed on our CentOS 7 system.</p>
<p>Next, configure PHP by editing the configuration file php.ini with vim.</p>
<p class="command">vim /etc/php.ini</p>
<p>Uncomment the line below and change the value to 0.</p>
<p class="system">cgi.fix_pathinfo=0</p>
<p>Save the file and exit the editor.</p>
<p>Now edit the PHP-FPM file www.conf.</p>
<p class="command">vim /etc/php-fpm.d/www.conf</p>
<p>PHP-FPM will run under the user and group '<strong>nginx</strong>', change the value of the two lines below to '<strong>nginx</strong>'.</p>
<p class="system">user = nginx<br/>group = nginx</p>
<p>Instead of using the server port, PHP-FPM will run under a&nbsp;socket file. Change the 'listen' value to the path '/<strong>run/php-fpm/php-fpm.sock</strong>' as shown below.</p>
<p class="system">listen = /run/php-fpm/php-fpm.sock</p>
<p>The socket file owner will be the 'nginx' user, and the permission mode is 660. Uncomment and change all values like this:</p>
<p class="system">listen.owner = nginx<br/>listen.group = nginx<br/>listen.mode&nbsp; = 0660</p>
<p>For the environment variables, uncomment these lines and set the values as shown below.</p>
<p class="system">env[HOSTNAME] = $HOSTNAME<br/>env[PATH] = /usr/local/bin:/usr/bin:/bin<br/>env[TMP] = /tmp<br/>env[TMPDIR] = /tmp<br/>env[TEMP] = /tmp</p>
<p>Save the file and exit vim, then start PHP-FPM and enable it to run at boot time.</p>
<p class="command">systemctl start php-fpm<br/>systemctl enable php-fpm</p>
<p>PHP-FPM is running under the socket file, check it with the command below.</p>
<p class="command">netstat -pl | grep php-fpm.sock</p>
<p><a class="fancybox" id="img-2" href="https://www.howtoforge.com/images/how_to_install_laravel_5x_with_nginx_and_php_fpm_7_on_centos_7/big/2.png"><img src="https://www.howtoforge.com/images/how_to_install_laravel_5x_with_nginx_and_php_fpm_7_on_centos_7/2.png" alt="Install and configure PHP 7 on CentOS 7" width="550" height="114"/></a></p>
<p>The PHP and PHP-FPM 7.1 installation and configuration have been completed.</p>
<h2 id="step-install-mariadb-server">Step 4 - Install MariaDB Server</h2>
<p>You can use MySQL or PostgreSQL for your Laravel project. I will use the MariaDB database server for this tutorial. It's available in the CentOS repository. Install MariaDB-server with the yum command below.</p>
<p class="command">yum -y install mariadb mariadb-server</p>
<p>When the installation is complete, start 'mariadb' and enable it to start at boot time.</p>
<p class="command">systemctl start mariadb<br/>systemctl enable mariadb</p>
<p>MariaDB has been started and is running on port 3306, check it with the&nbsp;netstat command.</p>
<p class="command">netstat -plntu</p>
<p><a class="fancybox" id="img-3" href="https://www.howtoforge.com/images/how_to_install_laravel_5x_with_nginx_and_php_fpm_7_on_centos_7/big/3.png"><img src="https://www.howtoforge.com/images/how_to_install_laravel_5x_with_nginx_and_php_fpm_7_on_centos_7/3.png" alt="Install MariaDB Server on CentOS 7" width="550" height="208"/></a></p>
<p>Next, configure the root password for MariaDB with the '<strong>mylsq_secure_installation</strong>' command below.</p>
<p class="command">mysql_secure_installation</p>
<p>Type in your mariadb root password, remove the anonymous user etc.</p>
<p class="system">Set root password? [Y/n] Y<br/>Remove anonymous users? [Y/n] Y<br/>Disallow root login remotely? [Y/n] Y<br/>Remove test database and access to it? [Y/n] Y<br/>Reload privilege tables now? [Y/n] Y</p>
<p>MariaDB installation and configuration has been completed.</p>
<h2 id="step-install-php-composer">Step 5 - Install PHP Composer</h2>
<p>PHP composer is a package manager for the PHP programming language. It has been created in 2011 and it's inspired by the Node.js 'npm' and Ruby's 'bundler' installer. Install composer with the curl command.</p>
<p class="command">curl -sS https://getcomposer.org/installer | sudo php -- --install-dir=/usr/bin --filename=composer</p>
<p>When the installation completed, try to use the '<strong>composer</strong>' command and you will see the results as below.</p>
<p class="command">composer</p>
<p><a class="fancybox" id="img-4" href="https://www.howtoforge.com/images/how_to_install_laravel_5x_with_nginx_and_php_fpm_7_on_centos_7/big/4.png"><img src="https://www.howtoforge.com/images/how_to_install_laravel_5x_with_nginx_and_php_fpm_7_on_centos_7/4.png" alt="Install PHP Composer on CentOS 7" width="550" height="201"/></a></p>
<p>PHP Composer installed on CentOS 7.</p>
<h2 id="step-configure-nginx-virtual-host-for-laravel">Step 6 - Configure Nginx Virtual Host for Laravel</h2>
<p>In this step, we will create the nginx virtual host configuration for the Laravel project. We need to define the web root directory for this Laravel installation, I&nbsp;will use the '<strong>/var/www/laravel</strong>' directory as web root directory.</p>
<p>Create it with the mkdir command below:</p>
<p class="command">mkdir -p /var/www/laravel</p>
<p>Next, go to the nginx directory and create a new virtual host configuration file laravel.conf in the conf.d directory.</p>
<p class="command">cd /etc/nginx<br/>vim conf.d/laravel.conf</p>
<p>Paste the configuration below into the file:</p>
<pre>server {<br/>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; listen 80;<br/>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; listen [::]:80 ipv6only=on;<br/> <br/>&nbsp;&nbsp;&nbsp; # Log files for Debugging<br/>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; access_log /var/log/nginx/laravel-access.log;<br/>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; error_log /var/log/nginx/laravel-error.log;<br/> <br/>&nbsp;&nbsp;&nbsp; # Webroot Directory for Laravel project<br/>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; root /var/www/laravel/public;<br/>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; index index.php index.html index.htm;<br/> <br/>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; # Your Domain Name<br/>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; server_name laravel.hakase-labs.co;<br/> <br/>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; location / {<br/>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; try_files $uri $uri/ /index.php?$query_string;<br/>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; }<br/> <br/>&nbsp;&nbsp;&nbsp; # PHP-FPM Configuration Nginx<br/>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; location ~ \.php$ {<br/>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; try_files $uri =404;<br/>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; fastcgi_split_path_info ^(.+\.php)(/.+)$;<br/>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; fastcgi_pass unix:/run/php-fpm/php-fpm.sock;<br/>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; fastcgi_index index.php;<br/>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;<br/>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; include fastcgi_params;<br/>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; }<br/>}</pre>
<p>Save the file and exit vim.</p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;"> 
 
<script type='text/javascript'>
GA_googleFillSlot('howtoforge_com_article_rectangle_b_300x250');
</script>
 </div>
<p>Test the&nbsp;nginx configuration and make sure there is no error, then restart the&nbsp;nginx service.</p>
<p class="command">nginx -t<br/>systemctl restart nginx</p>
<p><a class="fancybox" id="img-5" href="https://www.howtoforge.com/images/how_to_install_laravel_5x_with_nginx_and_php_fpm_7_on_centos_7/big/5.png"><img src="https://www.howtoforge.com/images/how_to_install_laravel_5x_with_nginx_and_php_fpm_7_on_centos_7/5.png" alt="Nginx Laravel Configuration" width="550" height="167"/></a></p>
<p>The nginx virtual host configuration for Laravel has been completed.</p>
<h2 id="step-install-laravel">Step 7 - Install Laravel</h2>
<p>Before installing Laravel, we need to install unzip on the server.</p>
<p class="command">yum -y install unzip</p>
<p>Now go to the laravel web root directory '/var/www/laravel'.</p>
<p class="command">cd /var/www/laravel</p>
<p>Laravel provides two ways for the installation of the framework on the server. We can install Laravel with the laravel installer, and we can install it with PHP composer. In this tutorial, I will install Laravel by creating a new project with the composer command.</p>
<p>Run the command below to install Laravel.</p>
<p class="command">composer create-project laravel/laravel .</p>
<p><a class="fancybox" id="img-6" href="https://www.howtoforge.com/images/how_to_install_laravel_5x_with_nginx_and_php_fpm_7_on_centos_7/big/6.png"><img src="https://www.howtoforge.com/images/how_to_install_laravel_5x_with_nginx_and_php_fpm_7_on_centos_7/6.png" alt="Laravel Installation on CentOS 7" width="550" height="218"/></a></p>
<p>Wait for the Laravel installation to finish. This may take some time.</p>
<p><a class="fancybox" id="img-7" href="https://www.howtoforge.com/images/how_to_install_laravel_5x_with_nginx_and_php_fpm_7_on_centos_7/big/7.png"><img src="https://www.howtoforge.com/images/how_to_install_laravel_5x_with_nginx_and_php_fpm_7_on_centos_7/7.png" alt="Laravel Installation on CentOS 7" width="550" height="126"/></a></p>
<p>When the installation is complete, change the owner of the Laravel web root directory to the 'nginx' user, and change the permission of the storage directory to 755 with the commands below.</p>
<p class="command">chown -R nginx:root /var/www/laravel<br/>chmod 755 /var/www/laravel/storage</p>
<p>Laravel installation has been completed.</p>
<h2 id="step-configure-selinux">Step 8 - Configure SELinux</h2>
<p>In this tutorial, Laravel will run under SELinux 'Enforcing' mode. To check the SELinux status, run the command below.</p>
<p class="command">sestatus</p>
<p><a class="fancybox" id="img-10" href="https://www.howtoforge.com/images/how_to_install_laravel_5x_with_nginx_and_php_fpm_7_on_centos_7/big/10.png"><img src="https://www.howtoforge.com/images/how_to_install_laravel_5x_with_nginx_and_php_fpm_7_on_centos_7/10.png" alt="SELinux status on CentOS 7" width="395" height="236"/></a></p>
<p>The result is that SELinux is running in '<strong>Enforcing</strong>' mode.</p>
<p>Next, we need to install the SELinux management tools for CentOS 7.</p>
<p>Install 'policycoreutils-python' on the server.</p>
<p class="command">yum -y install policycoreutils-python</p>
<p>Now we need to change the context of the Laravel directories and then apply the changes with the restorecon command. Run the SELinux management commands as shown below.</p>
<p class="command">semanage fcontext -a -t httpd_sys_rw_content_t '/var/www/laravel(/.*)?'<br/>semanage fcontext -a -t httpd_sys_rw_content_t '/var/www/laravel/public(/.*)?'<br/>semanage fcontext -a -t httpd_sys_rw_content_t '/var/www/laravel/storage(/.*)?'<br/>semanage fcontext -a -t httpd_sys_rw_content_t '/var/www/laravel/app(/.*)?'<br/>semanage fcontext -a -t httpd_sys_rw_content_t '/var/www/laravel/bootstrap(/.*)?'<br/>semanage fcontext -a -t httpd_sys_rw_content_t '/var/www/laravel/config(/.*)?'<br/>semanage fcontext -a -t httpd_sys_rw_content_t '/var/www/laravel/database(/.*)?'<br/>semanage fcontext -a -t httpd_sys_rw_content_t '/var/www/laravel/resources(/.*)?'<br/>semanage fcontext -a -t httpd_sys_rw_content_t '/var/www/laravel/routes(/.*)?'<br/>semanage fcontext -a -t httpd_sys_rw_content_t '/var/www/laravel/vendor(/.*)?'<br/>semanage fcontext -a -t httpd_sys_rw_content_t '/var/www/laravel/tests(/.*)?'<br/>restorecon -Rv '/var/www/laravel/'</p>
<p>SELinux configuration for Laravel is done.</p>
<p><a class="fancybox" id="img-8" href="https://www.howtoforge.com/images/how_to_install_laravel_5x_with_nginx_and_php_fpm_7_on_centos_7/big/8.png"><img src="https://www.howtoforge.com/images/how_to_install_laravel_5x_with_nginx_and_php_fpm_7_on_centos_7/8.png" alt="SELinux for Laravel" width="550" height="175"/></a></p>
<h2 id="step-testing-laravel">Step 9 - Testing Laravel</h2>
<p>Open your web browser and type in the Laravel URL of your server. We've defined the domain name for the Laravel in the Nginx virtual host file. Mine is&nbsp;<em><strong>laravel.hakase-labs.co</strong></em>.</p>
<p>When you visit the domain name, you will see the Laravel home page.</p>
<p><a class="fancybox" id="img-9" href="https://www.howtoforge.com/images/how_to_install_laravel_5x_with_nginx_and_php_fpm_7_on_centos_7/big/9.png"><img src="https://www.howtoforge.com/images/how_to_install_laravel_5x_with_nginx_and_php_fpm_7_on_centos_7/9.png" alt="Laravel installed with Nginx PHP-FPM and MariaDB on CentOS 7" width="550" height="236"/></a></p>
<p>Laravel installation with Nginx, PHP-FPM7, and MariaDB on CentOS 7 has been successful.</p>
<h2 id="reference">Reference</h2>
<ul>
<li><a href="https://laravel.com/docs/5.4/installation">https://laravel.com/docs/5.4/installation</a></li>
</ul>
<div style="height:30px; margin-top:20px;">
<p style="text-align:right;"><img src="/images/pdficon_small.png"/> <a href="/subscription/">view as pdf</a> | <img src="/images/print.gif"/> <a href="/subscription/">print</a></p>
</div>
<div style="height:30px; margin-top:20px;">
<div style="float:left;"><b>Share this page:</b></div>
<div style="float:left; margin-left:10px;"><a href="https://twitter.com/share" class="twitter-share-button" data-count="horizontal" data-lang="en-US" data-url="https://www.howtoforge.com/tutorial/how-to-install-laravel-5x-with-nginx-and-php-fpm-7-on-centos-7/" data-via="howtoforgecom">Tweet</a> <a class="twitter-follow-button" href="https://twitter.com/howtoforgecom">Follow</a></div>
<div style="float:left; margin-left:20px;"><fb:like href="https://www.howtoforge.com/tutorial/how-to-install-laravel-5x-with-nginx-and-php-fpm-7-on-centos-7/" layout="button_count" action="recommend" font="trebuchet ms" colorscheme="light"></fb:like></div>
<div style="float:left; margin-left:50px;"><div class="g-plusone" data-size="medium" data-count="true" data-href="https://www.howtoforge.com/tutorial/how-to-install-laravel-5x-with-nginx-and-php-fpm-7-on-centos-7/"></div></div>
</div>
</div>
 
 
<div id="htfContentPagePaging">
<h2>Suggested articles</h2>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-3043223216276099" data-ad-slot="8940054090"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
 
 
<div id="htfContentPageComment">
<a name="comments"></a>
<h2>0 Comment(s)</h2>
 
<div id="commentform">
<div class="commentContainerHead" style="font-size:18px;">Add comment</div>
<div class="commentContainer">
<form method="post" action="/tutorial/how-to-install-laravel-5x-with-nginx-and-php-fpm-7-on-centos-7/#comments">
<input type="hidden" name="reply_to" id="reply-to-comment" value="0"/>
<div id="commentFormDetail">
<div style="width:48%; float:left; margin-right:3%">
<label for="commentname">Name *</label>
<input id="commentname" name="commentname" value=""/>
</div>
<div style="width:48%;float:left;">
<label for="commentname">Email *</label>
<input id="commentemail" name="commentemail" value=""/>
</div>
<div style="clear:both;"></div>
</div>
<textarea id="commentedit" name="commentedit" style="width:auto;"></textarea>
<div>
<div style="float:left;">
<div class="g-recaptcha" data-sitekey="6LdX9fUSAAAAALWwVoPdeXScMSketz4npF-0QcQ1"></div>
<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en">
      </script>
</div>
<div style="margin-top:10px;margin-bottom:10px;">
<input type="submit" name="submit" class="button primary" style="float:right;" value="Submit comment">
</div>
<div style="clear:both;"></div>
</div>
 
<script>
	tinymce.init({
		selector: "textarea#commentedit",
		theme: "modern",
		height: 100,
		apply_source_formatting : true,
		remove_linebreaks : false,
		menubar : false,
		/*auto_focus : "commentedit",*/
		plugins: [
		"link"
		],
		/*plugins: [
			"advlist autolink link image lists charmap print preview hr anchor pagebreak spellchecker",
			"searchreplace wordcount visualblocks visualchars code fullscreen insertdatetime media nonbreaking",
			"save table contextmenu directionality emoticons template paste textcolor"
		],*/
		content_css: "https://www.howtoforge.com/themes/howtoforge/css/custom.css",
		toolbar: "undo redo | bold italic link", 
		/*style_formats: [
			{title: 'Bold text', inline: 'b'},
			{title: 'Red text', inline: 'span', styles: {color: '#ff0000'}},
			{title: 'Red header', block: 'h1', styles: {color: '#ff0000'}},
			{title: 'Example 1', inline: 'span', classes: 'example1'},
			{title: 'Example 2', inline: 'span', classes: 'example2'},
			{title: 'Table styles'},
			{title: 'Table row 1', selector: 'tr', classes: 'tablerow1'}
		]*/
	}); 
	</script>
</form>
</div>
</div>
 
</div>
 
<div class="breadBoxBottom">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Tutorials</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/tutorial/how-to-install-laravel-5x-with-nginx-and-php-fpm-7-on-centos-7/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to Install Laravel 5.x with Nginx and PHP-FPM 7.1 on CentOS 7</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
<script>
<!--

$(document).on('click', 'a.reply-to', function(e) {
	e.preventDefault();
	
	var self = $(this);
	var cid = self.attr('data-comment');
	console.log(cid);
	if(!cid) return this;
	
	$('#commentform').insertAfter('#comment' + cid);
	$('#reply-to-comment').val(cid);
	/*tinyMCE.activeEditor.focus();*/
	var textareaId = 'commentedit';
	tinyMCE.get(textareaId).remove();
	tinyMCE.execCommand("mceAddEditor", false, textareaId);
	tinyMCE.activeEditor.focus();
});
//-->
</script>
<div style="margin-top:10px;margin-bottom:10px;text-align:center;">
 
<center>
 
 
<script type='text/javascript'>
GA_googleFillSlot("howtoforge_com_article_leaderboard_b_728x90");
</script>
 
</center>
 </div>
 
 
<form action="/community/login/login?redirect=/tutorial/how-to-install-laravel-5x-with-nginx-and-php-fpm-7-on-centos-7/" method="post" class="xenForm eAuth" id="login" style="display:none">
<ul id="eAuthUnit">
<li><a href="/community/register/facebook?reg=1" class="fbLogin" tabindex="110"><span>Log in with Facebook</span></a></li>
<li><a href="/community/register/twitter?reg=1" class="twitterLogin" tabindex="110"><span>Log in with Twitter</span></a></li>
<li><span class="googleLogin GoogleLogin JsOnly" tabindex="110" data-client-id="198773272284-b6tfk0c28bje81p774prrcrkq9jb3o44.apps.googleusercontent.com" data-redirect-url="/community/register/google?code=__CODE__&amp;csrf=hVMXbW_3rnrmq4Em"><span>Log in with Google</span></span></li>
</ul>
<div class="ctrlWrapper">
<dl class="ctrlUnit">
<dt><label for="LoginControl">Your name or email address:</label></dt>
<dd><input type="text" name="login" id="LoginControl" class="textCtrl" tabindex="101"/></dd>
</dl>
<dl class="ctrlUnit">
<dt>
<label for="ctrl_password">Do you already have an account?</label>
</dt>
<dd>
<ul>
<li><label for="ctrl_not_registered"><input type="radio" name="register" value="1" id="ctrl_not_registered" tabindex="105"/>
No, create an account now.</label></li>
<li><label for="ctrl_registered"><input type="radio" name="register" value="0" id="ctrl_registered" tabindex="105" checked="checked" class="Disabler"/>
Yes, my password is:</label></li>
<li id="ctrl_registered_Disabler">
<input type="password" name="password" class="textCtrl" id="ctrl_password" tabindex="102"/>
<div class="lostPassword"><a href="/community/lost-password/" tabindex="106">Forgot your password?</a></div>
</li>
</ul>
</dd>
</dl>
<dl class="ctrlUnit submitUnit">
<dt></dt>
<dd>
<input type="submit" class="button primary" value="Log in" tabindex="104" data-loginPhrase="Log in" data-signupPhrase="Sign up"/>
<label for="ctrl_remember" class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_remember" tabindex="103"/> Stay logged in</label>
</dd>
</dl>
</div>
<input type="hidden" name="cookie_check" value="1"/>
<input type="hidden" name="redirect" value="/community/"/>
<input type="hidden" name="_xfToken" value=""/>
</form>
 
</div>
</div>
 
<aside>
<div class="sidebar">
<div class="section loginButton">
<div class="secondaryContent">
<label for="LoginControl" id="SignupButton"><a href="/community/login/" class="inner">Sign up now!</a></label>
</div>
</div>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-2">
 
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent socialMediaIcon">
<a href="https://twitter.com/howtoforgecom" target="_blank"><img src="/images/socialmedia/64x64/twitter.png"/></a>
<a href="https://www.facebook.com/howtoforge" target="_blank"><img src="/images/socialmedia/64x64/facebook.png"/></a>
<a href="https://plus.google.com/+howtoforge/posts" target="_blank"><img src="/images/socialmedia/64x64/googleplus.png"/></a>
<a href="https://www.howtoforge.com/feed" target="_blank"><img src="/images/socialmedia/64x64/rss.png"/></a>
</div>
</div>
</div>
<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<h3>Tutorial Info</h3>
<div class="pairsJustified">
<dl class="discussionCount">
<dt>Author:</dt>
<dd>Muhammad Arul</dd>
</dl>
<dl class="discussionCount">
<dt>Published:</dt>
<dd>May 09, 2017</dd>
</dl>
<dl class="discussionCount">
<dt>Tags:</dt>
<dd><a href='/tutorials/centos/' rel='tag'>centos</a>, <a href='/tutorials/linux/' rel='tag'>linux</a>, <a href='/tutorials/server/' rel='tag'>server</a>, <a href='/tutorials/web+server/' rel='tag'>web server</a></dd>
</dl>
</div>
</div>
</div>
 
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent">
<h3>Share This Page</h3>
<div class="tweet shareControl">
<a href="https://twitter.com/share" class="twitter-share-button" data-count="horizontal" data-lang="en-US" data-url="https://www.howtoforge.com/tutorial/how-to-install-laravel-5x-with-nginx-and-php-fpm-7-on-centos-7/" data-via="howtoforgecom">Tweet</a> <a class="twitter-follow-button" data-show-screen-name="false" href="https://twitter.com/howtoforgecom">Follow</a>
</div>
<div class="facebookLike shareControl">
<fb:like href="https://www.howtoforge.com/tutorial/how-to-install-laravel-5x-with-nginx-and-php-fpm-7-on-centos-7/" layout="button_count" action="recommend" font="trebuchet ms" colorscheme="light"></fb:like>
</div>
<div class="plusone shareControl">
<div class="g-plusone" data-size="medium" data-count="true" data-href="https://www.howtoforge.com/tutorial/how-to-install-laravel-5x-with-nginx-and-php-fpm-7-on-centos-7/"></div>
</div>
</div>
</div>
</div>
 
 
 
<script type="text/javascript">
    google_ad_client = "ca-pub-3043223216276099";
    google_ad_slot = "6709042890";
    google_ad_width = 300;
    google_ad_height = 600;
</script>
 
<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
 
 
</div>
</div>
</aside>
</div>
</div>
</div>
<footer>
<div class="footer">
<div class="pageWidth">
<div class="pageContent">
<div class='skin_branding'><a href="http://www.xenfocus.com" rel="nofollow">Xenforo skin</a><span> by <a href="http://www.xenfocus.com" rel="nofollow">Xenfocus</a></span></div>
<ul class="footerLinks">
<li><a href="/contribute/">Contribute</a></li>
<li><a href="/community/misc/contact">Contact</a></li>
<li><a href="/community/help/">Help</a></li>
<li><a href="/imprint/">Imprint</a></li>
<li><a href="/" class="homeLink">Tutorials</a></li>
<li><a href="#navigation" class="topLink">Top</a></li>
<li><a href="/feed" rel="alternate" class="globalFeed" target="_blank" title="RSS-Feed for Howtoforge">RSS-Feed</a></li>
</ul>
<span class="helper"></span>
</div>
</div>
</div>
<div class="footerLegal">
<div class="pageWidth">
<div class="pageContent">
<ul id="legal">
<li><a href="/community/help/terms">Terms</a></li>
</ul>
<div id="copyright"><a href="https://www.howtoforge.com" class="concealed">Howtoforge <span>&copy; projektfarm GmbH.</span></a></div>
<span class="helper"></span>
</div>
</div>
</div>
</footer>
<div style="height:100px;"></div>
<script>

jQuery.extend(true, XenForo,
{
	visitor: { user_id: 0 },
	serverTimeInfo:
	{
		now: 1409831907,
		today: 1409781600,
		todayDow: 4
	},
	_lightBoxUniversal: "0",
	_enableOverlays: "1",
	_animationSpeedMultiplier: "1",
	_overlayConfig:
	{
		top: "10%",
		speed: 200,
		closeSpeed: 100,
		mask:
		{
			color: "rgb(0, 0, 0)",
			opacity: "0.6",
			loadSpeed: 200,
			closeSpeed: 100
		}
	},
	_ignoredUsers: [],
	_loadedScripts: {"node_list":true,"node_category":true,"node_forum":true,"sidebar_share_page":true,"wf_default":true,"bbm_buttons":true,"login_bar":true,"twitter":true},
	_cookieConfig: { path: "/", domain: "", prefix: "xf_"},
	_csrfToken: "",
	_csrfRefreshUrl: "/community/login/csrf-token-refresh",
	_jsVersion: "303ae0ca"
});
jQuery.extend(XenForo.phrases,
{
	cancel: "Cancel",

	a_moment_ago:    "A moment ago",
	one_minute_ago:  "1 minute ago",
	x_minutes_ago:   "%minutes% minutes ago",
	today_at_x:      "Today at %time%",
	yesterday_at_x:  "Yesterday at %time%",
	day_x_at_time_y: "%day% at %time%",

	day0: "Sunday",
	day1: "Monday",
	day2: "Tuesday",
	day3: "Wednesday",
	day4: "Thursday",
	day5: "Friday",
	day6: "Saturday",

	_months: "January,February,March,April,May,June,July,August,September,October,November,December",
	_daysShort: "Sun,Mon,Tue,Wed,Thu,Fri,Sat",

	following_error_occurred: "The following error occurred",
	server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
	logging_in: "Logging in",
	click_image_show_full_size_version: "Click this image to show the full-size version.",
	show_hidden_content_by_x: "Show hidden content by {names}"
});

// Facebook Javascript SDK
XenForo.Facebook.appId = "";
XenForo.Facebook.forceInit = true;

/*
document.addEventListener('DOMContentLoaded', function(event) {
  cookieChoices.showCookieConsentBar('Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.',
  'OK');
});
*/

$(document).ready(function() {
	$("a.fancybox").fancybox();
});

</script>
<script async type="text/javascript" src="//cdn.fancybar.net/ac/fancybar.js?zoneid=1502&serve=C6ADVKE&placement=howtoforge" id="_fancybar_js"></script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2155872-1', 'auto');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');

</script>
</body>
</html>