<!DOCTYPE html>
<html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs LoggedOut Sidebar Responsive" xmlns:fb="http://www.facebook.com/2008/fbml">
<head>
<meta charset="utf-8" />
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<base href="https://www.howtoforge.com" />
<script>
			var _b = document.getElementsByTagName('base')[0], _bH = "https://www.howtoforge.com/tutorial/docker-guide-deploying-ghost-blog-with-mysql-and-traefik-with-docker/";
			if (_b && _b.href != _bH) _b.href = _bH;
		</script>
<title>Docker Guide: Deploying Ghost Blog with MySQL and Traefik with Docker</title>
<meta name="description" content="In this tutorial, we will show step-by-step how to install and configure Ghost as a Docker container. We will install and configure Ghost under the la... " />
<meta property="og:title" content="Docker Guide: Deploying Ghost Blog with MySQL and Traefik with Docker">
<meta property="og:description" content="In this tutorial, we will show step-by-step how to install and configure Ghost as a Docker container. We will install and configure Ghost under the la... ">
<meta property="og:site_name" content="HowtoForge">
<meta property="og:type" content="article">
<meta property="og:image" content="https://www.howtoforge.com/images/featured/docker-traefik-ghost.jpg">
<meta property="og:image:secure_url" content="https://www.howtoforge.com/images/featured/docker-traefik-ghost.jpg" />
<meta property="og:image:alt" content="Docker Guide: Deploying Ghost Blog with MySQL and Traefik with Docker" />
<meta name="twitter:image" content="https://www.howtoforge.com/images/featured/docker-traefik-ghost.jpg" />
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="@howtoforgecom">
<meta name="twitter:creator" content="@howtoforgecom">
<meta name="twitter:title" content="Docker Guide: Deploying Ghost Blog with MySQL and Traefik with Docker">
<meta name="twitter:description" content="In this tutorial, we will show step-by-step how to install and configure Ghost as a Docker container. We will install and configure Ghost under the la... ">
<link rel="alternate" href="https://www.howtoforge.com/tutorial/docker-guide-deploying-ghost-blog-with-mysql-and-traefik-with-docker/" hreflang="en" />
<link rel="canonical" href="https://www.howtoforge.com/tutorial/docker-guide-deploying-ghost-blog-with-mysql-and-traefik-with-docker/" />
<link rel="amphtml" href="https://www.howtoforge.com/tutorial/docker-guide-deploying-ghost-blog-with-mysql-and-traefik-with-docker/amp/" />
<script type="application/ld+json">
{
  "@context" : "http://schema.org",
  "@type" : "Article",
  "name" : "Docker Guide: Deploying Ghost Blog with MySQL and Traefik with Docker",
  "author" : {
    "@type" : "Person",
    "name" : "Muhammad Arul"
  },
  "articleSection" : "linux,virtualization,web server",
  "url" : "https://www.howtoforge.com/tutorial/docker-guide-deploying-ghost-blog-with-mysql-and-traefik-with-docker/",
  "publisher" : {
    "@type" : "Organization",
    "name" : "Howtoforge"
  }
}
</script>
<noscript><style>.JsOnly, .jsOnly { display: none !important; }</style></noscript>
<link rel="stylesheet" href="/community/styles/executive/xenfocus/icons/css/font-awesome.min.css" />
<link href='//fonts.googleapis.com/css?family=Open+Sans:400,700' rel='stylesheet' type='text/css' />
<link href="/themes/howtoforge/templates/xf.css" rel="stylesheet">
<script src="/js/jquery/jquery-1.11.3.min.js"></script>
<script src="/community/js/xenforo/xenforo.js?_v=303ae0ca"></script>
<script src="/community/js/bbm/zloader.js?_v=303ae0ca"></script>
<script type="text/javascript" src="/js/fancybox/jquery.mousewheel-3.0.4.pack.js"></script>
<script type="text/javascript" src="/js/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
<link rel="stylesheet" type="text/css" href="/js/fancybox/jquery.fancybox-1.3.4.css" media="screen" />
<link href="/themes/howtoforge/templates/style.min.css" rel="stylesheet">
<link rel="alternate" type="application/rss+xml" title="RSS-Feed für Howtoforge" href="/feed.rss" />
<script src="/js/tinymce_4.1.7/tinymce.min.js"></script>

<script type="text/javascript">
var gaProperty = 'UA-2155872-1';
var disableStr = 'ga-disable-' + gaProperty;
if (document.cookie.indexOf(disableStr + '=true') > -1) {
window[disableStr] = true;
}
function gaOptout() {
document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
window[disableStr] = true;
alert('Google Ananlyitics tracking has been disabled in this browser.');
}
</script>
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
	googletag.defineSlot('/1030080/howtoforge_com_list_sidebar_top', [300, 250], 'div-gpt-ad-1527185271042-4').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_list_content_middle', [[300, 250], [336, 280]], 'div-gpt-ad-1527185271042-5').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_a_300x250', [300, 250], 'div-gpt-ad-1527185271042-6').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_b_300x250', [300, 250], 'div-gpt-ad-1527185271042-7').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_leaderboard_b_728x90', [728, 90], 'div-gpt-ad-1527185271042-1').addService(googletag.pubads());
	googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script type="text/javascript">
    window.cookieconsent_options = {"message":"This website uses cookies to ensure you get the best experience on our website, analyze site traffic and show you relevant ads.","dismiss":"Got it!","learnMore":"More info","link":"https://www.howtoforge.com/community/help/cookies","theme":"dark-bottom"};
</script>
<script type="text/javascript" src="/js/cookieconsent.latest.min.js"></script>

</head>
<body>
<div id="loginBar">
<div class="pageWidth">
<div class="pageContent">
<h3 id="loginBarHandle">
<label for="LoginControl"><a href="/community/login/" class="concealed noOutline">Log in or Sign up</a></label>
</h3>
<span class="helper"></span>
</div>
</div>
</div>
<header>
<div id="header">
<div id="logoBlock">
<div class="pageWidth">
<div class="pageContent">
<div id="logo"><a href="/">
<span></span>
<img src="/images/howtoforge_logo_trans.gif" alt="Howtoforge" style="margin-left:20px;" />
</a></div>
<span class="helper"></span>
<div class="langSwitch">
<b><img src="/images/gb.png" alt="HowtoForge - Linux Tutorials in English" /> English</b> | <a href="https://www.howtoforge.de/" title="HowtoForge.de - Linux Tutorials auf Deutsch"><img src="/images/de.png" alt="HowtoForge.de - Linux Tutorials auf Deutsch" /> Deutsch</a>
</div>
</div>
</div>
</div>
<div id="navigation" class="pageWidth withSearch">
<div class="pageContent">
<nav>
<div class="navTabs">
<ul class="publicTabs">

<li class="navTab forums selected">
<a href="/" class="navLink">Tutorials</a>
<div class="tabLinks forumsTabLinks">
<ul class="secondaryContent blockLinksList">
<li><a href="/search/">Tutorial search</a></li>
</ul>
</div>
</li>
<li class="navTab forums PopupClosed">
<a href="/tutorials/" class="navLink">Tags</a>
</li>
<li class="navTab forums PopupClosed"><a href="/community/" class="navLink">Forums</a></li>
<li class="navTab forums PopupClosed"><a href="/linux-commands/" class="navLink">Linux Commands</a></li>
<li class="navTab forums PopupClosed"><a href="/subscription/" class="navLink">Subscribe</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.ispconfig.org" class="navLink">ISPConfig</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.lxer.com" class="navLink">News</a></li>
</ul>
</div>
<span class="helper"></span>
</nav>
</div>
</div>
<div id="searchBar" class="pageWidth">
<span id="QuickSearchPlaceholder" title=" Search..."> Search</span>
<fieldset id="QuickSearch">
<form action="/" method="post" class="formPopup">
<div class="primaryControls">

<input type="search" name="q" value="" class="textCtrl" placeholder="Search..." results="0" title="Enter your search and hit enter..." id="QuickSearchQuery" />

</div>
<input type="hidden" name="_xfToken" value="" />
</form>
</fieldset>
</div>
</div>
</header>
<div id="content" class="forum_list">
<div class="pageWidth">
<div class="pageContent">

<div class="mainContainer">
<div class="mainContent">

<div class="breadBoxTop">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Home</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/tutorial/docker-guide-deploying-ghost-blog-with-mysql-and-traefik-with-docker/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Docker Guide: Deploying Ghost Blog with MySQL and Traefik with Docker</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>

<div id="htfContentPage">
<div class="bsa-apiads"><a href="//srv.buysellads.com/ads/click/x/GTND42QICWSI5K3WF6A4YKQMCKBIK5QICVYIPZ3JCW7IP53MCTAD623KC6BIC2QUCE7DTK3EHJNCLSIZ" target="_blank" rel="nofollow">The brains behind your business in the U.S. just got another brain.</a><img src="https://ad.doubleclick.net/ddm/ad/N2434.3091281BUYSELLADS/B20651262.224782662;sz=1x1;ord=[1535742409];dc_lat=;dc_rdid=;tag_for_child_directed_treatment=;tfua=?" height="1" width="1" border="0" style="display:none;" /><img src="https://pixel.adsafeprotected.com/rfw/st/163180/26884433/skeleton.gif" height="1" width="1" border="0" style="display:none;" /></div>
<h1>Docker Guide: Deploying Ghost Blog with MySQL and Traefik with Docker</h1>
<div class="contributeEdit" style="float:right; width:450px; max-width:100%;">
<div id="tocContainer">
<h3>On this page</h3>
<ol class="toc">
<li><a href="#prerequisites">Prerequisites</a></li>
<li><a href="#what-we-will-do">What we will do</a></li>
<li><a href="#step-install-docker-ce-on-ubuntu-lts">Step 1 - Install Docker CE on Ubuntu 18.04 LTS</a></li>
<li><a href="#step-setup-docker-for-nonroot-user">Step 2 - Setup Docker for Non-root User</a></li>
<li><a href="#step-install-docker-compose">Step 3 - Install Docker Compose</a></li>
<li><a href="#step-configure-ghost-stack">Step 4 - Configure Ghost Stack</a>
<ol>
<li><a href="#create-a-custom-network">Create a Custom Network</a></li>
<li><a href="#create-a-project-directory">Create a Project Directory</a></li>
<li><a href="#create-and-configure-mysql-service">Create and Configure MySQL Service</a></li>
<li><a href="#create-and-configure-traefik-reverse-proxy">Create and Configure Traefik Reverse Proxy</a></li>
<li><a href="#create-and-configure-ghost-service">Create and Configure Ghost Service</a></li>
</ol>
</li>
<li><a href="#step-deploy-ghost-with-mysql-and-traefik">Step 5 - Deploy Ghost with MySQL and Traefik</a></li>
<li><a href="#step-testing">Step 6 - Testing</a></li>
<li><a href="#references">References</a></li>
</ol>
</div>
</div>
<p>Ghost is a powerful open source publishing and blog platform based on nodejs. It's well designed and easy to use. The ghost platform is written in JavaScript and uses node.js as a runtime environment. The first Ghost version released in 2013 under the MIT license..</p>
<p>Traefik is modern HTTP reverse proxy and load balancer for microservices. Traefik makes all microservices deployment easy, integrated with existing infrastructure components such as Docker, Swarm Mode, Kubernetes, Amazon ECS, Rancher, Etcd, Consul etc.</p>
<p>In this tutorial, we will show step-by-step how to install and configure Ghost as a Docker container. We will install and configure Ghost under the latest Docker CE version, use the MySQL as a database and use the Traefik as a Reverse Proxy.</p>
<h2 id="prerequisites">Prerequisites</h2>
<ul>
<li>Ubuntu 18.04 LTS</li>
<li>Root privileges</li>
</ul>
<h2 id="what-we-will-do">What we will do</h2>
<ol>
<li>Install Docker CE on Ubuntu 18.04 LTS</li>
<li>Setup Docker for Non-root User</li>
<li>Install Docker Compose</li>
<li>Configure Ghost Stack</li>
<ul>
<li>Create a Custom Network</li>
<li>Create a Project Directory</li>
<li>Create and Configure MySQL Container</li>
<li>Create and Configure Traefik Reverse Proxy</li>
<li>Create and Configure Ghost Container</li>
</ul>
<li>Deploy Ghost with MySQL and Traefik</li>
<li>Testing</li>
</ol>
<h2 id="step-install-docker-ce-on-ubuntu-lts">Step 1 - Install Docker CE on Ubuntu 18.04 LTS</h2>
<p>The first step we will do in this tutorial is to install the latest docker-ce version of the system. The docker-ce version can be installed from the official docker repository.</p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;">

<div id='div-gpt-ad-1527185271042-6' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-6'); });
</script>
</div>
</div>
<p>Add the docker key and docker-ce repository.</p>
<p class="command">curl -fsSL https://download.docker.com/linux/ubuntu/gpg | sudo apt-key add -<br />sudo add-apt-repository \<br />&nbsp;&nbsp; "deb [arch=amd64] https://download.docker.com/linux/ubuntu \<br />&nbsp;&nbsp; $(lsb_release -cs) \<br />&nbsp;&nbsp; stable"</p>
<p>The command will automatically update all repositories on the system.</p>
<p>Now install docker using the apt command below.</p>
<p class="command">sudo apt install docker-ce -y</p>
<p>After the installation is complete, start the docker service and enable it to launch every time at system startup.</p>
<p class="command">systemctl start docker<br />systemctl enable docker</p>
<p>The latest docker-ce version has been installed on the Ubuntu 18.04 system.</p>
<p style="text-align: center;"><a class="fancybox" id="img-1" href="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/big/1.png"><img src="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/1.png" alt="Installing Docker CE" width="500" height="364" /></a></p>
<h2 id="step-setup-docker-for-nonroot-user">Step 2 - Setup Docker for Non-root User</h2>
<p>In this guide, all container microservices will be run under the normal/non-root user. So we need to configure the user to be able to run the Docker container and run the sudo command for root privileges.</p>
<p>Create a new user named 'hakase' and create the password.</p>
<p class="command">useradd -m -s /bin/bash hakase<br />passwd hakase</p>
<p>Now assign the 'hakase' user to the 'sudo' and 'docker' groups.</p>
<p class="command">usermod -a -G root hakase<br />usermod -a -G docker hakase</p>
<p>And restart the docker service.</p>
<p class="command">systemctl restart docker</p>
<p>The 'hakase' can now run the docker container and run the sudo command for root privileges.</p>
<p style="text-align: center;"><a class="fancybox" id="img-2" href="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/big/2.png"><img src="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/2.png" alt="Setup Docker for Non-root User" width="500" height="216" /></a></p>
<p>Login as user 'hakase' and run the docker hello-world container.</p>
<p class="command">su - hakase<br />docker run -it hello-world</p>
<p>And following is the result.</p>
<p style="text-align: center;"><a class="fancybox" id="img-3" href="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/big/3.png"><img src="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/3.png" alt="Test docker as non-root user" width="500" height="428" /></a></p>
<h2 id="step-install-docker-compose">Step 3 - Install Docker Compose</h2>
<p>In this tutorial, we will install the docker compose 1.21 from a binary file on Github repository.</p>
<p>Download the docker-compose binary to the '/usr/local/bin' directory.</p>
<p class="command">sudo curl -L https://github.com/docker/compose/releases/download/1.21.2/docker-compose-$(uname -s)-$(uname -m) -o /usr/local/bin/docker-compose</p>
<p>And make the 'docker-compose' file executable by changing the file permission.</p>
<p class="command">sudo chmod +x /usr/local/bin/docker-compose</p>
<p>The docker compose has been installed - check it using the command below.</p>
<p class="command">docker-compose version<br />docker version</p>
<p style="text-align: center;"><a class="fancybox" id="img-4" href="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/big/4.png"><img src="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/4.png" alt="Install Docker Compose" width="500" height="269" /></a></p>
<p>Docker-compose 1.21 with Docker-ce 1.18 has been installed.</p>
<h2 id="step-configure-ghost-stack">Step 4 - Configure Ghost Stack</h2>
<p>In this step, we will configure the docker and create a new docker-compose file for the ghost installation.</p>
<p>We will create a new docker custom network and create a new docker-compose yml file that contains three main services, including MySQL database, Traefik reverse proxy, and Ghost blog itself.</p>
<h3 id="create-a-custom-network">Create a Custom Network</h3>
<p>Show the available docker network using docker network command below.</p>
<p class="command">docker network ls</p>
<p>Create a new custom docker network for the traefik reverse proxy named 'traefiknet'.</p>
<p class="command">docker network create traefiknet</p>
<p>Now check again the available network on the docker system.</p>
<p class="command">docker network ls</p>
<p style="text-align: center;"><a class="fancybox" id="img-5" href="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/big/5.png"><img src="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/5.png" alt="Create a Custom Network" width="500" height="283" /></a></p>
<p>The custom network for Treafik named 'traefiknet' has been created.</p>
<h3 id="create-a-project-directory">Create a Project Directory</h3>
<p>After creating the docker custom network, we will create a new project directory named 'ghost' and create a new docker-compose.yml file.</p>
<p>Login to the 'hakase' user.</p>
<p class="command">su - hakase</p>
<p>Create a new 'ghost' directory and change the working directory to it.</p>
<p class="command">mkdir ghost/<br />cd ghost/</p>
<p>And create a new docker-compose file.</p>
<p class="command">touch docker-compose.yml</p>
<h3 id="create-and-configure-mysql-service">Create and Configure MySQL Service</h3>
<p>MySQL is the first service we want to create, and we want to create the MySQL container with configurations below.</p>
<ul>
<li>We will be using the MySQL 5.7 docker image.</li>
<li>Mount the MySQL data directory to the local docker host directory.</li>
<li>Running the MySQL service on the local internal network.</li>
<li>Configure MySQL user and password.</li>
<ul>
<li>MySQL root password: mypassword</li>
<li>Database for the ghost named 'ghostdb' with user 'ghost' and password is 'ghostdbpass'</li>
</ul>
<li>The MySQL container will be named as 'mysql'.</li>
</ul>
<p>Inside the 'ghost' directory, create a new directory named 'data' and edit the 'docker-compose.yml' file.</p>
<p class="command">mkdir -p data/<br />vim docker-compose.yml</p>
<p>Paste the configuration below.</p>
<pre>version: '3.3'

services:

  mysql:
    image: mysql:5.7
    restart: always
    volumes:
      - ./data:/var/lib/mysql
    labels:
      - "traefik.enable=false"
    networks:
      - internal
    environment:
      MYSQL_ROOT_PASSWORD: mypassword
      MYSQL_USER: ghost
      MYSQL_PASSWORD: ghostdbpass
      MYSQL_DATABASE: ghostdb
    container_name: mysql</pre>
<p>Save and exit.</p>
<h3 id="create-and-configure-traefik-reverse-proxy">Create and Configure Traefik Reverse Proxy</h3>
<p>After creating the MySQL service, we will create and configure the traefik reverse proxy container.</p>
<p>Before editing the 'docker-compose.yml' script, we need to create a new traefik configuration named 'traefik.toml'.</p>
<p class="command">vim traefik.toml</p>
<p>Paste traefik rule configuration below.</p>
<pre>#Traefik Global Configuration
debug = false
checkNewVersion = true
logLevel = "ERROR"

#Define the EntryPoint for HTTP and HTTPS
defaultEntryPoints = ["https","http"]

#Define the HTTP port 80 and
#HTTPS port 443 EntryPoint
#Enable automatically redirect HTTP to HTTPS
[entryPoints]
[entryPoints.http]
address = ":80"
[entryPoints.http.redirect]
entryPoint = "https"
[entryPoints.https]
address = ":443"
[entryPoints.https.tls]

#Enable Traefik Dashboard on port 8080
#with basic authentication method
#hakase and password
[entryPoints.dash]
address=":8080"
[entryPoints.dash.auth]
[entryPoints.dash.auth.basic]
    users = [
        "hakase:$apr1$hEgpZUN2$OYG3KwpzI3T1FqIg9LIbi.",
    ]

[api]
entrypoint="dash"
dashboard = true

#Enable retry sending a request if the network error
[retry]

#Define Docker Backend Configuration
[docker]
endpoint = "unix:///var/run/docker.sock"
domain = "hakase-labs.io"
watch = true
exposedbydefault = false

#Letsencrypt Registration
#Define the Letsencrypt ACME HTTP challenge
[acme]
email = "<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="e38b8288829086a3848e828a8fcd808c8e">[email&#160;protected]</a>"
storage = "acme.json"
entryPoint = "https"
OnHostRule = true
  [acme.httpChallenge]
  entryPoint = "http"</pre>
<p>Save and exit.</p>
<p>Now we need to create a new file for the SSL Letsencrypt configuration 'acme.json'. <span class="highlight">It's used to store all letsencrypt generate a log.</span></p>
<p>Create the blank 'acme.json' file and change the permission to 600.</p>
<p class="command">touch acme.json<br />chmod 600 acme.json</p>
<p>Next, we will edit the 'docker-compose.yml' script and add the traefik service configuration.</p>
<ul>
<li>We will be using the latest traefik docker image.</li>
<li>The container will be named as 'traefik'</li>
<li>It's used the custom network 'traefiknet', and expose the HTTP and HTTPS ports.</li>
<li>Mount the docker sock file and the traefik configuration 'traefik.toml' and 'acme.json'</li>
<li>We defined the traefik dashboard URL and backend through the docker labels.</li>
</ul>
<p>Edit the 'docker-compose.yml'.</p>
<p class="command">vim docker-compose.yml</p>
<p>Paste the traefik service configuration below.</p>
<pre>  traefik:
    image: traefik:latest
    command: --docker
    ports:
      - 80:80
      - 443:443
    labels:
      - "traefik.enable=true"
      - "traefik.backend=dashboard"
      - "traefik.frontend.rule=Host:traef.hakase-labs.io"
      - "traefik.port=8080"
    networks:
      - traefiknet
    volumes:
      - /var/run/docker.sock:/var/run/docker.sock
      - ./traefik.toml:/traefik.toml
      - ./acme.json:/acme.json
    container_name: traefik
    restart: always</pre>
<p>Save and exit.</p>
<h3 id="create-and-configure-ghost-service">Create and Configure Ghost Service</h3>
<p>After configuring the traefik reverse proxy, we will create the main ghost service configuration.</p>
<p>Configuration details that we want to create.</p>
<ul>
<li>We will be using the ghost v1 and the small docker alpine version.</li>
<li>We will mount the ghost content directory to the local directory named 'blog'.</li>
<li>The ghost service will be running on the default port with the domain name 'gho.hakase-labs.io', the configuration through docker labels.</li>
<li>The ghost service will be using two docker networks, internal and traefiknet.</li>
<li>We're configuring the MySQL database details from the mysql container configuration.</li>
<li>And the ghost will be started when the traefik and MySQL container is up and running.</li>
</ul>
<p>Create a new directory named 'blog' and edit the 'docker-compose.yml' file.</p>
<p class="command">mkdir -p blog/<br />vim docker-compose.yml</p>
<p>Paste the configuration below.</p>
<pre>  ghost:
    image: ghost:1-alpine
    restart: always
    ports:
      - 2368
    volumes:
      - ./blog:/var/lib/ghost/content
    labels:
      - "traefik.enabled=true"
      - "traefik.backend=ghost"
      - "traefik.frontend.rule=Host:gho.hakase-labs.io"
      - "traefik.docker.network=traefiknet"
      - "traefik.port=2368"
    networks:
      - internal
      - traefiknet
    environment:
      database__client: mysql
      database__connection__host: mysql
      database__connection__user: ghost
      database__connection__password: ghostdbpass
      database__connection__database: ghostdb
    container_name: ghost
    depends_on:
      - mysql
      - traefik<br /><br />networks:
  traefiknet:
    external: true
  internal:
    external: false</pre>
<p>Save and exit.</p>
<p style="text-align: center;"><a class="fancybox" id="img-6" href="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/big/6.png"><img src="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/6.png" alt="Create and Configure Ghost Service" width="500" height="296" /></a></p>
<p>And now we got all directory and configuration as shown below.</p>
<p class="command">tree</p>
<p style="text-align: center;"><a class="fancybox" id="img-17" href="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/big/17.png"><img src="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/17.png" alt="config files" width="500" height="167" /></a></p>
<h2 id="step-deploy-ghost-with-mysql-and-traefik">Step 5 - Deploy Ghost with MySQL and Traefik</h2>
<p>To build and run all our ghost stack service, we can use the command below.</p>
<p class="command">docker-compose up -d</p>
<p style="text-align: center;"><a class="fancybox" id="img-18" href="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/big/18.png"><img src="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/18.png" alt="Deploy Ghost with MySQL and Traefik" width="500" height="519" /></a></p>
<p>When it's complete, check all running services.</p>
<p class="command">docker-compose ps</p>
<p>And the following is the result.</p>
<p style="text-align: center;"><a class="fancybox" id="img-19" href="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/big/19.png"><img src="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/19.png" alt="docker-compose ps" width="500" height="131" /></a></p>
<p>If you have an error, check the container log using commands below.</p>
<p class="command">docker-compose logs mysql<br />docker-compose logs traefik<br />docker-compose logs ghost</p>
<p style="text-align: center;"><a class="fancybox" id="img-20" href="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/big/20.png"><img src="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/20.png" alt="check the container log" width="500" height="179" /></a></p>
<p>The ghost stack with MySQL and the Traefik reverse proxy is up and running.</p>
<h2 id="step-testing">Step 6 - Testing</h2>
<p>Open the Traefik dashboard with its URL, mine is&nbsp;<em><strong>http://traef.hakase-labs.io/</strong></em></p>
<p>Log in with the user and password on the 'traefik.toml' file.</p>
<p style="text-align: center;"><a class="fancybox" id="img-7" href="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/big/7.png"><img src="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/7.png" alt="Login to Traefik" width="500" height="148" /></a></p>
<p>And following is the Traefik dashboard.</p>
<p style="text-align: center;"><a class="fancybox" id="img-8" href="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/big/8.png"><img src="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/8.png" alt="Traefik dashboard" width="500" height="285" /></a></p>
<p>For the Ghost installation, type the ghost URL on the address bar, mine is&nbsp;<strong>http://gho.hakase-labs.io/</strong></p>
<p>And you will get the ghost home page.</p>
<p style="text-align: center;"><a class="fancybox" id="img-11" href="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/big/11.png"><img src="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/11.png" alt="Ghost Blog running on Docker" width="500" height="289" /></a></p>
<p>Now visit the admin page to set up and configure a new admin user. My URL is:&nbsp;http://gho.hakase-labs.io/admin/</p>
<p>Click the green button to create a new admin user.</p>
<p style="text-align: center;"><a class="fancybox" id="img-12" href="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/big/12.png"><img src="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/12.png" alt="Ghost installer" width="500" height="277" /></a></p>
<p>Type detail user, password, email, and click again the green button.</p>
<p style="text-align: center;"><a class="fancybox" id="img-13" href="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/big/13.png"><img src="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/13.png" alt="Create admin login" width="500" height="289" /></a></p>
<p>For inviting a new member or user, click the 'I will do this later..' link.</p>
<p style="text-align: center;"><a class="fancybox" id="img-14" href="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/big/14.png"><img src="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/14.png" alt="Invite users" width="500" height="284" /></a></p>
<p>Now you will get the Ghost Dashboard.</p>
<p style="text-align: center;"><a class="fancybox" id="img-15" href="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/big/15.png"><img src="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/15.png" alt="Ghost Dashboard" width="500" height="270" /></a></p>
<p>And after creating the sample post, the following is the result.</p>
<p style="text-align: center;"><a class="fancybox" id="img-16" href="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/big/16.png"><img src="https://www.howtoforge.com/images/docker_guide_deploying_ghost_blog_with_mysql_and_traefik_with_docker/16.png" alt="Ghost glog running in Docker container" width="500" height="289" /></a></p>
<p>Ghost blog installation with MySQL database and Traefik Reverse Proxy on the Docker environment has been completed successfully.</p>
<h2 id="references">References</h2>
<ul>
<li><a href="https://hub.docker.com/_/ghost/">https://hub.docker.com/_/ghost/</a><a href="https://hub.docker.com/_/ghost/"></a></li>
<li><a href="https://docs.traefik.io/">https://docs.traefik.io/</a></li>
</ul>

<div class="authorbox" style="margin-top:20px;">
<p><strong>About Muhammad Arul</strong></p>
<p>Muhammad Arul is a freelance system administrator and technical writer. He is working with Linux Environments for more than 5 years, an Open Source enthusiast and highly motivated on Linux installation and troubleshooting. Mostly working with RedHat/CentOS Linux and Ubuntu/Debian, Nginx and Apache web server, Proxmox, Zimbra Administration, and Website Optimization. Currently learning about OpenStack and Container Technology.</p>
</div>

<div style="height:30px; margin-top:20px;">
<p style="text-align:right;"><img src="/images/pdficon_small.png" /> <a class="pdf-btn" href="javascript:void(0);">view as pdf</a> | <img src="/images/print.gif" /> <a class="print-btn" href="javascript:void(0);">print</a></p>
</div>
<div style="height:30px; margin-top:20px;">
<div style="float:left;"><b>Share this page:</b></div>
<p style="text-align:center;">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Ftutorial%2Fdocker-guide-deploying-ghost-blog-with-mysql-and-traefik-with-docker%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Ftutorial%2Fdocker-guide-deploying-ghost-blog-with-mysql-and-traefik-with-docker%2F&text=Docker+Guide%3A+Deploying+Ghost+Blog+with+MySQL+and+Traefik+with+Docker&via=howtoforgecom&related=howtoforgecom" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.howtoforge.com%2Ftutorial%2Fdocker-guide-deploying-ghost-blog-with-mysql-and-traefik-with-docker%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-gplus.png" height="20" /></a>
</p>
</div>
</div>


<div id="htfContentPagePaging">
<h2>Suggested articles</h2>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-3043223216276099" data-ad-slot="8940054090"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>


<div id="htfContentPageComment">
<a name="comments"></a>
<h2>0 Comment(s)</h2>

<div id="commentform">
<div class="commentContainerHead" style="font-size:18px;">Add comment</div>
<div class="commentContainer">
<form method="post" action="/tutorial/docker-guide-deploying-ghost-blog-with-mysql-and-traefik-with-docker/#comments">
<input type="hidden" name="reply_to" id="reply-to-comment" value="0" />
<div id="commentFormDetail">
<div style="width:48%; float:left; margin-right:3%">
<label for="commentname">Name *</label>
<input id="commentname" name="commentname" value="" />
</div>
<div style="width:48%;float:left;">
<label for="commentname">Email *</label>
<input id="commentemail" name="commentemail" value="" />
</div>
<div style="clear:both;"></div>
</div>
<textarea id="commentedit" name="commentedit" style="width:auto;"></textarea>
<div>
<div style="float:left;">
<div class="g-recaptcha" data-sitekey="6LdX9fUSAAAAALWwVoPdeXScMSketz4npF-0QcQ1"></div>
<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en">
      </script>
</div>
<div style="margin-top:10px;margin-bottom:10px;">
<input type="submit" name="submit" class="button primary" style="float:right;" value="Submit comment">
</div>
<div style="clear:both;"></div>
</div>
<script>
	tinymce.init({
		selector: "textarea#commentedit",
		theme: "modern",
		height: 100,
		apply_source_formatting : true,
		remove_linebreaks : false,
		menubar : false,
		/*auto_focus : "commentedit",*/
		plugins: [
		"link"
		],
		/*plugins: [
			"advlist autolink link image lists charmap print preview hr anchor pagebreak spellchecker",
			"searchreplace wordcount visualblocks visualchars code fullscreen insertdatetime media nonbreaking",
			"save table contextmenu directionality emoticons template paste textcolor"
		],*/
		content_css: "https://www.howtoforge.com/themes/howtoforge/css/custom.css",
		toolbar: "undo redo | bold italic link", 
		/*style_formats: [
			{title: 'Bold text', inline: 'b'},
			{title: 'Red text', inline: 'span', styles: {color: '#ff0000'}},
			{title: 'Red header', block: 'h1', styles: {color: '#ff0000'}},
			{title: 'Example 1', inline: 'span', classes: 'example1'},
			{title: 'Example 2', inline: 'span', classes: 'example2'},
			{title: 'Table styles'},
			{title: 'Table row 1', selector: 'tr', classes: 'tablerow1'}
		]*/
	}); 
	</script>
</form>
</div>
</div>

</div>

<div class="breadBoxBottom">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Home</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/tutorial/docker-guide-deploying-ghost-blog-with-mysql-and-traefik-with-docker/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Docker Guide: Deploying Ghost Blog with MySQL and Traefik with Docker</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
<script>
<!--

$(document).on('click', 'a.reply-to', function(e) {
	e.preventDefault();
	
	var self = $(this);
	var cid = self.attr('data-comment');
	console.log(cid);
	if(!cid) return this;
	
	$('#commentform').insertAfter('#comment' + cid);
	$('#reply-to-comment').val(cid);
	/*tinyMCE.activeEditor.focus();*/
	var textareaId = 'commentedit';
	tinyMCE.get(textareaId).remove();
	tinyMCE.execCommand("mceAddEditor", false, textareaId);
	tinyMCE.activeEditor.focus();
});
//-->
</script>
<div style="margin-top:10px;margin-bottom:10px;text-align:center;">

<center>


<div id='div-gpt-ad-1527185271042-1' style='height:90px; width:728px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-1'); });
</script>
</div>

</center>
</div>


<form action="/community/login/login?redirect=/tutorial/docker-guide-deploying-ghost-blog-with-mysql-and-traefik-with-docker/" method="post" class="xenForm eAuth" id="login" style="display:none">
<ul id="eAuthUnit">
<li><a href="/community/register/facebook?reg=1" class="fbLogin" tabindex="110"><span>Log in with Facebook</span></a></li>
<li><a href="/community/register/twitter?reg=1" class="twitterLogin" tabindex="110"><span>Log in with Twitter</span></a></li>
<li><span class="googleLogin GoogleLogin JsOnly" tabindex="110" data-client-id="198773272284-b6tfk0c28bje81p774prrcrkq9jb3o44.apps.googleusercontent.com" data-redirect-url="/community/register/google?code=__CODE__&amp;csrf=hVMXbW_3rnrmq4Em"><span>Log in with Google</span></span></li>
</ul>
<div class="ctrlWrapper">
<dl class="ctrlUnit">
<dt><label for="LoginControl">Your name or email address:</label></dt>
<dd><input type="text" name="login" id="LoginControl" class="textCtrl" tabindex="101" /></dd>
</dl>
<dl class="ctrlUnit">
<dt>
<label for="ctrl_password">Do you already have an account?</label>
</dt>
<dd>
<ul>
<li><label for="ctrl_not_registered"><input type="radio" name="register" value="1" id="ctrl_not_registered" tabindex="105" />
No, create an account now.</label></li>
<li><label for="ctrl_registered"><input type="radio" name="register" value="0" id="ctrl_registered" tabindex="105" checked="checked" class="Disabler" />
Yes, my password is:</label></li>
<li id="ctrl_registered_Disabler">
<input type="password" name="password" class="textCtrl" id="ctrl_password" tabindex="102" />
<div class="lostPassword"><a href="/community/lost-password/" tabindex="106">Forgot your password?</a></div>
</li>
</ul>
</dd>
</dl>
<dl class="ctrlUnit submitUnit">
<dt></dt>
<dd>
<input type="submit" class="button primary" value="Log in" tabindex="104" data-loginPhrase="Log in" data-signupPhrase="Sign up" />
<label for="ctrl_remember" class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_remember" tabindex="103" /> Stay logged in</label>
</dd>
</dl>
</div>
<input type="hidden" name="cookie_check" value="1" />
<input type="hidden" name="redirect" value="/community/" />
<input type="hidden" name="_xfToken" value="" />
</form>

</div>
</div>

<aside>
<div class="sidebar">
<div class="section loginButton">
<div class="secondaryContent">
<label for="LoginControl" id="SignupButton"><a href="/community/login/" class="inner">Sign up now!</a></label>
</div>
</div>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-2">

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent socialMediaIcon">
<a href="https://twitter.com/howtoforgecom" target="_blank"><img src="/images/socialmedia/64x64/twitter.png" /></a>
<a href="https://www.facebook.com/howtoforge" target="_blank"><img src="/images/socialmedia/64x64/facebook.png" /></a>
<a href="https://plus.google.com/+howtoforge/posts" target="_blank"><img src="/images/socialmedia/64x64/googleplus.png" /></a>
<a href="https://www.howtoforge.com/feed" target="_blank"><img src="/images/socialmedia/64x64/rss.png" /></a>
</div>
</div>
</div>
<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Tutorial Info</p>
<div class="pairsJustified">
<dl class="discussionCount">
<dt>Author:</dt>
<dd><a href="/author/muhammad+arul/" rel="author">Muhammad Arul</a></dd>
</dl>
<dl class="discussionCount">
<dt>Published:</dt>
<dd>Aug 31, 2018</dd>
</dl>
<dl class="discussionCount">
<dt>Tags:</dt>
<dd><a href='/tutorials/linux/' rel='tag'>linux</a>, <a href='/tutorials/virtualization/' rel='tag'>virtualization</a>, <a href='/tutorials/web+server/' rel='tag'>web server</a></dd>
</dl>
</div>
</div>
</div>
<script src="//m.servedby-buysellads.com/monetization.js" type="text/javascript"></script>
<div class="native-sidebar"></div>
<script>
  (function(){
    if(typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('default', 'CKYD55QU', 'placement:howtoforge', {
      target: '.native-sidebar',
      align: 'horizontal',
      disable_css: 'true'
    });
      }
  })();
</script>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent">
<p class="mnuinfo mnushare">Share This Page</p>
<p style="text-align:center;">
<a href="javascript:window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Ftutorial%2Fdocker-guide-deploying-ghost-blog-with-mysql-and-traefik-with-docker%2F', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="javascript:window.open('https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Ftutorial%2Fdocker-guide-deploying-ghost-blog-with-mysql-and-traefik-with-docker%2F&text=Docker+Guide%3A+Deploying+Ghost+Blog+with+MySQL+and+Traefik+with+Docker&via=howtoforgecom&related=howtoforgecom', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="javascript:window.open('https://plus.google.com/share?url=https%3A%2F%2Fwww.howtoforge.com%2Ftutorial%2Fdocker-guide-deploying-ghost-blog-with-mysql-and-traefik-with-docker%2F', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-gplus.png" height="20" /></a>
</p>
<p style="color:#EE; font-weight:bold; text-align:center; margin-top:5px;">40.2k Followers</p>
</div>
</div>
</div>


<script type="text/javascript">
    google_ad_client = "ca-pub-3043223216276099";
    google_ad_slot = "6709042890";
    google_ad_width = 300;
    google_ad_height = 600;
</script>

<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>


<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Popular Tutorials</p>
<div class="pairsJustified">
<ul>
<li><a href="/tutorial/perfect-server-ubuntu-18.04-with-apache-php-myqsl-pureftpd-bind-postfix-doveot-and-ispconfig/">The Perfect Server - Ubuntu 18.04 (Bionic Beaver) with Apache, PHP, MySQL, PureFTPD, BIND, Postfix, Dovecot and ISPConfig 3.1</a></li>
<li><hr /></li>
<li><a href="/reverse-ssh-tunneling">Reverse SSH Tunneling</a></li>
<li><hr /></li>
<li><a href="/tutorial/linux-grep-command/">How to use grep to search for strings in files on the shell</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-enable-voip-in-onlyoffice-using-twilio/">How to enable VoIP in ONLYOFFICE using Twilio</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-install-cachet-status-page-system-on-debian/">How to Install Cachet Status Page System on Debian 9</a></li>
<li><hr /></li>
<li><a href="/linux-chrt-command/">Linux chrt Command Tutorial for Beginners (5 Examples)</a></li>
<li><hr /></li>
<li><a href="/tutorial/setting-up-your-own-name-service-with-ispconfig/">Setting up your own name service (DNS) with ISPConfig</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-use-ftp-on-the-linux-shell/">How to use the Linux ftp command to up- and download files on the shell</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-install-hubzilla-on-ubuntu/">How to Install Hubzilla on Ubuntu 18.04 LTS</a></li>
<li><hr /></li>
<li><a href="/tutorial/setup-seafile-inside-ispconfig/">Installing Seafile 6.3.2 inside ISPConfig 3.1</a></li>
<li><hr /></li>
</ul>
</div>
</div>
</div>
</div>
</div>
</aside>
</div>
</div>
</div>
<footer>
<div class="footer">
<div class="pageWidth">
<div class="pageContent">
<div class='skin_branding'><span>Xenforo skin by <a href="http://www.xenfocus.com" rel="nofollow">Xenfocus</a></span></div>
<ul class="footerLinks">
<li><a href="/contribute/">Contribute</a></li>
<li><a href="/community/misc/contact">Contact</a></li>
<li><a href="/community/help/">Help</a></li>
<li><a href="/imprint/">Imprint and Legal Notice</a></li>
<li><a href="#navigation" class="topLink">Top</a></li>
<li><a href="/feed" rel="alternate" class="globalFeed" target="_blank" title="RSS-Feed for Howtoforge">RSS-Feed</a></li>
</ul>
<span class="helper"></span>
</div>
</div>
</div>
<div class="footerLegal">
<div class="pageWidth">
<div class="pageContent">
<ul id="legal">
<li><a href="/community/help/terms">Terms and Rules</a> <a href="https://www.howtoforge.com/community/help/privacy-policy">Privacy Policy</a></li>
</ul>
<div id="copyright"><a href="https://www.howtoforge.com" class="concealed">Howtoforge <span>&copy; projektfarm GmbH.</span></a></div>
<span class="helper"></span>
</div>
</div>
</div>
</footer>
<div style="height:100px;"></div>

<div id="subscriptionModal" class="modal">
<div class="modal-content">
<span class="close">&times;</span>
<p>This feature is only available to subscribers. Get your subscription <a href="/subscription">here</a>.</p>
</div>
</div>
<script>
//* Modal
var modal = document.getElementById('subscriptionModal');
var span = document.getElementsByClassName("close")[0];
$(".pdf-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
$(".print-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
span.onclick = function() {
	$("#subscriptionModal").css('display', 'none');
}
window.onclick = function(event) {
    if (event.target == modal) {
		$("#subscriptionModal").css('display', 'none');
    }
}
//* Xenforo
jQuery.extend(true, XenForo,
{
	visitor: { user_id: 0 },
	serverTimeInfo:
	{
		now: 1409831907,
		today: 1409781600,
		todayDow: 4
	},
	_lightBoxUniversal: "0",
	_enableOverlays: "1",
	_animationSpeedMultiplier: "1",
	_overlayConfig:
	{
		top: "10%",
		speed: 200,
		closeSpeed: 100,
		mask:
		{
			color: "rgb(0, 0, 0)",
			opacity: "0.6",
			loadSpeed: 200,
			closeSpeed: 100
		}
	},
	_ignoredUsers: [],
	_loadedScripts: {"node_list":true,"node_category":true,"node_forum":true,"sidebar_share_page":true,"wf_default":true,"bbm_buttons":true,"login_bar":true,"twitter":true},
	_cookieConfig: { path: "/", domain: "", prefix: "xf_"},
	_csrfToken: "",
	_csrfRefreshUrl: "/community/login/csrf-token-refresh",
	_jsVersion: "303ae0ca"
});
jQuery.extend(XenForo.phrases,
{
	cancel: "Cancel",

	a_moment_ago:    "A moment ago",
	one_minute_ago:  "1 minute ago",
	x_minutes_ago:   "%minutes% minutes ago",
	today_at_x:      "Today at %time%",
	yesterday_at_x:  "Yesterday at %time%",
	day_x_at_time_y: "%day% at %time%",

	day0: "Sunday",
	day1: "Monday",
	day2: "Tuesday",
	day3: "Wednesday",
	day4: "Thursday",
	day5: "Friday",
	day6: "Saturday",

	_months: "January,February,March,April,May,June,July,August,September,October,November,December",
	_daysShort: "Sun,Mon,Tue,Wed,Thu,Fri,Sat",

	following_error_occurred: "The following error occurred",
	server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
	logging_in: "Logging in",
	click_image_show_full_size_version: "Click this image to show the full-size version.",
	show_hidden_content_by_x: "Show hidden content by {names}"
});

// Facebook Javascript SDK
XenForo.Facebook.appId = "";
XenForo.Facebook.forceInit = true;

/*
document.addEventListener('DOMContentLoaded', function(event) {
  cookieChoices.showCookieConsentBar('Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.',
  'OK');
});
*/

$(document).ready(function() {
	$("a.fancybox").fancybox();
});

</script>

<script>
(function() {
  if (typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('fancybar', 'CKYDL27E', 'placement:howtoforgecom');
  }
})();
</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2155872-1', 'auto');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');

</script>
</body>
</html>