<!DOCTYPE html>
<html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs LoggedOut Sidebar Responsive" xmlns:fb="http://www.facebook.com/2008/fbml">
<head><meta charset="utf-8" />
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData)});}}
function AddPixelById(impFullId,pixelData){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData)});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){while(pixels.length>0){var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(__ez.template.isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
(new Image()).src=pixelURL;}}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=191-2&cb=1', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=191-2&cb=1', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=191-2&cb=2', false, [], true, false, true, false);</script>
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<base href="https://www.howtoforge.com" />
<script>
			var _b = document.getElementsByTagName('base')[0], _bH = "https://www.howtoforge.com/tutorial/debian_mysql/";
			if (_b && _b.href != _bH) _b.href = _bH;
		</script>
<title>How to install MySQL 8 on Debian 10</title>
<meta name="description" content="MySQL is an open-source relational database system that works on many Operating Systems, including Windows, Linux, macOS, and FreeBSD. It is probably ... " />
<meta property="og:title" content="How to install MySQL 8 on Debian 10">
<meta property="og:description" content="MySQL is an open-source relational database system that works on many Operating Systems, including Windows, Linux, macOS, and FreeBSD. It is probably ... ">
<meta property="og:site_name" content="HowtoForge">
<meta property="og:type" content="article">
<meta property="og:image" content="https://www.howtoforge.com/images/featured/mysql-debian.jpg">
<meta property="og:image:secure_url" content="https://www.howtoforge.com/images/featured/mysql-debian.jpg" />
<meta property="og:image:alt" content="How to install MySQL 8 on Debian 10" />
<meta name="twitter:image" content="https://www.howtoforge.com/images/featured/mysql-debian.jpg" />
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="@howtoforgecom">
<meta name="twitter:creator" content="@howtoforgecom">
<meta name="twitter:title" content="How to install MySQL 8 on Debian 10">
<meta name="twitter:description" content="MySQL is an open-source relational database system that works on many Operating Systems, including Windows, Linux, macOS, and FreeBSD. It is probably ... ">
<link rel="alternate" href="https://www.howtoforge.com/tutorial/debian_mysql/" hreflang="en" />
<link rel="canonical" href="https://www.howtoforge.com/tutorial/debian_mysql/" />
<link rel="amphtml" href="https://www.howtoforge.com/tutorial/debian_mysql/amp/" />
<script type="application/ld+json">
{
  "@context" : "http://schema.org",
  "@type" : "Article",
  "name" : "How to install MySQL 8 on Debian 10",
  "author" : {
    "@type" : "Person",
    "name" : "Muhammad Arul"
  },
  "articleSection" : "debian,mysql,server",
  "url" : "https://www.howtoforge.com/tutorial/debian_mysql/",
  "publisher" : {
    "@type" : "Organization",
    "name" : "Howtoforge"
  }
}
</script>
<noscript><style>.JsOnly, .jsOnly { display: none !important; }</style></noscript>
<link rel="stylesheet" href="/community/styles/executive/xenfocus/icons/css/font-awesome.min.css" />
<link href='//fonts.googleapis.com/css?family=Open+Sans:400,700' rel='stylesheet' type='text/css' />
<link href="/themes/howtoforge/templates/xf.css" rel="stylesheet">
<script src="/js/jquery/jquery-1.11.3.min.js"></script>
<script src="/community/js/xenforo/xenforo.js?_v=303ae0ca"></script>
<script src="/community/js/bbm/zloader.js?_v=303ae0ca"></script>
<script type="text/javascript" src="/js/fancybox/jquery.mousewheel-3.0.4.pack.js"></script>
<script type="text/javascript" src="/js/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
<link rel="stylesheet" type="text/css" href="/js/fancybox/jquery.fancybox-1.3.4.css" media="screen" />
<link href="/themes/howtoforge/templates/style.min.css" rel="stylesheet">
<link rel="alternate" type="application/rss+xml" title="RSS-Feed für Howtoforge" href="/feed.rss" />
<script src="/js/tinymce_4.1.7/tinymce.min.js"></script>
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/skin.min.css" as="style" />
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/content.min.css" as="style" />
<link rel="preload" href="/themes/howtoforge/css/custom.css" as="style" />
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/fonts/tinymce.woff" as="font">

<script type="text/javascript">
var gaProperty = 'UA-2155872-1';
var disableStr = 'ga-disable-' + gaProperty;
if (document.cookie.indexOf(disableStr + '=true') > -1) {
window[disableStr] = true;
}
function gaOptout() {
document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
window[disableStr] = true;
alert('Google Ananlyitics tracking has been disabled in this browser.');
}
</script>
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
	googletag.defineSlot('/1030080/howtoforge_com_list_sidebar_top', [300, 250], 'div-gpt-ad-1527185271042-4').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_list_content_middle', [[300, 250], [336, 280]], 'div-gpt-ad-1527185271042-5').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_a_300x250', [300, 250], 'div-gpt-ad-1527185271042-6').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_b_300x250', [300, 250], 'div-gpt-ad-1527185271042-7').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_leaderboard_b_728x90', [728, 90], 'div-gpt-ad-1527185271042-1').addService(googletag.pubads());
	googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-3043223216276099",
          enable_page_level_ads: true
     });
</script>


<script type="text/javascript" src="//m.servedby-buysellads.com/monetization.js"></script>

<script data-ezscrex="false" data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-158818458-34";</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(function(){
	_gat._createTracker('UA-158818458-34', 'e');
});
_gaq.push(function(){
	_gat._createTracker('UA-38339005-1', 'f');
});
_gaq.push(['e._setDomainName', 'howtoforge.com']);
_gaq.push(['f._setDomainName', 'howtoforge.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod60',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','howtoforge.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script>
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 178704;
var ezdomain = 'howtoforge.com';
var ezoicSearchable = 1;
</script>


<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":178704,"engaged_time_visit":0,"ezcache_level":1,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"ebee18e7-36d6-47e0-5d9e-af87c0088229","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":1288,"serverid":"3.84.242.120:6528","state":"VA","t_epoch":1602034207,"template_id":126,"time_on_site_visit":0,"url":"https://www.howtoforge.com/tutorial/debian_mysql/","user_id":0,"word_count":4765,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=191-2&v=9" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_178704=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["ebee18e7-36d6-47e0-5d9e-af87c0088229", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>
<body>
<div id="loginBar">
<div class="pageWidth">
<div class="pageContent">
<h3 id="loginBarHandle">
<label for="LoginControl"><a href="/community/login/" class="concealed noOutline">Log in or Sign up</a></label>
</h3>
<span class="helper"></span>
</div>
</div>
</div>
<header>
<div id="header">
<div id="logoBlock">
<div class="pageWidth">
<div class="pageContent">
<div id="logo"><a href="/">
<span></span>
<img src="/images/howtoforge_logo_trans.gif" alt="Howtoforge" style="margin-left:20px;" />
</a></div>
<span class="helper"></span>
</div>
</div>
</div>
<div id="navigation" class="pageWidth withSearch">
<div class="pageContent">
<nav>
<div class="navTabs">
<ul class="publicTabs">

<li class="navTab forums selected">
<a href="/" class="navLink">Tutorials</a>
<div class="tabLinks forumsTabLinks">
<ul class="secondaryContent blockLinksList">
<li><a href="/search/">Tutorial search</a></li>
</ul>
</div>
</li>
<li class="navTab forums PopupClosed">
<a href="/tutorials/" class="navLink">Tags</a>
</li>
<li class="navTab forums PopupClosed"><a href="/community/" class="navLink">Forums</a></li>
<li class="navTab forums PopupClosed"><a href="/linux-commands/" class="navLink">Linux Commands</a></li>
<li class="navTab forums PopupClosed"><a href="/subscription/" class="navLink">Subscribe</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.ispconfig.org" class="navLink">ISPConfig</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.lxer.com" class="navLink">News</a></li>
</ul>
</div>
<span class="helper"></span>
</nav>
</div>
</div>
<div id="searchBar" class="pageWidth">
<span id="QuickSearchPlaceholder" title=" Search..."> Search</span>
<fieldset id="QuickSearch">
<form action="/" method="post" class="formPopup">
<div class="primaryControls">

<input type="search" name="q" value="" class="textCtrl" placeholder="Search..." results="0" title="Enter your search and hit enter..." id="QuickSearchQuery" />

</div>
<input type="hidden" name="_xfToken" value="" />
</form>
</fieldset>
</div>
</div>
</header>
<div id="content" class="forum_list">
<div class="pageWidth">
<div class="pageContent">

<div class="mainContainer">
<div class="mainContent">

<div class="breadBoxTop">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Home</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/tutorial/debian_mysql/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to install MySQL 8 on Debian 10</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>

<div id="htfContentPage">
<article>
<h1>How to install MySQL 8 on Debian 10</h1>
<div class="contributeEdit" style="float:right; width:450px; max-width:100%;">
<div id="tocContainer">
<h3>On this page</h3>
<ol class="toc">
<li><a href="#step-add-mysql-repository">Step 1 - Add MySQL Repository</a></li>
<li><a href="#step-install-mysql-server">Step 2 - Install MySQL Server</a></li>
<li><a href="#step-secure-mysql-deployment-using-mysqlsecurepassword">Step 3 - Secure MySQL Deployment using mysql_secure_password</a></li>
<li><a href="#step-secure-mysql-server-using-additional-configuration">Step 4 - Secure MySQL Server Using Additional Configuration</a></li>
<li><a href="#step-secure-and-enable-mysql-remote-connection-using-ssl">Step 5 - Secure and Enable MySQL Remote Connection using SSL</a>
<ol>
<li><a href="#generate-ssl-certificates">Generate SSL Certificates</a></li>
<li><a href="#enable-ssl-and-remote-access-mysql-server">Enable SSL and Remote Access MySQL Server</a></li>
<li><a href="#setup-client-and-test-ssl-connection">Setup Client and Test SSL Connection</a></li>
</ol>
</li>
<li><a href="#step-install-and-configure-phpmyadmin">Step 6 - Install and Configure phpMyAdmin</a></li>
<li><a href="#step-create-mysql-user-and-database">Step 7 - Create MySQL User and Database</a>
<ol>
<li><a href="#connect-to-mysql-server-and-check-connection-status">Connect to MySQL Server and Check Connection Status</a></li>
<li><a href="#create-and-show-database">Create and Show Database</a></li>
<li><a href="#create-mysql-user">Create MySQL User</a></li>
<li><a href="#show-all-available-user-and-grants">Show All Available user and Grants</a></li>
</ol>
</li>
<li><a href="#step-additional-create-incremental-backup-mysql-database">Step 8 - Additional: Create Incremental Backup MySQL Database</a>
<ol>
<li><a href="#backup-all-databases">Backup All Databases</a></li>
<li><a href="#backup-specific-database">Backup Specific Database</a></li>
<li><a href="#backup-multiple-databases">Backup Multiple Databases</a></li>
<li><a href="#automatic-backup-mysql-database">Automatic Backup MySQL Database</a></li>
</ol>
</li>
<li><a href="#references">References</a></li>
</ol>
</div>
</div>
<p>MySQL is an open-source relational database system that works on many Operating Systems, including Windows, Linux, macOS, and FreeBSD. It is probably the most popular OpenSource RDBMS and a central component of the LAMP and LEMP Stacks. Many applications depend on MySQL like WordPress, Joomla, TYPO3, phpBB, and many more.</p>
<p>Several new features have been added to the MySQL 8 including, JSON support, Transactional Data Dictionary, Persistent runtime configuration, Document Store, Optimizer Hints, SQL roles, CTEs, window functions, Invisible indexes, and many more.</p>
<p><strong>What you will learn?</strong></p>
<p>In this tutorial, you will learn some stuff related to the MySQL server, and below are details about:</p>
<ul>
<li>Install MySQL Server 8 on Debian Buster 10</li>
<li>Set Up MySQL Root Password</li>
<li>Secure MySQL Server Deployment (Change Bind Address, Port, etc.)</li>
<li>Setup SSL and Enable Remote Connection for MySQL Server</li>
<li>Install and Configure phpMyAdmin</li>
<li>Basic MySQL Query for Creating User, Database, etc</li>
<li>Set up automatic backup MySQL databases</li>
</ul>
<p><strong>Prerequisites</strong></p>
<p>We will install the MySQL Server 8.04 on the latest Debian Buster 10 with 2GB of RAM and 4 CPUs for this guide. Also, we need the root privilege for installing packages and editing system configurations.</p>
<h2 id="step-add-mysql-repository">Step 1 - Add MySQL Repository</h2>
<p>For this tutorial, we will install the MySQL Server 8 from the official MySQL repository. To do that, we need to add the official MySQL repository to our Debian Server.</p>
<p>Before adding the MySQL repository, install the 'GnuPG' package using the apt command below.</p>
<pre class="command"><code spellcheck="false">sudo apt install gnupg -y</code></pre>
<p>Once all installation is completed, download the MySQL APT repository and add it to your system.</p>
<pre class="command"><code spellcheck="false">wget -q http://repo.mysql.com/mysql-apt-config_0.8.15-1_all.deb<br />sudo dpkg -i mysql-apt-config_0.8.15-1_all.deb</code></pre>
<p>Leave the repository as default and select '<strong>OK</strong>'.</p>
<p><a class="fancybox" id="img-1" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/1.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/1.png" alt="Add MySQL Server 8.0 Repository to the Debian Buster" style="display: block; margin-left: auto; margin-right: auto;" width="750" height="149" /></a></p>
<p>And the official MySQL repository has been added.</p>
<p>Next, update all available repositories on the Debian system using the following command.</p>
<pre class="command"><code spellcheck="false">sudo apt update</code></pre>
<p>And you will get the official MySQL repository on the list below.</p>
<p><a class="fancybox" id="img-2" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/2.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/2.png" alt="Update repositories Debian Buster 10" style="display: block; margin-left: auto; margin-right: auto;" width="750" height="344" /></a></p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;">

<div id='div-gpt-ad-1527185271042-6' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-6'); });
</script>
</div>
</div>
<p>As can be seen, the official MySQL repository has been added, and we're ready to install the MySQL Server 8.0 to the Debian Buster 10.</p>
<h2 id="step-install-mysql-server">Step 2 - Install MySQL Server</h2>
<p>To install the MySQL Server 8.0 to the Debian system, run the apt command below.</p>
<pre class="command"><code spellcheck="false">sudo apt install mysql-server</code></pre>
<p>Now type the root password for your MySQL installation and choose '<strong>OK</strong>'.</p>
<p><a class="fancybox" id="img-3" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/3.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/3.png" alt="Setup Root Password for MySQL Server" style="display: block; margin-left: auto; margin-right: auto;" width="750" height="136" /></a></p>
<p>Repeat the password for your MySQL root user.</p>
<p><a class="fancybox" id="img-4" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/4.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/4.png" alt="Setup Root Password for MySQL Server" style="display: block; margin-left: auto; margin-right: auto;" width="750" height="168" /></a></p>
<p>After that, you will be asked to configure the MySQL default authentication plugin. Select the '<strong>Strong Password Encryption</strong>' as recommended and choose '<strong>OK</strong>'.</p>
<p><a class="fancybox" id="img-5" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/5.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/5.png" alt="Setup Password Plugins for MySQL Server" style="display: block; margin-left: auto; margin-right: auto;" width="750" height="161" /></a></p>
<p>And the MySQL Server 8.0 installation is finished.</p>
<p>Now check the MySQL service using the following command.</p>
<pre class="command"><code spellcheck="false">systemctl is-enabled mysql<br />systemctl status mysql</code></pre>
<p>Below is the result you will get.</p>
<p><a class="fancybox" id="img-6" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/6.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/6.png" alt="Check MySQL Server Status" style="display: block; margin-left: auto; margin-right: auto;" width="750" height="248" /></a></p>
<p>As a result, the MySQL service is up and running on the Debian Server. The service will be running automatically at every system boot.</p>
<h2 id="step-secure-mysql-deployment-using-mysqlsecurepassword">Step 3 - Secure MySQL Deployment using mysql_secure_password</h2>
<p>In this step, we will improve the MySQL server installation's security using the '<em>mysql_secure_installation</em>' command-line tool.</p>
<p>The '<em>mysql_secure_installation</em>' tool will help you improve your MySQL deployment from different aspects such as setup the password strength, disable remote access, and removing default anonymous user and test databases.</p>
<p>Now run the '<em>mysql_secure_installation</em>' command on your shell.</p>
<pre class="command"><code spellcheck="false">mysql_secure_installation</code></pre>
<p>At the beginning of the MySQL installation, you've already configured the root password for MySQL. Now type the password to continue to the process.</p>
<pre class="system"><code spellcheck="false">Enter the password for user root: TYPE YOUR MYSQL ROOT PASSWORD</code></pre>
<p>After that, type '<strong>Y</strong>' to configure the '<strong>VALIDATE PASSWORD</strong>' component.</p>
<pre class="system"><code spellcheck="false">VALIDATE PASSWORD COMPONENT can be used to test passwords<br />and improve security. It checks the strength of the password<br />and allows the users to set only those passwords which are<br />secure enough. Would you like to setup VALIDATE PASSWORD component?<br /><br />Press y|Y for Yes, any other key for No: Y</code></pre>
<p>Now choose the password validation policy level for all users. Type '<strong>2</strong>' to set up the '<strong>STRONG</strong>' password level policy.</p>
<pre class="system"><code spellcheck="false">There are three levels of password validation policy:<br /><br />LOW&nbsp;&nbsp;&nbsp; Length &gt;= 8<br />MEDIUM Length &gt;= 8, numeric, mixed case, and special characters<br />STRONG Length &gt;= 8, numeric, mixed case, special characters, and dictionary&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; file<br /><br />Please enter 0 = LOW, 1 = MEDIUM and 2 = STRONG: 2<br />Using existing password for root.</code></pre>
<p>Now 'mysql_secure_installation' command will check your current password strength. As can be seen, the strength of our current password is '<strong>50</strong>'. Now type '<strong>Y</strong>' to change the current password with a new stronger password.</p>
<pre class="system"><code spellcheck="false">Estimated strength of the password: 50 <br />Change the password for root? ((Press y|Y for Yes, any other key for No) : Y</code></pre>
<p>Now type your strong password and make sure to have the score <strong>100</strong>, then type '<strong>Y</strong>' to continue with the new password.</p>
<pre class="system"><code spellcheck="false">New password: <br /><br />Re-enter new password: <br /><br />Estimated strength of the password: 100 <br />Do you wish to continue with the password provided? (Press y|Y for Yes, any other key for No) : Y</code></pre>
<p>As a result, the MySQL component 'VALIDATE PASSWORD' has been configured with a strong password policy, and the new MySQL password has been created.</p>
<p>Next, you will be asked to remove the default Anonymous user. Type '<strong>Y</strong>' to remove the default anonymous user for your installation.</p>
<pre class="system"><code spellcheck="false">By default, a MySQL installation has an anonymous user,<br />allowing anyone to log into MySQL without creating a user account. This is intended only for testing, and to make the installation go a bit smoother.<br />You should remove them before moving into a production<br />environment.<br /><br />Remove anonymous users? (Press y|Y for Yes, any other key for No) : Y</code></pre>
<p>Next, type '<strong>Y</strong>' again to disable MySQL remote login and if you want the MySQL server accessible only locally.</p>
<pre class="system"><code spellcheck="false">Normally, root should only be allowed to connect from<br />'localhost'. This ensures that someone cannot guess at<br />the root password from the network.<br /><br />Disallow root login remotely? (Press y|Y for Yes, any other key for No) : Y</code></pre>
<p>After that, remove the default database 'test' from your MySQL Server. Type '<strong>Y</strong>' and press Enter to continue.</p>
<pre class="system"><code spellcheck="false">By default, MySQL comes with a database named 'test' that<br />anyone can access. This is also intended only for testing,<br />and should be removed before moving into a production<br />environment.<br /><br />Remove test database and access to it? (Press y|Y for Yes, any other key for No) : Y</code></pre>
<p>Next, type <strong>'Y'</strong> again to reload the privilege tables. In effect, and new MySQL configuration changes have been applied.</p>
<pre class="system"><code spellcheck="false">Reloading the privilege tables will ensure that all changes<br />made so far will take effect immediately.<br /><br />Reload privilege tables now? (Press y|Y for Yes, any other key for No) : Y</code></pre>
<p>As a result, the Secure MySQL Server Deployment using te 'mysql_secure_installation' script has been completed. And at this stage, you've enabled the 'VALIDATE PASSWORD' component with the level '2' strong password policy, also the new strong root password for MySQL has been configured.</p>
<h2 id="step-secure-mysql-server-using-additional-configuration">Step 4 - Secure MySQL Server Using Additional Configuration</h2>
<p>For this tutorial, we will add additional configuration to improve the deployment of the MySQL Server. We will specify the MySQL Server's bind-address, change the default port, disable load data file, and set up a password expiration policy for all MySQL users.</p>
<p>Now go to the '/etc/mysql/conf.d/' directory and create a new configuration 'mysqld.cnf' using vim editor.</p>
<pre class="command"><code spellcheck="false">cd /etc/mysql/conf.d/<br />vim mysqld.cnf</code></pre>
<p>Paste the following configuration into it.</p>
<pre><code spellcheck="false">[mysqld]<br /><br /># MySQL running on 127.0.0.1 with port 8320<br />bind-address=127.0.0.1<br />port=8320<br /><br /># Disable LOAD DATA LOCA<br />local-infile=0<br /><br /># Password Expiration to 60 Days<br />default_password_lifetime=60<br /><br /># MySQLX Plugin running on 127.0.0.1 with port 8321<br />mysqlx_bind_address=127.0.0.1<br />mysqlx_port=8321</code></pre>
<p>Save and close.</p>
<p>Next, restart the MySQL service and check open ports on the system using the following command.</p>
<pre class="command"><code spellcheck="false">systemctl restart mysql<br />ss -plnt</code></pre>
<p>Below is the result you will get.</p>
<p><a class="fancybox" id="img-7" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/7.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/7.png" alt="Securing MySQL Server Deployment by changing the Listen address and default port" style="display: block; margin-left: auto; margin-right: auto;" width="750" height="141" /></a></p>
<p>As can be seen, the MySQL Server is up and running on the local IP address '127.0.0.1' on the non-default TCP port '8320'.</p>
<p>Next, to log in to the MySQL shell with the custom port, you can use the 'mysql' command with '-P port' option as below.</p>
<pre class="command"><code spellcheck="false">mysql -u root -P 8320 -p</code></pre>
<p>Type the root password for the MySQL Server.</p>
<p>Once you've logged in, run the following query to check the MySQL Server's port configuration.</p>
<pre class="command"><code spellcheck="false">show variables like 'port';</code></pre>
<p>And you will get the MySQL Server is running on the custom port '8320' as below.</p>
<p><a class="fancybox" id="img-8" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/8.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/8.png" alt="Login to MySQL Shell with custom Port and check the MySQL Port Configuration" style="display: block; margin-left: auto; margin-right: auto;" width="711" height="463" /></a></p>
<p>As a result, you've configured the MySQL Server to be running on the local IP address '127.0.0.1' with the custom TCP port '8320'.</p>
<h2 id="step-secure-and-enable-mysql-remote-connection-using-ssl">Step 5 - Secure and Enable MySQL Remote Connection using SSL</h2>
<p>Suppose you want to deploy the MySQL Server on the internal network and allow other hosts on the same network to access databases on the MySQL Server. In that case, it's recommended to enable SSL for your MySQL Server deployment.</p>
<p>In this step, you will learn how to set up and enable SSL and remote access on the MySQL Server.</p>
<h3 id="generate-ssl-certificates">Generate SSL Certificates</h3>
<p>By default, the MySQL Server 8.0 is generated SSL certificates automatically during the installation. All default SSL certificates are available at the '/var/lib/mysql' directory.</p>
<p>For this step, we will generate a new SSL certificate for the MySQL Server using the '<em>mysql_ssl_rsa_setup</em>' command-line tool.</p>
<p>Now create a new SSL directory '/etc/mysql/certs' and change that directory's ownership to the user 'mysql'.</p>
<pre class="command"><code spellcheck="false">mkdir -p /etc/mysql/certs/<br />sudo chown -R mysql:mysql /etc/mysql/certs</code></pre>
<p>Next, generate new SSL certificates for the MySQL Server using the following command. And make sure to change the '<em>--suffix=STRING</em>' with your Common Name.</p>
<pre class="command"><code spellcheck="false">sudo mysql_ssl_rsa_setup --suffix=HakasMySQLSrv --uid=mysql --datadir=/etc/mysql/certs/</code></pre>
<p>Once it's completed, new SSL certificates for the MySQL Server has been generated at the '/etc/mysql/certs' directory.</p>
<p><a class="fancybox" id="img-9" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/9.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/9.png" alt="Generate MySQL SSL Certificates using the mysql_ssl_rsa_setup utility" style="display: block; margin-left: auto; margin-right: auto;" width="750" height="360" /></a></p>
<p>Check your SSL certificates using the following command.</p>
<pre class="command"><code spellcheck="false">ls -lah /etc/mysql/certs/<br />openssl verify -CAfile /etc/mysql/certs/ca.pem /etc/mysql/certs/server-cert.pem /etc/mysql/certs/client-cert.pem</code></pre>
<p>Below is the result you will get.</p>
<p><a class="fancybox" id="img-10" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/10.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/10.png" alt="Verify MySQL Certificates" style="display: block; margin-left: auto; margin-right: auto;" width="750" height="239" /></a></p>
<p>The new SSL certificates for MySQL Server has been generated to the '/etc/mysql/certs/' directory.</p>
<h3 id="enable-ssl-and-remote-access-mysql-server">Enable SSL and Remote Access MySQL Server</h3>
<p>To enable the SSL and remote access on the MySQL Server, you will need to change the 'bind-address' option with your internal network's IP address and add the SSL configuration for MySQL.</p>
<p>Now go to the '/etc/mysql/conf.d/' directory and edit the configuration that we've created on top 'mysqld.cnf' using vim editor.</p>
<pre class="command"><code spellcheck="false">cd /etc/mysql/conf.d/<br />vim mysqld.cnf</code></pre>
<p>Change the 'bind-address' with your internal IP address as below.</p>
<pre><code spellcheck="false">bind-address=172.16.0.3</code></pre>
<p>Next, add the SSL configuration for the MySQL Server below and change the SSL path with your own.</p>
<pre><code spellcheck="false">ssl-ca=/etc/mysql/certs/ca.pem<br />ssl-cert=/etc/mysql/certs/server-cert.pem<br />ssl-key=/etc/mysql/certs/server-key.pem</code></pre>
<p>Additionally, you can specify the TLS version of al your clients and force them to use only the secure SSL connection using the following configuration.</p>
<pre><code spellcheck="false">#require_secure_transport=ON<br />tls_version=TLSv1.1,TLSv1.2</code></pre>
<p>Save and close.</p>
<p>Next, restart the MySQL service to apply the new configuration and check the MySQL server's IP address using the following command.</p>
<pre class="command"><code spellcheck="false">systemctl restart mysql<br />ss -plnt</code></pre>
<p>And you will get the MySQL Server is up and running on the internal network IP address with SSL enabled on it.</p>
<p><a class="fancybox" id="img-11" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/11.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/11.png" alt="MySQL Enable SSL Secure Connection and ENable Remote Access" style="display: block; margin-left: auto; margin-right: auto;" width="750" height="154" /></a></p>
<h3 id="setup-client-and-test-ssl-connection">Setup Client and Test SSL Connection</h3>
<p>To connect to the MySQL Server from another host/client, you must create a new MySQL user, copy the client certificates, and add the MySQL configuration for the client.</p>
<p>Log in to the MySQL shell using the following command.</p>
<pre class="command"><code spellcheck="false">mysql -u root -P 8320 -p</code></pre>
<p>Now create a new MySQL user for remote connection using the following query.</p>
<pre class="command"><code spellcheck="false">CREATE USER 'remoteuser'@'%' IDENTIFIED WITH mysql_native_password BY 'MyRemoteUserPasswordMySQL39==' REQUIRE SSL;<br />GRANT ALL PRIVILEGES ON *.* TO 'remoteuser'@'%' WITH GRANT OPTION;<br />FLUSH PRIVILEGES;</code></pre>
<p>Type '<strong>exit</strong>' to log out from the MySQL shell.</p>
<p><a class="fancybox" id="img-12" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/12.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/12.png" alt="Create MySQL USer for MySQL Remote User Access" style="display: block; margin-left: auto; margin-right: auto;" width="750" height="355" /></a></p>
<p>Next, you need to copy the CA and client certificate and key to the client machine using the SCP command as below.</p>
<pre class="command"><code spellcheck="false">scp /etc/mysql/certs/ca.pem <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="6f1d00001b2f0c03060a011b263f">[email&#160;protected]</a>:/certificates/directory/<br />scp /etc/mysql/certs/client-cert.pem <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="186a77776c587b74717d766c5148">[email&#160;protected]</a>:/certificates/directory/<br />scp /etc/mysql/certs/client-key.pem <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="55273a3a211536393c303b211c05">[email&#160;protected]</a>:/certificates/directory/</code></pre>
<p>After that, connect to your client machine and create a new configuration using the vim editor.</p>
<pre class="command"><code spellcheck="false">vim ~/.my.cnf</code></pre>
<p>Paste the MySQL client configuration as below and change the client SSL certificate path with your own.</p>
<pre><code spellcheck="false">[client]<br />ssl-ca=/home/gpk/certs/ca.pem<br />ssl-cert=/home/gpk/certs/client-cert.pem<br />ssl-key=/home/gpk/certs/client-key.pem</code></pre>
<p>Save and close.</p>
<p>To connect to the remote MySQL Server with a custom port, run the 'mysql' command below.</p>
<pre class="command"><code spellcheck="false">mysql -u remoteuser -h 172.16.0.3 -P 8320 -p</code></pre>
<p><a class="fancybox" id="img-13" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/13.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/13.png" alt="Connect to MySQL Server from Remote Machine/Client" style="display: block; margin-left: auto; margin-right: auto;" width="697" height="301" /></a></p>
<p>Once you've logged in, check your connection status using the following query.</p>
<pre class="command"><code spellcheck="false">STATUS<br />SELECT * FROM performance_schema.session_status<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; WHERE VARIABLE_NAME IN ('Ssl_version','Ssl_cipher');</code></pre>
<p>Below is the result you will get.</p>
<p><a class="fancybox" id="img-14" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/14.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/14.png" alt="Verify Connection Status and Check TLS Version that used for connecting to the MySQL Server" style="display: block; margin-left: auto; margin-right: auto;" width="750" height="498" /></a></p>
<p>As can be seen, you've logged in with SSL secure connection TLSv1.2 to the MySQL Server.</p>
<p>As a result, the remote access with a secure SSL connection for MySQL Server has been enabled.</p>
<h2 id="step-install-and-configure-phpmyadmin">Step 6 - Install and Configure phpMyAdmin</h2>
<p>In this step, you will learn how to install the latest phpMyAdmin with the Apache webserver. You will also learn how to connect to the MySQL Server on the remote host with a custom port and alose securely through SSL from the phpMyAdmin.</p>
<p>Before going any further, install some packages dependencies using the apt command below.</p>
<pre class="command"><code spellcheck="false">sudo apt install apache2 libapache2-mod-php php-imagick php-phpseclib php-php-gettext php-common php-mysql php-gd php-imap php-json php-curl php-zip php-xml php-mbstring php-bz2 php-intl php-gmp unzip</code></pre>
<p>Next, go to the '/var/www/html' directory and download the latest phpMyAdmin source code.</p>
<pre class="command"><code spellcheck="false">cd /var/www/html/<br />wget -q https://www.phpmyadmin.net/downloads/phpMyAdmin-latest-all-languages.tar.gz</code></pre>
<p>Now extract the phpMyAdmin source code and rename to the new directory named 'phpMyAdmin'.</p>
<pre class="command"><code spellcheck="false">tar -xf phpMyAdmin-latest-all-languages.tar.gz<br />mv phpMyAdmin-5.0.2-all-languages phpMyAdmin</code></pre>
<p>Next, go to the '/var/www/phpMyAdmin' drectory and copy the default configuration file to 'config.inc.php'.</p>
<pre class="command"><code spellcheck="false">cd /var/www/html/phpMyAdmin/<br />cp config.sample.inc.php config.inc.php</code></pre>
<p>Edit the 'config.inc.php' configuration file using vim editor.</p>
<pre class="command"><code spellcheck="false">vim config.inc.php</code></pre>
<p>Generate the blowfish secret code using this link and paste the code to the 'blowfish_secret' line as below.</p>
<pre><code spellcheck="false">$cfg['blowfish_secret'] = '6}2]RFleN-JT=/vXD}L/0j0v.YALV/e3'; /* YOU MUST FILL IN THIS FOR COOKIE AUTH! */</code></pre>
<p>Next, type your MySQL Server details under the 'Server Configuration' line as below.</p>
<pre><code spellcheck="false">/**<br />&nbsp;* Servers configuration<br />&nbsp;*/<br />$i = 0;<br /><br />.....<br />/* Custom MySQL Server Configuration */<br />$cfg['Servers'][$i]['host'] = '172.16.0.3';<br />$cfg['Servers'][$i]['port'] = '8320';<br />.....</code></pre>
<p>After that, paste the following configuration to enable the SSL communication from the phpMyAdmin to MySQL Server. And make sure to change the client and CA certificates' path with your own and make sure the user 'www-data' can access CA and client certificates.</p>
<pre><code spellcheck="false">/* SSL Configuration */<br />$cfg['Servers'][$i]['ssl'] = true;<br />$cfg['Servers'][$i]['ssl_key'] = '/opt/mysql/certs/client-key.pem';<br />$cfg['Servers'][$i]['ssl_cert'] = '/opt/mysql/certs/client-cert.pem';<br />$cfg['Servers'][$i]['ssl_ca'] = '/opt/mysql/certs/ca.pem';<br /><br />/* Disable SSL Verification for Self-signed certificates */<br />/* The Good: Connection between phpMyAdmin and MySQL Server are Encrypted */<br />/* But you're still vulnerable with the MiTM */<br />$cfg['Servers'][$i]['ssl_verify'] = false;<br /><br />/* Hide Some Databases */<br />$cfg['Servers'][$i]['hide_db'] = '(information_schema|performance_schema|sys|mysql)';</code></pre>
<p>Save and close.</p>
<p>Now change ownership of the 'phpMyAdmin' directory to the user 'www-data'.</p>
<pre class="command"><code spellcheck="false">sudo chown -R www-data:www-data /var/www/html/phpMyAdmin</code></pre>
<p>And the phpMyAdmin installation and configuration of phpMyAdmin has been completed.</p>
<p><a class="fancybox" id="img-15" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/15.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/15.png" alt="Download and Install phpMyAdmin on Debian Buster 10" style="display: block; margin-left: auto; margin-right: auto;" width="750" height="232" /></a></p>
<p>Now log in to the MySQL Server, check the MySQL SSL status, create a new database and user for phpMyAdmin.</p>
<p>Log in to the MySQL Server using the following command.</p>
<pre class="command"><code spellcheck="false">mysql -u root -P 8329 -p</code></pre>
<p>Now check the SSL status using the following queries.</p>
<pre class="command"><code spellcheck="false">SHOW VARIABLES LIKE '%ssl%';<br />STATUS</code></pre>
<p>Below is the result you will get.</p>
<p><a class="fancybox" id="img-19" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/19.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/19.png" alt="Check MySQL Connection Status and SSL Configurations" style="display: block; margin-left: auto; margin-right: auto;" width="495" height="750" /></a></p>
<p>As can be seen, the MySQL server is up and running with SSL enabled on it, and it's using SSL certificates that we've generated. We're also connected to the MySQL Server through the SSL secure connection using the '~/.my.cnf' configuration file.</p>
<p>Next, create a new database and user named 'phpmyadmin' using the following query.</p>
<pre class="command"><code spellcheck="false">CREATE DATABASE phpmyadmin;<br />CREATE USER 'phpmyadmin'@'%' IDENTIFIED WITH mysql_native_password BY 'phpMyAdminAdmn352#$';<br />GRANT ALL PRIVILEGES ON *.* TO 'phpmyadmin'@'%' WITH GRANT OPTION;<br />FLUSH PRIVILEGES;</code></pre>
<p>Type '<strong>exit</strong>' to log out from the MySQL Shell.</p>
<p><a class="fancybox" id="img-16" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/16.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/16.png" alt="Create MySQL User for phpMyAdmin" style="display: block; margin-left: auto; margin-right: auto;" width="750" height="478" /></a></p>
<p>Now open your web browser and type the server IP address with the path of 'phpMyAdmin' on the address bar.</p>
<p><em>http://server-ip/phpMyAdmin/</em></p>
<p>On the phpMyAdmin Login page, type the user 'phpmyadmin' with the password that we've created on top and click the 'GO' button.</p>
<p><a class="fancybox" id="img-17" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/17.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/17.png" alt="phpMyAdmin Login Page" style="display: block; margin-left: auto; margin-right: auto;" width="750" height="348" /></a></p>
<p>And you will get the phpMyAdmin Dashboard as below.</p>
<p><a class="fancybox" id="img-18" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/18.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/18.png" alt="phpMyAdmin Dashboard" style="display: block; margin-left: auto; margin-right: auto;" width="750" height="450" /></a></p>
<p>As a result, the installation and configuration of phpMyAdmin have been completed.</p>
<h2 id="step-create-mysql-user-and-database">Step 7 - Create MySQL User and Database</h2>
<p>For this step, you will learn the primary usage of MySQL queries for managing user, database, and the basic mysqldump command for database backup.</p>
<h3 id="connect-to-mysql-server-and-check-connection-status">Connect to MySQL Server and Check Connection Status</h3>
<p>To connect to the MySQL server, you can use the 'mysql' command line. And by default, all connections from the local MySQL Server will be using the Unix socket, which the SSL connection does not make connections any more secure.</p>
<p>Connect to the MySQL Server with default configuration using the following command.</p>
<pre class="command"><code spellcheck="false">mysql -u username -p</code></pre>
<p>If your MySQL Server is running on the custom port, use the '-P port' option below.</p>
<pre class="command"><code spellcheck="false">mysql -u root -P 8320 -p</code></pre>
<p>If your MySQL server runs on the local network with the custom port, use the 'h host/IP Address' and the '-P port' options below.</p>
<pre class="command"><code spellcheck="false">mysql -u root -h 172.16.0.3 -P 8320 -p</code></pre>
<p>Once you've connected to your MySQL Server, run the following query to check the connection status.</p>
<pre class="command"><code spellcheck="false">STATUS</code></pre>
<p>And you will get the following result.</p>
<p><a class="fancybox" id="img-33" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/33.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/33.png" alt="Check Connection Status MySQL Server" style="display: block; margin-left: auto; margin-right: auto;" width="750" height="360" /></a></p>
<p>And you're successfully connected to the MySQL Server.</p>
<h3 id="create-and-show-database">Create and Show Database</h3>
<p>After connecting to the MySQL shell, you will learn how to create the MySQL database, select the database, create tables, and insert data.</p>
<p>To create a new MySQL database, use the following query.</p>
<pre class="command"><code spellcheck="false">CREATE DATABASE hakase_db;<br />CREATE DATABASE yume_db;<br />CREATE DATABASE juice_db;</code></pre>
<p>Now check all list databases on your MySQL server using the following query.</p>
<pre class="command"><code spellcheck="false">SHOW DATABASES;<br />SHOW DATABASES LIKE "%db%";</code></pre>
<p><a class="fancybox" id="img-20" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/20.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/20.png" alt="Create Database and Show List Database on MySQL Server" style="display: block; margin-left: auto; margin-right: auto;" width="639" height="656" /></a></p>
<p>Next, you can switch and select the database using the following query.</p>
<pre class="command"><code spellcheck="false">USE hakase_db;</code></pre>
<p>Next, you can create a new table on your database using the 'CREATE TABLE' query as bellow.</p>
<pre class="command"><code spellcheck="false">CREATE TABLE users (first VARCHAR(20), last VARCHAR(20),<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; email VARCHAR(20), birth DATE, country VARCHAR(20));</code></pre>
<p>Now you can use 'DESCRIBE table-name' to check all fields on your database.</p>
<pre class="command"><code spellcheck="false">DESCRIBE users;</code></pre>
<p>And you will get all details fields on the table 'users'.</p>
<p><a class="fancybox" id="img-21" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/21.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/21.png" alt="Switch between databases and create table" style="display: block; margin-left: auto; margin-right: auto;" width="748" height="393" /></a></p>
<p>Next, you can insert data manually to your table using the 'INSERT' query as below.</p>
<pre class="command"><code spellcheck="false">INSERT INTO users<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; VALUES ('Mark','Mine','<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="0c61616562694c6b616d6560226f6361">[email&#160;protected]</a>','1999-03-20','Canada');</code></pre>
<p>Now you've successfully inserted data to the MySQL database. Next, check all data on the table using the 'SELECT' query as below.</p>
<pre class="command"><code spellcheck="false">SELECT * FROM users;<br />SELECT email, birth, country FROM users;</code></pre>
<p>And you will get all data from your table.</p>
<p><a class="fancybox" id="img-22" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/22.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/22.png" alt="Insert Data and Show Data on the Table" style="display: block; margin-left: auto; margin-right: auto;" width="750" height="376" /></a></p>
<h3 id="create-mysql-user">Create MySQL User</h3>
<p>After creating the database, you will learn how to create a user on the MySQL Server and grant the user privileges to databases.</p>
<p>The basic MySQL query for creating a user is by using the 'CREATE USER' query. Then you can grant privileges of the database to your user using the command 'GRANT' following by its options. And the last you must reload the grant tables to apply the new changes.</p>
<ul>
<li><strong>The Basic</strong></li>
</ul>
<p>Create a new user named '<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="056d646e64766045696a6664696d6a7671">[email&#160;protected]</a>' with the password 'MyHakasePasswordMySQL39==' and allow all privileges of the 'hakase_db' to the user using the following query.</p>
<pre class="command"><code spellcheck="false">CREATE USER 'hakase'@'localhost' IDENTIFIED BY 'MyHakasePasswordMySQL39==';<br />GRANT ALL PRIVILEGES ON hakase_db.* TO 'hakase'@'localhost' WITH GRANT OPTION;<br />FLUSH PRIVILEGES;</code></pre>
<p>Additional information, the hostname '<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="542127312614383b3735383c3b2720">[email&#160;protected]</a>' is a part of the account name. The '@localhost' only allows the user to connect from the local server. If not given, the default is '%' which allowing users from everywhere.</p>
<p><a class="fancybox" id="img-23" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/23.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/23.png" alt="Create MySQL User" style="display: block; margin-left: auto; margin-right: auto;" width="750" height="222" /></a></p>
<ul>
<li><strong>Create User for Remote Access with Specific Authentication Plugin</strong></li>
</ul>
<p>We will create a new user that can only log in from the specific host IP address and use the particular authentication plugin.</p>
<p>We will create a new user named 'yume' connecting through the client IP '172.16.0.4' with the 'mysql_native_password' authentication plugin, and the user will be allowed to access the database 'yume_db' only.</p>
<pre class="command"><code spellcheck="false">CREATE USER 'yume'@'172.16.0.4' IDENTIFIED WITH mysql_native_password BY 'MyYumePasswordMySQL39==';<br />GRANT ALL PRIVILEGES ON yume_db.* TO 'yume'@'172.16.0.4' WITH GRANT OPTION;<br />FLUSH PRIVILEGES;</code></pre>
<p>As a result, the user 'yume' will only connect to the MySQL server with IP address '172.16.0.4'. Otherwise, the authentication of the user will be denied by the MySQL Server.</p>
<p><a class="fancybox" id="img-24" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/24.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/24.png" alt="Create MySQL User with specific Autehntication Plugin" style="display: block; margin-left: auto; margin-right: auto;" width="750" height="189" /></a></p>
<ul>
<li><strong>Create User and Force to Use Encrypted SSL Connection</strong></li>
</ul>
<p>To force the user to use the SSL secure connection, you can use the 'REQUIRE SSL' option. If the secure connection fails, you can't connect to the MySQL Server (cannot establish the connections).</p>
<p>For a more secure scenario, you can use the 'REQUIRE X509' query, which means the connection to the MySQL Server only established when the user/client machine provided the client and CA certificates.</p>
<p>Create a new user named 'juice' with the hostname '%'. This hostname option '%' allows the user 'juice' to connect from any IP address, but the connection will be established when the client machine provided client and CA certificates.</p>
<pre class="command"><code spellcheck="false">CREATE USER 'juice'@'%' IDENTIFIED WITH mysql_native_password BY 'MyJuicePasswordMySQL39==' REQUIRE X509;<br />GRANT ALL PRIVILEGES ON juice_db.* TO 'juice'@'%' WITH GRANT OPTION;<br />FLUSH PRIVILEGES;</code></pre>
<p>As a result, the 'juice' user can connect to the MySQL Server when the machine provided client and CA certificates.</p>
<p><a class="fancybox" id="img-25" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/25.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/25.png" alt="Create User and Force User to use SSL Secure Connection and Provides Client Certificates" style="display: block; margin-left: auto; margin-right: auto;" width="750" height="188" /></a></p>
<h3 id="show-all-available-user-and-grants">Show All Available user and Grants</h3>
<p>After creating all users, check all users using the following queries.</p>
<pre class="command"><code spellcheck="false">SELECT User, Host FROM mysql.user;<br />SELECT User, Host, plugin FROM mysql.user;</code></pre>
<p>Now you will get details user, host, and the authentication plugins that are used by users.</p>
<p><a class="fancybox" id="img-26" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/26.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/26.png" alt="Show All Available Users on the MySQL Server" style="display: block; margin-left: auto; margin-right: auto;" width="704" height="628" /></a></p>
<p>Next, check all privileges of users using the 'SHOW GRANTS' query as below.</p>
<pre class="command"><code spellcheck="false">SHOW GRANTS FOR 'hakase'@'localhost';<br />SHOW GRANTS FOR 'yume'@'172.16.0.3';<br />SHOW GRANTS FOR 'juice'@'%';</code></pre>
<p>Now you will get detailed privileges of your users.</p>
<p><a class="fancybox" id="img-27" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/27.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/27.png" alt="Show Grant Opetion for Users on the MySQL" style="display: block; margin-left: auto; margin-right: auto;" width="750" height="494" /></a></p>
<p>As a result, you've learned the primary usage of MySQL Server, including create a database, create a table, insert data to the table, create and show users, and show details privileges of each user.</p>
<h2 id="step-additional-create-incremental-backup-mysql-database">Step 8 - Additional: Create Incremental Backup MySQL Database</h2>
<p>For this step, you will learn the primary usage of the 'mysqldump' command for backup all MySQL databases. The 'mysqldump' command-line allows you to backup all databases, specific or multiple databases, and backup tables.</p>
<p>Before going any further, create the backup directory and go into it.</p>
<pre class="command"><code spellcheck="false">mkdir -p ~/backup; cd ~/backup</code></pre>
<p>And you're ready to create MySQL databases backup using the 'mysqldump' utility.</p>
<h3 id="backup-all-databases">Backup All Databases</h3>
<p>To back up all databases on the MySQL Server, use mysqldump command with the '--add-databases' option below.</p>
<pre class="command"><code spellcheck="false">mysqldump -u root -P 8320 --all-databases -p &gt; alldbs.sql</code></pre>
<p>Now you will get all backup of your databases to the single SQL file named 'alldbs.sql'.</p>
<h3 id="backup-specific-database">Backup Specific Database</h3>
<p>To back up the specific MySQL database, include your database name on the mysqldump command below.</p>
<pre class="command"><code spellcheck="false">mysqldump -u root -P 8320 -p hakase_db &gt; backup_hakase_db.sql</code></pre>
<p>As a result, you will get the SQL backup file from the database 'hakase_db' named as 'backup_hakase_db.sql' on the backup directory.</p>
<h3 id="backup-multiple-databases">Backup Multiple Databases</h3>
<p>If you want to create a backup of multiple databases (not all databases on the MySQL Server), use the '--databases' option below.</p>
<pre class="command"><code spellcheck="false">mysqldump -u root -P 8320 -p --databases yume_db juice_db &gt; multi-db-once.sql</code></pre>
<p>As a result, the backup file for your two databases 'yume_db' and 'juice_db' has been created, named as 'multi-db-once.sql' file.</p>
<p><a class="fancybox" id="img-28" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/28.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/28.png" alt="Basic Usage of mysqldump command utility for Backup Databases" style="display: block; margin-left: auto; margin-right: auto;" width="750" height="304" /></a></p>
<h3 id="automatic-backup-mysql-database">Automatic Backup MySQL Database</h3>
<p>To set up an automatic backup for MySQL, we will be using the Linux 'cron'. We will create a new bash script for MySQL databases and run it automatically at a specific time using the Linux Cron.</p>
<p>Before going any further, log in to the MySQL shell using the following command.</p>
<pre class="command"><code spellcheck="false">mysql -u root -P 8320 -p</code></pre>
<p>Create a new backup user with some privileges using the following query.</p>
<pre class="command"><code spellcheck="false">CREATE USER 'backup'@'localhost' IDENTIFIED WITH mysql_native_password BY 'MyBackupPasswordMySQL39==';<br />GRANT PROCESS, SELECT, LOCK TABLES, SHOW VIEW, EVENT ON *.* TO 'backup'@'localhost' WITH GRANT OPTION;<br />FLUSH PRIVILEGES;</code></pre>
<p>Now type 'exit' to log out from the MySQL shell.</p>
<p><a class="fancybox" id="img-29" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/29.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/29.png" alt="Create MySQL Backup User" style="display: block; margin-left: auto; margin-right: auto;" width="750" height="190" /></a></p>
<p>Next, create a new backup directory '/opt/backup/mysql' for storing all your database backup files.</p>
<pre class="command"><code spellcheck="false">mkdir -p /opt/backup/mysql</code></pre>
<p>After that, go to the '/usr/local/sbin' directory and create a new bash file 'auto_backup.sh' using vim editor.</p>
<pre class="command"><code spellcheck="false">cd /usr/local/sbin/<br />vim auto_backup.sh</code></pre>
<p>Change the details user, password, and port with your own and paste the configuration into it.</p>
<pre><code spellcheck="false">#!/bin/bash<br /><br /># Basic configuration: datestamp e.g., YYYYMMDD<br />DATE=$(date +"%Y%m%d")<br /><br /># Location of your backups (create the directory first!)<br />BACKUP_DIR="/opt/backup/mysql"<br /><br /># MySQL login details<br />MYSQL_USER="backup"<br />MYSQL_PASSWORD="MyBackupPasswordMySQL39=="<br /><br /># MySQL executable locations (no need to change this)<br />MYSQL=/usr/bin/mysql<br />MYSQLDUMP=/usr/bin/mysqldump<br /><br /># MySQL databases you wish to skip<br />SKIPDATABASES="Database|information_schema|performance_schema|mysql"<br /><br /># Number of days to keep the directories (older than X days will be removed)<br />RETENTION=14<br /><br /># ---- DO NOT CHANGE BELOW THIS LINE ------------------------------------------<br />#<br /># Create a new directory into the backup directory location for this date<br />mkdir -p $BACKUP_DIR/$DATE<br /><br /># Retrieve a list of all databases<br />databases=`$MYSQL -u$MYSQL_USER -p$MYSQL_PASSWORD -e "SHOW DATABASES;" | grep -Ev "($SKIPDATABASES)"`<br /><br /># Dumb the databases in seperate names and gzip the .sql file<br />for db in $databases; do<br />echo $db<br />$MYSQLDUMP --opt --user=$MYSQL_USER -p$MYSQL_PASSWORD --skip-lock-tables --events --databases $db | gzip &gt; "$BACKUP_DIR/$DATE/$db.sql.gz"<br />done<br /><br /># Remove files older than X days<br />find $BACKUP_DIR/* -mtime +$RETENTION -delete</code></pre>
<p>Save and close.</p>
<p>Now make the 'auto_backup.sh' script executable and run the script for testing purposes.</p>
<pre class="command"><code spellcheck="false">chmod +x auto_backup.sh<br />./auto_backup.sh</code></pre>
<p><a class="fancybox" id="img-30" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/30.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/30.png" alt="Create Automatic Backup Script for MySQL" style="display: block; margin-left: auto; margin-right: auto;" width="750" height="360" /></a></p>
<p>As a result, you will get your database backup files on the '/opt/mysql/backup-current-date' directory. Check using the following command.</p>
<pre class="command"><code spellcheck="false">ls -lah /opt/backup/mysql/<br />ls -lah /opt/backup/mysql/datedir/</code></pre>
<p>Below is the result you will get.</p>
<p><a class="fancybox" id="img-31" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/31.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/31.png" alt="Database Backup Generated by the Bash Script" style="display: block; margin-left: auto; margin-right: auto;" width="750" height="299" /></a></p>
<p>As a result, you will get compressed files of your database backup, which means the script is working.</p>
<p>Next, create a new cronjob that will be running the MySQL auto backup script 'auto_backup.sh' every day at the time '00:00'.</p>
<p>Set the default editor to 'vim' and create a new cronjob as user root using the following command.</p>
<pre class="command"><code spellcheck="false">export EDITOR=vim<br />crontab -u root -e</code></pre>
<p>Now paste the following configuration into it.</p>
<pre><code spellcheck="false">0 0 * * * sh /usr/local/sbin/auto_backup.sh</code></pre>
<p>Save and close.</p>
<p>The new cronjob for user root has been created. Check all cronjob list for the root user using the following command.</p>
<pre class="command"><code spellcheck="false">crontab -u root -l</code></pre>
<p>And you will get details cron configuration for the user root.</p>
<p><a class="fancybox" id="img-32" href="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/big/32.png"><img src="https://www.howtoforge.com/images/how_to_install_mysql_on_debian_10/32.png" alt="Create Cronjob for the MySQL Automatic Backup Script" style="display: block; margin-left: auto; margin-right: auto;" width="647" height="609" /></a></p>
<p>As a result, you've successfully set up the automatic MySQL database backup using the bash script and Linux Cron.</p>
<p>Finally, you've learned how to install and secure the MySQL Database Server on the Debian Buster 10 with phpMyAdmin web-based database management. Also, you've learned the basic MySQL query for managing users, create database and tables, and using the mysqldump utility for backup databases.</p>
<h2 id="references">References</h2>
<ul>
<li><a href="https://dev.mysql.com/doc/refman/en/">https://dev.mysql.com/doc/refman/en/</a></li>
<li><a href="https://docs.phpmyadmin.net/en/latest/index.html" style="font-size: 14px;">https://docs.phpmyadmin.net/en/latest/index.html</a></li>
</ul>
</article>

<aside class="authorbox" style="margin-top:20px;">
<p><strong>About Muhammad Arul</strong></p>
<p>Muhammad Arul is a freelance system administrator and technical writer. He is working with Linux Environments for more than 5 years, an Open Source enthusiast and highly motivated on Linux installation and troubleshooting. Mostly working with RedHat/CentOS Linux and Ubuntu/Debian, Nginx and Apache web server, Proxmox, Zimbra Administration, and Website Optimization. Currently learning about OpenStack and Container Technology.</p>
</aside>

<div style="height:30px; margin-top:20px;">
<p style="text-align:right;"><img src="/images/pdficon_small.png" /> <a class="pdf-btn" href="javascript:void(0);">view as pdf</a> | <img src="/images/print.gif" /> <a class="print-btn" href="javascript:void(0);">print</a></p>
</div>
<div style="height:30px; margin-top:20px;">
<div style="float:left;"><b>Share this page:</b></div>
<p style="text-align:center;">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Ftutorial%2Fdebian_mysql%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Ftutorial%2Fdebian_mysql%2F&text=How+to+install+MySQL+8+on+Debian+10&via=howtoforgecom&related=howtoforgecom" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.howtoforge.com%2Ftutorial%2Fdebian_mysql%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-gplus.png" height="20" /></a>
</p>
</div>
</div>


<div id="htfContentPagePaging">
<h2>Suggested articles</h2>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-3043223216276099" data-ad-slot="8940054090"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>


<div id="htfContentPageComment">
<a name="comments"></a>
<h2>0 Comment(s)</h2>

<div id="commentform">
<div class="commentContainerHead" style="font-size:18px;">Add comment</div>
<div class="commentContainer">
<form method="post" action="/tutorial/debian_mysql/#comments">
<input type="hidden" name="reply_to" id="reply-to-comment" value="0" />
<div id="commentFormDetail">
<div style="width:48%; float:left; margin-right:3%">
<label for="commentname">Name *</label>
<input id="commentname" name="commentname" value="" />
</div>
<div style="width:48%;float:left;">
<label for="commentname">Email *</label>
<input id="commentemail" name="commentemail" value="" />
</div>
<div style="clear:both;"></div>
</div>
<textarea id="commentedit" name="commentedit" style="width:auto;"></textarea>
<div>
<div style="float:left;">
<div class="g-recaptcha" data-sitekey="6LdX9fUSAAAAALWwVoPdeXScMSketz4npF-0QcQ1"></div>
<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en">
      </script>
</div>
<div style="margin-top:10px;margin-bottom:10px;">
<input type="submit" name="submit" class="button primary" style="float:right;" value="Submit comment">
</div>
<div style="clear:both;"></div>
</div>
<script>
	tinymce.init({
		selector: "textarea#commentedit",
		theme: "modern",
		height: 100,
		apply_source_formatting : true,
		remove_linebreaks : false,
		menubar : false,
		/*auto_focus : "commentedit",*/
		plugins: [
		"link"
		],
		/*plugins: [
			"advlist autolink link image lists charmap print preview hr anchor pagebreak spellchecker",
			"searchreplace wordcount visualblocks visualchars code fullscreen insertdatetime media nonbreaking",
			"save table contextmenu directionality emoticons template paste textcolor"
		],*/
		content_css: "https://www.howtoforge.com/themes/howtoforge/css/custom.css",
		toolbar: "undo redo | bold italic link", 
		/*style_formats: [
			{title: 'Bold text', inline: 'b'},
			{title: 'Red text', inline: 'span', styles: {color: '#ff0000'}},
			{title: 'Red header', block: 'h1', styles: {color: '#ff0000'}},
			{title: 'Example 1', inline: 'span', classes: 'example1'},
			{title: 'Example 2', inline: 'span', classes: 'example2'},
			{title: 'Table styles'},
			{title: 'Table row 1', selector: 'tr', classes: 'tablerow1'}
		]*/
	}); 
	</script>
</form>
</div>
</div>

</div>

<div class="breadBoxBottom">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Home</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/tutorial/debian_mysql/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to install MySQL 8 on Debian 10</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
<script>
<!--

$(document).on('click', 'a.reply-to', function(e) {
	e.preventDefault();
	
	var self = $(this);
	var cid = self.attr('data-comment');
	console.log(cid);
	if(!cid) return this;
	
	$('#commentform').insertAfter('#comment' + cid);
	$('#reply-to-comment').val(cid);
	/*tinyMCE.activeEditor.focus();*/
	var textareaId = 'commentedit';
	tinyMCE.get(textareaId).remove();
	tinyMCE.execCommand("mceAddEditor", false, textareaId);
	tinyMCE.activeEditor.focus();
});
//-->
</script>
<div style="margin-top:10px;margin-bottom:10px;text-align:center;">

<center>


<div id='div-gpt-ad-1527185271042-1' style='height:90px; width:728px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-1'); });
</script>
</div>

</center>
</div>


<form action="/community/login/login?redirect=/tutorial/debian_mysql/" method="post" class="xenForm eAuth" id="login" style="display:none">
<ul id="eAuthUnit">
<li><a href="/community/register/facebook?reg=1" class="fbLogin" tabindex="110"><span>Log in with Facebook</span></a></li>
<li><a href="/community/register/twitter?reg=1" class="twitterLogin" tabindex="110"><span>Log in with Twitter</span></a></li>
<li><span class="googleLogin GoogleLogin JsOnly" tabindex="110" data-client-id="198773272284-b6tfk0c28bje81p774prrcrkq9jb3o44.apps.googleusercontent.com" data-redirect-url="/community/register/google?code=__CODE__&amp;csrf=hVMXbW_3rnrmq4Em"><span>Log in with Google</span></span></li>
</ul>
<div class="ctrlWrapper">
<dl class="ctrlUnit">
<dt><label for="LoginControl">Your name or email address:</label></dt>
<dd><input type="text" name="login" id="LoginControl" class="textCtrl" tabindex="101" /></dd>
</dl>
<dl class="ctrlUnit">
<dt>
<label for="ctrl_password">Do you already have an account?</label>
</dt>
<dd>
<ul>
<li><label for="ctrl_not_registered"><input type="radio" name="register" value="1" id="ctrl_not_registered" tabindex="105" />
No, create an account now.</label></li>
<li><label for="ctrl_registered"><input type="radio" name="register" value="0" id="ctrl_registered" tabindex="105" checked="checked" class="Disabler" />
Yes, my password is:</label></li>
<li id="ctrl_registered_Disabler">
<input type="password" name="password" class="textCtrl" id="ctrl_password" tabindex="102" />
<div class="lostPassword"><a href="/community/lost-password/" tabindex="106">Forgot your password?</a></div>
</li>
</ul>
</dd>
</dl>
<dl class="ctrlUnit submitUnit">
<dt></dt>
<dd>
<input type="submit" class="button primary" value="Log in" tabindex="104" data-loginPhrase="Log in" data-signupPhrase="Sign up" />
<label for="ctrl_remember" class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_remember" tabindex="103" /> Stay logged in</label>
</dd>
</dl>
</div>
<input type="hidden" name="cookie_check" value="1" />
<input type="hidden" name="redirect" value="/community/" />
<input type="hidden" name="_xfToken" value="" />
</form>

</div>
</div>

<aside>
<div class="sidebar">
<div class="section loginButton">
<div class="secondaryContent">
<label for="LoginControl" id="SignupButton"><a href="/community/login/" class="inner">Sign up now!</a></label>
</div>
</div>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-2">

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent socialMediaIcon">
<a href="https://twitter.com/howtoforgecom" target="_blank"><img src="/images/socialmedia/64x64/twitter.png" /></a>
<a href="https://www.facebook.com/howtoforge" target="_blank"><img src="/images/socialmedia/64x64/facebook.png" /></a>
<a href="https://news.ycombinator.com/" target="_blank" rel="nofollow"><img src="/images/socialmedia/64x64/hackernews.png" /></a>
<a href="https://www.howtoforge.com/feed" target="_blank"><img src="/images/socialmedia/64x64/rss.png" /></a>
</div>
</div>
</div>
<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Tutorial Info</p>
<div class="pairsJustified">
<dl class="discussionCount">
<dt>Author:</dt>
<dd><a href="/author/muhammad+arul/" rel="author">Muhammad Arul</a></dd>
</dl>
<dl class="discussionCount">
<dt>Published:</dt>
<dd>Oct 06, 2020</dd>
</dl>
<dl class="discussionCount">
<dt>Tags:</dt>
<dd><a href='/tutorials/debian/' rel='tag'>debian</a>, <a href='/tutorials/mysql/' rel='tag'>mysql</a>, <a href='/tutorials/server/' rel='tag'>server</a></dd>
</dl>
</div>
</div>
</div>

<div id="sponsor-banner">
</div>

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent">
<p class="mnuinfo mnushare">Share This Page</p>
<p style="text-align:center;">
<a href="javascript:window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Ftutorial%2Fdebian_mysql%2F', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="javascript:window.open('https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Ftutorial%2Fdebian_mysql%2F&text=How+to+install+MySQL+8+on+Debian+10&via=howtoforgecom&related=howtoforgecom', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="javascript:window.open('https://news.ycombinator.com/submitlink?t=How+to+install+MySQL+8+on+Debian+10&u=https%3A%2F%2Fwww.howtoforge.com%2Ftutorial%2Fdebian_mysql%2F', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-hackernews.png" height="20" /></a>
</p>
<p style="color:#EE; font-weight:bold; text-align:center; margin-top:5px;">40.2k Followers</p>
</div>
</div>
</div>


<script type="text/javascript">
    google_ad_client = "ca-pub-3043223216276099";
    google_ad_slot = "6709042890";
    google_ad_width = 300;
    google_ad_height = 600;
</script>

<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>


<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Popular Tutorials</p>
<div class="pairsJustified">
<ul>
<li><a href="/tutorial/linux-grep-command/">How to use grep to search for strings in files on the shell</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-use-ftp-on-the-linux-shell/">How to use the Linux ftp command to up- and download files on the shell</a></li>
<li><hr /></li>
<li><a href="/faq/how-to-edit-files-on-the-command-line">How do I edit files on the command line?</a></li>
<li><hr /></li>
<li><a href="/tutorial/install-laravel-on-ubuntu-for-apache/">How to Install Laravel PHP Web Framework on Ubuntu 20.04</a></li>
<li><hr /></li>
<li><a href="/tutorial/perfect-server-ubuntu-18.04-with-apache-php-myqsl-pureftpd-bind-postfix-doveot-and-ispconfig/">The Perfect Server - Ubuntu 18.04 (Bionic Beaver) with Apache, PHP, MySQL, PureFTPD, BIND, Postfix, Dovecot and ISPConfig 3.1</a></li>
<li><hr /></li>
<li><a href="/how-to-install-and-use-traefik-as-a-reverse-proxy-with-docker-on-centos-8/">How to Install and Use Traefik as a Reverse Proxy with Docker on CentOS 8</a></li>
<li><hr /></li>
<li><a href="/use-node-affinity-in-kubernetes/">Use Node Affinity in Kubernetes</a></li>
 <li><hr /></li>
<li><a href="/tutorial/linux-search-files-from-the-terminal/">How to search files from the Terminal on Linux</a></li>
<li><hr /></li>
<li><a href="/install-ispconfig-3-roundcube-plugins-on-debian-10/">Install ISPConfig 3 - Roundcube plugins on Debian 10</a></li>
<li><hr /></li>
<li><a href="/how-to-install-redis-server-on-centos-8/">How to Install Redis Server on CentOS 8</a></li>
<li><hr /></li>
</ul>
</div>
</div>
</div>
</div>
</div>
</aside>
</div>
</div>
</div>
<footer>
<div class="footer">
<div class="pageWidth">
<div class="pageContent">
<div class='skin_branding'><span>Xenforo skin by <a href="http://www.xenfocus.com" rel="nofollow">Xenfocus</a></span></div>
<ul class="footerLinks">
<li><a href="/contribute/">Contribute</a></li>
<li><a href="/community/misc/contact">Contact</a></li>
<li><a href="/community/help/">Help</a></li>
<li><a href="/imprint/">Imprint and Legal Notice</a></li>
<li><a href="#navigation" class="topLink">Top</a></li>
<li><a href="/feed" rel="alternate" class="globalFeed" target="_blank" title="RSS-Feed for Howtoforge">RSS-Feed</a></li>
</ul>
<span class="helper"></span>
</div>
</div>
</div>
<div class="footerLegal">
<div class="pageWidth">
<div class="pageContent">
<ul id="legal">
<li><a href="/community/help/terms">Terms and Rules</a> <a href="https://www.howtoforge.com/community/help/privacy-policy">Privacy Policy</a></li>
</ul>
<div id="copyright"><a href="https://www.howtoforge.com" class="concealed">Howtoforge <span>&copy; projektfarm GmbH.</span></a></div>
<span class="helper"></span>
</div>
</div>
</div>
</footer>
<div style="height:100px;"></div>

<div id="subscriptionModal" class="modal">
<div class="modal-content">
<span class="close">&times;</span>
<p>This feature is only available to subscribers. Get your subscription <a href="/subscription">here</a>.</p>
</div>
</div>
<script>
//* Modal
var modal = document.getElementById('subscriptionModal');
var span = document.getElementsByClassName("close")[0];
$(".pdf-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
$(".print-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
span.onclick = function() {
	$("#subscriptionModal").css('display', 'none');
}
window.onclick = function(event) {
    if (event.target == modal) {
		$("#subscriptionModal").css('display', 'none');
    }
}
//* Xenforo
jQuery.extend(true, XenForo,
{
	visitor: { user_id: 0 },
	serverTimeInfo:
	{
		now: 1409831907,
		today: 1409781600,
		todayDow: 4
	},
	_lightBoxUniversal: "0",
	_enableOverlays: "1",
	_animationSpeedMultiplier: "1",
	_overlayConfig:
	{
		top: "10%",
		speed: 200,
		closeSpeed: 100,
		mask:
		{
			color: "rgb(0, 0, 0)",
			opacity: "0.6",
			loadSpeed: 200,
			closeSpeed: 100
		}
	},
	_ignoredUsers: [],
	_loadedScripts: {"node_list":true,"node_category":true,"node_forum":true,"sidebar_share_page":true,"wf_default":true,"bbm_buttons":true,"login_bar":true,"twitter":true},
	_cookieConfig: { path: "/", domain: "", prefix: "xf_"},
	_csrfToken: "",
	_csrfRefreshUrl: "/community/login/csrf-token-refresh",
	_jsVersion: "303ae0ca"
});
jQuery.extend(XenForo.phrases,
{
	cancel: "Cancel",

	a_moment_ago:    "A moment ago",
	one_minute_ago:  "1 minute ago",
	x_minutes_ago:   "%minutes% minutes ago",
	today_at_x:      "Today at %time%",
	yesterday_at_x:  "Yesterday at %time%",
	day_x_at_time_y: "%day% at %time%",

	day0: "Sunday",
	day1: "Monday",
	day2: "Tuesday",
	day3: "Wednesday",
	day4: "Thursday",
	day5: "Friday",
	day6: "Saturday",

	_months: "January,February,March,April,May,June,July,August,September,October,November,December",
	_daysShort: "Sun,Mon,Tue,Wed,Thu,Fri,Sat",

	following_error_occurred: "The following error occurred",
	server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
	logging_in: "Logging in",
	click_image_show_full_size_version: "Click this image to show the full-size version.",
	show_hidden_content_by_x: "Show hidden content by {names}"
});

// Facebook Javascript SDK
XenForo.Facebook.appId = "";
XenForo.Facebook.forceInit = true;

/*
document.addEventListener('DOMContentLoaded', function(event) {
  cookieChoices.showCookieConsentBar('Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.',
  'OK');
});
*/

$(document).ready(function() {
	$("a.fancybox").fancybox();
});

</script>

<script>
_bsa.init('custom', 'CKYD55QU', 'placement:howtoforge',
    {
      target: '#sponsor-banner',
      template: `
<a href="##link##" style="background: linear-gradient(-330deg, ##backgroundColor##D9, ##backgroundColor##D9 30%, ##backgroundColor## 70%) #fff;" class="native-banner">
<img class="native-img" src="##logo##">
<div style="color: ##textColor##" class="native-tagline">##tagline##</div>
<div style="color: ##textColor##" class="native-desc">##description##</div>
<div style="color: ##ctaTextColor##; background-color: ##ctaBackgroundColor##;" class="native-cta">##callToAction##</div>
<div style="background-color: ##textColor##B2; color: ##backgroundColor##" class="native-ad">Ad</div>
</a>
`
    }
  );
</script>

<script>
(function() {
  if (typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('fancybar', 'CKYDL27E', 'placement:howtoforgecom');
  }
})();
</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2155872-1', 'auto');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');

</script>
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=2&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=2&shcb=34', false, [], true, false, false, false);
</script>
<script>var _audins_dom="howtoforge_com",_audins_did=178704;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=191-2");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.howtoforge_com,DomainId.178704" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript' data-cfasync='false'></script></body>
</html>