<!DOCTYPE html>
<html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs LoggedOut Sidebar Responsive" xmlns:fb="http://www.facebook.com/2008/fbml">
<head>
<meta charset="utf-8" />
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<base href="https://www.howtoforge.com" />
<script>
			var _b = document.getElementsByTagName('base')[0], _bH = "https://www.howtoforge.com/install-automad-cms-with-nginx-and-lets-encrypt-ssl-on-debian-10/";
			if (_b && _b.href != _bH) _b.href = _bH;
		</script>
<title>Install Automad CMS with Nginx and Let's Encrypt SSL on Debian 10</title>
<meta name="description" content="Automad is a file-based content management system (CMS) and a template engine written in PHP. In this tutorial, we will go through the Automad CMS ins... " />
<meta property="og:title" content="Install Automad CMS with Nginx and Let's Encrypt SSL on Debian 10">
<meta property="og:description" content="Automad is a file-based content management system (CMS) and a template engine written in PHP. In this tutorial, we will go through the Automad CMS ins... ">
<meta property="og:site_name" content="HowtoForge">
<meta property="og:type" content="article">
<meta property="og:image" content="https://www.howtoforge.com/images/featured/debian-automad-cms.jpg">
<meta property="og:image:secure_url" content="https://www.howtoforge.com/images/featured/debian-automad-cms.jpg" />
<meta property="og:image:alt" content="Install Automad CMS with Nginx and Let's Encrypt SSL on Debian 10" />
<meta name="twitter:image" content="https://www.howtoforge.com/images/featured/debian-automad-cms.jpg" />
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="@howtoforgecom">
<meta name="twitter:creator" content="@howtoforgecom">
<meta name="twitter:title" content="Install Automad CMS with Nginx and Let's Encrypt SSL on Debian 10">
<meta name="twitter:description" content="Automad is a file-based content management system (CMS) and a template engine written in PHP. In this tutorial, we will go through the Automad CMS ins... ">
<link rel="alternate" href="https://www.howtoforge.com/install-automad-cms-with-nginx-and-lets-encrypt-ssl-on-debian-10/" hreflang="en" />
<link rel="canonical" href="https://www.howtoforge.com/tutorial/install-automad-cms-with-nginx-and-lets-encrypt-ssl-on-debian-10/" />
<link rel="amphtml" href="https://www.howtoforge.com/install-automad-cms-with-nginx-and-lets-encrypt-ssl-on-debian-10/amp/" />
<script type="application/ld+json">
{
  "@context" : "http://schema.org",
  "@type" : "Article",
  "name" : "Install Automad CMS with Nginx and Let's Encrypt SSL on Debian 10",
  "author" : {
    "@type" : "Person",
    "name" : "Blago Eres"
  },
  "articleSection" : "debian,linux,web server",
  "url" : "https://www.howtoforge.com/install-automad-cms-with-nginx-and-lets-encrypt-ssl-on-debian-10/",
  "publisher" : {
    "@type" : "Organization",
    "name" : "Howtoforge"
  }
}
</script>
<noscript><style>.JsOnly, .jsOnly { display: none !important; }</style></noscript>
<link rel="stylesheet" href="/community/styles/executive/xenfocus/icons/css/font-awesome.min.css" />
<link href='//fonts.googleapis.com/css?family=Open+Sans:400,700' rel='stylesheet' type='text/css' />
<link href="/themes/howtoforge/templates/xf.css" rel="stylesheet">
<script src="/js/jquery/jquery-1.11.3.min.js"></script>
<script src="/community/js/xenforo/xenforo.js?_v=303ae0ca"></script>
<script src="/community/js/bbm/zloader.js?_v=303ae0ca"></script>
<script type="text/javascript" src="/js/fancybox/jquery.mousewheel-3.0.4.pack.js"></script>
<script type="text/javascript" src="/js/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
<link rel="stylesheet" type="text/css" href="/js/fancybox/jquery.fancybox-1.3.4.css" media="screen" />
<link href="/themes/howtoforge/templates/style.min.css" rel="stylesheet">
<link rel="alternate" type="application/rss+xml" title="RSS-Feed für Howtoforge" href="/feed.rss" />
<script src="/js/tinymce_4.1.7/tinymce.min.js"></script>

<script type="text/javascript">
var gaProperty = 'UA-2155872-1';
var disableStr = 'ga-disable-' + gaProperty;
if (document.cookie.indexOf(disableStr + '=true') > -1) {
window[disableStr] = true;
}
function gaOptout() {
document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
window[disableStr] = true;
alert('Google Ananlyitics tracking has been disabled in this browser.');
}
</script>
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
	googletag.defineSlot('/1030080/howtoforge_com_list_sidebar_top', [300, 250], 'div-gpt-ad-1527185271042-4').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_list_content_middle', [[300, 250], [336, 280]], 'div-gpt-ad-1527185271042-5').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_a_300x250', [300, 250], 'div-gpt-ad-1527185271042-6').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_b_300x250', [300, 250], 'div-gpt-ad-1527185271042-7').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_leaderboard_b_728x90', [728, 90], 'div-gpt-ad-1527185271042-1').addService(googletag.pubads());
	googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-3043223216276099",
          enable_page_level_ads: true
     });
</script>


<script src="//m.servedby-buysellads.com/monetization.js" type="text/javascript"></script>


<script type="text/javascript">
    window.cookieconsent_options = {"message":"This website uses cookies to ensure you get the best experience on our website, analyze site traffic and show you relevant ads.","dismiss":"Got it!","learnMore":"More info","link":"https://www.howtoforge.com/community/help/cookies","theme":"dark-bottom"};
</script>
<script type="text/javascript" src="/js/cookieconsent.latest.min.js"></script>

</head>
<body>
<div id="loginBar">
<div class="pageWidth">
<div class="pageContent">
<h3 id="loginBarHandle">
<label for="LoginControl"><a href="/community/login/" class="concealed noOutline">Log in or Sign up</a></label>
</h3>
<span class="helper"></span>
</div>
</div>
</div>
<header>
<div id="header">
<div id="logoBlock">
<div class="pageWidth">
<div class="pageContent">
<div id="logo"><a href="/">
<span></span>
<img src="/images/howtoforge_logo_trans.gif" alt="Howtoforge" style="margin-left:20px;" />
</a></div>
<span class="helper"></span>
</div>
</div>
</div>
<div id="navigation" class="pageWidth withSearch">
<div class="pageContent">
<nav>
<div class="navTabs">
<ul class="publicTabs">

<li class="navTab forums selected">
<a href="/" class="navLink">Tutorials</a>
<div class="tabLinks forumsTabLinks">
<ul class="secondaryContent blockLinksList">
<li><a href="/search/">Tutorial search</a></li>
</ul>
</div>
</li>
<li class="navTab forums PopupClosed">
<a href="/tutorials/" class="navLink">Tags</a>
</li>
<li class="navTab forums PopupClosed"><a href="/community/" class="navLink">Forums</a></li>
<li class="navTab forums PopupClosed"><a href="/linux-commands/" class="navLink">Linux Commands</a></li>
<li class="navTab forums PopupClosed"><a href="/subscription/" class="navLink">Subscribe</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.ispconfig.org" class="navLink">ISPConfig</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.lxer.com" class="navLink">News</a></li>
</ul>
</div>
<span class="helper"></span>
</nav>
</div>
</div>
<div id="searchBar" class="pageWidth">
<span id="QuickSearchPlaceholder" title=" Search..."> Search</span>
<fieldset id="QuickSearch">
<form action="/" method="post" class="formPopup">
<div class="primaryControls">

<input type="search" name="q" value="" class="textCtrl" placeholder="Search..." results="0" title="Enter your search and hit enter..." id="QuickSearchQuery" />

</div>
<input type="hidden" name="_xfToken" value="" />
</form>
</fieldset>
</div>
</div>
</header>
<div id="content" class="forum_list">
<div class="pageWidth">
<div class="pageContent">

<div class="mainContainer">
<div class="mainContent">

<div class="breadBoxTop">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Home</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/install-automad-cms-with-nginx-and-lets-encrypt-ssl-on-debian-10/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Install Automad CMS with Nginx and Let's Encrypt SSL on Debian 10</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>

<div id="htfContentPage">
<div class="bsa-apiads"><a href="//srv.buysellads.com/ads/click/x/GTND42QNCWSDCK7LCYS4YKQMCYSDT23LF67DVZ3JCWSDKK3LCTBI4K7KC6BIK2QNCEYDTK3EHJNCLSIZ" target="_blank" rel="nofollow">The word's best software engineering teams use CircleCI to automate their DevOps flow.</a></div>
<article>
<h1>Install Automad CMS with Nginx and Let's Encrypt SSL on Debian 10</h1>
<div class="contributeEdit" style="float:right; width:450px; max-width:100%;">
<div id="tocContainer">
<h3>On this page</h3>
<ol class="toc">
<li><a href="#requirements">Requirements</a></li>
<li><a href="#prerequisites">Prerequisites</a></li>
<li><a href="#initial-steps">Initial steps</a></li>
<li><a href="#step-install-nodejs-and-npm">Step 1 - Install PHP and necessary PHP extensions</a></li>
<li><a href="#step-install-acmesh-client-and-obtain-lets-encrypt-certificate-optional-">Step 2 - Install acme.sh client and obtain Let's Encrypt certificate ( optional )</a></li>
<li><a href="#stepnbsp-install-and-configurenbspnginx">Step 3 - Install and configure NGINX</a></li>
<li><a href="#step-installnbspautomad-cms">Step 4 - Install&nbsp;Automad CMS</a></li>
<li><a href="#stepnbsp-nbspfinish-thenbspautomadnbspinstallation">Step&nbsp;5 -&nbsp;Finish the&nbsp;Automad&nbsp;installation</a></li>
<li><a href="#step-install-phorum">Links</a></li>
</ol>
</div>
</div>
<p>Automad<span> is a file-based content management system (CMS) and a template engine written in PHP.&nbsp;<span>All content is stored in human-readable text files instead of a database. An Automad site is therefore fully portable, </span>easy to install, <span>and can be version controlled by using Git or Mercurial. It nevertheless offers database features like </span>searching<span> and&nbsp;</span>tagging<span>. The built-in </span>template engine<span> allows even inexperienced developers and designers to create beautiful themes and templates.&nbsp;<span>In this tutorial, we will go&nbsp;through the Automad&nbsp;CMS installation and setup on&nbsp;Debian 10 (buster)&nbsp;system by using&nbsp;NGINX as a web server.</span></span></span></p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;">

<div id='div-gpt-ad-1527185271042-6' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-6'); });
</script>
</div>
</div>
<h2 id="requirements">Requirements</h2>
<p><span>Requirements for installing and running Automad CMS are as follows:</span></p>
<ul>
<li>PHP version 5.4 or higher.</li>
<li>Web server software like Nginx or Apache.</li>
</ul>
<h2 id="prerequisites">Prerequisites</h2>
<ul>
<li>A&nbsp;Debian 10 (buster) operating system.</li>
<li>A non-root user with <code>sudo</code> privileges.</li>
</ul>
<h2 id="initial-steps">Initial steps</h2>
<p>Check your&nbsp;Debian version:</p>
<pre class="command"><code spellcheck="false">lsb_release -ds<br /># Debian GNU/Linux 10 (buster)</code></pre>
<p>Set up the timezone:</p>
<pre class="command"><code spellcheck="false">sudo dpkg-reconfigure tzdata</code></pre>
<p>Update your operating system packages (software). That is an essential first step because it ensures you have the latest updates and security fixes for your operating system's default software packages:</p>
<pre class="command"><code spellcheck="false">sudo apt update &amp;&amp; sudo apt upgrade -y</code></pre>
<p>Install some essential packages that are necessary for basic administration of the Debian&nbsp;operating system:</p>
<pre class="command"><code spellcheck="false">sudo apt install -y curl wget vim git unzip socat bash-completion apt-transport-https</code></pre>
<h2 id="step-install-nodejs-and-npm">Step 1 - Install PHP and necessary PHP extensions</h2>
<p>Install PHP, as well as the required PHP extensions:</p>
<pre class="command"><code spellcheck="false">sudo apt install -y php php-cli php-fpm php-common php-mbstring php-xmlrpc php-soap php-gd php-xml php-curl php-zip</code></pre>
<p>To show PHP compiled in modules, you can run:</p>
<pre class="command"><code spellcheck="false"><span>php -m<br /><br />ctype<br />curl<br />exif<br />fileinfo<br />. . .<br />. . .</span></code></pre>
<p>Check the version:</p>
<pre class="command"><code spellcheck="false">php --version<br /><br /># PHP 7.3.4-2 (cli) (built: Apr 13 2019 19:05:48) ( NTS )<br /># Copyright (c) 1997-2018 The PHP Group<br /># Zend Engine v3.3.4, Copyright (c) 1998-2018 Zend Technologies<br /># with Zend OPcache v7.3.4-2, Copyright (c) 1999-2018, by Zend Technologies</code></pre>
<p><span>PHP-FPM service is automatically started and enabled on reboot on the Debian 10 system, so there is no need to start and enable it manually.&nbsp;We can move on to the next step.</span></p>
<h2 id="step-install-acmesh-client-and-obtain-lets-encrypt-certificate-optional-">Step 2 - Install acme.sh client and obtain Let's Encrypt certificate ( optional )</h2>
<p>Securing your forum with HTTPS is not necessary, but it is a good practice to secure your site traffic. To obtain a TLS certificate from Let's Encrypt we will use acme.sh client. Acme.sh is a simple UNIX shell software for obtaining TLS certificates from Let's Encrypt with zero dependencies.</p>
<p>Download and install acme.sh:</p>
<pre class="command"><code spellcheck="false">sudo su - root<br />git clone https://github.com/Neilpang/acme.sh.git<br />cd acme.sh <br />./acme.sh --install --accountemail <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="641d0b11163b0109050d0824011c05091408014a070b09">[email&#160;protected]</a><br />source ~/.bashrc<br />cd ~</code></pre>
<p>Check acme.sh version:</p>
<pre class="command"><code spellcheck="false">acme.sh --version<br /># v2.8.2</code></pre>
<p>Obtain <strong>RSA</strong> and <strong>ECC/ECDSA</strong> certificates for your domain/hostname:<code><br /></code></p>
<pre class="command"><code spellcheck="false"># RSA 2048<br />acme.sh --issue --standalone -d example.com --keylength 2048<br /># ECDSA<br />acme.sh --issue --standalone -d example.com --keylength ec-256</code></pre>
<p>If you want fake certificates for testing, you can add <code>--staging</code> flag to the above commands.</p>
<p>After running the above commands, your <em>certificates</em> and <em>keys</em> will be in:</p>
<ul>
<li>For <strong>RSA</strong>: <code>/home/username/example.com</code> directory.</li>
<li>For <strong>ECC/ECDSA</strong>: <code>/home/username/example.com_ecc</code> directory.</li>
</ul>
<p>To list your issued certs you can run:</p>
<pre class="command"><code spellcheck="false">acme.sh --list</code></pre>
<p>Create a directory to store your certs. We will use the&nbsp;<code>/etc/letsencrypt</code> directory.</p>
<pre class="command"><code>mkdir -p /etc/letsecnrypt/example.com</code><br /><code>sudo mkdir -p /etc/letsencrypt/example.com_ecc</code></pre>
<p><span face="monospace">Install/copy certificates to<span face="monospace"> <span face="monospace">/etc/letsencrypt<span face="monospace"><span face="monospace"> <span face="monospace">directory<span face="monospace">.</span></span></span></span></span></span></span></p>
<pre class="command"><code spellcheck="false"># RSA<br />acme.sh --install-cert -d example.com --cert-file /etc/letsencrypt/example.com/cert.pem --key-file /etc/letsencrypt/example.com/private.key --fullchain-file /etc/letsencrypt/example.com/fullchain.pem --reloadcmd "sudo systemctl reload nginx.service"<br /># ECC/ECDSA<br />acme.sh --install-cert -d example.com --ecc --cert-file /etc/letsencrypt/example.com_ecc/cert.pem --key-file /etc/letsencrypt/example.com_ecc/private.key --fullchain-file /etc/letsencrypt/example.com_ecc/fullchain.pem --reloadcmd "sudo systemctl reload nginx.service"</code></pre>
<p><span face="monospace">All the certificates will be automatically renewed every 60 days.</span></p>
<p>After obtaining certs exit from root user and return to regular sudo user:</p>
<pre class="command"><code spellcheck="false">exit</code></pre>
<h2 id="stepnbsp-install-and-configurenbspnginx">Step 3 - Install and configure NGINX</h2>
<p><span>Download and install NGINX from the Debian&nbsp;repository:</span></p>
<pre class="command"><code spellcheck="false">sudo apt install -y nginx</code></pre>
<p><span>Check the&nbsp;NGINX version:</span></p>
<pre class="command"><code spellcheck="false">sudo nginx -v<br /># nginx version: nginx/1.14.2</code></pre>
<p>Run <code>sudo vim /etc/nginx/sites-available/automad.conf</code> and populate the file with the following configuration:</p>
<pre><code>server {

  listen [::]:443 ssl http2;<br />  listen 443 ssl http2;<br />  listen [::]:80;<br />  listen 80;<br />
  # RSA<br />  ssl_certificate /etc/letsencrypt/example.com/fullchain.pem;<br />  ssl_certificate_key /etc/letsencrypt/example.com/private.key;<br />  # ECC<br />  ssl_certificate /etc/letsencrypt/example.com_ecc/fullchain.pem;<br />  ssl_certificate_key /etc/letsencrypt/example.com_ecc/private.key;<br />
  server_name example.com;

  root /var/www/automad;

  index index.php index.html;

  client_max_body_size 100M;

  location / {
    try_files $uri $uri/ /index.php$is_args$args;
  }


  location ~ \.php$ {
    fastcgi_index index.php;
    fastcgi_pass unix:/var/run/php/php7.3-fpm.sock;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    include fastcgi_params;
  }

}
</code></pre>
<p>Activate the new <code>automad.conf</code> configuration by linking the file to the <code>sites-enabled</code> directory:</p>
<pre class="command"><code spellcheck="false">sudo ln -s /etc/nginx/sites-available/automad.conf /etc/nginx/sites-enabled/</code></pre>
<p><span>Check&nbsp;</span><span>NGINX</span> <span>configuration for syntax errors:</span></p>
<pre class="command"><code spellcheck="false">sudo nginx -t</code></pre>
<p>Reload Nginx:</p>
<pre class="command"><code spellcheck="false">sudo systemctl reload nginx.service</code></pre>
<h2 id="step-installnbspautomad-cms">Step 4 - Install&nbsp;Automad CMS</h2>
<p><span>Create a document root directory for Automad:</span></p>
<pre class="command"><code spellcheck="false">sudo mkdir -p /var/www/automad</code></pre>
<p>Navigate to the document root:</p>
<pre class="command"><code spellcheck="false">cd /var/www/automad</code></pre>
<p>Using <code>curl</code> download the latest release of Automad CMS. Don't forget to bump up the version numbers if there is a newer release:</p>
<pre class="command"><code spellcheck="false">sudo curl -O -J -L https://automad.org/download</code></pre>
<p>Uncompress the zip archive:</p>
<pre class="command"><code spellcheck="false">sudo unzip marcantondahmen-automad-6fff2a0456dc.zip</code></pre>
<p>Move all Automad files to the document root and remove downloaded zip archive:</p>
<pre class="command"><code spellcheck="false">sudo mv marcantondahmen-automad-6fff2a0456dc/* . &amp;&amp; sudo mv marcantondahmen-automad-6fff2a0456dc/.* .<br />sudo rm marcantondahmen-automad-6fff2a0456dc.zip<br />sudo rmdir marcantondahmen-automad-6fff2a0456dc</code></pre>
<p>Change ownership of the <code>/var/www/automad</code> directory to <code>www-data:</code></p>
<pre class="command"><code spellcheck="false">sudo chown -R www-data:www-data /var/www/automad</code></pre>
<h2 id="stepnbsp-nbspfinish-thenbspautomadnbspinstallation">Step&nbsp;5 -&nbsp;Finish the&nbsp;Automad&nbsp;installation</h2>
<p>As the last step, create a user account to use the browser-based user interface called the Dashboard. Therefore navigate to <code>https://example.com/dashboard</code> and follow the instructions.</p>
<p>Before you can use Automad dashboard, you will need to create an account:</p>
<p style="text-align: center;"><a class="fancybox" id="img-Screenshot_2019-07-03_at_07.49_.35_" href="https://www.howtoforge.com/images/how_to_install_automad_cms_on_ubuntu_1804/big/Screenshot_2019-07-03_at_07.49_.35_.png"><img src="https://www.howtoforge.com/images/how_to_install_automad_cms_on_ubuntu_1804/Screenshot_2019-07-03_at_07.49_.35_.png" alt="Create website in Automad" width="750" height="431" /></a></p>
<p>Create a user account using the form and download the generated file&nbsp;to your computer.&nbsp;After you will need to move the downloaded file to the "/config" directory within Automad installation directory.</p>
<p>After that you can log in to Automad dashboard:</p>
<p style="text-align: center;"><a class="fancybox" id="img-Screenshot_2019-07-03_at_08.13_.09_" href="https://www.howtoforge.com/images/how_to_install_automad_cms_on_ubuntu_1804/big/Screenshot_2019-07-03_at_08.13_.09_.png"><img src="https://www.howtoforge.com/images/how_to_install_automad_cms_on_ubuntu_1804/Screenshot_2019-07-03_at_08.13_.09_.png" alt="Automad Log in" width="750" height="431" /></a></p>
<p>In the end, Automad admin interface will be displayed:</p>
<p style="text-align: center;"><a class="fancybox" id="img-Screenshot_2019-07-03_at_08.13_.24_" href="https://www.howtoforge.com/images/how_to_install_automad_cms_on_ubuntu_1804/big/Screenshot_2019-07-03_at_08.13_.24_.png"><img src="https://www.howtoforge.com/images/how_to_install_automad_cms_on_ubuntu_1804/Screenshot_2019-07-03_at_08.13_.24_.png" alt="Automad admin dashboard" width="750" height="431" /></a></p>
<p>That's it. Automad installation is finished.</p>
<h2 id="step-install-phorum">Links</h2>
<ul>
<li><a href="https://automad.org/">https://automad.org/</a></li>
<li><a href="https://bitbucket.org/marcantondahmen/automad/">https://bitbucket.org/marcantondahmen/automad/</a></li>
</ul>
</article>

<aside class="authorbox" style="margin-top:20px;">
<img src="/images/profile/blago_eres.png" alt="Blago Eres" /> <p><strong>About Blago Eres</strong></p>
<p>Blago Eres is a freelance Web Developer, Linux System Administrator and Technical Writer with more than 3 years of experience. Blago is skilled at RHEL/CentOS, Debian/Ubuntu, Web Servers, Database Servers, HTTP, PHP, JavaScript, Load Balancing, Caching etc.</p>
</aside>

<div style="height:30px; margin-top:20px;">
<p style="text-align:right;"><img src="/images/pdficon_small.png" /> <a class="pdf-btn" href="javascript:void(0);">view as pdf</a> | <img src="/images/print.gif" /> <a class="print-btn" href="javascript:void(0);">print</a></p>
</div>
<div style="height:30px; margin-top:20px;">
<div style="float:left;"><b>Share this page:</b></div>
<p style="text-align:center;">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Finstall-automad-cms-with-nginx-and-lets-encrypt-ssl-on-debian-10%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Finstall-automad-cms-with-nginx-and-lets-encrypt-ssl-on-debian-10%2F&text=Install+Automad+CMS+with+Nginx+and+Let%27s+Encrypt+SSL+on+Debian+10&via=howtoforgecom&related=howtoforgecom" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.howtoforge.com%2Finstall-automad-cms-with-nginx-and-lets-encrypt-ssl-on-debian-10%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-gplus.png" height="20" /></a>
</p>
</div>
</div>


<div id="htfContentPagePaging">
<h2>Suggested articles</h2>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-3043223216276099" data-ad-slot="8940054090"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>


<div id="htfContentPageComment">
<a name="comments"></a>
<h2>0 Comment(s)</h2>

<div id="commentform">
<div class="commentContainerHead" style="font-size:18px;">Add comment</div>
<div class="commentContainer">
<form method="post" action="/install-automad-cms-with-nginx-and-lets-encrypt-ssl-on-debian-10/#comments">
<input type="hidden" name="reply_to" id="reply-to-comment" value="0" />
<div id="commentFormDetail">
<div style="width:48%; float:left; margin-right:3%">
<label for="commentname">Name *</label>
<input id="commentname" name="commentname" value="" />
</div>
<div style="width:48%;float:left;">
<label for="commentname">Email *</label>
<input id="commentemail" name="commentemail" value="" />
</div>
<div style="clear:both;"></div>
</div>
<textarea id="commentedit" name="commentedit" style="width:auto;"></textarea>
<div>
<div style="float:left;">
<div class="g-recaptcha" data-sitekey="6LdX9fUSAAAAALWwVoPdeXScMSketz4npF-0QcQ1"></div>
<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en">
      </script>
</div>
<div style="margin-top:10px;margin-bottom:10px;">
<input type="submit" name="submit" class="button primary" style="float:right;" value="Submit comment">
</div>
<div style="clear:both;"></div>
</div>
<script>
	tinymce.init({
		selector: "textarea#commentedit",
		theme: "modern",
		height: 100,
		apply_source_formatting : true,
		remove_linebreaks : false,
		menubar : false,
		/*auto_focus : "commentedit",*/
		plugins: [
		"link"
		],
		/*plugins: [
			"advlist autolink link image lists charmap print preview hr anchor pagebreak spellchecker",
			"searchreplace wordcount visualblocks visualchars code fullscreen insertdatetime media nonbreaking",
			"save table contextmenu directionality emoticons template paste textcolor"
		],*/
		content_css: "https://www.howtoforge.com/themes/howtoforge/css/custom.css",
		toolbar: "undo redo | bold italic link", 
		/*style_formats: [
			{title: 'Bold text', inline: 'b'},
			{title: 'Red text', inline: 'span', styles: {color: '#ff0000'}},
			{title: 'Red header', block: 'h1', styles: {color: '#ff0000'}},
			{title: 'Example 1', inline: 'span', classes: 'example1'},
			{title: 'Example 2', inline: 'span', classes: 'example2'},
			{title: 'Table styles'},
			{title: 'Table row 1', selector: 'tr', classes: 'tablerow1'}
		]*/
	}); 
	</script>
</form>
</div>
</div>

</div>

<div class="breadBoxBottom">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Home</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/install-automad-cms-with-nginx-and-lets-encrypt-ssl-on-debian-10/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Install Automad CMS with Nginx and Let's Encrypt SSL on Debian 10</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
<script>
<!--

$(document).on('click', 'a.reply-to', function(e) {
	e.preventDefault();
	
	var self = $(this);
	var cid = self.attr('data-comment');
	console.log(cid);
	if(!cid) return this;
	
	$('#commentform').insertAfter('#comment' + cid);
	$('#reply-to-comment').val(cid);
	/*tinyMCE.activeEditor.focus();*/
	var textareaId = 'commentedit';
	tinyMCE.get(textareaId).remove();
	tinyMCE.execCommand("mceAddEditor", false, textareaId);
	tinyMCE.activeEditor.focus();
});
//-->
</script>
<div style="margin-top:10px;margin-bottom:10px;text-align:center;">

<center>


<div id='div-gpt-ad-1527185271042-1' style='height:90px; width:728px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-1'); });
</script>
</div>

</center>
</div>


<form action="/community/login/login?redirect=/install-automad-cms-with-nginx-and-lets-encrypt-ssl-on-debian-10/" method="post" class="xenForm eAuth" id="login" style="display:none">
<ul id="eAuthUnit">
<li><a href="/community/register/facebook?reg=1" class="fbLogin" tabindex="110"><span>Log in with Facebook</span></a></li>
<li><a href="/community/register/twitter?reg=1" class="twitterLogin" tabindex="110"><span>Log in with Twitter</span></a></li>
<li><span class="googleLogin GoogleLogin JsOnly" tabindex="110" data-client-id="198773272284-b6tfk0c28bje81p774prrcrkq9jb3o44.apps.googleusercontent.com" data-redirect-url="/community/register/google?code=__CODE__&amp;csrf=hVMXbW_3rnrmq4Em"><span>Log in with Google</span></span></li>
</ul>
<div class="ctrlWrapper">
<dl class="ctrlUnit">
<dt><label for="LoginControl">Your name or email address:</label></dt>
<dd><input type="text" name="login" id="LoginControl" class="textCtrl" tabindex="101" /></dd>
</dl>
<dl class="ctrlUnit">
<dt>
<label for="ctrl_password">Do you already have an account?</label>
</dt>
<dd>
<ul>
<li><label for="ctrl_not_registered"><input type="radio" name="register" value="1" id="ctrl_not_registered" tabindex="105" />
No, create an account now.</label></li>
<li><label for="ctrl_registered"><input type="radio" name="register" value="0" id="ctrl_registered" tabindex="105" checked="checked" class="Disabler" />
Yes, my password is:</label></li>
<li id="ctrl_registered_Disabler">
<input type="password" name="password" class="textCtrl" id="ctrl_password" tabindex="102" />
<div class="lostPassword"><a href="/community/lost-password/" tabindex="106">Forgot your password?</a></div>
</li>
</ul>
</dd>
</dl>
<dl class="ctrlUnit submitUnit">
<dt></dt>
<dd>
<input type="submit" class="button primary" value="Log in" tabindex="104" data-loginPhrase="Log in" data-signupPhrase="Sign up" />
<label for="ctrl_remember" class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_remember" tabindex="103" /> Stay logged in</label>
</dd>
</dl>
</div>
<input type="hidden" name="cookie_check" value="1" />
<input type="hidden" name="redirect" value="/community/" />
<input type="hidden" name="_xfToken" value="" />
</form>

</div>
</div>

<aside>
<div class="sidebar">
<div class="section loginButton">
<div class="secondaryContent">
<label for="LoginControl" id="SignupButton"><a href="/community/login/" class="inner">Sign up now!</a></label>
</div>
</div>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-2">

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent socialMediaIcon">
<a href="https://twitter.com/howtoforgecom" target="_blank"><img src="/images/socialmedia/64x64/twitter.png" /></a>
<a href="https://www.facebook.com/howtoforge" target="_blank"><img src="/images/socialmedia/64x64/facebook.png" /></a>
<a href="https://news.ycombinator.com/" target="_blank" rel="nofollow"><img src="/images/socialmedia/64x64/hackernews.png" /></a>
<a href="https://www.howtoforge.com/feed" target="_blank"><img src="/images/socialmedia/64x64/rss.png" /></a>
</div>
</div>
</div>
<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Tutorial Info</p>
<div class="pairsJustified">
<dl class="discussionCount">
<dt>Author:</dt>
<dd><a href="/author/blago+eres/" rel="author">Blago Eres</a></dd>
</dl>
<dl class="discussionCount">
<dt>Published:</dt>
<dd>Aug 12, 2019</dd>
</dl>
<dl class="discussionCount">
<dt>Tags:</dt>
<dd><a href='/tutorials/debian/' rel='tag'>debian</a>, <a href='/tutorials/linux/' rel='tag'>linux</a>, <a href='/tutorials/web+server/' rel='tag'>web server</a></dd>
</dl>
</div>
</div>
</div>
<div id="sponsor-banner">
</div>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent">
<p class="mnuinfo mnushare">Share This Page</p>
<p style="text-align:center;">
<a href="javascript:window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Finstall-automad-cms-with-nginx-and-lets-encrypt-ssl-on-debian-10%2F', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="javascript:window.open('https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Finstall-automad-cms-with-nginx-and-lets-encrypt-ssl-on-debian-10%2F&text=Install+Automad+CMS+with+Nginx+and+Let%27s+Encrypt+SSL+on+Debian+10&via=howtoforgecom&related=howtoforgecom', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="javascript:window.open('https://news.ycombinator.com/submitlink?t=Install+Automad+CMS+with+Nginx+and+Let%27s+Encrypt+SSL+on+Debian+10&u=https%3A%2F%2Fwww.howtoforge.com%2Finstall-automad-cms-with-nginx-and-lets-encrypt-ssl-on-debian-10%2F', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-hackernews.png" height="20" /></a>
</p>
<p style="color:#EE; font-weight:bold; text-align:center; margin-top:5px;">40.2k Followers</p>
</div>
</div>
</div>


<script type="text/javascript">
    google_ad_client = "ca-pub-3043223216276099";
    google_ad_slot = "6709042890";
    google_ad_width = 300;
    google_ad_height = 600;
</script>

<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>


<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Popular Tutorials</p>
<div class="pairsJustified">
<ul>
<li><a href="/linux-commands/">Linux Commands - Overview and Examples</a></li>
<li><hr /></li>
<li><a href="/tutorial/linux-grep-command/">How to use grep to search for strings in files on the shell</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-create-docker-images-with-dockerfile/">How to create Docker Images with a Dockerfile</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-use-ftp-on-the-linux-shell/">How to use the Linux ftp command to up- and download files on the shell</a></li>
<li><hr /></li>
<li><a href="/tutorial/linux-search-files-from-the-terminal/">How to search files from the terminal on Linux</a></li>
<li><hr /></li>
<li><a href="/configure-remote-access-to-your-ubuntu-desktop">How To Configure Remote Access To Your Ubuntu Desktop</a></li>
<li><hr /></li>
<li><a href="/setting-changing-resetting-mysql-root-passwords">Setting, Changing and Resetting MySQL Root Passwords</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-setup-zsh-and-oh-my-zsh-on-linux/">How to Setup ZSH and Oh-my-zsh on Linux</a></li>
<li><hr /></li>
<li><a href="/perfect-server-debian-10-buster-apache-bind-dovecot-ispconfig-3-1/">The Perfect Server - Debian 10 (Buster) with Apache, BIND, Dovecot, PureFTPD and ISPConfig 3.1</a></li>
<li><hr /></li>
<li><a href="/how-to-install-strider-cd-on-ubuntu-1804/">How to Install Strider Continuous Integration Server on Ubuntu 18.04 LTS</a></li>
<li><hr /></li>
</ul>
</div>
</div>
</div>
</div>
</div>
</aside>
</div>
</div>
</div>
<footer>
<div class="footer">
<div class="pageWidth">
<div class="pageContent">
<div class='skin_branding'><span>Xenforo skin by <a href="http://www.xenfocus.com" rel="nofollow">Xenfocus</a></span></div>
<ul class="footerLinks">
<li><a href="/contribute/">Contribute</a></li>
<li><a href="/community/misc/contact">Contact</a></li>
<li><a href="/community/help/">Help</a></li>
<li><a href="/imprint/">Imprint and Legal Notice</a></li>
<li><a href="#navigation" class="topLink">Top</a></li>
<li><a href="/feed" rel="alternate" class="globalFeed" target="_blank" title="RSS-Feed for Howtoforge">RSS-Feed</a></li>
</ul>
<span class="helper"></span>
</div>
</div>
</div>
<div class="footerLegal">
<div class="pageWidth">
<div class="pageContent">
<ul id="legal">
<li><a href="/community/help/terms">Terms and Rules</a> <a href="https://www.howtoforge.com/community/help/privacy-policy">Privacy Policy</a></li>
</ul>
<div id="copyright"><a href="https://www.howtoforge.com" class="concealed">Howtoforge <span>&copy; projektfarm GmbH.</span></a></div>
<span class="helper"></span>
</div>
</div>
</div>
</footer>
<div style="height:100px;"></div>

<div id="subscriptionModal" class="modal">
<div class="modal-content">
<span class="close">&times;</span>
<p>This feature is only available to subscribers. Get your subscription <a href="/subscription">here</a>.</p>
</div>
</div>
<script>
//* Modal
var modal = document.getElementById('subscriptionModal');
var span = document.getElementsByClassName("close")[0];
$(".pdf-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
$(".print-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
span.onclick = function() {
	$("#subscriptionModal").css('display', 'none');
}
window.onclick = function(event) {
    if (event.target == modal) {
		$("#subscriptionModal").css('display', 'none');
    }
}
//* Xenforo
jQuery.extend(true, XenForo,
{
	visitor: { user_id: 0 },
	serverTimeInfo:
	{
		now: 1409831907,
		today: 1409781600,
		todayDow: 4
	},
	_lightBoxUniversal: "0",
	_enableOverlays: "1",
	_animationSpeedMultiplier: "1",
	_overlayConfig:
	{
		top: "10%",
		speed: 200,
		closeSpeed: 100,
		mask:
		{
			color: "rgb(0, 0, 0)",
			opacity: "0.6",
			loadSpeed: 200,
			closeSpeed: 100
		}
	},
	_ignoredUsers: [],
	_loadedScripts: {"node_list":true,"node_category":true,"node_forum":true,"sidebar_share_page":true,"wf_default":true,"bbm_buttons":true,"login_bar":true,"twitter":true},
	_cookieConfig: { path: "/", domain: "", prefix: "xf_"},
	_csrfToken: "",
	_csrfRefreshUrl: "/community/login/csrf-token-refresh",
	_jsVersion: "303ae0ca"
});
jQuery.extend(XenForo.phrases,
{
	cancel: "Cancel",

	a_moment_ago:    "A moment ago",
	one_minute_ago:  "1 minute ago",
	x_minutes_ago:   "%minutes% minutes ago",
	today_at_x:      "Today at %time%",
	yesterday_at_x:  "Yesterday at %time%",
	day_x_at_time_y: "%day% at %time%",

	day0: "Sunday",
	day1: "Monday",
	day2: "Tuesday",
	day3: "Wednesday",
	day4: "Thursday",
	day5: "Friday",
	day6: "Saturday",

	_months: "January,February,March,April,May,June,July,August,September,October,November,December",
	_daysShort: "Sun,Mon,Tue,Wed,Thu,Fri,Sat",

	following_error_occurred: "The following error occurred",
	server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
	logging_in: "Logging in",
	click_image_show_full_size_version: "Click this image to show the full-size version.",
	show_hidden_content_by_x: "Show hidden content by {names}"
});

// Facebook Javascript SDK
XenForo.Facebook.appId = "";
XenForo.Facebook.forceInit = true;

/*
document.addEventListener('DOMContentLoaded', function(event) {
  cookieChoices.showCookieConsentBar('Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.',
  'OK');
});
*/

$(document).ready(function() {
	$("a.fancybox").fancybox();
});

</script>
<script>
_bsa.init('custom', 'CKYD55QU', 'placement:howtoforge',
    {
      target: '#sponsor-banner',
      template: `
<a href="##link##" style="background: linear-gradient(-330deg, ##backgroundColor##D9, ##backgroundColor##D9 30%, ##backgroundColor## 70%) #fff;" class="native-banner">
<img class="native-img" src="##logo##">
<div style="color: ##textColor##" class="native-tagline">##tagline##</div>
<div style="color: ##textColor##" class="native-desc">##description##</div>
<div style="color: ##ctaTextColor##; background-color: ##ctaBackgroundColor##;" class="native-cta">##callToAction##</div>
<div style="background-color: ##textColor##B2; color: ##backgroundColor##" class="native-ad">Ad</div>
</a>
`
    }
  );
</script>
<script>
(function() {
  if (typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('fancybar', 'CKYDL27E', 'placement:howtoforgecom');
  }
})();
</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2155872-1', 'auto');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');

</script>
</body>
</html>