<!DOCTYPE html>
<html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs LoggedOut Sidebar Responsive" xmlns:fb="http://www.facebook.com/2008/fbml">
<head>
<meta charset="utf-8" />
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<base href="https://www.howtoforge.com" />
<script>
			var _b = document.getElementsByTagName('base')[0], _bH = "https://www.howtoforge.com/how-to-setup-riak-kv-nosql-database-cluster-on-centos-7/";
			if (_b && _b.href != _bH) _b.href = _bH;
		</script>
<title>How to Setup Riak KV NoSQL Database Cluster on CentOS 7</title>
<meta name="description" content="Riak is a distributed NoSQL database that offers high-availability, fault tolerance, operational simplicity, and scalability. In this tutorial, I will... " />
<meta property="og:title" content="How to Setup Riak KV NoSQL Database Cluster on CentOS 7">
<meta property="og:description" content="Riak is a distributed NoSQL database that offers high-availability, fault tolerance, operational simplicity, and scalability. In this tutorial, I will... ">
<meta property="og:site_name" content="HowtoForge">
<meta property="og:type" content="article">
<meta property="og:image" content="https://www.howtoforge.com/images/featured/riak-kv-cluster.jpg">
<meta property="og:image:secure_url" content="https://www.howtoforge.com/images/featured/riak-kv-cluster.jpg" />
<meta property="og:image:alt" content="How to Setup Riak KV NoSQL Database Cluster on CentOS 7" />
<meta name="twitter:image" content="https://www.howtoforge.com/images/featured/riak-kv-cluster.jpg" />
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="@howtoforgecom">
<meta name="twitter:creator" content="@howtoforgecom">
<meta name="twitter:title" content="How to Setup Riak KV NoSQL Database Cluster on CentOS 7">
<meta name="twitter:description" content="Riak is a distributed NoSQL database that offers high-availability, fault tolerance, operational simplicity, and scalability. In this tutorial, I will... ">
<link rel="alternate" href="https://www.howtoforge.com/how-to-setup-riak-kv-nosql-database-cluster-on-centos-7/" hreflang="en" />
<link rel="canonical" href="https://www.howtoforge.com/tutorial/how-to-setup-riak-kv-nosql-database-cluster-on-centos-7/" />
<link rel="amphtml" href="https://www.howtoforge.com/how-to-setup-riak-kv-nosql-database-cluster-on-centos-7/amp/" />
<script type="application/ld+json">
{
  "@context" : "http://schema.org",
  "@type" : "Article",
  "name" : "How to Setup Riak KV NoSQL Database Cluster on CentOS 7",
  "author" : {
    "@type" : "Person",
    "name" : "Muhammad Arul"
  },
  "articleSection" : "centos,linux",
  "url" : "https://www.howtoforge.com/how-to-setup-riak-kv-nosql-database-cluster-on-centos-7/",
  "publisher" : {
    "@type" : "Organization",
    "name" : "Howtoforge"
  }
}
</script>
<noscript><style>.JsOnly, .jsOnly { display: none !important; }</style></noscript>
<link rel="stylesheet" href="/community/styles/executive/xenfocus/icons/css/font-awesome.min.css" />
<link href='//fonts.googleapis.com/css?family=Open+Sans:400,700' rel='stylesheet' type='text/css' />
<link href="/themes/howtoforge/templates/xf.css" rel="stylesheet">
<script src="/js/jquery/jquery-1.11.3.min.js"></script>
<script src="/community/js/xenforo/xenforo.js?_v=303ae0ca"></script>
<script src="/community/js/bbm/zloader.js?_v=303ae0ca"></script>
<script type="text/javascript" src="/js/fancybox/jquery.mousewheel-3.0.4.pack.js"></script>
<script type="text/javascript" src="/js/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
<link rel="stylesheet" type="text/css" href="/js/fancybox/jquery.fancybox-1.3.4.css" media="screen" />
<link href="/themes/howtoforge/templates/style.min.css" rel="stylesheet">
<link rel="alternate" type="application/rss+xml" title="RSS-Feed für Howtoforge" href="/feed.rss" />
<script src="/js/tinymce_4.1.7/tinymce.min.js"></script>

<script type="text/javascript">
var gaProperty = 'UA-2155872-1';
var disableStr = 'ga-disable-' + gaProperty;
if (document.cookie.indexOf(disableStr + '=true') > -1) {
window[disableStr] = true;
}
function gaOptout() {
document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
window[disableStr] = true;
alert('Google Ananlyitics tracking has been disabled in this browser.');
}
</script>
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
	googletag.defineSlot('/1030080/howtoforge_com_list_sidebar_top', [300, 250], 'div-gpt-ad-1527185271042-4').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_list_content_middle', [[300, 250], [336, 280]], 'div-gpt-ad-1527185271042-5').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_a_300x250', [300, 250], 'div-gpt-ad-1527185271042-6').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_b_300x250', [300, 250], 'div-gpt-ad-1527185271042-7').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_leaderboard_b_728x90', [728, 90], 'div-gpt-ad-1527185271042-1').addService(googletag.pubads());
	googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-3043223216276099",
          enable_page_level_ads: true
     });
</script>


<script type="text/javascript">
    window.cookieconsent_options = {"message":"This website uses cookies to ensure you get the best experience on our website, analyze site traffic and show you relevant ads.","dismiss":"Got it!","learnMore":"More info","link":"https://www.howtoforge.com/community/help/cookies","theme":"dark-bottom"};
</script>
<script type="text/javascript" src="/js/cookieconsent.latest.min.js"></script>

</head>
<body>
<div id="loginBar">
<div class="pageWidth">
<div class="pageContent">
<h3 id="loginBarHandle">
<label for="LoginControl"><a href="/community/login/" class="concealed noOutline">Log in or Sign up</a></label>
</h3>
<span class="helper"></span>
</div>
</div>
</div>
<header>
<div id="header">
<div id="logoBlock">
<div class="pageWidth">
<div class="pageContent">
<div id="logo"><a href="/">
<span></span>
<img src="/images/howtoforge_logo_trans.gif" alt="Howtoforge" style="margin-left:20px;" />
</a></div>
<span class="helper"></span>
</div>
</div>
</div>
<div id="navigation" class="pageWidth withSearch">
<div class="pageContent">
<nav>
<div class="navTabs">
<ul class="publicTabs">

<li class="navTab forums selected">
<a href="/" class="navLink">Tutorials</a>
<div class="tabLinks forumsTabLinks">
<ul class="secondaryContent blockLinksList">
<li><a href="/search/">Tutorial search</a></li>
</ul>
</div>
</li>
<li class="navTab forums PopupClosed">
<a href="/tutorials/" class="navLink">Tags</a>
</li>
<li class="navTab forums PopupClosed"><a href="/community/" class="navLink">Forums</a></li>
<li class="navTab forums PopupClosed"><a href="/linux-commands/" class="navLink">Linux Commands</a></li>
<li class="navTab forums PopupClosed"><a href="/subscription/" class="navLink">Subscribe</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.ispconfig.org" class="navLink">ISPConfig</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.lxer.com" class="navLink">News</a></li>
</ul>
</div>
<span class="helper"></span>
</nav>
</div>
</div>
<div id="searchBar" class="pageWidth">
<span id="QuickSearchPlaceholder" title=" Search..."> Search</span>
<fieldset id="QuickSearch">
<form action="/" method="post" class="formPopup">
<div class="primaryControls">

<input type="search" name="q" value="" class="textCtrl" placeholder="Search..." results="0" title="Enter your search and hit enter..." id="QuickSearchQuery" />

</div>
<input type="hidden" name="_xfToken" value="" />
</form>
</fieldset>
</div>
</div>
</header>
<div id="content" class="forum_list">
<div class="pageWidth">
<div class="pageContent">

<div class="mainContainer">
<div class="mainContent">

<div class="breadBoxTop">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Home</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/how-to-setup-riak-kv-nosql-database-cluster-on-centos-7/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to Setup Riak KV NoSQL Database Cluster on CentOS 7</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>

<div id="htfContentPage">
<div class="bsa-apiads"><a href="//srv.buysellads.com/ads/click/x/GTND42QWCWYIK2QICKY4YKQMCEBI4K3UFT7IVZ3JCWBDPK7ICWAICKJKC6BIV2QJCWSDTK3EHJNCLSIZ" target="_blank" rel="nofollow">It's teamwork, but simpler, more pleasant and more productive.</a><img src="https://ad.doubleclick.net/ddm/trackimp/N32602.3091281BUYSELLADS/B21259774.226790394;dc_trk_aid=424684263;dc_trk_cid=104611490;ord=[1545159031];dc_lat=;dc_rdid=;tag_for_child_directed_treatment=;tfua=?" height="1" width="1" border="0" style="display:none;" /><img src="https://slack.sp1.convertro.com/view/vt/v1/slack/0/cvo.gif?cvosrc=display.carbon.one%20cpc&utm_source=carbon&utm_medium=display&utm_campaign=one%20cpc" height="1" width="1" border="0" style="display:none;" /></div>
<article>
<h1>How to Setup Riak KV NoSQL Database Cluster on CentOS 7</h1>
<div class="contributeEdit" style="float:right; width:450px; max-width:100%;">
<div id="tocContainer">
<h3>On this page</h3>
<ol class="toc">
<li><a href="#prerequisites">Prerequisites</a></li>
<li><a href="#what-we-will-do">What we will do</a></li>
<li><a href="#step-install-riak-kv-on-centos-">Step 1 - Install Riak KV on CentOS 7</a></li>
<li><a href="#step-basic-configuration-riak-kv">Step 2 - Basic Configuration Riak KV</a></li>
<li><a href="#step-setup-riak-kv-cluster">Step 3 - Setup Riak KV Cluster</a></li>
<li><a href="#step-testing">Step 4 - Testing</a></li>
<li><a href="#reference">Reference</a></li>
</ol>
</div>
</div>
<p>Riak is a distributed NoSQL database that offers high-availability, fault tolerance, operational simplicity, and scalability. Riak has been written in Erlang and is part of the 'Basho' product line that includes Riak KV (Key-value), Riak TS (optimized for IoT/Time Series), and Riak CS (Riak Cloud Storage).</p>
<p>In this tutorial, I will&nbsp;show you how to install and configure the NoSQL database Riak KV on CentOS 7 server. We will create the Riak KV cluster with three CentOS servers.</p>
<h2 id="prerequisites">Prerequisites</h2>
<ul>
<li>3 Servers CentOS 7</li>
<ul>
<li>riak01&nbsp;&nbsp;&nbsp;&nbsp; 10.1.1.10</li>
<li>riak02&nbsp;&nbsp;&nbsp;&nbsp; 10.1.1.11</li>
<li>riak03&nbsp;&nbsp;&nbsp;&nbsp; 10.1.1.12</li>
</ul>
<li>Root privileges</li>
</ul>
<h2 id="what-we-will-do">What we will do</h2>
<ol>
<li>Install Riak KV on CentOS 7</li>
<li>Basic Riak KV Configuration</li>
<li>Setup Riak KV Cluster</li>
<li>Testing</li>
</ol>
<h2 id="step-install-riak-kv-on-centos-">Step 1 - Install Riak KV on CentOS 7</h2>
<p>The first step we will do for this guide is to install the Riak KV packages on all of three CentOS servers, so run all commands in this stage on all servers.</p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;">

<div id='div-gpt-ad-1527185271042-6' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-6'); });
</script>
</div>
</div>
<p>We will install the Riak KV from the package cloud repository and will be using the Riak KV packages for the CentOS 7 server.</p>
<p>Add the repository by running the command below.</p>
<pre class="command"><code spellcheck="false">curl -s https://packagecloud.io/install/repositories/basho/riak/script.rpm.sh | sudo bash</code></pre>
<p>The command will download the riak repository and key to the system.</p>
<p>Now install the Riak KV package using the yum command below.</p>
<pre class="command"><code spellcheck="false">sudo yum install riak-2.2.3-1.el7.centos.x86_64</code></pre>
<p>Wait for the installations.</p>
<p style="text-align: center;"><a class="fancybox" id="img-1" href="https://www.howtoforge.com/images/how_to_setup_riak_kv_cluster_on_centos_7/big/1.png"><img src="https://www.howtoforge.com/images/how_to_setup_riak_kv_cluster_on_centos_7/1.png" alt="Install Riak KV on CentOS" width="500" height="255" /></a></p>
<h2 id="step-basic-configuration-riak-kv">Step 2 - Basic Configuration Riak KV</h2>
<p>In this step, we will configure the Riak KV for our NoSQL cluster. Before configuring the Riak KV itself, we need to set up the open files limit on the Ubuntu system.</p>
<p>Edit the '/etc/security/limits.conf' file using <a href="https://www.howtoforge.com/vim-basics" target="_blank">vim editor</a>.</p>
<pre class="command"><code spellcheck="false">vim /etc/security/limits.conf</code></pre>
<p>Now paste configuration below to the end of the file.</p>
<pre>riak soft nofile 65536
riak hard nofile 200000</pre>
<p>Save and exit.</p>
<p>Now go to the '/etc/riak' directory, and edit the default configuration file 'riak.conf'.</p>
<pre class="command"><code spellcheck="false">cd /etc/riak/<br />vim riak.conf</code></pre>
<p>Change the default nodename '<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="36445f575d765a5955575a5e594542">[email&#160;protected]</a>' with '<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="3b49525a507b685e494d5e49726b">[email&#160;protected]</a>'.</p>
<pre><code spellcheck="false">nodename = <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="e99b808882a9d8d9c7d8c7d8c7d8d9">[email&#160;protected]</a></code></pre>
<p>Now uncomment those scheduler lines below.</p>
<pre>erlang.schedulers.force_wakeup_interval = 500
erlang.schedulers.compaction_of_load = false</pre>
<p>Uncomment the 'ring_size' line and leave it to default '64'.</p>
<pre><code spellcheck="false">ring_size = 64</code></pre>
<p>Change the HTTP listener and protocol buffers with the 'ServerIP'.</p>
<pre>listener.http.internal = 10.1.1.10:8098
listener.protobuf.internal = 10.1.11.10:8087</pre>
<p>Save and exit.</p>
<p>Now test riak configurations, then start the riak service.</p>
<pre class="command"><code spellcheck="false">riak chkconfig<br />riak start</code></pre>
<p>Anthe d following is the result.</p>
<p style="text-align: center;"><a class="fancybox" id="img-2" href="https://www.howtoforge.com/images/how_to_setup_riak_kv_cluster_on_centos_7/big/2.png"><img src="https://www.howtoforge.com/images/how_to_setup_riak_kv_cluster_on_centos_7/2.png" alt="Adjust security limits" width="500" height="147" /></a></p>
<p>Next, we will test our riak service configuration by running commands below.</p>
<pre class="command"><code spellcheck="false">riak ping<br />curl -v http://10.1.1.10:8098/types/default/props</code></pre>
<p>Make sure you get the 'pong' result from the 'riak ping' command and get the HTTP status code '200' from the curl command.</p>
<p style="text-align: center;"><a class="fancybox" id="img-3" href="https://www.howtoforge.com/images/how_to_setup_riak_kv_cluster_on_centos_7/big/3.png"><img src="https://www.howtoforge.com/images/how_to_setup_riak_kv_cluster_on_centos_7/3.png" alt="Use riak ping to test the server" width="500" height="279" /></a></p>
<p>Basic configurations of Riak KV distributed NoSQL has been completed, and we're ready to set up the Riak KV Cluster.</p>
<p><strong>Note:</strong></p>
<ul>
<li>Run all commands on this stage on all server nodes.</li>
</ul>
<h2 id="step-setup-riak-kv-cluster">Step 3 - Setup Riak KV Cluster</h2>
<p>In this step, we will set up the cluster by joining the 'riak02' and 'riak03' nodes to the first node.</p>
<p><strong>- Second Node</strong></p>
<p>On the 'riak02' node, run the riak-admin below.</p>
<pre class="command"><code spellcheck="false">riak-admin cluster join <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="6f1d060e042f5e5f415e415e415e5f">[email&#160;protected]</a></code></pre>
<p style="text-align: center;"><a class="fancybox" id="img-4" href="https://www.howtoforge.com/images/how_to_setup_riak_kv_cluster_on_centos_7/big/4.png"><img src="https://www.howtoforge.com/images/how_to_setup_riak_kv_cluster_on_centos_7/4.png" alt="join cluster" width="500" height="101" /></a></p>
<p>Now back to the 'riak01' node, run riak-admin commands below.</p>
<pre class="command"><code spellcheck="false">riak-admin cluster plan<br />riak-admin cluster commit</code></pre>
<p>And the 'riak02' node has been added to the cluster, check it using the command below.</p>
<pre class="command"><code spellcheck="false">riak-admin cluster status</code></pre>
<p style="text-align: center;"><a class="fancybox" id="img-5" href="https://www.howtoforge.com/images/how_to_setup_riak_kv_cluster_on_centos_7/big/5.png"><img src="https://www.howtoforge.com/images/how_to_setup_riak_kv_cluster_on_centos_7/5.png" alt="Check the cluster status" width="474" height="550" /></a></p>
<p><strong>- Third Node</strong></p>
<p>On the 'riak03' node, run the riak-admin command below.</p>
<pre class="command"><code spellcheck="false">riak-admin cluster join <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="addfc4ccc6ed9c9d839c839c839c9d">[email&#160;protected]</a></code></pre>
<p style="text-align: center;"><a class="fancybox" id="img-6" href="https://www.howtoforge.com/images/how_to_setup_riak_kv_cluster_on_centos_7/big/6.png"><img src="https://www.howtoforge.com/images/how_to_setup_riak_kv_cluster_on_centos_7/6.png" alt="Add a third node" width="500" height="105" /></a></p>
<p>Now back to the 'riak01' node, run riak-admin commands below.</p>
<pre class="command"><code spellcheck="false">riak-admin cluster plan<br />riak-admin cluster commit</code></pre>
<p>All server node 'riak02' and 'riak03' has been added to the cluster, check again using the command below.</p>
<pre class="command"><code spellcheck="false">riak-admin cluster status</code></pre>
<p style="text-align: center;"><a class="fancybox" id="img-7" href="https://www.howtoforge.com/images/how_to_setup_riak_kv_cluster_on_centos_7/big/7.png"><img src="https://www.howtoforge.com/images/how_to_setup_riak_kv_cluster_on_centos_7/7.png" alt="Check cluster status after adding third node" width="477" height="550" /></a></p>
<p>The Riak KV cluster installation and configuration has been completed.</p>
<h2 id="step-testing">Step 4 - Testing</h2>
<p>The Riak KV NoSQL cluster has been created, now we want to test the cluster by uploading a data image to the cluster, and test to access from the other nodes to ensure data replication between all nodes.</p>
<p>On the 'riak01' server, download an image using the&nbsp;<a href="https://www.howtoforge.com/tutorial/linux-wget-command/" target="_blank">wget command</a> below.</p>
<pre class="command"><code spellcheck="false">cd ~/<br />wget https://vignette.wikia.nocookie.net/nichijou/images/a/a0/113407.jpg -O hakase.jpg</code></pre>
<p>Now upload the image to the Riak KV cluster using the <a href="https://www.howtoforge.com/linux-curl-command/" target="_blank">curl command</a>.</p>
<pre class="command"><code spellcheck="false">curl -XPUT http://10.1.1.10:8098/riak/images/hakase.jpg -H "Content-type: image/jpg" --data-binary @hakase.jpg</code></pre>
<p style="text-align: center;"><a class="fancybox" id="img-8" href="https://www.howtoforge.com/images/how_to_setup_riak_kv_cluster_on_centos_7/big/8.png"><img src="https://www.howtoforge.com/images/how_to_setup_riak_kv_cluster_on_centos_7/8.png" alt="Test Riak with curl" width="500" height="133" /></a></p>
<p>Open your web browser and type other nodes IP address, and you will get the same image.</p>
<p><strong>'riak02'.</strong></p>
<p>http://10.1.1.11:8098/riak/images/hakase.jpg</p>
<p style="text-align: center;"><a class="fancybox" id="img-9" href="https://www.howtoforge.com/images/how_to_setup_riak_kv_cluster_on_centos_7/big/9.png"><img src="https://www.howtoforge.com/images/how_to_setup_riak_kv_cluster_on_centos_7/9.png" alt="Test node 2" width="500" height="210" /></a></p>
<p><strong>'riak03'.</strong></p>
<p>http://10.1.1.12:8098/riak/images/hakase.jpg</p>
<p style="text-align: center;"><a class="fancybox" id="img-10" href="https://www.howtoforge.com/images/how_to_setup_riak_kv_cluster_on_centos_7/big/10.png"><img src="https://www.howtoforge.com/images/how_to_setup_riak_kv_cluster_on_centos_7/10.png" alt="test node 3" width="500" height="212" /></a></p>
<p>If you want to delete the image data, use the curl command below.</p>
<pre class="command"><code spellcheck="false">curl -XDELETE 'http://10.1.1.10:8098/riak/images/hakase.jpg'</code></pre>
<p>The Riak KV Cluster installation and configuration on CentOS 7 has been completed successfully.</p>
<h2 id="reference">Reference</h2>
<ul>
<li><a href="http://docs.basho.com/riak/kv/2.2.3/">http://docs.basho.com/riak/kv/2.2.3/</a></li>
</ul>
</article>

<aside class="authorbox" style="margin-top:20px;">
<p><strong>About Muhammad Arul</strong></p>
<p>Muhammad Arul is a freelance system administrator and technical writer. He is working with Linux Environments for more than 5 years, an Open Source enthusiast and highly motivated on Linux installation and troubleshooting. Mostly working with RedHat/CentOS Linux and Ubuntu/Debian, Nginx and Apache web server, Proxmox, Zimbra Administration, and Website Optimization. Currently learning about OpenStack and Container Technology.</p>
</aside>

<div style="height:30px; margin-top:20px;">
<p style="text-align:right;"><img src="/images/pdficon_small.png" /> <a class="pdf-btn" href="javascript:void(0);">view as pdf</a> | <img src="/images/print.gif" /> <a class="print-btn" href="javascript:void(0);">print</a></p>
</div>
<div style="height:30px; margin-top:20px;">
<div style="float:left;"><b>Share this page:</b></div>
<p style="text-align:center;">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-setup-riak-kv-nosql-database-cluster-on-centos-7%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-setup-riak-kv-nosql-database-cluster-on-centos-7%2F&text=How+to+Setup+Riak+KV+NoSQL+Database+Cluster+on+CentOS+7&via=howtoforgecom&related=howtoforgecom" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-setup-riak-kv-nosql-database-cluster-on-centos-7%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-gplus.png" height="20" /></a>
</p>
</div>
</div>


<div id="htfContentPagePaging">
<h2>Suggested articles</h2>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-3043223216276099" data-ad-slot="8940054090"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>


<div id="htfContentPageComment">
<a name="comments"></a>
<h2>0 Comment(s)</h2>

<div id="commentform">
<div class="commentContainerHead" style="font-size:18px;">Add comment</div>
<div class="commentContainer">
<form method="post" action="/how-to-setup-riak-kv-nosql-database-cluster-on-centos-7/#comments">
<input type="hidden" name="reply_to" id="reply-to-comment" value="0" />
<div id="commentFormDetail">
<div style="width:48%; float:left; margin-right:3%">
<label for="commentname">Name *</label>
<input id="commentname" name="commentname" value="" />
</div>
<div style="width:48%;float:left;">
<label for="commentname">Email *</label>
<input id="commentemail" name="commentemail" value="" />
</div>
<div style="clear:both;"></div>
</div>
<textarea id="commentedit" name="commentedit" style="width:auto;"></textarea>
<div>
<div style="float:left;">
<div class="g-recaptcha" data-sitekey="6LdX9fUSAAAAALWwVoPdeXScMSketz4npF-0QcQ1"></div>
<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en">
      </script>
</div>
<div style="margin-top:10px;margin-bottom:10px;">
<input type="submit" name="submit" class="button primary" style="float:right;" value="Submit comment">
</div>
<div style="clear:both;"></div>
</div>
<script>
	tinymce.init({
		selector: "textarea#commentedit",
		theme: "modern",
		height: 100,
		apply_source_formatting : true,
		remove_linebreaks : false,
		menubar : false,
		/*auto_focus : "commentedit",*/
		plugins: [
		"link"
		],
		/*plugins: [
			"advlist autolink link image lists charmap print preview hr anchor pagebreak spellchecker",
			"searchreplace wordcount visualblocks visualchars code fullscreen insertdatetime media nonbreaking",
			"save table contextmenu directionality emoticons template paste textcolor"
		],*/
		content_css: "https://www.howtoforge.com/themes/howtoforge/css/custom.css",
		toolbar: "undo redo | bold italic link", 
		/*style_formats: [
			{title: 'Bold text', inline: 'b'},
			{title: 'Red text', inline: 'span', styles: {color: '#ff0000'}},
			{title: 'Red header', block: 'h1', styles: {color: '#ff0000'}},
			{title: 'Example 1', inline: 'span', classes: 'example1'},
			{title: 'Example 2', inline: 'span', classes: 'example2'},
			{title: 'Table styles'},
			{title: 'Table row 1', selector: 'tr', classes: 'tablerow1'}
		]*/
	}); 
	</script>
</form>
</div>
</div>

</div>

<div class="breadBoxBottom">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Home</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/how-to-setup-riak-kv-nosql-database-cluster-on-centos-7/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to Setup Riak KV NoSQL Database Cluster on CentOS 7</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
<script>
<!--

$(document).on('click', 'a.reply-to', function(e) {
	e.preventDefault();
	
	var self = $(this);
	var cid = self.attr('data-comment');
	console.log(cid);
	if(!cid) return this;
	
	$('#commentform').insertAfter('#comment' + cid);
	$('#reply-to-comment').val(cid);
	/*tinyMCE.activeEditor.focus();*/
	var textareaId = 'commentedit';
	tinyMCE.get(textareaId).remove();
	tinyMCE.execCommand("mceAddEditor", false, textareaId);
	tinyMCE.activeEditor.focus();
});
//-->
</script>
<div style="margin-top:10px;margin-bottom:10px;text-align:center;">

<center>


<div id='div-gpt-ad-1527185271042-1' style='height:90px; width:728px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-1'); });
</script>
</div>

</center>
</div>


<form action="/community/login/login?redirect=/how-to-setup-riak-kv-nosql-database-cluster-on-centos-7/" method="post" class="xenForm eAuth" id="login" style="display:none">
<ul id="eAuthUnit">
<li><a href="/community/register/facebook?reg=1" class="fbLogin" tabindex="110"><span>Log in with Facebook</span></a></li>
<li><a href="/community/register/twitter?reg=1" class="twitterLogin" tabindex="110"><span>Log in with Twitter</span></a></li>
<li><span class="googleLogin GoogleLogin JsOnly" tabindex="110" data-client-id="198773272284-b6tfk0c28bje81p774prrcrkq9jb3o44.apps.googleusercontent.com" data-redirect-url="/community/register/google?code=__CODE__&amp;csrf=hVMXbW_3rnrmq4Em"><span>Log in with Google</span></span></li>
</ul>
<div class="ctrlWrapper">
<dl class="ctrlUnit">
<dt><label for="LoginControl">Your name or email address:</label></dt>
<dd><input type="text" name="login" id="LoginControl" class="textCtrl" tabindex="101" /></dd>
</dl>
<dl class="ctrlUnit">
<dt>
<label for="ctrl_password">Do you already have an account?</label>
</dt>
<dd>
<ul>
<li><label for="ctrl_not_registered"><input type="radio" name="register" value="1" id="ctrl_not_registered" tabindex="105" />
No, create an account now.</label></li>
<li><label for="ctrl_registered"><input type="radio" name="register" value="0" id="ctrl_registered" tabindex="105" checked="checked" class="Disabler" />
Yes, my password is:</label></li>
<li id="ctrl_registered_Disabler">
<input type="password" name="password" class="textCtrl" id="ctrl_password" tabindex="102" />
<div class="lostPassword"><a href="/community/lost-password/" tabindex="106">Forgot your password?</a></div>
</li>
</ul>
</dd>
</dl>
<dl class="ctrlUnit submitUnit">
<dt></dt>
<dd>
<input type="submit" class="button primary" value="Log in" tabindex="104" data-loginPhrase="Log in" data-signupPhrase="Sign up" />
<label for="ctrl_remember" class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_remember" tabindex="103" /> Stay logged in</label>
</dd>
</dl>
</div>
<input type="hidden" name="cookie_check" value="1" />
<input type="hidden" name="redirect" value="/community/" />
<input type="hidden" name="_xfToken" value="" />
</form>

</div>
</div>

<aside>
<div class="sidebar">
<div class="section loginButton">
<div class="secondaryContent">
<label for="LoginControl" id="SignupButton"><a href="/community/login/" class="inner">Sign up now!</a></label>
</div>
</div>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-2">

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent socialMediaIcon">
<a href="https://twitter.com/howtoforgecom" target="_blank"><img src="/images/socialmedia/64x64/twitter.png" /></a>
<a href="https://www.facebook.com/howtoforge" target="_blank"><img src="/images/socialmedia/64x64/facebook.png" /></a>
<a href="https://plus.google.com/+howtoforge/posts" target="_blank"><img src="/images/socialmedia/64x64/googleplus.png" /></a>
<a href="https://www.howtoforge.com/feed" target="_blank"><img src="/images/socialmedia/64x64/rss.png" /></a>
</div>
</div>
</div>
<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Tutorial Info</p>
<div class="pairsJustified">
<dl class="discussionCount">
<dt>Author:</dt>
<dd><a href="/author/muhammad+arul/" rel="author">Muhammad Arul</a></dd>
</dl>
<dl class="discussionCount">
<dt>Published:</dt>
<dd>Dec 18, 2018</dd>
</dl>
<dl class="discussionCount">
<dt>Tags:</dt>
<dd><a href='/tutorials/centos/' rel='tag'>centos</a>, <a href='/tutorials/linux/' rel='tag'>linux</a></dd>
</dl>
</div>
</div>
</div>
<script src="//m.servedby-buysellads.com/monetization.js" type="text/javascript"></script>
<div class="native-sidebar"></div>
<script>
  (function(){
    if(typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('default', 'CKYD55QU', 'placement:howtoforge', {
      target: '.native-sidebar',
      align: 'horizontal',
      disable_css: 'true'
    });
      }
  })();
</script>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent">
<p class="mnuinfo mnushare">Share This Page</p>
<p style="text-align:center;">
<a href="javascript:window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-setup-riak-kv-nosql-database-cluster-on-centos-7%2F', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="javascript:window.open('https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-setup-riak-kv-nosql-database-cluster-on-centos-7%2F&text=How+to+Setup+Riak+KV+NoSQL+Database+Cluster+on+CentOS+7&via=howtoforgecom&related=howtoforgecom', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="javascript:window.open('https://plus.google.com/share?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-setup-riak-kv-nosql-database-cluster-on-centos-7%2F', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-gplus.png" height="20" /></a>
</p>
<p style="color:#EE; font-weight:bold; text-align:center; margin-top:5px;">40.2k Followers</p>
</div>
</div>
</div>


<script type="text/javascript">
    google_ad_client = "ca-pub-3043223216276099";
    google_ad_slot = "6709042890";
    google_ad_width = 300;
    google_ad_height = 600;
</script>

<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>


<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Popular Tutorials</p>
<div class="pairsJustified">
<ul>
<li><a href="/how-to-install-anchor-cms-on-centos-7/">How to Install Anchor CMS on CentOS 7</a></li>
<li><hr /></li>
<li><a href="/reverse-ssh-tunneling">Reverse SSH Tunneling</a></li>
<li><hr /></li>
<li><a href="/linux-c-programming-introduction/">C Programming Language - Introduction</a></li>
<li><hr /></li>
<li><a href="/how-to-install-invoiceplane-on-centos-7/">How to Install InvoicePlane with Nginx on CentOS 7</a></li>
<li><hr /></li>
<li><a href="/tutorial/linux-grep-command/">How to use grep to search for strings in files on the shell</a></li>
<li><hr /></li>
<li><a href="/linux-type-command/">Linux type Command Tutorial for Beginners (with Examples)</a></li>
<li><hr /></li>
<li><a href="/tutorial/install-wordpress-5-with-apache-on-debian-9/">Install WordPress 5 with Apache on Debian 9</a></li>
<li><hr /></li>
<li><a href="/how-to-install-pagekit-cms-on-ubuntu-1804/">How to Install PageKit CMS on Ubuntu 18.04 LTS</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-use-ftp-on-the-linux-shell/">How to use the Linux ftp command to up- and download files on the shell</a></li>
<li><hr /></li>
<li><a href="/tutorial/perfect-server-ubuntu-18.04-with-apache-php-myqsl-pureftpd-bind-postfix-doveot-and-ispconfig/">The Perfect Server - Ubuntu 18.04 (Bionic Beaver) with Apache, PHP, MySQL, PureFTPD, BIND, Postfix, Dovecot and ISPConfig 3.1</a></li>
<li><hr /></li>
</ul>
</div>
</div>
</div>
</div>
</div>
</aside>
</div>
</div>
</div>
<footer>
<div class="footer">
<div class="pageWidth">
<div class="pageContent">
<div class='skin_branding'><span>Xenforo skin by <a href="http://www.xenfocus.com" rel="nofollow">Xenfocus</a></span></div>
<ul class="footerLinks">
<li><a href="/contribute/">Contribute</a></li>
<li><a href="/community/misc/contact">Contact</a></li>
<li><a href="/community/help/">Help</a></li>
<li><a href="/imprint/">Imprint and Legal Notice</a></li>
<li><a href="#navigation" class="topLink">Top</a></li>
<li><a href="/feed" rel="alternate" class="globalFeed" target="_blank" title="RSS-Feed for Howtoforge">RSS-Feed</a></li>
</ul>
<span class="helper"></span>
</div>
</div>
</div>
<div class="footerLegal">
<div class="pageWidth">
<div class="pageContent">
<ul id="legal">
<li><a href="/community/help/terms">Terms and Rules</a> <a href="https://www.howtoforge.com/community/help/privacy-policy">Privacy Policy</a></li>
</ul>
<div id="copyright"><a href="https://www.howtoforge.com" class="concealed">Howtoforge <span>&copy; projektfarm GmbH.</span></a></div>
<span class="helper"></span>
</div>
</div>
</div>
</footer>
<div style="height:100px;"></div>

<div id="subscriptionModal" class="modal">
<div class="modal-content">
<span class="close">&times;</span>
<p>This feature is only available to subscribers. Get your subscription <a href="/subscription">here</a>.</p>
</div>
</div>
<script>
//* Modal
var modal = document.getElementById('subscriptionModal');
var span = document.getElementsByClassName("close")[0];
$(".pdf-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
$(".print-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
span.onclick = function() {
	$("#subscriptionModal").css('display', 'none');
}
window.onclick = function(event) {
    if (event.target == modal) {
		$("#subscriptionModal").css('display', 'none');
    }
}
//* Xenforo
jQuery.extend(true, XenForo,
{
	visitor: { user_id: 0 },
	serverTimeInfo:
	{
		now: 1409831907,
		today: 1409781600,
		todayDow: 4
	},
	_lightBoxUniversal: "0",
	_enableOverlays: "1",
	_animationSpeedMultiplier: "1",
	_overlayConfig:
	{
		top: "10%",
		speed: 200,
		closeSpeed: 100,
		mask:
		{
			color: "rgb(0, 0, 0)",
			opacity: "0.6",
			loadSpeed: 200,
			closeSpeed: 100
		}
	},
	_ignoredUsers: [],
	_loadedScripts: {"node_list":true,"node_category":true,"node_forum":true,"sidebar_share_page":true,"wf_default":true,"bbm_buttons":true,"login_bar":true,"twitter":true},
	_cookieConfig: { path: "/", domain: "", prefix: "xf_"},
	_csrfToken: "",
	_csrfRefreshUrl: "/community/login/csrf-token-refresh",
	_jsVersion: "303ae0ca"
});
jQuery.extend(XenForo.phrases,
{
	cancel: "Cancel",

	a_moment_ago:    "A moment ago",
	one_minute_ago:  "1 minute ago",
	x_minutes_ago:   "%minutes% minutes ago",
	today_at_x:      "Today at %time%",
	yesterday_at_x:  "Yesterday at %time%",
	day_x_at_time_y: "%day% at %time%",

	day0: "Sunday",
	day1: "Monday",
	day2: "Tuesday",
	day3: "Wednesday",
	day4: "Thursday",
	day5: "Friday",
	day6: "Saturday",

	_months: "January,February,March,April,May,June,July,August,September,October,November,December",
	_daysShort: "Sun,Mon,Tue,Wed,Thu,Fri,Sat",

	following_error_occurred: "The following error occurred",
	server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
	logging_in: "Logging in",
	click_image_show_full_size_version: "Click this image to show the full-size version.",
	show_hidden_content_by_x: "Show hidden content by {names}"
});

// Facebook Javascript SDK
XenForo.Facebook.appId = "";
XenForo.Facebook.forceInit = true;

/*
document.addEventListener('DOMContentLoaded', function(event) {
  cookieChoices.showCookieConsentBar('Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.',
  'OK');
});
*/

$(document).ready(function() {
	$("a.fancybox").fancybox();
});

</script>

<script>
(function() {
  if (typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('fancybar', 'CKYDL27E', 'placement:howtoforgecom');
  }
})();
</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2155872-1', 'auto');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');

</script>
</body>
</html>