<!DOCTYPE html><html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs LoggedOut Sidebar Responsive" xmlns:fb="http://www.facebook.com/2008/fbml"><head><meta charset="utf-8" />
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>!function(){function e(i){return(e="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e})(i)}__ez.pel=function(){var i=[];function t(t,o,_,d,n,r,a,s){if(__ez.dot.isDefined(t)&&0!=__ez.dot.isAnyDefined(t.getSlotElementId,t.ElementId)){var p=parseInt(__ez.dot.getTargeting(t,"ap")),f=__ez.dot.getSlotIID(t),u=__ez.dot.getAdUnit(t,s),g=parseInt(__ez.dot.getTargeting(t,"compid")),c=0,l=0,z=function(i){if("undefined"==typeof _ezim_d)return!1;var t=__ez.dot.getAdUnitPath(i).split("/").pop();if("object"===("undefined"==typeof _ezim_d?"undefined":e(_ezim_d))&&_ezim_d.hasOwnProperty(t))return _ezim_d[t];for(var o in _ezim_d)if(o.split("/").pop()===t)return _ezim_d[o];return!1}(t);"object"==e(z)&&(void 0!==z.creative_id&&(l=z.creative_id),void 0!==z.line_item_id&&(c=z.line_item_id)),__ez.dot.isDefined(f,u)&&__ez.dot.isValid(o)&&i.push({type:"impression",impression_id:f,domain_id:__ez.dot.getDID(),unit:u,t_epoch:__ez.dot.getEpoch(0),revenue:_,est_revenue:d,ad_position:p,ad_size:"",bid_floor_filled:n,bid_floor_prev:r,stat_source_id:a,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:g,line_item_id:c,creative_id:l,data:__ez.dot.dataToStr(o),is_orig:s||__ez.template.isOrig})}}function o(){void 0!==document.visibilityState&&"prerender"===document.visibilityState||(__ez.dot.isDefined(i)&&i.length>0&&[i.filter((function(e){return e.is_orig})),i.filter((function(e){return!e.is_orig}))].forEach((function(e){for(;e.length>0;){var i=e[0].is_orig||!1,t=5;t>e.length&&(t=e.length);var o=e.splice(0,t),_=__ez.dot.getURL("/porpoiseant/army.gif")+"?orig="+(!0===i?1:0)+"&sts="+btoa(JSON.stringify(o));void 0!==window.isAmp&&isAmp&&void 0!==window._ezaq&&_ezaq.hasOwnProperty("domain_id")&&(_+="&visit_uuid="+_ezaq.visit_uuid),__ez.dot.Fire(_)}})),i=[])}return{Add:t,AddAndFire:function(e,i){t(e,i,0,0,0,0,0),o()},AddAndFireOrig:function(e,i){t(e,i,0,0,0,0,0,!0),o()},AddById:function(e,t,o){var _=e.split("/");if(__ez.dot.isDefined(e)&&3===_.length&&__ez.dot.isValid(t)){var d=_[0],n=_[2];i.push({type:"impression",impression_id:n,domain_id:__ez.dot.getDID(),unit:d,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(t),is_orig:o||__ez.template.isOrig})}},Fire:o,GetPixels:function(){return i}}}()}();__ez.queue.addFile('/detroitchicago/raleighz.js', '/detroitchicago/raleighz.js?gcb=195-2&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=195-2&cb=3', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=195-2&cb=5', false, [], true, false, true, false);</script>
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<base href="https://www.howtoforge.com" />
<script>
			var _b = document.getElementsByTagName('base')[0], _bH = "https://www.howtoforge.com/how-to-migrate-from-centos-8-to-rockylinux-8/";
			if (_b && _b.href != _bH) _b.href = _bH;
		</script>
<title>How to Migrate From CentOS 8 to RockyLinux 8.4</title>
<meta name="description" content="The end of 2021 is near, which means the EOL (end of life) of CentOS 8 is near too. In this guide, you will learn how to migrate from CentOS 8 to Rock... " />
<meta property="og:title" content="How to Migrate From CentOS 8 to RockyLinux 8.4" />
<meta property="og:description" content="The end of 2021 is near, which means the EOL (end of life) of CentOS 8 is near too. In this guide, you will learn how to migrate from CentOS 8 to Rock... " />
<meta property="og:site_name" content="HowtoForge" />
<meta property="og:type" content="article" />
<meta property="og:image" content="https://www.howtoforge.com/images/featured/centos-to-rocky-linux.jpg" />
<meta property="og:image:secure_url" content="https://www.howtoforge.com/images/featured/centos-to-rocky-linux.jpg" />
<meta property="og:image:alt" content="How to Migrate From CentOS 8 to RockyLinux 8.4" />
<meta name="twitter:image" content="https://www.howtoforge.com/images/featured/centos-to-rocky-linux.jpg" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@howtoforgecom" />
<meta name="twitter:creator" content="@howtoforgecom" />
<meta name="twitter:title" content="How to Migrate From CentOS 8 to RockyLinux 8.4" />
<meta name="twitter:description" content="The end of 2021 is near, which means the EOL (end of life) of CentOS 8 is near too. In this guide, you will learn how to migrate from CentOS 8 to Rock... " />
<link rel="alternate" href="https://www.howtoforge.com/how-to-migrate-from-centos-8-to-rockylinux-8/" hreflang="en" />
<link rel="canonical" href="https://www.howtoforge.com/how-to-migrate-from-centos-8-to-rockylinux-8/" />
<link rel="amphtml" href="https://www.howtoforge.com/how-to-migrate-from-centos-8-to-rockylinux-8/amp/" />
<script type="application/ld+json">
{
  "@context" : "http://schema.org",
  "@type" : "Article",
  "name" : "How to Migrate From CentOS 8 to RockyLinux 8.4",
  "author" : {
    "@type" : "Person",
    "name" : "Arvid L"
  },
  "articleSection" : "centos,linux",
  "url" : "https://www.howtoforge.com/how-to-migrate-from-centos-8-to-rockylinux-8/",
  "publisher" : {
    "@type" : "Organization",
    "name" : "Howtoforge"
  }
}
</script>
<noscript><style>.JsOnly, .jsOnly { display: none !important; }</style></noscript>
<link rel="stylesheet" href="/community/styles/executive/xenfocus/icons/css/font-awesome.min.css" />
<link href="//fonts.googleapis.com/css?family=Open+Sans:400,700" rel="stylesheet" type="text/css" />
<link href="/themes/howtoforge/templates/xf.css" rel="stylesheet" />
<script src="/js/jquery/jquery-1.11.3.min.js"></script>
<script src="/community/js/xenforo/xenforo.js?_v=303ae0ca"></script>
<script src="/community/js/bbm/zloader.js?_v=303ae0ca"></script>
<script type="text/javascript" src="/js/fancybox/jquery.mousewheel-3.0.4.pack.js"></script>
<script type="text/javascript" src="/js/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
<link rel="stylesheet" type="text/css" href="/js/fancybox/jquery.fancybox-1.3.4.css" media="screen" />
<link href="/themes/howtoforge/templates/style.min.css" rel="stylesheet" />
<link rel="alternate" type="application/rss+xml" title="RSS-Feed für Howtoforge" href="/feed.rss" />
<script src="/js/tinymce_4.1.7/tinymce.min.js"></script>
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/skin.min.css" as="style" />
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/content.min.css" as="style" />
<link rel="preload" href="/themes/howtoforge/css/custom.css" as="style" />
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/fonts/tinymce.woff" as="font" crossorigin="anonymous" />

<script type="text/javascript">
var gaProperty = 'UA-2155872-1';
var disableStr = 'ga-disable-' + gaProperty;
if (document.cookie.indexOf(disableStr + '=true') > -1) {
window[disableStr] = true;
}
function gaOptout() {
document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
window[disableStr] = true;
alert('Google Ananlyitics tracking has been disabled in this browser.');
}
</script>
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
	googletag.defineSlot('/1030080/howtoforge_com_list_sidebar_top', [300, 250], 'div-gpt-ad-1527185271042-4').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_list_content_middle', [[300, 250], [336, 280]], 'div-gpt-ad-1527185271042-5').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_a_300x250', [300, 250], 'div-gpt-ad-1527185271042-6').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_b_300x250', [300, 250], 'div-gpt-ad-1527185271042-7').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_leaderboard_b_728x90', [728, 90], 'div-gpt-ad-1527185271042-1').addService(googletag.pubads());
	googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-3043223216276099",
          enable_page_level_ads: true
     });
</script>


<script type="text/javascript" src="//m.servedby-buysellads.com/monetization.js"></script>

<script type="text/javascript">var ezouid = "1";</script><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script>
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 178704;
var ezdomain = 'howtoforge.com';
var ezoicSearchable = 1;
</script>


<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":178704,"domain_test_group":20210302,"engaged_time_visit":0,"ezcache_level":2,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"975de795-29e3-4b9e-7b5e-f41eae38ae99","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":46206,"response_time_orig":4,"serverid":"44.197.243.106:32297","state":"VA","t_epoch":1630046375,"template_id":126,"time_on_site_visit":0,"url":"https://www.howtoforge.com/how-to-migrate-from-centos-8-to-rockylinux-8/","user_id":0,"word_count":1374,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_178704=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["975de795-29e3-4b9e-7b5e-f41eae38ae99", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script><script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head>
<body>
<div id="loginBar">
<div class="pageWidth">
<div class="pageContent">
<h3 id="loginBarHandle">
<label for="LoginControl"><a href="/community/login/" class="concealed noOutline">Log in or Sign up</a></label>
</h3>
<span class="helper"></span>
</div>
</div>
</div>
<header>
<div id="header">
<div id="logoBlock">
<div class="pageWidth">
<div class="pageContent">
<div id="logo"><a href="/">
<span></span>
<img src="/images/howtoforge_logo_trans.gif" alt="Howtoforge" style="margin-left:20px;" />
</a></div>
<span class="helper"></span>
</div>
</div>
</div>
<div id="navigation" class="pageWidth withSearch">
<div class="pageContent">
<nav>
<div class="navTabs">
<ul class="publicTabs">

<li class="navTab forums selected">
<a href="/" class="navLink">Tutorials</a>
<div class="tabLinks forumsTabLinks">
<ul class="secondaryContent blockLinksList">
<li><a href="/search/">Tutorial search</a></li>
</ul>
</div>
</li>
<li class="navTab forums PopupClosed">
<a href="/tutorials/" class="navLink">Tags</a>
</li>
<li class="navTab forums PopupClosed"><a href="/community/" class="navLink">Forums</a></li>
<li class="navTab forums PopupClosed"><a href="/linux-commands/" class="navLink">Linux Commands</a></li>
<li class="navTab forums PopupClosed"><a href="/subscription/" class="navLink">Subscribe</a></li>
<li class="navTab forums PopupClosed"><a href="https://www.ispconfig.org" class="navLink">ISPConfig</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.lxer.com" class="navLink">News</a></li>
</ul>
</div>
<span class="helper"></span>
</nav>
</div>
</div>
<div id="searchBar" class="pageWidth">
<span id="QuickSearchPlaceholder" title=" Search..."> Search</span>
<fieldset id="QuickSearch">
<form action="/" method="post" class="formPopup">
<div class="primaryControls">

<input type="search" name="q" value="" class="textCtrl" placeholder="Search..." results="0" title="Enter your search and hit enter..." id="QuickSearchQuery" />

</div>
<input type="hidden" name="_xfToken" value="" />
</form>
</fieldset>
</div>
</div>
</header>
<div id="content" class="forum_list">
<div class="pageWidth">
<div class="pageContent">

<div class="mainContainer">
<div class="mainContent">

<div class="breadBoxTop">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://schema.org/BreadcrumbList">
<span itemprop="itemListElement" itemscope="" itemtype="http://schema.org/ListItem">
<a href="/" class="crumb" rel="up" itemprop="item"><span itemprop="name">Home</span></a>
<meta itemprop="position" content="1" />
</span>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://schema.org/BreadcrumbList">
<span itemprop="itemListElement" itemscope="" itemtype="http://schema.org/ListItem">
<a href="/how-to-migrate-from-centos-8-to-rockylinux-8/" class="crumb" rel="up" itemprop="item"><span itemprop="name">How to Migrate From CentOS 8 to RockyLinux 8.4</span></a>
<meta itemprop="position" content="2" />
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</span></fieldset>
</nav>
</div>

<div id="htfContentPage">
<div class="bsa-apiads"></div>
<article>
<h1>How to Migrate From CentOS 8 to RockyLinux 8.4</h1>
<div class="contributeEdit" style="float:right; width:450px; max-width:100%;">
<div id="tocContainer">
<h3>On this page</h3>
<ol class="toc">
<li><a href="#prerequisites">Prerequisites</a></li>
<li><a href="#upgrading-all-packages">Upgrading All Packages</a></li>
<li><a href="#installing-git">Installing Git</a></li>
<li><a href="#download-rocky-tools">Download Rocky Tools</a></li>
<li><a href="#migrating-centos-to-rocky-linux">Migrating CentOS 8 to Rocky Linux</a></li>
<li><a href="#verify-the-migration">Verify the Migration</a></li>
<li><a href="#conclusion">Conclusion</a></li>
</ol>
</div>
</div>
<p>The end of 2021 is near, which means the EOL (end of life) of CentOS 8 is near too. So there are no more updates and support for the CentOS 8 Linux, and it&#39;s huge disadvantages for everyone who using CentOS as the main operating system in the development and production environment. On contrary, there is a new Linux distro replacement for CentOS 8, one of them is called &#34;<strong>Rocky Linux</strong>&#34;.</p>
<p>In case you are CentOS 8 user and want to migrate to Rocky Linux, you don&#39;t need to rebuild and reinstall your server/server. Because the Rocky Linux project provides a handy migration tool for anyone who wants to migrate from CentOS 8 to Rocky Linux. This tool is a life-saver for anyone who wants to migrate their development or production environment to Rocky Linux.</p>
<p>In this guide, you will learn how to migrate from CentOS 8 to Rocky Linux 8.4 using the migration tool provided by the Rocky Linux project.</p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;">

<div id="div-gpt-ad-1527185271042-6" style="height:250px; width:300px;">
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-6'); });
</script>
</div>
</div>
<p>Note before migration: Back up all application data on your server, take an image snapshot of your CentOS 8 server to prevent data loss, and move the snapshot to a safe place.</p>
<h2 id="prerequisites">Prerequisites</h2>
<ul>
<li>A root user or user with sudo privileges. The Rocky Linux migration script must be run as root user.</li>
</ul>
<p>Below is the screen of our CentOS 8 server before migrating to Rocky Linux.</p>
<p><a class="fancybox" id="img-1-before-upgrade" href="https://www.howtoforge.com/images/how_to_migrate_from_centos_8_to_rockylinux_84/big/1-before-upgrade.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_migrate_from_centos_8_to_rockylinux_84/1-before-upgrade.png" alt="Before migrating to Rocky Linux" width="725" height="291" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Run the following command to check your CentOS system.</p>
<pre class="command">hostnamectl</pre>
<p>You will get similar output to the screenshot on top.</p>
<h2 id="upgrading-all-packages">Upgrading All Packages</h2>
<p>First, you need to upgrade all packages on your CentOS 8 system, then reboot the server server.</p>
<p>1. Execute the following command to upgrade all packages to the latest version.</p>
<pre class="command">sudo dnf upgrade</pre>
<p>Now type &#34;<strong>y</strong>&#34; to confirm the upgrade of packages and wait, it will take time depends on your internet connection.</p>
<p><a class="fancybox" id="img-2-upgrade-centos-packages" href="https://www.howtoforge.com/images/how_to_migrate_from_centos_8_to_rockylinux_84/big/2-upgrade-centos-packages.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_migrate_from_centos_8_to_rockylinux_84/2-upgrade-centos-packages.png" alt="Upgrade all CentOS packages" width="750" height="280" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>2. After that, reboot the server to apply all changes to the system using the following command.</p>
<pre class="command">sudo reboot</pre>
<p>Once the server is up, log in again to your server, then you can continue to the next stage.</p>
<h2 id="installing-git">Installing Git</h2>
<p>1. Execute the command below to install git on your system.</p>
<pre class="command">sudo dnf install git</pre>
<p>Type <strong>&#34;y&#34;</strong> to confirm the installation.</p>
<p><a class="fancybox" id="img-3-install-git" href="https://www.howtoforge.com/images/how_to_migrate_from_centos_8_to_rockylinux_84/big/3-install-git.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_migrate_from_centos_8_to_rockylinux_84/3-install-git.png" alt="Install Git on CentOS" width="750" height="232" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Now go to the next stage to continue.</p>
<h2 id="download-rocky-tools">Download Rocky Tools</h2>
<p>1. Clone the repository &#34;<strong>rocky-tools</strong>&#34; to your root home directory using the git command below.</p>
<pre class="command">git clone https://github.com/rocky-linux/rocky-tools.git</pre>
<p>Inside the &#34;<strong>rocky-tools</strong>&#34; directory you will see two tools, the &#34;<strong>migrate2rocky</strong>&#34; directory contain the migration tool for Rock Linux, and the &#34;<strong>mirror</strong>&#34; directory contains the tool for keeping a public and private mirror of Rocky Linux to sync.</p>
<p>2. Change the working directory to &#34;<strong>~/rocky-tools/migrate2rocky</strong>&#34; and run the &#34;<strong>ls</strong>&#34; command as below.</p>
<pre class="command">cd rocky-tools/migrate2rocky; ls -lah</pre>
<p>Now you will see the bash script for the Rocky Linux migration &#34;<strong>migrate2rocky.sh&#34;</strong>.</p>
<p><a class="fancybox" id="img-4-download-migration-script" href="https://www.howtoforge.com/images/how_to_migrate_from_centos_8_to_rockylinux_84/big/4-download-migration-script.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_migrate_from_centos_8_to_rockylinux_84/4-download-migration-script.png" alt="Download Rocky Linux migration script" width="750" height="330" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>3. Next, Make the script executable by changing the permission of the file using the following chmod command.</p>
<pre class="command">chmod +x migrate2rocky.sh</pre>
<p>4. Now execute script &#34;<strong>migrate2rocky.sh</strong>&#34; as below to show help and all available options.</p>
<pre class="command">./migrate2rocky.sh -h</pre>
<p>You will get similar output as below, and you are ready to go for migrating your CentOS 8 system to Rocky Linux.</p>
<pre>Usage: migrate2rocky.sh [OPTIONS]<br /><br />Options:<br />-h Display this help<br />-r Convert to rocky<br />-V Verify switch<br />   !! USE WITH CAUTION !!</pre>
<p><a class="fancybox" id="img-5-migrate2rocky-help-options" href="https://www.howtoforge.com/images/how_to_migrate_from_centos_8_to_rockylinux_84/big/5-migrate2rocky-help-options.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_migrate_from_centos_8_to_rockylinux_84/5-migrate2rocky-help-options.png" alt="Make Rocky Linux migration script executable and the help of the script" width="750" height="286" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<h2 id="migrating-centos-to-rocky-linux">Migrating CentOS 8 to Rocky Linux</h2>
<p>1. Start the migration from CentOS 8 to Rocky Linux by executing the script as below.</p>
<pre class="command">./migrate2rocky.sh -r</pre>
<p>2. At first, the script will check all main repositories (AppStream, BaseOS, and Extras) for CentOS 8 and remap to the Rocky Linux 8.</p>
<pre>Removing dnf cache<br />Preparing to migrate CentOS Linux 8 to Rocky Linux 8.<br /><br />Determining repository names for CentOS Linux 8.....<br /><br />Found the following repositories which map from CentOS Linux 8 to Rocky Linux 8:<br />CentOS Linux 8  Rocky Linux 8<br />appstream       appstream<br />baseos          baseos<br />extras          extras</pre>
<p><a class="fancybox" id="img-6-change-repository-to-rocky-linux" href="https://www.howtoforge.com/images/how_to_migrate_from_centos_8_to_rockylinux_84/big/6-change-repository-to-rocky-linux.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_migrate_from_centos_8_to_rockylinux_84/6-change-repository-to-rocky-linux.png" alt="Change main repository from CentOS to Rocky Linux" width="750" height="240" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>3. After that, the script will replace all packages related to CentOS with new packages for Rocky Linux. Also, it will remove unnecessary packages and install new additional packages.</p>
<pre>Getting system package names for CentOS Linux 8..........<br /><br />Found the following system packages which map from CentOS Linux 8 to Rocky Linux 8:<br />CentOS Linux 8        Rocky Linux 8<br />centos-logos-ipa      rocky-logos-ipa<br />centos-backgrounds    rocky-backgrounds<br />centos-gpg-keys       rocky-gpg-keys<br />centos-logos          rocky-logos<br />centos-indexhtml      rocky-indexhtml<br />centos-linux-release  rocky-release<br />centos-logos-httpd    rocky-logos-httpd<br />centos-linux-repos    rocky-repos<br /><br />Getting list of installed system packages.<br /><br />We will replace the following CentOS Linux 8 packages with their Rocky Linux 8 equivalents<br />Packages to be Removed  Packages to be Installed<br />centos-gpg-keys         rocky-gpg-keys<br />centos-linux-release    rocky-release<br />centos-linux-repos      rocky-repos<br /><br />Getting a list of enabled modules for the system repositories.<br /><br />In addition to the above the following system packages will be removed:<br />centos-linux-release<br />centos-linux-release<br /><br />Excluding modules:<br />libselinux-python:2.8<br /><br />Found the following modules to re-enable at completion:<br />perl:5.26<br />perl-IO-Socket-SSL:2.066<br />perl-libwww-perl:6.34</pre>
<p><a class="fancybox" id="img-7-replace-packages-with-rocky-linux-packages" href="https://www.howtoforge.com/images/how_to_migrate_from_centos_8_to_rockylinux_84/big/7-replace-packages-with-rocky-linux-packages.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_migrate_from_centos_8_to_rockylinux_84/7-replace-packages-with-rocky-linux-packages.png" alt="Replace all packages with Rocky Linux packages version" width="750" height="528" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>The installation of packages during the migration process will take time, so make sure you have a good internet connection.</p>
<p>4. When the migration process is successful, you will get similar output as below.</p>
<pre>...<br />Complete!<br />Done, please reboot your system.</pre>
<p>5. Next, execute the following command to make sure all installed packages are matched to the latest version available from any enabled repository on the system.</p>
<pre class="command">sudo dnf distro-sync -y</pre>
<p>6. After that, reboot the system to apply all changes to the system using the following command.</p>
<pre class="command">sudo reboot</pre>
<p><a class="fancybox" id="img-8-rocky-linux-migration-script-complete" href="https://www.howtoforge.com/images/how_to_migrate_from_centos_8_to_rockylinux_84/big/8-rocky-linux-migration-script-complete.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_migrate_from_centos_8_to_rockylinux_84/8-rocky-linux-migration-script-complete.png" alt="Rocky Linux migration completed" width="750" height="159" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>7. Now during the boot process, you will see the grub window with Rocky Linux available on the top menu.</p>
<p><a class="fancybox" id="img-9-rocky-linux-grub" href="https://www.howtoforge.com/images/how_to_migrate_from_centos_8_to_rockylinux_84/big/9-rocky-linux-grub.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_migrate_from_centos_8_to_rockylinux_84/9-rocky-linux-grub.png" alt="Rocky Linux Grub after migration" width="720" height="400" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Select &#34;<strong>Rocky Linux (4xxxx) 8.4 (Green Obsidian)</strong>&#34; and press &#34;<strong>Enter</strong>&#34; to boot to the new system.</p>
<h2 id="verify-the-migration">Verify the Migration</h2>
<p>1. Log in to the new system and run the following command to verify the migration result.</p>
<pre class="command">hostnamectl</pre>
<p>Upon the successful migration, you will see similar output as below.</p>
<pre>   Static hostname: server1<br />         Icon name: computer-vm<br />           Chassis: vm<br />        Machine ID: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx<br />           Boot ID: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx<br />    Virtualization: oracle<br />  Operating System: Rocky Linux 8.4 (Green Obsidian)<br />       CPE OS Name: cpe:/o:rocky:rocky:8.4:GA<br />            Kernel: Linux 4.18.0-305.10.2.el8_4.x86_64<br />      Architecture: x86-64</pre>
<p><a class="fancybox" id="img-10-verify-rocky-linux-migration-complete" href="https://www.howtoforge.com/images/how_to_migrate_from_centos_8_to_rockylinux_84/big/10-verify-rocky-linux-migration-complete.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_migrate_from_centos_8_to_rockylinux_84/10-verify-rocky-linux-migration-complete.png" alt="Successful migration from CentOS 8 to Rocky Linux 8.4" width="725" height="312" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>2. Also, you can show the os-release on the system.</p>
<pre class="command">cat /etc/os-release</pre>
<p>And you will get the following output.</p>
<pre>NAME=&#34;Rocky Linux&#34;<br />VERSION=&#34;8.4 (Green Obsidian)&#34;<br />ID=&#34;rocky&#34;<br />ID_LIKE=&#34;rhel fedora&#34;<br />VERSION_ID=&#34;8.4&#34;<br />PLATFORM_ID=&#34;platform:el8&#34;<br />PRETTY_NAME=&#34;Rocky Linux 8.4 (Green Obsidian)&#34;<br />ANSI_COLOR=&#34;0;32&#34;<br />CPE_NAME=&#34;cpe:/o:rocky:rocky:8.4:GA&#34;<br />HOME_URL=&#34;https://rockylinux.org/&#34;<br />BUG_REPORT_URL=&#34;https://bugs.rockylinux.org/&#34;<br />ROCKY_SUPPORT_PRODUCT=&#34;Rocky Linux&#34;<br />ROCKY_SUPPORT_PRODUCT_VERSION=&#34;8&#34;</pre>
<h2 id="conclusion">Conclusion</h2>
<p>Congratulation! you&#39;ve successfully migrated the CentOS 8 to Rocky Linux 8.4. The migration process is smooth without any error, and the system is up and running as a Rocky Linux. And now you are ready to start all your services and applications.</p>
</article>
<div style="height:30px; margin-top:20px;">
<p style="text-align:right;"><img src="/images/pdficon_small.png" /> <a class="pdf-btn" href="javascript:void(0);">view as pdf</a> | <img src="/images/print.gif" /> <a class="print-btn" href="javascript:void(0);">print</a></p>
</div>
<div style="height:30px; margin-top:20px;">
<div style="float:left;"><b>Share this page:</b></div>
<p style="text-align:center;">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-migrate-from-centos-8-to-rockylinux-8%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-migrate-from-centos-8-to-rockylinux-8%2F&amp;text=How+to+Migrate+From+CentOS+8+to+RockyLinux+8.4&amp;via=howtoforgecom&amp;related=howtoforgecom" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-migrate-from-centos-8-to-rockylinux-8%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-gplus.png" height="20" /></a>
</p>
</div>
</div>


<div id="htfContentPagePaging">
<h2>Suggested articles</h2>
<script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-3043223216276099" data-ad-slot="8940054090"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>


<div id="htfContentPageComment">
<a name="comments"></a>
<h2>0 Comment(s)</h2>

<div id="commentform">
<div class="commentContainerHead" style="font-size:18px;">Add comment</div>
<div class="commentContainer">
<form method="post" action="/how-to-migrate-from-centos-8-to-rockylinux-8/#comments">
<input type="hidden" name="reply_to" id="reply-to-comment" value="0" />
<div id="commentFormDetail">
<div style="width:48%; float:left; margin-right:3%">
<label for="commentname">Name *</label>
<input id="commentname" name="commentname" value="" />
</div>
<div style="width:48%;float:left;">
<label for="commentname">Email *</label>
<input id="commentemail" name="commentemail" value="" />
</div>
<div style="clear:both;"></div>
</div>
<textarea id="commentedit" name="commentedit" style="width:auto;"></textarea>
<div>
<div style="float:left;">
<div class="g-recaptcha" data-sitekey="6LdX9fUSAAAAALWwVoPdeXScMSketz4npF-0QcQ1"></div>
<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en">
      </script>
</div>
<div style="margin-top:10px;margin-bottom:10px;">
<input type="submit" name="submit" class="button primary" style="float:right;" value="Submit comment" />
</div>
<div style="clear:both;"></div>
</div>
<script>
	tinymce.init({
		selector: "textarea#commentedit",
		theme: "modern",
		height: 100,
		apply_source_formatting : true,
		remove_linebreaks : false,
		menubar : false,
		/*auto_focus : "commentedit",*/
		plugins: [
		"link"
		],
		/*plugins: [
			"advlist autolink link image lists charmap print preview hr anchor pagebreak spellchecker",
			"searchreplace wordcount visualblocks visualchars code fullscreen insertdatetime media nonbreaking",
			"save table contextmenu directionality emoticons template paste textcolor"
		],*/
		content_css: "https://www.howtoforge.com/themes/howtoforge/css/custom.css",
		toolbar: "undo redo | bold italic link", 
		/*style_formats: [
			{title: 'Bold text', inline: 'b'},
			{title: 'Red text', inline: 'span', styles: {color: '#ff0000'}},
			{title: 'Red header', block: 'h1', styles: {color: '#ff0000'}},
			{title: 'Example 1', inline: 'span', classes: 'example1'},
			{title: 'Example 2', inline: 'span', classes: 'example2'},
			{title: 'Table styles'},
			{title: 'Table row 1', selector: 'tr', classes: 'tablerow1'}
		]*/
	}); 
	</script>
</form>
</div>
</div>

</div>

<div class="breadBoxBottom">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Home</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/how-to-migrate-from-centos-8-to-rockylinux-8/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to Migrate From CentOS 8 to RockyLinux 8.4</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
<script>
<!--

$(document).on('click', 'a.reply-to', function(e) {
	e.preventDefault();
	
	var self = $(this);
	var cid = self.attr('data-comment');
	console.log(cid);
	if(!cid) return this;
	
	$('#commentform').insertAfter('#comment' + cid);
	$('#reply-to-comment').val(cid);
	/*tinyMCE.activeEditor.focus();*/
	var textareaId = 'commentedit';
	tinyMCE.get(textareaId).remove();
	tinyMCE.execCommand("mceAddEditor", false, textareaId);
	tinyMCE.activeEditor.focus();
});
//-->
</script>
<div style="margin-top:10px;margin-bottom:10px;text-align:center;">

<center>


<div id="div-gpt-ad-1527185271042-1" style="height:90px; width:728px;">
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-1'); });
</script>
</div>

</center>
</div>


<form action="/community/login/login?redirect=/how-to-migrate-from-centos-8-to-rockylinux-8/" method="post" class="xenForm eAuth" id="login" style="display:none">
<ul id="eAuthUnit">
<li><a href="/community/register/facebook?reg=1" class="fbLogin" tabindex="110"><span>Log in with Facebook</span></a></li>
<li><a href="/community/register/twitter?reg=1" class="twitterLogin" tabindex="110"><span>Log in with Twitter</span></a></li>
<li><span class="googleLogin GoogleLogin JsOnly" tabindex="110" data-client-id="198773272284-b6tfk0c28bje81p774prrcrkq9jb3o44.apps.googleusercontent.com" data-redirect-url="/community/register/google?code=__CODE__&amp;csrf=hVMXbW_3rnrmq4Em"><span>Log in with Google</span></span></li>
</ul>
<div class="ctrlWrapper">
<dl class="ctrlUnit">
<dt><label for="LoginControl">Your name or email address:</label></dt>
<dd><input type="text" name="login" id="LoginControl" class="textCtrl" tabindex="101" /></dd>
</dl>
<dl class="ctrlUnit">
<dt>
<label for="ctrl_password">Do you already have an account?</label>
</dt>
<dd>
<ul>
<li><label for="ctrl_not_registered"><input type="radio" name="register" value="1" id="ctrl_not_registered" tabindex="105" />
No, create an account now.</label></li>
<li><label for="ctrl_registered"><input type="radio" name="register" value="0" id="ctrl_registered" tabindex="105" checked="checked" class="Disabler" />
Yes, my password is:</label></li>
<li id="ctrl_registered_Disabler">
<input type="password" name="password" class="textCtrl" id="ctrl_password" tabindex="102" />
<div class="lostPassword"><a href="/community/lost-password/" tabindex="106">Forgot your password?</a></div>
</li>
</ul>
</dd>
</dl>
<dl class="ctrlUnit submitUnit">
<dt></dt>
<dd>
<input type="submit" class="button primary" value="Log in" tabindex="104" data-loginphrase="Log in" data-signupphrase="Sign up" />
<label for="ctrl_remember" class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_remember" tabindex="103" /> Stay logged in</label>
</dd>
</dl>
</div>
<input type="hidden" name="cookie_check" value="1" />
<input type="hidden" name="redirect" value="/community/" />
<input type="hidden" name="_xfToken" value="" />
</form>

</div>
</div>

<aside>
<div class="sidebar">
<div class="section loginButton">
<div class="secondaryContent">
<label for="LoginControl" id="SignupButton"><a href="/community/login/" class="inner">Sign up now!</a></label>
</div>
</div>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-2">

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent socialMediaIcon">
<a href="https://twitter.com/howtoforgecom" target="_blank"><img src="/images/socialmedia/64x64/twitter.png" /></a>
<a href="https://www.facebook.com/howtoforge" target="_blank"><img src="/images/socialmedia/64x64/facebook.png" /></a>
<a href="https://news.ycombinator.com/" target="_blank" rel="nofollow"><img src="/images/socialmedia/64x64/hackernews.png" /></a>
<a href="https://www.howtoforge.com/feed" target="_blank"><img src="/images/socialmedia/64x64/rss.png" /></a>
</div>
</div>
</div>
<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Tutorial Info</p>
<div class="pairsJustified">
<dl class="discussionCount">
<dt>Author:</dt>
<dd><a href="/author/arvid+l/" rel="author">Arvid L</a></dd>
</dl>
<dl class="discussionCount">
<dt>Published:</dt>
<dd>Aug 26, 2021</dd>
</dl>
<dl class="discussionCount">
<dt>Tags:</dt>
<dd><a href="/tutorials/centos/" rel="tag">centos</a>, <a href="/tutorials/linux/" rel="tag">linux</a></dd>
</dl>
</div>
</div>
</div>

<div id="sponsor-banner">
</div>

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent">
<p class="mnuinfo mnushare">Share This Page</p>
<p style="text-align:center;">
<a href="javascript:window.open(&#39;https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-migrate-from-centos-8-to-rockylinux-8%2F&#39;, &#39;_blank&#39;, &#39;status=1,height=500,width=360,resizable=0&#39;);void(0);"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="javascript:window.open(&#39;https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-migrate-from-centos-8-to-rockylinux-8%2F&amp;text=How+to+Migrate+From+CentOS+8+to+RockyLinux+8.4&amp;via=howtoforgecom&amp;related=howtoforgecom&#39;, &#39;_blank&#39;, &#39;status=1,height=500,width=360,resizable=0&#39;);void(0);"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="javascript:window.open(&#39;https://news.ycombinator.com/submitlink?t=How+to+Migrate+From+CentOS+8+to+RockyLinux+8.4&amp;u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-migrate-from-centos-8-to-rockylinux-8%2F&#39;, &#39;_blank&#39;, &#39;status=1,height=500,width=360,resizable=0&#39;);void(0);"><img src="/images/socialmedia/btn-hackernews.png" height="20" /></a>
</p>
<p style="color:#EE; font-weight:bold; text-align:center; margin-top:5px;">40.2k Followers</p>
</div>
</div>
</div>


<script type="text/javascript">
    google_ad_client = "ca-pub-3043223216276099";
    google_ad_slot = "6709042890";
    google_ad_width = 300;
    google_ad_height = 600;
</script>

<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>


<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Popular Tutorials</p>
<div class="pairsJustified">
<ul>
<li><a href="/intrusion_detection_with_ossec_hids">Securing Your Server With A Host-based Intrusion Detection System</a></li>
<li><hr /></li>
<li><a href="/kernel_compilation_debian">How to Compile A Kernel - The Debian Way</a></li>
<li><hr /></li>
<li><a href="/how-to-install-kuma-self-hosted-uptime-robot-alternative/">How to Install Kuma - Self-hosted Uptime Robot Alternative on Ubuntu 20.04</a></li>
<li><hr /></li>
<li><a href="/how-to-upgrade-from-debian-10-to-debian-11/">How to Upgrade from Debian 10 to Debian 11</a></li>
<li><hr /></li>
<li><a href="/install-and-configure-elasticsearch-on-rocky-linux-8/">Install and Configure Elasticsearch on Rocky Linux 8</a></li>
<li><hr /></li>
<li><a href="/tutorial/linux-grep-command/">How to use grep to search for strings in files on the shell</a></li>
<li><hr /></li>
<li><a href="/how-to-install-gulpjs-on-centos-8/">How to Install Gulp.js on CentOS 8</a></li>
<li><hr /></li>
<li><a href="/tutorial/ispconfig-multiserver-setup-debian-ubuntu/">ISPConfig Perfect Multiserver setup on Ubuntu 20.04 and Debian 10</a></li>
<li><hr /></li>
<li><a href="/tutorial/perfect-server-centos-7-apache-mysql-php-pureftpd-postfix-dovecot-and-ispconfig/">The Perfect Server CentOS 7.6 with Apache, PHP 7.2, Postfix, Dovecot, Pure-FTPD, BIND and ISPConfig 3.1</a></li>
<li><hr /></li>
<li><a href="/tutorial/linux-swappiness/">How to change the Swappiness of your Linux system</a></li>
<li><hr /></li>
</ul>
</div>
</div>
</div>
</div>
</div>
</aside>
</div>
</div>
</div>
<footer>
<div class="footer">
<div class="pageWidth">
<div class="pageContent">
<div class="skin_branding"><span>Xenforo skin by <a href="http://www.xenfocus.com" rel="nofollow">Xenfocus</a></span></div>
<ul class="footerLinks">
<li><a href="/contribute/">Contribute</a></li>
<li><a href="/community/misc/contact">Contact</a></li>
<li><a href="/community/help/">Help</a></li>
<li><a href="/imprint/">Imprint and Legal Notice</a></li>
<li><a href="#navigation" class="topLink">Top</a></li>
<li><a href="/feed" rel="alternate" class="globalFeed" target="_blank" title="RSS-Feed for Howtoforge">RSS-Feed</a></li>
</ul>
<span class="helper"></span>
</div>
</div>
</div>
<div class="footerLegal">
<div class="pageWidth">
<div class="pageContent">
<ul id="legal">
<li><a href="/community/help/terms">Terms and Rules</a> <a href="https://www.howtoforge.com/community/help/privacy-policy">Privacy Policy</a></li>
</ul>
<div id="copyright"><a href="https://www.howtoforge.com" class="concealed">Howtoforge <span>© projektfarm GmbH.</span></a></div>
<span class="helper"></span>
</div>
</div>
</div>
</footer>
<div style="height:100px;"></div>

<div id="subscriptionModal" class="modal">
<div class="modal-content">
<span class="close">×</span>
<p>This feature is only available to subscribers. Get your subscription <a href="/subscription">here</a>.</p>
</div>
</div>
<script>
//* Modal
var modal = document.getElementById('subscriptionModal');
var span = document.getElementsByClassName("close")[0];
$(".pdf-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
$(".print-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
span.onclick = function() {
	$("#subscriptionModal").css('display', 'none');
}
window.onclick = function(event) {
    if (event.target == modal) {
		$("#subscriptionModal").css('display', 'none');
    }
}
//* Xenforo
jQuery.extend(true, XenForo,
{
	visitor: { user_id: 0 },
	serverTimeInfo:
	{
		now: 1409831907,
		today: 1409781600,
		todayDow: 4
	},
	_lightBoxUniversal: "0",
	_enableOverlays: "1",
	_animationSpeedMultiplier: "1",
	_overlayConfig:
	{
		top: "10%",
		speed: 200,
		closeSpeed: 100,
		mask:
		{
			color: "rgb(0, 0, 0)",
			opacity: "0.6",
			loadSpeed: 200,
			closeSpeed: 100
		}
	},
	_ignoredUsers: [],
	_loadedScripts: {"node_list":true,"node_category":true,"node_forum":true,"sidebar_share_page":true,"wf_default":true,"bbm_buttons":true,"login_bar":true,"twitter":true},
	_cookieConfig: { path: "/", domain: "", prefix: "xf_"},
	_csrfToken: "",
	_csrfRefreshUrl: "/community/login/csrf-token-refresh",
	_jsVersion: "303ae0ca"
});
jQuery.extend(XenForo.phrases,
{
	cancel: "Cancel",

	a_moment_ago:    "A moment ago",
	one_minute_ago:  "1 minute ago",
	x_minutes_ago:   "%minutes% minutes ago",
	today_at_x:      "Today at %time%",
	yesterday_at_x:  "Yesterday at %time%",
	day_x_at_time_y: "%day% at %time%",

	day0: "Sunday",
	day1: "Monday",
	day2: "Tuesday",
	day3: "Wednesday",
	day4: "Thursday",
	day5: "Friday",
	day6: "Saturday",

	_months: "January,February,March,April,May,June,July,August,September,October,November,December",
	_daysShort: "Sun,Mon,Tue,Wed,Thu,Fri,Sat",

	following_error_occurred: "The following error occurred",
	server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
	logging_in: "Logging in",
	click_image_show_full_size_version: "Click this image to show the full-size version.",
	show_hidden_content_by_x: "Show hidden content by {names}"
});

// Facebook Javascript SDK
XenForo.Facebook.appId = "";
XenForo.Facebook.forceInit = true;

/*
document.addEventListener('DOMContentLoaded', function(event) {
  cookieChoices.showCookieConsentBar('Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.',
  'OK');
});
*/

$(document).ready(function() {
	$("a.fancybox").fancybox();
});

</script>

<script>
_bsa.init('custom', 'CKYD55QU', 'placement:howtoforge',
    {
      target: '#sponsor-banner',
      template: `
<a href="##link##" style="background: linear-gradient(-330deg, ##backgroundColor##D9, ##backgroundColor##D9 30%, ##backgroundColor## 70%) #fff;" class="native-banner">
<img class="native-img" src="##logo##">
<div style="color: ##textColor##" class="native-tagline">##tagline##</div>
<div style="color: ##textColor##" class="native-desc">##description##</div>
<div style="color: ##ctaTextColor##; background-color: ##ctaBackgroundColor##;" class="native-cta">##callToAction##</div>
<div style="background-color: ##textColor##B2; color: ##backgroundColor##" class="native-ad">Ad</div>
</a>
`
    }
  );
</script>

<script>
(function() {
  if (typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('fancybar', 'CKYDL27E', 'placement:howtoforgecom');
  }
})();
</script>
<script>
(function() {
  if (typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('custom', 'CEBDK2JM', 'placement:howtoforgecom', {
      target: '.bsa-apiads',
      template:
`
<a href="##statlink##" target="_blank" rel="sponsored nofollow">##company## — ##description##</a>
`
    });
  }
})();
</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2155872-1', 'auto');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');

</script>
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('/detroitchicago/edmonton.webp', '/detroitchicago/edmonton.webp?a=a&cb=2&shcb=34', true, ['/detroitchicago/minneapolisz.js'], true, false, false, false);
__ez.queue.addFile('/porpoiseant/jellyfish.webp', '/porpoiseant/jellyfish.webp?a=a&cb=2&shcb=34', false, [], true, false, false, false);
</script>
<script>var _audins_dom="howtoforge_com",_audins_did=178704;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=195-2");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.howtoforge_com,DomainId.178704" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=2&cb=3', false, ['/detroitchicago/minneapolisz.js'], true, false, true, false);</script><script type="text/javascript">(function(){window['__CF$cv$params']={r:'68534db5eb1859af',m:'7c65cbb22ea9cb1b02415cd8d802766abca0cb62-1630046375-1800-AawUkb32u9cuXKUj66K8WQqcdt4Wl31tlxvoJ/CHv5Mim7iBpW3GjXxoLCjNP78sHK+0uyDejM/zMvtcr7sPdZnEMNDpn1HgAvQ7bWLYjTBzmg0JN4Ma/Xod7S2k8PSziDQqsLec5zJUJpL2x6Aev3Ks4bbEO61CyEpOhOkjpyFE',s:[0xc2242dda06,0x17a03c2ac6],}})();</script></body></html>