<!DOCTYPE html><html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs LoggedOut Sidebar Responsive" xmlns:fb="http://www.facebook.com/2008/fbml"><head><meta charset="utf-8" />
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>!function(){function e(i){return e="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e(i)}__ez.pel=function(){var i=[];function t(t,o,_,d,n,r,a,s){if(__ez.dot.isDefined(t)&&0!=__ez.dot.isAnyDefined(t.getSlotElementId,t.ElementId)){void 0===s&&(s=!1);var p=parseInt(__ez.dot.getTargeting(t,"ap")),f=__ez.dot.getSlotIID(t),u=__ez.dot.getAdUnit(t,s),g=parseInt(__ez.dot.getTargeting(t,"compid")),c=0,l=0,z=function(i){if("undefined"==typeof _ezim_d)return!1;var t=__ez.dot.getAdUnitPath(i).split("/").pop();if("object"===("undefined"==typeof _ezim_d?"undefined":e(_ezim_d))&&_ezim_d.hasOwnProperty(t))return _ezim_d[t];for(var o in _ezim_d)if(o.split("/").pop()===t)return _ezim_d[o];return!1}(t);"object"==e(z)&&(void 0!==z.creative_id&&(l=z.creative_id),void 0!==z.line_item_id&&(c=z.line_item_id)),__ez.dot.isDefined(f,u)&&__ez.dot.isValid(o)&&("0"===f&&!0!==s||""===u||i.push({type:"impression",impression_id:f,domain_id:__ez.dot.getDID(),unit:u,t_epoch:__ez.dot.getEpoch(0),revenue:_,est_revenue:d,ad_position:p,ad_size:"",bid_floor_filled:n,bid_floor_prev:r,stat_source_id:a,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:g,line_item_id:c,creative_id:l,data:__ez.dot.dataToStr(o),is_orig:s||__ez.template.isOrig}))}}function o(){void 0!==document.visibilityState&&"prerender"===document.visibilityState||(__ez.dot.isDefined(i)&&i.length>0&&[i.filter((function(e){return e.is_orig})),i.filter((function(e){return!e.is_orig}))].forEach((function(e){for(;e.length>0;){var i=e[0].is_orig||!1,t=5;t>e.length&&(t=e.length);var o=e.splice(0,t),_=__ez.dot.getURL("/porpoiseant/army.gif")+"?orig="+(!0===i?1:0)+"&sts="+btoa(JSON.stringify(o));void 0!==window.isAmp&&isAmp&&void 0!==window._ezaq&&_ezaq.hasOwnProperty("domain_id")&&(_+="&visit_uuid="+_ezaq.visit_uuid),__ez.dot.Fire(_)}})),i=[])}return{Add:t,AddAndFire:function(e,i){t(e,i,0,0,0,0,0),o()},AddAndFireOrig:function(e,i){t(e,i,0,0,0,0,0,!0),o()},AddById:function(e,t,o,_){var d=e.split("/");if(__ez.dot.isDefined(e)&&3===d.length&&__ez.dot.isValid(t)){var n=d[0],r={type:"impression",impression_id:d[2],domain_id:__ez.dot.getDID(),unit:n,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(t),is_orig:o||__ez.template.isOrig};void 0!==_&&(r.revenue=_),i.push(r)}},Fire:o,GetPixels:function(){return i}}}()}();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=195-2&cb=6', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=195-2&cb=5', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=195-2&cb=7', false, [], true, false, true, false);</script>
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<base href="https://www.howtoforge.com" />
<script>
			var _b = document.getElementsByTagName('base')[0], _bH = "https://www.howtoforge.com/how-to-install-sonarqube-on-ubuntu-22-04/";
			if (_b && _b.href != _bH) _b.href = _bH;
		</script>
<title>How to Install SonarQube on Ubuntu 22.04</title>
<meta name="description" content="SonarQube or formerly Sonar is an open-source platform for static code analysis and code security. It allows you to perform static code analysis and c... " />
<meta property="og:title" content="How to Install SonarQube on Ubuntu 22.04" />
<meta property="og:description" content="SonarQube or formerly Sonar is an open-source platform for static code analysis and code security. It allows you to perform static code analysis and c... " />
<meta property="og:site_name" content="HowtoForge" />
<meta property="og:type" content="article" />
<meta property="og:image" content="https://www.howtoforge.com/images/featured/ubuntu-22-04-sonarqube.png" />
<meta property="og:image:secure_url" content="https://www.howtoforge.com/images/featured/ubuntu-22-04-sonarqube.png" />
<meta property="og:image:alt" content="How to Install SonarQube on Ubuntu 22.04" />
<meta name="twitter:image" content="https://www.howtoforge.com/images/featured/ubuntu-22-04-sonarqube.png" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@howtoforgecom" />
<meta name="twitter:creator" content="@howtoforgecom" />
<meta name="twitter:title" content="How to Install SonarQube on Ubuntu 22.04" />
<meta name="twitter:description" content="SonarQube or formerly Sonar is an open-source platform for static code analysis and code security. It allows you to perform static code analysis and c... " />
<link rel="alternate" href="https://www.howtoforge.com/how-to-install-sonarqube-on-ubuntu-22-04/" hreflang="en" />
<link rel="canonical" href="https://www.howtoforge.com/how-to-install-sonarqube-on-ubuntu-22-04/" />
<link rel="amphtml" href="https://www.howtoforge.com/how-to-install-sonarqube-on-ubuntu-22-04/amp/" />
<script type="application/ld+json">
{
  "@context" : "http://schema.org",
  "@type" : "Article",
  "name" : "How to Install SonarQube on Ubuntu 22.04",
  "author" : {
    "@type" : "Person",
    "name" : "Arvid L"
  },
  "articleSection" : "linux,ubuntu",
  "url" : "https://www.howtoforge.com/how-to-install-sonarqube-on-ubuntu-22-04/",
  "publisher" : {
    "@type" : "Organization",
    "name" : "Howtoforge"
  }
}
</script>
<noscript><style>.JsOnly, .jsOnly { display: none !important; }</style></noscript>

<link rel="stylesheet" href="/themes/howtoforge/icons/css/font-awesome.min.css" />

<link href="/themes/howtoforge/fonts/opensans.css?family=Open+Sans:400,700" rel="stylesheet" type="text/css" />
<link href="/themes/howtoforge/templates/xf.css" rel="stylesheet" />
<script src="/js/jquery/jquery-1.11.3.min.js"></script>

<script src="/themes/howtoforge/js/xenforo/xenforo.js?_v=303ae0ca"></script>

<script src="/themes/howtoforge/js/bbm/zloader.js?_v=303ae0ca"></script>
<script type="text/javascript" src="/js/fancybox/jquery.mousewheel-3.0.4.pack.js"></script>
<script type="text/javascript" src="/js/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
<link rel="stylesheet" type="text/css" href="/js/fancybox/jquery.fancybox-1.3.4.css" media="screen" />
<link href="/themes/howtoforge/templates/style.min.css" rel="stylesheet" />
<link rel="alternate" type="application/rss+xml" title="RSS-Feed für Howtoforge" href="/feed.rss" />
<script src="/js/tinymce_4.1.7/tinymce.min.js"></script>
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/skin.min.css" as="style" />
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/content.min.css" as="style" />
<link rel="preload" href="/themes/howtoforge/css/custom.css" as="style" />
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/fonts/tinymce.woff" as="font" crossorigin="anonymous" />

<script type="text/javascript">
var gaProperty = 'UA-2155872-1';
var disableStr = 'ga-disable-' + gaProperty;
if (document.cookie.indexOf(disableStr + '=true') > -1) {
window[disableStr] = true;
}
function gaOptout() {
document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
window[disableStr] = true;
alert('Google Ananlyitics tracking has been disabled in this browser.');
}
</script>
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
	googletag.defineSlot('/1030080/howtoforge_com_list_sidebar_top', [300, 250], 'div-gpt-ad-1527185271042-4').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_list_content_middle', [[300, 250], [336, 280]], 'div-gpt-ad-1527185271042-5').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_a_300x250', [300, 250], 'div-gpt-ad-1527185271042-6').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_b_300x250', [300, 250], 'div-gpt-ad-1527185271042-7').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_leaderboard_b_728x90', [728, 90], 'div-gpt-ad-1527185271042-1').addService(googletag.pubads());
	googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-3043223216276099",
          enable_page_level_ads: true
     });
</script>


<script type="text/javascript" src="//m.servedby-buysellads.com/monetization.js"></script>

<script type="text/javascript">var ezouid = "1";</script><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script>
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 178704;
var ezdomain = 'howtoforge.com';
var ezoicSearchable = 1;
</script>


<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":178704,"domain_test_group":20230804,"engaged_time_visit":0,"ezcache_level":2,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"ef4b54fe-b156-477b-5fd5-29ba2f15d90d","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":56591,"response_time_orig":5,"serverid":"44.193.7.95:9476","state":"VA","t_epoch":1664268106,"template_id":126,"time_on_site_visit":0,"url":"https://www.howtoforge.com/how-to-install-sonarqube-on-ubuntu-22-04/","user_id":0,"word_count":2348,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_178704=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["ef4b54fe-b156-477b-5fd5-29ba2f15d90d", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>
<body>
<div id="loginBar">
<div class="pageWidth">
<div class="pageContent">
<h3 id="loginBarHandle">
<label for="LoginControl"><a href="https://forum.howtoforge.com/login/" class="concealed noOutline">Log in or Sign up</a></label>
</h3>
<span class="helper"></span>
</div>
</div>
</div>
<header>
<div id="header">
<div id="logoBlock">
<div class="pageWidth">
<div class="pageContent">
<div id="logo"><a href="/">
<span></span>
<img src="/images/howtoforge_logo_trans.gif" alt="Howtoforge" style="margin-left:20px;" />
</a></div>
<span class="helper"></span>
</div>
</div>
</div>
<div id="navigation" class="pageWidth withSearch">
<div class="pageContent">
<nav>
<div class="navTabs">
<ul class="publicTabs">

<li class="navTab forums selected">
<a href="/" class="navLink">Tutorials</a>
<div class="tabLinks forumsTabLinks">
<ul class="secondaryContent blockLinksList">
<li><a href="/search/">Tutorial search</a></li>
</ul>
</div>
</li>
<li class="navTab forums PopupClosed">
<a href="/tutorials/" class="navLink">Tags</a>
</li>
<li class="navTab forums PopupClosed"><a href="https://forum.howtoforge.com/" class="navLink">Forums</a></li>
<li class="navTab forums PopupClosed"><a href="/linux-commands/" class="navLink">Linux Commands</a></li>
<li class="navTab forums PopupClosed"><a href="/subscription/" class="navLink">Subscribe</a></li>
</ul>
</div>
<span class="helper"></span>
</nav>
</div>
</div>
<div id="searchBar" class="pageWidth">
<span id="QuickSearchPlaceholder" title=" Search..."> Search</span>
<fieldset id="QuickSearch">
<form action="/" method="post" class="formPopup">
<div class="primaryControls">

<input type="search" name="q" value="" class="textCtrl" placeholder="Search..." results="0" title="Enter your search and hit enter..." id="QuickSearchQuery" />

</div>
<input type="hidden" name="_xfToken" value="" />
</form>
</fieldset>
</div>
</div>
</header>
<div id="content" class="forum_list">
<div class="pageWidth">
<div class="pageContent">

<div class="mainContainer">
<div class="mainContent">

<div class="breadBoxTop">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://schema.org/BreadcrumbList">
<span itemprop="itemListElement" itemscope="" itemtype="http://schema.org/ListItem">
<a href="/" class="crumb" rel="up" itemprop="item"><span itemprop="name">Home</span></a>
<meta itemprop="position" content="1" />
</span>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://schema.org/BreadcrumbList">
<span itemprop="itemListElement" itemscope="" itemtype="http://schema.org/ListItem">
<a href="/how-to-install-sonarqube-on-ubuntu-22-04/" class="crumb" rel="up" itemprop="item"><span itemprop="name">How to Install SonarQube on Ubuntu 22.04</span></a>
<meta itemprop="position" content="2" />
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</span></fieldset>
</nav>
</div>

<div id="htfContentPage">
<div class="bsa-apiads"></div>
<article>
<h1>How to Install SonarQube on Ubuntu 22.04</h1>
<div class="contributeEdit" style="float:right; width:450px; max-width:100%;">
<div id="tocContainer">
<h3>This tutorial exists for these OS versions</h3>
<ul><li><strong>Ubuntu 22.04 (Jammy Jellyfish)</strong></li><li><a href="/-how-to-install-sonarqube-on-ubuntu-20-04/">Ubuntu 20.04 (Focal Fossa)</a></li><li><a href="/how-to-install-sonarqube-on-ubuntu-1804/">Ubuntu 18.04 (Bionic Beaver)</a></li><li><a href="/tutorial/how-to-install-sonarqube-on-ubuntu-1604/">Ubuntu 16.04 (Xenial Xerus)</a></li></ul> <h3>On this page</h3>
<ol class="toc">
<li><a href="#prerequisites">Prerequisites</a></li>
<li><a href="#installing-java-openjdk">Installing Java OpenJDK</a></li>
<li><a href="#installing-postgresql-database-system">Installing PostgreSQL Database System</a></li>
<li><a href="#setting-up-system">Setting up System</a></li>
<li><a href="#downloading-sonarqube-package">Downloading SonarQube Package</a></li>
<li><a href="#configuring-sonarqube">Configuring SonarQube</a></li>
<li><a href="#running-sonarqube-with-reverse-proxy">Running SonarQube with Reverse Proxy</a></li>
<li><a href="#sonarqube-installatioon">SonarQube Installatioon</a></li>
<li><a href="#conclusion">Conclusion</a></li>
</ol>
</div>
</div>
<p>SonarQube or formerly Sonar is an open-source platform for static code analysis and code security. It allows you to perform static code analysis and code quality to detect bugs and enhance application security. It also provides reports such as duplicate code, coding standards, code complexity, and security recommendation.</p>
<p>With sonarQube, you can automate static code analysis for 29 programming languages. You can easily integrate SonarQube with your existing CI/CD tools such as Jenkins, Azure DevOps, or IDE such as IntelliJ and Visual Code Studio.</p>
<p>In this guide, you will learn how to install SonarQube static code analysis on Ubuntu 22.04 server. You will also learn how to install PostgreSQL which will be used as the database for SonarQube and the Nginx web server that will be used as the reverse proxy.</p>
<h2 id="prerequisites">Prerequisites</h2>
<p>Before starting this guide, you should have the following:</p>
<ul>
<li>An Ubuntu server 22.04 with UFW firewall enabled.</li>
<li>A non-root user with sudo/administrator privileges.</li>
<li>A domain name pointed to the Ubuntu server IP address.</li>
</ul>
<h2 id="installing-java-openjdk">Installing Java OpenJDK</h2>
<p>Your first step here is to install the Java OpenJDK on your Ubuntu system. The SonarQube server required Java OpenJDK v11 to be installed on your Linux machine.</p>
<p>Before start installing packages, run the following apt command to update and refresh your Ubuntu package index repository.</p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;">

<div id="div-gpt-ad-1527185271042-6" style="height:250px; width:300px;">
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-6'); });
</script>
</div>
</div>
<pre class="command">sudo apt update</pre>
<p>Then, install the Java OpenJDK v11 using the following apt command. The default OpenJDK version on the latest Ubuntu 22.04 is Java OpenJDK v11.</p>
<p>Input Y when prompted to confirm the installation and press ENTER to proceed.</p>
<pre class="command">sudo apt install default-jdk</pre>
<p><a class="fancybox" id="img-1-install-java" href="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/big/1-install-java.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/1-install-java.png" alt="install java" width="750" height="549" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Once Java OpenJDK is installed, verify the Java version using the following java command. You will see the output of the Java version that is installed on your system.</p>
<pre class="command">java -version</pre>
<p><a class="fancybox" id="img-2-check-java" href="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/big/2-check-java.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/2-check-java.png" alt="check java" width="750" height="135" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<h2 id="installing-postgresql-database-system">Installing PostgreSQL Database System</h2>
<p>SonarQube supports multiple database systems such as PostgreSQL, Microsoft SQL Server, and oracle database. For this example, you will use PostgreSQL as the database for your SonarQube installation.</p>
<p>At the time of this writing, the latest version of SonarQube required at least PostgreSQL v9.6. In this guide, you will install PostgreSQL v13 from the official PostgreSQL repository.</p>
<p>First, add the GPG key of the PostgreSQL repository using the following command.</p>
<pre class="command">wget -q https://www.postgresql.org/media/keys/ACCC4CF8.asc -O - | sudo apt-key add -</pre>
<p>Now, add the PostgreSQL repository for the Ubuntu system using the below command.</p>
<pre class="command">sudo sh -c &#39;echo &#34;deb http://apt.postgresql.org/pub/repos/apt/ `lsb_release -cs`-pgdg main&#34; &gt;&gt; /etc/apt/sources.list.d/pgdg.list&#39;</pre>
<p>Then, update and refresh your ubuntu package index.</p>
<pre class="command">sudo apt update</pre>
<p><a class="fancybox" id="img-3-setup-postgresql-repo" href="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/big/3-setup-postgresql-repo.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/3-setup-postgresql-repo.png" alt="add postgresql repository" width="750" height="154" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Now, install the PostgreSQL database v13 via the apt command below. Input Y when prompted to confirm the installation, then press ENTER to proceed.</p>
<pre class="command">sudo apt install postgresql-13</pre>
<p><a class="fancybox" id="img-4-install-postgresql" href="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/big/4-install-postgresql.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/4-install-postgresql.png" alt="install postgresql" width="743" height="379" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Once PostgreSQL is installed, run the following command to verify the &#39;postgresql&#39; service and to make sure the service is running.</p>
<pre class="command">sudo systemctl is-enabled postgresql<br />sudo systemctl status postgresql</pre>
<p>You will see the output of the &#39;<strong>postgresql</strong>&#39; service is enabled, which means will be run automatically at system boot. And the current status of the &#39;postgresql&#39; service is running.</p>
<p><a class="fancybox" id="img-5-check-postgresql-service" href="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/big/5-check-postgresql-service.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/5-check-postgresql-service.png" alt="check postgresql" width="750" height="188" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>With the PostgreSQL installed on your server, you are ready to set up a new database and user for the SonarQube via the PostgreSQL shell.</p>
<p>Run the following command to log in to the PostgreSQL shell.</p>
<pre class="command">sudo -u postgres psql</pre>
<p>Now, run the following PostgreSQL queries to create a new database and user for SnonarQube. In this example, you will create the PostgreSQL database and user &#39;<strong>sonarqube</strong>&#39;. And be sure to change the password with a strong password.</p>
<pre class="command">CREATE USER sonarqube WITH PASSWORD &#39;Password&#39;;<br />CREATE DATABASE sonarqube OWNER sonarqube;<br />GRANT ALL PRIVILEGES ON DATABASE sonarqube TO sonarqube;</pre>
<p><a class="fancybox" id="img-6-cretae-database" href="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/big/6-cretae-database.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/6-cretae-database.png" alt="create database" width="643" height="284" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Next, run the following queries to check the list of databases and users on the PostgreSQL server.</p>
<pre class="command">\l<br />\du</pre>
<p>If your database and user is created, you will see the database &#39;sonarqube&#39; on the list of databases, and the user &#39;sonarqube&#39; on the list of users.</p>
<p><a class="fancybox" id="img-7-check-database-user" href="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/big/7-check-database-user.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/7-check-database-user.png" alt="check database and user" width="750" height="424" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Lastly, log out from PostgreSQL using the query below.</p>
<pre class="command">\q</pre>
<h2 id="setting-up-system">Setting up System</h2>
<p>To install SonarQube on a Linux system, you must have a dedicated user that will be running SonarQube and some additional configurations such as ulimit and kernel parameters.</p>
<p>Now, you will create a new user for SonarQube, and set up custom kernel parameters via sysctl.conf file, and set up ulimit.</p>
<p>Run the following command to create a new user &#39;<strong>sonarqube</strong>&#39; on your system.</p>
<pre class="command">sudo useradd -b /opt/sonarqube -s /bin/bash sonarqube</pre>
<p>Next, open the file<em> /etc/sysctl.conf</em> using nano editor.</p>
<pre class="command">sudo nano /etc/sysctl.conf</pre>
<p>Add the following configuration to the bottom of the line. The SonarQube required the kernel parameter vm.max_map_count to be greater than &#39;<strong>524288</strong>&#39; and the fx.file-max to be greater than &#39;<strong>131072</strong>&#39;.</p>
<pre>vm.max_map_count=524288<br />fs.file-max=131072</pre>
<p>Save the file and exit the editor when you are finished.</p>
<p>Now, run the sysctl command below to apply new changes on the &#39;/etc/sysctl.conf&#39; file.</p>
<pre class="command">sudo sysctl --system</pre>
<p>In the following output, you can see the new kernel parameters is applied.</p>
<p><a class="fancybox" id="img-9-apply-sysctl" href="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/big/9-apply-sysctl.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/9-apply-sysctl.png" alt="apply sysctl" width="388" height="105" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<pre class="command">Next, run the following command to set up ulimit for the SonarQube. This will take temporary effects on your system, when the system is rebooted, the ulimits will revert to default.</pre>
<pre class="command">ulimit -n 131072<br />ulimit -u 8192</pre>
<p>To make ulimit configuration permanently, create a new config file &#39;<em>/etc/security/limits.d/99-sonarqube.conf</em>&#39; using the following command.</p>
<pre class="command">sudo nano /etc/security/limits.d/99-sonarqube.conf</pre>
<p>Add the following configuration to the file.</p>
<pre>sonarqube   -   nofile   131072<br />sonarqube   -   nproc    8192</pre>
<p>Save the file and close the editor when you are finished.</p>
<p>Now that you have completed the configuration of your Ubuntu system for SnonarQube installation. You will be downloading the SonarQube package and setting up SonarQube installation in the next step.</p>
<h2 id="downloading-sonarqube-package">Downloading SonarQube Package</h2>
<p>The SonarQube can be installed in two different ways, via zip file and Docker image. In this example, you will install the SonarQube via the zip file package that you will download from the official SonarQube download page.</p>
<p>At the time of this writing, the SonarQube latest version v9.6.1, which you will be installing in the following steps.</p>
<p>Before downloading the SonarQube package, run the following apt command to install a basic package such as unzip and wget.</p>
<pre class="command">sudo apt install unzip software-properties-common wget</pre>
<p>Now, download the SonarQube package via the wget command below.</p>
<pre class="command">wget https://binaries.sonarsource.com/Distribution/sonarqube/sonarqube-9.6.1.59531.zip</pre>
<p>After the SonarQube is downloaded, you will see the zip file &#39;<strong>sonarqube-9.6.1.59531.zip</strong>&#39; on your working directory.</p>
<p>Extract the SonarQube package using the unzip command below. You should get a new directory &#39;<strong>sonarqube-9.6.1.59531</strong>&#39; where the SonarQube package is stored.</p>
<pre class="command">unzip sonarqube-9.6.1.59531.zip</pre>
<p>Move the directory &#39;<em>sonarqube-9.6.1.59531</em>&#39; to the &#39;<em>/opt/sonarqube</em>&#39; using the below command.</p>
<pre class="command">mv sonarqube-9.6.1.59531 /opt/sonarqube</pre>
<p>Lastly, change the ownership of the SonarQube installation directory &#39;/opt/sonarqube&#39; to the user &#39;sonarquba&#39; via the chown command as below.</p>
<pre class="command">sudo chown -R sonarqube:sonarqube /opt/sonarqube</pre>
<p>Now you have downloaded the SonarQube package to the installation directory &#39;<em>/opt/sonarqube</em>&#39;. Next, you will configure your SonarQube installation, then set up a systemd service file for SonarQube.</p>
<p><a class="fancybox" id="img-10-download-sonarqube" href="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/big/10-download-sonarqube.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/10-download-sonarqube.png" alt="download sonarqube" width="750" height="157" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<h2 id="configuring-sonarqube">Configuring SonarQube</h2>
<p>After downloading the SonarQube package, you will set up the SonarQUbe installation by editing the default config file &#39;/opt/sonarqube/conf/sonar.properties&#39;.</p>
<p>You will add the PostgreSQL database details, set up the max memory heap for the Elasticsearch process, and set up the web host and port for the SonarQube service via the file &#39;/opt/sonarqube/conf/sonar.properties&#39;. And lastly, you will set up SonarQube as a systemd service.</p>
<p>Now, open the SonarQube configuration file<em> &#39;/opt/sonarqube/conf/sonar.properties&#39;</em> using nano editor.</p>
<pre class="command">nano /opt/sonarqube/conf/sonar.properties</pre>
<p>For the database configuration, uncomment some of the following options and change the default value using your database details.</p>
<pre>sonar.jdbc.username=sonarqube<br />sonar.jdbc.password=Password<br /><br />sonar.jdbc.url=jdbc:postgresql://localhost:5432/sonarqube</pre>
<p>Now, uncomment the following configuration to set up the max heap memory size for the elasticsearch process. In his example, the max heap will be 512 MB.</p>
<pre>sonar.search.javaOpts=-Xmx512m -Xms512m -XX:MaxDirectMemorySize=256m -XX:+HeapDumpOnOutOfMemoryError</pre>
<p>Lastly, uncomment and change the following configurations to set up the IP address and port of the SonarQube will be running. Also, the log level will be &#39;INFO&#34; and stored in the &#39;logs&#39; directory of the SonarQube installation directory.</p>
<pre>sonar.web.host=127.0.0.1<br />sonar.web.port=9000<br />sonar.web.javaAdditionalOpts=-server<br /><br />sonar.log.level=INFO<br />sonar.path.logs=logs</pre>
<p>Save the file and exit the editor when you are finished.</p>
<p>After you have finished the SonarQube configuration. Now, you will set up the systemd service file for SonarQube. This allows you easily to control the SonarQube process by using the systemctl command.</p>
<p>Run the following command to create a new systemd service file &#39;<em>/etc/systemd/system/sonarqube.service</em>&#39;.</p>
<pre class="command">sudo nano /etc/systemd/system/sonarqube.service</pre>
<p>Add the following configuration to the file.</p>
<pre>[Unit]<br />Description=SonarQube service<br />After=syslog.target network.target<br /><br />[Service]<br />Type=forking<br />ExecStart=/opt/sonarqube/bin/linux-x86-64/sonar.sh start<br />ExecStop=/opt/sonarqube/bin/linux-x86-64/sonar.sh stop<br />User=sonarqube<br />Group=sonarqube<br />Restart=always<br />LimitNOFILE=65536<br />LimitNPROC=4096<br /><br />[Install]<br />WantedBy=multi-user.target</pre>
<p>Save the file and exit the editor when you are done.</p>
<p>Now, reload the systemd manager by using the following command.</p>
<pre class="command">sudo systemctl daemon-reload</pre>
<p>After that, start and enable the &#39;sonarqube.service&#39; via the systemctl command below.</p>
<pre class="command">sudo systemctl start sonarqube.service<br />sudo systemctl enable sonarqube.service</pre>
<p><a class="fancybox" id="img-11-setup-sonarqube-service" href="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/big/11-setup-sonarqube-service.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/11-setup-sonarqube-service.png" alt="setup sonarqube service" width="750" height="201" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Lastly, verify the &#39;sonarqube.service&#39; status using the following command and make sure its status is running.</p>
<pre class="command">sudo systemctl status sonarqube.service</pre>
<p>You will see the output in the following screenshot. The &#39;sonarqube.service&#39; status is running, and it&#39;s also enabled, which means it will automatically run at system boot.</p>
<p><a class="fancybox" id="img-12-check-sonarqube-service" href="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/big/12-check-sonarqube-service.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/12-check-sonarqube-service.png" alt="check sonarqube service" width="750" height="249" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Now that you have the SonarQube is running as a systemd service, you will install and set up a reverse proxy for the SonarQube that runs on localhost with the default port TCP &#39;<strong>9000</strong>&#39;.</p>
<h2 id="running-sonarqube-with-reverse-proxy">Running SonarQube with Reverse Proxy</h2>
<p>Your SonarQube installation is now running, you can now install the Nginx web server and set up server blocks that will be used as the reverse proxy for SonarQube.</p>
<p>Run the following apt command to install the Nginx web server to your Ubuntu system. Input Y when prompted to confirm the installation and press ENTER to proceed.</p>
<pre class="command">sudo apt install nginx</pre>
<p><a class="fancybox" id="img-15-install-nginx" href="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/big/15-install-nginx.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/15-install-nginx.png" alt="install nginx" width="750" height="350" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Once nginx is installed, verify the nginx service and make sure the service status is running via the systemctl command as below.</p>
<pre class="command">sudo systemctl is-enabled nginx<br />sudo systemctl status nginx</pre>
<p>You will see the output of the nginx service is enabled, which means it will run automatically at system boot. And the current status of the nginx service is running.</p>
<p><a class="fancybox" id="img-19-check-nginx" href="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/big/19-check-nginx.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/19-check-nginx.png" alt="check nginx" width="750" height="209" /></a></p>
<p>After you have the Nginx web server is running, you will create a new server block configuration that will be used as a reverse proxy for SonarQube.</p>
<p>Create a new server blocks configuration &#39;/etc/nginx/sites-available/sonarqube.conf&#39; using the following command.</p>
<pre class="command">sudo nano /etc/nginx/sites-available/sonarqube.conf</pre>
<p>Add the following configuration to your file and be sure to change the domain name.</p>
<pre>server {<br /><br />    listen 80;<br />    server_name sonar.hwdomain.io;<br />    access_log /var/log/nginx/sonar.access.log;<br />    error_log /var/log/nginx/sonar.error.log;<br />    proxy_buffers 16 64k;<br />    proxy_buffer_size 128k;<br /><br />    location / {<br />        proxy_pass http://127.0.0.1:9000;<br />        proxy_next_upstream error timeout invalid_header http_500 http_502 http_503 http_504;<br />        proxy_redirect off;<br />        proxy_set_header Host $host;<br />        proxy_set_header X-Real-IP $remote_addr;<br />        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;<br />        proxy_set_header X-Forwarded-Proto http;<br />    }<br />}</pre>
<p>Save the file and exit the editor when you are finished.</p>
<p>Next, activate the server block configuration &#39;sonarqube.conf&#39; by creating a symlink of that file to the &#39;<em>/etc/nginx/sites-enabled</em>&#39; directory. Then, verify your Nginx configuration files.</p>
<pre class="command">sudo ln -s /etc/nginx/sites-available/sonarqube.conf /etc/nginx/sites-enabled/<br />sudo nginx -t</pre>
<p>If you have proper and correct Nginx configuration files, you should see the output message such as &#34;<strong>test is successfull&#34;</strong>.</p>
<p>Lastly, run the following systemctl command below to restart the nginx service and apply the new server block configuration.</p>
<pre class="command">sudo systemctl restart nginx</pre>
<h2 id="sonarqube-installatioon">SonarQube Installatioon</h2>
<p>After you have finished the reverse proxy configuration for SonarQube, now you can access your SonarQube installation via your domain and set up some basic configuration of SonarQube.</p>
<p>Open your web browser and visit the domain name for your SonarQube installation (i.e: http://sonar.hwdomain.io).</p>
<p>Now you will get the SonarQube login page. Input the default username and password <strong>admin/admin</strong> and click <strong>Login</strong>.</p>
<p><a class="fancybox" id="img-16-sonarqube-login" href="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/big/16-sonarqube-login.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/16-sonarqube-login.png" alt="login sonarqube" width="750" height="359" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Once you logged in, you will be asked to set up a new password for SnonarQube. Input the old password admin, then input the new strong password and repeat, then click Update.</p>
<p><a class="fancybox" id="img-17-change-password" href="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/big/17-change-password.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/17-change-password.png" alt="change password" width="575" height="558" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Now you will be shown the SonarQube user dashboard in the following screenshot.</p>
<p><a class="fancybox" id="img-18-sonarqube-dashboard" href="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/big/18-sonarqube-dashboard.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_sonarqube_on_ubuntu_2204/18-sonarqube-dashboard.png" alt="sonarqube dashboard" width="750" height="589" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<h2 id="conclusion">Conclusion</h2>
<p>In this guide, you have installed SonarQube on the latest Ubuntu 22.04 server. Also, you have completed the basic installation of the PostgreSQL database via the official PostgreSQL repository and installed the Nginx web server. Afterward, you have also configured the reverse proxy for the SOnarQube with Nginx server blocks.</p>
<p>SonarQube is now installed on your Ubuntu server. You can now add the project that you will be analyzing to the SonarQube via the git repository.</p>
</article>
<div style="height:30px; margin-top:20px;">
<p style="text-align:right;"><img src="/images/pdficon_small.png" /> <a class="pdf-btn" href="javascript:void(0);">view as pdf</a> | <img src="/images/print.gif" /> <a class="print-btn" href="javascript:void(0);">print</a></p>
</div>
<div style="height:30px; margin-top:20px;">
<div style="float:left;"><b>Share this page:</b></div>
<p style="text-align:center;">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-sonarqube-on-ubuntu-22-04%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-sonarqube-on-ubuntu-22-04%2F&amp;text=How+to+Install+SonarQube+on+Ubuntu+22.04&amp;via=howtoforgecom&amp;related=howtoforgecom" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-sonarqube-on-ubuntu-22-04%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-gplus.png" height="20" /></a>
</p>
</div>
</div>


<div id="htfContentPagePaging">
<h2>Suggested articles</h2>
<script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-3043223216276099" data-ad-slot="8940054090"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>


<div id="htfContentPageComment">
<a name="comments"></a>
<h2>0 Comment(s)</h2>

<div id="commentform">
<div class="commentContainerHead" style="font-size:18px;">Add comment</div>
<div class="commentContainer">
<form method="post" action="/how-to-install-sonarqube-on-ubuntu-22-04/#comments">
<input type="hidden" name="reply_to" id="reply-to-comment" value="0" />
<div id="commentFormDetail">
<div style="width:48%; float:left; margin-right:3%">
<label for="commentname">Name *</label>
<input id="commentname" name="commentname" value="" />
</div>
<div style="width:48%;float:left;">
<label for="commentname">Email *</label>
<input id="commentemail" name="commentemail" value="" />
</div>
<div style="clear:both;"></div>
</div>
<textarea id="commentedit" name="commentedit" style="width:auto;"></textarea>
<div>
<div style="float:left;">
<div class="g-recaptcha" data-sitekey="6LdX9fUSAAAAALWwVoPdeXScMSketz4npF-0QcQ1"></div>
 <script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en">
      </script>
</div>
<div style="margin-top:10px;margin-bottom:10px;">
<input type="submit" name="submit" class="button primary" style="float:right;" value="Submit comment" />
</div>
<div style="clear:both;"></div>
</div>
<script>
	tinymce.init({
		selector: "textarea#commentedit",
		theme: "modern",
		height: 100,
		apply_source_formatting : true,
		remove_linebreaks : false,
		menubar : false,
		/*auto_focus : "commentedit",*/
		plugins: [
		"link"
		],
		/*plugins: [
			"advlist autolink link image lists charmap print preview hr anchor pagebreak spellchecker",
			"searchreplace wordcount visualblocks visualchars code fullscreen insertdatetime media nonbreaking",
			"save table contextmenu directionality emoticons template paste textcolor"
		],*/
		content_css: "https://www.howtoforge.com/themes/howtoforge/css/custom.css",
		toolbar: "undo redo | bold italic link", 
		/*style_formats: [
			{title: 'Bold text', inline: 'b'},
			{title: 'Red text', inline: 'span', styles: {color: '#ff0000'}},
			{title: 'Red header', block: 'h1', styles: {color: '#ff0000'}},
			{title: 'Example 1', inline: 'span', classes: 'example1'},
			{title: 'Example 2', inline: 'span', classes: 'example2'},
			{title: 'Table styles'},
			{title: 'Table row 1', selector: 'tr', classes: 'tablerow1'}
		]*/
	}); 
	</script>
</form>
</div>
</div>

</div>

<div class="breadBoxBottom">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Home</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/how-to-install-sonarqube-on-ubuntu-22-04/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to Install SonarQube on Ubuntu 22.04</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
<script>
<!--

$(document).on('click', 'a.reply-to', function(e) {
	e.preventDefault();
	
	var self = $(this);
	var cid = self.attr('data-comment');
	console.log(cid);
	if(!cid) return this;
	
	$('#commentform').insertAfter('#comment' + cid);
	$('#reply-to-comment').val(cid);
	/*tinyMCE.activeEditor.focus();*/
	var textareaId = 'commentedit';
	tinyMCE.get(textareaId).remove();
	tinyMCE.execCommand("mceAddEditor", false, textareaId);
	tinyMCE.activeEditor.focus();
});
//-->
</script>
<div style="margin-top:10px;margin-bottom:10px;text-align:center;">

<center>


<div id="div-gpt-ad-1527185271042-1" style="height:90px; width:728px;">
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-1'); });
</script>
</div>

</center>
</div>


<form action="https://forum.howtoforge.com/login/login?redirect=/how-to-install-sonarqube-on-ubuntu-22-04/" method="post" class="xenForm eAuth" id="login" style="display:none">
<ul id="eAuthUnit">
<li><a href="https://forum.howtoforge.com/community/register/facebook?reg=1" class="fbLogin" tabindex="110"><span>Log in with Facebook</span></a></li>
<li><a href="https://forum.howtoforge.com/community/register/twitter?reg=1" class="twitterLogin" tabindex="110"><span>Log in with Twitter</span></a></li>
<li><span class="googleLogin GoogleLogin JsOnly" tabindex="110" data-client-id="198773272284-b6tfk0c28bje81p774prrcrkq9jb3o44.apps.googleusercontent.com" data-redirect-url="https://forum.howtoforge.com/register/google?code=__CODE__&amp;csrf=hVMXbW_3rnrmq4Em"><span>Log in with Google</span></span></li>
</ul>
<div class="ctrlWrapper">
<dl class="ctrlUnit">
<dt><label for="LoginControl">Your name or email address:</label></dt>
<dd><input type="text" name="login" id="LoginControl" class="textCtrl" tabindex="101" /></dd>
</dl>
<dl class="ctrlUnit">
<dt>
<label for="ctrl_password">Do you already have an account?</label>
</dt>
<dd>
<ul>
<li><label for="ctrl_not_registered"><input type="radio" name="register" value="1" id="ctrl_not_registered" tabindex="105" />
No, create an account now.</label></li>
<li><label for="ctrl_registered"><input type="radio" name="register" value="0" id="ctrl_registered" tabindex="105" checked="checked" class="Disabler" />
Yes, my password is:</label></li>
<li id="ctrl_registered_Disabler">
<input type="password" name="password" class="textCtrl" id="ctrl_password" tabindex="102" />
<div class="lostPassword"><a href="https://forum.howtoforge.com/lost-password/" tabindex="106">Forgot your password?</a></div>
</li>
</ul>
</dd>
</dl>
<dl class="ctrlUnit submitUnit">
<dt></dt>
<dd>
<input type="submit" class="button primary" value="Log in" tabindex="104" data-loginphrase="Log in" data-signupphrase="Sign up" />
<label for="ctrl_remember" class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_remember" tabindex="103" /> Stay logged in</label>
</dd>
</dl>
</div>
<input type="hidden" name="cookie_check" value="1" />
<input type="hidden" name="redirect" value="https://forum.howtoforge.com/" />
<input type="hidden" name="_xfToken" value="" />
</form>

</div>
</div>

<aside>
<div class="sidebar">
<div class="section loginButton">
<div class="secondaryContent">
<label for="LoginControl" id="SignupButton"><a href="https://forum.howtoforge.com/login/" class="inner">Sign up now!</a></label>
</div>
</div>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-2">

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent socialMediaIcon">
<a href="https://twitter.com/howtoforgecom" target="_blank"><img src="/images/socialmedia/64x64/twitter.png" /></a>
<a href="https://www.facebook.com/howtoforge" target="_blank"><img src="/images/socialmedia/64x64/facebook.png" /></a>
<a href="https://news.ycombinator.com/" target="_blank" rel="nofollow"><img src="/images/socialmedia/64x64/hackernews.png" /></a>
<a href="https://www.howtoforge.com/feed" target="_blank"><img src="/images/socialmedia/64x64/rss.png" /></a>
</div>
</div>
</div>
<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Tutorial Info</p>
<div class="pairsJustified">
<dl class="discussionCount">
<dt>Author:</dt>
<dd><a href="/author/arvid+l/" rel="author">Arvid L</a></dd>
</dl>
<dl class="discussionCount">
<dt>Published:</dt>
<dd>Sep 26, 2022</dd>
</dl>
<dl class="discussionCount">
<dt>Tags:</dt>
<dd><a href="/tutorials/linux/" rel="tag">linux</a>, <a href="/tutorials/ubuntu/" rel="tag">ubuntu</a></dd>
</dl>
</div>
</div>
</div>

<div id="sponsor-banner">
</div>

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent">
<p class="mnuinfo mnushare">Share This Page</p>
<p style="text-align:center;">
<a href="javascript:window.open(&#39;https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-sonarqube-on-ubuntu-22-04%2F&#39;, &#39;_blank&#39;, &#39;status=1,height=500,width=360,resizable=0&#39;);void(0);"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="javascript:window.open(&#39;https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-sonarqube-on-ubuntu-22-04%2F&amp;text=How+to+Install+SonarQube+on+Ubuntu+22.04&amp;via=howtoforgecom&amp;related=howtoforgecom&#39;, &#39;_blank&#39;, &#39;status=1,height=500,width=360,resizable=0&#39;);void(0);"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="javascript:window.open(&#39;https://news.ycombinator.com/submitlink?t=How+to+Install+SonarQube+on+Ubuntu+22.04&amp;u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-sonarqube-on-ubuntu-22-04%2F&#39;, &#39;_blank&#39;, &#39;status=1,height=500,width=360,resizable=0&#39;);void(0);"><img src="/images/socialmedia/btn-hackernews.png" height="20" /></a>
</p>
<p style="color:#EE; font-weight:bold; text-align:center; margin-top:5px;">40.2k Followers</p>
</div>
</div>
</div>


<script type="text/javascript">
    google_ad_client = "ca-pub-3043223216276099";
    google_ad_slot = "6709042890";
    google_ad_width = 300;
    google_ad_height = 600;
</script>

<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>


<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Popular Tutorials</p>
<div class="pairsJustified">
<ul>
<li><a href="/intrusion_detection_with_ossec_hids">Securing Your Server With A Host-based Intrusion Detection System</a></li>
<li><hr /></li>
<li><a href="/tutorial/ispconfig-multiserver-setup-debian-ubuntu/">ISPConfig Perfect Multiserver setup on Ubuntu 20.04 and Debian 10</a></li>
<li><hr /></li>
<li><a href="/how-to-install-tig-stack-telegraf-influxdb-and-grafana-on-ubuntu-22-04/">How to Install TIG Stack (Telegraf, InfluxDB, and Grafana) on Ubuntu 22.04</a></li>
<li><hr /></li>
<li><a href="/tutorial/perfect-server-centos-7-apache-mysql-php-pureftpd-postfix-dovecot-and-ispconfig/">The Perfect Server CentOS 7.6 with Apache, PHP 7.2, Postfix, Dovecot, Pure-FTPD, BIND and ISPConfig 3.1</a></li>
<li><hr /></li>
<li><a href="/how-to-install-yourls-on-centos-8/">How to Install YOURLS self-hosted URL shortener on CentOS 8</a></li>
<li><hr /></li>
<li><a href="/how-to-install-vtiger-crm-open-source-edition-on-debian-11/">How to Install vTiger CRM Open Source Edition on Debian 11</a></li>
<li><hr /></li>
<li><a href="/how-to-install-prestashop-with-apache-and-lets-encrypt-ssl-on-debian-11/">How to Install Prestashop with Apache and Let&#39;s Encrypt SSL on Debian 11</a></li>
<li><hr /></li>
<li><a href="/how-to-install-neos-cms-on-debian-11/">How to Install Neos CMS on Debian 11</a></li>
<li><hr /></li>
<li><a href="/how-to-install-vnc-server-on-rocky-linux/">How to Install VNC Server on Rocky Linux</a></li>
<li><hr /></li>
<li><a href="/getting-started-with-podman-manage-images-container-and-volumes/">Getting Started with Podman: Manage Images, Containers and Volumes</a></li>
<li><hr /></li>
</ul>
</div>
</div>
</div>
</div>
</div>
</aside>
</div>
</div>
</div>
<footer>
<div class="footer">
<div class="pageWidth">
<div class="pageContent">
<div class="skin_branding"><span>Xenforo skin by <a href="http://www.xenfocus.com" rel="nofollow">Xenfocus</a></span></div>
<ul class="footerLinks">
<li><a href="/contribute/">Contribute</a></li>
<li><a href="https://forum.howtoforge.com/misc/contact">Contact</a></li>
<li><a href="https://forum.howtoforge.com/help/">Help</a></li>
<li><a href="/imprint/">Imprint and Legal Notice</a></li>
<li><a href="#navigation" class="topLink">Top</a></li>
<li><a href="/feed" rel="alternate" class="globalFeed" target="_blank" title="RSS-Feed for Howtoforge">RSS-Feed</a></li>
</ul>
<span class="helper"></span>
</div>
</div>
</div>
<div class="footerLegal">
<div class="pageWidth">
<div class="pageContent">
<ul id="legal">
<li><a href="https://forum.howtoforge.com/help/terms">Terms and Rules</a> <a href="https://forum.howtoforge.com/help/privacy-policy">Privacy Policy</a></li>
</ul>
<div id="copyright"><a href="https://www.howtoforge.com" class="concealed">Howtoforge <span>© projektfarm GmbH.</span></a></div>
<span class="helper"></span>
</div>
</div>
</div>
</footer>
<div style="height:100px;"></div>

<div id="subscriptionModal" class="modal">
<div class="modal-content">
<span class="close">×</span>
<p>This feature is only available to subscribers. Get your subscription <a href="/subscription">here</a>.</p>
</div>
</div>
<script>
//* Modal
var modal = document.getElementById('subscriptionModal');
var span = document.getElementsByClassName("close")[0];
$(".pdf-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
$(".print-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
span.onclick = function() {
	$("#subscriptionModal").css('display', 'none');
}
window.onclick = function(event) {
    if (event.target == modal) {
		$("#subscriptionModal").css('display', 'none');
    }
}
//* Xenforo
jQuery.extend(true, XenForo,
{
	visitor: { user_id: 0 },
	serverTimeInfo:
	{
		now: 1409831907,
		today: 1409781600,
		todayDow: 4
	},
	_lightBoxUniversal: "0",
	_enableOverlays: "1",
	_animationSpeedMultiplier: "1",
	_overlayConfig:
	{
		top: "10%",
		speed: 200,
		closeSpeed: 100,
		mask:
		{
			color: "rgb(0, 0, 0)",
			opacity: "0.6",
			loadSpeed: 200,
			closeSpeed: 100
		}
	},
	_ignoredUsers: [],
	_loadedScripts: {"node_list":true,"node_category":true,"node_forum":true,"sidebar_share_page":true,"wf_default":true,"bbm_buttons":true,"login_bar":true,"twitter":true},
	_cookieConfig: { path: "/", domain: "", prefix: "xf_"},
	_csrfToken: "",
	_csrfRefreshUrl: "https://forum.howtoforge.com/login/csrf-token-refresh",
	_jsVersion: "303ae0ca"
});
jQuery.extend(XenForo.phrases,
{
	cancel: "Cancel",

	a_moment_ago:    "A moment ago",
	one_minute_ago:  "1 minute ago",
	x_minutes_ago:   "%minutes% minutes ago",
	today_at_x:      "Today at %time%",
	yesterday_at_x:  "Yesterday at %time%",
	day_x_at_time_y: "%day% at %time%",

	day0: "Sunday",
	day1: "Monday",
	day2: "Tuesday",
	day3: "Wednesday",
	day4: "Thursday",
	day5: "Friday",
	day6: "Saturday",

	_months: "January,February,March,April,May,June,July,August,September,October,November,December",
	_daysShort: "Sun,Mon,Tue,Wed,Thu,Fri,Sat",

	following_error_occurred: "The following error occurred",
	server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
	logging_in: "Logging in",
	click_image_show_full_size_version: "Click this image to show the full-size version.",
	show_hidden_content_by_x: "Show hidden content by {names}"
});

// Facebook Javascript SDK
XenForo.Facebook.appId = "";
XenForo.Facebook.forceInit = true;

/*
document.addEventListener('DOMContentLoaded', function(event) {
  cookieChoices.showCookieConsentBar('Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.',
  'OK');
});
*/

$(document).ready(function() {
	$("a.fancybox").fancybox();
});

</script>

<script>
_bsa.init('custom', 'CKYD55QU', 'placement:howtoforge',
    {
      target: '#sponsor-banner',
      template: `
<a href="##link##" style="background: linear-gradient(-330deg, ##backgroundColor##D9, ##backgroundColor##D9 30%, ##backgroundColor## 70%) #fff;" class="native-banner">
<img class="native-img" src="##logo##">
<div style="color: ##textColor##" class="native-tagline">##tagline##</div>
<div style="color: ##textColor##" class="native-desc">##description##</div>
<div style="color: ##ctaTextColor##; background-color: ##ctaBackgroundColor##;" class="native-cta">##callToAction##</div>
<div style="background-color: ##textColor##B2; color: ##backgroundColor##" class="native-ad">Ad</div>
</a>
`
    }
  );
</script>

<script>
(function() {
  if (typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('fancybar', 'CKYDL27E', 'placement:howtoforgecom');
  }
})();
</script>
<script>
(function() {
  if (typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('custom', 'CEBDK2JM', 'placement:howtoforgecom', {
      target: '.bsa-apiads',
      template:
`
<a href="##statlink##" target="_blank" rel="sponsored nofollow">##company## — ##description##</a>
`
    });
  }
})();
</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2155872-1', 'auto');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');

</script>
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('/detroitchicago/edmonton.webp', '/detroitchicago/edmonton.webp?a=a&cb=2&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('/porpoiseant/jellyfish.webp', '/porpoiseant/jellyfish.webp?a=a&cb=2&shcb=34', false, [], true, false, false, false);
</script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=2&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script>
<script type="text/javascript" data-cfasync="false"></script>
<script>var _audins_dom="howtoforge_com",_audins_did=178704;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=195-2");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.howtoforge_com,DomainId.178704" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script>__ez.queue.addFile('/beardeddragon/drake.js', '/beardeddragon/drake.js?gcb=2&cb=4', false, [], true, false, true, false);</script></body></html>