<!DOCTYPE html>
<html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs LoggedOut Sidebar Responsive" xmlns:fb="http://www.facebook.com/2008/fbml">
<head>
<meta charset="utf-8" />
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<base href="https://www.howtoforge.com" />
<script>
			var _b = document.getElementsByTagName('base')[0], _bH = "https://www.howtoforge.com/how-to-install-pagekit-cms-on-debian-9/";
			if (_b && _b.href != _bH) _b.href = _bH;
		</script>
<title>How to Install Pagekit CMS on Debian 9</title>
<meta name="description" content="Pagekit is modern, intuitive, modular, and flexible open source (MIT license) CMS built with Symfony components and Vue.js. In this tutorial, we will ... " />
<meta property="og:title" content="How to Install Pagekit CMS on Debian 9">
<meta property="og:description" content="Pagekit is modern, intuitive, modular, and flexible open source (MIT license) CMS built with Symfony components and Vue.js. In this tutorial, we will ... ">
<meta property="og:site_name" content="HowtoForge">
<meta property="og:type" content="article">
<meta property="og:image" content="https://www.howtoforge.com/images/featured/debian-pagekit-cms.jpg">
<meta property="og:image:secure_url" content="https://www.howtoforge.com/images/featured/debian-pagekit-cms.jpg" />
<meta property="og:image:alt" content="How to Install Pagekit CMS on Debian 9" />
<meta name="twitter:image" content="https://www.howtoforge.com/images/featured/debian-pagekit-cms.jpg" />
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="@howtoforgecom">
<meta name="twitter:creator" content="@howtoforgecom">
<meta name="twitter:title" content="How to Install Pagekit CMS on Debian 9">
<meta name="twitter:description" content="Pagekit is modern, intuitive, modular, and flexible open source (MIT license) CMS built with Symfony components and Vue.js. In this tutorial, we will ... ">
<link rel="alternate" href="https://www.howtoforge.com/how-to-install-pagekit-cms-on-debian-9/" hreflang="en" />
<link rel="canonical" href="https://www.howtoforge.com/tutorial/how-to-install-pagekit-cms-on-debian-9/" />
<link rel="amphtml" href="https://www.howtoforge.com/how-to-install-pagekit-cms-on-debian-9/amp/" />
<script type="application/ld+json">
{
  "@context" : "http://schema.org",
  "@type" : "Article",
  "name" : "How to Install Pagekit CMS on Debian 9",
  "author" : {
    "@type" : "Person",
    "name" : "Blago Eres"
  },
  "articleSection" : "debian,php,web server",
  "url" : "https://www.howtoforge.com/how-to-install-pagekit-cms-on-debian-9/",
  "publisher" : {
    "@type" : "Organization",
    "name" : "Howtoforge"
  }
}
</script>
<noscript><style>.JsOnly, .jsOnly { display: none !important; }</style></noscript>
<link rel="stylesheet" href="/community/styles/executive/xenfocus/icons/css/font-awesome.min.css" />
<link href='//fonts.googleapis.com/css?family=Open+Sans:400,700' rel='stylesheet' type='text/css' />
<link href="/themes/howtoforge/templates/xf.css" rel="stylesheet">
<script src="/js/jquery/jquery-1.11.3.min.js"></script>
<script src="/community/js/xenforo/xenforo.js?_v=303ae0ca"></script>
<script src="/community/js/bbm/zloader.js?_v=303ae0ca"></script>
<script type="text/javascript" src="/js/fancybox/jquery.mousewheel-3.0.4.pack.js"></script>
<script type="text/javascript" src="/js/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
<link rel="stylesheet" type="text/css" href="/js/fancybox/jquery.fancybox-1.3.4.css" media="screen" />
<link href="/themes/howtoforge/templates/style.min.css" rel="stylesheet">
<link rel="alternate" type="application/rss+xml" title="RSS-Feed für Howtoforge" href="/feed.rss" />
<script src="/js/tinymce_4.1.7/tinymce.min.js"></script>

<script type="text/javascript">
var gaProperty = 'UA-2155872-1';
var disableStr = 'ga-disable-' + gaProperty;
if (document.cookie.indexOf(disableStr + '=true') > -1) {
window[disableStr] = true;
}
function gaOptout() {
document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
window[disableStr] = true;
alert('Google Ananlyitics tracking has been disabled in this browser.');
}
</script>
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
	googletag.defineSlot('/1030080/howtoforge_com_list_sidebar_top', [300, 250], 'div-gpt-ad-1527185271042-4').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_list_content_middle', [[300, 250], [336, 280]], 'div-gpt-ad-1527185271042-5').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_a_300x250', [300, 250], 'div-gpt-ad-1527185271042-6').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_b_300x250', [300, 250], 'div-gpt-ad-1527185271042-7').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_leaderboard_b_728x90', [728, 90], 'div-gpt-ad-1527185271042-1').addService(googletag.pubads());
	googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-3043223216276099",
          enable_page_level_ads: true
     });
</script>


<script type="text/javascript">
    window.cookieconsent_options = {"message":"This website uses cookies to ensure you get the best experience on our website, analyze site traffic and show you relevant ads.","dismiss":"Got it!","learnMore":"More info","link":"https://www.howtoforge.com/community/help/cookies","theme":"dark-bottom"};
</script>
<script type="text/javascript" src="/js/cookieconsent.latest.min.js"></script>

</head>
<body>
<div id="loginBar">
<div class="pageWidth">
<div class="pageContent">
<h3 id="loginBarHandle">
<label for="LoginControl"><a href="/community/login/" class="concealed noOutline">Log in or Sign up</a></label>
</h3>
<span class="helper"></span>
</div>
</div>
</div>
<header>
<div id="header">
<div id="logoBlock">
<div class="pageWidth">
<div class="pageContent">
<div id="logo"><a href="/">
<span></span>
<img src="/images/howtoforge_logo_trans.gif" alt="Howtoforge" style="margin-left:20px;" />
</a></div>
<span class="helper"></span>
</div>
</div>
</div>
<div id="navigation" class="pageWidth withSearch">
<div class="pageContent">
<nav>
<div class="navTabs">
<ul class="publicTabs">

<li class="navTab forums selected">
<a href="/" class="navLink">Tutorials</a>
<div class="tabLinks forumsTabLinks">
<ul class="secondaryContent blockLinksList">
<li><a href="/search/">Tutorial search</a></li>
</ul>
</div>
</li>
<li class="navTab forums PopupClosed">
<a href="/tutorials/" class="navLink">Tags</a>
</li>
<li class="navTab forums PopupClosed"><a href="/community/" class="navLink">Forums</a></li>
<li class="navTab forums PopupClosed"><a href="/linux-commands/" class="navLink">Linux Commands</a></li>
<li class="navTab forums PopupClosed"><a href="/subscription/" class="navLink">Subscribe</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.ispconfig.org" class="navLink">ISPConfig</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.lxer.com" class="navLink">News</a></li>
</ul>
</div>
<span class="helper"></span>
</nav>
</div>
</div>
<div id="searchBar" class="pageWidth">
<span id="QuickSearchPlaceholder" title=" Search..."> Search</span>
<fieldset id="QuickSearch">
<form action="/" method="post" class="formPopup">
<div class="primaryControls">

<input type="search" name="q" value="" class="textCtrl" placeholder="Search..." results="0" title="Enter your search and hit enter..." id="QuickSearchQuery" />

</div>
<input type="hidden" name="_xfToken" value="" />
</form>
</fieldset>
</div>
</div>
</header>
<div id="content" class="forum_list">
<div class="pageWidth">
<div class="pageContent">

<div class="mainContainer">
<div class="mainContent">

<div class="breadBoxTop">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Home</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/how-to-install-pagekit-cms-on-debian-9/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to Install Pagekit CMS on Debian 9</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>

<div id="htfContentPage">
<div class="bsa-apiads"><a href="//srv.buysellads.com/ads/click/x/GTND42QMCT7DPKQEC6Y4YKQMCWYDCK3MF6AIPZ3JCWBITK3UF6YIK5QKC6BIPK3LCVADVK3EHJNCLSIZ" target="_blank" rel="nofollow">Quick. Proactive. Iterative. Atlassian’s collaboration software transforms how IT teams work together to deliver more.</a><img src="https://ad.doubleclick.net/ddm/trackimp/N320202.452584BUYSELLADS.COM/B22262741.239060420;dc_trk_aid=436621665;dc_trk_cid=103135774;ord=[1550230716];dc_lat=;dc_rdid=;tag_for_child_directed_treatment=;tfua=?" height="1" width="1" border="0" style="display:none;" /></div>
<article>
<h1>How to Install Pagekit CMS on Debian 9</h1>
<div class="contributeEdit" style="float:right; width:450px; max-width:100%;">
<div id="tocContainer">
<h3>On this page</h3>
<ol class="toc">
<li><a href="#requirements">Requirements</a></li>
<li><a href="#prerequisites" class="header-scroll is-api-header">Prerequisites</a></li>
<li><a href="#initial-steps">Initial steps</a></li>
<li><a href="#step-install-php-and-necessary-php-extensions">Step 1 - Install PHP and necessary PHP extensions</a></li>
<li><a href="#step-installnbspmariadbnbspand-create-a-database-fornbspoctober">Step 2 - Install&nbsp;MariaDB&nbsp;and create a database for&nbsp;Pagekit</a></li>
<li><a href="#step-install-acmesh-client-and-obtain-lets-encrypt-certificate-optional">Step 3 - Install Acme.sh client and obtain Let's Encrypt certificate (optional)</a></li>
<li><a href="#step-install-nginx-and-configure-nginx-for-matomo">Step&nbsp;4 - Install NGINX and configure NGINX for&nbsp;Pagekit</a></li>
<li><a href="#step-install-and-configurenbspnginx">Step 5 - Download and install&nbsp;Pagekit CMS</a></li>
<li><a href="#step-complete-the-cachet-setup">Step 6 - Complete the&nbsp;Pagekit setup</a></li>
<li><a href="#step-complete-the-cachet-setup-2">Links</a></li>
</ol>
</div>
</div>
<p>Pagekit is modern, intuitive, modular, and flexible open source (<span>MIT license</span>) CMS&nbsp;<span><span>built with Symfony components and Vue.js.&nbsp;<span>It gives you the tools to create beautiful websites. It has a rich theme and plugin ecosystem.&nbsp;</span></span></span></p>
<p><span><span><span><span>In this tutorial, we will walk you through the&nbsp;Pagekit CMS installation process on a Debian 9 (stretch) operating system&nbsp;</span><span>by using&nbsp;<span>NGINX</span><span>&nbsp;</span>as a web server, MariaDB&nbsp;as a database server, and&nbsp;optionally you can secure transport layer by using acme.sh client and Let's Encrypt certificate authority to add SSL support.</span></span></span></span></p>
<h2 id="requirements">Requirements</h2>
<p>To install Pagekit, make sure your server meets the following requirements:</p>
<ul>
<li>Apache version 2.2 or greater or NGINX web server.&nbsp;</li>
<li>MySQL version 5.1 or greater or SQLite 3.</li>
<li>PHP version 5.5.9 or greater.</li>
<li>Required PHP extensions: JSON, Session, ctype, Tokenizer, SimpleXML, DOM, mbstring, PCRE 8.0+, ZIP and PDO with MySQL or SQLite drivers.</li>
<li>Optional PHP extensions: cURL, iconv and XML Parser, as well as APC or XCache for caching.</li>
</ul>
<h2 id="prerequisites" class="header-scroll is-api-header">Prerequisites</h2>
<ul>
<li>A system running Debian 9 (stretch).</li>
<li><span>A non-root user with sudo privileges.</span></li>
</ul>
<h2 id="initial-steps">Initial steps</h2>
<p><span>Check&nbsp;your&nbsp;Debian system version:</span></p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;">

<div id='div-gpt-ad-1527185271042-6' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-6'); });
</script>
</div>
</div>
<pre class="command"><code spellcheck="false">lsb_release -ds<br /># Debian GNU/Linux 9.7 (stretch)</code></pre>
<p>Set up the timezone:</p>
<pre class="command"><code spellcheck="false">dpkg-reconfigure tzdata</code></pre>
<p>Update your operating system packages (software). This is an important first step because it ensures you have the latest updates and security fixes for your operating system's default software packages:</p>
<pre class="command"><code spellcheck="false">apt update &amp;&amp; apt upgrade -y</code></pre>
<p>Install some essential packages that are&nbsp;necessary for basic administration of the Debian&nbsp;operating system:</p>
<pre class="command"><code spellcheck="false">apt install -y curl wget vim git&nbsp;sudo unzip socat bash-completion dirmngr apt-transport-https</code></pre>
<h2 id="step-install-php-and-necessary-php-extensions">Step 1 - Install PHP and necessary PHP extensions</h2>
<p><span>Pagekit&nbsp;CMS platform requires PHP version 7.0 or greater. By default Debian 9 has PHP version 7.0 in its default software repositories which is fine for October CMS.&nbsp;</span></p>
<p>Download and install PHP 7.0 and required PHP extensions:</p>
<pre class="command"><code spellcheck="false">sudo apt install -y php7.0 php7.0-cli php7.0-fpm php7.0-common php7.0-mbstring php7.0-zip php7.0-mysql php7.0-sqlite3 php7.0-curl php7.0-xml</code></pre>
<p>To show PHP compiled in modules, you can run:</p>
<pre class="command"><code spellcheck="false"><span>php -m<br /><br />ctype<br />curl<br />exif<br />fileinfo<br />. . .<br />. . .</span></code></pre>
<p>Check PHP version:</p>
<pre class="command"><code spellcheck="false">php --version<br /># PHP 7.0.33-0+deb9u1 (cli) (built: Dec 7 2018 11:36:49) ( NTS )<br /># Copyright (c) 1997-2017 The PHP Group<br /># Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies<br />#     with Zend OPcache v7.0.33-0+deb9u1, Copyright (c) 1999-2017, by Zend Technologies</code></pre>
<p><span>PHP-FPM service is automatically started and enabled on reboot on&nbsp;Debian 9 system, so there is no need to start and enable it manually.&nbsp;</span><span>We can move on to the next step, which is the database installation and setup.</span></p>
<h2 id="step-installnbspmariadbnbspand-create-a-database-fornbspoctober">Step 2 - Install&nbsp;MariaDB&nbsp;and create a database for&nbsp;Pagekit</h2>
<p><span>Pagekit CMS supports MySQL, MariaDB and SQLite databases.&nbsp;<span>Debian team replaced MySQL with MariaDB as the default database from Debian 9 (stretch), so in&nbsp;</span></span><span>this tutorial,&nbsp;we will use&nbsp;MariaDB as the database server. If you want to install original MySQL you can add and use official MySQL repository maintained by Oracle.</span></p>
<p><span>Install&nbsp;MariaDB version 10.2 database server from the official MariaDB repo:</span></p>
<pre class="command"><code spellcheck="false"><span>sudo apt install -y software-properties-common dirmngr apt-transport-https</span><br /><span>sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 0xF1656F24C74CD1D8</span><br />sudo add-apt-repository 'deb [arch=amd64,i386,ppc64el] https://mirrors.nxthost.com/mariadb/repo/10.2/debian stretch main'<br />sudo apt update<br />sudo apt install -y mariadb-server<br /></code></pre>
<p><strong>NOTE</strong>: Y<em>ou will be prompted for root user password. Enter strong password and continue.</em></p>
<p>Check the MariaDB version:</p>
<pre class="command"><code spellcheck="false">mysql --version<br />#&nbsp;mysql&nbsp; Ver 15.1 Distrib 10.2.22-MariaDB, for debian-linux-gnu (x86_64) using readline 5.2</code></pre>
<p>Run<span>&nbsp;</span><code>mysql_secure installation</code><span>&nbsp;</span>script to improve MariaDB security and set the password for MariaDB<span>&nbsp;</span><code>root</code><span>&nbsp;</span>user:</p>
<pre class="command"><code spellcheck="false">sudo mysql_secure_installation</code></pre>
<p>Answer each of the questions:</p>
<pre><code spellcheck="false"><code spellcheck="false"><code spellcheck="false">Enter current password for root (enter for none): <strong>Press Enter</strong><br />Set root password? [Y/n] <strong>Y</strong><br />New password: <strong>your_secure_password</strong><br />Re-enter new password:&nbsp;<span><strong>your_secure_password</strong><br /></span>Remove anonymous users? [Y/n] <strong>Y</strong><br />Disallow root login remotely? [Y/n] <strong>Y</strong><br />Remove test database and access to it? [Y/n] <strong>Y</strong><br />Reload privilege tables now? [Y/n] <strong>Y</strong></code></code></code></pre>
<p>Log into MariaDB as the root user:</p>
<pre class="command"><code spellcheck="false">sudo mysql -u root -p<br /># Enter password</code></pre>
<p>Create a MariaDB database and user that you will use for your installation of Pagekit, and remember the credentials:</p>
<pre class="command"><code spellcheck="false">CREATE DATABASE dbname;<br />GRANT ALL ON dbname.* TO 'username' IDENTIFIED BY 'password';<br />FLUSH PRIVILEGES;</code></pre>
<p>Exit from MariaDB shell:</p>
<pre class="command"><code spellcheck="false">quit</code></pre>
<h2 id="step-install-acmesh-client-and-obtain-lets-encrypt-certificate-optional">Step 3 - Install Acme.sh client and obtain Let's Encrypt certificate (optional)</h2>
<p><span>Securing your website with HTTPS is not necessary, but it is a good practice to secure your site traffic. In order to obtain an SSL certificate from Let's Encrypt we will use Acme.sh client. Acme.sh is a pure UNIX shell software for obtaining SSL certificates from Let's Encrypt with zero dependencies.&nbsp;</span></p>
<p><span><span>Download and install<span>&nbsp;acme.sh:</span></span></span></p>
<pre class="command"><code spellcheck="false">sudo su - root<br />git clone https://github.com/Neilpang/acme.sh.git<br />cd acme.sh<span>&nbsp;</span><br />./acme.sh --install --accountemail<span>&nbsp;</span><a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="463f29333419232b272f2a06233e272b362a236825292b">[email&#160;protected]</a><br />source ~/.bashrc<br />cd ~</code></pre>
<p>Check acme.sh&nbsp;version:</p>
<pre class="command"><code spellcheck="false">acme.sh --version<br /># v2.8.1</code></pre>
<p>Obtain<span>&nbsp;</span><strong>RSA</strong><span>&nbsp;</span>and<span>&nbsp;</span><strong>ECC/ECDSA</strong><span>&nbsp;</span>certificates for your&nbsp;domain/hostname:</p>
<pre class="command"><code spellcheck="false"># RSA 2048<br />acme.sh --issue&nbsp;<span>--standalone</span> -d example.com --keylength 2048<br /># ECDSA<br />acme.sh --issue --standalone -d example.com --keylength ec-256</code></pre>
<p><span>If you want fake certificates for testing you can add<span>&nbsp;</span></span><span><code>--staging</code></span><span>&nbsp;flag&nbsp;to the above commands.</span></p>
<p>To list your issued certs you can run:</p>
<pre class="command"><code spellcheck="false">acme.sh --list</code></pre>
<p>Create a&nbsp;directory&nbsp;to store your certs. We will use&nbsp;<code>/etc/letsencrypt</code>&nbsp;directory.</p>
<pre class="command"><code>mkdir -p /etc/letsencrypt/example.com<br />sudo mkdir -p /etc/letsencrypt/example.com_ecc</code></pre>
<p><span face="monospace">Install/copy certificates to</span><span face="monospace">&nbsp;</span><span face="monospace">/etc/letsencrypt</span><span face="monospace"></span><span face="monospace">&nbsp;</span><span face="monospace">directory</span><span face="monospace">.</span></p>
<pre class="command"><code># RSA<br />acme.sh --install-cert -d example.com \ <br />        --cert-file /etc/letsencrypt/example.com/cert.pem \<br />        --key-file /etc/letsencrypt/example.com/private.key \<br />        --fullchain-file /etc/letsencrypt/example.com/fullchain.pem \<br />        --reloadcmd "sudo systemctl reload nginx.service"<br /><br /># ECC/ECDSA<br />acme.sh --install-cert -d example.com --ecc \<br />        --cert-file /etc/letsencrypt/example.com_ecc/cert.pem \<br />        --key-file /etc/letsencrypt/example.com_ecc/private.key \<br />        --fullchain-file /etc/letsencrypt/example.com_ecc/fullchain.pem \<br />        --reloadcmd "sudo systemctl reload nginx.service"</code></pre>
<p>After running the above commands, your&nbsp;<em>certificates</em>&nbsp;and&nbsp;<em>keys</em>&nbsp;will be in:</p>
<ul>
<li>For<span>&nbsp;</span><strong>RSA</strong>:<span>&nbsp;/etc/letsencrypt</span><code>/example.com</code><span>&nbsp;</span>directory.</li>
<li>For<span>&nbsp;</span><strong>ECC/ECDSA</strong>:<span>&nbsp;/etc/letsencrypt</span><code>/example.com_ecc</code><span>&nbsp;</span>directory.</li>
</ul>
<p><span face="monospace">All the&nbsp;certificates will be automatically renewed every 60 days.</span></p>
<p>After obtaining certs, exit from root user and return back to normal sudo user:</p>
<pre class="command"><code spellcheck="false">exit</code></pre>
<h2 id="step-install-nginx-and-configure-nginx-for-matomo">Step&nbsp;4 - Install NGINX and configure NGINX for&nbsp;Pagekit</h2>
<p>Install&nbsp;NGINX web server:</p>
<pre class="command"><code spellcheck="false">sudo apt install -y nginx</code></pre>
<p>Check the NGINX version:</p>
<pre class="command"><code spellcheck="false">sudo nginx -v<br /># nginx version: nginx/1.10.3</code></pre>
<p>Configure&nbsp;<span>NGINX</span><span>&nbsp;</span>for&nbsp;Pagekit by running:</p>
<pre class="command"><code spellcheck="false">sudo vim /etc/nginx/sites-available/pagekit.conf<br /></code></pre>
<p><span>And populate the file with the following configuration:</span></p>
<pre><code>server {<br />    listen [::]:443 ssl http2;<br />    listen 443 ssl http2;
    listen [::]:80;
    listen 80;
    
    server_name example.com;
    
    index index.php index.html;
    root /var/www/pagekit;<br />
    ssl_certificate /etc/letsencrypt/example.com/fullchain.pem;<br />    ssl_certificate_key /etc/letsencrypt/example.com/private.key;<br />    ssl_certificate /etc/letsencrypt/example.com_ecc/fullchain.pem;<br />    ssl_certificate_key /etc/letsencrypt/example.com_ecc/private.key;<br />
    location / {
        try_files $uri $uri/ /index.php?$query_string;
    }<br /><br />    location ~ \.php$ {<br />        include snippets/fastcgi-php.conf;<br />        fastcgi_pass unix:/var/run/php/php7.0-fpm.sock;<br />    }
    
}</code></pre>
<p>Activate the new<span>&nbsp;</span><code>pagekit.conf</code><span>&nbsp;</span>configuration by linking the file to the<span>&nbsp;</span><code>sites-enabled</code><span>&nbsp;</span>directory.</p>
<pre class="command"><code spellcheck="false"><span>sudo ln -s /etc/nginx/sites-available/pagekit.conf /etc/nginx/sites-enabled</span></code></pre>
<p><span>Check&nbsp;<span>NGINX</span><span>&nbsp;</span>configuration for syntax errors:</span></p>
<pre class="command"><code spellcheck="false"><span>sudo nginx -t</span></code></pre>
<p><span>Reload&nbsp;<span>NGINX</span><span>&nbsp;</span>service:</span></p>
<pre class="command"><code spellcheck="false">sudo systemctl reload nginx.service</code></pre>
<h2 id="step-install-and-configurenbspnginx">Step 5 - Download and install&nbsp;Pagekit CMS</h2>
<p><span>Create a document root directory where Pagekit should reside in:</span></p>
<pre class="command"><code spellcheck="false">sudo mkdir -p /var/www/pagekit<br /></code></pre>
<p>Change ownership of the<span>&nbsp;</span><code>/var/www/pagekit</code><span>&nbsp;</span>directory to<span>&nbsp;</span><code>[your_user]:</code></p>
<pre class="command"><code spellcheck="false">sudo chown -R [your_user]:[your_user] /var/www/pagekit</code></pre>
<p>Navigate to document root:</p>
<pre class="command"><code spellcheck="false">cd /var/www/pagekit</code></pre>
<p><span>Download the latest stable release of Pagekit CMS via <code>wget</code>:</span></p>
<pre class="command"><code spellcheck="false">wget https://github.com/pagekit/pagekit/releases/download/1.0.16/pagekit-1.0.16.zip</code></pre>
<p>Unpack&nbsp;Pagekit CMS content and remove downloaded <code>.zip</code> file.</p>
<pre class="command"><code spellcheck="false">unzip pagekit-1.0.16.zip<br />rm pagekit-1.0.16.zip</code></pre>
<p>Change ownership of the<span>&nbsp;</span><code>/var/www/pagekit</code><span>&nbsp;</span>directory to<span>&nbsp;</span><code>www-data</code>.</p>
<pre class="command"><code spellcheck="false">sudo chown -R www-data:www-data /var/www/pagekit</code></pre>
<h2 id="step-complete-the-cachet-setup">Step 6 - Complete the&nbsp;Pagekit setup</h2>
<p>Open your site in a web browser and you should see the following page:</p>
<p style="text-align: center;"><a class="fancybox" id="img-Screenshot_2019-02-12_at_07.55_.04_1" href="https://www.howtoforge.com/images/how_to_install_pagekit_cms_on_debian_9/big/Screenshot_2019-02-12_at_07.55_.04_1.png"><img src="https://www.howtoforge.com/images/how_to_install_pagekit_cms_on_debian_9/Screenshot_2019-02-12_at_07.55_.04_1.png" alt="Pagekit web installer" width="550" height="316" /></a></p>
<p style="text-align: left;">Click on the right arrow icon to&nbsp;proceed with the installation. Choose your language and click "Next" button:</p>
<p style="text-align: center;"><a class="fancybox" id="img-Screenshot_2019-02-12_at_07.55_.15_1" href="https://www.howtoforge.com/images/how_to_install_pagekit_cms_on_debian_9/big/Screenshot_2019-02-12_at_07.55_.15_1.png"><img src="https://www.howtoforge.com/images/how_to_install_pagekit_cms_on_debian_9/Screenshot_2019-02-12_at_07.55_.15_1.png" alt="Choose language" width="550" height="316" /></a></p>
<p style="text-align: left;">Next, choose you database either SQLite or MySQL and populate required fields and click "Next" button:</p>
<p style="text-align: left;"></p>
<p style="text-align: center;"><a class="fancybox" id="img-Screenshot_2019-02-12_at_07.55_.32_1" href="https://www.howtoforge.com/images/how_to_install_pagekit_cms_on_debian_9/big/Screenshot_2019-02-12_at_07.55_.32_1.png"><img src="https://www.howtoforge.com/images/how_to_install_pagekit_cms_on_debian_9/Screenshot_2019-02-12_at_07.55_.32_1.png" alt="Connect to database" width="550" height="316" /></a></p>
<p style="text-align: left;">After that setup your site by entering Site Titel and creating admin user account:</p>
<p style="text-align: center;"><a class="fancybox" id="img-Screenshot_2019-02-12_at_07.55_.59_1" href="https://www.howtoforge.com/images/how_to_install_pagekit_cms_on_debian_9/big/Screenshot_2019-02-12_at_07.55_.59_1.png"><img src="https://www.howtoforge.com/images/how_to_install_pagekit_cms_on_debian_9/Screenshot_2019-02-12_at_07.55_.59_1.png" alt="Setup website" width="550" height="316" /></a></p>
<p style="text-align: left;">And that should be it. You will be redirected to Pagekit login page. Provide your username and password to log into Pagekit dashboard.</p>
<p style="text-align: center;"><a class="fancybox" id="img-Screenshot_2019-02-12_at_07.56_.29_1" href="https://www.howtoforge.com/images/how_to_install_pagekit_cms_on_debian_9/big/Screenshot_2019-02-12_at_07.56_.29_1.png"><img src="https://www.howtoforge.com/images/how_to_install_pagekit_cms_on_debian_9/Screenshot_2019-02-12_at_07.56_.29_1.png" alt="Log in to pagekit admin area" width="550" height="316" /></a></p>
<p style="text-align: left;">That's all. If you stuck, check out the official Pagekit docs.</p>
<h2 id="step-complete-the-cachet-setup">Links</h2>
<ul>
<li><a href="https://pagekit.com/">https://pagekit.com/</a></li>
<li><a href="https://github.com/pagekit/pagekit">https://github.com/pagekit/pagekit</a></li>
</ul>
</article>

<aside class="authorbox" style="margin-top:20px;">
<img src="/images/profile/blago_eres.png" alt="Blago Eres" /> <p><strong>About Blago Eres</strong></p>
<p>Blago Eres is a freelance Web Developer, Linux System Administrator and Technical Writer with more than 3 years of experience. Blago is skilled at RHEL/CentOS, Debian/Ubuntu, Web Servers, Database Servers, HTTP, PHP, JavaScript, Load Balancing, Caching etc.</p>
</aside>

<div style="height:30px; margin-top:20px;">
<p style="text-align:right;"><img src="/images/pdficon_small.png" /> <a class="pdf-btn" href="javascript:void(0);">view as pdf</a> | <img src="/images/print.gif" /> <a class="print-btn" href="javascript:void(0);">print</a></p>
</div>
<div style="height:30px; margin-top:20px;">
<div style="float:left;"><b>Share this page:</b></div>
<p style="text-align:center;">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-pagekit-cms-on-debian-9%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-pagekit-cms-on-debian-9%2F&text=How+to+Install+Pagekit+CMS+on+Debian+9&via=howtoforgecom&related=howtoforgecom" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-pagekit-cms-on-debian-9%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-gplus.png" height="20" /></a>
</p>
</div>
</div>


<div id="htfContentPagePaging">
<h2>Suggested articles</h2>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-3043223216276099" data-ad-slot="8940054090"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>


<div id="htfContentPageComment">
<a name="comments"></a>
<h2>0 Comment(s)</h2>

<div id="commentform">
<div class="commentContainerHead" style="font-size:18px;">Add comment</div>
<div class="commentContainer">
<form method="post" action="/how-to-install-pagekit-cms-on-debian-9/#comments">
<input type="hidden" name="reply_to" id="reply-to-comment" value="0" />
<div id="commentFormDetail">
<div style="width:48%; float:left; margin-right:3%">
<label for="commentname">Name *</label>
<input id="commentname" name="commentname" value="" />
</div>
<div style="width:48%;float:left;">
<label for="commentname">Email *</label>
<input id="commentemail" name="commentemail" value="" />
</div>
<div style="clear:both;"></div>
</div>
<textarea id="commentedit" name="commentedit" style="width:auto;"></textarea>
<div>
<div style="float:left;">
<div class="g-recaptcha" data-sitekey="6LdX9fUSAAAAALWwVoPdeXScMSketz4npF-0QcQ1"></div>
<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en">
      </script>
</div>
<div style="margin-top:10px;margin-bottom:10px;">
<input type="submit" name="submit" class="button primary" style="float:right;" value="Submit comment">
</div>
<div style="clear:both;"></div>
</div>
<script>
	tinymce.init({
		selector: "textarea#commentedit",
		theme: "modern",
		height: 100,
		apply_source_formatting : true,
		remove_linebreaks : false,
		menubar : false,
		/*auto_focus : "commentedit",*/
		plugins: [
		"link"
		],
		/*plugins: [
			"advlist autolink link image lists charmap print preview hr anchor pagebreak spellchecker",
			"searchreplace wordcount visualblocks visualchars code fullscreen insertdatetime media nonbreaking",
			"save table contextmenu directionality emoticons template paste textcolor"
		],*/
		content_css: "https://www.howtoforge.com/themes/howtoforge/css/custom.css",
		toolbar: "undo redo | bold italic link", 
		/*style_formats: [
			{title: 'Bold text', inline: 'b'},
			{title: 'Red text', inline: 'span', styles: {color: '#ff0000'}},
			{title: 'Red header', block: 'h1', styles: {color: '#ff0000'}},
			{title: 'Example 1', inline: 'span', classes: 'example1'},
			{title: 'Example 2', inline: 'span', classes: 'example2'},
			{title: 'Table styles'},
			{title: 'Table row 1', selector: 'tr', classes: 'tablerow1'}
		]*/
	}); 
	</script>
</form>
</div>
</div>

</div>

<div class="breadBoxBottom">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Home</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/how-to-install-pagekit-cms-on-debian-9/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to Install Pagekit CMS on Debian 9</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
<script>
<!--

$(document).on('click', 'a.reply-to', function(e) {
	e.preventDefault();
	
	var self = $(this);
	var cid = self.attr('data-comment');
	console.log(cid);
	if(!cid) return this;
	
	$('#commentform').insertAfter('#comment' + cid);
	$('#reply-to-comment').val(cid);
	/*tinyMCE.activeEditor.focus();*/
	var textareaId = 'commentedit';
	tinyMCE.get(textareaId).remove();
	tinyMCE.execCommand("mceAddEditor", false, textareaId);
	tinyMCE.activeEditor.focus();
});
//-->
</script>
<div style="margin-top:10px;margin-bottom:10px;text-align:center;">

<center>


<div id='div-gpt-ad-1527185271042-1' style='height:90px; width:728px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-1'); });
</script>
</div>

</center>
</div>


<form action="/community/login/login?redirect=/how-to-install-pagekit-cms-on-debian-9/" method="post" class="xenForm eAuth" id="login" style="display:none">
<ul id="eAuthUnit">
<li><a href="/community/register/facebook?reg=1" class="fbLogin" tabindex="110"><span>Log in with Facebook</span></a></li>
<li><a href="/community/register/twitter?reg=1" class="twitterLogin" tabindex="110"><span>Log in with Twitter</span></a></li>
<li><span class="googleLogin GoogleLogin JsOnly" tabindex="110" data-client-id="198773272284-b6tfk0c28bje81p774prrcrkq9jb3o44.apps.googleusercontent.com" data-redirect-url="/community/register/google?code=__CODE__&amp;csrf=hVMXbW_3rnrmq4Em"><span>Log in with Google</span></span></li>
</ul>
<div class="ctrlWrapper">
<dl class="ctrlUnit">
<dt><label for="LoginControl">Your name or email address:</label></dt>
<dd><input type="text" name="login" id="LoginControl" class="textCtrl" tabindex="101" /></dd>
</dl>
<dl class="ctrlUnit">
<dt>
<label for="ctrl_password">Do you already have an account?</label>
</dt>
<dd>
<ul>
<li><label for="ctrl_not_registered"><input type="radio" name="register" value="1" id="ctrl_not_registered" tabindex="105" />
No, create an account now.</label></li>
<li><label for="ctrl_registered"><input type="radio" name="register" value="0" id="ctrl_registered" tabindex="105" checked="checked" class="Disabler" />
Yes, my password is:</label></li>
<li id="ctrl_registered_Disabler">
<input type="password" name="password" class="textCtrl" id="ctrl_password" tabindex="102" />
<div class="lostPassword"><a href="/community/lost-password/" tabindex="106">Forgot your password?</a></div>
</li>
</ul>
</dd>
</dl>
<dl class="ctrlUnit submitUnit">
<dt></dt>
<dd>
<input type="submit" class="button primary" value="Log in" tabindex="104" data-loginPhrase="Log in" data-signupPhrase="Sign up" />
<label for="ctrl_remember" class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_remember" tabindex="103" /> Stay logged in</label>
</dd>
</dl>
</div>
<input type="hidden" name="cookie_check" value="1" />
<input type="hidden" name="redirect" value="/community/" />
<input type="hidden" name="_xfToken" value="" />
</form>

</div>
</div>

<aside>
<div class="sidebar">
<div class="section loginButton">
<div class="secondaryContent">
<label for="LoginControl" id="SignupButton"><a href="/community/login/" class="inner">Sign up now!</a></label>
</div>
</div>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-2">

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent socialMediaIcon">
<a href="https://twitter.com/howtoforgecom" target="_blank"><img src="/images/socialmedia/64x64/twitter.png" /></a>
<a href="https://www.facebook.com/howtoforge" target="_blank"><img src="/images/socialmedia/64x64/facebook.png" /></a>
<a href="https://plus.google.com/+howtoforge/posts" target="_blank"><img src="/images/socialmedia/64x64/googleplus.png" /></a>
<a href="https://www.howtoforge.com/feed" target="_blank"><img src="/images/socialmedia/64x64/rss.png" /></a>
</div>
</div>
</div>
<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Tutorial Info</p>
<div class="pairsJustified">
<dl class="discussionCount">
<dt>Author:</dt>
<dd><a href="/author/blago+eres/" rel="author">Blago Eres</a></dd>
</dl>
<dl class="discussionCount">
<dt>Published:</dt>
<dd>Feb 14, 2019</dd>
</dl>
<dl class="discussionCount">
<dt>Tags:</dt>
<dd><a href='/tutorials/debian/' rel='tag'>debian</a>, <a href='/tutorials/php/' rel='tag'>php</a>, <a href='/tutorials/web+server/' rel='tag'>web server</a></dd>
</dl>
</div>
</div>
</div>
<script src="//m.servedby-buysellads.com/monetization.js" type="text/javascript"></script>
<div class="native-sidebar"></div>
<script>
  (function(){
    if(typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('default', 'CKYD55QU', 'placement:howtoforge', {
      target: '.native-sidebar',
      align: 'horizontal',
      disable_css: 'true'
    });
      }
  })();
</script>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent">
<p class="mnuinfo mnushare">Share This Page</p>
<p style="text-align:center;">
<a href="javascript:window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-pagekit-cms-on-debian-9%2F', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="javascript:window.open('https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-pagekit-cms-on-debian-9%2F&text=How+to+Install+Pagekit+CMS+on+Debian+9&via=howtoforgecom&related=howtoforgecom', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="javascript:window.open('https://plus.google.com/share?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-pagekit-cms-on-debian-9%2F', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-gplus.png" height="20" /></a>
</p>
<p style="color:#EE; font-weight:bold; text-align:center; margin-top:5px;">40.2k Followers</p>
</div>
</div>
</div>


<script type="text/javascript">
    google_ad_client = "ca-pub-3043223216276099";
    google_ad_slot = "6709042890";
    google_ad_width = 300;
    google_ad_height = 600;
</script>

<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>


<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Popular Tutorials</p>
<div class="pairsJustified">
<ul>
<li><a href="/tutorial/linux-grep-command/">How to use grep to search for strings in files on the shell</a></li>
<li><hr /></li>
<li><a href="/how-to-setup-private-docker-registry-on-ubuntu-1804-lts/">How to Setup Private Docker Registry on Ubuntu 18.04 LTS</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-install-nextcloud-15-on-debian-9/">How to Install Nextcloud 15 on Debian 9</a></li>
<li><hr /></li>
<li><a href="/tutorial/perfect-server-ubuntu-18.04-with-apache-php-myqsl-pureftpd-bind-postfix-doveot-and-ispconfig/">The Perfect Server - Ubuntu 18.04 (Bionic Beaver) with Apache, PHP, MySQL, PureFTPD, BIND, Postfix, Dovecot and ISPConfig 3.1</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-use-ftp-on-the-linux-shell/">How to use the Linux ftp command to up- and download files on the shell</a></li>
<li><hr /></li>
<li><a href="/how-to-install-foreman-on-ubuntu-server-1804-lts/">How to Install Foreman Server Management Tool on Ubuntu 18.04 LTS</a></li>
<li><hr /></li>
<li><a href="/how-to-install-nodebb-forum-on-fedora-29/">How to Install NodeBB Forum on Fedora 29</a></li>
<li><hr /></li>
<li><a href="/tutorial/perfect-server-debian-9-stretch-apache-bind-dovecot-ispconfig-3-1/">The Perfect Server - Debian 9 (Stretch) with Apache, BIND, Dovecot, PureFTPD and ISPConfig 3.1</a></li>
<li><hr /></li>
<li><a href="/how-to-install-matomo-web-analytics-on-fedora-29/">How to Install Matomo Web Analytics on Fedora 29</a></li>
<li><hr /></li>
<li><a href="/how-to-install-cachet-status-page-system-on-ubuntu-1804-lts/">How to Install Cachet Status Page System on Ubuntu 18.04 LTS</a></li>
<li><hr /></li>
</ul>
</div>
</div>
</div>
</div>
</div>
</aside>
</div>
</div>
</div>
<footer>
<div class="footer">
<div class="pageWidth">
<div class="pageContent">
<div class='skin_branding'><span>Xenforo skin by <a href="http://www.xenfocus.com" rel="nofollow">Xenfocus</a></span></div>
<ul class="footerLinks">
<li><a href="/contribute/">Contribute</a></li>
<li><a href="/community/misc/contact">Contact</a></li>
<li><a href="/community/help/">Help</a></li>
<li><a href="/imprint/">Imprint and Legal Notice</a></li>
<li><a href="#navigation" class="topLink">Top</a></li>
<li><a href="/feed" rel="alternate" class="globalFeed" target="_blank" title="RSS-Feed for Howtoforge">RSS-Feed</a></li>
</ul>
<span class="helper"></span>
</div>
</div>
</div>
<div class="footerLegal">
<div class="pageWidth">
<div class="pageContent">
<ul id="legal">
<li><a href="/community/help/terms">Terms and Rules</a> <a href="https://www.howtoforge.com/community/help/privacy-policy">Privacy Policy</a></li>
</ul>
<div id="copyright"><a href="https://www.howtoforge.com" class="concealed">Howtoforge <span>&copy; projektfarm GmbH.</span></a></div>
<span class="helper"></span>
</div>
</div>
</div>
</footer>
<div style="height:100px;"></div>

<div id="subscriptionModal" class="modal">
<div class="modal-content">
<span class="close">&times;</span>
<p>This feature is only available to subscribers. Get your subscription <a href="/subscription">here</a>.</p>
</div>
</div>
<script>
//* Modal
var modal = document.getElementById('subscriptionModal');
var span = document.getElementsByClassName("close")[0];
$(".pdf-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
$(".print-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
span.onclick = function() {
	$("#subscriptionModal").css('display', 'none');
}
window.onclick = function(event) {
    if (event.target == modal) {
		$("#subscriptionModal").css('display', 'none');
    }
}
//* Xenforo
jQuery.extend(true, XenForo,
{
	visitor: { user_id: 0 },
	serverTimeInfo:
	{
		now: 1409831907,
		today: 1409781600,
		todayDow: 4
	},
	_lightBoxUniversal: "0",
	_enableOverlays: "1",
	_animationSpeedMultiplier: "1",
	_overlayConfig:
	{
		top: "10%",
		speed: 200,
		closeSpeed: 100,
		mask:
		{
			color: "rgb(0, 0, 0)",
			opacity: "0.6",
			loadSpeed: 200,
			closeSpeed: 100
		}
	},
	_ignoredUsers: [],
	_loadedScripts: {"node_list":true,"node_category":true,"node_forum":true,"sidebar_share_page":true,"wf_default":true,"bbm_buttons":true,"login_bar":true,"twitter":true},
	_cookieConfig: { path: "/", domain: "", prefix: "xf_"},
	_csrfToken: "",
	_csrfRefreshUrl: "/community/login/csrf-token-refresh",
	_jsVersion: "303ae0ca"
});
jQuery.extend(XenForo.phrases,
{
	cancel: "Cancel",

	a_moment_ago:    "A moment ago",
	one_minute_ago:  "1 minute ago",
	x_minutes_ago:   "%minutes% minutes ago",
	today_at_x:      "Today at %time%",
	yesterday_at_x:  "Yesterday at %time%",
	day_x_at_time_y: "%day% at %time%",

	day0: "Sunday",
	day1: "Monday",
	day2: "Tuesday",
	day3: "Wednesday",
	day4: "Thursday",
	day5: "Friday",
	day6: "Saturday",

	_months: "January,February,March,April,May,June,July,August,September,October,November,December",
	_daysShort: "Sun,Mon,Tue,Wed,Thu,Fri,Sat",

	following_error_occurred: "The following error occurred",
	server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
	logging_in: "Logging in",
	click_image_show_full_size_version: "Click this image to show the full-size version.",
	show_hidden_content_by_x: "Show hidden content by {names}"
});

// Facebook Javascript SDK
XenForo.Facebook.appId = "";
XenForo.Facebook.forceInit = true;

/*
document.addEventListener('DOMContentLoaded', function(event) {
  cookieChoices.showCookieConsentBar('Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.',
  'OK');
});
*/

$(document).ready(function() {
	$("a.fancybox").fancybox();
});

</script>

<script>
(function() {
  if (typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('fancybar', 'CKYDL27E', 'placement:howtoforgecom');
  }
})();
</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2155872-1', 'auto');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');

</script>
</body>
</html>