<!DOCTYPE html><html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs LoggedOut Sidebar Responsive" xmlns:fb="http://www.facebook.com/2008/fbml"><head><meta charset="utf-8" />
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>!function(){function e(i){return e="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e(i)}__ez.pel=function(){var i=[];function t(t,o,d,_,n,r,a,s){if(__ez.dot.isDefined(t)&&0!=__ez.dot.isAnyDefined(t.getSlotElementId,t.ElementId)){void 0===s&&(s=!1);var p=parseInt(__ez.dot.getTargeting(t,"ap")),f=__ez.dot.getSlotIID(t),u=__ez.dot.getAdUnit(t,s),z=parseInt(__ez.dot.getTargeting(t,"compid")),g=0,c=0,l=function(i){if("undefined"==typeof _ezim_d)return!1;var t=__ez.dot.getAdUnitPath(i).split("/").pop();if("object"===("undefined"==typeof _ezim_d?"undefined":e(_ezim_d))&&_ezim_d.hasOwnProperty(t))return _ezim_d[t];for(var o in _ezim_d)if(o.split("/").pop()===t)return _ezim_d[o];return!1}(t);"object"==e(l)&&(void 0!==l.creative_id&&(c=l.creative_id),void 0!==l.line_item_id&&(g=l.line_item_id)),__ez.dot.isDefined(f,u)&&__ez.dot.isValid(o)&&("0"===f&&!0!==s||""===u||i.push({type:"impression",impression_id:f,domain_id:__ez.dot.getDID(),unit:u,t_epoch:__ez.dot.getEpoch(0),revenue:d,est_revenue:_,ad_position:p,ad_size:"",bid_floor_filled:n,bid_floor_prev:r,stat_source_id:a,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:z,line_item_id:g,creative_id:c,data:__ez.dot.dataToStr(o),is_orig:s||__ez.template.isOrig}))}}function o(){void 0!==document.visibilityState&&"prerender"===document.visibilityState||(__ez.dot.isDefined(i)&&i.length>0&&[i.filter((function(e){return e.is_orig})),i.filter((function(e){return!e.is_orig}))].forEach((function(e){for(;e.length>0;){var i=e[0].is_orig||!1,t=5;t>e.length&&(t=e.length);var o=e.splice(0,t),d=__ez.dot.getURL("/porpoiseant/army.gif")+"?orig="+(!0===i?1:0)+"&sts="+btoa(JSON.stringify(o));(void 0!==window.isAmp&&isAmp||void 0!==window.ezWp&&ezWp)&&void 0!==window._ezaq&&_ezaq.hasOwnProperty("domain_id")&&(d+="&visit_uuid="+_ezaq.visit_uuid),__ez.dot.Fire(d)}})),i=[])}return{Add:t,AddAndFire:function(e,i){t(e,i,0,0,0,0,0),o()},AddAndFireOrig:function(e,i){t(e,i,0,0,0,0,0,!0),o()},AddById:function(e,t,o,d){var _=e.split("/");if(__ez.dot.isDefined(e)&&3===_.length&&__ez.dot.isValid(t)){var n=_[0],r={type:"impression",impression_id:_[2],domain_id:__ez.dot.getDID(),unit:n,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(t),is_orig:o||__ez.template.isOrig};void 0!==d&&(r.revenue=d),i.push(r)}},Fire:o,GetPixels:function(){return i}}}()}();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=195-2&cb=6', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=195-2&cb=5', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=195-2&cb=7', false, [], true, false, true, false);</script>
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<base href="https://www.howtoforge.com" />
<script>
			var _b = document.getElementsByTagName('base')[0], _bH = "https://www.howtoforge.com/how-to-install-ms-sql-server-on-rocky-linux/";
			if (_b && _b.href != _bH) _b.href = _bH;
		</script>
<title>How to Install and Use MS SQL Server on Rocky Linux</title>
<meta name="description" content="MS SQL Server or Microsoft SQL Server is an RDBMS (Relational Database Management System) developed by Microsoft. In this tutorial, I will show you ho... " />
<meta property="og:title" content="How to Install and Use MS SQL Server on Rocky Linux" />
<meta property="og:description" content="MS SQL Server or Microsoft SQL Server is an RDBMS (Relational Database Management System) developed by Microsoft. In this tutorial, I will show you ho... " />
<meta property="og:site_name" content="HowtoForge" />
<meta property="og:type" content="article" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@howtoforgecom" />
<meta name="twitter:creator" content="@howtoforgecom" />
<meta name="twitter:title" content="How to Install and Use MS SQL Server on Rocky Linux" />
<meta name="twitter:description" content="MS SQL Server or Microsoft SQL Server is an RDBMS (Relational Database Management System) developed by Microsoft. In this tutorial, I will show you ho... " />
<link rel="alternate" href="https://www.howtoforge.com/how-to-install-ms-sql-server-on-rocky-linux/" hreflang="en" />
<link rel="canonical" href="https://www.howtoforge.com/how-to-install-ms-sql-server-on-rocky-linux/" />
<link rel="amphtml" href="https://www.howtoforge.com/how-to-install-ms-sql-server-on-rocky-linux/amp/" />
<script type="application/ld+json">
{
  "@context" : "http://schema.org",
  "@type" : "Article",
  "name" : "How to Install and Use MS SQL Server on Rocky Linux",
  "author" : {
    "@type" : "Person",
    "name" : "Arvid L"
  },
  "articleSection" : "linux,server",
  "url" : "https://www.howtoforge.com/how-to-install-ms-sql-server-on-rocky-linux/",
  "publisher" : {
    "@type" : "Organization",
    "name" : "Howtoforge"
  }
}
</script>
<noscript><style>.JsOnly, .jsOnly { display: none !important; }</style></noscript>

<link rel="stylesheet" href="/themes/howtoforge/icons/css/font-awesome.min.css" />

<link href="/themes/howtoforge/fonts/opensans.css?family=Open+Sans:400,700" rel="stylesheet" type="text/css" />
<link href="/themes/howtoforge/templates/xf.css" rel="stylesheet" />
<script src="/js/jquery/jquery-1.11.3.min.js"></script>

<script src="/themes/howtoforge/js/xenforo/xenforo.js?_v=303ae0ca"></script>

<script src="/themes/howtoforge/js/bbm/zloader.js?_v=303ae0ca"></script>
<script type="text/javascript" src="/js/fancybox/jquery.mousewheel-3.0.4.pack.js"></script>
<script type="text/javascript" src="/js/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
<link rel="stylesheet" type="text/css" href="/js/fancybox/jquery.fancybox-1.3.4.css" media="screen" />
<link href="/themes/howtoforge/templates/style.min.css" rel="stylesheet" />
<link rel="alternate" type="application/rss+xml" title="RSS-Feed für Howtoforge" href="/feed.rss" />
<script src="/js/tinymce_4.1.7/tinymce.min.js"></script>
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/skin.min.css" as="style" />
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/content.min.css" as="style" />
<link rel="preload" href="/themes/howtoforge/css/custom.css" as="style" />
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/fonts/tinymce.woff" as="font" crossorigin="anonymous" />

<script type="text/javascript">
var gaProperty = 'UA-2155872-1';
var disableStr = 'ga-disable-' + gaProperty;
if (document.cookie.indexOf(disableStr + '=true') > -1) {
window[disableStr] = true;
}
function gaOptout() {
document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
window[disableStr] = true;
alert('Google Ananlyitics tracking has been disabled in this browser.');
}
</script>
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
	googletag.defineSlot('/1030080/howtoforge_com_list_sidebar_top', [300, 250], 'div-gpt-ad-1527185271042-4').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_list_content_middle', [[300, 250], [336, 280]], 'div-gpt-ad-1527185271042-5').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_a_300x250', [300, 250], 'div-gpt-ad-1527185271042-6').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_b_300x250', [300, 250], 'div-gpt-ad-1527185271042-7').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_leaderboard_b_728x90', [728, 90], 'div-gpt-ad-1527185271042-1').addService(googletag.pubads());
	googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-3043223216276099",
          enable_page_level_ads: true
     });
</script>


<script type="text/javascript" src="//m.servedby-buysellads.com/monetization.js"></script>

<script type="text/javascript">var ezouid = "1";</script><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script>
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 178704;
var ezdomain = 'howtoforge.com';
var ezoicSearchable = 1;
</script>


<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":178704,"domain_test_group":20230804,"engaged_time_visit":0,"ezcache_level":2,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"668868f8-7062-4e90-76a4-1d09cf4f1493","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":50743,"response_time_orig":6,"serverid":"3.239.54.177:28128","state":"VA","t_epoch":1668717992,"template_id":126,"time_on_site_visit":0,"url":"https://www.howtoforge.com/how-to-install-ms-sql-server-on-rocky-linux/","user_id":0,"word_count":1969,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_178704=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["668868f8-7062-4e90-76a4-1d09cf4f1493", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>
<body>
<div id="loginBar">
<div class="pageWidth">
<div class="pageContent">
<h3 id="loginBarHandle">
<label for="LoginControl"><a href="https://forum.howtoforge.com/login/" class="concealed noOutline">Log in or Sign up</a></label>
</h3>
<span class="helper"></span>
</div>
</div>
</div>
<header>
<div id="header">
<div id="logoBlock">
<div class="pageWidth">
<div class="pageContent">
<div id="logo"><a href="/">
<span></span>
<img src="/images/howtoforge_logo_trans.gif" alt="Howtoforge" style="margin-left:20px;" />
</a></div>
<span class="helper"></span>
</div>
</div>
</div>
<div id="navigation" class="pageWidth withSearch">
<div class="pageContent">
<nav>
<div class="navTabs">
<ul class="publicTabs">

<li class="navTab forums selected">
<a href="/" class="navLink">Tutorials</a>
<div class="tabLinks forumsTabLinks">
<ul class="secondaryContent blockLinksList">
<li><a href="/search/">Tutorial search</a></li>
</ul>
</div>
</li>
<li class="navTab forums PopupClosed">
<a href="/tutorials/" class="navLink">Tags</a>
</li>
<li class="navTab forums PopupClosed"><a href="https://forum.howtoforge.com/" class="navLink">Forums</a></li>
<li class="navTab forums PopupClosed"><a href="/linux-commands/" class="navLink">Linux Commands</a></li>
<li class="navTab forums PopupClosed"><a href="/subscription/" class="navLink">Subscribe</a></li>
</ul>
</div>
<span class="helper"></span>
</nav>
</div>
</div>
<div id="searchBar" class="pageWidth">
<span id="QuickSearchPlaceholder" title=" Search..."> Search</span>
<fieldset id="QuickSearch">
<form action="/" method="post" class="formPopup">
<div class="primaryControls">

<input type="search" name="q" value="" class="textCtrl" placeholder="Search..." results="0" title="Enter your search and hit enter..." id="QuickSearchQuery" />

</div>
<input type="hidden" name="_xfToken" value="" />
</form>
</fieldset>
</div>
</div>
</header>
<div id="content" class="forum_list">
<div class="pageWidth">
<div class="pageContent">

<div class="mainContainer">
<div class="mainContent">

<div class="breadBoxTop">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://schema.org/BreadcrumbList">
<span itemprop="itemListElement" itemscope="" itemtype="http://schema.org/ListItem">
<a href="/" class="crumb" rel="up" itemprop="item"><span itemprop="name">Home</span></a>
<meta itemprop="position" content="1" />
</span>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://schema.org/BreadcrumbList">
<span itemprop="itemListElement" itemscope="" itemtype="http://schema.org/ListItem">
<a href="/how-to-install-ms-sql-server-on-rocky-linux/" class="crumb" rel="up" itemprop="item"><span itemprop="name">How to Install and Use MS SQL Server on Rocky Linux</span></a>
<meta itemprop="position" content="2" />
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</span></fieldset>
</nav>
</div>

<div id="htfContentPage">
<div class="bsa-apiads"></div>
<article>
<h1>How to Install and Use MS SQL Server on Rocky Linux</h1>
<div class="contributeEdit" style="float:right; width:450px; max-width:100%;">
<div id="tocContainer">
<h3>On this page</h3>
<ol class="toc">
<li><a href="#prerequisites">Prerequisites</a></li>
<li><a href="#adding-repository">Adding Repository</a></li>
<li><a href="#installing-mssql-server">Installing MSSQL Server</a></li>
<li><a href="#installing-and-configuring-sql-tools">Installing and Configuring SQL Tools</a></li>
<li><a href="#connecting-to-sql-server-using-sql-tools">Connecting to SQL Server using SQL Tools</a></li>
<li><a href="#basic-operations-ms-sql-server">Basic Operations MS SQL Server</a></li>
<li><a href="#conclusion">Conclusion</a></li>
</ol>
</div>
</div>
<p>MS SQL Server or Microsoft SQL Server is an RDBMS (Relational Database Management System) developed by Microsoft. As a database server, it is used to store data for your applications. The SQL Server is ideal for multiple purposes of applications, you can use MS SQL Server as the database for your desktop applications, use it for your web applications, or any small server applications.</p>
<p>In this tutorial, I will show you how to install MS SQL Server on a Rocky Linux server, set up SQL Tools for managing SQL Server, and also learn the basic operation of SQL Server for managing databases.</p>
<h2 id="prerequisites">Prerequisites</h2>
<p>Before you begin with this guide, ensure you have the following requirements:</p>
<ul>
<li>A Rocky Linux server - this example uses the Rocky Linux v8.x.</li>
<li>A regular user or non-root user with sudo root privileges - but also you can use the root user.</li>
<li>SELinux with permissive mode.</li>
</ul>
<h2 id="adding-repository">Adding Repository</h2>
<p>MS SQL Server is one of the popular RDBMS (Relational Database Management Systems) created by Microsoft. To install SQL Server, you must add the official SQL Server repository to your system.</p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;">

<div id="div-gpt-ad-1527185271042-6" style="height:250px; width:300px;">
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-6'); });
</script>
</div>
</div>
<p>Now, you will add the SQL Server repository for the SQL Server 2019.</p>
<p>Before adding the SQL Server repository, run the following dnf command to install basic dependencies.</p>
<pre class="command">sudo dnf install dnf-plugins-core curl -y</pre>
<p>Next, run the following curl command to download the SQL Server repository to your Rocky Linux server. The new SQL Server repository will be saved to <em>&#39;/etc/yum.repos.d/mssql-server.repo&#39;</em>.</p>
<pre class="command">sudo curl -o /etc/yum.repos.d/mssql-server.repo https://packages.microsoft.com/config/rhel/8/mssql-server-2019.repo</pre>
<p>Lastly, verify the list of available repositories on your system via the following dnf command. You should get the MS SQL Server 2019 repository added to your Rocky Linux server.</p>
<pre class="command">sudo dnf repolist</pre>
<p><a class="fancybox" id="img-1-add-repo" href="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/big/1-add-repo.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/1-add-repo.png" alt="setup repo" width="750" height="174" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Now that the MS SQL Server repository is added, you will next install the MS SQL Server package and start configuring it.</p>
<h2 id="installing-mssql-server">Installing MSSQL Server</h2>
<p>While the repository is added, you will now start the MS SQL Server installation and configuration. You can install it via the dnf command, and start configuring the SQL server via the &#39;mssql-conf&#39; command provided by SQL Server packages.</p>
<p>Run the following dnf command to install the SQL Server to the Rocky Linux server.</p>
<pre class="command">sudo dnf install mssql-server</pre>
<p>When prompted for the configuration, input<strong> y</strong> and press <strong>ENTER</strong> to proceed.</p>
<p><a class="fancybox" id="img-2-install-mssql-server" href="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/big/2-install-mssql-server.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/2-install-mssql-server.png" alt="install mssql server" width="750" height="366" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Also, you will be prompted to accept the GPG key of the MS SQL Server repository. Input y and press ENTER again to proceed, and the installation will begin.</p>
<p><a class="fancybox" id="img-3-acept-key" href="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/big/3-acept-key.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/3-acept-key.png" alt="gpg key" width="706" height="204" /></a></p>
<p>After SQL Server is installed, start configuring it with the &#39;<em>mssql-conf</em>&#39; tool.</p>
<p>Run the following &#39;<em>mssql-conf setup</em>&#39; command below to set up and configure the SQL Server installation.</p>
<pre class="command">sudo /opt/mssql/bin/mssql-conf setup</pre>
<ul>
<li>Choose the MS SQL Server edition that you want to install. In this example, you will set up the MS SQL Server Express. So, input number <strong>3</strong> and press <strong>ENTER</strong>.</li>
<li>For the License terms, input &#39;Yes&#39; to agree.</li>
<li>Lastly, input the new password for your MS SQL Server installation and repeat the password.</li>
</ul>
<p><a class="fancybox" id="img-4-configure-mssql-server" href="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/big/4-configure-mssql-server.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/4-configure-mssql-server.png" alt="configure ms sql server" width="709" height="746" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>When SQL Server configuration is finished, you will see the output like the following. You can see the message on your terminal &#39;<strong>Setup has been completed successfully. SQL Server is now running</strong>&#39;.</p>
<p><a class="fancybox" id="img-5-mssql-server-running" href="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/big/5-mssql-server-running.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/5-mssql-server-running.png" alt="sql server is running" width="750" height="94" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Next, verify the &#39;<em>mssql-server&#39;</em> service via the systemctl command below to make sure the service is running.</p>
<pre class="command">sudo systemctl is-enabled mssql-server<br />sudo systemctl status mssql-server</pre>
<p>You will see the &#39;<em>mssql-server&#39;</em> is enabled and will be running automatically at system boot. And the status of the current time is running.</p>
<p><a class="fancybox" id="img-6-verify-mssql-server-service" href="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/big/6-verify-mssql-server-service.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/6-verify-mssql-server-service.png" alt="verify sql server" width="681" height="303" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>If you want to allow remote login to your MS SQL Server on your local environment, you must add the MS SQL Server port to the firewalld.</p>
<p>The default SQL Server is running on TCP port <strong>1433</strong>, run the following firewall-cmd command to add the SQL Server port, then reload to apply new changes.</p>
<pre class="command">sudo firewall-cmd --zone=public --add-port=1433/tcp --permanent<br />sudo firewall-cmd --reload</pre>
<p>The MS SQL Server is now installed and configured. Next, you will install MS SQL Tools that will be used to connect and manage SQL Server.</p>
<h2 id="installing-and-configuring-sql-tools">Installing and Configuring SQL Tools</h2>
<p>The MS SQL Tools is a command-line tool provided by Microsoft for managing SQL Server. it contains two different tools, the &#39;sqlcmd&#39; is the SQL client for managing the SQL Server, and the &#39;bcp&#39; tool is for import-export and backup utility.</p>
<p>SQL Tools has its repository package. So, you will now add the SQL Tools repository, then install and configure the SQL Tools on the ROcky Linux system.</p>
<p>Run the following command to add the SQL Tools repository to your Rocky Linux system.</p>
<pre class="command">sudo curl -o /etc/yum.repos.d/mssql-prod.repo https://packages.microsoft.com/config/rhel/8/prod.repo</pre>
<p>You can verify the list of repositories on your system via the following dnf command. You will see the SQL Tools repository is added.</p>
<pre class="command">sudo dnf repolist</pre>
<p><a class="fancybox" id="img-7-add-sql-tools-repo" href="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/big/7-add-sql-tools-repo.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/7-add-sql-tools-repo.png" alt="add sql repo" width="750" height="228" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Next, run the following command to install SQL Tools to your Rocky Linux server.</p>
<pre class="command">sudo dnf install mssql-tools unixODBC-devel</pre>
<p>When prompted to confirm the installation, input y then press ENTER to proceed.</p>
<p><a class="fancybox" id="img-8-install-sql-tools" href="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/big/8-install-sql-tools.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/8-install-sql-tools.png" alt="install sql tools" width="750" height="255" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>You will also be prompted to confirm the GPP key of the SQL Tools repository. Input y to add the GPG key and press <strong>ENTER</strong> to confirm.</p>
<p>Additionally, you will also be prompted for two License terms for the SQL Tools. Input Yes to agree for both Licenses and the installation will begin.</p>
<p><a class="fancybox" id="img-9-accept-license" href="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/big/9-accept-license.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/9-accept-license.png" alt="accept license " width="590" height="452" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>After SQL Tools is installed, you can verify the SQL Tools installation directory at &#39;/opt/mssql-tools&#39;. You can see multiple directories for SQL Tools configurations and the bin directory where the main executable of SQL Tools is stored.</p>
<p>Next, you must add the SQL Tools bin directory &#39;<em>/opt/mssql-tools/bin</em>&#39; to the PATH Environment variable via the &#39;<em>~/.bashrc</em>&#39; file. This allows you to run SQL Tools without a full path to the binary executable files.</p>
<p>Run the following command to add the SQL Tools bin directory to the PATH environment variable.</p>
<pre class="command">echo &#39;export PATH=&#34;$PATH:/opt/mssql-tools/bin&#34;&#39; &gt;&gt; ~/.bashrc</pre>
<p>Now, reload the ~/.bashrc configuration and verify the PATH environment variable. You will see the SQL Tools bin directory &#39;<em>/opt/mssql-tools/bin</em>&#39; is added to the PATH environment variable.</p>
<pre class="command">source ~/.bashrc<br />echo $PATH</pre>
<p><a class="fancybox" id="img-10-configure-sql-tools" href="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/big/10-configure-sql-tools.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/10-configure-sql-tools.png" alt="configure sql tools" width="750" height="187" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>You can also verify using the following command. This will locate the binary file of SQL Tools &#39;<em>sqlcmd</em>&#39; and &#39;<em>bcp</em>&#39;, which is stored in the directory <em>&#39;/opt/mssql-tools/bin</em>&#39; directory.</p>
<pre class="command">which sqlcmd<br />which bcp</pre>
<p>Now that the SQL Tools is installed, you will now learn how to connect to the SQL Server via the &#39;<em>sqlcmd</em>&#39; command.</p>
<h2 id="connecting-to-sql-server-using-sql-tools">Connecting to SQL Server using SQL Tools</h2>
<p>At this point, you have installed and configured the MS SQL Server and the SQL Tools on the Rocky Linux server. Next, you will learn how to connect to the SQL Server via the &#39;<em>sqlcmd</em>&#39; SQL Tools.</p>
<p>Run the following &#39;<em>sqlcmd</em>&#39; command to connect to the SQL Server. Also, change the password with your SQL Server password that was configured during the installation stage.</p>
<pre class="command">sqlcmd -S localhost -U SA -P &#39;YourPassword&#39;</pre>
<p>After connecting to the SQL Server, run the following query to verify the current version of the SQL Server that you just installed.</p>
<pre class="command">select @@version<br />go</pre>
<p>You will see the output like the following. The current version of the SQL Server that was installed is &#39;<strong>Microsoft SQL Server 2019</strong>&#39;.</p>
<p><a class="fancybox" id="img-11-connect-to-sql-server" href="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/big/11-connect-to-sql-server.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/11-connect-to-sql-server.png" alt="connect to mssql server" width="750" height="361" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Next, you can also check and verify the default databases available on the SQL Server via the following queries. You will see four default databases on SQL Server, which is <em>master</em>, <em>tempdb</em>, <em>model</em>, and <em>msdb</em>.</p>
<pre class="command">select name from sys.databases;<br />go</pre>
<p>Now you can press &#39;<strong>Ctrl+c</strong>&#39; to exit from the &#39;<em>sqlcmd</em>&#39; SQL Tools.</p>
<h2 id="basic-operations-ms-sql-server">Basic Operations MS SQL Server</h2>
<p>Now that you&#39;ve learned how to connect to SQL Server via the &#39;<em>sqlcmd</em>&#39; command. Next, you will learn the basic queries of SQL servers for managing databases.</p>
<p>Run the following query to create a new SQL Server database &#39;<strong>TestDB</strong>&#39;.</p>
<pre class="command">CREATE DATABASE TestDB</pre>
<p>Now verify the list of the database on your SQL Server via the following query. And you should get the new database &#39;<strong>TestDB</strong>&#39; is created.</p>
<pre class="command">SELECT Name from sys.Databases<br />GO</pre>
<p><a class="fancybox" id="img-12-create-database" href="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/big/12-create-database.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/12-create-database.png" alt="create database" width="407" height="331" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Next, switch the new database &#39;<strong>TestDB</strong>&#39; using the following query. You should now see the output &#34;<strong>Changed the database context to &#39;TestDB</strong>&#39;&#34;. With this in mind, you can now create a new table and insert data into it.</p>
<pre class="command">USE TestDB<br />GO</pre>
<p>Run the following query to create a new table. In this example, you will create a new table &#39;users&#39; with some items inside <em>id, first_name, last_name, email, </em>and the<em> last_login</em>.</p>
<pre class="command">CREATE TABLE users (<br />    id INT PRIMARY KEY IDENTITY (1, 1),<br />    first_name VARCHAR (50) NOT NULL,<br />    last_name varchar(50) NOT NULL,<br />    email varchar(50),<br />    last_login DATE NOT NULL<br />);<br />GO</pre>
<p><a class="fancybox" id="img-13-create-table" href="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/big/13-create-table.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/13-create-table.png" alt="create table" width="549" height="296" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Now, run the following query to insert new data to the table &#39;<em>users</em>&#39;. You can see the output such as &#34;<em>(1 rows affected)</em>&#34;, which means you make changes to the table.</p>
<pre class="command">INSERT INTO users (first_name, last_name, email, last_login) VALUES (&#39;Alice&#39;, &#39;Wonderland&#39;, &#39;<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="90f1fcf9f3f5d0f8e7f4fffdf1f9febef9ff">[email&#160;protected]</a>&#39;, &#39;20220901&#39;);<br />GO</pre>
<p><a class="fancybox" id="img-14-insert-data" href="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/big/14-insert-data.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/14-insert-data.png" alt="insert data" width="750" height="107" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Next, run the following query to retrieve the data from table &#39;users&#39;. You should see the data that you just added.</p>
<pre class="command">SELECT * FROM users<br />GO</pre>
<p><a class="fancybox" id="img-15-retrieve-data" href="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/big/15-retrieve-data.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/15-retrieve-data.png" alt="retrieve data" width="750" height="96" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Lastly, to clean up your SQL Server environment installation, you can run the following query to delete the database &#39;<strong>TestDB</strong>&#39;.</p>
<pre class="command">DROP DATABASE TestDB<br />GO</pre>
<p>Now verify the list of available databases on your system using the following query. You will see the &#39;<strong>TestDB</strong>&#39; database is deleted from your SQL Server.</p>
<pre class="command">SELECT Name from sys.Databases<br />GO</pre>
<p><a class="fancybox" id="img-16-delete-database" href="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/big/16-delete-database.png"><img loading="lazy" src="https://www.howtoforge.com/images/how_to_install_ms_sql_server_on_rocky_linux/16-delete-database.png" alt="delete database" width="483" height="335" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<h2 id="conclusion">Conclusion</h2>
<p>In this guide, you installed and configured MS SQL Server on the Rocky Linux system. You also learned how to install and configure SQL Tools on Rocky Linux for managing MS SQL Server.</p>
<p>in the end, you also learned the basic usage of SQL Tools &#39;<em>sqlcmd</em>&#39; for connecting to the SQL Server and learned the basic operation of SQL Server for creating a database, and table, inserting data, and also retrieving data from the database.</p>
</article>
<div style="height:30px; margin-top:20px;">
<p style="text-align:right;"><img src="/images/pdficon_small.png" /> <a class="pdf-btn" href="javascript:void(0);">view as pdf</a> | <img src="/images/print.gif" /> <a class="print-btn" href="javascript:void(0);">print</a></p>
</div>
<div style="height:30px; margin-top:20px;">
<div style="float:left;"><b>Share this page:</b></div>
<p style="text-align:center;">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-ms-sql-server-on-rocky-linux%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-ms-sql-server-on-rocky-linux%2F&amp;text=How+to+Install+and+Use+MS+SQL+Server+on+Rocky+Linux&amp;via=howtoforgecom&amp;related=howtoforgecom" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-ms-sql-server-on-rocky-linux%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-gplus.png" height="20" /></a>
</p>
</div>
</div>


<div id="htfContentPagePaging">
<h2>Suggested articles</h2>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-3043223216276099" data-ad-slot="8940054090"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>


<div id="htfContentPageComment">
<a name="comments"></a>
<h2>0 Comment(s)</h2>

<div id="commentform">
<div class="commentContainerHead" style="font-size:18px;">Add comment</div>
<div class="commentContainer">
<form method="post" action="/how-to-install-ms-sql-server-on-rocky-linux/#comments">
<input type="hidden" name="reply_to" id="reply-to-comment" value="0" />
<div id="commentFormDetail">
<div style="width:48%; float:left; margin-right:3%">
<label for="commentname">Name *</label>
<input id="commentname" name="commentname" value="" />
</div>
<div style="width:48%;float:left;">
<label for="commentname">Email *</label>
<input id="commentemail" name="commentemail" value="" />
</div>
<div style="clear:both;"></div>
</div>
<textarea id="commentedit" name="commentedit" style="width:auto;"></textarea>
<div>
<div style="float:left;">
<div class="g-recaptcha" data-sitekey="6LdX9fUSAAAAALWwVoPdeXScMSketz4npF-0QcQ1"></div>
<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en">
      </script>
</div>
<div style="margin-top:10px;margin-bottom:10px;">
<input type="submit" name="submit" class="button primary" style="float:right;" value="Submit comment" />
</div>
<div style="clear:both;"></div>
</div>
<script>
	tinymce.init({
		selector: "textarea#commentedit",
		theme: "modern",
		height: 100,
		apply_source_formatting : true,
		remove_linebreaks : false,
		menubar : false,
		/*auto_focus : "commentedit",*/
		plugins: [
		"link"
		],
		/*plugins: [
			"advlist autolink link image lists charmap print preview hr anchor pagebreak spellchecker",
			"searchreplace wordcount visualblocks visualchars code fullscreen insertdatetime media nonbreaking",
			"save table contextmenu directionality emoticons template paste textcolor"
		],*/
		content_css: "https://www.howtoforge.com/themes/howtoforge/css/custom.css",
		toolbar: "undo redo | bold italic link", 
		/*style_formats: [
			{title: 'Bold text', inline: 'b'},
			{title: 'Red text', inline: 'span', styles: {color: '#ff0000'}},
			{title: 'Red header', block: 'h1', styles: {color: '#ff0000'}},
			{title: 'Example 1', inline: 'span', classes: 'example1'},
			{title: 'Example 2', inline: 'span', classes: 'example2'},
			{title: 'Table styles'},
			{title: 'Table row 1', selector: 'tr', classes: 'tablerow1'}
		]*/
	}); 
	</script>
</form>
</div>
</div>

</div>

<div class="breadBoxBottom">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Home</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/how-to-install-ms-sql-server-on-rocky-linux/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to Install and Use MS SQL Server on Rocky Linux</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
<script>
<!--

$(document).on('click', 'a.reply-to', function(e) {
	e.preventDefault();
	
	var self = $(this);
	var cid = self.attr('data-comment');
	console.log(cid);
	if(!cid) return this;
	
	$('#commentform').insertAfter('#comment' + cid);
	$('#reply-to-comment').val(cid);
	/*tinyMCE.activeEditor.focus();*/
	var textareaId = 'commentedit';
	tinyMCE.get(textareaId).remove();
	tinyMCE.execCommand("mceAddEditor", false, textareaId);
	tinyMCE.activeEditor.focus();
});
//-->
</script>
<div style="margin-top:10px;margin-bottom:10px;text-align:center;">

<center>


<div id="div-gpt-ad-1527185271042-1" style="height:90px; width:728px;">
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-1'); });
</script>
</div>

</center>
</div>


<form action="https://forum.howtoforge.com/login/login?redirect=/how-to-install-ms-sql-server-on-rocky-linux/" method="post" class="xenForm eAuth" id="login" style="display:none">
<ul id="eAuthUnit">
<li><a href="https://forum.howtoforge.com/community/register/facebook?reg=1" class="fbLogin" tabindex="110"><span>Log in with Facebook</span></a></li>
<li><a href="https://forum.howtoforge.com/community/register/twitter?reg=1" class="twitterLogin" tabindex="110"><span>Log in with Twitter</span></a></li>
<li><span class="googleLogin GoogleLogin JsOnly" tabindex="110" data-client-id="198773272284-b6tfk0c28bje81p774prrcrkq9jb3o44.apps.googleusercontent.com" data-redirect-url="https://forum.howtoforge.com/register/google?code=__CODE__&amp;csrf=hVMXbW_3rnrmq4Em"><span>Log in with Google</span></span></li>
</ul>
<div class="ctrlWrapper">
<dl class="ctrlUnit">
<dt><label for="LoginControl">Your name or email address:</label></dt>
<dd><input type="text" name="login" id="LoginControl" class="textCtrl" tabindex="101" /></dd>
</dl>
<dl class="ctrlUnit">
<dt>
<label for="ctrl_password">Do you already have an account?</label>
</dt>
<dd>
<ul>
<li><label for="ctrl_not_registered"><input type="radio" name="register" value="1" id="ctrl_not_registered" tabindex="105" />
No, create an account now.</label></li>
<li><label for="ctrl_registered"><input type="radio" name="register" value="0" id="ctrl_registered" tabindex="105" checked="checked" class="Disabler" />
Yes, my password is:</label></li>
<li id="ctrl_registered_Disabler">
<input type="password" name="password" class="textCtrl" id="ctrl_password" tabindex="102" />
<div class="lostPassword"><a href="https://forum.howtoforge.com/lost-password/" tabindex="106">Forgot your password?</a></div>
</li>
</ul>
</dd>
</dl>
<dl class="ctrlUnit submitUnit">
<dt></dt>
<dd>
<input type="submit" class="button primary" value="Log in" tabindex="104" data-loginphrase="Log in" data-signupphrase="Sign up" />
<label for="ctrl_remember" class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_remember" tabindex="103" /> Stay logged in</label>
</dd>
</dl>
</div>
<input type="hidden" name="cookie_check" value="1" />
<input type="hidden" name="redirect" value="https://forum.howtoforge.com/" />
<input type="hidden" name="_xfToken" value="" />
</form>

</div>
</div>

<aside>
<div class="sidebar">
<div class="section loginButton">
<div class="secondaryContent">
<label for="LoginControl" id="SignupButton"><a href="https://forum.howtoforge.com/login/" class="inner">Sign up now!</a></label>
</div>
</div>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-2">

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent socialMediaIcon">
<a href="https://twitter.com/howtoforgecom" target="_blank"><img src="/images/socialmedia/64x64/twitter.png" /></a>
<a href="https://www.facebook.com/howtoforge" target="_blank"><img src="/images/socialmedia/64x64/facebook.png" /></a>
<a href="https://news.ycombinator.com/" target="_blank" rel="nofollow"><img src="/images/socialmedia/64x64/hackernews.png" /></a>
<a href="https://www.howtoforge.com/feed" target="_blank"><img src="/images/socialmedia/64x64/rss.png" /></a>
</div>
</div>
</div>
<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Tutorial Info</p>
<div class="pairsJustified">
<dl class="discussionCount">
<dt>Author:</dt>
<dd><a href="/author/arvid+l/" rel="author">Arvid L</a></dd>
</dl>
<dl class="discussionCount">
<dt>Published:</dt>
<dd>Nov 16, 2022</dd>
</dl>
<dl class="discussionCount">
<dt>Tags:</dt>
<dd><a href="/tutorials/linux/" rel="tag">linux</a>, <a href="/tutorials/server/" rel="tag">server</a></dd>
</dl>
</div>
</div>
</div>

<div id="sponsor-banner">
</div>

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent">
<p class="mnuinfo mnushare">Share This Page</p>
<p style="text-align:center;">
<a href="javascript:window.open(&#39;https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-ms-sql-server-on-rocky-linux%2F&#39;, &#39;_blank&#39;, &#39;status=1,height=500,width=360,resizable=0&#39;);void(0);"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="javascript:window.open(&#39;https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-ms-sql-server-on-rocky-linux%2F&amp;text=How+to+Install+and+Use+MS+SQL+Server+on+Rocky+Linux&amp;via=howtoforgecom&amp;related=howtoforgecom&#39;, &#39;_blank&#39;, &#39;status=1,height=500,width=360,resizable=0&#39;);void(0);"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="javascript:window.open(&#39;https://news.ycombinator.com/submitlink?t=How+to+Install+and+Use+MS+SQL+Server+on+Rocky+Linux&amp;u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-install-ms-sql-server-on-rocky-linux%2F&#39;, &#39;_blank&#39;, &#39;status=1,height=500,width=360,resizable=0&#39;);void(0);"><img src="/images/socialmedia/btn-hackernews.png" height="20" /></a>
</p>
<p style="color:#EE; font-weight:bold; text-align:center; margin-top:5px;">40.2k Followers</p>
</div>
</div>
</div>


<script type="text/javascript">
    google_ad_client = "ca-pub-3043223216276099";
    google_ad_slot = "6709042890";
    google_ad_width = 300;
    google_ad_height = 600;
</script>

<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>


<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Popular Tutorials</p>
<div class="pairsJustified">
<ul>
<li><a href="/kernel_compilation_debian">How to Compile A Kernel - The Debian Way</a></li>
<li><hr /></li>
<li><a href="/how-to-install-linux-kernel-6-on-ubuntu-22-04/">How to Install Linux Kernel 6.0 on Ubuntu 22.04</a></li>
<li><hr /></li>
<li><a href="/tutorial/install-nginx-php-and-mysql-lemp-stack-on-opensuse-leap-42.1/">How to Install Nginx, PHP and MySQL (LEMP Stack) on OpenSUSE Leap 42.1</a></li>
<li><hr /></li>
<li><a href="/how-to-install-odoo-on-debian-11/">How to Install Odoo ERP Software (formerly OpenERP) on Debian 11</a></li>
<li><hr /></li>
<li><a href="/tutorial/ispconfig-multiserver-setup-debian-ubuntu/">ISPConfig Perfect Multiserver setup on Ubuntu 20.04 and Debian 10</a></li>
<li><hr /></li>
<li><a href="/how-to-install-django-with-postgres-nginx-and-gunicorn-on-rocky-linux-9/">How to Install Django with Postgres, Nginx, and Gunicorn on Rocky Linux 9</a></li>
<li><hr /></li>
<li><a href="/how-to-install-glassfish-java-application-server-on-rocky-linux/">How to Install GlassFish Java Application Server on Rocky Linux</a></li>
<li><hr /></li>
<li><a href="/how-to-install-lomp-stack-openlitespeed-mariadb-and-php-on-debian-11/">How to Install LOMP Stack (OpenLiteSpeed, MariaDB, and PHP) on Debian 11</a></li>
<li><hr /></li>
<li><a href="/how-to-install-librenms-monitoring-solution-on-rocky-linux/">How to Install LibreNMS Monitoring Solution on Rocky Linux</a></li>
<li><hr /></li>
<li><a href="/how-to-install-dozzle-real-time-log-viewer-for-docker-containers-on-ubuntu-22-04/">How to Install Dozzle Real-Time Log Viewer for Docker Containers on Ubuntu 22.04</a></li>
<li><hr /></li>
</ul>
</div>
</div>
</div>
</div>
</div>
</aside>
</div>
</div>
</div>
<footer>
<div class="footer">
<div class="pageWidth">
<div class="pageContent">
<div class="skin_branding"><span>Xenforo skin by <a href="http://www.xenfocus.com" rel="nofollow">Xenfocus</a></span></div>
<ul class="footerLinks">
<li><a href="/contribute/">Contribute</a></li>
<li><a href="https://forum.howtoforge.com/misc/contact">Contact</a></li>
<li><a href="https://forum.howtoforge.com/help/">Help</a></li>
<li><a href="/imprint/">Imprint and Legal Notice</a></li>
<li><a href="#navigation" class="topLink">Top</a></li>
<li><a href="/feed" rel="alternate" class="globalFeed" target="_blank" title="RSS-Feed for Howtoforge">RSS-Feed</a></li>
</ul>
<span class="helper"></span>
</div>
</div>
</div>
<div class="footerLegal">
<div class="pageWidth">
<div class="pageContent">
<ul id="legal">
<li><a href="https://forum.howtoforge.com/help/terms">Terms and Rules</a> <a href="https://forum.howtoforge.com/help/privacy-policy">Privacy Policy</a></li>
</ul>
<div id="copyright"><a href="https://www.howtoforge.com" class="concealed">Howtoforge <span>© projektfarm GmbH.</span></a></div>
<span class="helper"></span>
</div>
</div>
</div>
</footer>
<div style="height:100px;"></div>

<div id="subscriptionModal" class="modal">
<div class="modal-content">
<span class="close">×</span>
<p>This feature is only available to subscribers. Get your subscription <a href="/subscription">here</a>.</p>
</div>
</div>
<script>
//* Modal
var modal = document.getElementById('subscriptionModal');
var span = document.getElementsByClassName("close")[0];
$(".pdf-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
$(".print-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
span.onclick = function() {
	$("#subscriptionModal").css('display', 'none');
}
window.onclick = function(event) {
    if (event.target == modal) {
		$("#subscriptionModal").css('display', 'none');
    }
}
//* Xenforo
jQuery.extend(true, XenForo,
{
	visitor: { user_id: 0 },
	serverTimeInfo:
	{
		now: 1409831907,
		today: 1409781600,
		todayDow: 4
	},
	_lightBoxUniversal: "0",
	_enableOverlays: "1",
	_animationSpeedMultiplier: "1",
	_overlayConfig:
	{
		top: "10%",
		speed: 200,
		closeSpeed: 100,
		mask:
		{
			color: "rgb(0, 0, 0)",
			opacity: "0.6",
			loadSpeed: 200,
			closeSpeed: 100
		}
	},
	_ignoredUsers: [],
	_loadedScripts: {"node_list":true,"node_category":true,"node_forum":true,"sidebar_share_page":true,"wf_default":true,"bbm_buttons":true,"login_bar":true,"twitter":true},
	_cookieConfig: { path: "/", domain: "", prefix: "xf_"},
	_csrfToken: "",
	_csrfRefreshUrl: "https://forum.howtoforge.com/login/csrf-token-refresh",
	_jsVersion: "303ae0ca"
});
jQuery.extend(XenForo.phrases,
{
	cancel: "Cancel",

	a_moment_ago:    "A moment ago",
	one_minute_ago:  "1 minute ago",
	x_minutes_ago:   "%minutes% minutes ago",
	today_at_x:      "Today at %time%",
	yesterday_at_x:  "Yesterday at %time%",
	day_x_at_time_y: "%day% at %time%",

	day0: "Sunday",
	day1: "Monday",
	day2: "Tuesday",
	day3: "Wednesday",
	day4: "Thursday",
	day5: "Friday",
	day6: "Saturday",

	_months: "January,February,March,April,May,June,July,August,September,October,November,December",
	_daysShort: "Sun,Mon,Tue,Wed,Thu,Fri,Sat",

	following_error_occurred: "The following error occurred",
	server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
	logging_in: "Logging in",
	click_image_show_full_size_version: "Click this image to show the full-size version.",
	show_hidden_content_by_x: "Show hidden content by {names}"
});

// Facebook Javascript SDK
XenForo.Facebook.appId = "";
XenForo.Facebook.forceInit = true;

/*
document.addEventListener('DOMContentLoaded', function(event) {
  cookieChoices.showCookieConsentBar('Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.',
  'OK');
});
*/

$(document).ready(function() {
	$("a.fancybox").fancybox();
});

</script>

<script>
_bsa.init('custom', 'CKYD55QU', 'placement:howtoforge',
    {
      target: '#sponsor-banner',
      template: `
<a href="##link##" style="background: linear-gradient(-330deg, ##backgroundColor##D9, ##backgroundColor##D9 30%, ##backgroundColor## 70%) #fff;" class="native-banner">
<img class="native-img" src="##logo##">
<div style="color: ##textColor##" class="native-tagline">##tagline##</div>
<div style="color: ##textColor##" class="native-desc">##description##</div>
<div style="color: ##ctaTextColor##; background-color: ##ctaBackgroundColor##;" class="native-cta">##callToAction##</div>
<div style="background-color: ##textColor##B2; color: ##backgroundColor##" class="native-ad">Ad</div>
</a>
`
    }
  );
</script>

<script>
(function() {
  if (typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('fancybar', 'CKYDL27E', 'placement:howtoforgecom');
  }
})();
</script>
<script>
(function() {
  if (typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('custom', 'CEBDK2JM', 'placement:howtoforgecom', {
      target: '.bsa-apiads',
      template:
`
<a href="##statlink##" target="_blank" rel="sponsored nofollow">##company## — ##description##</a>
`
    });
  }
})();
</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2155872-1', 'auto');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');

</script>
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('/detroitchicago/edmonton.webp', '/detroitchicago/edmonton.webp?a=a&cb=2&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('/porpoiseant/jellyfish.webp', '/porpoiseant/jellyfish.webp?a=a&cb=2&shcb=34', false, [], true, false, false, false);
</script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=2&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script>
<script type="text/javascript" data-cfasync="false"></script>
<script>var _audins_dom="howtoforge_com",_audins_did=178704;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=195-2");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.howtoforge_com,DomainId.178704" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script>__ez.queue.addFile('/beardeddragon/drake.js', '/beardeddragon/drake.js?gcb=2&cb=4', false, [], true, false, true, false);</script></body></html>