<!DOCTYPE html>
<html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs LoggedOut Sidebar Responsive" xmlns:fb="http://www.facebook.com/2008/fbml">
<head><meta charset="utf-8" />
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">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</script>
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<base href="https://www.howtoforge.com" />
<script>
			var _b = document.getElementsByTagName('base')[0], _bH = "https://www.howtoforge.com/how-to-create-references-in-onlyoffice-with-mendeley-zotero-and-easybib/";
			if (_b && _b.href != _bH) _b.href = _bH;
		</script>
<title>How to create references in ONLYOFFICE with Mendeley, Zotero and EasyBib</title>
<meta name="description" content="In this tutorial we’ll learn how to build bibliographies in ONLYOFFICE document editor using Mendeley, Zotero and EasyBib plugins. ONLYOFFICE is an ... " />
<meta property="og:title" content="How to create references in ONLYOFFICE with Mendeley, Zotero and EasyBib">
<meta property="og:description" content="In this tutorial we’ll learn how to build bibliographies in ONLYOFFICE document editor using Mendeley, Zotero and EasyBib plugins. ONLYOFFICE is an ... ">
<meta property="og:site_name" content="HowtoForge">
<meta property="og:type" content="article">
<meta property="og:image" content="https://www.howtoforge.com/images/featured/onlyoffice-plugins.jpg">
<meta property="og:image:secure_url" content="https://www.howtoforge.com/images/featured/onlyoffice-plugins.jpg" />
<meta property="og:image:alt" content="How to create references in ONLYOFFICE with Mendeley, Zotero and EasyBib" />
<meta name="twitter:image" content="https://www.howtoforge.com/images/featured/onlyoffice-plugins.jpg" />
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="@howtoforgecom">
<meta name="twitter:creator" content="@howtoforgecom">
<meta name="twitter:title" content="How to create references in ONLYOFFICE with Mendeley, Zotero and EasyBib">
<meta name="twitter:description" content="In this tutorial we’ll learn how to build bibliographies in ONLYOFFICE document editor using Mendeley, Zotero and EasyBib plugins. ONLYOFFICE is an ... ">
<link rel="alternate" href="https://www.howtoforge.com/how-to-create-references-in-onlyoffice-with-mendeley-zotero-and-easybib/" hreflang="en" />
<link rel="canonical" href="https://www.howtoforge.com/how-to-create-references-in-onlyoffice-with-mendeley-zotero-and-easybib/" />
<link rel="amphtml" href="https://www.howtoforge.com/how-to-create-references-in-onlyoffice-with-mendeley-zotero-and-easybib/amp/" />
<script type="application/ld+json">
{
  "@context" : "http://schema.org",
  "@type" : "Article",
  "name" : "How to create references in ONLYOFFICE with Mendeley, Zotero and EasyBib",
  "author" : {
    "@type" : "Person",
    "name" : "Daria"
  },
  "articleSection" : "linux,server",
  "url" : "https://www.howtoforge.com/how-to-create-references-in-onlyoffice-with-mendeley-zotero-and-easybib/",
  "publisher" : {
    "@type" : "Organization",
    "name" : "Howtoforge"
  }
}
</script>
<noscript><style>.JsOnly, .jsOnly { display: none !important; }</style></noscript>
<link rel="stylesheet" href="/community/styles/executive/xenfocus/icons/css/font-awesome.min.css" />
<link href='//fonts.googleapis.com/css?family=Open+Sans:400,700' rel='stylesheet' type='text/css' />
<link href="/themes/howtoforge/templates/xf.css" rel="stylesheet">
<script src="/js/jquery/jquery-1.11.3.min.js"></script>
<script src="/community/js/xenforo/xenforo.js?_v=303ae0ca"></script>
<script src="/community/js/bbm/zloader.js?_v=303ae0ca"></script>
<script type="text/javascript" src="/js/fancybox/jquery.mousewheel-3.0.4.pack.js"></script>
<script type="text/javascript" src="/js/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
<link rel="stylesheet" type="text/css" href="/js/fancybox/jquery.fancybox-1.3.4.css" media="screen" />
<link href="/themes/howtoforge/templates/style.min.css" rel="stylesheet">
<link rel="alternate" type="application/rss+xml" title="RSS-Feed für Howtoforge" href="/feed.rss" />
<script src="/js/tinymce_4.1.7/tinymce.min.js"></script>
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/skin.min.css" as="style" />
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/content.min.css" as="style" />
<link rel="preload" href="/themes/howtoforge/css/custom.css" as="style" />
<link rel="preload" href="/js/tinymce_4.1.7/skins/lightgray/fonts/tinymce.woff" as="font">

<script type="text/javascript">
var gaProperty = 'UA-2155872-1';
var disableStr = 'ga-disable-' + gaProperty;
if (document.cookie.indexOf(disableStr + '=true') > -1) {
window[disableStr] = true;
}
function gaOptout() {
document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
window[disableStr] = true;
alert('Google Ananlyitics tracking has been disabled in this browser.');
}
</script>
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
	googletag.defineSlot('/1030080/howtoforge_com_list_sidebar_top', [300, 250], 'div-gpt-ad-1527185271042-4').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_list_content_middle', [[300, 250], [336, 280]], 'div-gpt-ad-1527185271042-5').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_a_300x250', [300, 250], 'div-gpt-ad-1527185271042-6').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_b_300x250', [300, 250], 'div-gpt-ad-1527185271042-7').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_leaderboard_b_728x90', [728, 90], 'div-gpt-ad-1527185271042-1').addService(googletag.pubads());
	googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-3043223216276099",
          enable_page_level_ads: true
     });
</script>


<script src="//m.servedby-buysellads.com/monetization.js" type="text/javascript"></script>


<script type="text/javascript">
    window.cookieconsent_options = {"message":"This website uses cookies to ensure you get the best experience on our website, analyze site traffic and show you relevant ads.","dismiss":"Got it!","learnMore":"More info","link":"https://www.howtoforge.com/community/help/cookies","theme":"dark-bottom"};
</script>
<script type="text/javascript" src="/js/cookieconsent.latest.min.js"></script>

<script data-ezscrex="false" data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-158818458-34";</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['e._setAccount', 'UA-158818458-34']);
_gaq.push(['f._setAccount', 'UA-38339005-1']);
_gaq.push(['e._setDomainName', 'howtoforge.com']);
_gaq.push(['f._setDomainName', 'howtoforge.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod11',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','howtoforge.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script>
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 178704;
var ezdomain = 'howtoforge.com';
var ezoicSearchable = 1;
</script>


<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":178704,"engaged_time_visit":0,"ezcache_level":1,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"fafe3c73-77fb-46ba-73a9-182c0969f85c","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":1262,"serverid":"54.88.111.189:10753","state":"VA","t_epoch":1591846784,"template_id":126,"time_on_site_visit":0,"url":"https://www.howtoforge.com/how-to-create-references-in-onlyoffice-with-mendeley-zotero-and-easybib/","user_id":0,"word_count":1161,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=188-0&v=8" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl() {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_178704=" + new Date().getTime() + "|fafe3c73-77fb-46ba-73a9-182c0969f85c|false; " + expires, 3);
}
function attach_ezolpl() {
    if(window.attachEvent) {
        window.attachEvent('onload', create_ezolpl);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl();
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl;
        }
    }
}
attach_ezolpl();
</script></head>
<body>
<div id="loginBar">
<div class="pageWidth">
<div class="pageContent">
<h3 id="loginBarHandle">
<label for="LoginControl"><a href="/community/login/" class="concealed noOutline">Log in or Sign up</a></label>
</h3>
<span class="helper"></span>
</div>
</div>
</div>
<header>
<div id="header">
<div id="logoBlock">
<div class="pageWidth">
<div class="pageContent">
<div id="logo"><a href="/">
<span></span>
<img src="/images/howtoforge_logo_trans.gif" alt="Howtoforge" style="margin-left:20px;" />
</a></div>
<span class="helper"></span>
</div>
</div>
</div>
<div id="navigation" class="pageWidth withSearch">
<div class="pageContent">
<nav>
<div class="navTabs">
<ul class="publicTabs">

<li class="navTab forums selected">
<a href="/" class="navLink">Tutorials</a>
<div class="tabLinks forumsTabLinks">
<ul class="secondaryContent blockLinksList">
<li><a href="/search/">Tutorial search</a></li>
</ul>
</div>
</li>
<li class="navTab forums PopupClosed">
<a href="/tutorials/" class="navLink">Tags</a>
</li>
<li class="navTab forums PopupClosed"><a href="/community/" class="navLink">Forums</a></li>
<li class="navTab forums PopupClosed"><a href="/linux-commands/" class="navLink">Linux Commands</a></li>
<li class="navTab forums PopupClosed"><a href="/subscription/" class="navLink">Subscribe</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.ispconfig.org" class="navLink">ISPConfig</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.lxer.com" class="navLink">News</a></li>
</ul>
</div>
<span class="helper"></span>
</nav>
</div>
</div>
<div id="searchBar" class="pageWidth">
<span id="QuickSearchPlaceholder" title=" Search..."> Search</span>
<fieldset id="QuickSearch">
<form action="/" method="post" class="formPopup">
<div class="primaryControls">

<input type="search" name="q" value="" class="textCtrl" placeholder="Search..." results="0" title="Enter your search and hit enter..." id="QuickSearchQuery" />

</div>
<input type="hidden" name="_xfToken" value="" />
</form>
</fieldset>
</div>
</div>
</header>
<div id="content" class="forum_list">
<div class="pageWidth">
<div class="pageContent">

<div class="mainContainer">
<div class="mainContent">

<div class="breadBoxTop">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Home</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/how-to-create-references-in-onlyoffice-with-mendeley-zotero-and-easybib/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to create references in ONLYOFFICE with Mendeley, Zotero and EasyBib</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>

<div id="htfContentPage">
<div class="bsa-apiads"><a href="https://ispprotect.com/?pk_campaign=htftxt" target="_blank" rel="nofollow">Scan your Web-Server for Malware with ISPProtect now. Get Free Trial.</a></div>
<article>
<h1>How to create references in ONLYOFFICE with Mendeley, Zotero and EasyBib</h1>
<div class="contributeEdit" style="float:right; width:450px; max-width:100%;">
<div id="tocContainer">
<h3>On this page</h3>
<ol class="toc">
<li><a href="#-how-to-install-and-use-mendeley-plugin-in-onlyoffice">1. How to install and use Mendeley plugin in ONLYOFFICE</a>
<ol>
<li><a href="#installation">Installation</a></li>
<li><a href="#configuration">Configuration</a></li>
<li><a href="#how-to-work">How to work</a></li>
</ol>
</li>
<li><a href="#-how-to-install-and-use-zotero-plugin-in-onlyoffice">2. How to install and use Zotero plugin in ONLYOFFICE</a>
<ol>
<li><a href="#configuration-2">Configuration</a></li>
<li><a href="#how-to-work-2">How to work</a></li>
</ol>
</li>
<li><a href="#-how-to-configure-and-use-easybib-plugin-in-onlyoffice">3. How to configure and use EasyBib plugin in ONLYOFFICE</a></li>
</ol>
</div>
</div>
<p><a href="https://www.onlyoffice.com/?utm_source=howtoforge&amp;utm_medium=cpc&amp;utm_campaign=ref_plugins">ONLYOFFICE</a> is an open-source office suite that comprises online editors for text documents, spreadsheets, and presentations along with productivity tools such as document and project management, mail, CRM, calendar, chat, etc.</p>
<p>ONLYOFFICE Document Server (online editors) is distributed under GNU AGPL v.3.0, ONLYOFFICE Community Server (collaboration platform) - under GNU GPL v.3.0.</p>
<p>In this tutorial we&rsquo;ll learn how to build bibliographies in ONLYOFFICE document editor using Mendeley, Zotero and EasyBib plugins.</p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;">

<div id='div-gpt-ad-1527185271042-6' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-6'); });
</script>
</div>
</div>
<p>If you&rsquo;re new to ONLYOFFICE, install it on Ubuntu following <a href="https://www.howtoforge.com/how-to-install-onlyoffice-100-on-ubuntu-1804-lts/">these instructions</a>.</p>
<p>Note that starting from version 5.5.3 of Document Server, Mendeley and Zotero plugins are pre-installed. You can skip the installation part and need only to configure the plugins.</p>
<h2 id="-how-to-install-and-use-mendeley-plugin-in-onlyoffice">1. How to install and use Mendeley plugin in ONLYOFFICE</h2>
<p>Mendeley is a free reference management service that allows searching and managing publication references and creating bibliographies.</p>
<h3 id="installation">Installation</h3>
<p>Put the <a href="https://github.com/ONLYOFFICE/plugin-mendeley/tree/master/src">src</a> folder with Mendeley plugin to the ONLYOFFICE Document Server folder (service restart is not required):</p>
<pre><code spellcheck="false">/var/www/onlyoffice/documentserver/sdkjs-plugins/</code></pre>
<p>Alternatively, you can edit the Document Server config file adding the following lines:</p>
<pre><code spellcheck="false">var docEditor = new DocsAPI.DocEditor("placeholder", {<br />&nbsp; &nbsp; "editorConfig": {<br />&nbsp; &nbsp; &nbsp; &nbsp; "plugins": {<br />&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; "autostart": [<br />&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; "asc.{BE5CBF95-C0AD-4842-B157-AC40FEDD9441}",<br />&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; ...<br />&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; ],<br />&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; "pluginsData": [<br />&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; "https://example.com/path/to/mendeley/config.json",<br />&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; ...<br />&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; ]<br />&nbsp; &nbsp; &nbsp; &nbsp; },<br />&nbsp; &nbsp; &nbsp; &nbsp; ...<br />&nbsp; &nbsp; },<br />&nbsp; &nbsp; ...<br />});</code></pre>
<h3 id="configuration"><br />Configuration</h3>
<p>Register the application:</p>
<ul>
<li>Go to <a href="https://dev.mendeley.com/myapps.html">dev.mendeley.com/myapps.html</a>.</li>
<li>Fill in the form using the link provided in the plugin interface as a redirect URL.</li>
<li>Press &lsquo;Generate secret&rsquo; and copy it.</li>
<li>Insert the generated secret into the corresponding field in the plugin interface.</li>
</ul>
<h3 id="how-to-work">How to work</h3>
<p>To insert a bibliography in your document:</p>
<ul>
<li>Launch ONLYOFFICE online editors and start Mendeley from the Plugins tab.</li>
<li>In the menu, search the desired source by author/title/year.</li>
<li>Select language and one of the citation styles.</li>
<li>Click &lsquo;Insert Bibliography&rsquo;.</li>
</ul>
<p style="text-align: center;"><a class="fancybox" id="img-onlyoffice_mendeley_plugin" href="https://www.howtoforge.com/images/how_to_create_references_in_onlyoffice_with_mendeley_zotero_and_easybib/big/onlyoffice_mendeley_plugin.png"><img src="https://www.howtoforge.com/images/how_to_create_references_in_onlyoffice_with_mendeley_zotero_and_easybib/onlyoffice_mendeley_plugin.png" width="750" height="461" alt="ONLYOFFICE Mendeley Plugin" /></a></p>
<h2 id="-how-to-install-and-use-zotero-plugin-in-onlyoffice">2. How to install and use Zotero plugin in ONLYOFFICE</h2>
<p>Zotero is a free open-source reference management software that allows managing bibliographic data and related research materials.<br />Installation</p>
<p>Put the <a href="https://github.com/ONLYOFFICE/plugin-zotero/tree/master/src">src</a> folder with Zotero plugin to the ONLYOFFICE Document Server folder (no service restart is required):</p>
<pre><code spellcheck="false">/var/www/onlyoffice/documentserver/sdkjs-plugins/</code></pre>
<p>Alternatively, you can add the following lines to the Document Server config file:</p>
<pre><code spellcheck="false">var docEditor = new DocsAPI.DocEditor("placeholder", {<br />&nbsp; &nbsp; "editorConfig": {<br />&nbsp; &nbsp; &nbsp; &nbsp; "plugins": {<br />&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; "autostart": [<br />&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; "asc.{BFC5D5C6-89DE-4168-9565-ABD8D1E48711}",<br />&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; ...<br />&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; ],<br />&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; "pluginsData": [<br />&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; "https://example.com/path/to/zotero/config.json",<br />&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; ...<br />&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; ]<br />&nbsp; &nbsp; &nbsp; &nbsp; },<br />&nbsp; &nbsp; &nbsp; &nbsp; ...<br />&nbsp; &nbsp; },<br />&nbsp; &nbsp; ...<br />});</code></pre>
<h3 id="configuration-2"><br />Configuration</h3>
<p>Register the application:</p>
<p>Once the plugin is installed, run it from the Plugins tab in the editors.</p>
<ul>
<li>Follow Zotero API settings link from the plugin&rsquo;s window.</li>
<li>Log in to your Zotero account (or register in case you don&rsquo;t have one), then press &lsquo;Create new private key&rsquo;.</li>
<li>Fill in Key Description, make sure the Allow library access box is checked, and press the Save Key button.</li>
<li>Copy the newly created key, paste it in the API Key field in the plugin&rsquo;s interface, and save it.</li>
</ul>
<h3 id="how-to-work-2">How to work</h3>
<p>To insert a bibliography in your document:</p>
<ul>
<li>Launch ONLYOFFICE online editors and start Zotero from the Plugins tab.</li>
<li>Search the desired source by author/title/year.</li>
<li>Select language and one of the citation styles.</li>
<li>Click the Insert Bibliography button.</li>
</ul>
<p>Note that Zotero works only with user&rsquo;s personal library associated with the account. The desired sources must be added to your library in Zotero before you can search and add them to your bibliography via the plugin.</p>
<p style="text-align: center;"><a class="fancybox" id="img-onlyoffice_zotero_plugin" href="https://www.howtoforge.com/images/how_to_create_references_in_onlyoffice_with_mendeley_zotero_and_easybib/big/onlyoffice_zotero_plugin.png"><img src="https://www.howtoforge.com/images/how_to_create_references_in_onlyoffice_with_mendeley_zotero_and_easybib/onlyoffice_zotero_plugin.png" width="750" height="465" alt="ONLYOFFICE Zotero" /></a></p>
<h2 id="-how-to-configure-and-use-easybib-plugin-in-onlyoffice">3. How to configure and use EasyBib plugin in ONLYOFFICE</h2>
<p>The EasyBib plugin allows you to automatically add the references to the document in full accordance with style guides of your choice.</p>
<p>The EasyBib plugin is already installed, you need only to activate it. &nbsp;</p>
<ul>
<li>Go to the EasyBib sign up page.</li>
<li>Fill in the form entering your name, email, application name and description.</li>
<li>Paste &lsquo;https://service.onlyoffice.com/oauth2.aspx&rsquo; in the URL field and click Submit.</li>
<li>Copy the EasyBib API key.</li>
<li>Launch ONLYOFFICE portal and go to Settings -&gt; Integration -&gt; Third-Party Services -&gt; EasyBib.</li>
<li>Enter the copied app key and click Enable.</li>
</ul>
<p>Once done, launch ONLYOFFICE online editors and run EasyBib from the Plugins tab.&nbsp;<br />Search for the necessary reference and select the style. The bibliography list will begin where you put the cursor.</p>
<p>That&rsquo;s all! Choose one of the plugins or combine several options to insert bibliographies in ONLYOFFICE online editors.</p>
<p style="text-align: center;"><a class="fancybox" id="img-onlyoffice_easybib_plugin" href="https://www.howtoforge.com/images/how_to_create_references_in_onlyoffice_with_mendeley_zotero_and_easybib/big/onlyoffice_easybib_plugin.png"><img src="https://www.howtoforge.com/images/how_to_create_references_in_onlyoffice_with_mendeley_zotero_and_easybib/onlyoffice_easybib_plugin.png" width="750" height="406" alt="ONLYOFFICE EasyBib" /></a></p>
</article>
<div style="height:30px; margin-top:20px;">
<p style="text-align:right;"><img src="/images/pdficon_small.png" /> <a class="pdf-btn" href="javascript:void(0);">view as pdf</a> | <img src="/images/print.gif" /> <a class="print-btn" href="javascript:void(0);">print</a></p>
</div>
<div style="height:30px; margin-top:20px;">
<div style="float:left;"><b>Share this page:</b></div>
<p style="text-align:center;">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-create-references-in-onlyoffice-with-mendeley-zotero-and-easybib%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-create-references-in-onlyoffice-with-mendeley-zotero-and-easybib%2F&text=How+to+create+references+in+ONLYOFFICE+with+Mendeley%2C+Zotero+and+EasyBib&via=howtoforgecom&related=howtoforgecom" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-create-references-in-onlyoffice-with-mendeley-zotero-and-easybib%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-gplus.png" height="20" /></a>
</p>
</div>
</div>


<div id="htfContentPagePaging">
<h2>Suggested articles</h2>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-3043223216276099" data-ad-slot="8940054090"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>


<div id="htfContentPageComment">
<a name="comments"></a>
<h2>0 Comment(s)</h2>

<div id="commentform">
<div class="commentContainerHead" style="font-size:18px;">Add comment</div>
<div class="commentContainer">
<form method="post" action="/how-to-create-references-in-onlyoffice-with-mendeley-zotero-and-easybib/#comments">
<input type="hidden" name="reply_to" id="reply-to-comment" value="0" />
<div id="commentFormDetail">
<div style="width:48%; float:left; margin-right:3%">
<label for="commentname">Name *</label>
<input id="commentname" name="commentname" value="" />
</div>
<div style="width:48%;float:left;">
<label for="commentname">Email *</label>
<input id="commentemail" name="commentemail" value="" />
</div>
<div style="clear:both;"></div>
</div>
<textarea id="commentedit" name="commentedit" style="width:auto;"></textarea>
<div>
<div style="float:left;">
<div class="g-recaptcha" data-sitekey="6LdX9fUSAAAAALWwVoPdeXScMSketz4npF-0QcQ1"></div>
<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en">
      </script>
</div>
<div style="margin-top:10px;margin-bottom:10px;">
<input type="submit" name="submit" class="button primary" style="float:right;" value="Submit comment">
</div>
<div style="clear:both;"></div>
</div>
<script>
	tinymce.init({
		selector: "textarea#commentedit",
		theme: "modern",
		height: 100,
		apply_source_formatting : true,
		remove_linebreaks : false,
		menubar : false,
		/*auto_focus : "commentedit",*/
		plugins: [
		"link"
		],
		/*plugins: [
			"advlist autolink link image lists charmap print preview hr anchor pagebreak spellchecker",
			"searchreplace wordcount visualblocks visualchars code fullscreen insertdatetime media nonbreaking",
			"save table contextmenu directionality emoticons template paste textcolor"
		],*/
		content_css: "https://www.howtoforge.com/themes/howtoforge/css/custom.css",
		toolbar: "undo redo | bold italic link", 
		/*style_formats: [
			{title: 'Bold text', inline: 'b'},
			{title: 'Red text', inline: 'span', styles: {color: '#ff0000'}},
			{title: 'Red header', block: 'h1', styles: {color: '#ff0000'}},
			{title: 'Example 1', inline: 'span', classes: 'example1'},
			{title: 'Example 2', inline: 'span', classes: 'example2'},
			{title: 'Table styles'},
			{title: 'Table row 1', selector: 'tr', classes: 'tablerow1'}
		]*/
	}); 
	</script>
</form>
</div>
</div>

</div>

<div class="breadBoxBottom">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Home</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/how-to-create-references-in-onlyoffice-with-mendeley-zotero-and-easybib/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to create references in ONLYOFFICE with Mendeley, Zotero and EasyBib</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
<script>
<!--

$(document).on('click', 'a.reply-to', function(e) {
	e.preventDefault();
	
	var self = $(this);
	var cid = self.attr('data-comment');
	console.log(cid);
	if(!cid) return this;
	
	$('#commentform').insertAfter('#comment' + cid);
	$('#reply-to-comment').val(cid);
	/*tinyMCE.activeEditor.focus();*/
	var textareaId = 'commentedit';
	tinyMCE.get(textareaId).remove();
	tinyMCE.execCommand("mceAddEditor", false, textareaId);
	tinyMCE.activeEditor.focus();
});
//-->
</script>
<div style="margin-top:10px;margin-bottom:10px;text-align:center;">

<center>


<div id='div-gpt-ad-1527185271042-1' style='height:90px; width:728px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-1'); });
</script>
</div>

</center>
</div>


<form action="/community/login/login?redirect=/how-to-create-references-in-onlyoffice-with-mendeley-zotero-and-easybib/" method="post" class="xenForm eAuth" id="login" style="display:none">
<ul id="eAuthUnit">
<li><a href="/community/register/facebook?reg=1" class="fbLogin" tabindex="110"><span>Log in with Facebook</span></a></li>
<li><a href="/community/register/twitter?reg=1" class="twitterLogin" tabindex="110"><span>Log in with Twitter</span></a></li>
<li><span class="googleLogin GoogleLogin JsOnly" tabindex="110" data-client-id="198773272284-b6tfk0c28bje81p774prrcrkq9jb3o44.apps.googleusercontent.com" data-redirect-url="/community/register/google?code=__CODE__&amp;csrf=hVMXbW_3rnrmq4Em"><span>Log in with Google</span></span></li>
</ul>
<div class="ctrlWrapper">
<dl class="ctrlUnit">
<dt><label for="LoginControl">Your name or email address:</label></dt>
<dd><input type="text" name="login" id="LoginControl" class="textCtrl" tabindex="101" /></dd>
</dl>
<dl class="ctrlUnit">
<dt>
<label for="ctrl_password">Do you already have an account?</label>
</dt>
<dd>
<ul>
<li><label for="ctrl_not_registered"><input type="radio" name="register" value="1" id="ctrl_not_registered" tabindex="105" />
No, create an account now.</label></li>
<li><label for="ctrl_registered"><input type="radio" name="register" value="0" id="ctrl_registered" tabindex="105" checked="checked" class="Disabler" />
Yes, my password is:</label></li>
<li id="ctrl_registered_Disabler">
<input type="password" name="password" class="textCtrl" id="ctrl_password" tabindex="102" />
<div class="lostPassword"><a href="/community/lost-password/" tabindex="106">Forgot your password?</a></div>
</li>
</ul>
</dd>
</dl>
<dl class="ctrlUnit submitUnit">
<dt></dt>
<dd>
<input type="submit" class="button primary" value="Log in" tabindex="104" data-loginPhrase="Log in" data-signupPhrase="Sign up" />
<label for="ctrl_remember" class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_remember" tabindex="103" /> Stay logged in</label>
</dd>
</dl>
</div>
<input type="hidden" name="cookie_check" value="1" />
<input type="hidden" name="redirect" value="/community/" />
<input type="hidden" name="_xfToken" value="" />
</form>

</div>
</div>

<aside>
<div class="sidebar">
<div class="section loginButton">
<div class="secondaryContent">
<label for="LoginControl" id="SignupButton"><a href="/community/login/" class="inner">Sign up now!</a></label>
</div>
</div>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-2">

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent socialMediaIcon">
<a href="https://twitter.com/howtoforgecom" target="_blank"><img src="/images/socialmedia/64x64/twitter.png" /></a>
<a href="https://www.facebook.com/howtoforge" target="_blank"><img src="/images/socialmedia/64x64/facebook.png" /></a>
<a href="https://news.ycombinator.com/" target="_blank" rel="nofollow"><img src="/images/socialmedia/64x64/hackernews.png" /></a>
<a href="https://www.howtoforge.com/feed" target="_blank"><img src="/images/socialmedia/64x64/rss.png" /></a>
</div>
</div>
</div>
<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Tutorial Info</p>
<div class="pairsJustified">
<dl class="discussionCount">
<dt>Author:</dt>
<dd><a href="/author/daria/" rel="author">Daria</a></dd>
</dl>
<dl class="discussionCount">
<dt>Published:</dt>
<dd>Jun 08, 2020</dd>
</dl>
<dl class="discussionCount">
<dt>Tags:</dt>
<dd><a href='/tutorials/linux/' rel='tag'>linux</a>, <a href='/tutorials/server/' rel='tag'>server</a></dd>
</dl>
</div>
</div>
</div>

<div id="sponsor-banner">
</div>

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent">
<p class="mnuinfo mnushare">Share This Page</p>
<p style="text-align:center;">
<a href="javascript:window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-create-references-in-onlyoffice-with-mendeley-zotero-and-easybib%2F', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="javascript:window.open('https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-create-references-in-onlyoffice-with-mendeley-zotero-and-easybib%2F&text=How+to+create+references+in+ONLYOFFICE+with+Mendeley%2C+Zotero+and+EasyBib&via=howtoforgecom&related=howtoforgecom', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="javascript:window.open('https://news.ycombinator.com/submitlink?t=How+to+create+references+in+ONLYOFFICE+with+Mendeley%2C+Zotero+and+EasyBib&u=https%3A%2F%2Fwww.howtoforge.com%2Fhow-to-create-references-in-onlyoffice-with-mendeley-zotero-and-easybib%2F', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-hackernews.png" height="20" /></a>
</p>
<p style="color:#EE; font-weight:bold; text-align:center; margin-top:5px;">40.2k Followers</p>
</div>
</div>
</div>


<script type="text/javascript">
    google_ad_client = "ca-pub-3043223216276099";
    google_ad_slot = "6709042890";
    google_ad_width = 300;
    google_ad_height = 600;
</script>

<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>


<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Popular Tutorials</p>
<div class="pairsJustified">
<ul>
<li><a href="/tutorial/linux-grep-command/">How to use grep to search for strings in files on the shell</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-use-ftp-on-the-linux-shell/">How to use the Linux ftp command to up- and download files on the shell</a></li>
<li><hr /></li>
<li><a href="/tutorial/perfect-server-ubuntu-18.04-with-apache-php-myqsl-pureftpd-bind-postfix-doveot-and-ispconfig/">The Perfect Server - Ubuntu 18.04 (Bionic Beaver) with Apache, PHP, MySQL, PureFTPD, BIND, Postfix, Dovecot and ISPConfig 3.1</a></li>
<li><hr /></li>
<li><a href="/tutorial/linux-search-files-from-the-terminal/">How to search files from the Terminal on Linux</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-create-docker-images-with-dockerfile-18-04/">How to create Docker Images with a Dockerfile on Ubuntu 18.04 LTS</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-setup-zsh-and-oh-my-zsh-on-linux/">How to Setup ZSH and Oh-my-zsh on Linux</a></li>
<li><hr /></li>
<li><a href="/faq/how-to-edit-files-on-the-command-line">How do I edit files on the command line?</a></li>
<li><hr /></li>
<li><a href="/configure-remote-access-to-your-ubuntu-desktop">How To Configure Remote Access To Your Ubuntu Desktop</a></li>
<li><hr /></li>
<li><a href="/linux-basics-set-a-static-ip-on-ubuntu">Linux Basics - Set a Static IP on Ubuntu</a></li>
<li><hr /></li>
<li><a href="/vim-basics">Vim Editor Basics</a></li>
<li><hr /></li>
</ul>
</div>
</div>
</div>
</div>
</div>
</aside>
</div>
</div>
</div>
<footer>
<div class="footer">
<div class="pageWidth">
<div class="pageContent">
<div class='skin_branding'><span>Xenforo skin by <a href="http://www.xenfocus.com" rel="nofollow">Xenfocus</a></span></div>
<ul class="footerLinks">
<li><a href="/contribute/">Contribute</a></li>
<li><a href="/community/misc/contact">Contact</a></li>
<li><a href="/community/help/">Help</a></li>
<li><a href="/imprint/">Imprint and Legal Notice</a></li>
<li><a href="#navigation" class="topLink">Top</a></li>
<li><a href="/feed" rel="alternate" class="globalFeed" target="_blank" title="RSS-Feed for Howtoforge">RSS-Feed</a></li>
</ul>
<span class="helper"></span>
</div>
</div>
</div>
<div class="footerLegal">
<div class="pageWidth">
<div class="pageContent">
<ul id="legal">
<li><a href="/community/help/terms">Terms and Rules</a> <a href="https://www.howtoforge.com/community/help/privacy-policy">Privacy Policy</a></li>
</ul>
<div id="copyright"><a href="https://www.howtoforge.com" class="concealed">Howtoforge <span>&copy; projektfarm GmbH.</span></a></div>
<span class="helper"></span>
</div>
</div>
</div>
</footer>
<div style="height:100px;"></div>

<div id="subscriptionModal" class="modal">
<div class="modal-content">
<span class="close">&times;</span>
<p>This feature is only available to subscribers. Get your subscription <a href="/subscription">here</a>.</p>
</div>
</div>
<script>
//* Modal
var modal = document.getElementById('subscriptionModal');
var span = document.getElementsByClassName("close")[0];
$(".pdf-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
$(".print-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
span.onclick = function() {
	$("#subscriptionModal").css('display', 'none');
}
window.onclick = function(event) {
    if (event.target == modal) {
		$("#subscriptionModal").css('display', 'none');
    }
}
//* Xenforo
jQuery.extend(true, XenForo,
{
	visitor: { user_id: 0 },
	serverTimeInfo:
	{
		now: 1409831907,
		today: 1409781600,
		todayDow: 4
	},
	_lightBoxUniversal: "0",
	_enableOverlays: "1",
	_animationSpeedMultiplier: "1",
	_overlayConfig:
	{
		top: "10%",
		speed: 200,
		closeSpeed: 100,
		mask:
		{
			color: "rgb(0, 0, 0)",
			opacity: "0.6",
			loadSpeed: 200,
			closeSpeed: 100
		}
	},
	_ignoredUsers: [],
	_loadedScripts: {"node_list":true,"node_category":true,"node_forum":true,"sidebar_share_page":true,"wf_default":true,"bbm_buttons":true,"login_bar":true,"twitter":true},
	_cookieConfig: { path: "/", domain: "", prefix: "xf_"},
	_csrfToken: "",
	_csrfRefreshUrl: "/community/login/csrf-token-refresh",
	_jsVersion: "303ae0ca"
});
jQuery.extend(XenForo.phrases,
{
	cancel: "Cancel",

	a_moment_ago:    "A moment ago",
	one_minute_ago:  "1 minute ago",
	x_minutes_ago:   "%minutes% minutes ago",
	today_at_x:      "Today at %time%",
	yesterday_at_x:  "Yesterday at %time%",
	day_x_at_time_y: "%day% at %time%",

	day0: "Sunday",
	day1: "Monday",
	day2: "Tuesday",
	day3: "Wednesday",
	day4: "Thursday",
	day5: "Friday",
	day6: "Saturday",

	_months: "January,February,March,April,May,June,July,August,September,October,November,December",
	_daysShort: "Sun,Mon,Tue,Wed,Thu,Fri,Sat",

	following_error_occurred: "The following error occurred",
	server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
	logging_in: "Logging in",
	click_image_show_full_size_version: "Click this image to show the full-size version.",
	show_hidden_content_by_x: "Show hidden content by {names}"
});

// Facebook Javascript SDK
XenForo.Facebook.appId = "";
XenForo.Facebook.forceInit = true;

/*
document.addEventListener('DOMContentLoaded', function(event) {
  cookieChoices.showCookieConsentBar('Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.',
  'OK');
});
*/

$(document).ready(function() {
	$("a.fancybox").fancybox();
});

</script>

<script>
_bsa.init('custom', 'CKYD55QU', 'placement:howtoforge',
    {
      target: '#sponsor-banner',
      template: `
<a href="##link##" style="background: linear-gradient(-330deg, ##backgroundColor##D9, ##backgroundColor##D9 30%, ##backgroundColor## 70%) #fff;" class="native-banner">
<img class="native-img" src="##logo##">
<div style="color: ##textColor##" class="native-tagline">##tagline##</div>
<div style="color: ##textColor##" class="native-desc">##description##</div>
<div style="color: ##ctaTextColor##; background-color: ##ctaBackgroundColor##;" class="native-cta">##callToAction##</div>
<div style="background-color: ##textColor##B2; color: ##backgroundColor##" class="native-ad">Ad</div>
</a>
`
    }
  );
</script>

<script>
(function() {
  if (typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('fancybar', 'CKYDL27E', 'placement:howtoforgecom');
  }
})();
</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2155872-1', 'auto');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');

</script>
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=33', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=33', false, [], true, false, false, false);
</script>
<script>var _audins_dom="howtoforge_com",_audins_did=178704;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=188-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.howtoforge_com,DomainId.178704" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript' data-cfasync='false'></script></body>
</html>