<!DOCTYPE html>
<html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs LoggedOut Sidebar Responsive" xmlns:fb="http://www.facebook.com/2008/fbml">
<head>
<meta charset="utf-8" />
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<base href="https://www.howtoforge.com" />
<script>
			var _b = document.getElementsByTagName('base')[0], _bH = "https://www.howtoforge.com/dockerizing-laravel-with-nginx-mysql-and-docker-compose/";
			if (_b && _b.href != _bH) _b.href = _bH;
		</script>
<title>Dockerizing Laravel with Nginx MySQL and Docker Compose on Ubuntu 18.04 LTS</title>
<meta name="description" content="In this guide, were going to show you how to Dockerize the Laravel project with PHP-FPM, MySQL database, and the Nginx web server using the Docker Co... " />
<meta property="og:title" content="Dockerizing Laravel with Nginx MySQL and Docker Compose on Ubuntu 18.04 LTS">
<meta property="og:description" content="In this guide, were going to show you how to Dockerize the Laravel project with PHP-FPM, MySQL database, and the Nginx web server using the Docker Co... ">
<meta property="og:site_name" content="HowtoForge">
<meta property="og:type" content="article">
<meta property="og:image" content="https://www.howtoforge.com/images/featured/ubuntu-docker-laravel.jpg">
<meta property="og:image:secure_url" content="https://www.howtoforge.com/images/featured/ubuntu-docker-laravel.jpg" />
<meta property="og:image:alt" content="Dockerizing Laravel with Nginx MySQL and Docker Compose on Ubuntu 18.04 LTS" />
<meta name="twitter:image" content="https://www.howtoforge.com/images/featured/ubuntu-docker-laravel.jpg" />
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="@howtoforgecom">
<meta name="twitter:creator" content="@howtoforgecom">
<meta name="twitter:title" content="Dockerizing Laravel with Nginx MySQL and Docker Compose on Ubuntu 18.04 LTS">
<meta name="twitter:description" content="In this guide, were going to show you how to Dockerize the Laravel project with PHP-FPM, MySQL database, and the Nginx web server using the Docker Co... ">
<link rel="alternate" href="https://www.howtoforge.com/dockerizing-laravel-with-nginx-mysql-and-docker-compose/" hreflang="en" />
<link rel="canonical" href="https://www.howtoforge.com/tutorial/dockerizing-laravel-with-nginx-mysql-and-docker-compose/" />
<link rel="amphtml" href="https://www.howtoforge.com/dockerizing-laravel-with-nginx-mysql-and-docker-compose/amp/" />
<script type="application/ld+json">
{
  "@context" : "http://schema.org",
  "@type" : "Article",
  "name" : "Dockerizing Laravel with Nginx MySQL and Docker Compose on Ubuntu 18.04 LTS",
  "author" : {
    "@type" : "Person",
    "name" : "Muhammad Arul"
  },
  "articleSection" : "linux,ubuntu,virtualization,web server",
  "url" : "https://www.howtoforge.com/dockerizing-laravel-with-nginx-mysql-and-docker-compose/",
  "publisher" : {
    "@type" : "Organization",
    "name" : "Howtoforge"
  }
}
</script>
<noscript><style>.JsOnly, .jsOnly { display: none !important; }</style></noscript>
<link rel="stylesheet" href="/community/styles/executive/xenfocus/icons/css/font-awesome.min.css" />
<link href='//fonts.googleapis.com/css?family=Open+Sans:400,700' rel='stylesheet' type='text/css' />
<link href="/themes/howtoforge/templates/xf.css" rel="stylesheet">
<script src="/js/jquery/jquery-1.11.3.min.js"></script>
<script src="/community/js/xenforo/xenforo.js?_v=303ae0ca"></script>
<script src="/community/js/bbm/zloader.js?_v=303ae0ca"></script>
<script type="text/javascript" src="/js/fancybox/jquery.mousewheel-3.0.4.pack.js"></script>
<script type="text/javascript" src="/js/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
<link rel="stylesheet" type="text/css" href="/js/fancybox/jquery.fancybox-1.3.4.css" media="screen" />
<link href="/themes/howtoforge/templates/style.min.css" rel="stylesheet">
<link rel="alternate" type="application/rss+xml" title="RSS-Feed für Howtoforge" href="/feed.rss" />
<script src="/js/tinymce_4.1.7/tinymce.min.js"></script>

<script type="text/javascript">
var gaProperty = 'UA-2155872-1';
var disableStr = 'ga-disable-' + gaProperty;
if (document.cookie.indexOf(disableStr + '=true') > -1) {
window[disableStr] = true;
}
function gaOptout() {
document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
window[disableStr] = true;
alert('Google Ananlyitics tracking has been disabled in this browser.');
}
</script>
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
	googletag.defineSlot('/1030080/howtoforge_com_list_sidebar_top', [300, 250], 'div-gpt-ad-1527185271042-4').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_list_content_middle', [[300, 250], [336, 280]], 'div-gpt-ad-1527185271042-5').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_a_300x250', [300, 250], 'div-gpt-ad-1527185271042-6').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_rectangle_b_300x250', [300, 250], 'div-gpt-ad-1527185271042-7').addService(googletag.pubads());
    googletag.defineSlot('/1030080/howtoforge_com_article_leaderboard_b_728x90', [728, 90], 'div-gpt-ad-1527185271042-1').addService(googletag.pubads());
	googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-3043223216276099",
          enable_page_level_ads: true
     });
</script>


<script type="text/javascript">
    window.cookieconsent_options = {"message":"This website uses cookies to ensure you get the best experience on our website, analyze site traffic and show you relevant ads.","dismiss":"Got it!","learnMore":"More info","link":"https://www.howtoforge.com/community/help/cookies","theme":"dark-bottom"};
</script>
<script type="text/javascript" src="/js/cookieconsent.latest.min.js"></script>

</head>
<body>
<div id="loginBar">
<div class="pageWidth">
<div class="pageContent">
<h3 id="loginBarHandle">
<label for="LoginControl"><a href="/community/login/" class="concealed noOutline">Log in or Sign up</a></label>
</h3>
<span class="helper"></span>
</div>
</div>
</div>
<header>
<div id="header">
<div id="logoBlock">
<div class="pageWidth">
<div class="pageContent">
<div id="logo"><a href="/">
<span></span>
<img src="/images/howtoforge_logo_trans.gif" alt="Howtoforge" style="margin-left:20px;" />
</a></div>
<span class="helper"></span>
</div>
</div>
</div>
<div id="navigation" class="pageWidth withSearch">
<div class="pageContent">
<nav>
<div class="navTabs">
<ul class="publicTabs">

<li class="navTab forums selected">
<a href="/" class="navLink">Tutorials</a>
<div class="tabLinks forumsTabLinks">
<ul class="secondaryContent blockLinksList">
<li><a href="/search/">Tutorial search</a></li>
</ul>
</div>
</li>
<li class="navTab forums PopupClosed">
<a href="/tutorials/" class="navLink">Tags</a>
</li>
<li class="navTab forums PopupClosed"><a href="/community/" class="navLink">Forums</a></li>
<li class="navTab forums PopupClosed"><a href="/linux-commands/" class="navLink">Linux Commands</a></li>
<li class="navTab forums PopupClosed"><a href="/subscription/" class="navLink">Subscribe</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.ispconfig.org" class="navLink">ISPConfig</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.lxer.com" class="navLink">News</a></li>
</ul>
</div>
<span class="helper"></span>
</nav>
</div>
</div>
<div id="searchBar" class="pageWidth">
<span id="QuickSearchPlaceholder" title=" Search..."> Search</span>
<fieldset id="QuickSearch">
<form action="/" method="post" class="formPopup">
<div class="primaryControls">

<input type="search" name="q" value="" class="textCtrl" placeholder="Search..." results="0" title="Enter your search and hit enter..." id="QuickSearchQuery" />

</div>
<input type="hidden" name="_xfToken" value="" />
</form>
</fieldset>
</div>
</div>
</header>
<div id="content" class="forum_list">
<div class="pageWidth">
<div class="pageContent">

<div class="mainContainer">
<div class="mainContent">

<div class="breadBoxTop">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Home</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/dockerizing-laravel-with-nginx-mysql-and-docker-compose/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Dockerizing Laravel with Nginx MySQL and Docker Compose on Ubuntu 18.04 LTS</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>

<div id="htfContentPage">
<div class="bsa-apiads"><a href="//srv.buysellads.com/ads/click/x/GTND42QMC6AIV23WC6A4YKQMCW7DTKJJCT7IVZ3JCWBI6K3MCKAI42JKC6BIPKQ7CKBDEK3EHJNCLSIZ" target="_blank" rel="nofollow">HelloSign is the #1 rated eSignature tool. It's the easiest way to sign docs, forms or agreements online.</a></div>
<article>
<h1>Dockerizing Laravel with Nginx MySQL and Docker Compose on Ubuntu 18.04 LTS</h1>
<div class="contributeEdit" style="float:right; width:450px; max-width:100%;">
<div id="tocContainer">
<h3>On this page</h3>
<ol class="toc">
<li><a href="#step-install-docker-and-docker-compose">Step 1 - Install Docker and Docker Compose</a></li>
<li><a href="#step-download-laravel-and-install-dependencies">Step 2 - Download Laravel and Install Dependencies</a></li>
<li><a href="#step-dockerizing-the-laravel-project">Step 3 - Dockerizing the Laravel Project</a>
<ol>
<li><a href="#-define-the-laravel-app-service">- Define the Laravel App Service</a></li>
<li><a href="#-define-nginx-http-service">- Define Nginx HTTP Service</a></li>
<li><a href="#-define-mysql-database-service">- Define MySQL Database Service</a></li>
<li><a href="#-create-nginx-virtual-host-for-laravel">- Create Nginx Virtual Host for Laravel</a></li>
<li><a href="#-create-dockerfile-for-the-laravel-app">- Create Dockerfile for the Laravel App</a></li>
</ol>
</li>
<li><a href="#step-build-laravel-with-nginx-and-mysql-services">Step 4 - Build Laravel with Nginx and MySQL Services</a></li>
<li><a href="#step-laravel-postinstallation">Step 5 - Laravel Post-Installation</a></li>
</ol>
</div>
</div>
<p>Laravel is a free and open source PHP framework that implements the MVC (Model-View-Controller) design pattern. It's designed with ease of use and allows developers to create both simple and complex applications within no time. Laravel was created by Taylor Otwell in 2011, as an attempt to provide an advanced alternative to the CodeIgniter (CI) framework. In 2011, Laravel released version 1 and version 2, and the latest version 5.6 comes with more and improved features like Command-Line (CLI) support named 'artisan', support for different database systems, Route improvements, etc.</p>
<p>In this guide, we're going to show you how to Dockerize the Laravel project with PHP-FPM, MySQL database, and the Nginx web server using the Docker Compose on the Ubuntu Server 18.04. We're going to create a new docker image for the Laravel Project, and then create the docker-compose.yml script that contains some services including, the App/Laravel itself, Nginx web server, and MySQL database.</p>
<p><strong>Prerequisites</strong></p>
<ul>
<li>Ubuntu 18.04</li>
<li>Root privileges</li>
</ul>
<p><strong>What we will do:</strong></p>
<ol>
<li>Install Docker and Docker Compose</li>
<li>Download Laravel and Install Dependencies</li>
<li>Dockerizing the Laravel Project</li>
<ul>
<li>Define Laravel App Service</li>
<li>Define Nginx HTTP Service</li>
<li>Define MySQL Database Service</li>
<li>Create Nginx Virtual Host for Laravel</li>
<li>Create Dockerfile for Laravel App</li>
</ul>
<li>Build the Laravel Project</li>
<li>Laravel Post-Installation</li>
</ol>
<h2 id="step-install-docker-and-docker-compose">Step 1 - Install Docker and Docker Compose</h2>
<p>Firstly, we're going to install Docker and Docker Compose packages to the Ubuntu system. And we will be using Docker packages from the Official Ubuntu repository.</p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;">

<div id='div-gpt-ad-1527185271042-6' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-6'); });
</script>
</div>
</div>
<p>Before going any further, we need to update repositories on the Ubuntu system. Simply by running the following command.</p>
<pre class="command"><code spellcheck="false">sudo apt update</code></pre>
<p>Now install Docker and Docker Compose packages using the apt command below.</p>
<pre class="command"><code spellcheck="false">sudo apt install docker.io -y<br />sudo apt install docker-compose -y</code></pre>
<p>The Docker and Docker Compose packages should now installed on the system, check it using the following commands.</p>
<pre class="command"><code spellcheck="false">docker version<br />docker-compose version</code></pre>
<p>As a result, you will get the version of Docker and Docker Compose on the system.</p>
<p><a class="fancybox" id="img-1" href="https://www.howtoforge.com/images/dockerizing_laravel_with_nginx_mysql_and_docker_compose/big/1.png"><img src="https://www.howtoforge.com/images/dockerizing_laravel_with_nginx_mysql_and_docker_compose/1.png" alt="Check docker version" width="500" height="517" style="display: block; margin-left: auto; margin-right: auto;" /></a></p>
<p>Next, we need to assign the non-root user to the docker group in order to run the Docker container for non-root users.</p>
<p>For this case, we're going to add the user called 'hakase' to the docker group by running the following command.</p>
<pre class="command"><code spellcheck="false">usermod -a -G docker hakase</code></pre>
<p>And after that, log in to the 'hakase' user shell and run the docker 'hello-world' command.</p>
<pre class="command"><code spellcheck="false">su - hakase<br />docker run hello-world</code></pre>
<p>Now you will be displayed the 'Hello World' message from Docker, and the Docker installation has been completed.</p>
<p style="text-align: center;"><a class="fancybox" id="img-2" href="https://www.howtoforge.com/images/dockerizing_laravel_with_nginx_mysql_and_docker_compose/big/2.png"><img src="https://www.howtoforge.com/images/dockerizing_laravel_with_nginx_mysql_and_docker_compose/2.png" alt="Add docker user" width="500" height="417" /></a></p>
<h2 id="step-download-laravel-and-install-dependencies">Step 2 - Download Laravel and Install Dependencies</h2>
<p>In this step,&nbsp; we're going to download Laravel web-framework to the 'hakase' home directory and then install Laravel dependencies using the PHP 'composer' docker image. So, ensure that you're logged in to the server as a non-root user.</p>
<p>Download Laravel project to the 'myapp' directory and go into it.</p>
<pre class="command"><code spellcheck="false">git clone https://github.com/laravel/laravel.git myapp/<br />cd myapp/</code></pre>
<p>Now run the following docker command in order to install Laravel dependencies.</p>
<pre class="command"><code spellcheck="false">docker run --rm -v $(pwd):/app composer install</code></pre>
<p>With the command above, we're going to run a new temporary docker container and mount the 'myapp' project directory to the '/app' directory on the container. The container based on the 'composer' docker image, and we're installing Laravel dependencies using the 'composer' command inside that temporary container.</p>
<p style="text-align: center;"><a class="fancybox" id="img-3" href="https://www.howtoforge.com/images/dockerizing_laravel_with_nginx_mysql_and_docker_compose/big/3.png"><img src="https://www.howtoforge.com/images/dockerizing_laravel_with_nginx_mysql_and_docker_compose/3.png" alt="Get Laravel Framework" width="500" height="166" /></a></p>
<p>Once the Laravel dependencies installation is finished, we must change the owner of 'myapp' directory to our own user using sudo command below.</p>
<pre class="command"><code spellcheck="false">sudo chown -R $USER:$USER ~/myapp</code></pre>
<p style="text-align: center;"><a class="fancybox" id="img-4" href="https://www.howtoforge.com/images/dockerizing_laravel_with_nginx_mysql_and_docker_compose/big/4.png"><img src="https://www.howtoforge.com/images/dockerizing_laravel_with_nginx_mysql_and_docker_compose/4.png" alt="Change owner of app directory" width="500" height="244" /></a></p>
<h2 id="step-dockerizing-the-laravel-project">Step 3 - Dockerizing the Laravel Project</h2>
<p>After downloading the Laravel and installing its dependencies, we're going to create a new docker-compose.yml script and create a new Dockerfile for the Laravel project.</p>
<pre class="command"><code spellcheck="false">cd myapp/<br />vim docker-compose.yml</code></pre>
<h3 id="-define-the-laravel-app-service">- Define the Laravel App Service</h3>
<p>Firstly, we're going to define the Laravel project itself and build the docker image for the Laravel project using the Dockerfile.</p>
<p>Paste the docker compose script into it.</p>
<pre><code spellcheck="false">version: '3'<br />services:<br /><br />&nbsp; #Laravel App<br />&nbsp; app:<br />&nbsp;&nbsp;&nbsp; build:<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; context: .<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; dockerfile: Dockerfile<br />&nbsp;&nbsp;&nbsp; image: hakase-labs/laravel<br />&nbsp;&nbsp;&nbsp; container_name: app<br />&nbsp;&nbsp;&nbsp; restart: unless-stopped<br />&nbsp;&nbsp;&nbsp; tty: true<br />&nbsp;&nbsp;&nbsp; environment:<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; SERVICE_NAME: app<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; SERVICE_TAGS: dev<br />&nbsp;&nbsp;&nbsp; working_dir: /var/www/html<br />&nbsp;&nbsp;&nbsp; volumes:<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; - ./:/var/www/html<br />&nbsp;&nbsp;&nbsp; networks:<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; - mynet</code></pre>
<p>Details of the Laravel container service:</p>
<ul>
<li>The Laravel container service will be named as 'app'. It's based on our custom docker image that will be created with our 'Dockerfile', and the new image will be named as 'hakase-labs/laravel'.</li>
<li>We want to mount the 'myapp' project directory to the '/var/www/html' inside the container service.</li>
<li>We're using the custom docker network for our setup, the network will be named as 'mynet'.</li>
</ul>
<h3 id="-define-nginx-http-service">- Define Nginx HTTP Service</h3>
<p>Now we will define the nginx container service.</p>
<p>Paste the following configuration after the 'app' container service line.</p>
<pre><code spellcheck="false">&nbsp; #Nginx Service<br />&nbsp; nginx:<br />&nbsp;&nbsp;&nbsp; image: nginx:alpine<br />&nbsp;&nbsp;&nbsp; container_name: nginx<br />&nbsp;&nbsp;&nbsp; restart: unless-stopped<br />&nbsp;&nbsp;&nbsp; tty: true<br />&nbsp;&nbsp;&nbsp; ports:<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; - "80:80"<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; - "443:443"<br />&nbsp;&nbsp;&nbsp; volumes:<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; - ./:/var/www/html<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; - ./nginx/conf.d/:/etc/nginx/conf.d/<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; - ./nginx/ssl/:/etc/nginx/ssl/<br />&nbsp;&nbsp;&nbsp; networks:<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; - mynet</code></pre>
<p>Configuration details of the nginx container service:</p>
<ul>
<li>We want to create a new container named 'nginx' based on the docker image 'nginx:alpine'.</li>
<li>The container service will open the HTTP and HTTPS ports.</li>
<li>The container will mount three different volumes. The 'myapp' project directory to the '/var/www/html' directory, the nginx virtual host configuration 'nginx/conf.d/' to the '/etc/nginx/conf.d' directory, and mount certificate files 'nginx/ssl/' to the '/etc/nginx/ssl' directory on the container.</li>
<li>The container service will be using the same network called 'mynet'.</li>
</ul>
<h3 id="-define-mysql-database-service">- Define MySQL Database Service</h3>
<p>And the last, we define the MySQL database service.</p>
<p>Paste the following configuration after the 'nginx' container service line.</p>
<pre><code spellcheck="false">&nbsp; #MySQL Service<br />&nbsp; db:<br />&nbsp;&nbsp;&nbsp; image: mysql:5.7<br />&nbsp;&nbsp;&nbsp; container_name: db<br />&nbsp;&nbsp;&nbsp; restart: unless-stopped<br />&nbsp;&nbsp;&nbsp; tty: true<br />&nbsp;&nbsp;&nbsp; ports:<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; - "3306:3306"<br />&nbsp;&nbsp;&nbsp; environment:<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; MYSQL_DATABASE: laraveldb<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; MYSQL_USER: laravel<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; MYSQL_PASSWORD: laravelpassworddb<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; MYSQL_ROOT_PASSWORD: rootpasswordmysql<br />&nbsp;&nbsp;&nbsp; volumes:<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; - mysqldata:/var/lib/mysql/<br />&nbsp;&nbsp;&nbsp; networks:<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; - mynet<br /><br />#Docker Networks<br />networks:<br />&nbsp; mynet:<br />&nbsp;&nbsp;&nbsp; driver: bridge<br />#Volumes<br />volumes:<br />&nbsp; mysqldata:<br />&nbsp;&nbsp;&nbsp; driver: local</code></pre>
<p>Save and close the configuration.</p>
<p>Details MySQL container service:</p>
<ul>
<li>The MySQL container service will be named as 'db', based on the 'mysql:5.7' docker image.</li>
<li>The 'db' service will open the default MySQL port '3306'.</li>
<li>The Laravel project will be using the database, user, and the password based on the environment variable of the 'db' service.</li>
<li>The MySQL 'db' service will mount the volume named 'mysqldata', and have the same network 'mynet'.</li>
<li>And we define the custom network 'mynet' with the 'bridge' driver, and the 'mysqldata' volume will be using the 'local' driver.</li>
</ul>
<p>Below is the completed 'docker-compose.yml' configuration:</p>
<pre>version: '3'
services:

  #Laravel App
  app:
    build:
      context: .
      dockerfile: Dockerfile
    image: hakase-labs/laravel
    container_name: app
    restart: unless-stopped
    tty: true
    environment:
      SERVICE_NAME: app
      SERVICE_TAGS: dev
    working_dir: /var/www/html
    volumes:
      - ./:/var/www/html
    networks:
      - mynet

  #Nginx Service
  nginx:
    image: nginx:alpine
    container_name: nginx
    restart: unless-stopped
    tty: true
    ports:
      - "80:80"
      - "443:443"
    volumes:
      - ./:/var/www/html
      - ./nginx/conf.d/:/etc/nginx/conf.d/
      - ./nginx/ssl/:/etc/nginx/ssl/
    networks:
      - mynet

  #MySQL Service
  db:
    image: mysql:5.7
    container_name: db
    restart: unless-stopped
    tty: true
    ports:
      - "3306:3306"
    environment:
      MYSQL_DATABASE: laraveldb
      MYSQL_USER: laravel
      MYSQL_PASSWORD: laravelpassworddb
      MYSQL_ROOT_PASSWORD: rootpasswordmysql
    volumes:
      - mysqldata:/var/lib/mysql/
    networks:
      - mynet

#Docker Networks
networks:
  mynet:
    driver: bridge
#Volumes
volumes:
  mysqldata:
    driver: local</pre>
<h3 id="-create-nginx-virtual-host-for-laravel">- Create Nginx Virtual Host for Laravel</h3>
<p>Within the 'myapp' project directory, create a new directory named 'nginx' that will contain two other directories 'conf.d' and 'ssl'. Then create a new nginx virtual host configuration 'laravel.conf' inside the 'conf.d' directory.</p>
<p>Run the following command.</p>
<pre class="command"><code spellcheck="false">mkdir -p nginx/{conf.d,ssl}<br />vim nginx/conf.d/laravel.conf</code></pre>
<pre>server {
    listen 80;
    server_name laravel.hakase-labs.io;

    return 301 https://laravel.hakase-labs.io$request_uri;
}


server {
    listen 443 ssl http2;
    server_name laravel.hakase-labs.io;

    ssl_certificate /etc/nginx/ssl/fullchain.pem;
    ssl_certificate_key /etc/nginx/ssl/privkey.pem;

    # Log files for Debug
    error_log  /var/log/nginx/error.log;
    access_log /var/log/nginx/access.log;

    # Laravel web root directory
    root /var/www/html/public;
    index index.php index.html;

    location / {
        try_files $uri $uri/ /index.php?$query_string;
        gzip_static on;
    }

    # Nginx Pass requests to PHP-FPM
    location ~ \.php$ {
        try_files $uri =404;
        fastcgi_split_path_info ^(.+\.php)(/.+)$;
        fastcgi_pass app:9000;
        fastcgi_index index.php;
        include fastcgi_params;
        fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
        fastcgi_param PATH_INFO $fastcgi_path_info;
    }
}</pre>
<p>Save and close.</p>
<p>After that, copy your ssl certificate file to the 'nginx/ssl/' directory.</p>
<pre class="command"><code spellcheck="false">sudo cp /path/to/ssl/fullchain.pem nginx/ssl/<br />sudo cp /path/to/ssl/privkey.pem nginx/ssl/</code></pre>
<h3 id="-create-dockerfile-for-the-laravel-app">- Create Dockerfile for the Laravel App</h3>
<p>Next, create a new Dockerfile for the Laravel project.</p>
<p>Run the following command.</p>
<pre class="command"><code spellcheck="false">vim Dockerfile</code></pre>
<p>Paste configuration below.</p>
<pre># Set master image
FROM php:7.2-fpm-alpine

# Copy composer.lock and composer.json
COPY composer.lock composer.json /var/www/html/

# Set working directory
WORKDIR /var/www/html

# Install Additional dependencies
RUN apk update &amp;&amp; apk add --no-cache \
    build-base shadow vim curl \
    php7 \
    php7-fpm \
    php7-common \
    php7-pdo \
    php7-pdo_mysql \
    php7-mysqli \
    php7-mcrypt \
    php7-mbstring \
    php7-xml \
    php7-openssl \
    php7-json \
    php7-phar \
    php7-zip \
    php7-gd \
    php7-dom \
    php7-session \
    php7-zlib

# Add and Enable PHP-PDO Extenstions
RUN docker-php-ext-install pdo pdo_mysql
RUN docker-php-ext-enable pdo_mysql

# Install PHP Composer
RUN curl -sS https://getcomposer.org/installer | php -- --install-dir=/usr/local/bin --filename=composer

# Remove Cache
RUN rm -rf /var/cache/apk/*

# Add UID '1000' to www-data
RUN usermod -u 1000 www-data

# Copy existing application directory permissions
COPY --chown=www-data:www-data . /var/www/html

# Change current user to www
USER www-data

# Expose port 9000 and start php-fpm server
EXPOSE 9000
CMD ["php-fpm"]</pre>
<p>Save and close the configuration.</p>
<p>And we're ready to build the 'myapp' Laravel project and run container services that we've defined.</p>
<h2 id="step-build-laravel-with-nginx-and-mysql-services">Step 4 - Build Laravel with Nginx and MySQL Services</h2>
<p>Build the custom docker image for our Laravel project using the following command.</p>
<pre class="command"><code spellcheck="false">docker-compose build</code></pre>
<p style="text-align: center;"><a class="fancybox" id="img-5" href="https://www.howtoforge.com/images/dockerizing_laravel_with_nginx_mysql_and_docker_compose/big/5.png"><img src="https://www.howtoforge.com/images/dockerizing_laravel_with_nginx_mysql_and_docker_compose/5.png" alt="Build Laravel with Nginx and MySQL Services" width="500" height="352" /></a></p>
<p>Then run again the following command.</p>
<pre class="command"><code spellcheck="false">docker-compose up -d</code></pre>
<p>It will download all docker images as we need and then build container services based on the 'docker-compose.yml' configuration.</p>
<p style="text-align: center;"><a class="fancybox" id="img-6" href="https://www.howtoforge.com/images/dockerizing_laravel_with_nginx_mysql_and_docker_compose/big/6.png"><img src="https://www.howtoforge.com/images/dockerizing_laravel_with_nginx_mysql_and_docker_compose/6.png" alt="Download docker images" width="500" height="425" /></a></p>
<p>When it's complete, verify using the docker-compose command below.</p>
<pre class="command"><code spellcheck="false">docker-compose ps</code></pre>
<p>And as a result, you will get the three container services are up and running. The 'app' that is running on default port '9000' PHP-FPM, the service 'nginx' is on the HTTP and HTTPS ports, and the MySQL 'db' service on the default MySQL port '3306'.</p>
<p>After that, verify again all available docker image and the open ports on the system.</p>
<pre class="command"><code spellcheck="false">docker-compose images<br />netstat -plntu</code></pre>
<p>You will get the custom docker image 'hakase-labs/laravel' on the list, and the HTTP and HTTPS port are on the 'LISTEN' state.</p>
<p style="text-align: center;"><a class="fancybox" id="img-7" href="https://www.howtoforge.com/images/dockerizing_laravel_with_nginx_mysql_and_docker_compose/big/7.png"><img src="https://www.howtoforge.com/images/dockerizing_laravel_with_nginx_mysql_and_docker_compose/7.png" alt="Check docker setup with netstat" width="500" height="311" /></a></p>
<h2 id="step-laravel-postinstallation">Step 5 - Laravel Post-Installation</h2>
<p>Until this stage, the Laravel project is up and running as a Docker container. And now we're going to create a new '.env' file, generate the key and migrate the Laravel data using the Laravel command line 'artisan'.</p>
<p>Copy the example of '.env' file and edit it inside the container.</p>
<pre class="command"><code spellcheck="false">cp .env.example .env<br />docker-compose exec app vim .env</code></pre>
<p>Change the database configuration as below.</p>
<pre><code spellcheck="false">DB_CONNECTION=mysql<br />DB_HOST=db<br />DB_PORT=3306<br />DB_DATABASE=laraveldb<br />DB_USERNAME=laravel<br />DB_PASSWORD=laravelpassworddb</code></pre>
<p>Save and close.</p>
<p>Next, generate the Laravel application key and clear the cache configuration.</p>
<pre class="command"><code spellcheck="false">docker-compose exec app php artisan key:generate<br />docker-compose exec app php artisan config:cache</code></pre>
<p>After that, migrate the database using the following command.</p>
<pre class="command"><code spellcheck="false">docker-compose exec app php artisan migrate</code></pre>
<p>Ensure there is no error.</p>
<p style="text-align: center;"><a class="fancybox" id="img-8" href="https://www.howtoforge.com/images/dockerizing_laravel_with_nginx_mysql_and_docker_compose/big/8.png"><img src="https://www.howtoforge.com/images/dockerizing_laravel_with_nginx_mysql_and_docker_compose/8.png" alt="Laravel post installation" width="500" height="220" /></a></p>
<p>Now open your web browser and type the domain name of your project.</p>
<p><em><strong>http://laravel.hakase-labs.io/</strong></em></p>
<p>And you will be redirected to the secure HTTPS connection and will be displayed the default Laravel home page as below.</p>
<p style="text-align: center;"><a class="fancybox" id="img-9" href="https://www.howtoforge.com/images/dockerizing_laravel_with_nginx_mysql_and_docker_compose/big/9.png"><img src="https://www.howtoforge.com/images/dockerizing_laravel_with_nginx_mysql_and_docker_compose/9.png" alt="Laravel with Docker successfully installed" width="500" height="198" /></a></p>
<p>Finally, the Dockerizing of Laravel project with Nginx web server and MySQL database has been completed successfully.</p>
</article>

<aside class="authorbox" style="margin-top:20px;">
<p><strong>About Muhammad Arul</strong></p>
<p>Muhammad Arul is a freelance system administrator and technical writer. He is working with Linux Environments for more than 5 years, an Open Source enthusiast and highly motivated on Linux installation and troubleshooting. Mostly working with RedHat/CentOS Linux and Ubuntu/Debian, Nginx and Apache web server, Proxmox, Zimbra Administration, and Website Optimization. Currently learning about OpenStack and Container Technology.</p>
</aside>

<div style="height:30px; margin-top:20px;">
<p style="text-align:right;"><img src="/images/pdficon_small.png" /> <a class="pdf-btn" href="javascript:void(0);">view as pdf</a> | <img src="/images/print.gif" /> <a class="print-btn" href="javascript:void(0);">print</a></p>
</div>
<div style="height:30px; margin-top:20px;">
<div style="float:left;"><b>Share this page:</b></div>
<p style="text-align:center;">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Fdockerizing-laravel-with-nginx-mysql-and-docker-compose%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Fdockerizing-laravel-with-nginx-mysql-and-docker-compose%2F&text=Dockerizing+Laravel+with+Nginx+MySQL+and+Docker+Compose+on+Ubuntu+18.04+LTS&via=howtoforgecom&related=howtoforgecom" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.howtoforge.com%2Fdockerizing-laravel-with-nginx-mysql-and-docker-compose%2F" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-gplus.png" height="20" /></a>
</p>
</div>
</div>


<div id="htfContentPagePaging">
<h2>Suggested articles</h2>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-3043223216276099" data-ad-slot="8940054090"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>


<div id="htfContentPageComment">
<a name="comments"></a>
<h2>0 Comment(s)</h2>

<div id="commentform">
<div class="commentContainerHead" style="font-size:18px;">Add comment</div>
<div class="commentContainer">
<form method="post" action="/dockerizing-laravel-with-nginx-mysql-and-docker-compose/#comments">
<input type="hidden" name="reply_to" id="reply-to-comment" value="0" />
<div id="commentFormDetail">
<div style="width:48%; float:left; margin-right:3%">
<label for="commentname">Name *</label>
<input id="commentname" name="commentname" value="" />
</div>
<div style="width:48%;float:left;">
<label for="commentname">Email *</label>
<input id="commentemail" name="commentemail" value="" />
</div>
<div style="clear:both;"></div>
</div>
<textarea id="commentedit" name="commentedit" style="width:auto;"></textarea>
<div>
<div style="float:left;">
<div class="g-recaptcha" data-sitekey="6LdX9fUSAAAAALWwVoPdeXScMSketz4npF-0QcQ1"></div>
<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en">
      </script>
</div>
<div style="margin-top:10px;margin-bottom:10px;">
<input type="submit" name="submit" class="button primary" style="float:right;" value="Submit comment">
</div>
<div style="clear:both;"></div>
</div>
<script>
	tinymce.init({
		selector: "textarea#commentedit",
		theme: "modern",
		height: 100,
		apply_source_formatting : true,
		remove_linebreaks : false,
		menubar : false,
		/*auto_focus : "commentedit",*/
		plugins: [
		"link"
		],
		/*plugins: [
			"advlist autolink link image lists charmap print preview hr anchor pagebreak spellchecker",
			"searchreplace wordcount visualblocks visualchars code fullscreen insertdatetime media nonbreaking",
			"save table contextmenu directionality emoticons template paste textcolor"
		],*/
		content_css: "https://www.howtoforge.com/themes/howtoforge/css/custom.css",
		toolbar: "undo redo | bold italic link", 
		/*style_formats: [
			{title: 'Bold text', inline: 'b'},
			{title: 'Red text', inline: 'span', styles: {color: '#ff0000'}},
			{title: 'Red header', block: 'h1', styles: {color: '#ff0000'}},
			{title: 'Example 1', inline: 'span', classes: 'example1'},
			{title: 'Example 2', inline: 'span', classes: 'example2'},
			{title: 'Table styles'},
			{title: 'Table row 1', selector: 'tr', classes: 'tablerow1'}
		]*/
	}); 
	</script>
</form>
</div>
</div>

</div>

<div class="breadBoxBottom">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Home</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/dockerizing-laravel-with-nginx-mysql-and-docker-compose/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Dockerizing Laravel with Nginx MySQL and Docker Compose on Ubuntu 18.04 LTS</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
<script>
<!--

$(document).on('click', 'a.reply-to', function(e) {
	e.preventDefault();
	
	var self = $(this);
	var cid = self.attr('data-comment');
	console.log(cid);
	if(!cid) return this;
	
	$('#commentform').insertAfter('#comment' + cid);
	$('#reply-to-comment').val(cid);
	/*tinyMCE.activeEditor.focus();*/
	var textareaId = 'commentedit';
	tinyMCE.get(textareaId).remove();
	tinyMCE.execCommand("mceAddEditor", false, textareaId);
	tinyMCE.activeEditor.focus();
});
//-->
</script>
<div style="margin-top:10px;margin-bottom:10px;text-align:center;">

<center>


<div id='div-gpt-ad-1527185271042-1' style='height:90px; width:728px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1527185271042-1'); });
</script>
</div>

</center>
</div>


<form action="/community/login/login?redirect=/dockerizing-laravel-with-nginx-mysql-and-docker-compose/" method="post" class="xenForm eAuth" id="login" style="display:none">
<ul id="eAuthUnit">
<li><a href="/community/register/facebook?reg=1" class="fbLogin" tabindex="110"><span>Log in with Facebook</span></a></li>
<li><a href="/community/register/twitter?reg=1" class="twitterLogin" tabindex="110"><span>Log in with Twitter</span></a></li>
<li><span class="googleLogin GoogleLogin JsOnly" tabindex="110" data-client-id="198773272284-b6tfk0c28bje81p774prrcrkq9jb3o44.apps.googleusercontent.com" data-redirect-url="/community/register/google?code=__CODE__&amp;csrf=hVMXbW_3rnrmq4Em"><span>Log in with Google</span></span></li>
</ul>
<div class="ctrlWrapper">
<dl class="ctrlUnit">
<dt><label for="LoginControl">Your name or email address:</label></dt>
<dd><input type="text" name="login" id="LoginControl" class="textCtrl" tabindex="101" /></dd>
</dl>
<dl class="ctrlUnit">
<dt>
 <label for="ctrl_password">Do you already have an account?</label>
</dt>
<dd>
<ul>
<li><label for="ctrl_not_registered"><input type="radio" name="register" value="1" id="ctrl_not_registered" tabindex="105" />
No, create an account now.</label></li>
<li><label for="ctrl_registered"><input type="radio" name="register" value="0" id="ctrl_registered" tabindex="105" checked="checked" class="Disabler" />
Yes, my password is:</label></li>
<li id="ctrl_registered_Disabler">
<input type="password" name="password" class="textCtrl" id="ctrl_password" tabindex="102" />
<div class="lostPassword"><a href="/community/lost-password/" tabindex="106">Forgot your password?</a></div>
</li>
</ul>
</dd>
</dl>
<dl class="ctrlUnit submitUnit">
<dt></dt>
<dd>
<input type="submit" class="button primary" value="Log in" tabindex="104" data-loginPhrase="Log in" data-signupPhrase="Sign up" />
<label for="ctrl_remember" class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_remember" tabindex="103" /> Stay logged in</label>
</dd>
</dl>
</div>
<input type="hidden" name="cookie_check" value="1" />
<input type="hidden" name="redirect" value="/community/" />
<input type="hidden" name="_xfToken" value="" />
</form>

</div>
</div>

<aside>
<div class="sidebar">
<div class="section loginButton">
<div class="secondaryContent">
<label for="LoginControl" id="SignupButton"><a href="/community/login/" class="inner">Sign up now!</a></label>
</div>
</div>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-2">

<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent socialMediaIcon">
<a href="https://twitter.com/howtoforgecom" target="_blank"><img src="/images/socialmedia/64x64/twitter.png" /></a>
<a href="https://www.facebook.com/howtoforge" target="_blank"><img src="/images/socialmedia/64x64/facebook.png" /></a>
<a href="https://plus.google.com/+howtoforge/posts" target="_blank"><img src="/images/socialmedia/64x64/googleplus.png" /></a>
<a href="https://www.howtoforge.com/feed" target="_blank"><img src="/images/socialmedia/64x64/rss.png" /></a>
</div>
</div>
</div>
<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Tutorial Info</p>
<div class="pairsJustified">
<dl class="discussionCount">
<dt>Author:</dt>
<dd><a href="/author/muhammad+arul/" rel="author">Muhammad Arul</a></dd>
</dl>
<dl class="discussionCount">
<dt>Published:</dt>
<dd>Mar 06, 2019</dd>
</dl>
<dl class="discussionCount">
<dt>Tags:</dt>
<dd><a href='/tutorials/linux/' rel='tag'>linux</a>, <a href='/tutorials/ubuntu/' rel='tag'>ubuntu</a>, <a href='/tutorials/virtualization/' rel='tag'>virtualization</a>, <a href='/tutorials/web+server/' rel='tag'>web server</a></dd>
</dl>
</div>
</div>
</div>
<script src="//m.servedby-buysellads.com/monetization.js" type="text/javascript"></script>
<div class="native-sidebar"></div>
<script>
  (function(){
    if(typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('default', 'CKYD55QU', 'placement:howtoforge', {
      target: '.native-sidebar',
      align: 'horizontal',
      disable_css: 'true'
    });
      }
  })();
</script>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent">
<p class="mnuinfo mnushare">Share This Page</p>
<p style="text-align:center;">
<a href="javascript:window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.howtoforge.com%2Fdockerizing-laravel-with-nginx-mysql-and-docker-compose%2F', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-recommend.png" height="20" /></a>
<a href="javascript:window.open('https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.howtoforge.com%2Fdockerizing-laravel-with-nginx-mysql-and-docker-compose%2F&text=Dockerizing+Laravel+with+Nginx+MySQL+and+Docker+Compose+on+Ubuntu+18.04+LTS&via=howtoforgecom&related=howtoforgecom', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-tweet.png" height="20" /></a>
<a href="https://twitter.com/howtoforgecom/" target="_blank" rel="nofollow"><img src="/images/socialmedia/btn-follow.png" height="20" /></a>
<a href="javascript:window.open('https://plus.google.com/share?url=https%3A%2F%2Fwww.howtoforge.com%2Fdockerizing-laravel-with-nginx-mysql-and-docker-compose%2F', '_blank', 'status=1,height=500,width=360,resizable=0');void(0);"><img src="/images/socialmedia/btn-gplus.png" height="20" /></a>
</p>
<p style="color:#EE; font-weight:bold; text-align:center; margin-top:5px;">40.2k Followers</p>
</div>
</div>
</div>


<script type="text/javascript">
    google_ad_client = "ca-pub-3043223216276099";
    google_ad_slot = "6709042890";
    google_ad_width = 300;
    google_ad_height = 600;
</script>

<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>


<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<p class="mnuinfo">Popular Tutorials</p>
<div class="pairsJustified">
<ul>
<li><a href="/tutorial/linux-grep-command/">How to use grep to search for strings in files on the shell</a></li>
<li><hr /></li>
<li><a href="/how-to-install-cachet-status-page-system-on-centos-7/">How to Install Cachet Status Page System on CentOS 7</a></li>
<li><hr /></li>
<li><a href="/tutorial/perfect-server-ubuntu-18.04-with-apache-php-myqsl-pureftpd-bind-postfix-doveot-and-ispconfig/">The Perfect Server - Ubuntu 18.04 (Bionic Beaver) with Apache, PHP, MySQL, PureFTPD, BIND, Postfix, Dovecot and ISPConfig 3.1</a></li>
<li><hr /></li>
<li><a href="/tutorial/how-to-use-ftp-on-the-linux-shell/">How to use the Linux ftp command to up- and download files on the shell</a></li>
<li><hr /></li>
<li><a href="/how-to-install-matomo-web-analytics-on-centos-7/">How to Install Matomo Web Analytics on CentOS 7</a></li>
<li><hr /></li>
<li><a href="/how-to-install-monica-on-ubuntu-1804/">How to Install Monica Personal Relationship Manager on Ubuntu 18.04 LTS</a></li>
<li><hr /></li>
<li><a href="/how-to-install-wikijs-on-ubuntu-1804-lts/">How to Install Wiki.js on Ubuntu 18.04 LTS</a></li>
<li><hr /></li>
<li><a href="/how-to-install-freeipa-client-on-centos-7/">How to Install FreeIPA Client on CentOS 7</a></li>
<li><hr /></li>
<li><a href="/how-to-add-puppet-agents-to-foreman/">How to add Puppet Agents to Foreman</a></li>
<li><hr /></li>
<li><a href="/tutorial/ubuntu-elastic-stack/">How to Install Elastic Stack on Ubuntu 18.04 LTS</a></li>
<li><hr /></li>
</ul>
</div>
</div>
</div>
</div>
</div>
</aside>
</div>
</div>
</div>
<footer>
<div class="footer">
<div class="pageWidth">
<div class="pageContent">
<div class='skin_branding'><span>Xenforo skin by <a href="http://www.xenfocus.com" rel="nofollow">Xenfocus</a></span></div>
<ul class="footerLinks">
<li><a href="/contribute/">Contribute</a></li>
<li><a href="/community/misc/contact">Contact</a></li>
<li><a href="/community/help/">Help</a></li>
<li><a href="/imprint/">Imprint and Legal Notice</a></li>
<li><a href="#navigation" class="topLink">Top</a></li>
<li><a href="/feed" rel="alternate" class="globalFeed" target="_blank" title="RSS-Feed for Howtoforge">RSS-Feed</a></li>
</ul>
<span class="helper"></span>
</div>
</div>
</div>
<div class="footerLegal">
<div class="pageWidth">
<div class="pageContent">
<ul id="legal">
<li><a href="/community/help/terms">Terms and Rules</a> <a href="https://www.howtoforge.com/community/help/privacy-policy">Privacy Policy</a></li>
</ul>
<div id="copyright"><a href="https://www.howtoforge.com" class="concealed">Howtoforge <span>&copy; projektfarm GmbH.</span></a></div>
<span class="helper"></span>
</div>
</div>
</div>
</footer>
<div style="height:100px;"></div>

<div id="subscriptionModal" class="modal">
<div class="modal-content">
<span class="close">&times;</span>
<p>This feature is only available to subscribers. Get your subscription <a href="/subscription">here</a>.</p>
</div>
</div>
<script>
//* Modal
var modal = document.getElementById('subscriptionModal');
var span = document.getElementsByClassName("close")[0];
$(".pdf-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
$(".print-btn").click(function() {
  $("#subscriptionModal").css('display', 'block');
});
span.onclick = function() {
	$("#subscriptionModal").css('display', 'none');
}
window.onclick = function(event) {
    if (event.target == modal) {
		$("#subscriptionModal").css('display', 'none');
    }
}
//* Xenforo
jQuery.extend(true, XenForo,
{
	visitor: { user_id: 0 },
	serverTimeInfo:
	{
		now: 1409831907,
		today: 1409781600,
		todayDow: 4
	},
	_lightBoxUniversal: "0",
	_enableOverlays: "1",
	_animationSpeedMultiplier: "1",
	_overlayConfig:
	{
		top: "10%",
		speed: 200,
		closeSpeed: 100,
		mask:
		{
			color: "rgb(0, 0, 0)",
			opacity: "0.6",
			loadSpeed: 200,
			closeSpeed: 100
		}
	},
	_ignoredUsers: [],
	_loadedScripts: {"node_list":true,"node_category":true,"node_forum":true,"sidebar_share_page":true,"wf_default":true,"bbm_buttons":true,"login_bar":true,"twitter":true},
	_cookieConfig: { path: "/", domain: "", prefix: "xf_"},
	_csrfToken: "",
	_csrfRefreshUrl: "/community/login/csrf-token-refresh",
	_jsVersion: "303ae0ca"
});
jQuery.extend(XenForo.phrases,
{
	cancel: "Cancel",

	a_moment_ago:    "A moment ago",
	one_minute_ago:  "1 minute ago",
	x_minutes_ago:   "%minutes% minutes ago",
	today_at_x:      "Today at %time%",
	yesterday_at_x:  "Yesterday at %time%",
	day_x_at_time_y: "%day% at %time%",

	day0: "Sunday",
	day1: "Monday",
	day2: "Tuesday",
	day3: "Wednesday",
	day4: "Thursday",
	day5: "Friday",
	day6: "Saturday",

	_months: "January,February,March,April,May,June,July,August,September,October,November,December",
	_daysShort: "Sun,Mon,Tue,Wed,Thu,Fri,Sat",

	following_error_occurred: "The following error occurred",
	server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
	logging_in: "Logging in",
	click_image_show_full_size_version: "Click this image to show the full-size version.",
	show_hidden_content_by_x: "Show hidden content by {names}"
});

// Facebook Javascript SDK
XenForo.Facebook.appId = "";
XenForo.Facebook.forceInit = true;

/*
document.addEventListener('DOMContentLoaded', function(event) {
  cookieChoices.showCookieConsentBar('Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.',
  'OK');
});
*/

$(document).ready(function() {
	$("a.fancybox").fancybox();
});

</script>

<script>
(function() {
  if (typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('fancybar', 'CKYDL27E', 'placement:howtoforgecom');
  }
})();
</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2155872-1', 'auto');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');

</script>
</body>
</html>