The Perfect Desktop - Mepis 11 - Page 4

Want to support HowtoForge? Become a subscriber!
 
Submitted by CSch (Contact Author) (Forums) on Thu, 2011-09-15 18:05. ::

11 Google Picasa

Go to http://picasa.google.com/linux/download.html#picasa30 and select the right .deb package for your architecture (i386 or amd64):

Save the file to your computer. After the download has finished, open a terminal and become root:

su

Then go to the directory where you have saved Picasa, e.g. /home/ctest/Downloads:

cd /home/ctest/Downloads

Take a look at the contents of the directory:

ls -l

[root@mepis1 Downloads]# ls -l
insgesamt 31040
-rw-r--r-- 1 ctest users 31747574 31. Aug 13:52 picasa_3.0-current_amd64.deb
[root@mepis1 Downloads]#

You can now install Picasa as follows:

gdebi picasa_3.0-current_amd64.deb

Afterwards you can delete the Picasa .deb package:

rm -f picasa_3.0-current_amd64.deb

 

12 RealPlayer (For i386 Systems Only)

(RealPlayer is available for i386 systems only. If you are on an x86_64 system, please skip this chapter.)

Open Firefox and go to http://uk.real.com/realplayer/other-versions. Click on the correct .deb link:

Then install the package exactly as shown for Picasa.

 

13 dvdrip

dvdrip gives you dependency errors if you try to install it via Synaptic. That is why you have to install aptitude first.

apt-get install aptitude

After that install dvdrip via aptitude (please notice the highlighted input choices):

aptitude install dvdrip

[root@mepis1 ctest]# aptitude install dvdrip
Die folgenden NEUEN Pakete werden zusätzlich installiert:
  dvdrip fping{a} gtk2-ex-formfactory-perl{a}
  libanyevent-perl{a} libcairo-perl{a}
  libevent-execflow-perl{a} libevent-perl{a}
  libevent-rpc-perl{a} libglib-perl{a} libgtk2-perl{a}
  libintl-perl{a} libmjpegtools-1.9{a} libmp3lame0{a}
  libpango-perl{a} lsdvd{a} transcode{ab} transcode-utils{a}
Die folgenden Pakete werden EMPFOHLEN, aber NICHT installiert:
  dvdrip-doc libasync-interrupt-perl libio-socket-ssl-perl
  mjpegtools sox subtitleripper transcode-doc twolame
0 Pakete aktualisiert, 17 zusätzlich installiert, 0 werden entfernt und 7 nicht aktualisiert.
Muss 7.777 kB an Archiven herunterladen. Nach dem Entpacken werden 24,7 MB zusätzlich belegt sein.
Die folgenden Pakete haben verletzte Abhägigkeiten:
  transcode: Hängt ab von: libavcodec52 (>= 5:0.6.1+svn20101128) aber 4:0.6.1-5 ist installiert.
             Hängt ab von: libavformat52 (>= 5:0.6.1+svn20101128) aber 4:0.6.1-5 ist installiert.
             Hängt ab von: libpostproc51 (>= 5:0.6.1+svn20101128) aber 4:0.6.1-5 ist installiert.
Die folgenden Aktionen werden diese Abhängigkeiten auflösen:

     Beibehalten der folgenden Pakete in ihrer aktuellen Version:
1)     dvdrip [Nicht installiert]
2)     transcode [Nicht installiert]



Diese Lösung akzeptieren? [Y/n/q/?]
 <--- n


Die folgenden Aktionen werden diese Abhängigkeiten auflösen:

      Installiere die folgenden Pakete:
1)      libavcore0 [5:0.6.1+svn20101128-0.2 (stable)]
2)      libfaac0 [1.28-0.3 (stable)]
3)      libx264-112 [1:0.svn20110115-0.0 (stable)]
4)      libxvidcore4 [2:1.2.2-0.1 (stable)]

      Aktualisieren der folgenden Pakete:
5)      ffmpeg [4:0.6.1-5 (mepis, now) -> 5:0.6.1+svn20101128-0.2 (s
6)      libavcodec52 [4:0.6.1-5 (mepis, now) -> 5:0.6.1+svn20101128-
7)      libavdevice52 [4:0.6.1-5 (mepis, now) -> 5:0.6.1+svn20101128
8)      libavfilter1 [4:0.6.1-5 (mepis, now) -> 5:0.6.1+svn20101128-
9)      libavformat52 [4:0.6.1-5 (mepis, now) -> 5:0.6.1+svn20101128
10)     libavutil50 [4:0.6.1-5 (mepis, now) -> 5:0.6.1+svn20101128-0
11)     libpostproc51 [4:0.6.1-5 (mepis, now) -> 5:0.6.1+svn20101128
12)     libswscale0 [4:0.6.1-5 (mepis, now) -> 5:0.6.1+svn20101128-0



Diese Lösung akzeptieren? [Y/n/q/?]
 <--- Y
Die folgenden NEUEN Pakete werden zusätzlich installiert:
  dvdrip fping{a} gtk2-ex-formfactory-perl{a}
  libanyevent-perl{a} libavcore0{a} libcairo-perl{a}
  libevent-execflow-perl{a} libevent-perl{a}
  libevent-rpc-perl{a} libfaac0{a} libglib-perl{a}
  libgtk2-perl{a} libintl-perl{a} libmjpegtools-1.9{a}
  libmp3lame0{a} libpango-perl{a} libx264-112{a}
  libxvidcore4{a} lsdvd{a} transcode{a} transcode-utils{a}
Die folgenden Pakete werden aktualisiert:
  ffmpeg libavcodec52 libavdevice52 libavfilter1 libavformat52
  libavutil50 libpostproc51 libswscale0
Die folgenden Pakete werden EMPFOHLEN, aber NICHT installiert:
  dvdrip-doc libasync-interrupt-perl libio-socket-ssl-perl
  mjpegtools sox subtitleripper transcode-doc twolame
8 Pakete aktualisiert, 21 zusätzlich installiert, 0 werden entfernt und 7 nicht aktualisiert.
Muss 12,3 MB an Archiven herunterladen. Nach dem Entpacken werden 27,0 MB zusätzlich belegt sein.
Wollen Sie fortsetzen? [Y/n/?]
 <--- Y
Hole:1 http://www.debian-multimedia.org/ squeeze/main ffmpeg amd64 5:0.6.1+svn20101128-0.2 [309 kB]
Hole:2 http://www.debian-multimedia.org/ squeeze/main libavfilter1 amd64 5:0.6.1+svn20101128-0.2 [63,3 kB]
Hole:3 http://www.debian-multimedia.org/ squeeze/main libswscale0 amd64 5:0.6.1+svn20101128-0.2 [110 kB]
Hole:4 ftp://ftp.debian.org/debian/ squeeze/main libglib-perl amd64 2:1.223-1 [459 kB]
Hole:5 http://www.debian-multimedia.org/ squeeze/main libpostproc51 amd64 5:0.6.1+svn20101128-0.2 [38,9 kB]
Hole:6 http://www.debian-multimedia.org/ squeeze/main libavdevice52 amd64 5:0.6.1+svn20101128-0.2 [43,3 kB]
Hole:7 http://www.debian-multimedia.org/ squeeze/main libavformat52 amd64 5:0.6.1+svn20101128-0.2 [434 kB]
Hole:8 http://www.debian-multimedia.org/ squeeze/main libavcodec52 amd64 5:0.6.1+svn20101128-0.2 [2.611 kB]
Hole:9 ftp://ftp.debian.org/debian/ squeeze/main libcairo-perl amd64 1.070-1 [123 kB]
Hole:10 http://www.debian-multimedia.org/ squeeze/main libavutil50 amd64 5:0.6.1+svn20101128-0.2 [64,0 kB]
Hole:11 http://www.debian-multimedia.org/ squeeze/main libavcore0 amd64 5:0.6.1+svn20101128-0.2 [30,3 kB]
Hole:12 http://www.debian-multimedia.org/ squeeze/main libfaac0 amd64 1.28-0.3 [41,8 kB]
Hole:13 http://www.debian-multimedia.org/ squeeze/main libmp3lame0 amd64 3.98.4-0.0 [261 kB]
Hole:14 http://www.debian-multimedia.org/ squeeze/main libx264-112 amd64 1:0.svn20110115-0.0 [503 kB]
Hole:15 ftp://ftp.debian.org/debian/ squeeze/main libpango-perl amd64 1.221-2 [246 kB]
Hole:16 http://www.debian-multimedia.org/ squeeze/main libxvidcore4 amd64 2:1.2.2-0.1 [264 kB]
Hole:17 http://www.debian-multimedia.org/ squeeze/main libmjpegtools-1.9 amd64 1:1.9.0-0.7 [265 kB]
Hole:18 http://www.debian-multimedia.org/ squeeze/main transcode amd64 3:1.1.5-0.7 [1.346 kB]
Hole:19 ftp://ftp.debian.org/debian/ squeeze/main libgtk2-perl amd64 2:1.222-1 [1.252 kB]
Hole:20 http://www.debian-multimedia.org/ squeeze/main transcode-utils amd64 3:1.1.5-0.7 [253 kB]
Hole:21 http://www.debian-multimedia.org/ squeeze/main gtk2-ex-formfactory-perl all 0.66-0.0 [218 kB]
Hole:22 http://www.debian-multimedia.org/ squeeze/main libevent-execflow-perl all 0.64-0.0 [41,8 kB]
Hole:23 http://www.debian-multimedia.org/ squeeze/main dvdrip amd64 1:0.98.11-0.0 [1.392 kB]
Hole:24 ftp://ftp.debian.org/debian/ squeeze/main libanyevent-perl amd64 5.271-2 [339 kB]
Hole:25 ftp://ftp.debian.org/debian/ squeeze/main fping amd64 2.4b2-to-ipv6-16.1 [33,9 kB]
Hole:26 ftp://ftp.debian.org/debian/ squeeze/main libintl-perl all 1.20-1 [1.188 kB]
Hole:27 ftp://ftp.debian.org/debian/ squeeze/main lsdvd amd64 0.16-3+b1 [15,6 kB]
Hole:28 ftp://ftp.debian.org/debian/ squeeze/main libevent-perl amd64 1.12-1 [283 kB]
Hole:29 ftp://ftp.debian.org/debian/ squeeze/main libevent-rpc-perl all 1.01-1 [64,9 kB]
12,3 MB wurden in 22 s heruntergeladen (553 kB/s)
(Lese Datenbank ... 138059 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Ersetzen von ffmpeg 4:0.6.1-5 (durch .../ffmpeg_5%3a0.6.1+svn20101128-0.2_amd64.deb) ...
Ersatz für ffmpeg wird entpackt ...
Vorbereitung zum Ersetzen von libavfilter1 4:0.6.1-5 (durch .../libavfilter1_5%3a0.6.1+svn20101128-0.2_amd64.deb) ...
Ersatz für libavfilter1 wird entpackt ...
Vorbereitung zum Ersetzen von libswscale0 4:0.6.1-5 (durch .../libswscale0_5%3a0.6.1+svn20101128-0.2_amd64.deb) ...
Ersatz für libswscale0 wird entpackt ...
Vorbereitung zum Ersetzen von libpostproc51 4:0.6.1-5 (durch .../libpostproc51_5%3a0.6.1+svn20101128-0.2_amd64.deb) ...
Ersatz für libpostproc51 wird entpackt ...
Vorbereitung zum Ersetzen von libavdevice52 4:0.6.1-5 (durch .../libavdevice52_5%3a0.6.1+svn20101128-0.2_amd64.deb) ...
Ersatz für libavdevice52 wird entpackt ...
Vorbereitung zum Ersetzen von libavformat52 4:0.6.1-5 (durch .../libavformat52_5%3a0.6.1+svn20101128-0.2_amd64.deb) ...
Ersatz für libavformat52 wird entpackt ...
Vorbereitung zum Ersetzen von libavcodec52 4:0.6.1-5 (durch .../libavcodec52_5%3a0.6.1+svn20101128-0.2_amd64.deb) ...
Ersatz für libavcodec52 wird entpackt ...
Vorbereitung zum Ersetzen von libavutil50 4:0.6.1-5 (durch .../libavutil50_5%3a0.6.1+svn20101128-0.2_amd64.deb) ...
Ersatz für libavutil50 wird entpackt ...
Vormals abgewähltes Paket libavcore0 wird gewählt.
Entpacken von libavcore0 (aus .../libavcore0_5%3a0.6.1+svn20101128-0.2_amd64.deb) ...
Vormals abgewähltes Paket libfaac0 wird gewählt.
Entpacken von libfaac0 (aus .../libfaac0_1.28-0.3_amd64.deb) ...
Vormals abgewähltes Paket libmp3lame0 wird gewählt.
Entpacken von libmp3lame0 (aus .../libmp3lame0_3.98.4-0.0_amd64.deb) ...
Vormals abgewähltes Paket libx264-112 wird gewählt.
Entpacken von libx264-112 (aus .../libx264-112_1%3a0.svn20110115-0.0_amd64.deb) ...
Vormals abgewähltes Paket libxvidcore4 wird gewählt.
Entpacken von libxvidcore4 (aus .../libxvidcore4_2%3a1.2.2-0.1_amd64.deb) ...
Vormals abgewähltes Paket libmjpegtools-1.9 wird gewählt.
Entpacken von libmjpegtools-1.9 (aus .../libmjpegtools-1.9_1%3a1.9.0-0.7_amd64.deb) ...
Vormals abgewähltes Paket transcode wird gewählt.
Entpacken von transcode (aus .../transcode_3%3a1.1.5-0.7_amd64.deb) ...
Vormals abgewähltes Paket transcode-utils wird gewählt.
Entpacken von transcode-utils (aus .../transcode-utils_3%3a1.1.5-0.7_amd64.deb) ...
Vormals abgewähltes Paket libglib-perl wird gewählt.
Entpacken von libglib-perl (aus .../libglib-perl_2%3a1.223-1_amd64.deb) ...
Vormals abgewähltes Paket libcairo-perl wird gewählt.
Entpacken von libcairo-perl (aus .../libcairo-perl_1.070-1_amd64.deb) ...
Vormals abgewähltes Paket libpango-perl wird gewählt.
Entpacken von libpango-perl (aus .../libpango-perl_1.221-2_amd64.deb) ...
Vormals abgewähltes Paket libgtk2-perl wird gewählt.
Entpacken von libgtk2-perl (aus .../libgtk2-perl_2%3a1.222-1_amd64.deb) ...
Vormals abgewähltes Paket gtk2-ex-formfactory-perl wird gewählt.
Entpacken von gtk2-ex-formfactory-perl (aus .../gtk2-ex-formfactory-perl_0.66-0.0_all.deb) ...
Vormals abgewähltes Paket libanyevent-perl wird gewählt.
Entpacken von libanyevent-perl (aus .../libanyevent-perl_5.271-2_amd64.deb) ...
Vormals abgewähltes Paket libevent-execflow-perl wird gewählt.
Entpacken von libevent-execflow-perl (aus .../libevent-execflow-perl_0.64-0.0_all.deb) ...
Vormals abgewähltes Paket fping wird gewählt.
Entpacken von fping (aus .../fping_2.4b2-to-ipv6-16.1_amd64.deb) ...
Vormals abgewähltes Paket libintl-perl wird gewählt.
Entpacken von libintl-perl (aus .../libintl-perl_1.20-1_all.deb) ...
Vormals abgewähltes Paket lsdvd wird gewählt.
Entpacken von lsdvd (aus .../lsdvd_0.16-3+b1_amd64.deb) ...
Vormals abgewähltes Paket libevent-perl wird gewählt.
Entpacken von libevent-perl (aus .../libevent-perl_1.12-1_amd64.deb) ...
Vormals abgewähltes Paket libevent-rpc-perl wird gewählt.
Entpacken von libevent-rpc-perl (aus .../libevent-rpc-perl_1.01-1_all.deb) ...
Vormals abgewähltes Paket dvdrip wird gewählt.
Entpacken von dvdrip (aus .../dvdrip_1%3a0.98.11-0.0_amd64.deb) ...
Trigger für man-db werden verarbeitet ...
Trigger für menu werden verarbeitet ...
libavutil50 (5:0.6.1+svn20101128-0.2) wird eingerichtet ...
libavcore0 (5:0.6.1+svn20101128-0.2) wird eingerichtet ...
libfaac0 (1.28-0.3) wird eingerichtet ...
libmp3lame0 (3.98.4-0.0) wird eingerichtet ...
libx264-112 (1:0.svn20110115-0.0) wird eingerichtet ...
libxvidcore4 (2:1.2.2-0.1) wird eingerichtet ...
libavcodec52 (5:0.6.1+svn20101128-0.2) wird eingerichtet ...
libavformat52 (5:0.6.1+svn20101128-0.2) wird eingerichtet ...
libavdevice52 (5:0.6.1+svn20101128-0.2) wird eingerichtet ...
libswscale0 (5:0.6.1+svn20101128-0.2) wird eingerichtet ...
libavfilter1 (5:0.6.1+svn20101128-0.2) wird eingerichtet ...
libpostproc51 (5:0.6.1+svn20101128-0.2) wird eingerichtet ...
ffmpeg (5:0.6.1+svn20101128-0.2) wird eingerichtet ...
Neue Version der Konfigurationsdatei /etc/ffserver.conf wird installiert ...
libmjpegtools-1.9 (1:1.9.0-0.7) wird eingerichtet ...
transcode (3:1.1.5-0.7) wird eingerichtet ...
transcode-utils (3:1.1.5-0.7) wird eingerichtet ...
libglib-perl (2:1.223-1) wird eingerichtet ...
libcairo-perl (1.070-1) wird eingerichtet ...
libpango-perl (1.221-2) wird eingerichtet ...
libgtk2-perl (2:1.222-1) wird eingerichtet ...
gtk2-ex-formfactory-perl (0.66-0.0) wird eingerichtet ...
libanyevent-perl (5.271-2) wird eingerichtet ...
libevent-execflow-perl (0.64-0.0) wird eingerichtet ...
fping (2.4b2-to-ipv6-16.1) wird eingerichtet ...
libintl-perl (1.20-1) wird eingerichtet ...
lsdvd (0.16-3+b1) wird eingerichtet ...
libevent-perl (1.12-1) wird eingerichtet ...
libevent-rpc-perl (1.01-1) wird eingerichtet ...
dvdrip (1:0.98.11-0.0) wird eingerichtet ...
Trigger für menu werden verarbeitet ...

Aktueller Status: 7 Aktualisierungen [-8].
[root@mepis1 ctest]#

 

14 Inventory (III)

We have now all wanted applications installed:

Graphics:
[x] The GIMP
[x] F-Spot
[x] Picasa

Internet:
[x] Firefox/Iceweasel
[x] Opera
[x] Google Chrome
[x] Flash Player 10
[x] FileZilla
[x] Thunderbird/Icedove
[x] Evolution
[x] aMule
[x] Transmission BitTorrent Client
[x] Azureus/Vuze
[x] Empathy IM Client
[x] Skype
(i386 only)
[x] Google Earth
[x] Xchat IRC

Office:
[x] OpenOffice Writer
[x] OpenOffice Calc
[x] Adobe Reader
[x] GnuCash
[x] Scribus
[x] gedit

Sound & Video:
[x] Amarok
[x] Audacity
[x] Banshee
[x] MPlayer
[x] Rhythmbox Music Player
[x] gtkPod
[x] XMMS
[x] dvd::rip
[x] Kino
[x] Sound Juicer CD Extractor
[x] VLC Media Player
[x] Real Player
(i386 only)
[x] Totem
[x] Xine
[x] Brasero
[x] K3B
[x] Multimedia-Codecs

Programming:
[x] KompoZer
[x] Bluefish
[x] Eclipse

Other:
[x] VirtualBox
[x] TrueType fonts
[x] Java
[x] Read/Write support for NTFS partition

 

15 Links


Please do not use the comment function to ask for help! If you need help, please use our forum.
Comments will be published after administrator approval.
Submitted by Loic (not registered) on Mon, 2012-02-06 04:50.
Thank you very much. This information was really useful especially for guys like me. I installed Mepis 11 on  my PC less than 24 hours ago and yet i already have all the softwares i need. Except Picasa. Google came up with a new version and they've not compiled one for linux yet.
Submitted by Stevo (not registered) on Mon, 2011-09-19 07:14.

As you noted, MEPIS comes with the Adobe Flash plugin installed via the Debian flashplugin-nonfree package.  The debian-multimedia version is called mozilla-flashplayer, but does not need to be installed....instead, update the installed version with this terminal command (and check frequently for updates):

su -c 'update-flashplugin-nonfree --install --verbose'

The main debian-multimedia repository is already in sources.list, it is just disabled.  It is a good idea to change it to the nearest mirror, though.

Also present in sources.list but disabled are the MEPIS Community repositories, which have many updated and unique programs.  You need to  enable them and set the preferred distro to "mepis" in the Synaptic settings to upgrade programs that are both in the MEPIS and MEPIS CR repos, such as VLC (currently 1.1.11 in the CR)

Submitted by Anonymous (not registered) on Sun, 2011-09-18 22:41.

I have found that most windows users want to be able to simply use a photo manager and upload their pics to facebook, or easily email them. The only easy way in linux I have found, is using digikam for photo management, and thunderbird for pim. Digikam which easily exports to facebook and can access  thunderbird to email pics. Thunderbird with google calendar plugins installed, makes a very nice pim. 

 As of yet I have had no luck intigrating evolution  and shotwell (very good programs on their own) and evolution always mangles my contacts imported from yahoo, or palm. Google contacts is the only contact manager that hasn't mangled my contacts on import.

 I believe to seduce window users, we need programs which are simple to use and when it comes to photos, easy to manage and send to email and facebook and the like. Digikam is not the most simple, but is fully loaded and meets all other expectations and is fully capable of making a windows user happy.

Submitted by Louis (not registered) on Sat, 2011-09-17 21:14.

dvdrip gives you dependency errors ...

yes but only because you didnt use pinning for your multimedia packages.

If pinning is used you can choose from which tree your installing and dont have dependecies messages.