<!DOCTYPE html>
<html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs LoggedOut Sidebar Responsive" xmlns:fb="http://www.facebook.com/2008/fbml">
<head>
<meta charset="utf-8"/>
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1"/>
<meta name="viewport" content="width=device-width, initial-scale=1">
<base href="https://www.howtoforge.com"/>
<script>
			var _b = document.getElementsByTagName('base')[0], _bH = "https://www.howtoforge.com/tutorial/protect-your-server-computer-with-badips-and-fail2ban/";
			if (_b && _b.href != _bH) _b.href = _bH;
		</script>
<title>How to protect your server with badIPs.com and report IPs with Fail2ban on Debian</title>
<meta name="keywords" content="debian,linux,security"/>
<meta name="description" content="This tutorial documents the process of using the badips abuse tracker in conjunction with Fail2ban to protect your server or computer. I've tested it ... "/>
<meta name="og:title" content="How to protect your server with badIPs.com and report IPs with Fail2ban on Debian">
<meta name="og:description" content="This tutorial documents the process of using the badips abuse tracker in conjunction with Fail2ban to protect your server or computer. I've tested it ... ">
<meta name="og:site_name" content="Howtoforge">
<meta name="og:type" content="article">
<meta property="og:image" content="https://www.howtoforge.com/images/teaser/debian.gif">
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="howtoforgecom">
<meta name="twitter:creator" content="howtoforgecom">
<meta name="twitter:title" content="How to protect your server with badIPs.com and report IPs with Fail2ban on Debian">
<meta name="twitter:description" content="This tutorial documents the process of using the badips abuse tracker in conjunction with Fail2ban to protect your server or computer. I've tested it ... ">
<link rel="alternate" href="https://www.howtoforge.com/tutorial/protect-your-server-computer-with-badips-and-fail2ban/" hreflang="en"/>
<link rel="canonical" href="https://www.howtoforge.com/tutorial/protect-your-server-computer-with-badips-and-fail2ban/"/>
<noscript><style>.JsOnly,.jsOnly{display:none!important;}</style></noscript>
<link rel="stylesheet" href="/community/styles/executive/xenfocus/icons/css/font-awesome.min.css"/>
<link href='//fonts.googleapis.com/css?family=Open+Sans:400,700' rel='stylesheet' type='text/css'/>
 
<link rel="stylesheet" href="/community/css.php?css=xenforo,form,public&amp;style=3&amp;dir=LTR&amp;d=1420029973"/>
<link rel="stylesheet" href="/community/css.php?css=bb_code,bbm_buttons,facebook,google,login_bar,node_category,node_forum,node_list,profile_post_list_simple,sidebar_share_page,twitter,wf_default&amp;style=3&amp;dir=LTR&amp;d=1420029973"/>
<script src="//ajax.googleapis.com/ajax/libs/jquery/1.11.3/jquery.min.js"></script>
<script>if (!window.jQuery) { document.write('<scr'+'ipt type="text/javascript" src="/js/jquery/jquery-1.11.3.min.js"><\/scr'+'ipt>'); }</script>
<script src="/community/js/xenforo/xenforo.js?_v=303ae0ca"></script>
<script src="/community/js/bbm/zloader.js?_v=303ae0ca"></script>
<link href="//netdna.bootstrapcdn.com/font-awesome/4.0.3/css/font-awesome.css" rel="stylesheet">
<script type="text/javascript" src="/js/fancybox/jquery.mousewheel-3.0.4.pack.js"></script>
<script type="text/javascript" src="/js/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
<link rel="stylesheet" type="text/css" href="/js/fancybox/jquery.fancybox-1.3.4.css" media="screen"/>
<link href="/themes/howtoforge/templates/style.css" rel="stylesheet">
<link rel="alternate" type="application/rss+xml" title="RSS-Feed für Howtoforge" href="/feed.rss"/>
<script src="/js/tinymce_4.1.7/tinymce.min.js"></script>
<script type='text/javascript' src='https://partner.googleadservices.com/gampad/google_service.js'>
</script>
<script type='text/javascript'>
GS_googleAddAdSenseService("ca-pub-3043223216276099");
GS_googleEnableAllServices();
</script>
<script language="JavaScript">
GA_googleAddAttr("Category", "Debian");
GA_googleAddAttr("Category", "Linux");
GA_googleAddAttr("Category", "Security");
</script>
<script type='text/javascript'>
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_leaderboard_a_728x90");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_rectangle_a_300x250");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_rectangle_b_300x250");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_halfpage_a_300x600");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_leaderboard_b_728x90");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_article_halfpage_b_300x600");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_a_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_b_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_c_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_textlink_d_600x50");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_list_sidebar_top");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_list_content_middle");
GA_googleAddSlot("ca-pub-3043223216276099", "howtoforge_com_list_bottom");
</script>
<script type='text/javascript'>
GA_googleFetchAds();
</script>
 
<script type="text/javascript">
    window.cookieconsent_options = {"message":"This website uses cookies to ensure you get the best experience on our website","dismiss":"Got it!","learnMore":"More info","link":"https://www.howtoforge.com/community/help/cookies","theme":"dark-bottom"};
</script>
<script type="text/javascript" src="/js/cookieconsent.latest.min.js"></script>
 
</head>
<body>
<div id="loginBar">
<div class="pageWidth">
<div class="pageContent">
<h3 id="loginBarHandle">
<label for="LoginControl"><a href="/community/login/" class="concealed noOutline">Log in or Sign up</a></label>
</h3>
<span class="helper"></span>
</div>
</div>
</div>
<header>
<div id="header">
<div id="logoBlock">
<div class="pageWidth">
<div class="pageContent">
<div id="logo"><a href="/">
<span></span>
<img src="/images/howtoforge_logo_trans.gif" alt="Howtoforge" style="margin-left:20px;"/>
</a></div>
<span class="helper"></span>
<div class="langSwitch">
<b><img src="/images/gb.png" alt="HowtoForge - Linux Tutorials in English"/> English</b> | <a href="https://www.howtoforge.de/" title="HowtoForge.de - Linux Tutorials auf Deutsch"><img src="/images/de.png" alt="HowtoForge.de - Linux Tutorials auf Deutsch"/> Deutsch</a>
</div>
</div>
</div>
</div>
<div id="navigation" class="pageWidth withSearch">
<div class="pageContent">
<nav>
<div class="navTabs">
<ul class="publicTabs">
 
<li class="navTab forums selected">
<a href="/" class="navLink">Tutorials</a>
<div class="tabLinks forumsTabLinks">
<ul class="secondaryContent blockLinksList">
<li><a href="/search/">Tutorial search</a></li>
</ul>
</div>
</li>
<li class="navTab forums PopupClosed">
<a href="/tutorials/" class="navLink">Tags</a>
</li>
<li class="navTab forums PopupClosed"><a href="/community/" class="navLink">Forums</a></li>
<li class="navTab forums PopupClosed"><a href="/contribute/" class="navLink">Contribute</a></li>
<li class="navTab forums PopupClosed"><a href="/subscription/" class="navLink">Subscribe</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.ispconfig.org" class="navLink">ISPConfig</a></li>
<li class="navTab forums PopupClosed"><a href="http://www.lxer.com" class="navLink">News</a></li>
</ul>
</div>
<span class="helper"></span>
</nav>
</div>
</div>
<div id="searchBar" class="pageWidth">
<span id="QuickSearchPlaceholder" title=" Search..."> Search</span>
<fieldset id="QuickSearch">
<form action="/" method="post" class="formPopup">
<div class="primaryControls">
 
<input type="search" name="q" value="" class="textCtrl" placeholder="Search..." results="0" title="Enter your search and hit enter..." id="QuickSearchQuery"/>
 
</div>
<input type="hidden" name="_xfToken" value=""/>
</form>
</fieldset>
</div>
</div>
</header>
<div id="content" class="forum_list">
<div class="pageWidth">
<div class="pageContent">
 
<div class="mainContainer">
<div class="mainContent">
 
<div class="breadBoxTop">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Tutorials</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/tutorial/protect-your-server-computer-with-badips-and-fail2ban/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to protect your server with badIPs.com and report IPs with Fail2ban on Debian</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
 
<div id="htfContentPage">
<h1>How to protect your server with badIPs.com and report IPs with Fail2ban on Debian</h1>
<div class="bsa-apiads"><a href="//srv.buysellads.com/ads/click/x/GTND423YCYSI4K7JCTS4YKQWFTSD523ICW7I4Z3JCEADK2JYCTSI52JKC6BDE2JNF67DTK3EHJNCLSIZ" target="_blank" rel="nofollow">Have an app idea and want to see if it'll fly?</a><img src="https://ad.atdmt.com/i/img;p=11087210530757;a=11087210553845;idfa=;aaid=;idfa_lat=;aaid_lat=;cache="/></div>
<div class="contributeEdit" style="float:right; width:450px; max-width:100%;">
 
<div id="tocContainer">
<h3>On this page</h3>
<ol class="toc">
<li><a href="#use-the-badips-list">Use the badIPs list</a>
<ol>
<li><a href="#define-your-security-level-and-category">Define your security level and category</a></li>
</ol>
</li>
<li><a href="#lets-create-the-script">Let's create the script</a></li>
<li><a href="#report-ip-addresses-to-badips-with-failban">Report IP addresses to badIPs with Fail2ban</a>
<ol>
<li><a href="#failban-gt-">Fail2ban &gt;= 0.8.12</a></li>
<li><a href="#failban-ltnbsp">Fail2ban &lt;&nbsp;0.8.12</a></li>
</ol>
</li>
<li><a href="#statistics-of-your-ip-reporting">Statistics of your IP reporting</a></li>
</ol>
</div>
</div>
<p>This tutorial documents the process of using the badips&nbsp;abuse tracker in conjunction with Fail2ban to protect your server or computer. I've tested it on a Debian 8 Jessie and Debian 7 Wheezy.</p>
<p><strong>What is badIPs?</strong></p>
<p>BadIps is a listing of IP that are reported as bad in combinaison with <a href="http://www.fail2ban.org" target="_blank">fail2ban</a>.</p>
<p>This tutorial contains two parts, the first one will deal with the use of the list and the second will deal with the injection of data.</p>
<h2 id="use-the-badips-list"><br/>Use the badIPs list</h2>
<h3 id="define-your-security-level-and-category">Define your security level and category</h3>
<p>You can get the IP address list by simply using the REST API.</p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;"> 
 
<script type='text/javascript'>
GA_googleFillSlot('howtoforge_com_article_rectangle_a_300x250');
</script>
 </div>
<p>When you GET this URL :&nbsp;<a href="https://www.badips.com/get/categories" target="_blank">https://www.badips.com/get/categories</a><br/>You&rsquo;ll see all the different categories that are present on the service.</p>
<ul>
<li>Second step, determine witch score is made for you.<br/>Here a quote from badips that should help (personnaly I took score = 3):</li>
<li>If you'd like to compile a statistic or use the data for some experiment etc. you may start with score 0.</li>
<li>If you'd like to firewall your private server or website, go with scores from 2. Maybe combined with your own results, even if they do not have a score above 0 or 1.</li>
<li>If you're about to protect a webshop or high traffic, money-earning e-commerce server, we recommend to use values from 3 or 4. Maybe as well combined with your own results (key / sync).</li>
<li>If you're paranoid, take 5.</li>
</ul>
<p>So now that you get your two variables, let's make your link by concatening them and grab your link.</p>
<p class="command">http://www.badips.com/get/list/{{SERVICE}}/{{LEVEL}}</p>
<p>Note: Like me, you can take all the services. Change the name of the service to "any" in this case.</p>
<p>The resulting URL is:</p>
<p class="command">https://www.badips.com/get/list/any/3</p>
<p></p>
<h2 id="lets-create-the-script">Let's create the script</h2>
<p>Alright, when that&rsquo;s done, we&rsquo;ll create a simple script.</p>
<ol>
<li>Put our list in a tempory file.</li>
<li>(only once) create a chain in iptables.</li>
<li>Flush all the data linked to our chain (old entries).</li>
<li>We&rsquo;ll link each IP to our new chain.</li>
<li>When it&rsquo;s done, block all INPUT / OUTPUT / FORWARD that&rsquo;s linked to our chain.</li>
<li>Remove our temp file.</li>
</ol>
<p>Nowe we'll create the script for that:</p>
<p class="command">cd /home/<span class="highlight">&lt;user&gt;</span>/<br/>vi&nbsp;<span>myBlacklist.sh</span></p>
<p>Enter the following content into that file.</p>
<pre><span>#!/bin/sh<br/># based on this version <a href="http://www.timokorthals.de/?p=334">http://www.timokorthals.de/?p=334</a><br/># adapted by St&eacute;phane T.<br/><br/>_ipt=/sbin/iptables&nbsp; &nbsp; # Location of iptables (might be correct)<br/></span>_input=badips.db &nbsp; &nbsp; &nbsp; # Name of database (will be downloaded with this name)<br/>_pub_if=eth0 &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; # Device which is connected to the internet (ex. $ifconfig for that)<br/>_droplist=droplist &nbsp; &nbsp; # Name of chain in iptables (Only change this if you have already a chain with this name)<br/>_level=3 &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; # Blog level: not so bad/false report (0) over confirmed bad (3) to quite aggressive (5) (see www.badips.com for that)<br/>_service=any &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; # Logged service (see www.badips.com for that)<br/><br/># Get the bad IPs<br/>wget -qO- http://www.badips.com/get/list/${_service}/$_level &gt; $_input || { echo "$0: Unable to download ip list."; exit 1; }<br/><br/>### Setup our black list ###<br/># First flush it<br/>$_ipt --flush $_droplist<br/><br/># Create a new chain<br/># <span class="highlight"><strong>Decomment the next line on the first run</strong></span><br/># $_ipt -N $_droplist<br/><br/># Filter out comments and blank lines<br/># store each ip in $ip<br/>for ip in `cat $_input`<br/>do<br/># Append everything to $_droplist<br/>$_ipt -A $_droplist -i ${_pub_if} -s $ip -j LOG --log-prefix "Drop Bad IP List "<br/>$_ipt -A $_droplist -i ${_pub_if} -s $ip -j DROP<br/>done<br/><br/># Finally, insert or append our black list<br/>$_ipt -I INPUT -j $_droplist<br/>$_ipt -I OUTPUT -j $_droplist<br/>$_ipt -I FORWARD -j $_droplist<br/><br/># Delete your temp file<br/>rm $_input<br/>exit 0</pre>
<p>When that&rsquo;s done, you should create a cronjob that will update our blacklist.</p>
<p>For this, I used crontab and I run the script every day on 11:30PM (just before my delayed backup).</p>
<p class="command"><span>crontab -e</span></p>
<pre><span>23 30 * * * /home/<span class="highlight">&lt;user&gt;</span>/myBlacklist.sh #Block BAD IPS</span></pre>
<p>Don&rsquo;t forget to chmod your script:</p>
<p class="command">chmod + x myBlacklist.sh</p>
<p>Now that&rsquo;s done, your server/computer should be a little bit safer.</p>
<p>You can also run the script manually like this:</p>
<p class="command">cd /home/<span class="highlight">&lt;user&gt;</span>/<br/>./myBlacklist.sh</p>
<p>It should take some time&hellip; so don&rsquo;t break the script. In fact, the value of it lies in the last lines.</p>
<p></p>
<h2 id="report-ip-addresses-to-badips-with-failban">Report IP addresses to badIPs with Fail2ban</h2>
<p>In the second part of this tutorial, I will show you how to report bd IP addresses bach to the badips.com website by using Fail2ban.</p><div style="width:336px;float:left; margin: 10px 15px 10px 0px;background-color:white;"> 
 
<script type='text/javascript'>
GA_googleFillSlot('howtoforge_com_article_rectangle_b_300x250');
</script>
 </div>
<h3 id="failban-gt-">Fail2ban &gt;= 0.8.12</h3>
<p>The reporting is made with Fail2ban. Depending on your Fail2ban version you must use the first or second section of this chapter.If you have fail2ban in version 0.8.12.</p>
<p>If you have fail2ban version 0.8.12 or later.</p>
<p class="command">fail2ban-server --version</p>
<p>In each&nbsp;category that you&rsquo;ll report, simply add an action.</p>
<pre>[ssh]<br/> enabled = true<br/> action = iptables-multiport<br/>          <strong>badips[category=ssh]</strong><br/> port = ssh<br/> filter = sshd<br/> logpath = /var/log/auth.log<br/> maxretry= 6</pre>
<p>As you can see, the category is SSH, take a look here (<a href="https://www.badips.com/get/categories" target="_blank">https://www.badips.com/get/categories</a>) to find the correct category.</p>
<h3 id="failban-ltnbsp">Fail2ban &lt;&nbsp;0.8.12</h3>
<p>If the version is less recent than 0.8.12, you&rsquo;ll have a to create an action. This can be downloaded here:&nbsp;<a href="https://www.badips.com/asset/fail2ban/badips.conf" target="_blank">https://www.badips.com/asset/fail2ban/badips.conf</a>.</p>
<p class="command">wget https://www.badips.com/asset/fail2ban/badips.conf -O /etc/fail2ban/action.d/badips.conf</p>
<p>With the badips.conf from above, you can either activate per category as above or you can enable it globally:</p>
<p class="command"><span>cd /etc/fail2ban/<br/>vi jail.conf</span></p>
<pre><span>[DEFAULT]<br/><br/>...<br/><br/>banaction = iptables-multiport<br/><span class="Apple-tab-span"> </span><span class="Apple-tab-span"> </span><span class="Apple-tab-span"> </span><span class="Apple-tab-span"> </span><span class="Apple-tab-span"> </span><span class="Apple-tab-span"> </span><span class="Apple-tab-span"> </span><span class="Apple-tab-span"> </span><span class="Apple-tab-span"> </span><span class="Apple-tab-span"> </span><span class="Apple-tab-span"> </span><span class="Apple-tab-span"> </span><strong>badips</strong></span></pre>
<p>Now restart fail2ban - it should start reporting from now on.</p>
<p class="command"><span>service fail2ban restart</span></p>
<p></p>
<h2 id="statistics-of-your-ip-reporting">Statistics of your IP reporting</h2>
<p><br/>Last step &ndash; not really useful&hellip; You can create a key.<br/>This one is usefull if you want to see your data.<br/>Just copy / paste this and a JSON response will appear on your console.</p>
<p class="command">wget https://www.badips.com/get/key -qO -</p>
<pre class="bi-code">{
  "err":"",
  "suc":"new key 5f72253b673eb49fc64dd34439531b5cca05327f has been set.",
  "key":"<span class="highlight"><strong>5f72253b673eb49fc64dd34439531b5cca05327f</strong></span>"
}</pre>
<p>Then go on <a href="https://www.badips.com" target="_blank">badips</a>&nbsp;website, enter your &ldquo;key&rdquo; and click &ldquo;statistics&rdquo;.</p>
<p>Here we go&hellip; all your stats by category.</p>
<div style="height:30px; margin-top:20px;">
<p style="text-align:right;"><img src="/images/pdficon_small.png"/> <a href="/subscription/">view as pdf</a> | <img src="/images/print.gif"/> <a href="/subscription/">print</a></p>
</div>
<div style="height:30px; margin-top:20px;">
<div style="float:left;"><b>Share this page:</b></div>
<div style="float:left; margin-left:10px;"><a href="https://twitter.com/share" class="twitter-share-button" data-count="horizontal" data-lang="en-US" data-url="https://www.howtoforge.com/tutorial/protect-your-server-computer-with-badips-and-fail2ban/" data-via="howtoforgecom">Tweet</a> <a class="twitter-follow-button" href="https://twitter.com/howtoforgecom">Follow</a></div>
<div style="float:left; margin-left:20px;"><fb:like href="https://www.howtoforge.com/tutorial/protect-your-server-computer-with-badips-and-fail2ban/" layout="button_count" action="recommend" font="trebuchet ms" colorscheme="light"></fb:like></div>
<div style="float:left; margin-left:50px;"><div class="g-plusone" data-size="medium" data-count="true" data-href="https://www.howtoforge.com/tutorial/protect-your-server-computer-with-badips-and-fail2ban/"></div></div>
</div>
</div>
 
 
<div id="htfContentPageComment">
<a name="comments"></a>
<h2>0 Comment(s)</h2>
 
<div id="commentform">
<div class="commentContainerHead" style="font-size:18px;">Add comment</div>
<div class="commentContainer">
<form method="post" action="/tutorial/protect-your-server-computer-with-badips-and-fail2ban/#comments">
<input type="hidden" name="reply_to" id="reply-to-comment" value="0"/>
<div id="commentFormDetail">
<div style="width:48%; float:left; margin-right:3%">
<label for="commentname">Name *</label>
<input id="commentname" name="commentname" value=""/>
</div>
<div style="width:48%;float:left;">
<label for="commentname">Email *</label>
<input id="commentemail" name="commentemail" value=""/>
</div>
<div style="clear:both;"></div>
</div>
<textarea id="commentedit" name="commentedit" style="width:auto;"></textarea>
<div>
<div style="float:left;">
<div class="g-recaptcha" data-sitekey="6LdX9fUSAAAAALWwVoPdeXScMSketz4npF-0QcQ1"></div>
<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en">
      </script>
</div>
<div style="margin-top:10px;margin-bottom:10px;">
<input type="submit" name="submit" class="button primary" style="float:right;" value="Submit comment">
</div>
<div style="clear:both;"></div>
</div>
 
<script>
	tinymce.init({
		selector: "textarea#commentedit",
		theme: "modern",
		height: 100,
		apply_source_formatting : true,
		remove_linebreaks : false,
		menubar : false,
		/*auto_focus : "commentedit",*/
		plugins: [
		"link"
		],
		/*plugins: [
			"advlist autolink link image lists charmap print preview hr anchor pagebreak spellchecker",
			"searchreplace wordcount visualblocks visualchars code fullscreen insertdatetime media nonbreaking",
			"save table contextmenu directionality emoticons template paste textcolor"
		],*/
		content_css: "https://www.howtoforge.com/themes/howtoforge/css/custom.css",
		toolbar: "undo redo | bold italic link", 
		/*style_formats: [
			{title: 'Bold text', inline: 'b'},
			{title: 'Red text', inline: 'span', styles: {color: '#ff0000'}},
			{title: 'Red header', block: 'h1', styles: {color: '#ff0000'}},
			{title: 'Example 1', inline: 'span', classes: 'example1'},
			{title: 'Example 2', inline: 'span', classes: 'example2'},
			{title: 'Table styles'},
			{title: 'Table row 1', selector: 'tr', classes: 'tablerow1'}
		]*/
	}); 
	</script>
</form>
</div>
</div>
 
</div>
 
<div class="breadBoxBottom">
<nav>
<fieldset class="breadcrumb">
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Tutorials</span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="/tutorial/protect-your-server-computer-with-badips-and-fail2ban/" class="crumb" rel="up" itemprop="url"><span itemprop="title">How to protect your server with badIPs.com and report IPs with Fail2ban on Debian</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
<script>
<!--

$(document).on('click', 'a.reply-to', function(e) {
	e.preventDefault();
	
	var self = $(this);
	var cid = self.attr('data-comment');
	console.log(cid);
	if(!cid) return this;
	
	$('#commentform').insertAfter('#comment' + cid);
	$('#reply-to-comment').val(cid);
	/*tinyMCE.activeEditor.focus();*/
	var textareaId = 'commentedit';
	tinyMCE.get(textareaId).remove();
	tinyMCE.execCommand("mceAddEditor", false, textareaId);
	tinyMCE.activeEditor.focus();
});
//-->
</script>
<div style="margin-top:10px;margin-bottom:10px;text-align:center;">
 
<center>
 
 
<script type='text/javascript'>
GA_googleFillSlot("howtoforge_com_article_leaderboard_b_728x90");
</script>
 
</center>
 </div>
 
 
<form action="/community/login/login?redirect=/tutorial/protect-your-server-computer-with-badips-and-fail2ban/" method="post" class="xenForm eAuth" id="login" style="display:none">
<ul id="eAuthUnit">
<li><a href="/community/register/facebook?reg=1" class="fbLogin" tabindex="110"><span>Log in with Facebook</span></a></li>
<li><a href="/community/register/twitter?reg=1" class="twitterLogin" tabindex="110"><span>Log in with Twitter</span></a></li>
<li><span class="googleLogin GoogleLogin JsOnly" tabindex="110" data-client-id="198773272284-b6tfk0c28bje81p774prrcrkq9jb3o44.apps.googleusercontent.com" data-redirect-url="/community/register/google?code=__CODE__&amp;csrf=hVMXbW_3rnrmq4Em"><span>Log in with Google</span></span></li>
</ul>
<div class="ctrlWrapper">
<dl class="ctrlUnit">
<dt><label for="LoginControl">Your name or email address:</label></dt>
<dd><input type="text" name="login" id="LoginControl" class="textCtrl" tabindex="101"/></dd>
</dl>
<dl class="ctrlUnit">
<dt>
<label for="ctrl_password">Do you already have an account?</label>
</dt>
<dd>
<ul>
<li><label for="ctrl_not_registered"><input type="radio" name="register" value="1" id="ctrl_not_registered" tabindex="105"/>
No, create an account now.</label></li>
<li><label for="ctrl_registered"><input type="radio" name="register" value="0" id="ctrl_registered" tabindex="105" checked="checked" class="Disabler"/>
Yes, my password is:</label></li>
<li id="ctrl_registered_Disabler">
<input type="password" name="password" class="textCtrl" id="ctrl_password" tabindex="102"/>
<div class="lostPassword"><a href="/community/lost-password/" tabindex="106">Forgot your password?</a></div>
</li>
</ul>
</dd>
</dl>
<dl class="ctrlUnit submitUnit">
<dt></dt>
<dd>
<input type="submit" class="button primary" value="Log in" tabindex="104" data-loginPhrase="Log in" data-signupPhrase="Sign up"/>
<label for="ctrl_remember" class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_remember" tabindex="103"/> Stay logged in</label>
</dd>
</dl>
</div>
<input type="hidden" name="cookie_check" value="1"/>
<input type="hidden" name="redirect" value="/community/"/>
<input type="hidden" name="_xfToken" value=""/>
</form>
 
</div>
</div>
 
<aside>
<div class="sidebar">
<div class="section loginButton">
<div class="secondaryContent">
<label for="LoginControl" id="SignupButton"><a href="/community/login/" class="inner">Sign up now!</a></label>
</div>
</div>
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-2">
 
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent socialMediaIcon">
<a href="https://twitter.com/howtoforgecom" target="_blank"><img src="/images/socialmedia/64x64/twitter.png"/></a>
<a href="https://www.facebook.com/howtoforge" target="_blank"><img src="/images/socialmedia/64x64/facebook.png"/></a>
<a href="https://plus.google.com/+howtoforge/posts" target="_blank"><img src="/images/socialmedia/64x64/googleplus.png"/></a>
<a href="https://www.howtoforge.com/feed" target="_blank"><img src="/images/socialmedia/64x64/rss.png"/></a>
</div>
</div>
</div>
<div class="section widget-group-no-name widget-container">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Stats" id="widget-3">
<h3>Tutorial Info</h3>
<div class="pairsJustified">
<dl class="discussionCount">
<dt>Author:</dt>
<dd>Stephane T.</dd>
</dl>
<dl class="discussionCount">
<dt>Published:</dt>
<dd>Feb 09, 2017</dd>
</dl>
<dl class="discussionCount">
<dt>Tags:</dt>
<dd><a href='/tutorials/debian/' rel='tag'>debian</a>, <a href='/tutorials/linux/' rel='tag'>linux</a>, <a href='/tutorials/security/' rel='tag'>security</a></dd>
</dl>
</div>
</div>
</div>
 
<div class="widget WidgetFramework_WidgetRenderer_ShareThisPage" id="widget-5">
<div class="section infoBlock sharePage">
<div class="secondaryContent">
<h3>Share This Page</h3>
<div class="tweet shareControl">
<a href="https://twitter.com/share" class="twitter-share-button" data-count="horizontal" data-lang="en-US" data-url="https://www.howtoforge.com/tutorial/protect-your-server-computer-with-badips-and-fail2ban/" data-via="howtoforgecom">Tweet</a> <a class="twitter-follow-button" data-show-screen-name="false" href="https://twitter.com/howtoforgecom">Follow</a>
</div>
<div class="facebookLike shareControl">
<fb:like href="https://www.howtoforge.com/tutorial/protect-your-server-computer-with-badips-and-fail2ban/" layout="button_count" action="recommend" font="trebuchet ms" colorscheme="light"></fb:like>
</div>
<div class="plusone shareControl">
<div class="g-plusone" data-size="medium" data-count="true" data-href="https://www.howtoforge.com/tutorial/protect-your-server-computer-with-badips-and-fail2ban/"></div>
</div>
</div>
</div>
</div>
 
 
 
<script type="text/javascript">
    google_ad_client = "ca-pub-3043223216276099";
    google_ad_slot = "6709042890";
    google_ad_width = 300;
    google_ad_height = 600;
</script>
 
<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
 
 
</div>
</div>
</aside>
</div>
</div>
</div>
<footer>
<div class="footer">
<div class="pageWidth">
<div class="pageContent">
<div class='skin_branding'><a href="http://www.xenfocus.com" rel="nofollow">Xenforo skin</a><span> by <a href="http://www.xenfocus.com" rel="nofollow">Xenfocus</a></span></div>
<ul class="footerLinks">
<li><a href="/community/misc/contact">Contact</a></li>
<li><a href="/community/help/">Help</a></li>
<li><a href="/imprint/">Imprint</a></li>
<li><a href="/" class="homeLink">Tutorials</a></li>
<li><a href="#navigation" class="topLink">Top</a></li>
<li><a href="/feed" rel="alternate" class="globalFeed" target="_blank" title="RSS-Feed for Howtoforge">RSS-Feed</a></li>
</ul>
<span class="helper"></span>
</div>
</div>
</div>
<div class="footerLegal">
<div class="pageWidth">
<div class="pageContent">
<ul id="legal">
<li><a href="/community/help/terms">Terms</a></li>
</ul>
<div id="copyright"><a href="https://www.howtoforge.com" class="concealed">Howtoforge <span>&copy; projektfarm GmbH.</span></a></div>
<span class="helper"></span>
</div>
</div>
</div>
</footer>
<div style="height:100px;"></div>
<script>

jQuery.extend(true, XenForo,
{
	visitor: { user_id: 0 },
	serverTimeInfo:
	{
		now: 1409831907,
		today: 1409781600,
		todayDow: 4
	},
	_lightBoxUniversal: "0",
	_enableOverlays: "1",
	_animationSpeedMultiplier: "1",
	_overlayConfig:
	{
		top: "10%",
		speed: 200,
		closeSpeed: 100,
		mask:
		{
			color: "rgb(0, 0, 0)",
			opacity: "0.6",
			loadSpeed: 200,
			closeSpeed: 100
		}
	},
	_ignoredUsers: [],
	_loadedScripts: {"node_list":true,"node_category":true,"node_forum":true,"sidebar_share_page":true,"wf_default":true,"bbm_buttons":true,"login_bar":true,"twitter":true},
	_cookieConfig: { path: "/", domain: "", prefix: "xf_"},
	_csrfToken: "",
	_csrfRefreshUrl: "/community/login/csrf-token-refresh",
	_jsVersion: "303ae0ca"
});
jQuery.extend(XenForo.phrases,
{
	cancel: "Cancel",

	a_moment_ago:    "A moment ago",
	one_minute_ago:  "1 minute ago",
	x_minutes_ago:   "%minutes% minutes ago",
	today_at_x:      "Today at %time%",
	yesterday_at_x:  "Yesterday at %time%",
	day_x_at_time_y: "%day% at %time%",

	day0: "Sunday",
	day1: "Monday",
	day2: "Tuesday",
	day3: "Wednesday",
	day4: "Thursday",
	day5: "Friday",
	day6: "Saturday",

	_months: "January,February,March,April,May,June,July,August,September,October,November,December",
	_daysShort: "Sun,Mon,Tue,Wed,Thu,Fri,Sat",

	following_error_occurred: "The following error occurred",
	server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
	logging_in: "Logging in",
	click_image_show_full_size_version: "Click this image to show the full-size version.",
	show_hidden_content_by_x: "Show hidden content by {names}"
});

// Facebook Javascript SDK
XenForo.Facebook.appId = "";
XenForo.Facebook.forceInit = true;

/*
document.addEventListener('DOMContentLoaded', function(event) {
  cookieChoices.showCookieConsentBar('Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.',
  'OK');
});
*/

$(document).ready(function() {
	$("a.fancybox").fancybox();
});

</script>
<script async type="text/javascript" src="//cdn.fancybar.net/ac/fancybar.js?zoneid=1502&serve=C6ADVKE&placement=howtoforge" id="_fancybar_js"></script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2155872-1', 'auto');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');

</script>
</body>
</html>