ZoneMinder on Ubuntu - dependancy problems when installing

Discussion in 'HOWTO-Related Questions' started by mendoza, Apr 21, 2008.

  1. mendoza

    mendoza New Member

    Hi All,
    (this is how to:

    when i try to install zoneminder from .deb i get following error message:
    dpkg: dependency problems prevent configuration of zoneminder
    i think i need to upgrade some packages but i'm not sure how. I did usuall apt-get update, upgrade and i tried to change sources.list to what i found in Perfect Setup for Ubuntu 6.606 but no success.

    I run
    sudo apt-get -f install
    but it only suggested me to remove zoneminder.

    Also the link to zoneminder deb package ( doesn't exist anymore so i used this source:

    Here are the error messages in all glory:
    sudo dpkg -i zoneminder_1.22.3-8_i386.deb 
    Selecting previously deselected package zoneminder.
    (Reading database ... 19437 files and directories currently installed.)
    Unpacking zoneminder (from zoneminder_1.22.3-8_i386.deb) ...
    dpkg: dependency problems prevent configuration of zoneminder:
     zoneminder depends on libc6 (>= 2.6.1-1); however:
      Version of libc6 on system is 2.3.6-0ubuntu20.5.
     zoneminder depends on libgcc1 (>= 1:4.2.1); however:
      Version of libgcc1 on system is 1:4.0.3-1ubuntu5.
     zoneminder depends on libmysqlclient15off (>= 5.0.27-1); however:
      Version of libmysqlclient15off on system is 5.0.22-0ubuntu6.06.9.
     zoneminder depends on libstdc++6 (>= 4.2.1); however:
      Version of libstdc++6 on system is 4.0.3-1ubuntu5.
     zoneminder depends on zlib1g (>= 1:; however:
      Version of zlib1g on system is 1:1.2.3-6ubuntu4.
    dpkg: error processing zoneminder (--install):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
    I'm using Ubuntu Server 6.06.1, very new install. (kernel 2.6.15-51)
  2. wisu

    wisu New Member

    Packages are now in the Ubuntu Repository

    Hi... ur private message caught my attention...

    Yes.. the debs at don't exist anymore... after a little research I found that the Gutsy Gibbons repository has included zoneminder...

    on my laptop running Gutsy

    looking more deeper at the Hardy Heron repository i found that it also includes zoneminder...

    What i suggest is.... if you want to go with LTS wait 3 days for the HH release, install it.... enable the universe repository and apt-get install zoneminder...

    I would appreciate it if you could update this post on your progres....

  3. mendoza

    mendoza New Member

    8.04 works

    so i tried ubuntu 8.04 (desktop) and apt-get install zoneminder (had to add universe repository and update) worked without any problems.
    that my zoran card doesn't want to work (probably driver) is different story (and different mailing-list...)
    thanks for help
  4. cumie

    cumie New Member

    Jul 14 12:27:02 havid zmdc[2343]: INF [Starting pending process, zmc -m 1]
    Jul 14 12:27:02 havid zmdc[2343]: INF ['zmc -m 1' starting at 09/07/14 12:27:02, pid = 2733]
    Jul 14 12:27:02 havid zmdc[2733]: INF ['zmc -m 1' started at 09/07/14 12:27:02]
    Jul 14 12:27:02 havid zmc_m1[2733]: INF [Debug Level = 0, Debug Log = <none>]
    Jul 14 12:27:02 havid zmc_m1[2733]: INF [Starting Capture]
    Jul 14 12:27:02 havid zmc_m1[2733]: ERR [Invalid response status 400: Bad Request]
    Jul 14 12:27:02 havid zmc_m1[2733]: ERR [Unable to get response]
    Jul 14 12:27:02 havid zmc_m1[2733]: ERR [Failed to post-capture monitor 0]
    Jul 14 12:27:02 havid zmdc[2343]: ERR ['zmc -m 1' exited abnormally, exit status 255]

    :confused: dunno what to do

    i use on ubuntu 9.0.4 server remoting grand ip camera. but it cant work :(
  5. fishy6969

    fishy6969 New Member

    I had the same problem with remote images and despite googling haven't come up with an answer. I've resorted to using webcam (in the repos) and uploading the image to the zoneminder machine. An alternative would be making a quick bash script to wget or curl the image file to the zoneminder machine. Not ideal but it does work OK.

Share This Page