Zimbra Mail problem

Discussion in 'Server Operation' started by ryazkhan, Apr 5, 2008.

  1. ryazkhan

    ryazkhan New Member

    Hi I followed how to, to setup my zimbra mail server it is working fine i can send mail from it but i cannot get mails in it. I kind of know why is that because I could not find out where to put these lines I mean in which files /etc/hosts or /etc/resolv.conf or somewhere else

    ...]
    mail.example.com. A 1.2.3.4
    mail.example.com. MX 0 mail.example.com.
    example.com. MX 0 mail.example.com.
    [...]

    my domain not getting resolved any way I am not able to access it using name however I am able to access it with IP address and that is the main reason I belive because when reply come it come to domain name not to IP address. So please help me with that and guide me where to put stated above lines in which files to work it correctly. Any help is much appreciated

    Thank you in advance for your time and instruction
    and if possible provide me content of specific file after inserting above lines into that files.

    Many many thanks to all of you
    [email protected]
     
  2. falko

    falko Super Moderator ISPConfig Developer

    You must create the DNS records on the DNS servers that are responsible for your domain (usually that are your registrar's name servers).

    You can find out about these name servers by running
    Code:
    dig ns yourdomain.com
     
  3. ryazkhan

    ryazkhan New Member

    thank you for getting back to me
    I know it has to do some with dns but not sure where I have to create and how to do that. I have bind9 running on my virtual machine. I am trying to setup same machine as dns server as well. I dont have any external IP so just want to make it work internal first and then will wory about external. I am using default mail.example.com and when I tried to ping form same box I got it resolved but not from any other box. I can send emails out but cannot get. I cant even get that message I sent to myself using zimbra. I would be really greatefull to you if you provide me step by step info and how to do that. Many many thanks
    I will appreciate your help
    I am a student of networking and just in love with Linux specially ubuntu I belive. so please help me as much as you possibly could.
    Thanks
     
  4. falko

    falko Super Moderator ISPConfig Developer

  5. ryazkhan

    ryazkhan New Member

    Thank you so much I really appreciate for your time

    I dont have any privat address or some since I am not a firm I still in school doing networking and like linux and want to do stuff in linux rather that window. I have a dyndns though which point to my router and that is
    servernet.selfip.info www. can be put before servernet also. So here I want to setup. I have linux box name as simple as ubuntu and my local domain I want to name some as lserver.net so that would be ubuntu.lserver.net

    Outside Domain= servernet.selfip.info
    Inside Domain= lserver.net

    I am trying to get it up so I will be able to send which I already am and receive mails from outside and local as well.
    Any help would be appreciated
    Thank you for your time
     
  6. falko

    falko Super Moderator ISPConfig Developer

    I think in the selfip.info control panel you can enable MX records for your subdomain. IT should point to your router's public IP address as well.
     
  7. ryazkhan

    ryazkhan New Member

    Sorry for delay was kind of busy at work & school projects

    I set it up to selfip.info as you pointed but I am still not getting mail and while installing zimbra I gets error message saying that dns dont have MX records in it, but if i skipp that error installation can completed but again would be able to receive mail.
    Please help me with setting MX in DNS if you can. I am not sure where to go and what to type:confused: so please guide me through and always thank you for your time and support. Do I need bind9 for that?
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Code:
    server2:~# dig mx servernet.selfip.info
    
    ; <<>> DiG 9.3.4 <<>> mx servernet.selfip.info
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 29618
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;servernet.selfip.info.         IN      MX
    
    ;; ANSWER SECTION:
    [B][COLOR="Red"]servernet.selfip.info.  14400   IN      MX      10 selfip.info.[/COLOR][/B]
    
    ;; ADDITIONAL SECTION:
    selfip.info.            86400   IN      A       63.208.196.104
    
    ;; Query time: 407 msec
    ;; SERVER: 213.191.92.84#53(213.191.92.84)
    ;; WHEN: Thu Apr 17 21:35:40 2008
    ;; MSG SIZE  rcvd: 71
    
    server2:~#
    That doesn't look ok. Try
    servernet.selfip.info. 14400 IN MX 10 servernet.selfip.info.
    instead, and make sure that servernet.selfip.info is pointing to your public IP address.
     
  9. ryazkhan

    ryazkhan New Member

    I have not done anything to it. I just select dyndns option which let you configure mail or some and I name my computer that way so it should look like that.
    I still need help with creating MX record because I am not sure where to go and what to type
    If you can help me with that I would appreciated your help so please please do.
    thank you for your time and help so far
     
  10. falko

    falko Super Moderator ISPConfig Developer

  11. ryazkhan

    ryazkhan New Member

    I end up with setting split DNS for that and finally it worked thanks to zimbra forum and wiki. I created mini how to for my quick reference www.freetech.selfip.info/dns.php. Zimbra is a peice of cake now:)
     

Share This Page