Zimbra 7.0.1 GA ubuntu 10.04 installing on Ubuntu 10.10

Discussion in 'Installation/Configuration' started by Dagunchi, Mar 30, 2011.

  1. Dagunchi

    Dagunchi New Member

    Hello, I has tried several times install and configure, but without success at the moment, i fixed almost all errors and all install go with success, but when installation finished i see in the setup log error "ERROR: account.NO_SUCH_SERVER (no such server: mail.dga.lv)" and several errors about certificates and i can't access zimbra webadmin it only hangs and never timeout. This error i try fix about week and can't find solution in forums and in configuration. I think there is something with my configuration problem, but where i don't know.

    There is my configuration:

    /etc/hostname

    Code:
    mail.dga.lv
    But when i installed ubuntu i add a hostname "dga" and later when i try install zimbra only then i change to mail.dga.lv

    /etc/hosts

    Code:
    127.0.0.1--TAB--localhost.localdomain localdomain
    77.93.23.16--TAB--mail.dga.lv mail
    77.93.23.16 --TAB--dga.lv
    127.0.1.1--TAB--dga
    
    # The following lines are desirable for IPv6 capable hosts
    ::1     localhost ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    /etc/resolv.conf

    Code:
    search dga.lv
    nameserver 77.93.23.16
    nameserver 127.0.0.1
    nameserver 82.193.64.2
    nameserver 8.8.8.8
    dig dga.lv mx

    Code:
    ; <<>> DiG 9.7.1-P2 <<>> dga.lv mx
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 63614
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 3
    
    ;; QUESTION SECTION:
    ;dga.lv.                                IN      MX
    
    ;; ANSWER SECTION:
    dga.lv.                 38400   IN      MX      10 mail.dga.lv.
    
    ;; AUTHORITY SECTION:
    dga.lv.                 38400   IN      NS      ns1.dga.lv.
    dga.lv.                 38400   IN      NS      ns2.dga.lv.
    
    ;; ADDITIONAL SECTION:
    mail.dga.lv.            38400   IN      A       77.93.23.16
    ns1.dga.lv.             38400   IN      A       77.93.23.16
    ns2.dga.lv.             38400   IN      A       77.93.23.16
    
    ;; Query time: 0 msec
    ;; SERVER: 77.93.23.16#53(77.93.23.16)
    ;; WHEN: Wed Mar 30 19:15:25 2011
    ;; MSG SIZE  rcvd: 129
    dig dga.lv any

    Code:
    ; <<>> DiG 9.7.1-P2 <<>> dga.lv any
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 13321
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 0, ADDITIONAL: 3
    
    ;; QUESTION SECTION:
    ;dga.lv.                                IN      ANY
    
    ;; ANSWER SECTION:
    dga.lv.                 38400   IN      NS      ns2.dga.lv.
    dga.lv.                 38400   IN      NS      ns1.dga.lv.
    dga.lv.                 38400   IN      SOA     ns1.dga.lv. admin.dga.lv. 1301071331 10800 3600 604800 38400
    dga.lv.                 38400   IN      MX      10 mail.dga.lv.
    dga.lv.                 38400   IN      A       77.93.23.16
    
    ;; ADDITIONAL SECTION:
    ns1.dga.lv.             38400   IN      A       77.93.23.16
    ns2.dga.lv.             38400   IN      A       77.93.23.16
    mail.dga.lv.            38400   IN      A       77.93.23.16
    
    ;; Query time: 0 msec
    ;; SERVER: 77.93.23.16#53(77.93.23.16)
    ;; WHEN: Wed Mar 30 19:16:18 2011
    ;; MSG SIZE  rcvd: 187
    host `hostname`

    Code:
    mail.dga.lv has address 77.93.23.16
    I know there are several threads in zimbra forums, but i can't find the answer for my problem.

    Maybe you can help find the problem.

    Thanks
     
  2. falko

    falko Super Moderator ISPConfig Developer

  3. Dagunchi

    Dagunchi New Member

    Yes i read that before, but i install fresh and it needs to install fine without that problem. Maybe somepermissions problem somewhere? when i install i use root.

    I give you some details from log where it fails our have errors.

    This logs from fresh install tonight.
    Code:
    Fri Apr  1 01:11:50 2011 Setting up CA...
    Fri Apr  1 01:11:50 2011 *** Running as root user: /opt/zimbra/bin/zmcertmgr createca 
    ** Creating directory /opt/zimbra/ssl/zimbra
    ** Creating directory /opt/zimbra/ssl/zimbra/ca
    ** Creating directory /opt/zimbra/ssl/zimbra/server
    ** Creating directory /opt/zimbra/ssl/zimbra/commercial
    ** Creating directory /opt/zimbra/mailboxd/webapps/zimbraAdmin/tmp
    ** Creating /opt/zimbra/ssl/zimbra/ca/zmssl.cnf...done
    ** Retrieving CA private key from ldap...failed.
    ** Retrieving CA cert from ldap...failed.
    ** Retrieving Commercial CA cert from ldap...failed.
    ** Creating CA private key /opt/zimbra/ssl/zimbra/ca/ca.key...done.
    ** Creating CA cert /opt/zimbra/ssl/zimbra/ca/ca.pem...done.
    Fri Apr  1 01:11:59 2011 done.
    Fri Apr  1 01:11:59 2011 Deploying CA to /opt/zimbra/conf/ca ...
    Fri Apr  1 01:11:59 2011 *** Running as root user: /opt/zimbra/bin/zmcertmgr deployca -localonly
    ** Importing CA /opt/zimbra/ssl/zimbra/ca/ca.pem into CACERTS...done.
    ** Copying CA to /opt/zimbra/conf/ca...done.
    Fri Apr  1 01:12:01 2011 done.
    Fri Apr  1 01:12:01 2011 Creating SSL certificate...
    Fri Apr  1 01:12:01 2011 *** Running as root user: /opt/zimbra/bin/zmcertmgr createcrt self 
    ** Creating /opt/zimbra/conf/zmssl.cnf...done
    ** Backup /opt/zimbra/ssl/zimbra to /opt/zimbra/ssl/zimbra.20110401011202 
    ** Retrieving server config key zimbraSSLCertificate...failed.
    ** Retrieving server config key zimbraSSLPrivateKey...failed.
    ** Generating a server csr for download self -keysize 1024
    ** Backup /opt/zimbra/ssl/zimbra to /opt/zimbra/ssl/zimbra.20110401011207 
    ** Retrieving Commercial CA cert from ldap...failed.
    ** Creating server cert request /opt/zimbra/ssl/zimbra/server/server.csr...done.
    ** Saving server config key zimbraSSLPrivateKey...failed.
    ** Signing cert request /opt/zimbra/ssl/zimbra/server/server.csr...done.
    Fri Apr  1 01:12:13 2011 done.
    Fri Apr  1 01:12:13 2011 Installing mailboxd SSL certificates...
    Fri Apr  1 01:12:13 2011 /opt/zimbra/mailboxd/etc/keystore didn't exist.
    Fri Apr  1 01:12:13 2011 *** Running as root user: /opt/zimbra/bin/zmcertmgr deploycrt self 
    ** Saving server config key zimbraSSLCertificate...failed.
    ** Saving server config key zimbraSSLPrivateKey...failed.
    ** Installing mta certificate and key...done.
    ------------------
    Fri Apr  1 01:12:54 2011 ERROR: account.NO_SUCH_SERVER (no such server: mail.dga.lv)
    Fri Apr  1 01:12:54 2011 *** Running as zimbra user: /opt/zimbra/bin/zmprov -m -l cs mail.dga.lv
    
     
  4. be04376

    be04376 New Member

    Hi,

    where you able to solve his?
    I'm facing the exact same issue when i try to install a ldap replica
     

Share This Page