Zimabra SA Update for spamassassin now working

Discussion in 'HOWTO-Related Questions' started by tebogor, Sep 20, 2010.

  1. tebogor

    tebogor New Member

    Zimabra SA Update for spamassassin not working

    Please help i am new with Zimbra and would like to update spamassassin as am picking up allot of spam,the guy who use to manage this left and never update the spamassassin.

    Output when i run sa-update manauly
    /opt/zimbra/zimbramon/bin# ./sa-update
    config: no configuration text or files found! please check your setup
    check: no loaded plugin implements 'check_main': cannot scan! at /opt/zimbra/zimbramon/lib/Mail/SpamAssassin/PerMsgStatus.pm line 164.

    Last edited: Sep 20, 2010
  2. tebogor

    tebogor New Member

    Any advice would be much aprecaited
  3. falko

    falko Super Moderator ISPConfig Developer

    Unfortunately I have no idea how to solve this... :(
  4. chrisedes

    chrisedes New Member

    I had this problem too. I had to do a few things to solve it. I was really disappointed that no one posted a solution, so I will do just that.

    One, since /opt/zimbra is owned by root, yet sa-update should be run as the zimbra user, I had to do the following as root:

    mkdir /opt/zimbra/.gnupg
    chown zimbra:zimbra /opt/zimbra/.gnupg
    chmod 700 /opt/zimbra/.gnupg

    mkdir /opt/zimbra/.spamassassin
    chown zimbra:zimbra /opt/zimbra/.spamassassin

    Two, sa-update still tried to create the .gnupg directory unless I specified the parameter manually with " --gpghomedir /opt/zimbra/.gnupg".

    Three, I had to edit the sa-update script thus:

    my $DEF_RULES_DIR = '/opt/zimbra/conf/spamassassin';
    my $LOCAL_RULES_DIR = '/opt/zimbra/conf/spamassassin';
    # my $LOCAL_RULES_DIR = '/etc/mail/spamassassin';

    You can see I commented out the default LOCAL_RULES_DIR definition and replaced it with the value for DEF_RULES_DIR.

    Four, in addition to the change above, I had to specify the parameter "--updatedir /opt/zimbra/conf/spamassassin". So the command I used was:

    ./sa-update --gpghomedir /opt/zimbra/.gnupg --updatedir /opt/zimbra/conf/spamassassin

    You can also pass "-D" to sa-update to put it into debug mode. That makes it a lot easier to fix any problems.

Share This Page