Zend Optimizer, Guard, and IONCube

Discussion in 'General' started by Code5, Aug 16, 2008.

  1. Code5

    Code5 New Member

    Hi there, please can anyone tell me how to go about installing Zend Optimizer, Guard, and IONCube with ISPConfig.

    Ive tried to use the following guide but no luck;

    http://www.howtoforge.com/linux_apache2_ssl_php5_zendoptimizer_ioncubeloader

    Ive also modified /etc/php5/apache2/php.ini and /etc/php5/cgi/php.ini and added the following lines to them both after
    PHP:

    zend_extension
    =/usr/local/lib/ioncube/ioncube_loader_lin_5.0.so
    zend_extension
    =/usr/local/lib/Zend/ZendOptimizer.so
    zend_optimizer
    .optimization_level=15

    When i run my phpinfo
    .php it does not bring back anything about Zend Optimizer or IONCube.

    Just for some added info my phpinfo file brings back the following top line:

    PHP Version 5.2.4-2ubuntu5.3


    Thanks 
    for any help here.
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    You use php 5.2 and not 5.0, so you will have to load the file ioncube_loader_lin_5.2.so and not ioncube_loader_lin_5.0.so.
     
  3. Code5

    Code5 New Member

    Cheers, how stupid of me not to think that.

    Changed all to 5.2, sorted.
     

Share This Page