yum Update

Discussion in 'Installation/Configuration' started by schneid, Jul 20, 2007.

  1. schneid

    schneid New Member

    Hello guys. :)

    I already install my cent0s 4.4 with no problem and also my ISPConfig on my system. Nowadays, I want to update some features but I got this errors;

    I only use yum update, how can I resolve this? Any help is appreciated. :confused:
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Please run
    Code:
    yum install cracklib-dicts pam httpd openssh
    and try again.
     
  3. schneid

    schneid New Member

    I installed that but this is what happened;

    Code:
    [root@HUBPORT ~]# yum install cracklib-dicts pam httpd openssh
    Setting up Install Process
    Setting up repositories
    Reading repository metadata in from local files
    Parsing package install arguments
    Resolving Dependencies
    --> Populating transaction set with selected packages. Please wait.
    ---> Package openssh.i386 0:3.9p1-8.RHEL4.20 set to be updated
    ---> Package httpd.i386 0:2.0.52-32.3.ent.centos4 set to be updated
    ---> Package cracklib-dicts.i386 0:2.8.9-1.3 set to be updated
    ---> Package pam.i386 0:0.77-66.21 set to be updated
    --> Running transaction check
    --> Processing Dependency: cracklib-dicts@i386 = 2.7-29 for package: cracklib
    --> Processing Dependency: httpd = 2.0.52-28.ent.centos4 for package: mod_ssl
    --> Processing Dependency: openssh = 3.9p1-8.RHEL4.15 for package: openssh-server
    --> Processing Dependency: pam = 0.77-66.17 for package: pam-devel
    --> Processing Dependency: httpd = 2.0.52-28.ent.centos4 for package: httpd-suexec
    --> Processing Dependency: openssh = 3.9p1-8.RHEL4.15 for package: openssh-askpass
    --> Processing Dependency: openssh = 3.9p1-8.RHEL4.15 for package: openssh-askpass-gnome
    --> Processing Dependency: httpd = 2.0.52-28.ent.centos4 for package: httpd-manual
    --> Processing Dependency: initscripts >= 7.93.26.EL-1 for package: httpd
    --> Processing Dependency: openssh = 3.9p1-8.RHEL4.15 for package: openssh-clients
    --> Restarting Dependency Resolution with new changes.
    --> Populating transaction set with selected packages. Please wait.
    ---> Package mod_ssl.i386 1:2.0.52-32.3.ent.centos4 set to be updated
    ---> Package openssh-server.i386 0:3.9p1-8.RHEL4.20 set to be updated
    ---> Package openssh-askpass-gnome.i386 0:3.9p1-8.RHEL4.20 set to be updated
    ---> Package openssh-askpass.i386 0:3.9p1-8.RHEL4.20 set to be updated
    ---> Package initscripts.i386 0:7.93.29.EL-1.centos4 set to be updated
    --> Running transaction check
    --> Processing Dependency: cracklib-dicts@i386 = 2.7-29 for package: cracklib
    --> Processing Dependency: pam = 0.77-66.17 for package: pam-devel
    --> Processing Dependency: openssh = 3.9p1-8.RHEL4.15 for package: openssh-clients
    --> Processing Dependency: httpd = 2.0.52-28.ent.centos4 for package: httpd-manual
    --> Processing Dependency: httpd = 2.0.52-28.ent.centos4 for package: httpd-suexec
    --> Finished Dependency Resolution
    Error: Missing Dependency: cracklib-dicts@i386 = 2.7-29 is needed by package cracklib
    Error: Missing Dependency: pam = 0.77-66.17 is needed by package pam-devel
    Error: Missing Dependency: httpd = 2.0.52-28.ent.centos4 is needed by package httpd-suexec
    Error: Missing Dependency: httpd = 2.0.52-28.ent.centos4 is needed by package httpd-manual
    Error: Missing Dependency: openssh = 3.9p1-8.RHEL4.15 is needed by package openssh-clients
    
    How can I suppose to to install those repositories or missing dependencies on my server. I used yum but no effect. Also my ISPConfig got this problem;

    How can I connect them back? I restarted them but the same result appear.
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    You can try to download the packages manually from a CentOS mirror and install them with rpm -ivh.
     
  5. schneid

    schneid New Member

    what if my packages are in my cd (.iso)? Can I install it back using an rpm? is it also need a new repositories? i am using CentOS 4.4 as my linux server, can I have the mirror site so that i can install it using rpm.

    thanks for your help falko.
     
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    You can also install the rpm packages from your CD with rpm -ivh. :)
     
  7. schneid

    schneid New Member

    when i try to use rpm -ivh, i've got this message;

    rpm: no packages given for install

    I already mount my .iso part 1 into my linux but nothing happened. Please kindly heeeelp me., Falko.
     
  8. ipfreely

    ipfreely New Member

    Hi,
    the rpm command requires the package you wish to install. For example
    rpm -Uvh "packagename.rpm"
    do not include the quotes.

    you can find all your missing dependancies and download them and rpm each one then try the yum update. For example you can find the

    Error: Missing Dependency: cracklib-dicts@i386 = 2.7-29 is needed by package cracklib

    at

    http://rpmfind.net/linux/rpm2html/search.php?query=cracklib

    Downaload it and

    rpm -Uvh cracklib-2.8.2-1.i386.rpm

    do that for each missing dependancy and then your yum

    Hope this helps!

    Good luck,
    Chris
     
  9. schneid

    schneid New Member

    hello ipfreely,

    i will also try your suggestion on my missing packages using rpm -ivh "package.rpm"

    I hope it will help me a lot.

    Thanks
     
  10. schneid

    schneid New Member

    Waa. T_T..

    The same error was occured. I did not get why is it, I always got those errors. I dont know now how to solve it. its been 3 weeks and the same errors appear.

    I.m down now.
    T_T
     
  11. o.meyer

    o.meyer New Member Moderator HowtoForge Supporter ISPConfig Developer

    Have you changed the settings for the standard repositorys or added some other repositorys?

    Have a look at /etc/yum.repos.d/

    Olli
     
  12. bogus

    bogus New Member

    Simple when you know how

    I've been having the same problem with a number of our systems. I did try substituting the new ISOs to upgrade to 4.5 (see http://www.brandonhutchinson.com/mrepo_configuration.html ) but somehow it didn't find the new initscripts rpm. Anyway, just install the newer initscripts manually:

    rpm -ivF initscripts-7.93.29.EL-1.centos4.i386.rpm

    You can then run yum without problems. This hasn't picked up the actual 4.5 base files, don't see how to do that, but at least the 4.4 is now updating again....
     

Share This Page