Yum update fails when setting up server

Discussion in 'Installation/Configuration' started by RonH, Jan 17, 2008.

  1. RonH

    RonH New Member

    Hello All!

    I'm trying to set up my first web server, using this tutorial, but I got to step 5 on page 3 where I'm supposed to do a:
    yum update
    I tried it, but I get back a
    Setting up Update Process
    Setting up repositories
    Cannot find a valid baseurl for repo: update
    Error: Cannot find a valid baseurl for repo: update
    I looked around on google and it seems people usually suggest doing a:
    ping www.google.com
    I tried that, I get:
    ping: unknown host www.google.com
    Some people were saying that they could ping IP addresses, so I tried pinging my laptop (connected wirelessly if that matters) IP and I got:
    connect: Network is unreachable
    And if it helps, here is my /etc/resolv.conf
    search rondotexe.com
    I bought the domain (rondotexe.com) so I figured that's what I was supposed to put there, and I got the two DNS IPs from /ipconfig /all using the command line cmd.exe in windows.

    I figure this has something to do with my internet connection. My internet works just fine (I'm on that connection right now. But is there some other problem?

    Oh yes, last thing. On this page, I made my /etc/hosts look like this:
    # Do not remove the following line, or various programs
    # that require network functionality will fail.               localhost.localdomain localhost             mesb.rondotexe.com mesb
    *mesb is the name of the server. I got the IP address ( from my ISP.

    Sorry for all this information, but I figured if I didn't tell you guys from the get-go, you'd ask.
  2. devnull3d

    devnull3d New Member

    It looks like your name servers are down
    home:~# cp /etc/resolv.conf /etc/resolv.conf_bak
    home:~# echo nameserver > /etc/resolv.conf
    home:~# echo nameserver >> /etc/resolv.conf
    home:~# ping google.com
    ping: unknown host google.com
    Try using open DNS servers such as and or contact your ISP to supply you with their nameservers.
    And BTW is a private netblock. So it only works on your local network, but not on the internet.
    Try pinging if you get a reply you're OK to go, if not then your box isn't on the internet :)
    Last edited: Jan 17, 2008
  3. RonH

    RonH New Member

    Thanks devnull3d!

    I figured that IP (and another one that was 66.xx.xx.xx.xx) were different than the ones I usually see on computer. I guess I was trying to set up a internet server without ordering business cable, and this is how they'd make it so that I can't do that.

    I'm going to try changing the DNS Servers and I'll post the effects later today.

Share This Page