Yum Update CentOS 7.4 for Meltdown/Spectre fstab Boot Error

Discussion in 'Installation/Configuration' started by bpmee, Jan 7, 2018.

  1. bpmee

    bpmee Member

    My host advised updating CentOS 7.4 using ]# yum update to patch security problems from the Meltdown/Spectre microprocessor vulnerabilities. After update my backup service stopped working. Host said edit the /etc/lvm/lvm.conf file and reboot.

    On reboot the server failed . The host said they needed to comment out all log mounts in /etc/fstab file to boot the server. This worked.

    However, all my /home/www/[site]/log/ files are gone except error.log. It is 0 bytes.

    What happened on update and reboot to cause this problem, I need my log files back! Or should I just wait until ISPConfig creates new log files? How can I return /etc/fstab to normal state without commented log files? Will my logs come back?

    Thanks to anyone for help!
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Ask your hosting provider which error they got and what have you changed in lvm.conf? The bind mounts are in fstab are required to have the log files mounted in the website log dir, so commenting them out will remove log access there. I guess that the change in lvm.conf caused the issue and not the updated CentOS kernel.
    bpmee likes this.
  3. bpmee

    bpmee Member

    Hi Till, thanks for your reply. I reviewed boot.log from yesterday. /web10/log attempts mount, then fails with systemctl status message.

    I think this has to do with the yum update I performed, though I'm not sure. Everything else seems to be fine. Will monitor if backup runs successfully today.

    [^[[32m  OK  ^[[0m] Reached target Local File Systems (Pre).
             Mounting /var/www/clients/client1/web10/log...
             Mounting /var/www/clients/client1/web25/log...
             [other sites]
             Mounting /boot...
             [other sites]
    [^[[32m  OK  ^[[0m] Reached target Swap.
    [^[[1;31mFAILED^[[0m] Failed to mount /var/www/clients/client1/web10/log.
    See 'systemctl status var-www-clients-client1-web10-log.mount' for details.
    [^[[1;33mDEPEND^[[0m] Dependency failed for Local File Systems.
    [^[[1;33mDEPEND^[[0m] Dependency failed for Mark the need to relabel after reboot.
    [^[[1;33mDEPEND^[[0m] Dependency failed for Relabel all filesystems, if necessary.
    [^[[1;33mDEPEND^[[0m] Dependency failed for Migrate local SELinux policy changes from the old store structure to the new structure.
    [^[[1;31mFAILED^[[0m] Failed to mount /var/www/clients/client1/web25/log.
    See 'systemctl status var-www-clients-client1-web25-log.mount' for details.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You can e.g. try to enable one of the bind mount lines and then run:

    mount -a

    to activate it and see if you get an error.
    bpmee likes this.
  5. bpmee

    bpmee Member

    I uncommented all lines, ran ]#mount -a

    No errors reported, but I'm still afraid to reboot!
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run:

    uname -a

    which shows the currently running kernel version and post that info.
    bpmee likes this.
  7. bpmee

    bpmee Member

    [[email protected] ~]# uname -a
    Linux server1.server.com 3.10.0-693.11.6.el7.x86_64 #1 SMP Thu Jan 4 01:06:37 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
    Question: Would symlinked /var/www -> /home/www contribute to this problem?

    Some old fstab paths are /var/www, some newer paths are direct /home/www. This resulted from a partitioning problem when I migrated an old server.
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess this will not contribute to this issue but produce another one. Config actions for sites that have a symlink in the path are skipped. To relocate such a path, use bind mounts instead. There is a tutorial about that at howtoforge.

    Regarding mount issue, maybe these options can help when added to the bind mount line:

    so that the system does not try to mount them during startup, instead they get mounted by system when they are used the first time.
    bpmee likes this.
  9. bpmee

    bpmee Member

    Till, thanks so much. Should I place the code in the /etc/fstab file like the following?

    /var/log/ispconfig/httpd/site.com /var/www/clients/client1/web1/log    none    bind,nobootwait    0 0
    /var/log/ispconfig/httpd/site.com /var/www/clients/client1/web1/log    none    bind,nobootwait,noauto,x-systemd.automount    0 0
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, that's what you might try.
  11. bpmee

    bpmee Member

    I tried adding the options you mentioned. Server still booted into emergency mode.

    I reviewed the boot.log again. The server didn't throw errors trying to mount web logs in /home/www, but it did complain about the symlink /var/www paths.

    I backed up fstab. Then I removed the options you suggested, restoring the original syntax. Then I replaced all symlinked /var/www with /home/www. Rebooted, no errors.

    I hope this works and does not produce any further problems. Best of all, I maintain the original ISPConfig lines in /etc/fstab, no custom changes needed! Thanks again, Till, for your assistance.
    till likes this.

Share This Page