You cannot assign HTTPD Includes to this website

Discussion in 'Installation/Configuration' started by blizzardville, Dec 6, 2007.

  1. blizzardville

    blizzardville New Member

    I'm attempting ISPconfig + Mongrel setup. I would like to place my proxy stuff into the "Apache Directives (Optional):" box.

    It doesn't matter what I put in there though I always get:

    You cannot assign HTTPD Includes to this website

    This is what I would like to put in there (substituting my own configuration)


    ProxyPass /
    ProxyPassReverse /
    ProxyPreserveHost on

    Even if I cut this down to just:


    I still get the error. How can I diagnose this problem. I have looked in the apache error log but nothing is there.
  2. blizzardville

    blizzardville New Member

  3. blizzardville

    blizzardville New Member

    ProxyPass not working in Apache Directives

    I look in the vhosts file and my


    directive is there but the Proxy???? directives do not show up.

    The documentation says they would be commented out if there was syntax error, so something else must be happening because they are not even in there commented out.

    This thread says to edit the vhosts file directly for this.

    Is that wise? Won't subsequent changes to Vhosts via ISPConfig wipe out any manual edits I put in there?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats not a good idea as your changes will be lost. The Vhost_ispconfig.conf file should never be edited manually.

    Please check this:
  5. blizzardville

    blizzardville New Member

    Ok, that makes sense.

    What I need to know is how to do a ProxyPass then.

    If I put ProxyPass into Apache Directives it gets filtered out and never makes it to the Vhosts_ispconfig.conf file. I can't edit it directly, how do I get ProxyPass in there?

    Do I need to dig through the ispconfig php code and make some custom edits to solve this one?
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig does not filter the code in the apache directives field. So please check your apache config as described in the thread that I posted above.
  7. blizzardville

    blizzardville New Member

    Aaahhh now I see.

    I was expecting the proxypass directives to be inserted into the config file but be commented out if they were syntax erroring out. I read this somewhere, but it is not so.

    So if syntax errors are generated then the Vhosts file is created with the date and time instead.

    You are right I tried putting the proxypass directives in again and it worked this time.

    The real issue I was having that was causing the proxypass problem was not having both mod_proxy and mod_proxy_http enabled.

    It seems like most of the howto guides I was looking at leave out the mod_proxy_http part.

    Its working now, and I love this ISPConfig. I'm not an ISP and am probably only going to host a handfull of virtual sites on this host, but it seems to me this ISPConfig tool is going to make managing this webserver a lot easier.

    Thanks again!!!:)

Share This Page