yaa - autoresponse not working

Discussion in 'HOWTO-Related Questions' started by qtx, May 22, 2008.

  1. qtx

    qtx New Member

    Hi there,

    I set up the yaa-Autoresponder on another server a while ago, everything worked out well.

    But now, on another machine, I run into problems.

    System: Debian Etch
    MTA : postfix

    Before I installed yaa I upgraded the system.

    Output of the mail.log:
    Code:
    May 22 00:04:08 localhost amavis[31965]: (31965-06) Passed CLEAN, LOCAL [127.0.0.1] [62.202.37.7] <sender@mail2.com> -> <my@mail.com>, Message-ID: <48349C57.4050805@mail2.com>, mail_id: PDWJq-Cgnuur, Hits: -, queued_as: C27133154004, 296 ms
    May 22 00:04:08 localhost postfix/smtp[6086]: 6161E3154002: to=<my@mail.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.55, delays=0.2/0.02/0.01/0.31, dsn=2.6.0, status=sent (250 2.6.0 Ok, id=31965-06, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as C27133154004)
    May 22 00:04:08 localhost postfix/qmgr[11691]: 6161E3154002: removed
    May 22 00:04:08 localhost postfix/virtual[6089]: C27133154004: to=<my@mail.com>, relay=virtual, delay=0.15, delays=0.05/0.07/0/0.03, dsn=2.0.0, status=sent (delivered to maildir)
    May 22 00:04:09 localhost yaa.pl[6091]: Warning: setting empty lookup query order for attribute 'subject'. 
    May 22 00:04:09 localhost yaa.pl[6091]: Warning: setting empty lookup query order for attribute 'forward'. 
    May 22 00:04:09 localhost yaa.pl[6091]: Warning: setting empty lookup query order for attribute 'active'. 
    May 22 00:04:09 localhost yaa.pl[6091]: Warning: setting empty lookup query order for attribute 'charset'. 
    May 22 00:04:09 localhost yaa.pl[6091]: Warning: setting empty lookup query order for attribute 'message'. 
    May 22 00:04:09 localhost yaa.pl[6091]: Warning: setting empty lookup query order for attribute 'rewrite_recipient'. 
    May 22 00:04:09 localhost yaa.pl[6091]: Warning: setting empty lookup query order for attribute 'rewrite_sender'. 
    May 22 00:04:09 localhost yaa.pl[6091]: Warning: setting empty lookup query order for attribute 'local_domains'. 
    May 22 00:04:09 localhost yaa.pl[6091]: 4545151: Processing new request, id 4545151 
    May 22 00:04:09 localhost yaa.pl[6091]: 4545151: Warning: Your MTA does not provide Delivered-To header. Yaa will have to rely on message headers which are very easy to fake. You've been warned. 
    May 22 00:04:09 localhost yaa.pl[6091]: 4545151: Warning: Your MTA violates RFC 822 by not adding Return-Path header in message. Yaa will have to rely on message headers which are very easy to fake. You've been warned. 
    May 22 00:04:09 localhost yaa.pl[6091]: 4545151: Message sender: sender@mail2.com, recipients: my@mail.com 
    May 22 00:04:09 localhost yaa.pl[6091]: 4545151: Processing complete. 
    May 22 00:04:09 localhost postfix/pipe[6090]: C27133154004: to=<my@autoreply.mail.com>, orig_to=<my@mail.com>, relay=yaa, delay=0.56, delays=0.05/0.09/0/0.41, dsn=2.0.0, status=sent (delivered via yaa service)
    May 22 00:04:09 localhost postfix/qmgr[11691]: C27133154004: removed
    
    The MySQL-Database *mail* with table *autoresponder* are set up properly.
    The DB-User works.
    -> The mailserver is beeing used since 2 years, just without yaa, yet.

    Any hints and tipps are appreciated very much :)

    Thanks, QT
     
  2. qtx

    qtx New Member

    solved - yaa - autoresponse not working

    Hey list,

    Never mind.
    Using the yaa.conf-file from my other server did the trick.

    Now everything works just fine.

    Thanks anyway, although only :eek: spammers:eek: replied to this post :p

    Cheers, QT
     
  3. tarheels4l

    tarheels4l New Member

    yaa - autoresponder not working

    Hello,

    I am having the same problem. I am using postfix version 2.3.8 on debian etch as described here http://www.howtoforge.com/virtual_users_and_domains_with_postfix_debian_etch



    Feb 1 17:39:57 etch yaa.pl[8321]: 7269333: Warning: Your MTA does not provide Delivered-To header. Yaa will have to rely on message headers which are very easy to fake. You've been warned.
    Feb 1 17:39:57 etch yaa.pl[8321]: 7269333: Warning: Your MTA violates RFC 822 by not adding Return-Path header in message. Yaa will have to rely on message headers which are very easy to fake. You've been warned.
    Feb 1 17:39:57 etch yaa.pl[8321]: 7269333: Message sender: test@domain.com, recipients: test2@domain.com
    Feb 1 17:39:57 etch yaa.pl[8321]: 7269333: Processing complete.
    Feb 1 17:39:57 etch postfix/pipe[8302]: D745553892: to=<catchall@autoreply.domain.com>, orig_to=<test2@domain.com>, relay=yaa, delay=0.22, delays=0.04/0/0/0.17, dsn=2.0.0, status=sent (delivered via yaa service)
    Feb 1 17:39:57 etch postfix/qmgr[8211]: D745553892: removed

    Any ideas? Could you post your working yaa.conf for etch?
     

Share This Page