Xp Cant See Samba Domain

Discussion in 'Server Operation' started by sheffrem, Jun 11, 2007.

  1. sheffrem

    sheffrem New Member

    HI guys, i just joinned the list.
    For almost a week i have been trying to setup samba as a domain controller, and followed on of the how to http://howtoforge.com/samba_setup_ubuntu_5.10

    But after all well done xp tell me he cant find the domain, that etheir the netbios name is not registered with wins, or dns cant find it.
    Well i added the wins support = yes if you check the configurations i have.


    [global]
    workgroup = Engineering.net
    netbios name = LinuxPrintServer
    server string = %h server (Domain Controller,Print Server)


    passdb backend = tdbsam
    security = user
    username map = /etc/samba/smbusers
    name resolve order = wins bcast hosts
    domain logons = yes
    preferred master = yes
    wins support = yes

    # Set CUPS for printing
    printcap name = CUPS
    printing = CUPS

    # Default logon
    logon drive = H:
    logon script = scripts/logon.bat
    logon path = \\LinuxPrintServer\profile\%U


    # Useradd scripts
    add user script = /usr/sbin/useradd -m %u
    delete user script = /usr/sbin/userdel -r %u
    add group script = /usr/sbin/groupadd %g
    delete group script = /usr/sbin/groupdel %g
    add user to group script = /usr/sbin/usermod -G %g %u
    add machine script = /usr/sbin/useradd -s /bin/false/ -d /var/lib/nobody %u
    idmap uid = 15000-20000
    idmap gid = 15000-20000


    # sync smb passwords woth linux passwords
    passwd program = /usr/bin/passwd %u
    passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n .
    passwd chat debug = yes
    unix password sync = yes

    # set the loglevel
    log level = 3


    [homes]
    comment = Home
    valid users = %S
    read only = no
    browsable = no


    [printers]
    comment = All Printers
    path = /var/spool/samba
    printable = yes
    guest ok = yes
    browsable = no


    [netlogon]
    comment = Network Logon Service
    path = /home/samba/netlogon
    admin users = Administrator
    valid users = %U
    read only = no


    [profile]
    comment = User profiles
    path = /home/samba/profiles
    valid users = %U
    create mode = 0600
    directory mode = 0700
    writable = yes
    browsable = no


    [allusers]
    comment = All Users
    path = /home/shares/allusers
    valid users = @users
    force group = users
    create mask = 0660
    directory mask = 0771
    writable = yes

    PLS HELP ME, ITS A JOB THAT I HAVE TO COMPLETE BY WEDNESDAY.:confused: :confused: :confused:
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Can you compare your configuration again with the one from the tutorial? Maybe there's a typo somewhere or something else...
     

Share This Page