Discussion in 'Server Operation' started by cameron365, Sep 10, 2009.

  1. cameron365

    cameron365 New Member


    I had XEN server and because of RAM I decided to change the hardware so i moved the SATA HDD to new system and turn on the system and the server comes up but there was no nic then i found the nic name has been changed to eth1! then i went to /etc/network/interfaces and change the eth0 to eth1 and then i reboot the server to be sure after when i login to server and used ifconfig i see:

    #ifconfig eth1
    eth1 Link encap:Ethernet HWaddr 00:16:76:bd:10:54
    inet addr: Bcast: Mask:
    inet6 addr: fe80::216:------------- Scope: Link
    RX packets:14 errors:0 dropped:0 overruns:0 frame:0
    TX packets:36 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX byte:392 (392.0 B) TX byte:1728 (1.6 KB)
    here the resault of

    lshw -C network
    descriptions: Ethernet interface
    product: 82801G ( ICH7 Family) LAN Controller
    vendor: Intel Corporation
    phisical id: 8
    bus info: [email protected]:06:08.0
    logical name: eth1
    version: 01
    serial: 00:16:76:bd:10:54
    size: 100MB/s
    capacity: 100 MB/s
    width: 32 bits
    clock: 33MHz
    Capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver-e100 driverversion=3.5.23-k4-NAPI duplex=full firmware=N/A ip= latency=32 link=yes maxlatency=56 mingnt=8 mudule-e100 multicast=yes port=MII speed=100MB/s
    I cant ping the IP Address of gateway
    PLEASE HELP ME my Xen quests is off
  2. Torsson

    Torsson New Member

    this is just a guess but you can try it

    go to the following file

    And change:
    (network-script network-bridge)

    (network-script 'network-bridge netdev=ethX')

    ethX the interface you want to use (eth0 or eth1)

    be sure to use the same in interfaces on the guest host.

    and you should need to restart Xen or the whole machine if you want.

    Hope this helps, as i said its just a long shot guess :)
  3. Franz

    Franz Member

    what is output of:
     route -n
  4. cameron365

    cameron365 New Member


    dear friends,

    i just cant ping from server itself to the ip address in local network,
    please someone help on this situation:(
  5. cameron365

    cameron365 New Member


    i have default gateway and it is true.
    it it another thing,
    I only change the hardware i mean i move the HDD to another box that's all.
    now i cant ping the gateway from box itself and even i guests in the box.
    please someone give me the HELO

Share This Page