XEN Questions on Ubuntu Hardy (AMD64)

Discussion in 'HOWTO-Related Questions' started by atjensen11, Jul 11, 2008.

  1. atjensen11

    atjensen11 New Member

    I am new to XEN and just installed it with the following tutorial:

    http://www.howtoforge.com/ubuntu-8.04-server-install-xen-from-ubuntu-repositories

    I was sitting at the terminal, directly at the machine, watching as it reboots. The output to the screen flashes through many lines, eventually settling on one that says something like processing local scripts.

    After that line, no more output is every sent to the screen, including a login prompt.

    I can SSH into both Dom0 and DomU, but it doesn't appear that I can actually login at the terminal.

    Is this normal?

    Also, being new to XEN, is it possible to change setting on a DomU after the initial creation such as RAM, HD disk space, etc.? Does anyone know of a good source that explains how to do those items?

    Thanks.
     
  2. ralic

    ralic New Member

    No, you've hit the same problem as described and fixed here: Xen installation issues w/ Ubuntu 8.04 LTS server

    Basically, there's a bug in one of the scripts used in generating the DomU that breaks the Dom0's terminal configuration. The link above describes the quick-fix to get your Dom0 console login ability back and fix the bug so that future creations of DomU's won't result in it repeating.
     
  3. atjensen11

    atjensen11 New Member

    OK, so that patch works and I can login to the terminal on the host machine just fine. I have also applied the patch that was listed in the post and now the init.d script shuts down the domains as well without the error.

    However, I cannot get Xen to delete virtual machines by using the "xm delete server1.example.com" command. It keeps returning:

    Code:
    Error: <Fault 3: 'server1.example.com'>
    Usage: xm delete <DomainName>
    
    Remove a domain from Xend domain management.
    
    Is this related to the same script issues?
     
    Last edited: Jul 15, 2008
  4. atjensen11

    atjensen11 New Member

    This command works where "xm delete server1.example.com" did not:

    Code:
    xen-delete-image server1.example.com
     
  5. ralic

    ralic New Member

    I tried the 'xm delete instance' on a running instance and received a message indicating that the instance was running, so I tried the same thing after stopping it and get the same error as you did.

    I didn't find that sub-command in the xm man page, what is it supposed to do?

    I expect it's going to delete a xen domU, but that really isn't more than a config file and optionally some hdd resource files, which is easy enough to do by hand.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    I think it's xm destroy.
     

Share This Page