Xen on Debian installed but no eth0

Discussion in 'HOWTO-Related Questions' started by mksco, Jun 9, 2007.

  1. mksco

    mksco New Member


    I have a Intel DQ965gf MOBO system that boots fine in Debian Linux 2.6.18-4.

    I built Xen 3.0.3 from the source IAW the User's guide and basically following the steps in the howto here (I didn't find it until afterwords, and I'm not setting it up to boot to a separate partition). I made sure the Intel Gigabit NIC driver was built as a module but the module is not loaded when the xen kernel boots. Everything else seems to work fine, but without network support, I can't install guest domains.

    There is no mention of e1000 or eth0 in the dmseg output when I boot Xen, but it is there in the normal Debian boot.

    The controller shows up in lspci's output in both cases.

    When I boot Xen, ifconfig only lists lo and xnbr0 but lsmod shows e1000 is loaded.

    I also tried building with the NIC driver built in.

    I'm a relative linux and Xen newbie, I am at a loss as to what to look at or try next. I tried to get help on the Xen forum but the only suggestion was to switch to fedora, which is not an option (the Debian version was specified by others in my team).

  2. aqua

    aqua New Member

    try modprobe e1000 or modrobe e1000.o

    also try ifconfig -a. this will show all the networks on the system. your card maybe recognized, but not enabled. if this is the case, and it shows up in ifconfig -a, the try ifconfig ethx up where x is your network card number.

  3. mksco

    mksco New Member

    It turns out the problem was a bug in the driver. Downloading the latest source for the driver, building and installing it solved the problem. My supposition was that it was failing to load and not outputting any messages since there was nothing in dmesg.

    aqua, thanks for the suggestions. I had already tried modprobe and ifconfig -a didn't ever list the interface.


Share This Page