Xen for Centos 6.3 HowTo needs updating.

Discussion in 'HOWTO-Related Questions' started by Peter Williams, Oct 8, 2012.

  1. allawi78

    allawi78 New Member

    same error for me as well.

    installed centos minimal, and failed to build.
    I have spent a lot of time googling for a solution with no luck.
    it seems that it is a new problem.

    anybody got it solved ??
  2. jeq

    jeq New Member

    Problem solved, sort of...

    Yes, I found the solution.

    I've lost the reference, but in another forum found a comment that Xen 4.2 is incompatible with libvirt.

    I backed out xen 4.2 and installed 4.1.3, and was able to properly build libvirt.

    The resulting system does not work, but I believe that is because my underlying hardware is not up to the task. :mad:
  3. full_rains

    full_rains New Member


    Many thanks for this, it's work!!! But I have a little problem here.
    When I reboot to xend dom0, it just stand in boot screen with the quote "Centos 6.3" in the low right and it not boot to login screen!!!...:confused:
  4. Saijitsu

    Saijitsu New Member

    Had the same issue. The solution is actually really easy.

    If you follow this tutorial http://www.howtoforge.com/virtualiz...aravirtualization-and-hardware-virtualization
    you are adding an additional repository from http://au1.mirror.crc.id.au/repo/
    and there is xen 4.1.3 available. libvirt is incompatible to xen 4.2 at the moment so you have to use 4.1.3.
    After you added the repository just do

    thats it. now you should be able to patch libvirt just fine. You need to make sure that if you used yum install xen that you remove all references to xen-4.2 or you will get lots of errors. So uninstall everything for xen 4.2 before you install xen-4.1.3
    Last edited: Jan 16, 2013
  5. Midnight Hacker

    Midnight Hacker New Member

    libvirt not compatible with Xen 4.2

    I found the thread discussing the problem with Xen 4.2 and libvirt...

    The new libxenlight introduced in Xen 4.2 leads to the compile issues.

    Going back to Xen 4.1.3 solves the issue if you need to use Virtual Machine Manager (virt-manager). Or skip the libvirt update and use xm to manage the VMs.

Share This Page