[XEN , etch] prob with creation of my domU

Discussion in 'Installation/Configuration' started by mopsos, Sep 23, 2007.

  1. mopsos

    mopsos New Member

    Hi,
    I want install xen on my system debian etch.
    I install a basic etch system.
    Then I install
    Code:
    aptitude update;aptitute install xen-linux-system-2.6.18-5-xen-686 libc6-xen
    update-grub
    
    Then I reboot my system.
    All is ok I boot on the new kernel.
    I have a partition for install my "dom1" : /dev/sda8 /xen2
    For test :
    I do this :
    Code:
    dd if=/dev/zero of=/xen2/image1.img bs=1M count=3500
    mke2fs -j /xen2/image1.img
    mount -o loop /xen2/image1.img /xen2
    debootstrap etch /xen2 ftp://ftp.fr.debian.org/debian
    chroot /xen2 /bin/bash
    
    I configure my file system fstab
    Code:
    /dev/hda1 / ext3 defaults,errors=remount-ro 0 1
    
    and my file interfaces :
    Code:
    auto lo
    iface lo inet loopback
    allow-hotplug eth0
    iface eth0 inet dhcp
    
    I quit my chroot
    I lauch the script of network brige of xen with
    sh /etc/xen/scripts/network-bridge start

    then I create a file for xen
    vi /etc/xen/xen1.xsp
    Code:
    
    kernel = "/boot/vmlinuz-2.6.18-5-xen-686"
    memory = 1024
    name = "xen2"
    root = "/dev/hda1 ro"
    ramdisk = '/boot/initrd.img-2.6.18-5-xen-686'
    disk = [ 'file:/xen2/image1.img,hda1,w' ]
    vif = [ '' ]
    dhcp="dhcp"
    extra="3"
    
    But when i lauch my xen1 I have a few error :
    Code:
    FATAL: Error inserting fan (/lib/modules/2.6.18-5-xen-686/kernel/drivers/acpi/fan.ko): No such device
    FATAL: Error inserting thermal (/lib/modules/2.6.18-5-xen-686/kernel/drivers/acpi/thermal.ko): No such device
    Loading kernel modules...FATAL: Could not load /lib/modules/2.6.18-5-xen-686/modules.dep: No such file or directory
    /etc/init.d/bootclean: line 24: /var/lock/.clean: Read-only file system
    /etc/init.d/bootclean: line 24: /tmp/.clean: Read-only file system
    * bootclean: Failure creating '/tmp/.clean'.
    rm: cannot remove `./motd': Read-only file system
    * bootclean: Failure cleaning /var/run.
    rm: cannot remove `./aptitude': Read-only file system
    * bootclean: Failure cleaning /var/lock.
    /etc/rcS.d/S55bootmisc.sh: line 28: /var/run/utmp: Read-only file system
    
    
    At the end I have a lot of line like this :
    Code:
    4gb seg fixup, process logsave (pid 872), cs:ip 73:b7f39cd8
    printk: 9 messages suppressed.
    4gb seg fixup, process logsave (pid 872), cs:ip 73:b7f39cd8
    printk: 9 messages suppressed.
    4gb seg fixup, process logsave (pid 872), cs:ip 73:b7f39cd8
    printk: 9 messages suppressed.
    4gb seg fixup, process logsave (pid 872), cs:ip 73:b7f39cd8
    printk: 9 messages suppressed.
    
    I can log me, but it's very long to start him.
    It stay a long time on
    Starting system log daemon: syslogd
    And I can't install system,
    it says me :
    Code:
    W: Could not lock the cache file.  Opening in read-only mode; any changes you make to the states of packages will NOT be preserved!
    W: Not using locking for read only lock file /var/lib/apt/lists/lock
    E: Unable to open /var/log/aptitude to log actions - do_log (30 Read-only file system)
    W: Not using locking for read only lock file /var/lib/dpkg/lock
    
    Can you say me If I do a mistake?

    Thanks.
     
  2. falko

    falko Super Moderator ISPConfig Developer

  3. the_spy

    the_spy New Member

    "Read-only file system"

    you are in read only mode for this partition

    I see in one file: root = "/dev/hda1 ro" , you may try with rw instead of ro may be.
     

Share This Page