[Xen]Direct access to hardware

Discussion in 'HOWTO-Related Questions' started by Balbuzard, Jun 22, 2009.

  1. Balbuzard

    Balbuzard New Member


    I am using Xen to provide separated VM and to run network applications in one of them (No graphic applications) and a Media Center in Dom0. I would like to run the Media Center in a DomU, which would be better for safety reason, and for this purpose, I have to get direct access to the Hardware and more specifically to the graphic card. (VNC is not enought).
    With Xen, the dom0 and the DomU are both in the hypervisor, and should have the same structure, except that dom0 can control or modify the domUs. So, if I remove direct access to the hardware for dom0, I can provide it for one of the domU. But until now, I have not found any documentation about it.
    I just want to install a graphic server on one of the DomU, remove the direct access to the graphic card from the dom0, and then provide the direct access to the graphic card to the domU.
    Can someone tell me if this is possible, and in this case, if there is somewhere some documentation/tutorial/any clue to begin with?

    Thank you very much for your answer!
  2. Balbuzard

    Balbuzard New Member

    So I have tried to install a graphic server in the VM.
    apt-get install x-window-system-core
    and then a desktop
    apt-get install xfce4
    But during the installation, this message returns:
    No userspace software suspend support in the kernel
    The current kernel doesn't support userspace software suspend. 
    Please recompile the kernel with the 'CONFIG_SOFTWARE_SUSPEND=y' option.
    Which I have tried to google but without success.
    In fact, I presume that I should recompile my kernel, but how is it possible with paravirtualisation - Image-Based VM with xen?
    And what does this error mean?
    Thanks a lot for your help!
  3. Balbuzard

    Balbuzard New Member

    Oki, I have tried to install kde instead of xfce and no error occurs.
    It is working by VNC.
    I have then compiled and installed XBMC without any problem, but it does not work.
    When I enter xbmc" in the shell, it returns:
    Xlib: extention "RANDR" missing on display ":1.0"
    RandR extension missing
    I have tried then to export DISPLAY=":0.0" (which does not seem to be right, because vncserver is running on 1:0) and then the shell returns
    Cannot get root display. Is X11 running and is your DISPLAY variable set?
    Indeed, as I am running via VNC, and not directly to the graphic server, X11 can as well appear as not running.
    Is there any trick to workaround this issue?
    Or, is it possible to provide the direct access to the graphic server and the graphic card to DomU instead of Dom0?
    I am sure it is possible, because the structure of the DomU and Dom0 is basically the same with paravirtualization, with Dom0 is only provided tools to control the DomUs.
    But I don't know how to make the graphic server connect directly to the hardware.
    Thanks a lot for your help and answers! Any kind of documentation related to my issue would be very helpful!

Share This Page