Xen Debian 3 lib depenency errors

Discussion in 'Installation/Configuration' started by unclecameron, Apr 10, 2006.

  1. unclecameron

    unclecameron New Member

    Hi all,

    I installed the how-to for xen 3 debian 3, and then after I created the dom1 and used debootstrap to configure it, but it installs the testing packages when I do this, the perfect debian 3 install (to use with ISPconfig) won't work, because it requires the use stable libraries.

    How can I just create an empty image for dom1 and then use stable sources for the install rather than testing? Otherwise I'm having trouble with

    libdb3++-dev: Depends: libdb3-dev (= 3.2.9-22) but 3.2.9-25 is to be installed

    and similar errors for libsasl2, perl issues and about 4 other libraries for the install. So there is no way I can install postfix, bind9, apache or spamassassin without library errors. Any help would be appreciated :)

    Thanks,
    Cameron
    San Diego
     
  2. falko

    falko Super Moderator

  3. unclecameron

    unclecameron New Member

    Hmm, I followed that exactly, but I still have a bunch of lib problems, I've done this twice. I edited the /etc/apt/sources.list per the how to, but it still looks like it's installing later packages than in the how to. I've noticed that when I ps aux|grep libsasl and some of the other libs included in the install, and I think they are there even before I apt-get install all the apache and other packages, can I just delete the libs that I already have and install apache and other packages without attempting to install them?

    here's what I get when I run ps aux|grep

    xen1:/# ps aux|grep libsasl
    root 29749 0.0 0.8 1900 568 pts/0 R+ 07:11 0:00 grep libsasl

    Or is there a way I can just boot off the cdrom or mount it (debian cd #1) and install things per the perfect Debian 3 install (for use to install ISPconfig later)

    Thanks,
    Cameron
    San Diego
     
  4. falko

    falko Super Moderator

Share This Page