Xen and the Art of Debootstrap

Discussion in 'HOWTO-Related Questions' started by zeeclor, Apr 9, 2006.

  1. zeeclor

    zeeclor New Member

    I have created a debian minimal netinstall box and have been working my way through the recent Xen 3.0 HowTo. My only variation has been to use reiserfs. I get to section 4.1 and fail at the debootstrap. I have tried other repositories with the same result.

    I wasn't sure if this was a gpg signature problem or more likely a download problem. However, my connection for other downloads (e.g. Knoppix CD under bittorrent yesterday) seems fine.

    I seek your guidance to the path of enlightenment.

    David

    xentor:/xen/images# debootstrap --arch i386 sarge /xen/vm_base/ http://ftp2.de.debian.org/debian
    I: Retrieving Packages
    W: Retrying failed download of http://ftp2.de.debian.org/debian/dists/sarge/main/binary-i386/Packages.gz
    W: Retrying failed download of http://ftp2.de.debian.org/debian/dists/sarge/main/binary-i386/Packages.gz
    W: Retrying failed download of http://ftp2.de.debian.org/debian/dists/sarge/main/binary-i386/Packages.gz
    I: Validating Packages
    W: http://ftp2.de.debian.org/debian/dists/sarge/main/binary-i386/Packages.gz was corrupt
    I: Retrieving Packages
    I: Resolving dependencies of required packages...
    I: Resolving dependencies of base packages...
    E: Couldn't find these debs: adduser apt apt-utils aptitude at base-config base-files base-passwd bash bsdmainutils bsdutils
    snip

    --
    Tab to the left of me
    Enter's to the right
    Stuck in the middle with U
     
  2. zeeclor

    zeeclor New Member

    For the record, bypassing apt-cacher and squid may have been the cure.

    David
     
  3. zeeclor

    zeeclor New Member

    Nope. That wasn't it.

    The problem seems to be that I cannot get a full package download onto the mounted ext3 filesystem at ../images/vm_base.img. Yet debootstrap loads normally into the dom0 filesystem.

    I'm stymied. :confused:

    David
     
  4. falko

    falko Super Moderator

    What's the output of
    Code:
    ping -c4 ftp2.de.debian.org
    ?
    How big is vm_base.img? What's in /etc/resolv.conf?
     
  5. zeeclor

    zeeclor New Member

    Thanks Falko, I've made it through. :)

    The particular problem with debootstrap was that the instruction:-
    dd if=/dev/zero of=/vserver/images/vm_base.img bs=1024k count=1000
    returned immediately and did not create a 1 gig file in which to place the new installation.

    As a word of warning to others, I suggest strictly following Falko's "cut and paste" instructions. Starting in dom0 with etch, not sarge, is a mistake and the same applies to DomU initial installs with testing not stable.

    I'll remember not to be such a deviant next time.

    David
     

Share This Page